Altium NEXUS Documentation

Support for Verification of Imported Data in the Altium NEXUS CAM Editor

Created: January 27, 2017 | Updated: June 22, 2021

Altium NEXUS's CAM Editor allows you to import Gerber, NC Drill, ODB++, Netlist, Mill/Rout, and along with other varying aperture files, then run a set of design rules to verify the data in the imported files. Once verified, you may utilize an Auto Fix option for many of these rules.

Creating a New CAM Document

You may create a new CAM document by selecting File » New » CAM Document from the menu. A new, blank CAM document appears in the design window. You can save the document by selecting File » Save (Ctrl+S).

Importing Files Using Quick Load

Select File » Import » Quick Load to open the File Import - Quick Load dialog. To import the desired files into the new CAM document, you may use the Quick Load option to imports all files found in the selected folder in one instance.

The File Import - Quick Load dialogThe File Import - Quick Load dialog

Click () to open your file directory and select the folder you wish to import. Once all files (including Gerber, NC Drill, and netlist files) are imported, the Import Drill Data dialog will open.

The Import Drill Data dialogThe Import Drill Data dialog

After configuring the settings to your liking, the files imported into the CAM Editor will be displayed in the design window alongside a Quick Load Process Report (*.log).

If your board has any holes, e.g. through holes or blind or buried vias, you must provide at least the signal layers (e.g. Gerber files for top and bottom) and one or more NC Drill files (Excellon 2 format).

Verify Layer Assignments

All Gerber, NC Drill, and netlist layers within the CAM document must be assigned to an appropriate layer type. The CAM Editor attempts to do this for you, matching the extensions of your Gerber files with those listed in the Layer Types Detection Template dialog, but it's encouraged to review the Layers Table for completeness and accuracy. To view or modify the Layer Types Detection Template, select Tables » Layer Type Detection to open the Layer Types Detection Template dialog.

The Layer Types Detection Template dialogThe Layer Types Detection Template dialog

The important layers for netlist extraction, which is required before running the DRC to verify the data, are the signal and plane layers. Signal layers may be assigned to the following layer types: top, bottom, or internal. Silkscreen layers will be taken into account during DRC as well. If you need to add another layer type string, add a string (separated by a comma from the previous entry as shown above) to associate the layer with layer type. Note that if you have made changes to this template at this stage, you will have to re-import your files to see the new associations.

The Layers Table dialogThe Layers Table dialog

To review or edit the Layers Table, select Tables » Layers from the main menu to open the Layers Table dialog.

You may review the listing of layer names is set up through the automatic type assignments. In doing so, you may see that the layer names have been assigned to the layer types as defined in the Layer Types Detection template. Mechanical layers are set to Temporary.

Verify Layers Order

Once all layers are correctly assigned, you may review the Layers Order Table to ensure that the PCB layer stack is correct.

Select Tables » Layers Order to open the Create/Update Layers Order dialog. This dialog provides a map between the layers as they were imported into the CAM Editor (the layer logical order), and their physical build-up for manufacturing (layer physical order). You may review the listing of layer names with automatic mapping assignments. Change the Layer Physical Order, if necessary by clicking on the drop-down list of a layer available in this column and selecting a new value. Note that you cannot assign the same Layer Physical Order to more than one layer.

The Create/Update Layers Order dialogThe Create/Update Layers Order dialog

If you close and reopen this dialog, you will notice that the stackup has been rearranged to reflect any changes to the Layer Physical Order.

Verify Layers Sets

Checking layer sets is only necessary if your board contains blind and/or buried vias, where you must designate each drill set individually, associate the corresponding NC Drill file, and select all layers through which that drill set will pass. To set up layer sets for a different design, begin by selecting Tables » Layers Sets to open the Create/Update Layers Sets dialog.

The Create/Update Layers Set dialog The Create/Update Layers Set dialog 

From the Create/Update Layers Sets dialog, you may insert or delete layer sets and select layer pairs. To create a layer set, type a name in the Layers Set Name column, e.g. Blind Top, or click Insert Layers Set to add a new set. Enter the data to create the Layer Sets required for the blind and buried vias in the design. Select an assigned drill layer from the drop-down list that displays when you click in the Assigned Drill Layer column.

Select the signal/plane layers that will be included in the set from the Select Layer Pairs dialog that displays when you click in the Signal/Plane Layers in Set column. You may use the Ctrl or Shift keys to select multiple layers.

Extract and Rename the Netlist

Once you have checked the layer setups, you may create a netlist. A netlist must be extracted before you run a Design Rule Check to verify the design. To do so, select Tools » Netlist » Extract. Once the netlist is extracted, nets are traced along connected copper from one layer to another according to the layer stack-up and layer sets provided. Click on the Nets tab in the CAMtastic panel to view the net names. At this stage, generic net names have been assigned, e.g. $Net1.

Renaming Nets

If desired, you may rename nets back to their original names in the PCB design because we included the IPC Netlist, which stores the original net names, in the Quick Load import process. If an IPC-356-D netlist file for your Gerber and NC Drill data had not been included in the Quick Load folder, you may import it using the File » Import » Netlist command.

To rename the nets, select Tools » Netlist » Rename Nets. The net names are renamed from the CAM Editor generated nets (e.g. $Net1) to their original names as they appeared in the PCB design, such as GND and VCC. After the net names are updated, the changes will be reflected in the Nets tab in the CAMtastic panel.

Setting Up the Design Rule Check

To ensure that there are no violations in your .CAM file that may affect fabrication, you can run a Design Rule Check (DRC) to verify there are no violations. Additionally, you can select Analysis » PCB Design Check/Fix to open the PCB Design Check/Fix dialog.

The PCB Design Check / Fix dialog

From this dialog, you can change relevant size values, if required, or enable the Auto Fix option, if available. With Auto Fix, the CAM Editor attempts to fix any violations found. We will first run the DRC without Auto Fix enabled to review the number of violations and then with it enabled.

Using Auto Fix

Once the PCB Design Check/Fix dialog has been tailored to your liking, click OK to run the DRC. Once complete, the Information dialog will display details regarding each violation.

The Information dialogThe Information dialog

You can also use the Auto Fix option, where applicable, from the right-click menu when in the DRC tab of the CAMtastic panel. This allows you to fix individual errors, as well as entire DRC types. To auto-fix silkscreen over solder mask errors, for example, right-click the Silkscreen over Solder Mask violations folder in the DRC tab of the CAMtastic panel and select Fix All Silkscreen over Solder Mask errors. To auto-fix individual errors, where available, right-click on an individual error Ref folder and select Fix DRC Error.

You may use Edit » Undo (Ctrl+Z) to reverse any auto-fixes.

Double-clicking on a DRC error from within the DRC tab of the CAMtastic panel will highlight the location of the selected error.

Querying a Violation for Further Information

You may find more information about the possible reason for errors by querying the object(s) involved in the violation. If the CAMtastic panel is active, press Shift+F5 to make the design window active, or click in the design space.

Select Analysis » Query » Object or press Q to change the cursor to a pointing hand. Click on the object you wish to find more information about. The information about the selected object is displayed in the Info tab of the CAMtastic panel. At the bottom of the Info Query section, all the DRC errors are listed that relate to the queried object. Click on these errors to zoom into those related violations.

You may also want to measure distances between objects if there are clearance issues. If so, you can select a measuring option, such as Point to Point or Object to Object from the Analysis » Measure submenu then click on the points or objects you want to measure. The measurements are displayed in the Info tab of the CAMtastic panel.

You may also want to measure distances between objects if there are clearance issues. If so, you can select a measuring option, such as Point to Point or Object to Object from the Analysis » Measure submenu then click on the points or objects you want to measure. The measurements are displayed in the Info tab of the CAMtastic panel.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: