Creación del documento BOM
De un vistazo
- Aprenderás a crear un BomDoc, qué ocurre al añadirlo a un proyecto y la limitación fundamental de un solo BomDoc por proyecto.
- Verás cómo se organiza la lista de elementos de la BOM, incluidos los modos de vista, los controles de las columnas, las herramientas de edición, el comportamiento de la agrupación y las opciones de configuración de la visualización.
- Comprenderás cómo ActiveBOM gestiona los componentes agrupados y las entradas personalizadas de la BOM, lo que te permitirá tener en cuenta tanto los componentes del diseño como los elementos adicionales del proyecto.
Creación del documento BOM
El documento BOM de trabajo de ActiveBOM se denomina BomDoc. Añada un nuevo BomDoc al proyecto mediante el submenú File » New o haga clic con el botón derecho en el proyecto en el panel Projects. Cuando el proyecto contiene al menos un componente, se puede crear un nuevo BomDoc haciendo clic en el control + Create situado junto a la entrada ActiveBOM dentro de la estructura del proyecto en el panel Projects. Tenga en cuenta que cada proyecto de PCB solo puede incluir un BomDoc.
Al añadir un nuevo BomDoc al proyecto, el esquema se compila automáticamente y todos los componentes existentes se incluyen en el BomDoc. Para los componentes de la biblioteca del espacio de trabajo que incluyen opciones de piezas, las soluciones se detallarán en la zona inferior de la interfaz, como se explica en la sección Descripción de la solución más adelante.
A medida que se colocan componentes adicionales en el esquema, estos se añaden automáticamente al BomDoc. También se pueden añadir manualmente elementos adicionales de la BOM y parámetros adicionales directamente en ActiveBOM mediante el botón Add new, situado encima de la lista de componentes. Consulte la sección Elementos y columnas personalizados de la BOM para obtener más información.
La lista de elementos de la BOM
La zona superior del BomDoc es una lista tabular de todos los componentes detectados en el proyecto de diseño de PCB, así como de los elementos adicionales de la BOM que haya añadido directamente al BomDoc. Esta zona se denomina lista de elementos de la BOM.

La lista de componentes, o elementos de la BOM, mostrada en la vista Base.
Hay 3 modos de visualización disponibles para mostrar los elementos de la BOM. Seleccione el modo deseado mediante los botones situados encima de la lista:
Flat view - una fila por cada componente.
Base view - una fila por cada componente único del proyecto; la columna Designador enumera los designadores de todos los componentes de este tipo. Hay varias opciones de presentación disponibles para los designadores agrupados. Seleccione el modo Designator Grouping deseado en el panel Properties.
Consolidated view - se utiliza cuando el proyecto incluye variantes para mostrar una BOM consolidada de todas las variantes.
Funciones de edición de la lista de elementos de la BOM
La lista de componentes admite varias funciones de edición similares a las de una hoja de cálculo, entre ellas:
- Utilice la pestaña Column del panel Properties para mostrar u ocultar una columna y definir un alias para su nombre. También puede definir un alias mediante el cuadro de diálogo Introducir propiedades de columna, al que se accede haciendo clic con el botón derecho en el nombre de una columna en la zona de encabezados de columna del BomDoc y seleccionando después el comando Rename Column del menú contextual. Tenga en cuenta que el alias será el nombre de la columna en las salidas de BOM generadas.
-
También se pueden añadir y eliminar columnas mediante el cuadro de diálogo Select Columns , al que se accede haciendo clic con el botón derecho en el nombre de una columna en la zona de encabezados de columna del BomDoc y seleccionando después Select Columns.

El cuadro de diálogo Select ColumnsOpciones/controles del cuadro de diálogo Seleccionar columnas
- Search - escriba caracteres en el campo para filtrar la lista de columnas y mostrar solo aquellas cuyo nombre incluya los caracteres introducidos.
-
Visibility column - se utiliza para controlar si una columna de ActiveBOM es visible en el documento de ActiveBOM (
*.BomDoc). Haga clic en el icono del ojo para alternar la visibilidad de una columna. Las columnas visibles siempre aparecen en la parte superior del cuadro de diálogo en el mismo orden en que aparecen en el BomDoc. -
Data Source column - muestra la fuente de datos de la columna. Las fuentes de datos compatibles incluyen:
-
- elementos añadidos directamente a la BOM
-
- parámetros de componentes del esquema
-
- parámetros de componentes del espacio de trabajo
-
- parámetros de bases de datos vinculadas (DbLink, DbLib)
-
- parámetros del documento de esquema
-
- Altium Cloud Services
-
- Column Name - muestra el nombre de la fuente de datos, que aparece como nombre de columna en el BomDoc.
- Up / Down - se utiliza para mover la columna seleccionada hacia arriba o hacia abajo en la lista. Como resultado, la columna se moverá a la izquierda o a la derecha en el BomDoc al hacer clic en OK. Tenga en cuenta que solo se puede cambiar la posición de las columnas visibles.
-
- haga clic en el símbolo de filtro situado junto a cada encabezado para filtrar la información de la cuadrícula por el elemento seleccionado de la lista.
- Arrastre y suelte para cambiar el orden de las columnas.
- Ordene por cualquier columna; mantenga pulsado Shift para aplicar una ordenación secundaria por las columnas siguientes.
-
Haga clic en el icono de filtro para filtrar por los valores de las columnas
- Seleccione celdas mediante las técnicas de selección estándar de Windows.
- Copie el contenido de las celdas de ActiveBOM y pegue valores de un editor de hojas de cálculo externo en columnas personalizadas de ActiveBOM.
- Se pueden definir números de línea configurables por el usuario cuando la BOM está en la vista Base. En la vista Base, haga clic en el botón Set line numbers para añadir un número de línea a cada fila. Haga clic en el icono desplegable situado a la derecha del botón para abrir el cuadro de diálogo Opciones de número de línea, donde se pueden definir los valores de inicio e incremento. Consulte la sección Columna de número de línea para obtener más información.
- Haga clic en el desplegable Add New para añadir filas o columnas adicionales. Consulte la sección Elementos y columnas personalizados de la BOM para obtener más información.
- Haga clic en el botón Group by para agrupar la cuadrícula por la columna habilitada. Se pueden habilitar varias columnas de agrupación (mostrar imagen) y cambiar su orden arrastrándolas y soltándolas. Esta es una función de visualización de la cuadrícula; la agrupación no se transfiere al cuadro de diálogo Report Manager cuando se ejecuta el comando Bill of Materials.
- Haga clic en el botón Restablecer cadena de suministro para eliminar la clasificación de soluciones definida por el usuario y las prioridades de SPN asignadas manualmente de los elementos de la BOM seleccionados.
- La configuración actual de la cuadrícula de elementos de la BOM se puede guardar como un conjunto de BOM. Consulte la sección Configurar y guardar la visualización de la cuadrícula de elementos de la BOM para obtener más información.
-
Utilice los atajos estándar de Windows para desplazarse por la lista de elementos de la BOM:
- Desplazamiento vertical = MouseWheel Roll
- Desplazamiento horizontal = Shift + MouseWheel Roll
Los grupos de columnas

La lista de componentes de ActiveBOM tiene distintos grupos de columnas que aparecen en cada modo de vista; la imagen anterior muestra la vista Base.
La cuadrícula de elementos de la BOM se organiza en los siguientes grupos principales:
- Item Details (resaltado en naranja en la imagen): estas columnas muestran datos paramétricos de los componentes, como el designador, la descripción, la referencia de biblioteca y otros parámetros de componente.
- Solutions (resaltado en verde en la imagen): el fabricante y los proveedores mejor clasificados de la cadena de suministro. El número de soluciones (piezas de fabricante) y el número de proveedores de cada solución se configuran en el panel Properties de ActiveBOM; se indican mediante una franja de color sólido en la ficha del proveedor. La clasificación es automática y también se puede definir manualmente, como se explica en la sección Comprender la solución más adelante.
- BOM Status (resaltado en cian en la imagen): una indicación del riesgo actual asociado a cada componente. Pase el cursor sobre un icono para ver una descripción o, si lo prefiere, habilite la columna detallada BOM Status en el panel Properties para mostrar la descripción.
Elementos y columnas personalizados de la BOM
La gestión de la BOM de un proyecto de diseño de PCB requiere gestionar componentes y elementos de la BOM más allá de los colocados en el esquemático y la PCB, por ejemplo, piezas aún por definir, elementos de fijación, la placa sin componentes o el adhesivo de montaje. Hay muchos casos en los que se utilizan elementos o parámetros personalizados de la BOM en el proyecto de diseño de PCB. Para estas situaciones, ActiveBOM permite añadir elementos y columnas (parámetros) adicionales a la BOM, que después se pueden incluir en la BOM generada:
- Custom row - una forma sencilla de añadir un elemento personalizado de la BOM que deba tenerse en cuenta en el diseño (placa sin componentes, adhesivo, etc.). Todos los campos de una fila personalizada los define el usuario. ActiveBOM no gestiona las filas personalizadas; por ejemplo, si la cantidad se establece en 3, no se mostrarán 3 elementos independientes en la vista Plana. Las filas personalizadas tampoco admiten búsquedas en la cadena de suministro.
- Custom column - una columna adicional de la BOM, gestionada en ActiveBOM, que puede contener cualquier texto definido por el usuario.
- Custom Item - un elemento adicional de la BOM, normalmente para aquellos elementos que se necesitarán, pero que aún no se conocen por completo o todavía no existen en la biblioteca. Esto permite incluir el coste de estos elementos en la estimación del coste total de la placa.
-
Managed Component - un elemento adicional de la BOM que se gestiona manualmente en el documento de la BOM. Se abrirá el cuadro de diálogo Component Search, que muestra los componentes del espacio de trabajo conectado actualmente.
Opciones y controles del cuadro de diálogo Búsqueda de componentes
- Search - utilice el cuadro de texto de búsqueda para buscar manualmente un componente específico.
-
- haga clic para acceder a un menú y seleccionar una de las siguientes opciones:
- File-based Libraries Preferences - haga clic para abrir el cuadro de diálogo Bibliotecas basadas en archivos disponibles y añadir o eliminar bibliotecas.
- File-based Libraries Search - haga clic para abrir el cuadro de diálogo Búsqueda de bibliotecas basadas en archivos y buscar bibliotecas.
- Refresh - haga clic para actualizar el cuadro de diálogo.
-
- haga clic para abrir o cerrar la Details región del cuadro de diálogo (descrita a continuación).
Categorías
Utilice este filtro para mostrar determinados tipos de componentes o todos los componentes disponibles. Utilice
para acceder a la Categories barra de búsqueda, que permite buscar manualmente un componente específico o un archivo .IntLib.
Filtros
Haga clic en el Filters icono para abrir la Filters región, donde puede aplicar más filtros a las categorías seleccionadas en la Components lista.
Componentes
- Name - el nombre del componente.
- Description - la descripción de cada componente.
- Footprint - la huella del componente.
- Operating Temperature Range - el intervalo de temperatura adecuado en el que funcionan estos componentes.
- Package Description - la descripción del encapsulado del componente.
- Manufacturer Part Search - haga clic para abrir el panel Búsqueda de piezas de fabricantes para buscar y elegir la pieza más adecuada.
- Create component - haga clic para abrir el cuadro de diálogo Create new component para seleccionar el tipo de componente.
- Results - muestra el número total de componentes encontrados/listados en la búsqueda.
Detalles
- Component Revision ID - muestra el ID de revisión y el precio de un componente determinado. Haga clic en el ID de revisión para abrir el panel Explorador y obtener más información sobre un componente.
- References - haga clic para abrir la información de referencia del componente en un navegador web. Utilice el menú desplegable para acceder a Manufacturer URL o Datasheet.
- Place - haga clic para colocar el componente seleccionado en un documento esquemático.
- Component information - muestra información relevante sobre el componente, incluido el fabricante, la fecha de lanzamiento e información descriptiva. Haga clic en el enlace Show More para ver toda la información; haga clic en Show Less para contraer la información.
- Models - expanda para ver los modelos proporcionados. Utilice los enlaces disponibles para mostrar distintas partes de un mismo modelo.
- References - expanda para acceder a Manufacturer URL o Datasheet.
- Part Choices - expanda para ver las opciones de piezas. Se proporcionan un nombre, un precio y una descripción. También se mostrará la hoja de datos del componente.
- Where Used - expanda para ver los proyectos que utilizan el componente.
Menú contextual
- Place <component> - haga clic para colocar el componente en el documento adecuado.
- Edit - haga clic para abrir los documentos de biblioteca de componentes del componente seleccionado.
- Navigate to <revision> - haga clic para abrir el componente seleccionado en el panel Explorador.
- Operations - pase el cursor para acceder a las opciones Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL y Full Item History.
- Refresh - haga clic para actualizar y ver las actualizaciones o modificaciones recientes. También puede actualizar mediante el atajo F5.
Añadir instancias de un componente gestionado o un elemento personalizado
Después de añadir un componente gestionado o un elemento personalizado, haga clic con el botón derecho sobre él y seleccione el comando Operations » Add Instances of para acceder al cuadro de diálogo Add to BOM Components. Utilice este cuadro de diálogo para definir el número de instancias del componente en la BOM.
Especifique Designator prefix, el valor opcional Separator (que se puede definir para obtener resultados como X-1 o X:1) y Quantity de componentes necesarios (este valor se utiliza para definir el intervalo de designadores y también aparecerá en la columna Quantity de ActiveBOM). Todos los demás parámetros, como la descripción, se pueden editar directamente en la cuadrícula de elementos de la BOM.
Cambiar/eliminar un componente gestionado o un elemento personalizado
Para editar el designador o eliminar una instancia de un componente gestionado o un elemento personalizado, haga clic con el botón derecho sobre él y seleccione el comando Operations » Edit item. Se abrirá el cuadro de diálogo Change / Remove.
Opciones y controles del cuadro de diálogo Cambiar/eliminar
- BOM Components - la región de la cuadrícula del cuadro de diálogo muestra cada instancia del nuevo elemento. Para editar el prefijo o el valor del designador, haga clic en la celda New Designator correspondiente y edítela según sea necesario.
- Remove All - al hacer clic en este botón, se seleccionarán todas las instancias del elemento adicional de la BOM que aparecen en el cuadro de diálogo y se marcarán para su eliminación. Al hacer clic en el botón OK del cuadro de diálogo, todos los elementos marcados para eliminar se eliminarán de la cuadrícula de elementos de la BOM de ActiveBOM. Tenga en cuenta que, al no quedar ninguna instancia de ese nuevo elemento, también se eliminará el elemento. Esta acción no se puede deshacer.
- Remove None - haga clic en este botón para borrar todas las marcas de eliminación.
- Remove Selected - cuando se selecciona una instancia que no está marcada para su eliminación, se puede utilizar el tercer botón para marcar para su eliminación las instancias seleccionadas.
- Restore Selected - cuando se selecciona una instancia que está marcada para su eliminación, se puede utilizar el tercer botón para borrar la marca de eliminación de las instancias seleccionadas.
Fuentes de datos
Las fuentes de datos predeterminadas disponibles en ActiveBOM son los parámetros de los componentes del esquemático , los parámetros de los componentes del espacio de trabajo para el contenido del espacio de trabajo y los datos proporcionados por ActiveBOM A partir de estas fuentes, ActiveBOM genera la cuadrícula principal de elementos de la BOM del proyecto. Las fuentes de datos se habilitan y su visualización se controla en la pestaña Columns del panel Propiedades de ActiveBOM.
Al habilitar el botón Sources correspondiente (encima de la lista de columnas), la BOM también puede incluir información de las siguientes fuentes de datos adicionales:
The PCB - habilite estas opciones para incluir los datos de ubicación, rotación y cara de la placa de la PCB en Columns disponibles para cada uno de los componentes. Si el proyecto contiene varios documentos de PCB, se abrirá el cuadro de diálogo Elegir PCB que se utilizará, en el que podrá seleccionar la PCB necesaria.
Database - para cargar parámetros adicionales de los componentes desde una base de datos externa (mediante *.DbLib, *.SVNDbLib o *.DbLink).
Altium Cloud Services - habilite esta opción para acceder a una amplia variedad de datos adicionales de los componentes, para aquellos elementos de la BOM que hayan sido identificados por el proveedor de piezas de Altium y muestren una solución de cadena de suministro.
Document Parameters - habilite esta opción para incluir todos los parámetros de documentos esquemáticos detectados en todos los esquemáticos del proyecto de PCB en Columns disponibles.

La fuente de cada parámetro se indica mediante el icono de la lista de columnas.
Prioridad de los parámetros de las fuentes de datos
Si el mismo parámetro está presente en más de una fuente de datos, se aplican las siguientes prioridades en ActiveBOM (de mayor a menor):
- BOM
- PCB
- Documentos
- Servidor
- Base de datos
- Nube
- Esquemático
- Manual
Columna de número de línea
En diseños de PCB con planos de montaje, o para el intercambio de datos de la lista de materiales entre ingenieros de diseño, ingenieros de costes o especialistas en compras, el número de línea de la lista de materiales (n.º de posición del elemento de la lista de materiales) es un método sencillo para distinguir individualmente las líneas de la lista de materiales, que después pueden utilizarse para identificar explícitamente o find la llamada, el componente y la representación correspondientes en el diseño.
Como fuente de datos de la lista de materiales del proyecto, ActiveBOM admite números de línea definidos por el usuario para la lista de materiales del proyecto y dispone de funciones de gestión manual y automática de los números de línea (n.º de posición del elemento de la lista de materiales).
-
Para establecer automáticamente el número de posición de todos los elementos de la lista de materiales del proyecto (en la vista base), haga clic en el botón Set Line #
. Los números de línea se muestran en la columna Line #, dentro del grupo de columnas Detalles del elemento. Haga clic en el icono desplegable situado a la derecha del botón para abrir el cuadro de diálogo Line # Options, donde puede definir los valores inicial y de incremento.

El cuadro de diálogo Line Number Options- Start number - el valor que se utilizará si la primera celda Line # está vacía.
- Increment - incrementar cada campo Line # vacío en esta cantidad.
-
Para cambiar manualmente los números de línea, cambie al modo de vista base y seleccione las celdas necesarias en la columna N.º de línea y:
- Pulse Delete en el teclado para borrar el contenido de las celdas y, a continuación,
- introduzca manualmente los nuevos valores, o
- pegue un rango de valores desde el portapapeles de Windows.
-
Para renumerar o continuar la numeración a partir de un número añadido manualmente, haga clic en la celda N.º de línea del elemento correspondiente y, a continuación, en el botón Set Line #
. Se abrirá el cuadro de diálogo Line Numbering, donde puede utilizar los números existentes como referencia y numerar de forma consecutiva las celdas vacías seleccionadas o todas las celdas vacías, empezando por las celdas no vacías más cercanas situadas encima (Continue numbering), o eliminar todos los números existentes y renumerar todas las filas (Renumber all). Para calcular los números añadidos se utilizan los últimos valores de base e incremento definidos en el cuadro de diálogo Line # Options; si es necesario, puede introducir un valor inicial en la celda N.º de línea seleccionada para definir el número de inicio.
Configuración y guardado de la visualización de la cuadrícula de elementos de la lista de materiales
Como en cualquier buena aplicación de hojas de cálculo, la cuadrícula de elementos de la lista de materiales puede configurarse para adaptarse a sus necesidades. Además de las funciones habituales para organizar las columnas y ordenar los datos, la configuración actual puede guardarse como un conjunto de lista de materiales.
Funciones de configuración de la cuadrícula
- Mostrar u ocultar cualquier columna: mediante la función Columnas del panel Properties. Utilice el campo Search situado en la parte superior del panel para localizar rápidamente una columna.
- Cambiar el orden de las columnas: mantenga pulsado el título de la columna y arrástrela y suéltela.
- Cambiar la anchura de una columna: sitúe el puntero sobre el borde de la columna en la zona del título y haga clic y arrastre (busque el cursor , o haga doble clic en ese punto para ajustar automáticamente la anchura al contenido de la columna.
-
Ordenar toda la cuadrícula por una columna:
- Haga clic en el título de la columna para ordenar alfanuméricamente la cuadrícula por el contenido de esa columna.
- Haga clic de nuevo para ordenar en sentido inverso.
- Mantenga pulsada la tecla Mayús y haga clic en el título de otra columna para aplicar un criterio de ordenación secundario según el contenido de esa columna.
-
Filtrar la cuadrícula por un valor específico: haga clic en el icono de filtro
para filtrar la cuadrícula por un valor utilizado en esa columna. Seleccione (Custom) para acceder al cuadro de diálogo Filter Editor y definir la condición, el operador, el valor, el tipo de operador, etc., para filtrar la columna seleccionada.
- Guardar la configuración como un conjunto de lista de materiales: se explica con más detalle a continuación.
Trabajo con conjuntos de lista de materiales
Puede guardar tantas configuraciones de la cuadrícula de elementos de la lista de materiales como desee; cada una de ellas se denomina conjunto de lista de materiales. Después de configurar la cuadrícula según sus necesidades, haga clic en el botón Add de la sección BOM Sets del panel Properties de ActiveBOM para añadir un conjunto de lista de materiales a la lista.

Haga clic en el icono del ojo para habilitar un conjunto de lista de materiales.
Los conjuntos de lista de materiales se configuran en el panel Propiedades de ActiveBOM.
Sustitución de un componente
No es raro detectar un problema con un componente al revisar el BomDoc y prepararlo para realizar el pedido de piezas. Por ejemplo, es posible que el diseñador haya olvidado finalizar la selección de un componente, o que un componente haya llegado al final de su vida útil y el diseñador quiera consultar el precio y la disponibilidad de posibles sustitutos. Anteriormente, la única forma de resolverlo era volver al esquema y editar el componente, seleccionar una pieza adecuada y, después, actualizar el BomDoc.
Como alternativa, puede cambiar un componente en el BomDoc y, a continuación, transferir ese cambio al esquema mediante una orden de cambio de ingeniería. Haga clic con el botón derecho en los componentes seleccionados y seleccione el comando Operations » Change <ComponentName>. Se abrirá el cuadro de diálogo Sustituir componente, donde podrá buscar el componente de sustitución.
Al hacer clic en el botón Replace Component OK, se abrirá el cuadro de diálogo Engineering Change Order, que detalla los cambios necesarios para sincronizar el esquema con el BomDoc.
Trabajo con variantes
ActiveBOM admite proyectos de PCB que incluyen variantes de diseño. La función de variantes de diseño permite crear un único diseño de PCB base, que después se monta con distintas configuraciones de componentes. Cada configuración de montaje diferente de la placa ensamblada se denomina design variant.
Trabajo con variantes de diseño:
- Las variantes de diseño se configuran en el cuadro de diálogo Gestión de variantes o en el Administrador de variantes (Project » Variants).
- Para examinar una variante, haga doble clic en su nombre en la carpeta Variantes del proyecto, en el panel Projects, como se muestra en la imagen siguiente.
ActiveBOM admite variantes de las siguientes maneras:
- Mostrar la BOM de una variante específica en el modo de vista Base o Plana
- Opción para incluir los elementos no montados en la lista de elementos de la BOM
- Mostrar una lista consolidada de todas las piezas utilizadas en todas las variantes, en el modo de vista Consolidada
- Definir soluciones manuales tanto para los componentes base como para los componentes modificados en las variantes
Variantes en el modo de vista Base
Para la variante seleccionada, habilite la opción Show Not Fitted en el panel Properties para incluir estas piezas en la tabla de elementos de la BOM. Cuando esta opción está habilitada, la columna Fitted se muestra automáticamente en los detalles del elemento.
En el modo de vista Base, la columna Fitted mostrará Fitted o Not Fitted. Si una pieza se modifica en la variante (se ha elegido una pieza alternativa en esta variante), los detalles de la pieza alternativa se muestran automáticamente para ese elemento de la BOM.

Tenga en cuenta que la variante actual se muestra en la línea de estado de ActiveBOM.
Variantes en el modo de vista Consolidada
El modo de vista Consolidada muestra todos los componentes utilizados en todas las variantes. La vista Consolidada ofrece las siguientes funciones:
- Si un componente se modifica en una variante, habrá un elemento de la BOM por cada componente alternativo utilizado, y todos estos elementos de la BOM tendrán el mismo designador. Por ejemplo, en la imagen siguiente, los componentes DS1 y DS2 aparecen dos veces cada uno, ya que la variante BGA utiliza un LED de un color diferente al de la variante TSOP. El componente R1 aparece tres veces porque tanto la variante BGA como la TSOP utilizan una resistencia diferente de la original del diseño base.
-
En el modo de vista Consolidada, cuando la opción Show Not Fitted está habilitada, la columna Fitted mostrará
FittedoVaried. Dado que la vista Consolidada muestra todos los componentes utilizados en todas las variantes, cada componente mostrado se monta en el diseño base o en una variante. - Para cada variante, hay una columna <VariantName> - Qty (que indica cuántas unidades de este componente se utilizan en esta variante) y una columna <VariantName> - Price, que es el precio unitario multiplicado por el valor de la columna de cantidad.
- Dado que algunos diseñadores crean documentación de fabricación tanto a partir del diseño base como de las variantes, también hay una columna Quantity, que refleja el número de instancias de este componente utilizadas en la fabricación del diseño base. Oculte esta columna si no genera documentación de fabricación a partir del diseño base.
- La tabla del modo de vista Consolidada utiliza colores para indicar las celdas cuyo valor difiere del valor de esa misma celda en el diseño base, como se muestra a continuación.

El color de una celda indica que su valor es diferente del valor de esa misma celda en el diseño base.
Para obtener más información sobre las variantes, consulte la página Variantes de diseño.
Trabajo entre el BomDoc, el esquema y la PCB
Hay dos funciones disponibles para ayudarle a trabajar entre el BomDoc, el esquema y el diseño de PCB: Selección cruzada y Localización cruzada. El comportamiento de estas funciones se configura en la página Sistema - Navegación del cuadro de diálogo Preferences.
Ambas funciones permiten localizar el mismo componente en otros documentos. La diferencia entre Selección cruzada y Localización cruzada es que el modo Selección cruzada selecciona el componente en el documento de destino, pero no muestra activamente ese documento, mientras que Localización cruzada muestra activamente el documento de destino y también puede cambiar al editor de ese documento y convertirlo en el editor activo.
Puede utilizar Selección cruzada o Localización cruzada desde el BomDoc hacia el esquema y la PCB, pero no desde el esquema o la PCB hacia el BomDoc.
Modo Selección cruzada
El modo Selección cruzada debe habilitarse en cada editor en el que desee utilizarlo. Seleccione el comando Tools » Cross Select Mode (Shift+Ctrl+X). Cuando el modo Selección cruzada esté habilitado, el icono del menú aparecerá resaltado con un contorno
.
El modo Selección cruzada requiere que el documento de destino esté abierto. Cuando seleccione un componente en la lista de elementos de la BOM del BomDoc, ese componente se seleccionará y se centrará en los documentos de esquema y PCB de destino (si Zooming está habilitado en las opciones Cross Select Mode de la página Sistema - Navegación del cuadro de diálogo Preferences). Tenga en cuenta que el documento de destino no se mostrará como documento activo.
Si el BomDoc está en el modo de vista Base, se seleccionarán todas las instancias de esa pieza en el esquema y en la PCB, como se muestra en la imagen siguiente.

Utilice la función Selección cruzada para localizar y seleccionar, en el esquema y en la PCB, el componente elegido en la lista de elementos de la BOM.
Localización cruzada
Mientras que Selección cruzada es simplemente un modo que, cuando está habilitado, muestra el resultado cada vez que hace clic en la lista de elementos de la BOM, Localización cruzada es una acción deliberada.
Elija Tools » Cross Probe de los menús principales o haga clic con el botón derecho en un elemento de la BOM y seleccione Cross Probe en el menú contextual para realizar una localización cruzada de ese componente en el esquema; también se localizará el componente en la PCB si el archivo de la placa está abierto.
Una función clave de la localización cruzada es la posibilidad de cambiar al editor del documento de destino. Para realizar una localización cruzada y cambiar de editor, mantenga pulsada la tecla Ctrl mientras selecciona el comando Cross Probe.

Haga clic con el botón derecho para acceder al comando de localización cruzada; habrá una entrada para el designador de cada componente presente en ese elemento de la BOM.
Panel Propiedades
Cuando el documento activo es un documento BOM (*.BomDoc), el panel Properties muestra Document Options.
Las siguientes secciones desplegables contienen información sobre las opciones y los controles disponibles:
General
- Production Quantity – el número de placas que se fabricarán. Es importante definir este campo, ya que se utiliza durante las búsquedas en la cadena de suministro para comprobar la disponibilidad de los componentes de los proveedores.
- Currency – la moneda preferida para mostrar los precios de los componentes. Los tipos de cambio para la conversión de divisas se actualizan a diario siempre que haya iniciado sesión en su cuenta de Altium. Al desconectarse de Altium (en la página Sistema – Gestión de cuentas del cuadro de diálogo Preferences), se pierde el acceso a estos tipos de cambio actualizados. En esta situación, el cuadro de diálogo de informes de la BOM ofrece una opción para utilizar los datos almacenados en caché.
- Price Per Board – se obtiene a partir de los datos de los proveedores y es la suma de Supplier Subtotals per Board, como se describe a continuación. Tenga en cuenta que Price Per Board no considera las cantidades mínimas de pedido (MOQ).
- Order Price – suma de Supplier Subtotals. Tenga en cuenta que Order Price tiene en cuenta las MOQ y es el importe que se paga al proveedor.
Cadena de suministro
La información de la cadena de suministro se presenta en la sección inferior de la interfaz de ActiveBOM, que muestra un componente del fabricante a la izquierda y una o varias tarjetas de proveedores de colores a su derecha. Esta sección muestra datos cuando se puede identificar información válida de la cadena de suministro para un elemento de la BOM. Cada una de estas filas de Manufacturer & Supplier(s) Details se denomina solución. Los detalles del fabricante se abrevian como MPN (números de pieza del fabricante) y los detalles del proveedor se abrevian como SPN (números de pieza del proveedor).
- Solutions per Item – el número de piezas de fabricantes que desea encontrar para cada elemento de la BOM.
- Suppliers per Solution – el número de proveedores que desea encontrar para cada pieza del fabricante.
-
Solutions
- Exclude Invalid SPNs – seleccione esta opción para excluir los SPN no válidos.
- Favorite Suppliers List – abre el cuadro de diálogo Proveedores favoritos, en el que se puede configurar la lista general de proveedores para este BomDoc.
-
Manufacturer Link – abre el cuadro de diálogo Definir campos de vínculo del fabricante, en el que se identifican los parámetros de los componentes del esquema que contienen el nombre del fabricante y el número de pieza del fabricante. Si el diseño contiene piezas de bibliotecas que no pertenecen a un Workspace (piezas que no se han colocado desde un Workspace y que tampoco tienen detalles del proveedor), ActiveBOM puede consultar Altium Parts Provider para identificar soluciones adecuadas de la cadena de suministro. Se pueden definir varios pares de parámetros de nombre / número de pieza. En el cuadro de diálogo, haga clic en el botón Detect fields para añadir automáticamente todos los pares de parámetros que incluyan el término
manufactureren su nombre y que puedan emparejarse de forma lógica.
Elementos de la BOM
Esta sección se utiliza para configurar cómo deben agruparse los elementos de la BOM en la tabla de elementos de la BOM.
-
Items
-
Show not Fitted – si el proyecto de PCB incluye variantes y la variante elegida tiene piezas configuradas como
Not Fitted, active esta opción para mostrar los elementos no montados en la tabla de elementos de la BOM. - Designator Grouping – los modos de vista Base y Consolidada muestran las piezas comunes en una sola fila de la tabla de elementos de la BOM. Utilice esta opción para configurar si los designadores se muestran individualmente o en rangos cuando una fila muestra varias piezas.
- Component Grouping – al hacer clic en el botón Edit se abre el cuadro de diálogo Component Grouping. En la vista Base o la vista Consolidated, ActiveBOM identifica los componentes como iguales cuando comparten el mismo ItemID (biblioteca de Workspace) o LibRef (biblioteca basada en archivos o en una base de datos). Active parámetros en el cuadro de diálogo para precisar cómo deben agruparse los componentes. Tenga en cuenta que, si el proyecto solo incluye componentes gestionados, el botón Edit no estará disponible, ya que los componentes gestionados siempre se agrupan por ItemID.
-
Show not Fitted – si el proyecto de PCB incluye variantes y la variante elegida tiene piezas configuradas como
Conjuntos de BOM
Los conjuntos de BOM permiten capturar la disposición y la configuración de la tabla de elementos de la BOM y guardarlas como un conjunto con nombre. Se puede definir cualquier número de conjuntos de BOM.
-
Current BOM Set – haga clic en el icono del ojo para aplicar ese conjunto de BOM a la tabla de elementos de la BOM.
-
Add – configure la visibilidad, el orden y el ancho de las columnas y, a continuación, haga clic en Add para guardar esa configuración como un conjunto de BOM. Para editar el nombre del conjunto de BOM, haga clic una vez para seleccionarlo y, después, haga clic de nuevo para editar el texto.
-
Update – si se modifica la configuración de la cuadrícula de elementos de la BOM, haga clic en Update para volver a guardar esta configuración.
-
Delete – haga clic en
para eliminar el conjunto de BOM seleccionado.
Comprobaciones de la BOM
ActiveBOM realiza una comprobación exhaustiva de cada elemento de la BOM y de todos los datos de la cadena de suministro que se hayan detectado para ese elemento.
- Violation Type grid – muestra una lista de los tipos y las cantidades de infracciones presentes actualmente en el BomDoc. Haga clic en el icono de filtro para mostrar solo los elementos de la BOM que no superen esa comprobación de la BOM. Tenga en cuenta que un elemento de la BOM puede no superar varias comprobaciones de la BOM.
-
BOM Checks – haga clic en
para abrir el cuadro de diálogo Comprobaciones de la BOM, en el que se puede configurar el modo de informe para cada posible tipo de infracción.
Columnas
Esta sección del panel se utiliza para configurar qué parámetros se muestran para cada elemento de la BOM y las fuentes de datos disponibles para esos parámetros.
-
Sources – además de los datos añadidos directamente al BomDoc , las fuentes de datos predeterminadas disponibles en ActiveBOM son los parámetros de los componentes del esquema y los parámetros de los componentes de la biblioteca del espacio de trabajo para el contenido del espacio de trabajo A partir de estas fuentes, ActiveBOM genera la cuadrícula principal de elementos de la BOM del proyecto. La BOM también puede incluir información extraída de las siguientes fuentes de datos adicionales:
-
PCB – active esta opción para incluir los datos de ubicación, rotación y cara de la PCB en los Columns disponibles para cada uno de los componentes.
-
Database – active esta opción para cargar parámetros adicionales de los componentes desde una base de datos externa (*.DbLib,*.SVNDbLibo*.DbLink). -
Document – active esta opción para incluir todos los parámetros de documento de esquema detectados en todos los esquemas del proyecto de PCB en los Columns disponibles.
-
Altium Cloud Services – active esta opción para acceder a una amplia gama de datos adicionales de componentes para aquellos elementos de la BOM que hayan sido identificados por el proveedor de componentes de Altium y que muestren una solución de cadena de suministro.
-
-
Columns – lista de todas las fuentes de información de componentes disponibles para ActiveBOM. La sección Columnas se puede ordenar haciendo clic en cualquiera de los campos del encabezado.
- Visibility – cada fila tiene un icono de ojo; haga clic en él para controlar la visibilidad de esa columna en la cuadrícula principal de elementos de la BOM.
- Source – muestra un icono que indica de dónde procede ese parámetro.
- Name – el nombre de la propiedad o del parámetro, tal como se define en el documento de origen o como se haya introducido para una columna de BomDoc creada por el usuario.
- Alias – si es necesario, se puede definir un alias para cambiar el nombre de una columna.
- Add – haga clic para añadir una nueva columna personalizada a la cuadrícula de elementos de la BOM.





