Bibliotecas integradas

De un vistazo

Las bibliotecas integradas de Altium Designer reúnen símbolos esquemáticos, modelos vinculados y parámetros de componentes en un único archivo portátil. Este artículo explica cómo crear un paquete de biblioteca integrada, hacer que los modelos referenciados estén disponibles y compilar el paquete mientras se comprueba si faltan modelos o hay errores de asignación de pines. Sigue leyendo para dar el siguiente paso hacia la creación y validación de tus propias bibliotecas integradas.

- Comprende cómo las bibliotecas integradas mejoran la portabilidad y mantienen juntos los modelos de los componentes.
- Aprende a preparar las bibliotecas de origen y a hacer que los modelos estén disponibles mediante archivos de proyecto, bibliotecas instaladas o rutas de búsqueda.
- Descubre cómo configurar la notificación de errores y compilar tu paquete de biblioteca para generar un archivo IntLib.
Profundiza con IA:

Las bibliotecas integradas reflejan el modelo Integrated Component de Altium Designer. En este modelo, el componente de nivel superior se representa dentro del símbolo esquemático en un archivo de biblioteca de esquemas (*.SchLib). Los demás modelos se vinculan desde el símbolo y los parámetros del componente se añaden al símbolo. Todas las bibliotecas de origen —el símbolo y los modelos vinculados— se definen dentro de un proyecto Integrated Library Package, que posteriormente se compila en un único archivo: un Integrated Library o IntLib.

Este documento analiza las distintas formas de crear una biblioteca integrada, así como la colocación de componentes desde ella y su modificación.

Ventajas de las bibliotecas integradas

Las principales ventajas de compilar en una biblioteca integrada son:

  • Toda la información de los componentes está disponible en un único archivo portátil. Dado que todos los modelos se incluyen en la biblioteca integrada, solo es necesario que un archivo esté disponible para el proyecto o que se traslade cuando se cambie la ubicación del proyecto. Esta portabilidad es inestimable si reparte su trabajo entre distintas estaciones de trabajo o si desea compartir sus diseños con otras personas.
  • Si se coloca un componente en un esquema de diseño desde una biblioteca integrada, Altium Designer tiene garantizado encontrar el modelo correcto con solo localizar la biblioteca integrada de la que procede (es decir, no es necesario manejar archivos de biblioteca y de modelos separados, cuyos vínculos a los modelos pueden resultar muy «frágiles» y romperse fácilmente con tareas de gestión cotidianas, como cambiar el nombre de las carpetas de un disco duro).
  • Desde el punto de vista de la seguridad, las bibliotecas integradas son sólidas. Una vez generadas, no se pueden modificar. De hecho, actualizar una biblioteca integrada implica sustituirla por completo. Es necesario abrir expresamente el paquete de bibliotecas original, actualizar los documentos de origen y volver a compilarlo.
  • La integridad de estas bibliotecas también se comprueba al compilarlas. Esto significa que no solo se comprueba la disponibilidad de los modelos, sino también la correcta asignación de pines. Incluso si desea seguir utilizando archivos de biblioteca independientes, se recomienda compilar las bibliotecas de esquemas en un paquete de bibliotecas integradas, aunque solo sea para garantizar que los componentes de origen se correspondan correctamente con los modelos de destino. Una vez comprobado esto, puede prescindir de la biblioteca integrada que ha creado y seguir colocando componentes directamente desde sus bibliotecas de esquemas.

Creación de una IntLib mediante un paquete de bibliotecas

Un paquete de bibliotecas integradas (*.LibPkg) es un tipo de proyecto de Altium Designer que se utiliza para reunir el conjunto de documentos de diseño necesarios para generar una biblioteca integrada. Los símbolos esquemáticos se dibujan en el editor de bibliotecas de esquemas y, para cada uno de ellos, se definen las referencias o los vínculos a los modelos, junto con la información paramétrica correspondiente. Estos se almacenan en uno o varios archivos de biblioteca de esquemas. Los modelos referenciados pueden incluir huellas de PCB, modelos de simulación de circuitos y modelos de integridad de señal.

El único documento que debe añadirse al paquete de bibliotecas integradas es la biblioteca de esquemas (o las bibliotecas). Los archivos que contienen los modelos 2D/3D de componentes de PCB y los modelos de simulación o subcircuitos pueden encontrarse en cualquier ubicación de búsqueda válida dentro del proyecto, en archivos de la lista de bibliotecas instaladas o en las rutas de búsqueda especificadas para el paquete.

A continuación, el paquete de bibliotecas se compila en un único archivo de biblioteca integrada (*.IntLib).

Reunir las bibliotecas de modelos en el proyecto o localizarlas mediante rutas de búsqueda depende de su forma de trabajar. Si comprueba y edita modelos mientras prepara el paquete de bibliotecas integradas, puede que prefiera tener las bibliotecas de modelos a mano y, por tanto, añadirlas al propio paquete. Si añade continuamente bibliotecas de modelos a carpetas específicas de un disco duro o de la red, quizá prefiera utilizar las rutas de búsqueda y dejar que el compilador detecte automáticamente las bibliotecas recién añadidas.
Tenga en cuenta que, actualmente, los modelos SPICE de las bibliotecas *.LIB no se añaden a las bibliotecas integradas compiladas.

En resumen, la creación de una biblioteca integrada consta esencialmente de cuatro pasos:

  1. Crear un paquete de bibliotecas de origen.

  2. Crear y añadir los archivos de biblioteca de esquemas de origen necesarios.

  3. Crear y añadir los archivos de modelos de dominio necesarios (o indicar su ubicación).

  4. Compilar el paquete de bibliotecas para generar el archivo de biblioteca integrada.

Creación del paquete de bibliotecas de origen

Cree un nuevo paquete de bibliotecas integradas seleccionando el comando File » New » Library en los menús principales y, a continuación, la opción Integrated Library en la sección File del cuadro de diálogo New Library que se abre. Tras hacer clic en Create, el nuevo proyecto vacío de paquete de bibliotecas se añadirá al panel Projects y, al principio, no contendrá ningún documento.

Creación y adición de una biblioteca de esquemas de origen

Cree la biblioteca de esquemas de origen (*.SchLib) con los componentes necesarios. Para cada componente, añada los vínculos a modelos y la información paramétrica necesarios. Existen dos formas de crear una biblioteca de esquemas de origen:

  • Desde cero, utilizando el comando File » New » Library de los menús principales y seleccionando la opción Schematic Library en la sección File del cuadro de diálogo New Library. Cree nuevos componentes con el editor de símbolos esquemáticos o copie componentes de otras bibliotecas de esquemas abiertas.
  • Haciendo clic con el botón derecho en la entrada del paquete de bibliotecas en el panel Projects y seleccionando después el comando Add New to Project » Schematic Library en el menú contextual.
  • A partir de los componentes que ya se han colocado en los documentos esquemáticos de un proyecto, mediante el comando Design » Make Schematic Library.
Al crear una biblioteca de esquemas a partir de componentes colocados en un proyecto de diseño existente, todos los documentos esquemáticos de origen se abrirán automáticamente. La biblioteca resultante recibirá el nombre del proyecto (<ProjectName>.SchLib).

Una vez preparadas las bibliotecas de esquemas de origen, añádalas al paquete de bibliotecas mediante uno de los siguientes métodos:

  • Utilizando el comando Project » Add Existing to Project.
  • Haciendo clic con el botón derecho en la entrada del paquete de bibliotecas en el panel Projects y seleccionando después el comando Add Existing to Project en el menú contextual.

SchLib de origen añadida al paquete de bibliotecas.
SchLib de origen añadida al paquete de bibliotecas.

Creación y adición de archivos de modelos de dominio

Cree los modelos a los que hacen referencia los componentes esquemáticos en sus archivos correspondientes: los modelos 2D/3D de componentes de PCB en una biblioteca de PCB (*.PcbLib), y los modelos de simulación y subcircuitos en archivos de modelo (*.Mdl) y de subcircuito (*.Ckt). Naturalmente, el modelo más importante será el modelo 2D/3D del componente de PCB que, al igual que su equivalente en la biblioteca de esquemas, puede crearse de dos formas:

  • Utilizando el comando File » New » Library de los menús principales y seleccionando la opción PCB Library en la sección File del cuadro de diálogo New Library. Cree nuevas huellas 2D (y añada la información de los cuerpos 3D que corresponda) con el editor de huellas de PCB o copie componentes de otras bibliotecas de PCB abiertas.
  • Haciendo clic con el botón derecho en la entrada del paquete de bibliotecas en el panel Projects y seleccionando después el comando Add New to Project » PCB Library en el menú contextual.
  • A partir de los modelos 2D/3D de componentes de PCB que ya se han colocado en el documento de PCB, mediante el comando Design » Make PCB Library.
Al crear una biblioteca de PCB a partir de un documento de PCB existente, asegúrese de que el documento esté abierto y activo. La biblioteca resultante recibirá el nombre del archivo del documento de PCB (<PCBDocumentName>.PcbLib).

Especificación de dónde encontrar los modelos

Una vez definidos los archivos de modelo, es necesario ponerlos a disposición del paquete de bibliotecas para que puedan localizarse fácilmente cuando se necesiten. Recuerde que los componentes del esquema hacen referencia a los modelos (o están vinculados a ellos). Altium Designer dispone de un sistema estándar para poner los modelos a disposición, tanto si está creando un paquete de bibliotecas integradas como si está trabajando en un diseño esquemático. Hay tres formas de poner los modelos a disposición:

  • Añadir la biblioteca o el modelo al proyecto.
  • Instalar la biblioteca o el modelo en la lista de bibliotecas instaladas. De este modo, estará disponible para todos los proyectos de diseño.
  • Definir una ruta de búsqueda a la biblioteca o al modelo.

Cada método tiene sus ventajas, así que elija el que mejor se adapte a su forma de trabajar. Además, algunos métodos resultan más adecuados para determinados modelos. Por ejemplo, puede que no quiera ver un gran número de modelos de simulación en el panel Projects al abrir el paquete de bibliotecas, pero sí las bibliotecas de modelos de componentes PCB 2D/3D. En este caso, defina una ruta de búsqueda a la carpeta donde se almacenan los modelos de simulación y añada la biblioteca PCB al paquete de bibliotecas.

En conjunto, estos tres métodos para poner los modelos a disposición conforman las Libraries Preferences (disponibles para un proyecto) y todos pueden definirse en el cuadro de diálogo Libraries Preferences, al que se accede haciendo clic en Libraries dialogs access button, en la esquina superior derecha del panel Components, y seleccionando después el comando Libraries Preferences.

Defina la disponibilidad de los modelos en el cuadro de diálogo Libraries Preferences .
Defina la disponibilidad de los modelos en el cuadro de diálogo Libraries Preferences .

La biblioteca PCB (y otros archivos de modelo, si es necesario) también puede añadirse directamente al paquete de bibliotecas mediante el comando Add Existing to Project, disponible en el menú principal Project o en el menú contextual de la entrada del paquete de bibliotecas en el panel Projects.

PcbLib de origen añadida al paquete de bibliotecas.
PcbLib de origen añadida al paquete de bibliotecas.

Al definir rutas de búsqueda a los archivos de modelo desde la pestaña Search Path del cuadro de diálogo Libraries Preferences, se accede a la pestaña Search Paths del cuadro de diálogo Options for Integrated Library (Project » Project Options). Añada una o varias rutas según sea necesario, teniendo en cuenta que los modelos se buscan en estas rutas en orden, de arriba abajo. Haga clic en el botón Refresh List para comprobar que se encuentran los archivos de modelo necesarios y ajuste alguna ruta si es preciso.

Para acceder a la pestaña Search Paths del cuadro de diálogo Options for Integrated Library, la opción UI.ProjectOptions.SearchPaths debe estar habilitada en el cuadro de diálogo Advanced Settings, al que se accede haciendo clic en el botón Advanced de la página System – General del cuadro de diálogo Preferences. Deberá reiniciar Altium Designer para que el cambio de esta configuración surta efecto.

Ejemplo de una ruta de búsqueda definida para localizar el archivo de modelo PcbLib necesario.
Ejemplo de una ruta de búsqueda definida para localizar el archivo de modelo PcbLib necesario.

Compilación y validación del paquete de bibliotecas

Una vez añadidas las bibliotecas de origen al paquete de bibliotecas y definidas las rutas a los archivos de modelo que sean necesarias, se puede compilar el paquete para generar la biblioteca integrada. Como ocurre con cualquier otro proyecto, el compilador de un paquete de bibliotecas integradas generará una lista de mensajes de advertencia o error; por ejemplo, advertencias sobre modelos que no se hayan encontrado. Además, se pueden comprobar los errores de asignación de pines, como las instrucciones de asignación a los pads 1 y 2 cuando la huella real contiene los pads A y K.

Aunque prefiera seguir utilizando archivos de biblioteca independientes (*.SchLib, *.PcbLib), se recomienda compilar las bibliotecas de esquemas en un paquete de bibliotecas integradas, aunque solo sea para asegurarse de que los componentes de origen se asignen correctamente a los modelos de destino.

Antes de ejecutar una compilación, conviene revisar y configurar adecuadamente las condiciones de notificación de errores en la pestaña Error Reporting del cuadro de diálogo Options for Integrated Library.

Es recomendable configurar las opciones de notificación de errores y los niveles de gravedad según sea necesario antes de compilar el paquete de bibliotecas.
Es recomendable configurar las opciones de notificación de errores y los niveles de gravedad según sea necesario antes de compilar el paquete de bibliotecas.

Para iniciar la compilación, utilice el comando Compile Integrated Library, ya sea desde el menú principal Project o desde el menú contextual de la entrada del paquete de bibliotecas en el panel Projects. Las bibliotecas de origen y los archivos de modelo se compilan en una biblioteca integrada con el mismo nombre que el paquete de bibliotecas de origen (<LibraryPackageName>.IntLib). El compilador comprobará si hay infracciones, y los errores o advertencias encontrados se mostrarán en el panel Messages. Corrija los problemas en las bibliotecas de origen y vuelva a compilar.

Ejemplos de errores señalados por el compilador al compilar el paquete de bibliotecas integradas.
Ejemplos de errores señalados por el compilador al compilar el paquete de bibliotecas integradas.

La biblioteca integrada se guarda en la carpeta de salida especificada en la pestaña Options del cuadro de diálogo Options for Integrated Library (de forma predeterminada, una subcarpeta de la ubicación del proyecto: \Project Outputs for <ProjectName>). Si la opción Open outputs after compile está habilitada en la pestaña Options del cuadro de diálogo Options for Integrated Library, la biblioteca integrada se añade automáticamente a la pestaña Installed del cuadro de diálogo Libraries Preferences  y a la página Data Management – File-based Libraries del cuadro de diálogo Preferences.

La biblioteca integrada compilada se añade a la pestaña Installed del cuadro de diálogo Libraries Preferences .
La biblioteca integrada compilada se añade a la pestaña Installed del cuadro de diálogo Libraries Preferences .

Creación de una IntLib a partir de los documentos del proyecto

También se puede crear una biblioteca integrada directamente a partir de los documentos que componen un proyecto (los esquemas de origen y el documento PCB). Esto resulta útil si desea crear y reutilizar una biblioteca funcional o un archivo de su diseño terminado. Utilice el comando Make Integrated Library, disponible en el menú principal Design tanto del editor de esquemas como del editor PCB.

El proceso consiste básicamente en:

  1. Abrir todos los documentos de esquema de origen y crear una biblioteca de esquemas.
  2. Crear una biblioteca PCB a partir del documento PCB.
  3. Compilar estas bibliotecas en una biblioteca integrada con el mismo nombre que el proyecto (<ProjectName>.IntLib).

La IntLib se añade al proyecto (en Libraries\Compiled Libraries, en el panel Projects), se añade a las bibliotecas instaladas (como parte de las Available File-based Libraries disponibles para cualquier proyecto) y queda disponible a través del panel Components.

Creación simplificada de una biblioteca integrada, directamente a partir de los documentos de esquema y PCB del proyecto de diseño activo.
Creación simplificada de una biblioteca integrada, directamente a partir de los documentos de esquema y PCB del proyecto de diseño activo.

  • Si se detectan componentes con la misma referencia de biblioteca pero con distinta estructura interna, se abrirá el cuadro de diálogo Duplicated Components. Utilice este cuadro de diálogo para especificar cómo gestionar dichos componentes: procesar la primera instancia e ignorar todas las demás, procesar todos los componentes y asignarles nombres únicos, o cancelar la creación de la biblioteca.
  • El panel Messages mostrará los problemas encontrados al generar la IntLib; por ejemplo, los modelos vinculados que no se hayan podido encontrar.

Creación de una IntLib a partir de una biblioteca de base de datos

Related page: Bibliotecas de bases de datos

Las bibliotecas de base de datos de Altium Designer son una opción ideal si desea que sus componentes de Altium Designer estén estrechamente vinculados a la base de datos de su empresa. Si el diseño debe salir de las instalaciones de su empresa, o si prefiere que sus diseñadores trabajen con bibliotecas integradas seguras, puede conseguirlo fácilmente. Altium Designer permite compilar una biblioteca integrada directamente a partir de una biblioteca de base de datos: ya sea una biblioteca de base de datos estándar (DbLib) o una biblioteca de base de datos SVN con control de versiones (SVNDbLib). De este modo, los responsables de las bibliotecas CAD pueden seguir utilizando bibliotecas de base de datos, mientras que los diseñadores utilizan bibliotecas integradas regeneradas periódicamente para trabajar, por así decirlo, «sin conexión».

La conversión se realiza mediante el asistente de creación de bibliotecas integradas sin conexión. El proceso se lleva a cabo por separado para cada tabla de la base de datos, con control total sobre qué tablas se incluyen. Se generará una biblioteca integrada independiente para cada tabla incluida.

Convierta sus bibliotecas de base de datos (DbLib o SVNDbLib) en bibliotecas integradas «sin conexión» mediante el Offline Integrated Library Maker.
Convierta sus bibliotecas de base de datos (DbLib o SVNDbLib) en bibliotecas integradas «sin conexión» mediante el Offline Integrated Library Maker.

El proceso consta de los siguientes pasos:

  1. Con el archivo de biblioteca de base de datos (*.DbLib) o el archivo de biblioteca de base de datos SVN (*.SVNDbLib) que desea convertir abierto como documento activo, seleccione el comando Tools » Offline Integrated Library Maker en los menús principales para acceder al Offline Integrated Library Maker.
  2. Utilice la página Library to Convert para especificar la DbLib o SVNDbLib que se va a procesar. La biblioteca activa desde la que se haya accedido al Offline Integrated Library Maker se especificará de forma predeterminada como la biblioteca que se va a convertir. Si es necesario, puede buscar y seleccionar otra biblioteca de base de datos.
  3. Utilice la página Options para especificar qué tablas de la base de datos vinculada se incluirán en la conversión. De forma predeterminada, se incluyen todas las tablas de la base de datos. Para excluir una tabla, asegúrese de que su opción Convert asociada esté desactivada. Esta página del Offline Integrated Library Maker también permite indicar un directorio de salida en el que se almacenarán las bibliotecas integradas generadas. Introduzca directamente la ruta de este directorio base o haga clic en el icono Browse icon situado a la derecha del campo para acceder a un cuadro de diálogo en el que podrá buscar y seleccionar el directorio deseado. El resultado generado (biblioteca integrada) para cada tabla de base de datos incluida se almacenará en su propia subcarpeta dentro del directorio de salida especificado, con el nombre de la tabla.
  4. Tras elegir la biblioteca de base de datos y configurar las opciones de conversión correspondientes según sea necesario, haga clic en Next para iniciar la conversión. Se mostrará una barra de progreso junto con información sobre la tabla de la base de datos que se está convirtiendo. Recuerde que el proceso de conversión se realiza para cada tabla de la base de datos que haya seleccionado. A continuación se describen las etapas principales de este proceso:
    1. Se crea un paquete de biblioteca integrada (*.LibPkg) y se abre en el panel Proyectos. El paquete recibe el nombre de la tabla. Por ejemplo, para una tabla denominada Capacitor - Ceramic, el resultado sería Capacitor - Ceramic.LibPkg.
    2. Se crea un documento de biblioteca de esquemas y se añade al LibPkg. La biblioteca de esquemas también recibe el nombre de la tabla (p. ej., Capacitor - Ceramic.SchLib).
    3. A continuación, se procesa cada registro de la tabla y se crea el componente de Altium Designer correspondiente. Para ello, se recupera el símbolo de esquema referenciado de la biblioteca de origen correspondiente y se añade como componente al nuevo documento de biblioteca de esquemas. Después, se añade a ese componente la información de parámetros y vínculos a modelos definida en el registro.
    4. Se recuperan los modelos de huella referenciados en el registro y se añaden a un documento de biblioteca de PCB. Este documento también recibe el nombre de la tabla (p. ej., Capacitor - Ceramic.PcbLib). A continuación, el documento de biblioteca de PCB se añade al LibPkg.
    5. Si la biblioteca de origen es una DbLib y se han definido vínculos a modelos PCB3D y/o de simulación en el registro de la base de datos, los archivos de biblioteca PCB3D y de modelos de simulación referenciados también se añaden al LibPkg. La ubicación de estos modelos no cambia. La ruta completa de cada modelo se especifica como parte de su vínculo al modelo correspondiente.
    6. A continuación, se compila el LibPkg para obtener la biblioteca integrada (p. ej., Capacitor - Ceramic.IntLib), que posteriormente se añade a las bibliotecas instaladas de Altium Designer.

Las bibliotecas instaladas actualmente pueden consultarse en la página Gestión de datos – Bibliotecas basadas en archivos del cuadro de diálogo Preferences y en la pestaña Installed del cuadro de diálogo Bibliotecas basadas en archivos disponibles, al que se accede haciendo clic en Libraries dialogs access button, en la esquina superior derecha del panel Componentes, y seleccionando después File-based Libraries Preferences.

Resultados del proceso de conversión: proyectos de paquetes de bibliotecas con sus documentos de símbolos y modelos de huella y las IntLib compiladas, que también se añaden como bibliotecas instaladas.
Resultados del proceso de conversión: proyectos de paquetes de bibliotecas con sus documentos de símbolos y modelos de huella y las IntLib compiladas, que también se añaden como bibliotecas instaladas.

Creación de una IntLib mediante la adquisición de componentes

Related page: Adquisición de datos del espacio de trabajo mediante el carrito de contenido

También puede adquirir componentes de su espacio de trabajo e incorporarlos a una biblioteca integrada (*.IntLib). Al colocar componentes desde una biblioteca integrada de este tipo, los vínculos reales apuntan a los componentes del espacio de trabajo. Esto le permite utilizar los componentes del espacio de trabajo de su empresa sin conexión, al tiempo que garantiza que el diseño siga manteniendo una conexión real con esos componentes en el espacio de trabajo de origen.

Desde el cuadro de diálogo Carrito de contenido, el proceso para adquirir una IntLib es el siguiente:

  1. Haga clic en el vínculo Select target server y seleccione IntLib file en el menú.

    Establezca un archivo IntLib como destino del Content Cart.
    Establezca un archivo IntLib como destino del Content Cart.

  2. Especifique el nombre y la ubicación del archivo IntLib generado. De forma predeterminada, el archivo recibirá un nombre con el formato Integrated_Library - <Date> - <Time>.IntLib y se generará en la ubicación \Users\Public\Documents\Altium\AD<Solution/Version>\Library\ExportCmpLib. Modifique estos valores según sea necesario mediante el cuadro de diálogo Save As, al que se accede haciendo clic en el vínculo Change.

    Acepte la carpeta de destino y el nombre de archivo predeterminados, o cámbielos según sea necesario.
    Acepte la carpeta de destino y el nombre de archivo predeterminados, o cámbielos según sea necesario.

  3. Si necesita adquirir componentes adicionales e incorporarlos a la misma IntLib, haga clic en el vínculo Add More Items y seleccione la opción Select para acceder al cuadro de diálogo Choose Item (una versión «reducida» del panel Explorador). Desde aquí puede explorar el espacio de trabajo de origen para buscar más elementos. Como alternativa, seleccione la opción Add manually para acceder al cuadro de diálogo Add new items. Este cuadro de diálogo permite pegar una lista externa de los elementos que necesita (un elemento por línea), que después pueden buscarse en el espacio de trabajo de origen utilizando un criterio de búsqueda seleccionado (GUID, Item ID, Name o MPN).

  4. Cuando esté listo, haga clic en el botón para generar la IntLib. Se creará un paquete de biblioteca integrada temporal (*.LibPkg), al que se añadirán los archivos de origen SchLib (con símbolos, parámetros y vínculos a modelos) y PcbLib (con modelos de huella) generados. A continuación, se compilará este paquete para producir el archivo IntLib, que se generará en la carpeta especificada. Un cuadro de diálogo informativo confirmará que el archivo se ha generado correctamente.

    Entregue el carrito en la carpeta de destino, que contendrá el archivo de biblioteca integrada requerido.
    Entregue el carrito en la carpeta de destino, que contendrá el archivo de biblioteca integrada requerido.

Tras su generación, la IntLib se añade a la lista de bibliotecas instaladas, que forma parte de Available File-based Libraries del software.

Colocación de componentes desde una biblioteca integrada

La colocación de componentes desde una biblioteca integrada se realiza desde el panel Components. La colocación puede realizarse desde el documento esquemático activo o desde el documento PCB activo. Puede realizarse de las siguientes maneras:

  • Seleccione el archivo *.IntLib deseado en la lista desplegable del panel Components, haga clic con el botón derecho en el componente que desea colocar y elija Place <ComponentName> en el menú contextual. Sitúe el componente en el documento esquemático y, a continuación, haga clic para colocarlo.

  • Haga clic en el componente deseado y arrástrelo al espacio de diseño.

Mediante el método del botón Place, se pueden colocar varias instancias de un componente, ya que este método permanece en modo de colocación hasta que se hace clic con el botón derecho o se pulsa Esc. El método de arrastrar y soltar resulta más inmediato, pero solo permite colocar una instancia cada vez.

Aunque una biblioteca de esquemáticos y una biblioteca integrada pueden contener el mismo componente (con los mismos enlaces a modelos), los componentes colocados desde cada una de estas bibliotecas se comportarán de manera diferente al recuperar la información de sus modelos. Los componentes colocados desde bibliotecas integradas buscarán la biblioteca integrada original para obtener sus modelos, mientras que los componentes colocados desde bibliotecas de esquemáticos no tendrán acceso a los modelos almacenados en bibliotecas integradas.

Modificación de una biblioteca integrada

Las bibliotecas integradas se utilizan para colocar componentes y no se pueden editar directamente. Para realizar cambios en una biblioteca integrada, modifique primero las bibliotecas de origen y, a continuación, vuelva a compilar el paquete de bibliotecas para generar una nueva biblioteca integrada que incluya esos cambios.

Para modificar una biblioteca integrada:

  1. Abra el proyecto del paquete de bibliotecas de origen de la biblioteca integrada deseada.
  2. Abra las bibliotecas de esquemáticos o de modelos de origen que desee modificar.
  3. Realice los cambios necesarios, guarde las bibliotecas modificadas y ciérrelas.
  4. Vuelva a compilar el paquete de bibliotecas. La biblioteca integrada recién generada sustituirá a la versión anterior existente.

Descompilación de una biblioteca integrada

En ocasiones, puede ser necesario acceder a las bibliotecas de origen de una biblioteca integrada para modificarlas, pero, por algún motivo, no se dispone de acceso al proyecto del paquete de bibliotecas de origen original para hacerlo. Aquí es donde entra en juego otra característica de disponer de un único archivo de biblioteca integrada portátil. Aunque las bibliotecas integradas no se pueden editar directamente, se pueden descompilar para recuperar las bibliotecas de símbolos y modelos de origen que las componen.

Para ello:

  1. Abra la biblioteca integrada que contiene las bibliotecas de origen que necesita modificar. Puede hacerlo de una de estas dos maneras:
    1. Elija el comando File » Open, busque la biblioteca integrada en el cuadro de diálogo Choose Document to Open y haga clic en Open.
    2. Arrastre el archivo IntLib desde el Explorador de archivos de Windows y suéltelo en la ventana de Altium Designer.
  2. En el cuadro de diálogo Open Integrated Library que aparece, haga clic en el botón Extract.

Las bibliotecas de esquemáticos y de modelos de origen se extraen y se guardan en una nueva carpeta que recibe el nombre del archivo de la biblioteca integrada y se ubica en la carpeta donde se encuentra la biblioteca integrada original. A continuación, se crea un paquete de bibliotecas (<IntegratedLibraryFileName>.LibPkg), y las bibliotecas de esquemáticos y PCB de origen se añaden al proyecto y se muestran en el panel Projects. Los archivos de modelos de simulación y subcircuitos no se añaden automáticamente al proyecto.


Extracción de las bibliotecas de origen de una biblioteca integrada: descompilación para generar un proyecto de paquete de bibliotecas.

Se añade automáticamente una ruta a la carpeta que contiene los archivos de las bibliotecas y los modelos de origen (cuando corresponda) en la pestaña Search Paths del cuadro de diálogo Options for Integrated Library (Project » Project Options), lo que garantiza que se encuentren todos los modelos (especialmente los archivos .mdl y .ckt).
El paquete de bibliotecas no se guarda automáticamente. Determine dónde y con qué nombre se guardará el proyecto; de forma predeterminada, el archivo se guardará en la misma carpeta que los archivos de origen extraídos.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents