Anotación de los componentes en un diseño
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Descubre el propósito de la anotación de diseños y por qué es importante que los designadores de los componentes sean únicos en los esquemas, el diseño de la PCB y los documentos de salida, como la lista de materiales (BOM).
- Comprende las diferencias entre la anotación a nivel de esquema, de PCB y de placa, incluidos los tipos de diseño para los que resulta más adecuado cada método.
- Obtén una visión general del cuadro de diálogo Anotar y de los principales ajustes que permiten controlar el alcance de la anotación, el orden de procesamiento, las opciones de correspondencia y los cambios propuestos.
La anotación del diseño es el proceso sistemático y metódico que garantiza que cada componente del diseño pueda identificarse individualmente mediante un designador único. Aunque Altium Designer puede mantener la identidad de los componentes mediante identificadores únicos globales (GUID), tradicionalmente la mayoría de los diseñadores utilizan el designador del componente como principal medio para referenciarlo tanto en el esquema (lógico) como en la PCB (física), así como en los documentos de salida, como la lista de materiales (BOM).
Existen tres enfoques para anotar un diseño. La elección de la herramienta de anotación depende de varios factores, como el tipo de diseño, las preferencias personales y las políticas y los procedimientos de la empresa.
Schematic Level Annotation
La anotación a nivel de esquema utiliza una visión puramente lógica del diseño para determinar los designadores de los componentes. Resulta especialmente útil para diseños sencillos que no utilizan hojas de dispositivos, pero, dado que permite especificar el orden de procesamiento y ofrece la opción de completar encapsulados existentes de componentes de varias partes, también es un requisito previo para la anotación a nivel de placa.
En resumen, utilice la anotación a nivel de esquema para:
- Agrupar componentes de varias partes en encapsulados.
- Anotar los componentes según su posición en el diseño del esquema.
- Anotar diseños multicanal utilizando el esquema de nomenclatura predeterminado especificado en las opciones del proyecto.
- Preparar un diseño para una anotación adicional.
PCB Annotation
La anotación de PCB utiliza la ubicación física de los componentes en la PCB para determinar su designación. Esto permite codificar eficazmente la información de posición en el designador de un componente y puede resultar muy útil al depurar una PCB ensamblada. En resumen, debe utilizar la anotación de PCB para anotar los componentes según su posición en la placa dentro del diseño de PCB.
Board Level Annotation
La anotación a nivel de placa establece una correspondencia entre los designadores utilizados en el diseño del esquema (lógico) y sus equivalentes reales en el diseño de PCB (físico). Aunque la anotación a nivel de placa puede utilizarse en cualquier diseño, resulta especialmente útil para diseños multicanal o diseños que incorporan hojas de dispositivos cuyos designadores no pueden editarse en la propia hoja de dispositivos. De este modo, se puede volver a anotar todo el diseño sin modificar las hojas de dispositivos originales. La anotación a nivel de placa resuelve los conflictos de anotación que puedan surgir debido a designadores duplicados en un proyecto y guarda los cambios en un archivo de texto *.Annotation. Incluye palabras clave adicionales para personalizar los esquemas de nomenclatura y permite aplicarlos a todas las partes o solo a un conjunto seleccionado.
En resumen, utilice la anotación a nivel de placa para:
- Anotar los componentes compilados de las hojas de dispositivos.
- Asignar nombres únicos a todos los componentes de varios canales mediante esquemas de nomenclatura que incluyen anotación por posición, indexación global y otras opciones configurables.
- Asignar nombres a los componentes manualmente.
Anotación del esquema
La anotación del esquema se configura mediante el cuadro de diálogo Annotate . Este cuadro de diálogo proporciona controles para asignar sistemáticamente designadores a todas las partes o a las partes seleccionadas de determinadas hojas de un proyecto y garantiza que los designadores sean únicos y estén ordenados según su posición. Las opciones de anotación pueden configurarse para agrupar componentes de varias partes en encapsulados, establecer opciones de índice y sufijo, restablecer los designadores del esquema, incluidos los duplicados, y realizar una anotación inversa desde la PCB.
Se accede al cuadro de diálogo Annotate ejecutando el comando Anotar esquemas (Tools » Annotation » Annotate Schematics).

El cuadro de diálogo Annotate se abre mediante el comando Annotate Schematics.
El cuadro de diálogo se divide en dos áreas principales:
- Schematic Annotation Configuration - esta área se utiliza para configurar el esquema de anotación y el alcance de la anotación.
- Proposed Change List - esta área enumera los cambios propuestos que se realizarán una vez aceptados y ejecutados mediante una orden de cambio de ingeniería (ECO).
Opciones y controles del cuadro de diálogo Anotar
Configuración de la anotación del esquema
Orden de procesamiento
Utilice esta área para especificar el método de anotación por posición que desee. Al seleccionar un método en la lista desplegable, la representación gráfica correspondiente se actualiza dinámicamente para ilustrar cómo se anotarán los componentes. Elija entre los siguientes métodos de anotación por posición:
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Referencia de ubicación para el procesamiento
Utilice esta área para especificar la referencia de ubicación de los componentes al procesar el orden de anotación. Elija entre las siguientes opciones:
- Designator - se utiliza el designador del componente como referencia de su ubicación al determinar el orden de procesamiento.
- Part - se utiliza el centro del componente como referencia de su ubicación al determinar el orden de procesamiento.
Sustituir subpartes
Utilice la lista desplegable para seleccionar si se deben sustituir las subpartes como parte del proceso de anotación.
Opciones de coincidencia
Cuando se utilizan encapsulados de varias partes, suele ser conveniente agrupar tantas partes como sea posible en el menor número de componentes físicos, ya que esto minimiza el coste total de la lista de materiales del diseño. Los controles de esta área permiten definir cómo se buscarán coincidencias entre los componentes y cómo se agruparán, así como los criterios utilizados para determinar las agrupaciones válidas.
-
Complete Existing Packages - utilice este control para decidir si las partes sin anotar se incluirán en los encapsulados existentes y de qué manera. Utilice la lista desplegable para elegir entre las siguientes opciones:
- None - no se completarán los encapsulados existentes y todas las partes nuevas se colocarán en encapsulados nuevos.
- Per Sheet - los encapsulados existentes solo incluirán partes nuevas de la misma hoja de esquema.
- Whole Project - los encapsulados existentes incluirán partes nuevas de cualquiera de las hojas de esquema del proyecto.
- Component Parameter - esta lista incluye todos los parámetros presentes en los componentes del diseño actual. Marque la casilla asociada a un parámetro para utilizarlo como criterio de coincidencia al agrupar partes en encapsulados. Si los componentes de varias partes comparten los mismos parámetros habilitados y un valor común, se agruparán en el mismo encapsulado (siempre que la opción Complete Existing Packages no esté establecida en None). Los componentes restantes que no tengan los parámetros habilitados también se agruparán entre sí.
- Strictly - active esta opción para un Component Parameter de la lista para indicar que todos los componentes must tener ese parámetro para agruparse en un encapsulado. Los componentes que no tengan este parámetro se anotarán como componentes individuales y no se agruparán en encapsulados.
Menú contextual
- Parameter » Enable Selected Parameters - permite marcar la casilla «Incluir» de todos los parámetros seleccionados actualmente en la lista.
- Parameter » Enable All Parameters - permite marcar la casilla «Incluir» de todos los parámetros de la lista.
- Parameter » Disable Selected Parameters - permite desmarcar la casilla «Incluir» de todos los parámetros seleccionados actualmente en la lista.
- Parameter » Disable All Parameters - permite desmarcar la casilla «Incluir» de todos los parámetros de la lista.
- Match Strictly » Enable Strict Matching On Selected Parameters - permite activar la opción Strictly para todos los parámetros seleccionados actualmente en la lista.
- Match Strictly » Enable Strict Matching On All Parameters - permite activar la opción Strictly para todos los parámetros de la lista.
- Match Strictly » Disable Strict Matching On Selected Parameters - permite desactivar la opción Strictly para todos los parámetros seleccionados actualmente en la lista.
- Match Strictly » Disable Strict Matching On All Parameters - permite desactivar la opción Strictly para todos los parámetros de la lista.
- Selection » Select All - permite seleccionar todas las entradas de parámetros de la lista.
- Selection » Deselect All - permite deseleccionar todas las entradas de parámetros de la lista.
- Selection » Invert Selection - permite seleccionar todos los parámetros que no estén seleccionados actualmente en la lista y deseleccionar los que sí lo estén.
Hojas de esquemático que se anotarán
Esta sección del cuadro de diálogo muestra todas las hojas de esquemático de origen del proyecto de diseño. Los controles disponibles en esta sección permiten determinar qué hojas se incluirán en el proceso de anotación y cómo se calcularán los cambios de anotación. Para cada hoja, se presenta lo siguiente:
- Include/Exclude checkbox - active esta casilla para incluir la hoja de esquemático en el proceso de anotación.
- Schematic Sheet - este campo muestra el nombre de la hoja de esquemático.
-
Annotation Scope - utilice este campo para determinar el alcance de la anotación con respecto a los componentes de la hoja. Utilice la lista desplegable para elegir uno de los siguientes alcances:
- All - se anotarán todas las partes de la hoja de esquemático.
- Ignore Selected Parts - se anotarán todas las partes, excepto las seleccionadas actualmente en el diseño.
- Only Selected Parts - solo se anotarán las partes seleccionadas actualmente en el diseño.
- Order - utilice este campo para especificar la posición de esta hoja en el orden general de anotación de hojas. Escriba el número de orden deseado directamente en el campo o utilice las flechas que aparecen al hacer clic en él para ajustar el valor.
- Designator Index Control - utilice los controles de esta columna para habilitar el uso de un índice inicial (marcando la casilla correspondiente) y definir su valor. El valor del designador comenzará a partir de este índice.
- Add Suffix - utilice este campo para especificar un sufijo que se añadirá a cada designador anotado. Se admiten sufijos alfabéticos (A, B, C...), numéricos (1, 2, 3...) y no alfanuméricos (_ * . %...), así como combinaciones de estos.
Additional Controls
- All On - haga clic para incluir todas las hojas de esquemático en el proceso de anotación.
- All Off - haga clic para excluir todas las hojas de esquemático del proceso de anotación.
-
Right-Click Menu - los siguientes comandos están disponibles en el menú contextual de la sección:
-
Order Alphabetically - permite ordenar alfabéticamente la lista de esquemáticos. Esto afectará a la entrada Order asociada a cada hoja.
-
Order By Project Order - permite ordenar la lista de esquemáticos según el orden en el que aparecen en el proyecto (tal como se muestra en el panel Projects ). Esto afectará a la entrada Order asociada a cada hoja.
-
All On - permite incluir todas las hojas de esquemático en el proceso de anotación.
-
All Off - permite excluir todas las hojas de esquemático del proceso de anotación.
-
Lista de cambios propuestos
-
Main List - esta sección del cuadro de diálogo muestra todos los designadores de las partes contenidas en las hojas seleccionadas para la anotación. Para cada entrada, se incluyen detalles de los valores Current y Proposed Designator , junto con la Sub (parte) del componente y el Location of Part de origen. Los iconos de candado se utilizan para indicar las columnas bloqueadas e impedir cambios en los designadores y las subpartes.
Al marcar la casilla situada junto a un designador en la columna Current («designador bloqueado»), se impedirá cualquier cambio en ese designador concreto. Del mismo modo, al marcar la casilla situada junto al campo Sub de un designador («subparte bloqueada»), se impedirá la actualización de esa subparte concreta del componente multiparte al que pertenece.
Los siguientes comandos están disponibles en el menú contextual de la sección:
- Designator » Lock Selected Designators - permite marcar la casilla «designador bloqueado» de todos los designadores seleccionados actualmente en la lista.
- Designator » Lock All Designators - permite marcar la casilla «designador bloqueado» de todos los designadores.
- Designator » Unlock Selected Designators - permite desmarcar la casilla «designador bloqueado» de todos los designadores seleccionados actualmente en la lista.
- Designator » Unlock All Designators - permite desmarcar la casilla «designador bloqueado» de todos los designadores.
- Part ID » Lock Selected Part ID - permite marcar la casilla «subparte bloqueada» de todos los designadores seleccionados actualmente en la lista.
- Part ID » Lock All Part ID - permite marcar la casilla «subparte bloqueada» de todos los designadores.
- Part ID » Unlock Selected Part ID - permite desmarcar la casilla «subparte bloqueada» de todos los designadores seleccionados actualmente en la lista.
- Part ID » Unlock All Part ID - permite desmarcar la casilla «subparte bloqueada» de todos los designadores.
- Selection » Select All - permite seleccionar todas las entradas de designadores de la lista.
- Selection » Select All With '?' - permite seleccionar todas las entradas cuyo designador actual contenga ? (es decir, que se hayan restablecido).
- Selection » Deselect All - permite deseleccionar todas las entradas de designadores de la lista.
- Selection » Invert Selection - permite seleccionar todos los designadores que no estén seleccionados actualmente en la lista y deseleccionar los que sí lo estén.
- Annotation Summary - esta área proporciona un resumen de la anotación en cuanto al número de hojas implicadas y las opciones de coincidencia. Se actualiza dinámicamente a medida que se realizan cambios en estas áreas.
- Update Changes List - haga clic para actualizar la lista principal de cambios propuestos con los nuevos cambios calculados según los ajustes de anotación definidos en el lado izquierdo del cuadro de diálogo. Un cuadro de diálogo informativo mostrará cuántos cambios se han realizado desde el estado anterior y cuántos desde el estado original.
- Reset All - haga clic para restablecer todos los designadores de la lista principal (que no estén bloqueados) a sus prefijos de componente predeterminados, por ejemplo, R?, C?, D?. Los cambios se cargarán en la columna de designadores Proposed . El menú desplegable del botón permite cambiar el comando a Reset Duplicates. Si dos o más componentes tienen el mismo designador, todos excepto uno se restablecerán a sus prefijos predeterminados. De nuevo, un cuadro de diálogo informativo mostrará cuántos cambios se han realizado desde el estado anterior y cuántos desde el estado original.
- Back Annotate - haga clic para abrir un cuadro de diálogo en el que buscar y seleccionar el archivo para la anotación inversa.
- Accept Changes (Create ECO) - después de revisar todos los cambios propuestos, haga clic en este botón para acceder al cuadro de diálogo Engineering Change Order, que muestra los cambios propuestos como modificaciones dentro de la categoría de modificación Anotar componente. Utilice este cuadro de diálogo para validar y ejecutar la ECO y completar el proceso de anotación a nivel de esquema.
Bloquear componentes
En el caso de componentes de varias partes no homogéneas, asegúrese de que los iconos de bloqueo estén cerrados en el panel Properties para evitar cambios en las subpartes durante la anotación.
Opción de coincidencia estricta
Si la casilla Strictly está activada para un Component Parameter, todos los componentes deben tener una coincidencia en ese parámetro para agruparse en un encapsulado. Los componentes que no tengan este parámetro se anotarán como componentes individuales y no se agruparán en encapsulados.
El siguiente ejemplo ilustra cómo se combinan estas opciones para obtener un resultado específico:
Considere un diseño con ocho puertas OR y ocho resistencias (como se muestra en la imagen siguiente). Las puertas OR contienen un parámetro denominado QuadOrGate: un grupo de cuatro puertas OR tiene el valor de parámetro Package1 y el otro grupo de cuatro puertas OR tiene el valor de parámetro Package2. Las resistencias no tienen este parámetro. Al activar la casilla de QuadOrGate en el control Component Parameter, se garantiza que este parámetro se utilice para controlar cómo se agrupan los componentes en encapsulados; en este caso, la casilla Strictly no está activada.
Tras ejecutar el comando Tools » Annotation » Annotate Schematics, las partes con el parámetro QuadOrGate = Package1 se agruparán en el mismo componente físico y las que tengan el parámetro QuadOrGate = Package2 se agruparán por separado. Los componentes restantes que no tengan el parámetro QuadOrGate se agruparán entre sí. En este caso, las resistencias se agrupan juntas, ya que su atributo común es que no contienen el parámetro QuadOrGate.

Ejemplo de componentes agrupados en encapsulados con la opción Strictly desactivada.
Si se anota el mismo diseño con la opción Strictly activada, solo se agruparán en encapsulados los componentes que tengan el parámetro QuadOrGate . En este caso, las puertas OR se agruparán, pero las resistencias quedarán sin agrupar. Por lo tanto, aunque la opción Strictly ofrece un control muy preciso del proceso de agrupación, en la mayoría de los casos convendrá dejarla desactivada.

Ejemplo de componentes agrupados en encapsulados con la opción Strictly activada.
Hojas de esquema que se van a anotar
Se ofrece un alto grado de control sobre las hojas de esquema y los componentes que se verán afectados por la anotación, así como sobre la forma en que se calcularán esos cambios.

Especificación del alcance de la anotación.
- Una marca en la casilla situada a la izquierda de una hoja de esquema de la lista indica que se procesará como parte del comando de anotación.
- El alcance de la anotación se determina mediante la lista desplegable Annotation Scope y puede ampliarse para incluir toda la hoja de esquema o limitarse a los componentes seleccionados o no seleccionados. Para utilizar las opciones Ignore Selected Parts o Only Selected Parts , es necesario haber seleccionado los componentes en el diseño antes de ejecutar el comando de anotación.
- Configure el orden en el que se anotarán las hojas de esquema mediante el campo Order. Introduzca un valor directamente en el campo o utilice las flechas que aparecen al hacer clic en él para establecer el valor deseado.
- Si la opción Designator Index Control está activada, el valor del designador comenzará a partir del valor Start Index. El Start Index no tiene efecto si la opción Designator Index Control no está activada.
- Se puede añadir un sufijo adicional al final de cada designador especificando una cadena o un valor en la columna Suffix correspondiente. Evite utilizar sufijos de un solo carácter, como 'A' o '1', ya que pueden confundirse fácilmente con subpartes u otros valores de designador.
Lista de cambios propuestos
Haga clic en el botón Update Changes List para actualizar Proposed Change List y poder revisar todos los cambios en los designadores antes de aplicarlos. Solo se verán afectados por los cambios los designadores que no se hayan asignado previamente (es decir, R?, C?, etc.). Por lo tanto, si se pretende actualizar todos los designadores del diseño, primero deben restablecerse pulsando el botón Reset All.

Restablecimiento de los designadores antes de aplicar los ajustes de anotación.
El Proposed Change List muestra todos los designadores de las partes contenidas en las hojas seleccionadas para la anotación. Para cada entrada, se incluyen los valores de designador Current y Proposed, junto con el Sub (parte) del componente y el Location of Part de origen.
Al activar la casilla asociada a un Designator , se bloqueará ese designador para impedir cualquier cambio. Del mismo modo, al activar la casilla Sub , se impedirá la actualización de ese componente de varias partes. Esta opción puede utilizarse como alternativa a activar el icono Lock en el panel Properties .
Después de revisar la lista de cambios propuestos, haga clic en el botón Accept Changes (Create ECO) para abrir el cuadro de diálogo Engineering Change Order. Una vez ejecutada la ECO, los cambios de anotación se aplicarán al diseño.
Comandos adicionales de anotación de esquemas
El menú Herramientas » Annotation contiene varios comandos específicos de anotación de esquemas. El primer elemento del grupo, Annotate Schematic, ya se ha descrito.

Diversos comandos de anotación disponibles
Restablecer designadores del esquema
Si se han cortado y pegado grandes porciones de contenido de distintas fuentes en un nuevo diseño, puede ser necesario restablecer todos los designadores. Dado que este comando utiliza la configuración del cuadro de diálogo Anotar , se aplicará a los elementos configurados previamente en dicho cuadro de diálogo. Por ejemplo, si anteriormente se habían marcado todos los Schematic Sheets To Annotate, el comando Reset Schematic Designators se aplicará a todo el proyecto, independientemente de que las hojas estén abiertas en el editor o no. Si solo se habían marcado algunos Schematic Sheets To Annotate, el comando Reset Schematic Designators solo afectará a esas hojas.
Tras ejecutar el comando, aparecerá un cuadro de diálogo de confirmación que resume el número de designadores que requieren actualización y pregunta si desea continuar con los cambios. Después de hacer clic en Yes, se restablecerán todos los designadores de componentes de todas las hojas de esquemático del proyecto activo que tengan habilitada la anotación, y aparecerán con el formato: R?, C?, D?, U?, etc.
Los designadores bloqueados no se restablecen ni se modifican de ninguna manera.
Restablecer designadores de esquemático duplicados
Al duplicar partes de un diseño, los componentes recién copiados conservarán los mismos valores de designador que los componentes originales. El comando Reset Duplicate Schematic Designators permite restablecer rápidamente los designadores duplicados a '?'. Dado que este comando utiliza la configuración del cuadro de diálogo Annotate , se aplicará a los elementos configurados previamente en dicho cuadro de diálogo. Por ejemplo, si anteriormente se habían marcado todos los Schematic Sheets To Annotate, el comando Reset Duplicate Schematic Designators se aplicará a todo el proyecto, independientemente de que las hojas estén abiertas en el editor o no. Si solo se habían marcado algunos Schematic Sheets to Annotate, el comando Reset Schematic Designators solo afectará a esas hojas.
Tras ejecutar el comando, aparecerá un cuadro de diálogo de confirmación que resume el número de designadores que requieren actualización y pregunta si desea continuar con los cambios. Después de hacer clic en Yes, se restablecerán todos los designadores de componentes duplicados que se encuentren en todas las hojas de esquemático del proyecto activo que tengan habilitada la anotación, y aparecerán con el formato: R?, C?, D?, U?, etc.
Los designadores bloqueados no se restablecen ni se modifican de ninguna manera.
Anotar esquemáticos sin abrir el cuadro de diálogo
El comando Annotate Schematics Quietly se utiliza para examinar todos los documentos de esquemático de origen del proyecto activo que tengan habilitada la anotación y asignar un designador único a cualquier componente que no tenga uno actualmente. La anotación se realiza sin abrir el cuadro de diálogo, lo que permite aplicar toda la configuración anterior del cuadro de diálogo Annotate sin necesidad de volver a abrirlo. Esto resulta especialmente útil si el diseño está pasando por una fase de desarrollo rápido y el diseñador desea anotarlo rápidamente antes de compilarlo.
Forzar la anotación de todos los esquemáticos
Este comando se utiliza para examinar todos los documentos de esquemático de origen del proyecto activo que tengan habilitada la anotación y volver a anotar todos sus componentes de acuerdo con el esquema de anotación definido actualmente en el cuadro de diálogo Annotate.
Ejecutar el comando Force Annotate All Schematics equivale a ejecutar el comando Reset Schematic Designators seguido inmediatamente del comando Annotate Schematics Quietly. Por consiguiente, el comando Force Annotate All Schematics utiliza la configuración establecida previamente en el cuadro de diálogo Annotate para determinar qué componentes y hojas se pueden actualizar.
Tras ejecutar este comando, aparece una solicitud de confirmación que detalla el número de designadores que se actualizarán si se acepta. Después de hacer clic en Yes, se volverán a anotar, cuando sea necesario, todos los designadores de componentes de todas las hojas de esquemático del proyecto activo que tengan habilitada la anotación, para ajustarse al esquema actual de anotación por posición definido en la región Schematic Annotation Configuration del cuadro de diálogo Annotate .
Realizar la anotación inversa de esquemáticos
Antes de la introducción de Design Compiler y Synchronizer de Altium Designer, los cambios de anotación se transferían del esquemático a la PCB mediante un archivo de lista de conexiones (*.net). Los cambios de anotación que debían propagarse en sentido inverso, de la PCB al esquemático, se gestionaban mediante un proceso de anotación inversa. Este proceso utiliza un archivo Was-Is (*.WAS) o un archivo de orden de cambio de ingeniería (*.ECO) para indicar los cambios que deben aplicarse a los designadores del esquemático.
Tras ejecutar el comando, aparecerá el cuadro de diálogo Choose WAS-IS File for Back-Annotation from PCB. Busque y seleccione el archivo .was (o .eco) necesario. Después de hacer clic en Open, aparecerá un cuadro de diálogo informativo que indica cuántos cambios se han realizado en los designadores desde el estado anterior y cuántos desde el estado original. En este punto, los cambios aún no se han aplicado. Haga clic en OK para abrir el cuadro de diálogo Annotate, donde podrá ver los cambios propuestos para los designadores actuales antes de decidir si desea crear una ECO para aplicarlos.
Numerar hojas de esquemático
El comando Number Schematic Sheets no modifica los designadores de componentes, sino los designadores (números) de las hojas de esquemático. Por lo tanto, está relacionado conceptualmente con la noción general de anotación del diseño.
La numeración de hojas y documentos permite controlar la designación de las hojas y almacenar estos valores como parámetros en los respectivos documentos de esquemático. La función de cadenas especiales de Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) permite después mostrar estos valores en la hoja (por ejemplo, en el pie de hoja) como objetos de texto.

Numeración de hojas de esquemático.
El proceso de numeración de hojas es el siguiente:
Numeración automática de hojas (opción del proyecto)
Habilite esta opción para realizar la numeración automática de las hojas. Los valores se mostrarán en el panel Projects. También puede habilitar la numeración automática de hojas marcando la opción Automatic Sheet Numbering en la pestaña Opciones del cuadro de diálogo Project Options.
Numeración automática de hojas
Haga clic en el botón desplegable Auto Sheet Number para acceder a las opciones de numeración de hojas.
Las opciones de Select Numbering Scheme son:
- Display Order - las hojas se numeran en el orden en que se muestran.
- Sheets Hierarchical Structure - Depth First - las hojas se numeran desde el nivel superior hacia cada rama. Primero se numera el nivel superior y, a continuación, se numera por completo la primera rama situada bajo el nivel superior, luego la segunda rama, y así sucesivamente.
- Sheets Hierarchical Structure - Breadth First - las hojas se numeran según su nivel en la jerarquía. Primero se numera el nivel superior, después todos los niveles secundarios, y así sucesivamente.
Las opciones de Select Numbering Method permiten seleccionar valores secuenciales Increasing o Decreasing .
Numeración automática de documentos
Haga clic en el desplegable Auto Document Number para acceder a las opciones de numeración de documentos. Son básicamente las mismas que las opciones de Auto Sheet Number, con la adición de los valores Prefix y Postfix .
Las opciones de Parameters son las siguientes:
-
Prefix - elija un prefijo para colocarlo delante del número de documento. Se admiten prefijos alfabéticos (
A,B,C, etc.), numéricos (1,2,3, etc.) y no numéricos (_,*,.,%, etc.), así como combinaciones de todos ellos. - Start - elija un valor numérico a partir del cual comenzar la numeración.
-
Postfix - elija un sufijo para añadirlo al número de documento. Se admiten sufijos alfabéticos (
A,B,C, etc.), numéricos (1,2,3, etc.) y no numéricos (_,*,.,%, etc.), así como combinaciones de todos ellos. - Step - elija un valor para incrementar cada número de documento. Por ejemplo, si el índice Start se establece en 1 y el valor Step se establece en 100, el primer número de documento será 1, el siguiente será 101 (inicio + incremento), el siguiente 201, y así sucesivamente.
Actualizar el recuento de hojas
Haga clic en el botón Update Sheet Count para contar las hojas del proyecto actual y colocar el resultado en la columna SheetTotal. El recuento de hojas será el número total de hojas del proyecto, independientemente del esquema de numeración seleccionado en cualquiera de los controles anteriores.
Subir/Bajar
Utilice los botones Move Up o Move Down para subir o bajar un documento esquemático seleccionado en la lista. Esto es relevante al utilizar el esquema de numeración Display Order para especificar los números de hoja o de documento.
Numeración y nombres personalizados
Si una organización tiene un sistema específico de numeración o de nombres que no se puede automatizar mediante los comandos Auto Sheet Number o Auto Document Number, los nombres y números de hoja personalizados pueden introducirse directamente en los campos SheetNumber o DocumentNumber .
Numeración de hojas de esquemático y hojas de dispositivo
Los números de hoja o de documento no se pueden configurar para las hojas de dispositivo cuando son de solo lectura (estado predeterminado); estas aparecerán con un tramado cruzado en el cuadro de diálogo Numeración de hojas del proyecto para indicar que no se pueden actualizar. Cuando las hojas de dispositivo se configuran como editables, se elimina el tramado cruzado y la numeración de hojas y documentos se puede configurar con normalidad.
Control de la visualización del designador en la PCB
Las cadenas de designadores extendidos de un diseño multicanal pueden resultar tediosas de colocar en el editor de PCB. Puede elegir opciones de nomenclatura que den como resultado un nombre corto o mostrar en su lugar la designación lógica original del componente. Por ejemplo, C30_CIN1 se mostraría como C30. Esto requeriría añadir alguna otra indicación a la placa para identificar los distintos canales, como dibujar un recuadro alrededor de cada canal en la capa de serigrafía de componentes.
Puede elegir entre la visualización de designadores lógicos o físicos en la PCB mediante el desplegable Designator Display de la región Other del panel Properties en el modo Board . Si elige mostrar los designadores lógicos de los componentes de un diseño multicanal, estos se mostrarán en la PCB y en cualquier salida generada, como impresiones y archivos Gerber. Sin embargo, al generar una lista de materiales siempre se utilizan los designadores físicos únicos.
Sincronización del diseño: finalización del proceso de anotación
La sincronización directa del diseño es el método preferido para mantener la correspondencia entre los designadores del esquemático y de la PCB, salvo que no tenga acceso a ambos editores. La sincronización del diseño compara los componentes y la conectividad del esquemático directamente con la PCB y genera una lista de diferencias. La lista de cambios necesarios para resolver estas diferencias se genera como una ECO (orden de cambio de ingeniería). Un archivo ECO describe las diferencias entre el diseño actual y el diseño deseado y se puede ejecutar para actualizar el destino y sincronizar el diseño.
Sincronización directa e inversa
Los términos sincronización directa y sincronización inversa describen de forma específica la dirección en la que se transfieren la anotación y los cambios de diseño durante la sincronización de datos. Si se considera un flujo de diseño que comienza con el esquemático y está guiado por él, la sincronización directa es el proceso de trasladar a la PCB los cambios realizados en el editor de esquemáticos. La sincronización inversa es el proceso de trasladar al editor de esquemáticos los cambios realizados en la PCB.
Sincronización directa
Algunos motivos para sincronizar los datos del esquemático con la PCB son:
- Se ha añadido un nuevo componente en el editor de esquemáticos y es necesario incorporarlo al diseño de la PCB.
- Ha anotado su diseño esquemático por primera vez o desde la última sincronización del diseño.
- En un diseño multicanal, ha cambiado Project Options para modificar el estilo de nomenclatura física (PCB).
- Ha realizado una anotación a nivel de placa por primera vez o desde la última sincronización del diseño.
Para sincronizar su diseño esquemático con el diseño de la PCB
Elija uno de los siguientes métodos para sincronizar su diseño esquemático con el diseño de la PCB:
- Seleccione Update PCB Document en el menú Design del editor de esquemáticos. Si existen diferencias entre estos y el documento de PCB de destino, se abrirá el cuadro de diálogo Engineering Change Order con una lista de las modificaciones necesarias para sincronizar la PCB con el diseño esquemático. Haga clic en Execute Changes para sincronizar su diseño.
- Seleccione Import Changes en el menú Design del editor de PCB; esta acción importa los cambios de los documentos esquemáticos al documento de PCB.
Sincronización inversa
La sincronización inversa se realiza cuando ha anotado o modificado su diseño de PCB y desea actualizar el diseño esquemático.
Para sincronizar su diseño de PCB con el diseño esquemático
Elija uno de los siguientes métodos para sincronizar su diseño de PCB con el diseño esquemático:
-
en el editor de PCB, seleccione Update Schematics en el menú Design . De forma predeterminada, la opción Push Component Designator Changes to Annotation File (if any) de la pestaña Generación de ECO del cuadro de diálogo Project Options está marcada, de modo que los cambios realizados en el editor de PCB se trasladarán únicamente al archivo de anotación y, en última instancia, a los documentos compilados al compilar. Desmarque esta opción para trasladar los cambios únicamente al documento esquemático de origen (vista Editor ).
- Desde el editor de esquemas, seleccione Tools » Annotation » Annotate Schematics y, a continuación, haga clic en el botón Back Annotate del cuadro de diálogo Anotar. Elija el archivo WAS-IS generado al volver a anotar los designadores en el entorno de PCB.
- Desde el editor de esquemas, seleccione Tools » Annotation » Board Level Annotate y, a continuación, haga clic en el botón Back Annotate del cuadro de diálogo Anotar a nivel de placa. Elija el archivo WAS-IS generado al volver a anotar los designadores en el entorno de PCB.
- Desde el editor de esquemas, seleccione Tools » Annotation » Back Annotate Schematics. Elija el archivo WAS-IS generado al volver a anotar los designadores en el entorno de PCB.
Métodos tradicionales de sincronización del diseño
Altium Designer admite el método tradicional de archivos intermedios (netlist y WAS/IS) para la sincronización del diseño. La sincronización directa de los datos de anotación puede realizarse mediante un archivo netlist y la sincronización inversa, mediante un archivo WAS/IS (que indica lo que cada designador WAS y lo que ahora IS). El método preferido para sincronizar el diseño es la sincronización directa del diseño.
Vinculación de componentes mediante identificadores únicos
Si ha vuelto a anotar el diseño, los designadores de los componentes del esquema o los designadores de los componentes compilados ya no coincidirán con los designadores de los componentes de la PCB, por lo que será necesario sincronizarlos para finalizar correctamente el diseño. En lugar de depender del propio designador como campo clave que relaciona un símbolo del esquema con su huella equivalente en la PCB, Altium Designer puede mantener la sincronización del diseño mediante el sistema de identificadores únicos (UID). El UID es un valor generado por el sistema que identifica de forma única el componente de origen y asocia cada componente del esquema con el componente correspondiente de la PCB.
Cuando se coloca un componente en una hoja de esquema, se le asigna automáticamente un UID. La primera vez que se transfiere la información de los componentes desde los documentos de esquema de origen a una PCB vacía, la información del UID de cada componente del esquema se asigna al componente correspondiente de la PCB.
La refactorización permite convertir hojas de dispositivo en hojas de esquema y viceversa, manteniendo el identificador único de la hoja y sus componentes. Además, puede refactorizar (o mover) subcircuitos a otras hojas de esquema del proyecto actual, manteniendo el identificador único del subcircuito. El comando Refactor se encuentra en el menú Edit .
La función de sincronización de Altium Designer, que se inicia al ejecutar el comando Design » Update, utiliza estos UID para asociar cada componente del esquema con su equivalente en la PCB. Las actualizaciones o los cambios del diseño pueden implementarse entonces mediante órdenes de cambio de ingeniería (ECO). Una ECO enumera todas las modificaciones necesarias para implementar cambios en uno o más documentos de diseño con el fin de llevar a cabo la acción de sincronización solicitada. Las ECO se utilizan para realizar actualizaciones del diseño en diversas situaciones, como:
- Actualizaciones del diseño del esquema a la PCB.
- Actualizaciones de anotación de los designadores de los componentes del esquema y de los designadores de los componentes compilados.
- Implementación de actualizaciones de parámetros mediante Parameter Manager (Tools » Parameter Manager).
- Actualización de la información de los parámetros con información almacenada en las bibliotecas de origen o en una base de datos de la empresa. Siempre que compara el esquema y la PCB (por ejemplo, al seleccionar Design » Update), Altium Designer asocia primero los componentes que comparten el mismo UID. Cuando se detectan componentes que no comparten un UID, se le avisa y la aplicación ofrece intentar asociarlos por designador. Hasta que haya asignado un UID coincidente tanto en el esquema como en la PCB, seguirá recibiendo este mensaje. Los identificadores únicos y su correspondencia se gestionan en el cuadro de diálogo Editar vínculos de componentes (Project » Component Links).
Tenga en cuenta que el cuadro de diálogo solo puede abrirse cuando hay un documento de PCB activo, ya que los cambios de UID siempre se aplican a la PCB y no al esquema. Utilice el cuadro de diálogo en cualquier etapa del diseño para ver los vínculos entre los componentes y verificar que los componentes de los distintos documentos estén correctamente asociados, así como para asignar UID coincidentes a los componentes que aún no estén asociados.
