Trabajar con Pads y Vías

De un vistazo

Este artículo presenta cómo funcionan los pads y las vías en Altium Designer: explica qué son, en qué se diferencian, dónde se utilizan y cómo se colocan y editan tanto en el editor de PCB como en el de huellas de PCB. También destaca los principales tipos de vías, describe los flujos de trabajo de colocación directa y conversión, y aborda las funciones de gestión de plantillas y vías relacionadas con el rendimiento que ofrece el software. Si quieres comprender mejor los objetos esenciales de una PCB que permiten conectar componentes y enrutar entre capas, este artículo te ayudará a familiarizarte con estos conceptos fundamentales con confianza. Sigue leyendo.

- Aprenderás la diferencia práctica entre pads y vías, incluida su estructura, su finalidad y los principales tipos de vías utilizados en el diseño de PCB.
- Verás cómo colocar, mover, convertir y asignar pads y vías en los flujos de trabajo de Altium Designer.
- Obtendrás una visión general de cómo se gestionan las propiedades de los pads y las vías, incluido el uso de plantillas y las principales opciones de edición del panel Properties.
Profundiza con IA:

Resumen de pads y vías

Los pads se utilizan para proporcionar tanto fijación mecánica como conexiones eléctricas a los pines del componente Los pads se utilizan para proporcionar tanto fijación mecánica como conexiones eléctricas a los pines del componente

Un pad es un objeto primitivo de diseño. Los pads se utilizan para fijar el componente a la placa y para crear los puntos de interconexión entre los pines del componente y el ruteo de la placa. Los pads pueden existir en una sola capa, por ejemplo, como un pad de un dispositivo de montaje superficial, o pueden ser pads tridimensionales de orificio pasante, con un cuerpo en forma de barril en el plano Z (vertical) y una superficie plana en cada capa de cobre (horizontal). El cuerpo en forma de barril del pad se forma cuando la placa se taladra y los orificios se metalizan durante la fabricación. En los planos X e Y, los pads pueden tener una forma circular, rectangular, octagonal, rectangular con esquinas redondeadas, rectangular con esquinas achaflanadas o personalizada. Los pads pueden utilizarse individualmente como pads libres en un diseño o, más habitualmente, en el editor de bibliotecas de PCB, donde se incorporan junto con otras primitivas a las huellas de los componentes.

Una vía que abarca y conecta desde la capa superior (rojo) hasta la capa inferior (azul), y que también se conecta a un plano de alimentación interno (verde). 
Una vía que abarca y conecta desde la capa superior (rojo) hasta la capa inferior (azul), y que también se conecta a un plano de alimentación interno (verde).

Una vía es un objeto primitivo de diseño. Las vías se utilizan para establecer una conexión eléctrica vertical entre dos o más capas eléctricas de una PCB. Las vías son objetos tridimensionales y tienen un cuerpo en forma de barril en el plano Z (vertical), con un anillo plano en cada capa de cobre (horizontal). El cuerpo en forma de barril de la vía se forma cuando la placa se taladra y los orificios se metalizan durante la fabricación. Las vías son circulares en los planos X e Y, al igual que los pads redondos. La diferencia principal entre una vía y un pad es que, además de poder abarcar todas las capas de la placa (de la superior a la inferior), una vía también puede abarcar desde una capa superficial hasta una capa interna o entre dos capas internas.

Las vías pueden ser de los siguientes tipos:

  • Thru-Hole – este tipo de vía atraviesa la placa desde la capa superior hasta la capa inferior y permite conexiones a todas las capas de señal internas.
  • Blind – este tipo de vía conecta la superficie de la placa con una capa de señal interna.
  • Buried – este tipo de vía conecta una capa de señal interna con otra capa de señal interna.

Los tipos de vías que pueden utilizarse en el diseño se definen en Layer Stack Manager. Para obtener más información, consulte la página Definición de vías ciegas, enterradas y microvías.

Las definiciones de pads y vías también pueden almacenarse en bibliotecas de plantillas de pads y vías; consulte la página Trabajo con plantillas y bibliotecas de pads y vías para obtener más información.

Las plantillas de pads y vías que no están vinculadas a una biblioteca externa de pads y vías se almacenan dentro del documento PCB, lo que permite reducir los tiempos de carga.

Esta función está disponible cuando la opción PCB.Performance.PadViaTemplate.LoadingOptimization está habilitada en el cuadro de diálogo Configuración avanzada.

El editor de PCB utiliza el concepto de «instanciación de vías», un método para construir la geometría de una instancia de una vía, en lugar de la de una plantilla de vía. Esto mejora el rendimiento y reduce tanto el consumo de memoria como el tiempo de construcción de la escena.

Esta función está en beta abierta y está disponible cuando la opción PCB.ViaInstancing está habilitada en el cuadro de diálogo Configuración avanzada.

Colocación directa de pads y vías

Los pads y las vías pueden colocarse tanto en el editor de PCB como en el editor de huellas de PCB. Las vías suelen colocarse automáticamente durante los procesos de ruteo interactivo o automático, pero pueden colocarse manualmente si es necesario. Las vías colocadas manualmente se denominan vías «libres». Tras iniciar el comando de colocación de pads (Place » Pad) o vías (Place » Via), el cursor cambiará a una cruz y se activará el modo de colocación.

  1. Sitúe el cursor y, a continuación, haga clic o pulse Enter para colocar un pad o una vía.
  2. Siga colocando pads o vías, o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Un pad o una vía adoptará un nombre de red si se coloca sobre un objeto que ya está conectado a una red.

Durante la colocación, pulse la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical según la dirección inicial del movimiento.

Normalmente, las vías no se colocan manualmente, sino automáticamente como parte del proceso de ruteo interactivo. Consulte la sección Colocación de vías durante el ruteo interactivo para obtener más información.

Los pads libres de la capa Multi-layer pueden convertirse en vías. Un pad libre es aquel que no forma parte de un objeto de componente principal. Convertir pads libres en vías puede resultar útil al convertir manualmente archivos Gerber importados de nuevo al formato PCB. Seleccione todos los pads libres que desee convertir en el espacio de diseño y elija el comando Tools » Convert » Convert Selected Free Pads to Vias en los menús principales. Los pads libres se convertirán en vías con el mismo tamaño de orificio. El valor más alto encontrado entre todos los pares de dimensiones XY disponibles para el pad (correspondientes al tamaño del pad en las distintas capas) se utilizará como diámetro de la vía.

También es posible convertir vías en pads libres. Convertir vías en pads libres puede resultar útil al importar archivos PADS-PCB y PADS 2000, en los que se utilizan vías para conectarse a las capas de alimentación y tierra. Esto permite una conexión adecuada a los planos de alimentación internos mediante pads editables. Seleccione todas las vías que desee convertir en el espacio de diseño y elija el comando Tools » Convert » Convert Selected Vias to Free Pads en los menús principales. Las vías se convertirán en pads libres del mismo estilo (Simple, Top-Middle-Bottom o Full Stack) y con el mismo tamaño de orificio. El diámetro de la vía se utiliza para las dimensiones XY del pad en las capas correspondientes. La forma del pad se establecerá en Round.

Edición gráfica

Las propiedades de los pads y las vías no pueden modificarse gráficamente, salvo su ubicación.

  • Para mover un pad libre y también las pistas conectadas, haga clic sobre el pad, mantenga pulsado el botón y muévalo. El ruteo conectado permanecerá unido al pad mientras se mueve. Tenga en cuenta que el pad no se moverá si pertenece a un componente.
  • Para mover un pad libre sin mover las pistas conectadas en el editor de PCB o de bibliotecas de PCB, seleccione el comando Edit » Move » Move y, a continuación, haga clic en el pad, mantenga pulsado el botón y muévalo.
  • Si hace clic y arrastra un rectángulo de selección alrededor de pads component, estos no se seleccionarán, ya que en realidad son objetos secundarios del componente. Para seleccionar únicamente los pads, mantenga pulsado Ctrl mientras hace clic y arrastra la ventana de selección.
  • Si está moviendo una vía junto con el trazado para crear más espacio para el trazado o los componentes, puede resultar más eficiente volver a trazar las pistas que moverlas. El software incluye una función denominada Loop Removal. Con esta función activada, trace una nueva ruta (que comience y termine en algún punto del trazado original); en cuanto haga clic con el botón derecho para salir del modo de trazado interactivo, se eliminará el trazado anterior (bucle), incluidas las vías redundantes.

Edición no gráfica mediante el panel Properties

Este método de edición utiliza el modo correspondiente del panel Properties para modificar las propiedades de un objeto pad/vía.

Alivios térmicos de pads y vías

El campo Thermal Relief de la región Pad Stack / Via Stack del panel Properties resume la configuración de alivio térmico aplicada actualmente. Por ejemplo, Relief, 15mil, 10mil, 4, 90 significa que:

  • se aplica la conexión con alivio térmico;
  • el espacio de separación tiene 15 mil de ancho;
  • los conductores de alivio térmico tienen 10 mil de ancho;
  • los conductores de alivio térmico tienen una rotación de 90 grados.

Cuando la casilla del campo Thermal Relief está desactivada, los alivios térmicos de los pads y las vías conectados a polígonos son rules-driven, es decir, estos alivios se definen mediante las reglas de diseño de estilo de conexión de polígonos aplicables. Para cada pad, la configuración de alivio térmico se puede personalizar activando la opción Thermal Relief asociada a la capa deseada. En este caso, los alivios térmicos se consideran custom. Obtenga más información sobre cómo definir alivios térmicos personalizados.

Expansiones de las máscaras de soldadura y de pasta

La máscara de soldadura se crea automáticamente en cada pad/vía de la capa de máscara de soldadura. La máscara de soldadura se define en negativo; es decir, los objetos colocados definen aberturas en la capa de máscara de soldadura. La máscara de pasta se crea automáticamente en cada pad de la capa de máscara de pasta. La forma que se crea en la capa de máscara es la del pad/vía, expandida o contraída según el valor especificado por las reglas de diseño Expansión de máscara de soldadura y Expansión de máscara de pasta configuradas en el editor de PCB o según lo especificado en el panel Properties.

Pads con la máscara de soldadura visible.
Pads con la máscara de soldadura visible.

Al editar un pad o una vía, verá los ajustes de expansión de la máscara de soldadura y de la máscara de pasta en las secciones Pad Stack y Solder Mask Expansion del panel Properties, respectivamente. Aunque estos ajustes permiten controlar localmente los requisitos de expansión de un pad/vía, normalmente no necesitará utilizarlos. Por lo general, resulta más sencillo controlar los requisitos de las máscaras de pasta y de soldadura definiendo las reglas de diseño adecuadas en el editor de PCB. Al utilizar reglas de diseño, se define una regla para establecer la expansión de todos los componentes de la placa y, si es necesario, se pueden añadir otras reglas para situaciones específicas, como todas las instancias de un tipo de huella utilizado en la placa, un pad concreto de un componente determinado, etc.

  

Para configurar las expansiones de máscara en las reglas de diseño:

  1. Confirme que la opción Rule Expansion esté seleccionada como Shape en la sección Pad Stack del panel Properties (para pads) y/o que la opción Rule esté seleccionada en la sección Solder Mask Expansion del panel Properties (para vías).

  2. En el editor de PCB, seleccione Design » Rules en los menús principales y examine las reglas de diseño de la categoría Mask en el cuadro de diálogo Editor de reglas y restricciones de PCB. Estas reglas se aplicarán cuando la huella se coloque en la PCB.

Para anular las reglas de diseño de expansión y especificar una expansión de máscara como atributo del pad/vía, seleccione Manual Expansion como Shape en la sección Pad Stack del panel Properties (para pads) y/o Manual en la sección Solder Mask Expansion del panel Properties (para vías) e introduzca los valores necesarios.

La capa de máscara de pasta para pads de agujero pasante es compatible con los documentos de Draftsman y las salidas Gerber, Gerber X2, ODB++, IPC-2581 e impresión de PCB.
Para los pads, también puede seleccionar manualmente una forma de máscara de un conjunto estándar de formas predefinidas o crear su propia forma personalizada: más información.

Cobertura de pads y vías con máscara de soldadura

La cobertura parcial o completa de pads y vías con máscara de soldadura se puede conseguir definiendo un valor adecuado de expansión de máscara de soldadura. Esta restricción de expansión puede definirse individualmente para cada objeto en el panel Properties o mediante las reglas de diseño de expansión de máscara de soldadura adecuadas. Al establecer un valor de expansión apropiado, puede conseguir lo siguiente:

  • Para cubrir parcialmente un pad/vía, cubriendo solo el área de cobre, establezca la expansión en un valor negativo que cierre la máscara hasta el agujero del pad/vía.
  • Para cubrir completamente un pad/vía, cubriendo tanto el área de cobre como el agujero, establezca la expansión en un valor negativo cuya magnitud sea igual o superior al radio del pad/vía.
  • Para cubrir todos los pads/vías de una sola capa, establezca el valor de expansión adecuado y asegúrese de que el alcance (consulta completa) de una regla de expansión de máscara de soldadura incluya todos los pads/vías de la capa requerida.
  • Para cubrir completamente todos los pads/vías de un diseño en el que se hayan definido vías de distintos tamaños, establezca la expansión en un valor negativo cuya magnitud sea igual o superior al radio del pad/vía más grande. Al cubrir un pad/vía individual, puede optar por utilizar la expansión definida en la regla de diseño aplicable o anular la regla y aplicar una expansión específica directamente al pad/vía en cuestión.

Puntos de prueba

Related page: Asignación de puntos de prueba en la placa

El software ofrece compatibilidad completa con los puntos de prueba y permite especificar pads (de agujero pasante o SMD) y vías como ubicaciones de puntos de prueba para las pruebas de fabricación y/o ensamblaje. Para designar un pad/vía como punto de prueba, se configuran sus propiedades correspondientes: si debe ser un punto de prueba de fabricación o de ensamblaje y en qué lado de la placa debe utilizarse como punto de prueba. Estas propiedades se encuentran en la sección Testpoint del panel Propiedades .

Para agilizar el proceso y reducir la necesidad de configurar manualmente las propiedades de los puntos de prueba, el software ofrece un método para asignarlos automáticamente en función de las reglas de diseño definidas y mediante el Administrador de puntos de prueba (Tools » Testpoint Manager). En cada caso, esta asignación automática configura las propiedades correspondientes del punto de prueba para el pad/vía.

Características específicas de los pads

Designadores de pads

Cada pad debe etiquetarse con un designador (que suele representar el número de pin de un componente) de hasta 20 caracteres alfanuméricos. Los designadores de los pads se incrementarán automáticamente de uno en uno durante la colocación si el pad inicial tiene un designador que termina en un carácter numérico. Antes de colocarlo, cambie el designador del primer pad desde el panel Propiedades .

Para obtener incrementos alfabéticos, por ejemplo, 1A, 1B, o incrementos numéricos distintos de 1, utilice el cuadro de diálogo Configurar matriz de pegado, al que se accede pulsando el botón Paste Array en el cuadro de diálogo Pegado especial (Edit » Paste Special).

Función de pegado en matriz

Si establece el designador del pad antes de copiarlo al portapapeles, puede utilizar el cuadro de diálogo Setup Paste Array para aplicar automáticamente una secuencia de designadores durante la colocación de los pads. Mediante el campo Text Increment del cuadro de diálogo Setup Paste Array, se pueden colocar las siguientes secuencias de designadores de pads:

  • Numérica (1, 3, 5)
  • Alfabética (A, B, C)
  • Combinación alfanumérica (A1 A2, 1A 1B, A1 B1 o 1A 2A, etc.)

Para incrementar numéricamente, establezca el campo Text Increment en el valor del incremento deseado. Para incrementar alfabéticamente, establezca el campo Text Increment en la letra del alfabeto que represente el número de posiciones que desea avanzar. Por ejemplo, si el pad inicial tiene el designador 1A, establezca el campo en A (primera letra del alfabeto) para incrementar los designadores de uno en uno. Si establece el campo en C (tercera letra del alfabeto), los designadores serán 1A, 1D (tres posiciones después de A), 1G, etc.

Conexiones mediante puentes

Las conexiones mediante puentes definen conexiones eléctricas entre pads de componentes que no están enrutadas físicamente mediante primitivas en la PCB. Son especialmente útiles en placas de una sola capa, en las que se utiliza un cable para pasar por encima de las pistas de la única capa física.

Los pads de un componente pueden etiquetarse con un Jumper valor desde el panel Properties. Los pads que comparten el mismo puente y la misma red eléctrica indican al sistema que existe una conexión válida entre ellos, aunque no estén conectados físicamente.

Las conexiones mediante puentes se muestran como líneas de conexión curvas en el editor de PCB. El comprobador de reglas de diseño no notificará las conexiones mediante puentes como redes sin rutear.

Detalles de las vías

Definición de las propiedades de las vías

Mientras que los requisitos de extensión entre capas (plano Z) de cada tipo de vía se definen en la pestaña Tipos de vías del Administrador de apilado de capas, las propiedades de tamaño de la vía se definen mediante:

Configuración de la regla de diseño de estilo de vías de ruteo

Main page: Definición, alcance y gestión de las reglas de diseño de PCB

Las propiedades de tamaño de las vías colocadas durante el ruteo interactivo, ActiveRouting o el ruteo automático se controlan mediante la regla de diseño de estilo de vías de ruteo aplicable. Para facilitar la selección de las vías a las que se aplica la regla de diseño, existe un conjunto de palabras clave de consulta relacionadas con las vías que puede utilizar en el alcance de la regla (Where the Object Matches); estas se detallan a continuación.

Cuando realiza un cambio de capa durante el ruteo, el software examina las capas inicial y final de ese cambio y selecciona un tipo de vía permitido de Layer Stack Manager. A continuación, identifica la regla de diseño de estilo de vías de ruteo aplicable con la mayor prioridad y aplica los ajustes de tamaño de vía de la sección Constraints de esa regla a la vía que se va a colocar.

Por ejemplo, puede tener un conjunto de redes DRAM_DATA que requieren µVias para la transición de la capa TopLayer a la capa S2 y de la capa S2 a la capa S3, y una vía pasante taladrada para todas las demás transiciones entre capas (que también es distinta de la vía requerida por otras redes). Esto puede resolverse creando dos reglas de diseño de estilo de vías de ruteo para estas redes DRAM_DATA. A continuación se muestra un ejemplo de una regla de diseño adecuada para µVias; sitúe el cursor sobre la imagen para mostrar la regla de diseño para vías pasantes.

El alcance de las reglas de diseño puede definirse para que se apliquen a tipos específicos de vías.
El alcance de las reglas de diseño puede definirse para que se apliquen a tipos específicos de vías.

Cuando una vía se coloca en un espacio libre, el software no puede aplicar una regla de diseño de estilo de ruteo durante la colocación. En esta situación, se colocará la vía predeterminada.

Query Keywords

Para simplificar la definición del alcance de las reglas de diseño de estilo de vías de ruteo, están disponibles las siguientes palabras clave de consulta relacionadas con las vías:

Via Type Query Returns
IsVia Todos los objetos de vía, independientemente del tipo de vía.
IsThruVia Todas las vías que se extienden desde la capa superior hasta la capa inferior.
IsBlindVia Todas las vías que comienzan en una capa superficial y terminan en una capa interna y que no son µVias.
IsBuriedVia Todas las vías que comienzan en una capa interna y terminan en otra capa interna y que no son µVias.
IsMicroVia Todas las vías que tienen activada la opción µVia y conectan capas adyacentes.
IsSkipVia Todas las vías que tienen activada la opción µVia y abarcan 2 capas.

Utilice la función Máscara del Asistente de consultas para encontrar las palabras clave disponibles relacionadas con las vías. Pulse F1 cuando haya seleccionado una palabra clave de consulta en la lista para obtener ayuda sobre ella.

Colocación de vías durante el ruteo interactivo

Cuando cambia de capa durante el ruteo interactivo, el software inserta automáticamente una vía. La vía seleccionada depende de lo siguiente:

  • Los tipos de vía disponibles para las capas que se abarcan en el cambio de capa.
  • La regla de diseño de estilo de vías de ruteo aplicable al tipo de vía seleccionado para ese cambio de capa.

Para cambiar de capa durante el ruteo interactivo:

  • Pulse la tecla * del teclado numérico para pasar a la siguiente capa de señal.
  • Utilice la combinación Ctrl+Shift+WheelRoll para desplazarse hacia arriba o hacia abajo por las capas.

Colocación de µVias apiladas durante un cambio de capa de L1 a L4. El modo Interactive Routing del panel Properties muestra los tipos de vía que se colocarán; pulse 6 para recorrer los posibles apilamientos de vías; pulse 8 para mostrar una lista de los posibles apilamientos de vías.

Control de la vía colocada durante el ruteo interactivo

  • Al cambiar de capa de ruteo, el software selecciona automáticamente el tipo de vía más adecuado para esa extensión entre capas.

  • Si pueden utilizarse varios tipos de vía o combinaciones (apilamientos de vías), pulse el atajo de teclado 6 para recorrer de forma interactiva todos los apilamientos de vías disponibles para ese cambio de capa; pulse el atajo 8 para mostrar una lista. Los apilamientos de vías se presentan en este orden: usar µVias, usar µVia de salto, usar vía ciega, usar vía pasante. Las vías apiladas pueden colocarse si el cambio abarca más de una capa y se han definido tipos de vía adecuados. Los tipos de vía propuestos se detallan en la barra de estado y en la visualización superpuesta, por ejemplo [µVia 1:2, µVia 2:3, µVia 3:4], como se muestra en la imagen anterior.

  • El último apilamiento de vías utilizado se conserva como predeterminado para la siguiente red que rutee. El apilamiento de vías predeterminado solo se conserva durante la sesión de edición actual.

  • Las propiedades de tamaño de las vías se especifican mediante la regla de diseño de estilo de vías de ruteo aplicable; las estrategias para definir una regla de diseño de estilo de vías de ruteo adecuada se describen más arriba.

  • Para cambiar de forma interactiva el tamaño de la vía mientras se realiza un cambio de capa, pulse el atajo 4. Esto recorrerá los modos de tamaño de vía: Rule Minimum; Rule Preferred; Rule Maximum; User Choice; el modo de tamaño de vía actual se mostrará en la visualización superpuesta y en la barra de estado (como se muestra en la imagen anterior). Si se selecciona Elección del usuario, pulse Shift+V para abrir el cuadro de diálogo Elegir tamaños de vía y seleccione el tamaño de vía que prefiera. La lista de tamaños de vía disponibles que se muestra en el cuadro de diálogo se obtiene de la lista de vías ya utilizadas en el diseño; puede examinarlas en el modo Plantillas de pads y vías del panel PCB.

    Si se utiliza el modo Template preferred en la regla de diseño de estilo de vías de ruteo aplicable, el atajo 4 recorrerá las plantillas de vía habilitadas.

  • En el panel Properties se muestra una vista lateral de los tipos de vía propuestos, como se muestra arriba.

  • Para colocar una vía y continuar el ruteo en la misma capa, pulse el atajo 2.

  • Para colocar una vía y suspender el ruteo de esta conexión, pulse el atajo / del teclado numérico.

  • Si la red que se está ruteando debe conectarse a un plano de alimentación interno, pulse la tecla / (del teclado numérico) para colocar una vía que se conecte al plano de alimentación correspondiente. Esto funcionará en todos los modos de colocación de pistas excepto en el modo Cualquier ángulo .

  • Pulse Shift+F1 mientras enruta para ver un menú con todos los atajos disponibles durante el comando.

Trabajo con vías apiladas

  • Las vías apiladas que forman una conexión continua se pueden manipular como si fueran una sola vía; click and drag sobre la pila para moverlas todas junto con el enrutado conectado.

  • Haga clic una vez para seleccionar la vía superior de la pila. Si no mueve el ratón, los siguientes clics seleccionarán, por turnos, cada una de las demás vías de la pila.

    Si la opción Display popup selection dialog está habilitada en la página PCB Editor – General del cuadro de diálogo Preferences, al hacer clic en una pila de vías se abrirá una ventana emergente de selección en la que podrá seleccionar la vía deseada.

  • Ctrl+Click and drag para mover únicamente la vía seleccionada junto con el enrutado conectado.

  • Para seleccionar todas las vías de una pila, haga clic una vez para seleccionar una y, a continuación, pulse Tab para ampliar la selección e incluir todas las vías de esa pila.

Configuración de la visualización de vías

Hay varias funciones de visualización disponibles para facilitar el trabajo con vías.

Colores de las vías

Los colores de las vías se configuran en el panel View Configuration. El anillo de cobre de la vía se muestra con el ajuste actual de Multi-Layer en la sección Layers . El color del orificio de la vía se muestra con el ajuste de Via Holes en la sección System Colors . También puede desactivar la visualización de los orificios alternando  para los ajustes deseados.

En la primera imagen se muestra una vía pasante. La vía de la segunda imagen es una vía ciega; el orificio se muestra con los colores de las capas inicial y final.
En la primera imagen se muestra una vía pasante. La vía de la segunda imagen es una vía ciega; el orificio se muestra con los colores de las capas inicial y final.

Vías y máscara de soldadura

La presentación predeterminada de las capas en el editor de PCB muestra siempre Multi-Layer como la capa superior. Esto puede dificultar la visualización precisa del contenido de las capas de máscara de soldadura, especialmente cuando un pad o una vía utiliza una expansión negativa de la máscara, ya que el contenido de la capa de máscara de soldadura quedará oculto bajo el objeto multicapa. Puede cambiar este comportamiento modificando el orden de dibujado de las capas en la página PCB Editor – Display del cuadro de diálogo Preferences. Configure la capa actual para que se dibuje como la capa superior.

Al cambiar el orden de dibujado para mostrar la capa actual por encima de las demás, cuando establezca Top Solder como capa actual, las aperturas de la máscara se representarán con precisión, como se muestra en la siguiente imagen. Las flechas verdes indican el tamaño de la apertura de la máscara de soldadura de una vía a la izquierda, de un pad con la apertura reducida en el centro y de un pad con la apertura ampliada a la derecha.

Configure los ajustes de visualización para poder examinar las aperturas de la máscara de soldadura.
Configure los ajustes de visualización para poder examinar las aperturas de la máscara de soldadura.

Visualización de vías apiladas

Si hay vías apiladas, los números mostrados corresponden a las capas inicial y final de todas las vías de la pila. Pase el cursor sobre la siguiente imagen para mostrar las vías en 3D; a la derecha de la imagen hay una pila de tres vías.

Las capas abarcadas pueden mostrarse en las vías. Pase el cursor para mostrar las vías en 3D.Las capas abarcadas pueden mostrarse en las vías. Pase el cursor para mostrar las vías en 3D.

Otros ajustes de visualización de vías

Para mostrar el nombre de la red de la vía y los números de capa en el tramo que abarca la vía, habilite las opciones Via Nets y Via Span, respectivamente, en la región Additional Options de la pestaña View Options del panel View Configuration.

Exploración de orificios de pads y vías

En el modo del panel PCB Hole Size Editor, sus tres regiones principales cambian para reflejar lo siguiente (de arriba abajo):

  • El filtrado general de los tipos de orificios y su estado, con una subsección para los pares de capas de taladrado definidos actualmente para la placa.
  • Unique Holes organizados en grupos según su tamaño y forma.
  • Los Pads/Vias individuales que constituyen cada grupo de objetos de orificio.

Las secciones del panel muestran el filtrado acumulado aplicado a los tipos, estilos y estados de los orificios.
Las secciones del panel muestran el filtrado acumulado aplicado a los tipos, estilos y estados de los orificios.

Los grupos de orificios se pueden editar de forma conjunta en la región Unique Holes del panel introduciendo valores en la celda de la columna correspondiente. Puede introducir un valor numérico para cambiar el tamaño actual del orificio de pads y vías en la columna Hole Size .

Edición del tamaño del orificio para el grupo seleccionado de seis estilos de orificio coincidentes.
Edición del tamaño del orificio para el grupo seleccionado de seis estilos de orificio coincidentes.

También puede cambiar las entradas Hole Length, Hole Type y Plated correspondientes a los orificios, cuando proceda.

Cambio del tipo de orificio para el grupo seleccionado de seis estilos de orificio coincidentes.
Cambio del tipo de orificio para el grupo seleccionado de seis estilos de orificio coincidentes.

Los objetos individuales de pad/vía que pertenecen al grupo de orificios seleccionado se enumeran en la sección inferior Pad/Via del panel PCB. Haga clic con el botón derecho en un objeto de la lista y seleccione Properties (o haga doble clic directamente en la entrada) para abrir el modo correspondiente del panel Properties para esa primitiva, donde podrá ver y editar sus propiedades.

Para actualizar el panel PCB en su modo Hole Size Editor con los datos actuales de los símbolos de taladrado de la PCB, haga clic con el botón derecho dentro de una región del panel en este modo y seleccione el comando Refresh.

Los datos de los símbolos de taladrado se actualizan automáticamente al guardar el documento de PCB y al generar cualquier salida que contenga estos datos.

Los datos de los símbolos de taladrado no se actualizan automáticamente en el panel PCB para mejorar el rendimiento. La actualización manual de estos datos está disponible cuando la opción PCB.LiveDrillSymbols está deshabilitada en el cuadro de diálogo Advanced Settings.

Compatibilidad con el taladrado posterior

El modo Hole Size Editor del panel PCB también se puede utilizar para examinar los pads y las vías destinados al taladrado posterior. Los pares de capas de taladrado posterior se muestran en la lista Layer Pairs identificados mediante la adición del texto [BD].

Cuando se selecciona un tamaño de orificio de taladrado posterior, el Kind de los objetos se muestra como Backdrill. Utilice esta función para localizar y examinar rápidamente los orificios con taladrado posterior. Tenga en cuenta que los ajustes de taladrado posterior no se pueden editar en el panel.

Informe de taladrado posterior

Para generar un informe de todas las operaciones de taladrado posterior, haga clic con el botón derecho en la lista Unique Holes y seleccione Backdrill Report en el menú contextual.

El informe detalla cada operación de taladrado posterior, incluida la ubicación, el diámetro de taladrado y la profundidad de taladrado.

Para obtener más información sobre el taladrado posterior, consulte Taladrado de profundidad controlada o taladrado posterior.

Compatibilidad con cajeados y avellanados

El modo Hole Size Editor del panel PCB también se puede utilizar para examinar pads con funciones de cajeado o avellanado habilitadas. Cuando el diseño de PCB contiene objetos de pad con funciones de cajeado o avellanado habilitadas en una o ambas caras, los grupos Counterholes Top y/o Counterholes Bottom correspondientes se muestran en la lista Layer Pairs. Las columnas Counterhole Depth y Counterhole Angle se pueden mostrar en Unique Holes del panel. Ten en cuenta que los ajustes de los avellanados y cajeados no se pueden editar en el panel.

La información sobre los avellanados y cajeados del diseño se muestra en el modo Hole Size Editor del panel PCB.
La información sobre los avellanados y cajeados del diseño se muestra en el modo Hole Size Editor del panel PCB.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents