Definición de requisitos de diseño con Constraint Manager
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Aprenderás a comprobar si el Administrador de restricciones está disponible para tu proyecto y qué implica que tu proyecto siga utilizando el método anterior de gestión de reglas.
- Verás cómo se organiza el Administrador de restricciones, qué tipos de restricciones se pueden definir en cada vista y cómo acceder a él desde el editor de esquemas o de PCB.
- Conocerás aspectos clave para el trabajo diario, como guardar y actualizar los cambios, distinguir entre los valores predeterminados y los personalizados, y definir las separaciones en la matriz.
El Administrador de restricciones es una interfaz de usuario basada en documentos, similar a una hoja de cálculo, que permite ver, crear y gestionar las restricciones de diseño utilizadas en sus diseños de PCB.
Algunas de las ventajas de utilizar el Administrador de restricciones, especialmente en diseños complejos con muchas redes, clases, etc., son:
-
Su disponibilidad a nivel de proyecto permite acceder a la gestión de restricciones de diseño de forma similar tanto desde el entorno de captura de esquemáticos como desde el de diseño de PCB.
-
El cambio de la definición del ámbito de las reglas mediante consultas a la correspondencia con el tipo de objeto al que se aplican simplifica la creación de reglas de restricción.
-
El uso de conjuntos de restricciones agiliza el proceso de definición de las restricciones.
-
La prioridad de las reglas se establece automáticamente según la jerarquía natural de los objetos de diseño.
-
El uso de una interfaz basada en documentos en lugar de un cuadro de diálogo permite que los editores de esquemáticos y de PCB y sus funciones asociadas permanezcan activos y accesibles.
Acceso al Administrador de restricciones
Para acceder al Administrador de restricciones, seleccione el comando Design » Constraint Manager en los menús principales del editor de esquemáticos o de PCB.

Acceso al Administrador de restricciones desde el editor de esquemáticos

Acceso al Administrador de restricciones desde el editor de PCB
Tipos de restricciones
Con los botones situados en la esquina superior izquierda del Administrador de restricciones, puede cambiar entre sus vistas para definir distintos tipos de restricciones.
Notas sobre el uso del Administrador de restricciones:
-
Utilice la opción Units del panel Properties (o las opciones correspondientes del submenú Tools » Measurement Units en los menús principales; atajo de teclado:
Ctrl+Q) para cambiar entre las unidades de medida (mm o mils) en las que se muestran los valores en el área de cuadrícula del Administrador de restricciones. -
Utilice la opción Show Default Values del panel Properties (o la opción correspondiente del menú principal View o del submenú View Options del menú contextual del área de cuadrícula) para mostrar u ocultar los valores predeterminados (por ejemplo, los valores heredados de una clase de red o de un par diferencial) en el Administrador de restricciones. Cuando se muestran, estos valores predeterminados aparecen en gris en el área de cuadrícula del Administrador de restricciones. Los valores personalizados aparecen en blanco.
-
En las vistas Physical o Electrical, utilice la opción Show Only Object Custom Values del panel Properties (o la opción correspondiente del menú principal View o del submenú View Options del menú contextual del área de cuadrícula) para mostrar u ocultar las entradas de objetos con valores predeterminados (es decir, para excluir las entradas con valores predeterminados cuando la opción está habilitada).
-
Se pueden copiar y pegar valores desde y hacia las celdas: utilice los comandos del submenú Copy/Paste Values del menú contextual o los atajos de teclado
Ctrl+CyCtrl+V. -
Utilice el campo Search de la esquina superior derecha del Administrador de restricciones para filtrar la lista de objetos introduciendo una cadena de búsqueda. Haga clic en el icono
situado a la derecha de la barra Search para eliminar la cadena de búsqueda definida actualmente.
-
Utilice el campo Comment situado en la parte inferior del Administrador de restricciones cuando haya seleccionado una celda de una restricción/regla para añadir un comentario a dicha restricción/regla, por ejemplo, una descripción significativa de para qué se utiliza Cuando la parte inferior del Administrador de restricciones permita definir restricciones para distintas reglas, podrá definir un comentario individual para cada una de ellas cambiando la regla actual mediante la lista desplegable Rule
-
Debe guardar los cambios en el Administrador de restricciones para que se reflejen en el diseño. Para ello, utilice el comando File » Save (cuando acceda al Administrador de restricciones desde el esquema) o File » Save to PCB (cuando acceda al Administrador de restricciones desde la PCB) de los menús principales del Administrador de restricciones, o el atajo de teclado
Ctrl+S. -
Al guardar por primera vez en el Administrador de restricciones al que se ha accedido desde el esquema, el documento de restricciones del esquema (
Constraints.xml) se añade al proyecto y queda disponible a través del panel Projects (en la subcarpeta Settings/Constraints – Además, los datos de restricciones del documento se vuelven a cargar o se actualizan después de actualizar el proyecto desde el Workspace conectado. -
Si hay cambios en el diseño del esquema o en el apilado de capas de la PCB (cambios que afecten a las capas y/o a los perfiles de impedancia), haga clic en el botón
situado en la parte superior del Administrador de restricciones (al que se accede desde el editor correspondiente) para reflejar estos cambios en el Administrador de restricciones. Este botón también permite importar directivas de los esquemas al Administrador de restricciones – más información. Si tiene cambios en el Administrador de restricciones que aún no se han guardado, aparecerá un cuadro de diálogo de confirmación que le advertirá de que se perderán estos cambios.
-
Las siguientes opciones globales están disponibles en la sección Clearances Settings del panel Properties desde las vistas Clearances y Physical cuando se accede al Administrador de restricciones desde el esquema o la PCB:
-
Ignore Pad to Pad clearances within a footprint – utilice esta opción para aplicar el ajuste a todas las reglas de separación definidas. Esta opción le permite especificar si se ignoran las separaciones entre pads de una misma huella de componente.
-
Apply zero Keepout clearance – cuando esta opción está activada, se aplica una regla de separación predeterminada, con una distancia de «0», entre una zona de exclusión y todas las demás primitivas del diseño. Tenga en cuenta que esta regla no es visible en ninguna de las vistas del Administrador de restricciones y, por tanto, no se puede modificar. Si está desactivada, se utilizarán los valores habituales de la matriz de separaciones.
-
-
Puede deshacer o rehacer rápidamente los cambios realizados en el Administrador de restricciones mediante
en la esquina superior izquierda del espacio de diseño o mediante Edit » Undo/Redo en los menús principales. Esta función está disponible en la mayoría de las áreas, incluidas las reglas, los ámbitos y los conjuntos de restricciones. Al igual que en otras áreas del software, los iconos/comandos solo están disponibles si se ha realizado una acción (para deshacer) o se ha deshecho una acción (para rehacer).
Trabajar con la matriz de separaciones
De forma predeterminada, la matriz de separaciones de la vista Clearances del Administrador de restricciones incluye una única entrada de All Net Classes a All Net Classes, con la que puede definir un valor de separación predeterminado entre cualesquiera redes del diseño. Utilice el control Add situado en la parte superior izquierda de la matriz (o haga clic con el botón derecho en cualquier celda de la matriz de separaciones y utilice el comando Add del menú contextual) para mostrar una ventana emergente con una lista de las clases de redes y de pares diferenciales definidas actualmente. Seleccione las clases necesarias (puede seleccionar varias entradas de clase mediante Shift+Click o Ctrl+Click) y haga clic en el botón Add. Se añadirán a la matriz una fila y una columna por cada clase seleccionada.
Haga clic en la celda donde se cruzan la fila y la columna de dos clases para seleccionarla y mostrar los ajustes detallados de separación en la parte inferior del Administrador de restricciones, donde puede definir valores de separación específicos entre distintos objetos y en distintas capas.
Utilice el campo Clearance de la parte inferior para introducir el valor necesario, que se aplicará a todos los pares de objetos y a todas las capas de este par de clases. También puede hacer doble clic en una celda de la matriz de la parte superior para introducir directamente el valor necesario.
Introduzca en la tabla los valores de separación necesarios para pares de objetos específicos. Tenga en cuenta que la celda de la matriz de separaciones muestra el intervalo entre los valores mínimo y máximo definidos en la tabla.
Notas sobre el uso de la vista Clearances:
-
Al introducir un valor en una celda de la matriz de separaciones o en el campo Clearance, ese valor se aplicará automáticamente a todos los campos de la cuadrícula de la parte inferior del Administrador de restricciones cuando haya una celda seleccionada en la matriz de separaciones. Solo es necesario editar la cuadrícula cuando se deba definir una separación en función del tipo de objeto.
-
En los ajustes detallados de separación de la parte inferior del Administrador de restricciones, también puede activar la restricción Creepage para las clases seleccionadas y definir el valor de la distancia de fuga Esta restricción comprueba la distancia de fuga entre las señales especificadas a lo largo de la superficie de la placa, a través de orificios no metalizados y recortes, y alrededor del borde de la placa.
-
En los ajustes detallados de separación de la parte inferior del Administrador de restricciones, también puede activar la restricción Z-Axis Clearance para las clases seleccionadas y definir el valor de separación en el eje Z Esta restricción se utiliza para comprobar las separaciones mínimas entre primitivas en distintas capas de cobre.
-
Para restablecer el valor de separación de un par de objetos específico (por ejemplo, un par de Track a Track) a su valor predeterminado (es decir, al valor definido para la entrada de All Net Classes a All Net Classes), seleccione su celda en la tabla inferior y pulse la tecla
Deleteo haga clic con el botón derecho en la celda y seleccione el comando Reset to Default del menú contextual. -
Para restablecer los valores de separación de todos los pares de objetos de una entrada específica de la matriz de separaciones (por ejemplo, una entrada entre una clase de redes y otra clase de redes) a sus valores predeterminados, haga clic con el botón derecho en la celda correspondiente de la matriz de separaciones y seleccione el comando Remove Rule del menú contextual.
-
Para eliminar una clase de la matriz de separaciones, haga clic con el botón derecho en cualquier celda de la fila de esta clase en la matriz de separaciones y seleccione el comando Remove Scope del menú contextual.
Configuración de separaciones por capa
Mediante las pestañas situadas debajo de la tabla, también puede definir valores de separación por capas. Utilice el control Add para añadir una pestaña para una capa específica.
Filtrado de clases
Para facilitar el trabajo con un gran número de clases en la vista Clearances, puede utilizar la función de filtrado/agrupación. Esta permite crear filtros (o agrupaciones) de clases para alternar entre subconjuntos específicos de la matriz de separaciones y trabajar con ellos.
Utilice el botón
situado en la parte superior derecha de la vista Clearances para acceder a una ventana emergente desde la que puede crear, editar, eliminar y activar/desactivar filtros.
Trabajo con restricciones físicas y eléctricas
En la vista Physical o Electrical del Administrador de restricciones, haga clic en una celda del área de la cuadrícula para mostrar la configuración de las reglas correspondientes en la parte inferior del Administrador de restricciones, donde puede definir sus valores de restricción.
En la vista Physical se pueden configurar las siguientes restricciones:
-
Width – esta restricción especifica el ancho de las pistas colocadas en las capas de señal.
-
Diff Pair Gap – esta restricción especifica la separación (o distancia) entre las redes de los pares diferenciales incluidos en su ámbito de aplicación.
-
Clearance – esta restricción especifica la separación mínima permitida entre los objetos de las redes incluidas en su ámbito de aplicación y los objetos de otras redes del diseño.
-
Via Style – esta restricción especifica el estilo de las vías que se pueden utilizar durante el enrutado. Puede definir valores específicos mínimos, máximos y preferidos para el diámetro y el tamaño del taladro de la vía (Min/Max Preferred) o, cuando se accede al Administrador de restricciones desde la PCB o al configurar restricciones para un apilado de capas específico (más información), utilizar las plantillas disponibles para el diseño de la placa (Templates).
-
Polygon Connect – esta restricción especifica el estilo de conexión de un pad de componente o una vía enrutada a un relleno de polígono.
Para obtener más información sobre los valores de restricción, consulte la página Tipos de reglas de planos.
-
Same Net Clearance – esta restricción especifica la separación mínima permitida entre dos objetos primitivos cualesquiera que pertenezcan a la misma red (p. ej., entre una vía y un pad de la misma red, o entre dos segmentos de pista de la misma red).
-
Routing Neck Down – esta restricción especifica la longitud máxima permitida de los trazados continuos cuyo ancho esté entre los valores Min Width y Preferred Width definidos por la restricción de ancho aplicable.
En la vista Electrical se pueden configurar las siguientes restricciones:
-
La pestaña Nets:
-
Topology – esta restricción especifica la topología que se debe emplear al enrutar las redes de la placa. La topología de una red es la disposición o el patrón de las conexiones entre pines.
Para obtener más información sobre los valores de restricción, consulte la página Tipos de reglas de enrutado.
-
Impedance – esta restricción especifica la impedancia mínima y máxima permitida para la red.
-
All Layer Sets – esta restricción especifica qué capas se pueden utilizar para el enrutamiento.
-
Maximum Via Count – esta restricción especifica el número máximo de vías permitido.
-
Min / Max Total Length – esta restricción especifica las longitudes mínima y máxima de una red.
-
Max Stub Length – esta restricción especifica la longitud máxima permitida de los stubs de una red con topología en cadena.
-
Max Via Stub Length – un stub es la longitud del cuerpo metalizado de una vía o un pad que sobresale más allá de la última capa de señal utilizada a la que se conecta la vía o el pad. Se aplicará retrotaladrado a las vías y los pads adecuados de las redes seleccionadas, de acuerdo con las casillas Layer habilitadas para cada lado de la placa y los pares de retrotaladrado definidos en la pestaña Back Drills del Layer Stack Manager.
Para obtener más información sobre los valores de las restricciones, consulte la página Tipos de reglas de alta velocidad.
Para obtener más información sobre el retrotaladrado, consulte la página Taladrado de profundidad controlada (retrotaladrado).
-
-
La pestaña Diff Pairs:
-
Impedance – esta restricción especifica la impedancia mínima y máxima permitida para la red.
-
Gap – esta restricción especifica la separación (o distancia) entre las redes de los pares diferenciales incluidos en su ámbito de aplicación.
-
Width – esta restricción especifica el ancho permitido para las pistas al enrutar el par diferencial.
-
Max Uncoupled Length – esta restricción especifica el valor de la longitud máxima sin acoplamiento permitida entre las redes positiva y negativa del par diferencial.
-
Tolerance – esta restricción especifica una tolerancia de longitud al comparar con la red más larga del par diferencial.
-
Dynamic Phase Tolerance – esta restricción especifica el desfase permitido entre las pistas de un par diferencial, por encima del cual se requiere compensación.
-
Matching Distance – esta restricción especifica la distancia a lo largo de la cual debe aplicarse la compensación tras superar la tolerancia.
-
-
La pestaña xSignals:
-
Tolerance – esta restricción especifica una tolerancia de longitud al comparar cada xSignal de la clase de xSignals con el xSignal seleccionado como Matching Target para la clase.
-
Notas sobre el trabajo con las vistas Physical o Electrical:
-
El Administrador de restricciones define automáticamente las prioridades de las reglas en estas vistas: la prioridad se ordena desde All (la más baja), pasando por la clase de objeto, hasta el objeto (la más alta).
-
Para eliminar los valores de restricción personalizados definidos por una regla específica (es decir, restablecer los valores predeterminados de esta regla), haga clic con el botón derecho en la celda correspondiente de la cuadrícula y seleccione el comando Remove rule en el menú contextual.
-
Para eliminar los valores de restricción personalizados de todas las reglas de un objeto, haga clic con el botón derecho en cualquier celda de la fila de ese objeto en la cuadrícula y seleccione el comando Remove rules from scope en el menú contextual.
-
Todos los nodos, excepto los predefinidos (p. ej., All Nets), están contraídos de forma predeterminada en las vistas Physical y Electrical . Puede utilizar los comandos Expand All y Collapse All del menú contextual para controlar los nodos de la cuadrícula.
-
Cuando se introduce un valor en la cuadrícula superior de la vista Physical para una sola red o xNet (Min Width o Preferred Width), un par diferencial (Min Width, Preferred Width o Preferred Diff Pair Gap) o una clase de redes, xNets o pares diferenciales, este valor se propagará a los campos de ancho (Min Width/Preferred Width/Max Width) o separación (Min Gap/Preferred Gap/Max Gap) correspondientes de las regiones de restricciones situadas debajo. Tenga en cuenta que un valor introducido solo se propagará a otros campos si el objeto no tiene definida la regla específica.
-
Al definir los valores mínimos, máximos y preferidos de los anchos de enrutamiento y las separaciones de los pares diferenciales en la vista Physical, la tabla Values by Layer situada en la parte inferior de la vista resaltará las entradas no válidas con texto rojo. Esto puede ocurrir, por ejemplo, al especificar un valor mínimo de restricción mayor que el valor máximo. La definición incorrecta de la restricción también se resalta al mostrarse en rojo los valores de ancho o separación en la cuadrícula superior de la vista.
Configuración de los valores de restricción por capa
Al acceder al Administrador de restricciones desde el esquema, puede configurar las restricciones de ancho y de enrutamiento de pares diferenciales para las capas de un apilado de capas seleccionado.
En el menú desplegable de la parte superior del Administrador de restricciones, seleccione una entrada correspondiente a un documento PCB específico del proyecto de diseño. Si la PCB seleccionada contiene varios apilados de capas, puede elegir el apilado para el que desea configurar las restricciones mediante las pestañas de la parte inferior del Administrador de restricciones cuando esté seleccionada la regla correspondiente. También puede utilizar un perfil de impedancia seleccionado (si se ha definido como parte del apilado de capas de la PCB seleccionada).
Definición de pares diferenciales
Los pares diferenciales se crean desde la vista Physical o desde la pestaña Diff Pairs de la vista Electrical del Administrador de restricciones. Para que el Administrador de restricciones cree pares diferenciales a partir de redes, las redes que se van a emparejar deben seguir un esquema de nomenclatura coherente (es decir, deben tener una raíz común seguida de un sufijo positivo/negativo coherente, por ejemplo, TX0_P y TX0_N).
Haga clic con el botón derecho en cualquier punto del área de la cuadrícula de la vista Physical o de la pestaña Diff Pairs de la vista Electrical y seleccione el comando Differential Pairs » Create Differential Pairs From Nets en el menú contextual para abrir el cuadro de diálogo Create Differential Pairs From Nets y definir las opciones de creación de pares diferenciales. Los filtros de la parte superior del cuadro de diálogo permiten seleccionar rápidamente estas redes según la clase de red a la que pertenecen y el factor diferenciador utilizado para distinguir las redes positiva y negativa del par que se desea crear, por ejemplo, _P y _N. También puede definir un prefijo que se añadirá a los objetos de par diferencial creados y determinar a qué clase de pares diferenciales se añadirán.
Para cada objeto de par diferencial, el cuadro de diálogo muestra las redes positiva y negativa que lo componen. De forma predeterminada, todos los posibles objetos de par diferencial están seleccionados para su creación; puede excluirlos individualmente desmarcando la casilla Create correspondiente.
Una vez configuradas todas las opciones según sea necesario, haga clic en el botón
: se crearán los objetos de par diferencial y se mostrarán en la vista Physical del Administrador de restricciones, con las redes que los componen enumeradas debajo de sus entradas.
Los pares diferenciales también pueden crearse a partir de xNets. Utilice el menú desplegable de la parte superior del cuadro de diálogo Create Differential Pairs From Nets para seleccionar All xNets o una clase de xNets específica. Una vez configuradas las demás opciones del cuadro de diálogo según sea necesario, haga clic en el botón
para crear los pares diferenciales correspondientes.
Para eliminar un par diferencial, haga clic con el botón derecho en su entrada y seleccione el comando Differential Pairs » Remove Differential Pair del menú contextual. También puede eliminar varios pares diferenciales seleccionando sus entradas mediante la técnica Ctrl+Click, Shift+Click o Click, Hold&Drag, haciendo clic con el botón derecho en la selección y eligiendo el comando Differential Pairs » Remove Differential Pair del menú contextual.
La pestaña Diff Pairs de la vista Electrical también permite gestionar explícitamente los pares diferenciales. En esta pestaña se muestra una lista jerárquica de los pares diferenciales del diseño. Seleccione una celda de un par diferencial o de una clase de pares diferenciales para mostrar sus restricciones en la parte inferior del Constraint Manager.
Definición de xNets
Una ruta desde un componente de origen hasta un componente de destino que pasa por uno o varios componentes en serie puede definirse como una xNet.
En la región xNets Creation de la pestaña Opciones del cuadro de diálogo Opciones del proyecto se pueden definir listas separadas por comas de prefijos de designadores de componentes que pueden utilizarse como componentes de origen o destino (Sources/Destinations) y componentes en serie (Discretes).

La región xNets Creation de la pestaña Options del cuadro de diálogo Project Options

Ejemplo de una ruta que puede definirse como una xNet en el Constraint Manager (según la configuración de creación de xNets mostrada anteriormente)
En la vista Physical o Electrical del Constraint Manager (al acceder desde un esquemático o una PCB), haga clic con el botón derecho en una red que desee incluir en una nueva xNet y seleccione el comando xNets » Create xNets From Selected Nets del menú contextual. Se creará una nueva xNet y se mostrará en las vistas Physical o Electrical del Constraint Manager, con las redes que la componen enumeradas debajo de su entrada.
La generación de xNets también admite componentes en serie con más de dos pines. Se admiten los siguientes componentes en serie:
-
Dual-inline component with an even number of pins – Las xNets pueden generarse a partir de las redes conectadas al primer y al último pin del componente, luego al segundo y al penúltimo, etc.
-
Single-inline component with an even number of pins – Las xNets pueden generarse a partir de las redes conectadas al primer y al segundo pin del componente, luego al tercero y al cuarto, etc. Tenga en cuenta que el componente debe incluir un parámetro llamado
PinPairsConfigurationcon el valorSIP; de lo contrario, las xNets se generarán como en el caso del componente de doble hilera. -
Component with an odd number of pins – Se genera una xNet a partir de las redes conectadas a todos los pines del componente.
Para eliminar una xNet, haga clic con el botón derecho en su entrada y seleccione el comando xNets » Remove xNet del menú contextual. También puede eliminar varias xNets seleccionando sus entradas mediante la técnica Ctrl+Click, Shift+Click o Click, Hold&Drag, haciendo clic con el botón derecho en la selección y eligiendo el comando xNets » Remove xNet del menú contextual.
Definición de xSignals
Desde el Constraint Manager, también puede definir xSignals : rutas de señal definidas por el usuario entre dos nodos de la PCB. En la vista Electrical del Constraint Manager, seleccione la celda de la columna Topology correspondiente a una red o xNet, elija Custom en la lista desplegable de la parte inferior del Constraint Manager y, a continuación, utilice los controles disponibles para definir la topología personalizada y seleccionar las xSignals correspondientes.
A continuación se describe y se muestra un ejemplo de definición de xSignals para la xNet que aparece más abajo.

Ejemplo de una xNet para la que deben crearse xSignals.
Puede definir una topología personalizada mediante el gráfico de topología de la parte inferior del Constraint Manager. Utilice el menú contextual del área del gráfico para añadir y eliminar nodos, cambiar su tipo de Source a Destination y viceversa, y Click, Hold&Drag los nodos para definir la topología.
La lista de xSignals propuestas (denominadas según el esquema <SourceNetName> (<SourcePinDesignator> → <DestinationPinDesignator>)) aparece a la derecha del área de la cuadrícula. La lista se divide en dos grupos: xSignals que van de un origen a un destino (S-T) y xSignals que van de un destino a otro (T-T). Utilice las casillas de verificación de los grupos o de las xSignals individuales para seleccionar o deseleccionar las xSignals que se crearán. Las xSignals seleccionadas aparecerán en la pestaña xSignals de la vista Electrical.
Ejemplo de creación de xSignals mediante el gráfico de topología
Para una clase de xSignals creada (consulte la sección Definición de clases más abajo para obtener más información), se puede definir la restricción Tolerance y seleccionar una xSignal de esta clase como Matching Length. Cuando se accede al Constraint Manager desde la PCB, también están disponibles las columnas Actual Value y Margin.
En el documento PCB, las xSignals definidas se pueden examinar desde el panel PCB en su modo xSignals. También se crearán los From-To correspondientes, que se pueden examinar desde el panel PCB en su modo From-To Editor.
Definición de clases
El Constraint Manager permite definir clases de redes, pares diferenciales, xNets y xSignals.
-
Para añadir objetos de la vista Physical o Electrical del Constraint Manager a una clase existente, seleccione varias entradas de objetos mediante la técnica
Ctrl+Click,Shift+ClickoClick, Hold&Drag; a continuación, haga clic con el botón derecho en la selección y elija la clase deseada en el submenú Classes » Add Selected to Class del menú contextual.Cuando hay más de 30 clases, se muestra el comando Classes » Add Selected to Class » Existing Class en lugar de la lista de clases. Utilice este comando para acceder a un cuadro de diálogo en el que puede seleccionar una clase existente a la que añadir los objetos seleccionados.
-
Para añadir una nueva clase de objetos incluidos en la vista Physical o Electrical del Constraint Manager, selecciónelos; a continuación, haga clic con el botón derecho en la selección y elija el comando Classes » Add Selected to Class » New Class del menú contextual para abrir el cuadro de diálogo Add Class. Defina el Name de la clase (que debe ser único y no estar vacío) y el conjunto de miembros de la clase. Los objetos seleccionados antes de acceder al cuadro de diálogo ya aparecerán en la lista Member. Si es necesario, ajuste el conjunto de miembros de la clase moviendo las entradas de objetos entre las listas Non-Members y Member mediante los botones de flecha.
-
Como alternativa, haga clic con el botón derecho en el área de la cuadrícula y seleccione el comando Classes » Add Class en la vista Clearances o Electrical o un comando de (para añadir una clase de redes) o del submenú Classes » Add Class para acceder al cuadro de diálogo Add Class. Al acceder al cuadro de diálogo de esta manera, las listas Member estarán inicialmente vacías.
-
Para quitar objetos de una clase a la que pertenecen actualmente, selecciónelos; a continuación, haga clic con el botón derecho en la selección y elija el comando Classes » Remove Selected from Class del menú contextual.
-
Para editar una clase, haga clic con el botón derecho en su entrada y seleccione el comando Classes » Edit Class del menú contextual para acceder al cuadro de diálogo Edit Class, donde podrá editar el nombre y los miembros de la clase.
-
Para eliminar una clase existente, haga clic con el botón derecho en su entrada y elija el comando Classes » Remove Class del menú contextual. También puede eliminar varias clases seleccionando sus entradas mediante la técnica
Ctrl+Click,Shift+ClickoClick, Hold&Drag, haciendo clic con el botón derecho en la selección y eligiendo el comando Classes » Remove Class del menú contextual.
Como alternativa, puede utilizar el cuadro de diálogo Object Class Explorer para añadir, editar y eliminar clases. Haga clic con el botón derecho en el área de la cuadrícula y seleccione el comando Classes » Class Explorer del menú contextual para abrir el cuadro de diálogo.
El panel de árbol de carpetas situado a la izquierda del cuadro de diálogo muestra los tipos de clases de objetos admitidos y las clases de objetos existentes de cada tipo.
- Haga clic en la carpeta raíz Object Classes para acceder, en el área principal de edición del cuadro de diálogo, a una lista de resumen de todas las clases específicas que se han definido en todos los tipos de clases de objetos.
- Haga clic en una carpeta secundaria de tipo de clase de objetos para acceder a una lista de resumen de todas las clases específicas que se han definido para ese tipo.
- Haga clic en la entrada de una clase específica (o haga doble clic en su entrada en una lista de resumen) para acceder a los controles que permiten gestionar los objetos que pertenecen a esa clase.
Para añadir una nueva clase definida por el usuario desde el cuadro de diálogo Object Class Explorer, haga clic con el botón derecho dentro de la categoría de la clase que desea crear y elija Add Class en el menú contextual. Para cambiar el nombre de una clase definida por el usuario o eliminarla, haga clic con el botón derecho en su nombre y elija Rename Class o Delete Class, respectivamente.
Conjuntos de restricciones
Para agilizar el proceso de definición de restricciones para los objetos, el Constraint Manager permite guardar un grupo de restricciones como un conjunto de restricciones y, posteriormente, aplicarlo a los objetos.
Para guardar las restricciones definidas actualmente para un objeto como un conjunto de restricciones, haga clic con el botón derecho en una celda de este objeto y seleccione el comando Save as Constraint Set del menú contextual. En la ventana emergente New Constraint Set, introduzca el nombre deseado para el conjunto de restricciones (que debe ser único y no estar vacío) y haga clic en Create.
El conjunto de restricciones recién creado se aplicará al objeto a partir del cual se haya creado. Para aplicar un conjunto de restricciones a otro objeto, haga clic con el botón derecho en su celda y seleccione el conjunto de restricciones deseado en el submenú Select Constraint Set del menú contextual. Las celdas a las que se aplica un conjunto de restricciones se distinguen por un símbolo en la esquina superior izquierda (por ejemplo, y, en las vistas Physical o Electrical, el nombre del conjunto de restricciones aplicado se mostrará en la columna Constraint Set.
Para editar los valores de un conjunto de restricciones existente, seleccione un objeto al que se aplique este conjunto de restricciones y haga clic en
botón. Cambie los valores de las restricciones según sea necesario y, a continuación, haga clic en el botón Save de la ventana emergente que aparece para guardar los cambios. Los cambios se aplicarán a todos los objetos que tengan seleccionado actualmente ese conjunto de restricciones.
Los conjuntos de restricciones definidos actualmente se muestran en la región Constraint Sets del panel Properties. Haga clic en la entrada de un conjunto de restricciones para mostrar sus valores de restricción. Para eliminar un conjunto de restricciones seleccionado en el panel Properties, haga clic en el botón
situado en la parte inferior de la región Constraint Sets. Los objetos que tuvieran seleccionado el conjunto de restricciones eliminado conservarán los valores de restricción que este les había aplicado antes de su eliminación.
Importación de directivas desde esquemáticos
Puede importar al Administrador de restricciones clases de redes y de pares diferenciales, pares diferenciales y restricciones desde las directivas de diseño de conjunto de parámetros y de par diferencial colocadas y definidas en los documentos fuente del esquemático. Para ello, haga clic en el botón
al acceder al Administrador de restricciones desde el esquemático. El cuadro de diálogo Refresh Constraint Manager mostrará un resumen de la importación desde el esquemático al Administrador de restricciones, que se completará al hacer clic en el botón
del cuadro de diálogo.
Se indica el estado de sincronización entre una restricción del Administrador de restricciones y su equivalente definida en una directiva colocada en un esquemático.
-
Cuando un objeto del esquemático tiene una directiva de conjunto de parámetros o de par diferencial colocada sobre él, y esta directiva contiene valores de restricción distintos de los definidos para el mismo objeto en el Administrador de restricciones, estos valores se marcarán con una barra naranja en el lado izquierdo de la celda correspondiente de la vista Physical o Electrical del Administrador de restricciones al acceder a este desde un esquemático (p. ej.,
-
Cuando los valores de la restricción están sincronizados entre el Administrador de restricciones y la directiva, la indicación cambia a una barra verde (p. ej.,
También se indica el estado de sincronización de las clases de redes, los pares diferenciales y las clases de pares diferenciales importados desde directivas. Se detectan los cambios (elementos nuevos o eliminados), y las incoherencias que requieren sincronización se indican mediante una barra naranja a la izquierda del nombre del objeto correspondiente (p. ej., El estado sincronizado se indica mediante una barra verde (p. ej.,
Notas sobre la importación de directivas al Administrador de restricciones:
-
Las restricciones ya definidas para redes, clases de redes, pares diferenciales o clases de pares diferenciales mediante el Administrador de restricciones tendrán prioridad y se conservarán al procesar una importación. Por lo tanto, si un valor de restricción que se ha sincronizado con una directiva se edita en el Administrador de restricciones después de la importación, no se sincronizará al volver a importar posteriormente.
-
Después de sincronizar los datos mediante la importación desde las directivas al Administrador de restricciones y guardar los cambios en este:
-
Las directivas importadas se distinguen en el espacio de diseño por su color azul y por utilizar un símbolo ligeramente diferente
-
Las entradas de clases y reglas importadas al Administrador de restricciones se pueden ocultar mediante el botón Constraint Manager situado en la parte superior de la región Parameters del panel Properties.
-
En el caso de una directiva de conjunto de parámetros asociada a un único hilo, los datos asociados del Administrador de restricciones (nombre de la clase de redes o de pares diferenciales y ajustes de las reglas) pueden mostrarse junto a esa directiva en la hoja del esquemático. Para una directiva de conjunto de parámetros que incluya clases de redes definidas y esté asociada a una cobertura, tras la sincronización o importación con el Administrador de restricciones, también es posible activar o desactivar la visualización de la información de la directiva de clase de redes en el espacio de diseño. Para una directiva de par diferencial asociada a una cobertura, es posible activar o desactivar la visualización de la información de la clase de pares diferenciales y de las reglas asociadas en el espacio de diseño después de sincronizar o importar las directivas al Administrador de restricciones. Utilice el control de visibilidad situado a la izquierda de la entrada de datos correspondiente en el panel Properties cuando la directiva esté seleccionada.
-
Los controles para añadir una nueva clase de redes, de pares diferenciales o de componentes, o para eliminar una existente, aparecerán atenuados en el panel Properties para las directivas correspondientes.
-
Los controles para añadir una nueva regla o editar o eliminar una existente seguirán estando disponibles en el panel Properties para las directivas correspondientes. También puede editar el nombre de una clase de redes. Para aplicar a los datos del Administrador de restricciones los cambios realizados en las reglas o en el nombre de la clase de redes de una directiva ya importada, haga clic en el botón
al acceder al Administrador de restricciones desde el esquemático.
-
-
Las reglas añadidas a una directiva de conjunto de parámetros que no se muestren en las vistas Physical y Electrical se crearán automáticamente como reglas avanzadas y se mostrarán en la vista Todas las reglas al acceder al Administrador de restricciones desde la PCB. Las reglas avanzadas se crean al completar la importación de directivas y la ECO posterior del esquemático a la PCB.
-
Para permitir la importación al Administrador de restricciones de las clases de redes definidas mediante directivas, debe habilitarse la opción Generate Net Classes en la pestaña Generación de clases del cuadro de diálogo Opciones del proyecto. Tenga en cuenta que, si se importaron clases de redes al Administrador de restricciones y después se deshabilitó la opción Generate Net Classes, una importación posterior al Administrador de restricciones propondrá eliminar las clases de redes importadas.
Modificación de directivas importadas de documentos de solo lectura
Las directivas que se han importado de documentos de solo lectura (por ejemplo, hojas de dispositivo y hojas gestionadas) no se pueden modificar si la opción Make Device Sheets In Projects Read-Only está habilitada (marcada) en la página Gestión de datos - Hojas de dispositivo del cuadro de diálogo Preferences.
Cuando la opción está deshabilitada (desmarcada), las directivas se pueden modificar. Una vez importadas las directivas (con la opción habilitada), la regla se resalta en azul en el Administrador de restricciones.
Importación y exportación de restricciones y conjuntos de restricciones
Puede importar y exportar restricciones y conjuntos de restricciones entre diseños. Para acceder a esta función, haga clic con el botón derecho en la vista Clearances, Physical, o Electrical del Administrador de restricciones y, a continuación, seleccione Import o Export.
Tras seleccionar Import, se abre el cuadro de diálogo estándar File Explorer, en el que puede seleccionar la restricción o el conjunto de restricciones deseado (*.CstrDot ) para importarlo a su diseño. Se abre el cuadro de diálogo Constraints to Import, en el que puede seleccionar las restricciones o los conjuntos de restricciones que desea importar al diseño actual. Las restricciones o los conjuntos de restricciones seleccionados se aplicarán a los objetos correspondientes del diseño de destino.
Exporting Constraints and Constraint Sets
Tras seleccionar una o varias celdas en la vista Clearances o una o varias filas en la vista Physical o Electrical y, a continuación, elegir Export, se abre el cuadro de diálogo Constraints to Export con las restricciones y los conjuntos de restricciones de todos los objetos seleccionados antes de elegir el comando, enumerados en la cuadrícula. Seleccione las restricciones o los conjuntos de restricciones que desea exportar mediante las casillas de verificación (las restricciones relacionadas con la vista actual estarán seleccionadas de forma predeterminada en el cuadro de diálogo). Tras hacer clic en el botón Export items, se abre el cuadro de diálogo estándar File Explorer, en el que puede asignar un nombre y guardar las restricciones o los conjuntos de restricciones. El archivo se exportará con la extensión *.CstrDot y, posteriormente, podrá importarse a otro diseño.
Trabajo con todas las reglas en el lado de la PCB
Cuando se accede al Administrador de restricciones desde el editor de PCB, está disponible la vista All Rules, que contiene una lista de todas las reglas del diseño de PCB. Desde aquí, puede crear reglas avanzadas que incluyan expresiones de consulta más complejas en su ámbito de coincidencia.
Creación de una nueva regla avanzada
Para crear una nueva regla avanzada en la vista All Rules del Administrador de restricciones, seleccione Add Advanced Rule en el menú contextual que aparece al hacer clic con el botón derecho (o utilice el botón
de la parte inferior del Administrador de restricciones cuando no haya ninguna regla seleccionada en el área de la cuadrícula) y, a continuación, introduzca un ámbito de coincidencia basado en consultas y los parámetros de restricción en la cuadrícula de columnas o en la representación gráfica inferior.
Gestión de la biblioteca de ámbitos
Para simplificar el proceso repetitivo de creación de reglas avanzadas, Constraints Manager permite almacenar ámbitos de coincidencia de objetos basados en consultas en la biblioteca de ámbitos. La biblioteca se gestiona mediante Scopes Library cuadro de diálogo al que se accede haciendo clic en el botón Edit Library de la región Scopes Library del panel Properties . La biblioteca se presenta en el panel Properties, donde los ámbitos personalizados se pueden importar y exportar como un archivo XML, que luego se puede utilizar para completar la biblioteca de ámbitos de otra instalación de Altium Designer.
Para exportar un ámbito a la biblioteca o importarlo desde ella, utilice los comandos del menú del botón
situado junto al campo Object Match / Second Object Match en la parte inferior del Administrador de restricciones. Una vez que se haya aplicado a una regla un ámbito basado en la biblioteca, el nombre del ámbito se mostrará en la columna Object Match / Second Object Match del área de cuadrícula y encima del campo Object Match / Second Object Match. Puede utilizar el menú
del campo para devolver el ámbito a su formato basado en consultas (Detach Scope).
Activar/desactivar reglas
Puede activar/desactivar las reglas básicas y avanzadas que aparecen en la vista All Rules. La columna Enabled refleja el estado de una regla: True (activada) o False (desactivada). Haga doble clic en una celda de la columna para cambiar el estado de una regla específica. Las celdas correspondientes a reglas básicas desactivadas se etiquetan como (Disabled) y aparecen atenuadas en las vistas Physical y Electrical.
El estado de activación de las reglas avanzadas de un tipo o una categoría determinados, o de todas las reglas avanzadas, también se puede cambiar mediante los comandos disponibles en el menú contextual que se abre al hacer clic con el botón derecho en la entrada correspondiente del árbol Rule Class.
|
Haga clic con el botón derecho en una entrada de tipo de regla del árbol Rule Class para activar/desactivar las reglas avanzadas de este tipo. Haga clic con el botón derecho en una entrada de categoría de reglas del árbol Rule Class para activar/desactivar las reglas avanzadas de esta categoría. Haga clic con el botón derecho en el encabezado Rule Class para activar/desactivar todas las reglas avanzadas. |
Importar y exportar reglas
Desde la vista All Rules, puede importar y exportar reglas (avanzadas y/o básicas).
Para exportar, seleccione varias reglas de la lista utilizando Ctrl+Click, Shift+Click o Click, Hold&Drag; a continuación, haga clic con el botón derecho y seleccione el comando Export Selected Rules (x) (x representa el número de reglas seleccionadas). También puede exportar reglas mediante los comandos disponibles en el menú contextual que se abre al hacer clic con el botón derecho en la entrada correspondiente del árbol Rule Class:
-
Haga clic con el botón derecho en una entrada de tipo de regla del árbol y seleccione el comando Export <RuleType> Rules para exportar las reglas de este tipo.
-
Haga clic con el botón derecho en una entrada de categoría de reglas del árbol y seleccione el comando Export <RuleCategory> Rules para exportar las reglas de esta categoría.
-
Haga clic con el botón derecho en el encabezado Rule Class del árbol y seleccione el comando Export All Rules para exportar todas las reglas.
Tras elegir un comando Export, se abre el cuadro de diálogo Constraints to Export, en el que puede seleccionar qué regla exportar a un archivo *.CstrDot que se podrá importar posteriormente en otro proyecto. Después de hacer clic en el botón Export x Items (x representa el número de elementos seleccionados en el cuadro de diálogo), se abre el cuadro de diálogo estándar File Explorer, en el que puede definir el nombre y la ubicación del archivo. Las reglas se exportarán a un archivo *.CstrDot que se podrá importar posteriormente en otro diseño.
|
Haga clic con el botón derecho en una o varias reglas seleccionadas para exportarlas. Haga clic con el botón derecho en una entrada de tipo de regla del árbol Rule Class para exportar las reglas de este tipo. Haga clic con el botón derecho en una entrada de categoría de reglas del árbol Rule Class para exportar las reglas de esta categoría. Haga clic con el botón derecho en el encabezado Rule Class para exportar todas las reglas. |
Para importar, haga clic con el botón derecho en el área de la lista o en el árbol Rule Class de la vista All Rules y seleccione el comando Import Rules. Se abre la ventana estándar File Explorer, en la que debe seleccionar el archivo *.CstrDot deseado; a continuación, haga clic en Open. Se abre el cuadro de diálogo Constraints to Import, en el que puede seleccionar las reglas que desea importar al diseño actual. Al importarlas, los ámbitos personalizados asociados se aplican automáticamente.
Eliminar reglas avanzadas
Para eliminar la regla avanzada seleccionada actualmente, haga clic con el botón derecho en ella y seleccione Remove Advanced Rule. Para eliminar varias reglas avanzadas a la vez, seleccione varias reglas utilizando Ctrl+Click, Shift+Click o Click, Hold&Drag; a continuación, haga clic con el botón derecho y seleccione Remove Advance Rules (x). 'x' representa el número de reglas que se eliminarán. También puede eliminar todas las reglas avanzadas de un tipo o una categoría determinados, o todas las reglas avanzadas, mediante los comandos disponibles en el menú contextual que se abre al hacer clic con el botón derecho en la entrada correspondiente del árbol Rule Class.
|
Haga clic con el botón derecho en varias reglas seleccionadas para eliminarlas. Haga clic con el botón derecho en una entrada de tipo de regla del árbol Rule Class para eliminar las reglas avanzadas de este tipo. Haga clic con el botón derecho en una entrada de categoría de reglas del árbol Rule Class para eliminar las reglas avanzadas de esta categoría. Haga clic con el botón derecho en el encabezado Rule Class para eliminar todas las reglas avanzadas. |
En todos los casos, las reglas se eliminarán inmediatamente sin solicitar confirmación.
Localización cruzada
El Administrador de restricciones incluye una función de localización cruzada que muestra los objetos asociados resaltándolos visualmente en el documento correspondiente. Para localizar cualquier objeto mediante esta función, haga clic con el botón derecho en su entrada y, a continuación, elija la opción Cross Probe del menú contextual o seleccione Cross Probe en el menú
de una regla avanzada.
Ajuste Cross Probe View Settings en el panel Properties para configurar la localización cruzada.
Utilice la opción Clear Filter del editor de esquemas/PCB (haga clic con el botón derecho en el espacio de diseño y seleccione Clear Filter, atajo: Shift+C) para restablecer el resaltado de la localización cruzada.
Consulte la página Localización y selección cruzadas para obtener más información sobre la localización cruzada en Altium Designer.
Selección cruzada
La función de selección cruzada facilita la selección dinámica y bidireccional de objetos. Cuando el modo de selección cruzada está activado (mediante Cross Select Mode del menú principal Tools del Gestor de restricciones, del editor de esquemas o del editor de PCB), los objetos seleccionados en el Gestor de restricciones también se seleccionan en los documentos de esquemas y PCB, y viceversa.
Consulte la página Sondeo y selección cruzados para obtener más información sobre la selección cruzada en Altium Designer.
Transferencia de restricciones entre el esquema y la PCB
Los cambios aplicados en el Gestor de restricciones se transfieren entre los diseños de esquemas y PCB mediante el proceso de orden de cambio de ingeniería (ECO). Seleccione un comando para actualizar las restricciones en el otro lado.
-
Para transferir los cambios del esquema a la PCB – seleccione el comando Design » Update PCB Document <PCBDocumentName> en los menús principales del editor de esquemas.
-
Para transferir los cambios (realizados en las vistas Clearances, Physical y/o Electrical del Gestor de restricciones) de la PCB al esquema – seleccione el comando Design » Update Schematics in <PCBProjectName> en los menús principales del editor de PCB.
Utilice el cuadro de diálogo Engineering Change Order que aparece a continuación para explorar, validar y ejecutar los cambios.
Consulte la página Mantener sincronizados los esquemas y la PCB para obtener más información.
Migración de las reglas de diseño al Gestor de restricciones
Si un proyecto de PCB utiliza el sistema antiguo de gestión de reglas (es decir, el cuadro de diálogo PCB Rules and Constraints Editor), puede realizar una migración única y unidireccional al Gestor de restricciones.
Utilice el comando Design » Migrate Project to Constraint Manager Flow de los menús principales de los editores de PCB y de esquemas. Se abrirá el cuadro de diálogo Migration Required para advertir de que se realizará la migración y de que no se podrá deshacer después de hacer clic en el botón
.
Tanto las reglas de diseño de PCB como las directivas de los esquemas se transferirán a las restricciones correspondientes aplicables dentro del Gestor de restricciones. Una vez que la migración haya finalizado correctamente, se abrirá el Gestor de restricciones (en el contexto del editor que estuviera activo cuando se realizó la migración).
).



).
).
).

).
).
).






)
)
)








).
).





).

).










).
).
).