Trabajar con Rooms en una PCB
De un vistazo
- Aprenderás qué es una región en una PCB y cómo se utiliza para controlar la colocación de objetos y los requisitos de diseño dentro de un área definida de la placa.
- Conocerás los principales métodos para crear regiones en el editor de PCB, incluida la colocación interactiva, la creación a partir de componentes seleccionados y la creación mediante restricciones de diseño.
- Comprenderás cómo funcionan conjuntamente los objetos de región y las restricciones de definición de región en Altium Designer, y cómo se aplica esto en el editor de reglas y restricciones de PCB y en el administrador de restricciones.
Resumen
Una sala es un área definida en una de las capas superficiales de la PCB. Se utiliza para definir requisitos de diseño dentro de esa área de la placa, como: these components must be in this area, o route these nets this width, o use routing vias of this size.
Una sala se coloca como otros objetos poligonales, ya sea con forma rectangular o poligonal.
Además de existir como una forma X-Y con nombre en la placa, cada sala se convierte automáticamente en una restricción de diseño de definición de sala con nombre Los ajustes de la restricción de definición de sala determinan: los objects a los que se aplica la sala, si esos objetos deben mantenerse inside or outside de la sala y la layer en la que se aplica la sala.
Además del sencillo requisito de keep these objects in (or out) que especifica directamente la restricción de definición de sala, la sala también puede utilizarse para definir un área de la placa en la que se aplican otras restricciones de diseño. Por ejemplo, el enrutado bajo un BGA puede necesitar un ancho específico , o el enrutado de pares diferenciales bajo un BGA puede requerir que se aplique un perfil de impedancia específico
Disponibilidad
Las salas solo pueden colocarse o crearse en el editor de PCB. Utilice los siguientes métodos para crear salas:
-
Seleccione el comando necesario en el submenú Design » Rooms y, a continuación, defina de forma interactiva la forma de la sala (si ha seleccionado un comando Place) o cree la sala automáticamente (si ha seleccionado un comando Create).
-
Añada una nueva restricción de diseño Room Definition, edite la nueva restricción de sala y, a continuación, haga clic en el botón Define para definir de forma interactiva la forma de la sala poligonal.
-
Cree una sala a partir de un contorno cerrado (seleccionado) formado por un conjunto de pistas o arcos, mediante el comando Tools » Convert » Create Room from Selected Primitives.
-
Cree salas automáticamente durante la sincronización del diseño entre el esquema y la PCB. Obtenga más información sobre las salas generadas automáticamente (incluido cómo desactivarlas).
Creación de una sala
El procedimiento utilizado para crear una sala en el documento de PCB depende de si está colocando o creando la sala de forma interactiva y del método concreto de colocación o creación que haya elegido.
Existen distintas técnicas para colocar o crear una sala.
Colocación interactiva de salas
Se pueden colocar salas rectangulares o poligonales en las capas superior o inferior del diseño. Tenga en cuenta que, aunque pueden colocarse con cualquier capa activa, la capa a la que se aplican se asigna como parte de la restricción de diseño de definición de sala.
Sala rectangular
Tras ejecutar el comando Design » Rooms » Place Rectangular Room, el cursor cambiará a una cruz y se activará el modo de colocación de salas. La colocación se realiza mediante la siguiente secuencia de acciones:
-
Haga clic o pulse Enter para fijar la primera esquina de la sala.
-
Para editar sobre la marcha las propiedades de la restricción de definición de sala asociada, pulse la tecla Tab durante la colocación.
-
Mueva el cursor para ajustar el tamaño de la sala y, a continuación, haga clic o pulse Enter para fijar la esquina diagonalmente opuesta y completar la colocación de la sala.
-
Continúe colocando más salas o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Sala poligonal
Tras ejecutar el comando Design » Rooms » Place Polygonal Room, el cursor cambiará a una cruz y se activará el modo de colocación de salas. La colocación se realiza mediante la siguiente secuencia de acciones:
-
Sitúe el cursor y haga clic para fijar el punto inicial de la sala.
-
Sitúe el cursor y haga clic para fijar una serie de vértices que definan la forma poligonal de la sala.
-
Después de colocar el último vértice, haga clic con el botón derecho o pulse Esc para completar la colocación de la sala. No es necesario cerrar el polígono, ya que el software completará automáticamente la forma conectando el punto inicial con el último punto colocado.
-
Continúe colocando más salas poligonales o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
A partir de componentes seleccionados
Si los componentes ya están situados en la placa y desea crear una nueva sala que se ajuste a su colocación, utilice uno de los tres comandos Create xxx Room from selected components. Estos comandos permiten crear automáticamente salas no ortogonales, ortogonales y rectangulares a partir de los componentes seleccionados en el espacio de diseño. En todos los casos, el método de creación es el mismo:
-
Seleccione todos los componentes para los que desee crear la sala. Para seleccionar los componentes de la PCB desde el esquema, ejecute el comando Tools » Cross Select Mode y, a continuación, seleccione los componentes en el esquema.
-
En el editor de PCB, ejecute el comando de creación correspondiente (Design » Rooms » Create xxx Room from selected components). Se creará automáticamente una clase de componentes que incluya los componentes seleccionados (a menos que ya exista una).
-
A continuación, se crea el tipo de recinto elegido y la regla de diseño de definición de recinto se asocia automáticamente con la clase de componentes creada.
-
El recinto se dimensionará para dar cabida a todos los componentes de la selección, en función de los rectángulos de selección de los componentes.
-
Si hace clic y arrastra para mover ese recinto, también se moverán todos los componentes de la clase de componentes asociada.
Se crea un recinto ortogonal a partir de los componentes de la PCB seleccionados previamente en el esquema.
Mediante la adición de una restricción de diseño de definición de recinto
También se puede crear un nuevo recinto definiendo una nueva restricción en PCB Rule and Constraints Editor o en Constraint Manager.
¿Qué enfoque se utiliza para definir las restricciones de diseño?
Altium Designer admite dos enfoques distintos para definir las restricciones de diseño: el Administrador de restricciones y el Editor de reglas y restricciones de PCB.
El PCB Rule and Constraints Editor fue la primera interfaz desarrollada para definir restricciones en el editor de PCB. Si se utiliza el PCB Rule and Constraints Editor, el diseñador define: what objects the constraint (rule) applies to y how those objects are to be constrained. Este enfoque es potente porque permite al diseñador especificar con precisión los objetos a los que desea aplicar restricciones; puede abarcarlo todo (por ejemplo, todas las redes) o centrarse en un objeto específico de la placa (ese pad). Este método flexible para seleccionar los objetos de diseño se basa en un motor de reglas que utiliza un lenguaje de consultas.
El Constraint Manager aporta un enfoque centrado en los objetos a la tarea de definir las restricciones. El diseñador trabaja desde la perspectiva de los objetos, aplicando las distintas restricciones eléctricas y físicas necesarias para el diseño en una interfaz similar a una hoja de cálculo; los objetos se resaltan en el editor gráfico a medida que se seleccionan en el Constraint Manager. Esto permite al diseñador configurar y examinar fácilmente todos los requisitos de un objeto, por ejemplo: esta clase de redes debe enrutarse con este ancho, con esta separación, utilizando esta vía de enrutamiento y este estilo de conexión a polígonos. También podría requerir que esa clase de redes se enrute en estas capas, con estas impedancias. Esta vista centrada en los objetos no es posible en el PCB Rule and Constraints Editor. En última instancia, el software convierte las restricciones centradas en los objetos al mismo formato de reglas que se define en el PCB Rule and Constraints Editor; cambie a la vista All Rules cuando haya abierto las restricciones desde el editor de PCB para verlas.
Esta página de documentación muestra imágenes de las restricciones tal como se definen tanto en el cuadro de diálogo PCB Rule and Constraints Editor como en el Constraint Manager. Tenga en cuenta que los términos constraint y rule se utilizan indistintamente.
Adición de una nueva restricción de diseño de definición de recinto
En el Editor de reglas y restricciones de PCB
Por cada recinto que se coloca o crea, se crea automáticamente una restricción de diseño de definición de recinto asociada. También sucede a la inversa: si añade una nueva regla de este tipo, el objeto de recinto correspondiente aparecerá en el espacio de diseño. Tenga en cuenta que esto también se aplica a la eliminación: si elimina un recinto en el editor gráfico, la restricción se elimina automáticamente; si elimina la restricción de diseño, se elimina el objeto gráfico.
Si la restricción de recinto se define desde el PCB Rules and Constraint Editor, se crea un objeto de recinto predeterminado de 5 por 5 pulgadas, a 1 pulgada del origen absoluto (la esquina inferior izquierda del espacio de edición). Tenga en cuenta que el marcador de origen muestra el origen relativo definido por el usuario, que puede establecerse en cualquier lugar del espacio de edición.
Cuando se añade una nueva restricción de recinto, se define un recinto predeterminado en el espacio de edición.
Una vez añadida la restricción, puede volver al espacio de edición y editar gráficamente el recinto. Como alternativa, cuando esté en el PCB Rules and Constraints Editor, puede editar la restricción de recinto y, a continuación, hacer clic en el botón Define para definir la forma de manera interactiva. Dado que un recinto define un área de la placa, lo más habitual es colocar el recinto de manera interactiva y dejar que la restricción de diseño se cree automáticamente.
Obtenga más información sobre cómo añadir una nueva restricción en el Editor de reglas y restricciones de PCB.
En el Administrador de restricciones
Para crear una nueva restricción de confinamiento (recinto) en el Constraint Manager:, cambie a la vista All Rules, seleccione Room Definition en la categoría Placement y, a continuación, haga clic con el botón derecho en la lista de reglas avanzadas y seleccione Add Advanced Rule en el menú contextual, como se muestra a continuación.
Se puede añadir una nueva restricción de recinto en el Administrador de restricciones.
En este punto, el objeto de recinto aún no existe en el espacio de edición gráfico; ahora debe hacer clic en el botón Define (lo que le llevará al editor de PCB) y definir la forma del recinto. Una vez hecho esto, existirán tanto la restricción de recinto como el objeto de recinto, y se podrán guardar las restricciones.
-
Si la restricción de recinto se va a utilizar para obligar a que los objetos estén dentro (o fuera) de esa área de la placa, el siguiente paso es configurar el Object Match y los demás ajustes de la restricción en la parte inferior del Constraint Manager. Siga leyendo para obtener más información al respecto.
-
Si la restricción de recinto se va a utilizar como definición de área en otro tipo de restricción, como el ancho de enrutamiento, consulte la sección Definición de restricciones dentro de un recinto para obtener más información.
Obtenga más información sobre cómo añadir una nueva restricción en el Administrador de restricciones.
¿Qué es una restricción de recinto?
Como se indicó anteriormente, un recinto es un área definida en una de las capas superficiales de la PCB que se utiliza para definir requisitos de diseño dentro de esa área de la placa.
Todas las restricciones de diseño tienen dos elementos clave:
-
what objects this constraint applies to y
-
how those objects are to be constrained
Si la restricción de recinto se define en un área de la placa donde no hay componentes, el criterio Object Match (the objects this constraint applies to) toma de forma predeterminada el valor False, lo que significa que esta restricción no se aplica a ningún objeto. Edítelo según sea necesario.
La definición de recinto recién creada. Tenga en cuenta que el alcance de la regla es Falso, lo que significa que no se aplica a ningún objeto.
Restricción de una clase de componentes
Una forma habitual de utilizar una restricción de región es definir la ubicación de una clase de componentes, fijando esa clase de componentes a un área específica de la placa.
La clase de componentes Encoder está restringida a la región denominada Room-Encoder, en la capa superior de la placa.
La imagen anterior muestra cómo la clase de componentes Encoder está restringida within la región Room-Encoder, en la Top side de la placa en el PCB Rules and Constraints Editor (básicamente igual que en el Constraint Manager Una vez que se han asignado componentes a una región, estos se desplazan al mover la región. Para mover una región sin desplazar los componentes, desactive temporalmente la regla Room Definition asociada.
Obtenga más información sobre la restricción de diseño Room Definition.
El editor de PCB incluye varias herramientas potentes para trabajar con regiones; consulte más información en la sección Trabajo con regiones de esta página.
Además de ser una restricción de diseño por sí misma (Room Definition), una región también puede utilizarse como objeto para limitar el ámbito de otra restricción de diseño a un área de la placa, como el ancho, la separación o el estilo de vía. Este tema se trata en la sección Definición de restricciones dentro de una región de esta página.
Creación durante la sincronización del diseño del esquema con la PCB
Al transferir el diseño del esquema a la PCB, tiene la opción de crear una región que contenga los componentes de cada hoja de esquema. En un diseño jerárquico de varios niveles, esto puede resultar poco útil, pero en un diseño plano de gran tamaño, disponer de una región para cada hoja puede ser útil a la hora de colocar los componentes en la placa.
La pestaña Class Generation del cuadro de diálogo Project Options incluye opciones para generar regiones para cada hoja del diseño Si la opción Generate Rooms está marcada, se creará una región para esa hoja y se asignará a esa región una clase que contenga todos los componentes de la hoja cuando se ejecute el comando Design » Update. Tenga en cuenta que los componentes de cada hoja se añaden a una clase de componentes, por lo que la opción Generate Rooms requiere que también esté habilitada la opción Component Class correspondiente.
En la PCB, cada restricción de región se crea con el ámbito InComponentClass('<SheetSymbolDesignator>'). No se creará ninguna región si la hoja no contiene componentes. Cuando el esquema se transfiere inicialmente a la PCB, los componentes de cada clase de componentes se disponen en una fila y, a continuación, se crea una región alrededor de esa clase de componentes, como se muestra en la imagen siguiente.
Desmarque las casillas Generate Rooms del cuadro de diálogo Project Options si no necesita regiones generadas automáticamente.
La PCB tras la sincronización inicial del diseño: se ha creado una región para cada hoja, con la clase de componentes de esa hoja asignada a ella.
Obtenga más información sobre la generación automática de regiones, clases de componentes y clases de redes a partir del proyecto de esquemas.
Para obtener más información sobre la sincronización del diseño, consulte la página Mantener sincronizados los esquemas y la PCB .
A partir de pistas y arcos seleccionados
Se puede definir un objeto de región mediante un contorno cerrado formado por objetos de pista y/o arco seleccionados. Para ello, seleccione todas las primitivas de pista y arco que componen el contorno cerrado en el espacio de diseño y elija el comando Tools » Convert » Create Room from Selected Primitives en los menús principales. La presentación de diapositivas siguiente muestra los pasos necesarios.
|
Se han colocado pistas en una capa mecánica para definir el espacio de la placa disponible para los componentes Encoder. Ejecute el comando Tools » Convert » Create Room from Selected Primitives para crear una restricción Room Definition con la misma forma. Aparece el cuadro de diálogo Edit Room Definition para definir los parámetros de la restricción. Se está asignando la clase de componentes Para ajustar la forma de la región, haga clic para seleccionarla y, a continuación, ejecute el comando Design » Rooms » Edit Polygonal Verticies, y haga clic en un vértice o un borde para modificar la forma de la región. |
Edición de una región
La forma X-Y de la región y su ubicación en la placa pueden modificarse de forma interactiva. Tenga en cuenta que existen dos procesos diferentes para editar una región de forma interactiva: a partir de su rectángulo de selección (descrito en la sección Cambio del tamaño y la ubicación) o a partir de sus vértices de edición de forma (descrito en la sección Cambio de la forma).
Además de acceder a los comandos mediante el submenú Design » Rooms, también puede acceder a comandos de región específicos del contexto haciendo clic con el botón derecho en una región colocada y seleccionando el submenú Room Actions.
Haga clic con el botón derecho en una región para acceder a los comandos específicos de las regiones.
Cambio del tamaño y la ubicación
Al hacer clic una vez en una región para seleccionarla, aparecen los siguientes controles de edición, independientemente de si la región se colocó originalmente como rectangular o poligonal:
Los controles de edición aparecen al hacer clic para seleccionar una sala.
Cambiar el tamaño de la sala
-
Al arrastrar los controles de las esquinas (A), se cambia el tamaño de la sala horizontal y verticalmente a la vez.
-
Al arrastrar un control de borde (B), se cambia el tamaño del objeto en esa dirección (horizontal o vertical).
-
La sala se puede girar o voltear mientras se arrastra pulsando:
-
Spacebar para girar el objeto en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. El giro se realiza de acuerdo con el valor del incremento de rotación definido en la página PCB Editor - General del cuadro de diálogo Preferences.
-
X o Y para voltear el objeto respecto al eje X o al eje Y.
-
L para voltear el objeto al otro lado de la placa. Si la sala tiene componentes asociados, estos se voltearán junto con ella.
-
Mover una sala
Haga clic en una sala y arrástrela para moverla a una nueva ubicación. También puede mover un objeto de sala mediante el comando Design » Rooms » Move Room de los menús principales o el comando Room Actions » Move Room del menú contextual de la sala. Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de movimiento de salas; haga clic en la sala para moverla.
Al hacer clic en una sala para moverla:
-
La sala quedará unida al cursor. El punto por el que se sujeta la sala depende de la configuración actual de Object Snap Options , y el cursor se ajustará al punto de ajuste habilitado más cercano (pad de componente, referencia de componente o vértice de la sala).
-
Mueva la sala a la posición deseada y, a continuación, haga clic o pulse Enter para colocarla.
-
Continúe moviendo otras salas o haga clic con el botón derecho o pulse Esc para salir.
-
Si hay componentes en la sala que se está moviendo, puede mostrar guías dinámicas de alineación de color verde durante el movimiento pulsando las teclas Shift o Ctrl. Utilice Shift para mantener el ajuste a la rejilla activa; utilice Ctrl para desactivar temporalmente la rejilla y alinearse con un objeto existente situado fuera de ella.
-
Si la sala contiene objetos sin red y/o bloqueados, se abrirá el cuadro de diálogo Room containing No Net/Locked Objects. Utilice este cuadro de diálogo para determinar si estos objetos deben moverse junto con la sala y, a continuación, haga clic en OK. Para que aparezca este cuadro de diálogo, la opción Ask when moving rooms containing No Net/Locked Objects debe estar habilitada en la página PCB Editor - General del cuadro de diálogo Preferences

El cuadro de diálogo Room containing No Net / Locked Objects
Cuadro de diálogo Sala con objetos sin red/bloqueados |
|
| No Net Objects | Active esta opción para mover los objetos sin red junto con la sala. |
| Locked Objects | Active esta opción para mover los objetos bloqueados junto con la sala. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | Active esta opción para guardar los ajustes seleccionados y seguir utilizándolos durante el resto de la sesión de PCB. El cuadro de diálogo no volverá a abrirse hasta que se inicie una nueva sesión. |
Cambiar la forma
La forma del contorno de una sala se modifica ejecutando el comando Edit Polygonal Room Vertices. Se accede a este comando desde el submenú Design » Rooms o desde el submenú contextual Room Actions que aparece al hacer clic con el botón derecho.
Al ejecutar el comando, se muestran los controles de edición del contorno de la forma poligonal de la sala; a continuación, puede:
-
Hacer clic en un control A y mover el cursor para desplazar ese vértice. Haga clic de nuevo en la nueva ubicación para colocar el vértice.
-
Mientras mueve un control A, pulse la tecla Delete del teclado para eliminar ese vértice de la sala.
-
Hacer clic en B o en un borde (entre los controles) y, a continuación, mover el cursor para deslizar ese borde. Pulse Shift+Spacebar mientras mueve el borde para alternar entre los modos de comportamiento del borde disponibles (deslizar borde, quebrar borde, curvar borde).
-
Ctrl+Click B o Ctrl+Click en un borde y, a continuación, mover el cursor para añadir un vértice a ese borde y desplazarlo. Haga clic de nuevo en la nueva ubicación para colocar el vértice. De este modo, el nuevo vértice se convierte en un vértice A y se añaden nuevos vértices B entre este y los vértices A originales.
-
Para acceder a un control situado fuera de la rejilla, mantenga pulsada la tecla Ctrl para desactivar temporalmente el ajuste a la rejilla.
-
Continúe modificando la forma de la sala según sea necesario, o haga clic con el botón derecho o pulse Esc para finalizar. La visualización de la sala se actualizará de acuerdo con la nueva forma del contorno.
Este comando puede utilizarse tanto si la sala de destino está bloqueada como si no.
Dividir una sala
Hay comandos disponibles para slice gráficamente un objeto de sala colocado en dos o más salas independientes. El proceso de división es similar al de colocar una línea e incluye los mismos modos de esquina (de hecho, el ancho del objeto de corte es el ancho de línea predeterminado actual). Tenga en cuenta que los objetos utilizados para mostrar la trayectoria de corte no son objetos que se estén colocando; solo se muestran para indicar la trayectoria de corte y se eliminan una vez finalizado el proceso de división. Además, no es necesario comenzar el corte exactamente en el borde de una sala; resulta más fácil empezar ligeramente fuera de ella y terminar también ligeramente fuera.
Hay dos comandos de división disponibles. El proceso para definir el trazado de división es el mismo para ambos; se diferencian en cómo gestionan los componentes presentes en la región que se está dividiendo. Las diferencias entre los comandos se explican después de describir el proceso de división.
|
Haga clic con el botón derecho en una región para acceder a los comandos Slice del menú Room Actions. Se definieron dos divisiones mediante el proceso descrito a continuación. Se han creado tres regiones. |
El proceso de división
Después de ejecutar un comando Slice:
-
El cursor cambia a una cruz y se le solicita que seleccione un punto inicial para la división.
-
Sitúe el cursor justo fuera de la región que desea dividir y, a continuación, haga clic o pulse Enter. Ahora se encuentra en el modo de división (básicamente, el modo de colocación de líneas).
-
Mueva el cursor hacia el interior de la región para definir el primer segmento de división y, a continuación, haga clic o pulse Enter para fijar el extremo de ese segmento.
-
Siga moviendo el cursor y haciendo clic para definir una serie de vértices que determinen la forma de la división.
-
Después de colocar el último vértice (justo fuera de la región), haga clic con el botón derecho o pulse Esc para finalizar la colocación de esa división.
-
Ahora puede iniciar otra división de la región, o hacer clic con el botón derecho o pulsar Esc para salir del modo de división.
-
Se abrirá un cuadro de diálogo de confirmación que indica en cuántas regiones se dividirá la región original. Haga clic en Yes para aplicar las divisiones realizadas, o en No para descartarlas. Los nuevos objetos de región resultantes se actualizarán según corresponda y se crearán y asociarán las reglas de definición de región pertinentes.
-
Durante la división, pulse:
-
Shift+Spacebar para recorrer los modos de esquina.
-
Spacebar para alternar la dirección de la esquina.
-
Cada segmento de división requiere un punto inicial y uno final.
-
Si el modo de colocación de divisiones incluye una esquina, pulse el atajo 1 para alternar entre colocar un segmento por clic o dos segmentos por clic.
-
Backspace para eliminar el último segmento de división colocado.
-
Reajustar una región existente
Otra forma de modificar la forma de una región existente consiste en indicar al software que vuelva a ajustar la región alrededor de la clase de componentes que tiene asignada. Tanto el submenú Room Actions del menú contextual como el submenú Design » Rooms incluyen los tres comandos de ajuste de región, como se muestra en la presentación.
|
Si cambia la colocación de los componentes dentro de una región, utilice uno de los tres comandos Wrap para actualizar la forma de la región. El comando Wrap Non-Orthogonal coloca los bordes de la región de modo que unan los puntos extremos de los contornos de los componentes. El comando Wrap Orthogonal coloca bordes de región verticales y horizontales alrededor de los contornos de los componentes. El comando Wrap Rectangular coloca la región rectangular más pequeña que engloba los contornos de los componentes. |
Edición en el panel Propiedades
El objeto de región tiene la particularidad de ser tanto un objeto como una restricción de diseño.
Edición mediante el panel Propiedades
Las propiedades del objeto de región, incluidas su ubicación y su forma en el espacio de edición, se pueden editar en el panel Properties cuando la región está seleccionada. El panel se puede mostrar mediante el botón Panels de paneles, situado en la parte inferior derecha del espacio de diseño, o mediante el comando View » Panels » Properties.
El panel Properties se puede utilizar para editar las propiedades gráficas de una región.
| Name | El nombre actual de la región (y de la regla de definición de región asociada). Se puede cambiar según sea necesario. Además de ayudar a identificar cada región, el nombre se puede utilizar para especificar una región concreta en una regla de diseño. |
| (X/Y) (dos campos) | La posición X e Y actual del primer vértice de la región, con respecto al origen actual. Edite el valor del campo para cambiar la posición de la región con respecto al origen actual. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente. Las unidades predeterminadas (métricas o imperiales) se muestran en la barra de estado y se configuran en la sección Other del panel Properties (cuando no hay objetos seleccionados en el espacio de diseño). Estos valores solo pueden editarse si la opción X/Y está desbloqueada (se muestra el icono |
Vértices del contorno |
|
| Vertices Grid | Enumera todos los vértices definidos actualmente para la región, en el orden en que se definieron al colocarla. Se utilizan segmentos rectos para conectar cada vértice con el siguiente. Si prefiere una conexión en arco, introduzca un valor para el Arc Angle requerido. El valor se introduce en el campo asociado al vértice de origen y el arco va desde este vértice hasta el siguiente de la lista. Haga clic con el botón derecho para Copy / Paste o Import / Export to CSV. |
| Index | El índice asignado al vértice (no editable, basado en el orden en que se colocaron los vértices durante la definición de la región). |
| X | La coordenada X (horizontal) del vértice. Haga clic para editarla. |
| Y | La coordenada Y (vertical) del vértice. Haga clic para editarla. |
| Arc Angle (Neg = CW) | El ángulo del arco que se traza para conectar este vértice con el siguiente. De forma predeterminada, las conexiones son segmentos rectos y este campo permanece vacío. Haga clic para editarlo y, a continuación, introduzca el ángulo de arco deseado. Al introducir un valor positivo, se trazará un arco en sentido antihorario. Para trazar un arco en sentido horario, introduzca un valor negativo. |
Trabajar con regiones
El software incluye diversas funciones que le ayudan a trabajar con regiones y con los objetos que contienen. Entre ellas se incluyen comandos para organizar las regiones en una cuadrícula, moverlas a la cuadrícula de ajuste actual y, en diseños que incluyen secciones de circuitos repetidas, copiar la colocación y el enrutado de una región a otra.
También puede utilizar una región para limitar otras restricciones de diseño a un área de la placa; por ejemplo, exigir que en esta región las redes se enruten con una anchura y una separación específicas, o que los pares diferenciales se enruten con un perfil de impedancia específico.
Un mezclador de 8 canales: se colocó y enrutó el primer canal de entrada y, a continuación, se replicó en los otros siete canales de entrada mediante el comando Copy Room Format.
Definir restricciones dentro de una región
Además de restringir los objetos para que estén dentro o fuera de una región (como se explica en la sección Restricción de diseño de definición de región), una región también puede utilizarse para delimitar el área de aplicación de otras restricciones de diseño. Por ejemplo, la restricción de anchura de enrutado puede exigir que el enrutado bajo un BGA se realice con anchuras diferentes, o la restricción de separación eléctrica puede exigir separaciones diferentes en un área específica de la placa.
La anchura de enrutado y las separaciones se ajustan automáticamente dentro de la región, de acuerdo con los ajustes de su definición.
Esto se consigue añadiendo las restricciones de anchura de enrutado y de separación eléctrica que se muestran en la presentación de diapositivas siguiente.
En el Administrador de restricciones
Cuando se añade una restricción de región en la vista All Rules del Constraint Manager, ese objeto de región también pasa a estar disponible en la vista Physical. Con esta vista puede definir rápidamente restricciones basadas en áreas que deben aplicarse dentro de la región, entre ellas: la anchura de enrutado, la separación eléctrica, el estilo de vía de enrutado, las propiedades de los pares diferenciales, el estrechamiento del enrutado y el estilo de conexión de polígonos. La presentación de diapositivas siguiente muestra las restricciones de la placa del vídeo anterior.
|
Dentro de esta región, todos los objetos de enrutado deben tener una anchura dentro del intervalo especificado. Dentro de esta región, todos los objetos de enrutado deben mantener, como mínimo, esta separación con respecto a los objetos pertenecientes a otras redes. Dentro de esta región, todos los objetos de enrutado deben mantener, como mínimo, esta separación eléctrica. Dentro de esta región, todos los pares diferenciales deben enrutarse utilizando el perfil de impedancia |
En el Editor de reglas y restricciones de PCB
Para obtener el mismo resultado en el PCB Rules and Constraint Editor, cree una consulta que defina el área de la región. La detección de los objetos de la región puede realizarse de dos maneras: seleccionando los objetos que se encuentran completamente dentro de la región (mediante la palabra clave WithinRoom) o seleccionando los objetos que tocan la región (mediante la palabra clave TouchesRoom). La presentación de diapositivas siguiente muestra las mismas propiedades de anchura de enrutado, separación eléctrica, estilo de vía de enrutado y pares diferenciales que se mostraron en la Constraint Manager presentación anterior.
Organizar las regiones seleccionadas
Para organizar las regiones seleccionadas dentro del espacio de diseño, puede utilizar el comando Design » Rooms » Arrange Rooms. Seleccione las regiones deseadas y, a continuación, ejecute el comando para abrir el cuadro de diálogo Arrange Rooms.
El cuadro de diálogo Arrange Rooms.
Especifique cómo desea organizar las regiones y en qué orden deben colocarse. También puede especificar la posición inicial, ya sea introduciendo las coordenadas X-Y en el cuadro de diálogo o haciendo clic en el espacio de trabajo, así como la separación entre regiones adyacentes. Después de hacer clic en OK, las regiones seleccionadas se moverán a su posición.
Columnas/Filas |
|
| Columns | El número de columnas utilizadas para colocar las regiones. Edite este campo según sea necesario. |
| Rows | El número de filas utilizadas para colocar las regiones. Edite este campo según sea necesario. Si hay más regiones de las que caben en la disposición personalizada de filas y columnas, se añadirán más filas en la parte superior. |
Ordenar por |
|
| SortBy | Muestra el orden de clasificación elegido, es decir, los criterios utilizados para distinguir la primera región de la siguiente. Las opciones disponibles se detallan a continuación. |
| Channel Name | Ordena las regiones alfanuméricamente según su nombre de canal. Obtenga más información sobre el diseño multicanal. |
| Room Area | Ordena las regiones según su área. |
| Room Component Count | Ordene las rooms según el número de componentes que contienen. |
| Room Width | Ordene las rooms por su tamaño en X (horizontal). |
| Room Height | Ordene las rooms por su tamaño en Y (vertical). |
| Sort in Ascending order | Active esta opción para ordenar las rooms en orden ascendente (de menor a mayor), según los criterios actuales de SortBy. Si esta opción está desactivada, el orden será descendente (de mayor a menor). |
Posición |
|
| Origin X | Define la ubicación X (horizontal) donde comenzará la colocación de las rooms. Edite este campo para cambiar la coordenada X, que puede definirse en mm o mil. Para especificar las unidades al introducir un número, añada el sufijo mm o mil al valor. Las unidades predeterminadas (métricas o imperiales) se determinan mediante el ajuste Units del panel Propiedades y se utilizan si no se especifican unidades. |
| Origin Y | Define la ubicación Y (vertical) donde comenzará la colocación de las rooms. Edite este campo para cambiar la coordenada Y, que puede definirse en mm o mil. Para especificar las unidades al introducir un número, añada el sufijo mm o mil al valor. Las unidades predeterminadas (métricas o imperiales) se determinan mediante el ajuste Units del panel Propiedades y se utilizan si no se especifican unidades. |
| Select Origin Using Mouse | Si se activa, se le solicitará que establezca manualmente el origen para la distribución de las rooms. La opción debe estar desactivada para poder editar Origin X y Origin Y. |
| X-Spacing | Define la distancia X (horizontal) que se dejará entre rooms adyacentes. |
| Y-Spacing | Define la distancia Y (vertical) que se dejará entre rooms adyacentes. |
| Auto Spacing | Si se activa, las rooms se distribuyen con la misma separación en X (horizontal) y en Y (vertical). La opción debe estar desactivada para poder editar X-Spacing y Y-Spacing. |
| Place On Grid | Active esta opción para forzar la alineación de las rooms con la cuadrícula de ajuste actual de la PCB. |
Mover rooms a la cuadrícula
Para mover cada una de las rooms seleccionadas al punto más cercano de la cuadrícula de ajuste actual, utilice el comando Design » Rooms » Move Rooms to Grid. Tras ejecutar el comando, se abrirá un cuadro de diálogo de confirmación que le preguntará si desea mover los objetos junto con las rooms seleccionadas. Haga clic en Yes para mover las rooms y los objetos que contienen al punto más cercano de la cuadrícula de ajuste, o haga clic en No para mover solo las rooms.
Copiar formatos de rooms
Una de las funciones más potentes de las rooms es la posibilidad de copiar la forma, la colocación y el enrutado de una room a otras que contengan un conjunto idéntico de componentes. El comando es especialmente útil durante el diseño físico de un diseño multicanal, ya que permite propagar la colocación y el enrutado realizados en un canal a todos los demás canales.
Para copiar el formato de una room a otras:
-
Haga clic en Design » Rooms » Copy Room Formats en los menús principales.
-
La barra de estado le solicitará que elija una room de origen. Sitúe el cursor sobre la room de origen y haga clic o pulse Enter.
-
La barra de estado le solicitará que elija una room de destino. Sitúe el cursor sobre la room a la que desea copiar el formato y haga clic o pulse Enter. Si desea aplicar el formato a varias rooms, este segundo clic puede hacerse en cualquiera de ellas.
-
Se abrirá el cuadro de diálogo Confirm Channel Format Copy. Utilice las opciones para definir cómo se copiará el formato. De forma predeterminada, el formato se copiará desde Source Room hasta Destination Room, según lo seleccionado. Para copiar desde la room de origen a cada una de las rooms de la clase de canales detectada, active la opción Apply to Specified Channels y confirme que las casillas Copy correspondientes a las rooms de destino estén activadas.
-
Haga clic en OK en el cuadro de diálogo para actualizar las rooms de destino.
-
Puede seguir seleccionando otras rooms de destino o hacer clic con el botón derecho para finalizar.
Rooms |
|
| Source Room | El nombre de la room de origen (que representa el canal del esquema), cuya colocación de componentes y enrutado se copiarán. |
| Destination Room | Este campo contiene el nombre de la room de destino (que representa el canal del esquema), a la que se aplicarán la colocación y el enrutado copiados. Si el proyecto es un diseño multicanal y los canales de origen y destino pertenecen a la misma clase de canales, la copia del formato se aplicará a los canales activados en la región Channel Class del cuadro de diálogo Tenga en cuenta que el canal de origen (room) y el canal de destino (room) deben pertenecer a la misma clase de canales si desea copiar el formato de un canal de origen (room) a otros canales (rooms). |
Opciones |
|
| Copy Component Placement | Copie la colocación de los componentes de la room de origen a las rooms de destino. |
| Copy Designator and Comment Formatting | Copie el formato de los designadores y los comentarios de la room de origen a la room de destino. |
| Copy Routed Nets | Copie la disposición del enrutado (pistas/arcos y vías utilizados para enrutar las redes) de la room de origen a la room de destino. |
| Copy Room Size/Shape | Copie la forma de la room de origen y aplíquela a la room de destino. Si la opción Copy Room Orientation está activada en el cuadro de diálogo, la forma de la room de destino cambiará con respecto a su punto inicial (inferior izquierdo); es decir, el punto inferior izquierdo de la room de destino permanecerá sin cambios. |
| Copy Room Orientation | Copie la orientación de la room. Altium Designer detecta la orientación de las rooms (mediante el ángulo de rotación del componente con el mayor número de pines o, si hay varios componentes con el mismo número máximo de pines, el componente de mayor área) y la utiliza para girar la room de destino. |
| Copy Selected Objects Only | Copie el formato de los objetos seleccionados de la room de origen a la room de destino. |
Opciones para objetos en contacto |
|
| Copy All Objects Touching the Room | Incluir objetos (distintos de los componentes y las pistas/arcos de enrutado & vías) que estén total o parcialmente dentro de la sala. Esta opción debe estar habilitada para copiar objetos con y sin red asignada, como regiones, polígonos y áreas de exclusión, de una sala a otra. |
| Exclude NoNet Objects | Excluir objetos que no tengan una red asignada. |
Solo completamente incluidos / Incluidos y en contacto |
|
| Fully Enclosed Objects Only | Si la opción Copy All Objects Touching the Room está habilitada, habilite esta opción para copiar solo los objetos que estén completamente dentro de la sala. |
| Enclosed & Touching Objects | Si la opción Copy All Objects Touching the Room está habilitada, habilite esta opción para copiar tanto los objetos que estén dentro de la sala como los que estén en contacto con ella. |
Correspondencia de componentes entre canales |
|
| Match Components by Channel Offsets | A cada componente de un canal repetido se le asigna un desplazamiento de canal durante la transferencia del diseño del esquemático a la PCB; utilice el desplazamiento de canal para identificar el mismo componente en cada canal. |
| Match Components by Source Designator | Como alternativa, utilice el designador de origen (del esquemático) para identificar los componentes correspondientes en cada canal. |
Eliminar conexiones afectadas |
|
| Whole connections | Una vez procesada la copia del formato del canal, el software necesita saber cómo eliminar las conexiones afectadas. Si se selecciona esta opción, se eliminan las conexiones afectadas tanto dentro como fuera de la sala. |
| Touching parts of connections only | Si se selecciona esta opción, solo se eliminan las conexiones afectadas que estén en contacto con la sala. |
| Contained parts of connections only | Si se selecciona esta opción, solo se eliminan las conexiones afectadas dentro de la sala. |
Clase de canales |
|
| Channel Class | Cuando se transfiere un diseño multicanal del esquemático a la PCB, los circuitos repetidos (canales) se identifican como una clase de canales en el cuadro de diálogo Object Class Explorer del editor de PCB Esta clase de canales se utiliza para identificar los canales a los que se aplicará la copia del formato. Si la sección Channel Class del cuadro de diálogo está vacía, compruebe que la clase de canales esté correctamente definida en el cuadro de diálogo Object Class Explorer (Design » Classes). Si no se identifica ninguna clase de canales, el comando de copia solo se aplica desde la sala de origen a la sala de destino. |
| Channel Members | Esta lista contiene los canales, cada uno identificado por el nombre de su sala. Si la sala de origen forma parte de una clase de canales definida, se mostrarán la clase y todos sus miembros. Se muestran la capa (el lado de la placa en el que se ha colocado la sala) y el número de componentes de cada canal. Cada canal incluye una casilla que permite controlar si se le aplica la copia del formato; esta casilla se puede utilizar si la opción Apply To Specified Channel está habilitada. |
| Apply To Specified Channel | El comportamiento predeterminado es copiar el formato de Source Room a todos los canales de la clase de canales a la que pertenece la sala de origen (canal). Al habilitar esta opción, la casilla Copy de cada canal pasa a estar disponible, lo que permite seleccionar los canales de la clase a los que se aplicará la copia del formato. |
Ocultar salas
Las salas de un documento determinado se pueden mostrar, ocultar o mostrar en modo borrador de forma global mediante las opciones de la pestaña View Options del panel Configuración de vista.
Ajuste el control deslizante Visibilidad de objetos correspondiente a las salas para atenuarlas u ocultarlas en el espacio de edición.
).

).
)
).
).
).




)
).








).