Preparación de salidas y liberación del proyecto

De un vistazo

Prepara tu diseño de PCB terminado para la fabricación con este tutorial paso a paso de Altium Designer. Aprende a crear archivos de tareas de salida (Output Job), configurar la documentación de fabricación y ensamblaje e incluir una comprobación de las reglas de diseño en el proceso de publicación. Una vez configuradas las salidas, tu proyecto estará listo para su publicación. Sigue leyendo para completar estos últimos pasos de preparación de tu diseño de PCB.

- Configura las salidas Gerber y de taladrado NC, incluidas las unidades, la precisión y las ubicaciones de salida.
- Configura las salidas de BOM, Draftsman y Pick & Place para la documentación de ensamblaje.
- Añade un informe de validación DRC para comprobar las reglas de diseño antes de generar las demás salidas de publicación.
Profundiza con IA:

Main page: Preparación del diseño para la fabricación

Ahora que has completado el diseño y la disposición de la PCB, puedes generar la documentación de salida necesaria para revisar, fabricar y ensamblar la placa.

Dada la variedad de tecnologías y métodos que existen para la fabricación de PCB, Altium Designer permite generar numerosos tipos de salida para distintos fines, como archivos Gerber, archivos ODB++, archivos Pick and Place, informes de lista de materiales, etc.

Adición de un archivo Output Job al proyecto

Main page: Preparación de los datos de fabricación con Output Jobs

Aunque puedes generar de forma selectiva las salidas necesarias desde editores específicos (por ejemplo, mediante los comandos de los submenús Fabrication Outputs y Assembly Outputs del menú principal File del editor de PCB), Altium Designer permite utilizar archivos Output Job. Un archivo Output Job (o «OutJob», para abreviar) almacena la configuración de cada tipo de salida. Un OutJob permite configurar cada tipo de salida, así como su nombre, formato y ubicación. Las salidas pueden generarse directamente desde un OutJob o como parte del proceso integrado de publicación del proyecto.

  1. Haz clic con el botón derecho en la entrada del proyecto en el panel Projects y selecciona el comando Add New to Project » Output Job File en el menú contextual. Se abrirá un nuevo archivo Output Job y aparecerá una entrada vinculada al proyecto en el panel Projects, bajo la entrada Settings\Output Job Files.

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Haz clic con el botón derecho en la entrada del OutJob en el panel Projects y selecciona el comando Save As. Se abrirá el cuadro de diálogo Save As, listo para guardar el documento en la misma ubicación que el archivo del proyecto. Escribe el nombre Fabrication en el campo File name y haz clic en el botón Save.

  3. La adición del OutJob ha modificado el proyecto, así que guárdalo localmente haciendo clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccionando Save.

Adición y configuración de las salidas de fabricación

Main page: Preparación de los datos de fabricación

En esta parte del tutorial, configurarás las salidas necesarias para fabricar la placa: archivos Gerber y NC Drill. 

  1. Para añadir una nueva salida Gerber, haz clic en el enlace Add New Fabrication Output de la sección Fabrication Outputs de la región Outputs del OutJob y selecciona Gerber Files » [PCB Document].

    Si seleccionas la opción [PCB Document], el documento PCB del proyecto se utilizará automáticamente como origen de la salida. Esta elección también permite copiar fácilmente el OutJob entre proyectos, ya que no será necesario actualizar este ajuste. Si el proyecto contiene varios documentos PCB, tendrás que seleccionar la placa específica.

  2. Haz doble clic en la entrada de salida Gerber Files que has añadido. Se abrirá el cuadro de diálogo Gerber Setup. Configura las opciones del cuadro de diálogo de la siguiente manera:

    1. Como la placa se ha diseñado en el sistema métrico, asegúrate de que la opción Units esté establecida en Millimeters.

    2. La unidad más pequeña utilizada en la placa es de 0,25 mm para el enrutado y la separación, pero, como la mayoría de los componentes tienen su punto de referencia en su centro geométrico (y se colocaron en una cuadrícula de 1 mm), algunos de sus pads estarán en realidad en una cuadrícula de 0,01 mm. Establece la opción Decimal en 0.001 mm. Esto garantiza que la resolución de los datos de salida sea más que suficiente para representar estas posiciones de la cuadrícula.

    3. Haz clic en el botón  de la parte inferior de la pestaña Layer to plot y elige Select Used. Las capas utilizadas en el diseño se habilitarán en la columna Plot de la tabla situada encima.

  3. Haz clic en Apply para aceptar los demás ajustes predeterminados y cerrar el cuadro de diálogo Gerber Setup.

  4. Como la placa tiene taladros, también es necesario generar un archivo NC Drill. Del mismo modo, añade la salida NC Drill al archivo OutJob: haz clic en el enlace Add New Fabrication Output de la sección Fabrication Outputs de la región Outputs del OutJob y selecciona NC Drill Files » [PCB Document].

  5. Haz doble clic en la entrada de salida NC Drill Files que has añadido para acceder al cuadro de diálogo NC Drill Setup. Para garantizar que los archivos NC Drill se creen con el mismo formato que los archivos Gerber, establece Units en Millimeters y Format en 4:3. Asegúrate de que la opción Coordinate Position esté establecida en Reference to relative origin.

  6. Haz clic en Aceptar para aceptar los demás ajustes predeterminados y cerrar el cuadro de diálogo NC Drill Setup.

  7. Ahora que los ajustes de Gerber y NC Drill están configurados, el siguiente paso es configurar sus nombres y la ubicación de salida. Para ello, debes asociarlos a un contenedor de salida en el lado derecho del OutJob. Para archivos independientes con su propio formato, utiliza un contenedor de estructura de carpetas. Un nuevo OutJob incluye algunos contenedores de forma predeterminada. Selecciona la entrada Folder Structure en la lista de contenedores de salida y, a continuación, haz clic en los botones de opción de los archivos Gerber y NC Drill en la columna Enabled de la región Outputs para asociar estas salidas al contenedor seleccionado, como se muestra a continuación.

  8. El último paso es configurar el contenedor. Para ello, haz clic en el enlace Change de la entrada del contenedor cuando esté seleccionado para abrir el cuadro de diálogo Folder Structure settings. En la parte superior del cuadro de diálogo hay un conjunto de controles que se utilizan para configurar la ubicación de salida. Asegúrate de que el primer control esté establecido en Release Managed. La parte inferior del cuadro de diálogo mostrará cómo cambian los nombres y la estructura de carpetas al seleccionar distintas opciones.

  9. Haz clic en OK para cerrar el cuadro de diálogo Folder Structure settings.

Adición y configuración de un informe de validación DRC

Main page: Preparación de los informes de validación

Altium Designer incluye una serie de comprobaciones de validación que pueden incluirse como salida durante la generación de salidas. Cada una genera un archivo de informe HTML. Durante el proceso de publicación del proyecto, estas comprobaciones se realizarán antes de generar las demás salidas y, si alguna no se supera, la publicación fallará.

  1. Para añadir una nueva salida de validación DRC, haz clic en el enlace Add Validation Output de la sección Validation Outputs de la región Outputs del OutJob y selecciona Design Rules Check » [PCB Document].

  2. Asocia el informe añadido al contenedor Folder Structure existente. Selecciona la entrada Folder Structure en la lista del lado derecho del OutJob y, a continuación, haz clic en el botón de opción de la salida Design Rules Check en la columna Enabled de la región Outputs.

  3. Guarda el archivo Output Job localmente haciendo clic con el botón derecho en su entrada en el panel Projects y seleccionando Save en el menú contextual.

  4. Cierre el archivo Output Job haciendo clic con el botón derecho en su pestaña, en la parte superior del espacio de diseño, y seleccionando el comando Close Fabrication.OutJob en el menú contextual. 

Adición y configuración de salidas de ensamblaje

Main page: Configuración de la BOM en el gestor de informes

El archivo BOM de salida se genera mediante el cuadro de diálogo Report Manager, un motor de generación de informes altamente configurable que permite generar salidas en diversos formatos, como texto, CSV, PDF, HTML y Excel. También se puede aplicar una plantilla a las BOM en formato Excel, ya sea una de las plantillas predefinidas o una propia.

  1. Añada un nuevo archivo OutJob al proyecto haciendo clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccionando el comando Add New to Project » Output Job File en el menú contextual.

  2. Haga clic con el botón derecho en la entrada de OutJob del panel Projects y seleccione el comando Save As. Se abrirá el cuadro de diálogo Save As, listo para guardar el documento en la misma ubicación que el archivo del proyecto. Escriba el nombre Assembly en el campo File name y haga clic en el botón Save.

  3. Guarde el proyecto localmente haciendo clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccionando Save.

  4. Para añadir una nueva salida de BOM, haga clic en el enlace Add New Report Output de la sección Report Outputs del OutJob y seleccione Bill of Materials » [ActiveBOM Document].

  5. Haga doble clic en la salida Bill of Materials añadida para abrir el cuadro de diálogo Report Manager.

  6. En la región Export Options del panel Properties, situado a la derecha del cuadro de diálogo, utilice la lista desplegable File Format para seleccionar Generic XLS (*.xls, *.xlsx, *.xlsm) y, a continuación, utilice la lista desplegable Template para seleccionar la plantilla BOM Template Single Supplier de entre las disponibles en su espacio de trabajo.

  7. Haga clic en OK para guardar los cambios y cerrar el cuadro de diálogo Report Manager.

  8. Añada una nueva salida de Draftsman haciendo clic en el enlace Add New Documentation Output de la sección Documentation Outputs del OutJob y seleccionando Draftsman » All Draftsman Documents.

  9. Asocie las salidas de BOM y Draftsman añadidas al contenedor de salida PDF existente. Para ello, seleccione la entrada PDF en la lista de contenedores de salida situada a la derecha del OutJob y, a continuación, haga clic en los botones de opción de las salidas Bill of Materials y Draftsman en la columna Enabled de la región Outputs.

  10. Con la entrada del contenedor PDF seleccionada, haga clic en el enlace Change de la entrada para abrir el cuadro de diálogo PDF settings.

  11. Haga clic en la entrada Assembly.PDF de la parte superior del cuadro de diálogo PDF settings, seleccione Separate file for each output using output name y haga clic en el botón . A la BOM y al plano de salida se les asignará el nombre definido para la salida en el OutJob (Bill of Materials.pdf y Draftsman.pdf, respectivamente), que puede verse en la región Preview del cuadro de diálogo.

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. Haga clic en OK para cerrar el cuadro de diálogo.

  13. Añada una nueva salida de inserción y colocación haciendo clic en el enlace Add New Documentation Output de la sección Documentation Outputs del OutJob y seleccionando Generates pick and place files » [PCB Document].

  14. Haga doble clic en la salida Generates pick and place files añadida para acceder al cuadro de diálogo Pick and Place Setup.

  15. En la región Output Setting, situada en la parte inferior izquierda del cuadro de diálogo, establezca Units en Metric.

  16. Haga clic en OK para aceptar el resto de los ajustes predeterminados y cerrar el cuadro de diálogo Pick and Place Setup.

  17. Asocie la salida de inserción y colocación añadida al contenedor de salida Folder Structure existente. Para ello, seleccione la entrada Folder Structure en la lista de contenedores de salida situada a la derecha del OutJob y, a continuación, haga clic en el botón de opción de la salida Generates pick and place files en la columna Enabled de la región Outputs.

  18. Guarde el archivo Output Job localmente haciendo clic con el botón derecho en su entrada en el panel Projects y seleccionando Save en el menú contextual.

  19. Cierre el archivo Output Job haciendo clic con el botón derecho en su pestaña, en la parte superior del espacio de diseño, y seleccionando el comando Close Assembly.OutJob en el menú contextual.

Publicación del proyecto

Main page: Publicación del proyecto de diseño

Una vez configurada la documentación de salida en los archivos Output Job, el proyecto estará listo para publicarse en el espacio de trabajo conectado. El proceso de publicación del diseño de la placa está automatizado, lo que permite publicar los proyectos de diseño de placas sin los riesgos asociados a los procedimientos de publicación manuales. Cuando se publica un proyecto, se toma una instantánea de los archivos fuente del diseño y se archiva junto con todas las salidas generadas, que representan un producto tangible fabricado a partir de ese proyecto de diseño y comercializado por la empresa.

El proceso de publicación se realiza mediante Project Releaser de Altium Designer, cuya interfaz de usuario se presenta en una vista específica: la vista de publicación. El proceso de publicación se divide en etapas, y las entradas del lado izquierdo de la vista permiten identificar de un vistazo la etapa actual.

  1. Haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Project Releaser en el menú contextual. La vista de publicación se abrirá como una pestaña de documento independiente.

  2. En la primera etapa, 1. Configure Server Release, se especifican los tipos de datos que se desean generar. Haga clic en los controles Details situados en el extremo derecho del encabezado de cada conjunto de datos para consultar los detalles de lo que generará exactamente cada conjunto.

  3. Haga clic en el botón , situado en la parte inferior izquierda de la vista, para acceder al cuadro de diálogo Project Release Options. En la pestaña Release Options del cuadro de diálogo, asegúrese de que Managed - <WorkspaceName> esté seleccionado como Release Target, Fabrication esté asignado al conjunto Fabrication Data y Assembly esté asignado al conjunto Assembly Data.

  4. Haga clic en OK para cerrar el cuadro de diálogo y volver a la vista de publicación.

  5. Asegúrese de que las opciones Include Fabrication Data y Include Assembly Data for No Variant estén activadas.

  6. Haga clic en el botón  de la parte inferior derecha de la vista para continuar.

  7. Se abrirá el cuadro de diálogo Item Creation, con la lista de elementos de publicación que se crearán en el espacio de trabajo. Seleccione la opción Create items para confirmar la creación de los elementos.

  8. En el cuadro de diálogo Project Modified que se abre, seleccione la opción Save and Commit changes para guardar los cambios localmente y continuar guardando los cambios en el espacio de trabajo.

  9. En el cuadro de diálogo Commit to Version Control que se abre, introduzca un comentario significativo en el campo Comment (p. ej., The project is ready for release) y, a continuación, haga clic en el botón .

  10. La siguiente etapa del proceso de publicación, 2. Validate Project, se ejecuta automáticamente porque el archivo de trabajo de salida Fabrication incluye el informe de comprobación de reglas de diseño.

    Si alguna de las comprobaciones de validación no se supera, la publicación fallará. Para la publicación del proyecto de este tutorial, esto significará que el documento de PCB incluye al menos una infracción de las reglas de diseño (DRC). En este caso, detenga el proceso de publicación con el botón  de la esquina inferior derecha de la vista, abra el documento de PCB, resuelva las infracciones de DRC y vuelva a iniciar el proceso de publicación.

  11. Una vez superada la validación, la siguiente etapa del proceso de publicación, 3. Generate Data, se ejecuta automáticamente. En esta etapa se ejecutan todas las demás salidas, definidas en los archivos OutJob asignados a los elementos de datos incluidos, para generar los datos que se publicarán en los elementos de destino correspondientes del espacio de trabajo.

  12. Una vez superadas todas las comprobaciones de validación y generados los datos de salida, la siguiente etapa del proceso de publicación, 4. Review Data, le permite revisar los datos generados. Para continuar con la publicación, haga clic en el botón  de la esquina inferior derecha de la vista.

  13. Se abrirá el cuadro de diálogo Confirm Release, que resume las configuraciones del proyecto que se publicarán en el espacio de trabajo. Introduzca un Release Note (p. ej., Initial Release) y haga clic en OK.

  14. Tras confirmar la publicación en la etapa anterior, se pasa automáticamente a la siguiente etapa, 5. Upload Data. Esta simplemente muestra el progreso de la carga de datos en las revisiones de los elementos de datos correspondientes del espacio de trabajo.

  15. La etapa final del proceso, 6. Execution Report, proporciona un resumen de la publicación. Cierre la vista de publicación haciendo clic en el botón  de la esquina inferior derecha de la vista.

Diseño colaborativo con un espacio de trabajo

En la mayoría de los casos, varias personas participan en el diseño y desarrollo de un producto electrónico. Para hacerlo de manera eficaz, los miembros de ese equipo de diseño deben poder trabajar de forma colaborativa. Altium Designer, junto con un espacio de trabajo conectado, ofrece diversas funciones de diseño colaborativo. A continuación se enumeran algunas de ellas.

  • Project history – la vista específica de historial es una cronología avanzada del historial del proyecto, con una representación gráfica que muestra de forma progresiva los principales eventos relacionados con el proyecto: su creación, confirmaciones de cambios, publicaciones, clonaciones e intercambios con MCAD. Además, permite realizar diversas acciones cuando corresponde (). Para acceder a la vista de historial de un proyecto del espacio de trabajo desde Altium Designer, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando History & Version Control » Show Project History en el menú contextual.

    Más información: Historial del proyecto, Project History (Espacio de trabajo de Altium 365, Espacio de trabajo de Enterprise Server)

  • Web Viewer – la interfaz del visor web del espacio de trabajo proporciona acceso universal a los documentos del proyecto mediante un navegador estándar. Es mucho más que un simple visor basado en navegador: su avanzada tecnología permite a los usuarios navegar por la estructura del proyecto, interactuar con los documentos de diseño, resaltar áreas u objetos para añadir comentarios, así como buscar, realizar sondeos cruzados, seleccionar e inspeccionar componentes y redes en todo el diseño. Para acceder al visor web de un proyecto del espacio de trabajo desde Altium Designer, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Show in Web Browser en el menú contextual.

    Más información: Web Viewer (Plataforma Altium 365, Espacio de trabajo de Enterprise Server)

  • Document commenting – un comentario es una nota añadida por un usuario que se asigna a un punto, objeto o área específicos (según corresponda) de una vista de datos compatible y a la que otros usuarios pueden responder. Los comentarios fomentan la colaboración entre usuarios sin modificar los datos compartidos, ya que el espacio de trabajo almacena los comentarios de forma independiente de dichos datos. Los comentarios añadidos en la interfaz del visor web en las siguientes ubicaciones están disponibles en Altium Designer y viceversa. En Altium Designer, la función de comentarios se gestiona mediante el panel Comments and Tasks ().

    Más información: Comentarios en documentos, Web Viewer (Plataforma Altium 365, Espacio de trabajo de Enterprise Server)

  • Sharing a project – una vez guardado un proyecto en el espacio de trabajo, puede determinar qué usuarios pueden acceder a él para colaborar en su diseño o revisarlo. Esto se hace compartiendo el proyecto o, más concretamente, configurando sus permisos de acceso. En Altium Designer, el uso compartido de proyectos se gestiona mediante el cuadro de diálogo Share (), al que se accede haciendo clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccionando el comando Share en el menú contextual.

    Más información: Compartir un diseño, Workspace Projects (Espacio de trabajo de Altium 365, Espacio de trabajo de Enterprise Server)

¡Enhorabuena! Ha comenzado con una hoja de esquema en blanco y ha llegado hasta una PCB terminada con sus salidas publicadas en el espacio de trabajo: ¡ha completado todo el proceso de diseño en Altium Designer!

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents