Ansys CoDesigner

A causa della complessità dei moderni prodotti elettronici che includono circuiti ad alta velocità e RF, durante il processo di progettazione del PCB è richiesta una comunicazione intensa tra gli ingegneri PCB e quelli di simulazione, e questa comunicazione dovrebbe essere il più chiara e semplice possibile per entrambe le parti. Non è sufficiente esportare un progetto modificato dall’ingegnere PCB o ottimizzato dall’ingegnere di simulazione e passarlo all’altra parte: è necessario anche comunicare che cosa è stato modificato, operazione che di solito viene svolta via e-mail o verbalmente. Questo approccio è imperfetto a causa della necessità di tenere traccia di tutte le richieste e confrontare manualmente i dati per decidere le modifiche al progetto o avviare una nuova analisi. Queste e altre sfide correlate possono essere superate grazie a Ansys CoDesigner, un’interfaccia per il trasferimento dei progetti di circuiti stampati tra i domini della progettazione PCB e della simulazione.

Questa funzionalità è disponibile quando sono installate l’estensione Ansys CoDesigner (per Altium Designer) e l’estensione Altium Link (per Ansys Electronics Desktop).

Software supportato

La seguente piattaforma di simulazione e le relative versioni sono attualmente supportate:

Ansys Electronics Desktop (AEDT) – versione 2023 R1, 2023 R2, 2024 R1, 2024 R2, 2025 R1, 2025 R2, 2026 R1

Installazione e configurazione

Per accedere ad Ansys CoDesigner in Altium Designer, deve essere installata l’estensione software Ansys CoDesigner. Questa estensione può essere installata o rimossa manualmente.

Per maggiori informazioni sulla gestione delle estensioni, fare riferimento alla pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Per accedere ad Ansys CoDesigner in Ansys Electronics Desktop, deve essere installata l’estensione Altium Link. Il processo è il seguente:

  1. Scaricare e decomprimere l’archivio dell’estensione Altium Link. Può essere ottenuto contattando ansyscollaboration@altium.com (specificare la versione AEDT utilizzata).

  2. Assicurarsi che l’applicazione AEDT sia chiusa.

  3. Nella cartella decompressa, individuare il file install_altiumlink.bat, fare clic con il pulsante destro su di esso e selezionare Run as administrator.

  4. Aprire AEDT e selezionare il comando Tools » Layout Links dai menu principali.

  5. Nella scheda Config della finestra di dialogo Layout Links che si apre, fare clic sul pulsante Add Link, passare alla cartella \AnsysEM\<version>\Win64 dei file di programma AEDT e aprire il file altiumlink.dll.

  6. Nella scheda Layout Links della finestra di dialogo Layout Links, assicurarsi che il collegamento Altium sia elencato e chiudere la finestra di dialogo.

Come funziona

Una volta aggiunta la funzionalità Ansys CoDesigner al software di progettazione PCB e di simulazione, è possibile trasferire le modifiche di progetto in entrambe le direzioni. Le modifiche di progetto vengono trasferite tramite un Altium 365 Workspace, che funge da ponte tra i due domini. Il vantaggio del trasferimento delle modifiche di progetto tramite un Workspace è che il processo di aggiornamento diventa stateless. Ciò significa che ciascuna parte può continuare a lavorare in modo indipendente; non è necessario preoccuparsi di a che punto sia l’altro team nel processo di progettazione/simulazione.

Ansys CoDesigner facilita il push/pull bidirezionale delle modifiche di progetto tra i due domini. Da Altium Designer, vengono rilevate e possono essere applicate in AEDT le modifiche allo stackup dei layer e ai materiali, ai componenti e alle primitive. Da AEDT, le modifiche proposte allo stackup dei layer e ai materiali possono essere inviate tramite il file EDB e rilevate/applicate in Altium Designer. Gli ingegneri ECAD e di simulazione possono comunicare tramite il sistema di commenti, con ogni thread di commenti associato a uno specifico componente di un progetto. I risultati della simulazione possono essere inviati da AEDT all’Altium 365 Workspace e associati a una revisione del progetto, con la possibilità di visualizzarli tramite l’interfaccia browser del Workspace e di visualizzarne un’anteprima all’interno di Altium Designer.

L’interfaccia di collaborazione

  • In Altium Designer, il pannello Ansys CoDesigner  viene utilizzato per eseguire Push e Pull delle modifiche di progetto in entrambe le direzioni e visualizzare i messaggi.

    Il pannello Ansys CoDesigner  è accessibile dall’editor PCB in Altium Designer facendo clic sul pulsante Panels in basso a destra nello spazio di progettazione e selezionando l’opzione Ansys CoDesigner  dal menu visualizzato. Si noti che per accedere al pannello è necessario essere connessi a un Workspace e che il documento PCB deve far parte di un progetto PCB archiviato in questo Workspace per poter utilizzare la funzionalità.

  • In AEDT, le finestre di dialogo accessibili dalla finestra di dialogo Layout Links (Tools » Layout Links) o dalla scheda Desktop della barra multifunzione quando un progetto è aperto vengono utilizzate per:
    • Connettersi al proprio Altium 365 Workspace e importare da esso un progetto PCB.
    • Inviare il progetto al Workspace e recuperarlo dal Workspace.
    • Esplorare la cronologia dello scambio dati tra Altium Designer e AEDT.
    • Aggiungere commenti ai componenti nel progetto.

Invio delle modifiche da Altium Designer

Per inviare il progetto da Altium Designer, fare clic sul pulsante Push nel pannello Ansys CoDesigner . Nella parte superiore del pannello viene visualizzata una finestra di modifica. Immettere un messaggio relativo alla modifica del progetto, quindi fare clic su Send. L’area Latest from Altium Designer del pannello Ansys CoDesigner  verrà aggiornata con i dettagli di questo invio.

Il progetto può quindi essere importato in AEDT. Per un progetto che è già stato importato, le modifiche possono essere recuperate in AEDT.

Si noti che quando si utilizza la funzionalità Ansys CoDesign, le informazioni sui modelli di simulazione (SPICE, IBIS, ecc.) vengono trasferite dagli schemi al PCB durante l’applicazione dell’Engineering Change Order. Utilizzare il tipo di confronto Changed Simulation Model nella scheda Comparator della finestra di dialogo Project Options e il tipo di modifica Change Component Simulation Model nella scheda ECO Generation della finestra di dialogo Project Options per configurare rispettivamente il rilevamento delle differenze nei modelli di simulazione tra schemi e PCB e la creazione di ECO per tali differenze.

Scopri di più su Keeping the Schematics & PCB Synchronized.

Push and Share per invitare un ingegnere di simulazione

Quando si fa clic su Push nel pannello Ansys CoDesigner , è anche possibile abilitare l’opzione Share sotto il campo Comment per inviare via e-mail un invito all’ingegnere di simulazione utilizzando la finestra di dialogo Share with a Simulation Engineer che si apre dopo aver fatto clic sul pulsante Send.

Immettere l’indirizzo e-mail dell’ingegnere di simulazione e una nota facoltativa (se necessaria), quindi fare clic sul pulsante Share . È possibile condividere con una persona che è già membro del team del proprio Workspace, con un altro utente Altium registrato all’interno o all’esterno della propria organizzazione, oppure con un utente che non dispone di un account Altium. Potrebbe comparire una finestra di dialogo di notifica per avvisare che l’utente il cui indirizzo e-mail è stato inserito potrebbe trovarsi al di fuori della propria organizzazione: fare clic su OK per invitarlo comunque.

Dopo un breve ritardo, apparirà un’altra finestra di dialogo per segnalare che l’invito è stato inviato correttamente.

Come parte del processo di invito:

  • Un utente che è già membro del team del proprio Workspace riceverà la condivisione del progetto con diritti di visualizzazione e riceverà un’e-mail di invito tramite la quale potrà accedere al progetto all’interno del Workspace.
  • Un utente che non è membro del team del proprio Workspace ma dispone di un account Altium (indipendentemente dal fatto che si trovi all’interno o all’esterno della propria organizzazione) verrà aggiunto come membro del team del Workspace e il progetto verrà condiviso con lui con diritti di visualizzazione. Riceverà un’e-mail di invito tramite la quale potrà accedere al progetto all’interno del Workspace.
  • Un utente senza account Altium riceverà un’e-mail che lo indirizzerà a un modulo intermedio per registrarsi/creare un account Altium. Verrà aggiunto come membro del team del Workspace al momento della registrazione e il progetto verrà condiviso con lui con diritti di visualizzazione.
  • L’invito può essere eseguito solo da un amministratore del Workspace.
  • L’ingegnere di simulazione non potrà importare il progetto della scheda in AEDT se il progetto non è condiviso con lui.
  • È necessario accedere al proprio Workspace nel browser e confermare che all’ingegnere di simulazione invitato sia stato assegnato Edit permissions nella finestra di dialogo del progetto Share . Sebbene l’ingegnere di simulazione sarà in grado di eseguire il Pull del progetto con i soli permessi di visualizzazione, non potrà eseguire il Push delle modifiche al progetto se the project non è condiviso con lui con permessi di modifica.
  • Si noti che l’utente che non dispone di un account Altium verrà trattato, al momento della registrazione, come se fosse una propria organizzazione personale. Non verrà aggiunto alla propria organizzazione.

Recupero delle modifiche in Altium Designer

Quando nuove modifiche vengono inviate da AEDT, il banner New changes have been detected viene visualizzato automaticamente nel pannello Ansys CoDesigner . Il pannello riporterà il nome dell’ingegnere di simulazione che ha eseguito il Push e il commento facoltativo immesso al momento del Push.

Quando si fa clic sul pulsante Pull e se il file EDB è stato incluso nel Push da AEDT, viene elencata ogni modifica che deve essere apportata al file di lavoro per sincronizzarlo con lo snapshot presente nel proprio Workspace. Ogni differenza rilevata è elencata nella lista Changes del pannello. Deselezionare la casella per ogni modifica che non si desidera applicare. Quando si è pronti, fare clic sul pulsante Apply per applicare tutte le modifiche abilitate al progetto.

Se i risultati della simulazione sono stati inclusi nel Push da AEDT, nel pannello verrà presentato il controllo Design Summary . Fare clic sul controllo per visualizzare i risultati della simulazione nella finestra di dialogo Design Summary.

I risultati della simulazione possono anche essere consultati nella vista del progetto nell’interfaccia browser di Altium 365, nella cartella Ansys dell’area Simulation .

Importazione di un progetto in AEDT

Per iniziare a lavorare su un progetto PCB in AEDT, è necessario prima importarlo in AEDT. Per farlo:

  1. Nella finestra di dialogo Layout Links (Tools » Layout Links), fare clic sulla cella [Action] per il collegamento Altium nella scheda Layout Links e selezionare Projects. In alternativa, fare clic sul pulsante Projects nella scheda Desktop della barra multifunzione quando un progetto è aperto. Si aprirà la finestra di dialogo Altium.
  2. Accedere al proprio account Altium. Assicurarsi che la voce Altium Account sia selezionata nel menu a discesa nella parte superiore della finestra di dialogo e fare clic sul pulsante Sign In. Si aprirà una pagina nel browser predefinito in cui sarà possibile inserire le credenziali del proprio account Altium o utilizzare SSO per accedere al proprio account Altium – mostra esempio.

    • Il metodo di autenticazione SSO è supportato in AEDT 2024 R1.
    • Quando si è connessi, utilizzare il pulsante Sign Out nella parte superiore della finestra di dialogo Altium per disconnettersi dall’account Altium attualmente connesso. 
  3. Selezionare il Workspace in cui si trova il progetto richiesto dall’elenco a discesa Workspace.
  4. Selezionare il progetto nell’elenco Projects e fare clic sul pulsante Import.

    Si noti che il progetto deve essere inviato da Altium Designer per essere disponibile per l’importazione.
  5. Salvare il file di progetto AEDT utilizzando la finestra di dialogo Save As che si apre, quindi chiudere la finestra di dialogo Altium.

  • Utilizzare il pulsante Refresh nella finestra di dialogo Altium per aggiornare la finestra con i dati più recenti dal Workspace connesso.
  • In una fase successiva, è possibile continuare a lavorare su un progetto importato riaprendo la propria copia di lavoro del progetto AEDT (File » Open).

Invio delle modifiche da AEDT

Per inviare il progetto da AEDT:

  1. Nella finestra di dialogo Layout Links (Tools » Layout Links), fare clic sulla cella [Action] per il collegamento Altium nella scheda Layout Links e selezionare Push/Pull. In alternativa, fare clic sul pulsante Push/Pull nella scheda Desktop della barra multifunzione quando il progetto è aperto.
  2. Utilizzare il campo Comment nella parte superiore della finestra di dialogo che si apre per aggiungere un commento che descriva che cosa è incluso nel Push.
  3. Abilitare le opzioni Include EDB file (per inviare le modifiche di progetto) e/o Include the Simulation Result (per inviare i risultati della simulazione).
  4. Fare clic sul pulsante Push to Altium 365. L’area Latest from Ansys della finestra di dialogo verrà aggiornata con i dettagli di questo invio.

L’invio verrà rilevato in Altium Designer e potrà essere recuperato in Altium Designer come descritto sopra.

Recupero delle modifiche in AEDT

Quando le modifiche di progetto sono state inviate da Altium Designer, possono essere recuperate in AEDT.

  1. Nella finestra di dialogo Layout Links (Tools » Layout Links), fare clic sulla cella [Action] per il collegamento Altium nella scheda Layout Links e selezionare Push/Pull. In alternativa, fare clic sul pulsante Push/Pull nella scheda Desktop della barra multifunzione quando il progetto è aperto.
  2. Controllare l’area Latest From Altium della finestra di dialogo che si apre per informazioni sull’ultimo Push da Altium Designer e fare clic sul pulsante Show Changes per aprire la finestra di dialogo in cui vengono descritte le differenze tra il progetto nel Workspace e il progetto corrente in AEDT. Utilizzare le caselle di controllo fornite nelle schede della finestra di dialogo per selezionare le modifiche che si desidera applicare al progetto in AEDT.

    Utilizzare il pulsante Refresh per aggiornare l’area Latest From Altium con i dati più recenti.
  3. Una volta esaminate le modifiche, fare clic sul pulsante Apply changes per applicare le modifiche al progetto in AEDT.

In tutte le versioni AEDT supportate, sarà necessario fare clic sul pulsante Apply changes in ogni scheda della finestra di dialogo EDB Diff, per recuperare le modifiche all in AEDT.

Esplorazione della cronologia degli scambi

La cronologia dei Push e dei Pull del progetto viene conservata.

Per esaminare la cronologia in Altium Designer, fare clic sul controllo History a destra del titolo dell’area Latest from the Ansys nel pannello Ansys Codesigner . Si aprirà l’elenco dei Push e Pull da Altium Designer e Ansys. Utilizzare il pulsante nella parte superiore del pannello per tornare alle modifiche più recenti.

Per esaminare la cronologia in AEDT, fare clic sulla cella [Action] per il collegamento Altium nella scheda Layout Links della finestra di dialogo Layout Links (Tools » Layout Links) e selezionare Push/Pull o Comment oppure fare clic sul pulsante Push/Pull o Comment  nella scheda Desktop della barra multifunzione. Selezionare la scheda History della finestra di dialogo che si apre. Espandere una voce di push/pull per visualizzarne i dettagli. Utilizzare il pulsante Refresh per aggiornare la scheda con i dati più recenti.

Aggiunta di commenti in Altium Designer e AEDT

Sia gli ingegneri elettrici sia quelli di simulazione possono beneficiare del supporto ai commenti del Workspace creando thread di commenti associati a componenti specifici.

In Altium Designer, i commenti esistenti sono disponibili tramite il pannello Comments and Tasks.

  • Per aggiungere un nuovo commento a un componente sul PCB, fare clic sul pulsante Comments nella parte superiore del pannello, posizionare il cursore su un componente nello spazio di progettazione in modo che venga evidenziato con un bordo blu, quindi fare clic. Nella finestra di inserimento del commento che si apre, digitare il commento e fare clic su Post.

  • Per rispondere a un commento, selezionare la voce del commento nel pannello Comments and Tasks, digitare la risposta nel campo di testo fornito nella finestra di inserimento del commento e fare clic su Reply. La risposta verrà aggiunta al thread di commenti.

Fare riferimento alla pagina Document Commenting per ulteriori informazioni.

In AEDT, i thread di commenti vengono gestiti tramite la scheda Comments della finestra di dialogo Altium accessibile facendo clic sulla cella [Action] per il collegamento Altium nella scheda Layout Links della finestra di dialogo Layout Links (Tools » Layout Links) e selezionando Comment. L’elenco nella parte superiore della finestra di dialogo mostra i thread di commenti esistenti per il progetto.

Per aggiungere un commento a un componente in AEDT:

  1. Selezionare un componente specifico nel pannello Components (View » Components) o nello spazio di progettazione.
  2. Nella finestra di dialogo Layout Links (Tools » Layout Links), fare clic sulla cella [Action] per il collegamento Altium nella scheda Layout Links e selezionare Comment.
  3. Digitare il commento nel campo Comment nella parte inferiore della finestra di dialogo che si apre. Fare clic sul pulsante Create Thread . Un nuovo thread verrà aggiunto all’elenco.

Per rispondere a un thread esistente da AEDT:

  1. Selezionare una voce di commento numerata nell’elenco della scheda Comments della finestra di dialogo Altium.
  2. Digitare la risposta nel campo Comment nella parte inferiore della finestra di dialogo.
  3. Fare clic sul pulsante Reply Thread . Una nuova risposta verrà aggiunta sotto la voce del thread di commenti correlato nell’elenco.

  • Una volta aggiunti, i nuovi thread e le risposte aggiunti da AEDT saranno disponibili nel pannello Comments and Tasks di Altium Designer.
  • Per aggiornare la scheda Comments della finestra di dialogo Altium con nuovi commenti e risposte aggiunti da Altium Designer, fare clic sul pulsante Refresh.
  • Abilitare l’opzione Unresolved Only nella finestra di dialogo Altium per nascondere dall’elenco i thread di commenti contrassegnati come risolti (in Altium Designer).
  • Utilizzare il menu del clic destro di una voce selezionata per un commento e un thread di commenti nella finestra di dialogo Altium per eliminare questa voce, selezionare il componente correlato o eseguire lo zoom sul componente nello spazio di progettazione.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contenuto