Ansys CoDesigner

高速回路やRF回路を備えた最新の電子製品は複雑であるため、PCB設計プロセスではPCBエンジニアとシミュレーションエンジニアの間で密接なコミュニケーションが必要であり、そのやり取りは双方にとってできるだけ明確かつ簡潔であるべきです。PCBエンジニアが変更した設計や、シミュレーションエンジニアが最適化した設計をエクスポートして相手に渡すだけでは十分ではありません。何が変更されたのかも伝える必要があり、通常はメールや口頭で行われます。この方法は、すべての依頼を追跡し、設計変更を判断したり新たな解析を開始したりするために手作業でデータを比較する必要があるため、不完全です。これらおよび関連する課題は、PCB設計領域とシミュレーション領域の間でプリント回路基板設計を受け渡すためのインターフェースであるAnsys CoDesignerによって解決できます。

この機能は、Ansys CoDesigner 拡張機能(Altium Designer用)およびAltium Link 拡張機能(Ansys Electronics Desktop用)がインストールされている場合に利用できます。

対応ソフトウェア

現在対応しているシミュレーションプラットフォームとそのバージョンは次のとおりです。

Ansys Electronics Desktop (AEDT) – バージョン 2023 R1、2023 R2、2024 R1、 2024 R2、 2025 R1、2025 R2、2026 R1

インストールと設定

Altium DesignerでAnsys CoDesignerにアクセスするには、Ansys CoDesigner ソフトウェア拡張機能をインストールする必要があります。この拡張機能は手動でインストールまたは削除できます。

拡張機能の管理の詳細については、 Extending Your Installation ページ(Altium Designer DevelopAltium Designer AgileAltium Designer)を参照してください。

Ansys Electronics DesktopでAnsys CoDesignerにアクセスするには、Altium Link 拡張機能をインストールする必要があります。手順は以下のとおりです。

  1. Altium Link拡張機能のアーカイブをダウンロードして展開します。これはansyscollaboration@altium.com に連絡することで入手できます(使用しているAEDTのバージョンを伝えてください)。

  2. AEDTアプリケーションが閉じていることを確認します。

  3. 展開したフォルダ内で install_altiumlink.bat ファイルを見つけて右クリックし、Run as administrator を選択します。

  4. AEDTを開き、メインメニューから Tools » Layout Links コマンドを選択します。

  5. 開いた Config ダイアログの Layout Links タブで、Add Link ボタンをクリックし、AEDTプログラムファイルの \AnsysEM\<version>\Win64 フォルダを参照して、altiumlink.dll ファイルを開きます。

  6. Layout Links タブの Layout Links ダイアログで、Altium リンクが一覧に表示されていることを確認し、ダイアログを閉じます。

動作の仕組み

Ansys CoDesigner 機能がPCB設計ソフトウェアとシミュレーションソフトウェアに追加されると、設計変更を双方向に受け渡しできるようになります。設計変更は、両領域の橋渡し役となる Altium 365 Workspace を介して受け渡されます。Workspace経由で設計変更を受け渡す利点は、更新プロセスが stateless になることです。つまり、各担当者はそれぞれ独立して作業を進めることができ、相手チームが設計/シミュレーションプロセスのどこまで進んでいるかを気にする必要がありません。

Ansys CoDesigner は、両領域間での設計変更の双方向Push/Pullを実現します。Altium Designerからは、レイヤースタックと材料、コンポーネント、およびプリミティブの変更が検出され、AEDTに適用できます。AEDTからは、レイヤースタックと材料への変更案をEDBファイル経由でPushし、Altium Designerで検出して適用できます。ECADエンジニアとシミュレーションエンジニアはコメントシステムを使ってコミュニケーションでき、各コメントスレッドは設計内の特定のコンポーネントに関連付けられます。シミュレーション結果はAEDTからAltium 365 WorkspaceにPushでき、設計のリビジョンに関連付けられます。これらはWorkspaceのブラウザインターフェースで表示でき、Altium Designer内でもプレビューできます。

コラボレーションインターフェース

  • Altium Designerでは、Ansys CoDesigner パネルを使用して設計変更のPush/Pullやメッセージ表示を行います。

    Ansys CoDesigner パネルは、Altium DesignerのPCBエディタで、デザインスペース右下の Panels ボタンをクリックし、表示されたメニューから Ansys CoDesigner  オプションを選択すると開けます。このパネルにアクセスするにはWorkspaceに接続している必要があり、さらにPCBドキュメントはこのWorkspaceに保存されたPCBプロジェクトの一部である必要があります。

  • AEDTでは、Layout Links ダイアログ(Tools » Layout Links)またはプロジェクトを開いたときにリボンの Desktop タブからアクセスする各ダイアログを使用して、次の操作を行います。
    • Altium 365 Workspaceに接続し、そこからPCB設計をインポートする。
    • 設計をWorkspaceにPushし、WorkspaceからPullする。
    • Altium DesignerとAEDT間のデータ交換履歴を確認する。
    • 設計内のコンポーネントにコメントを追加する。

Altium Designerから変更をPushする

Altium Designerから設計をPushするには、Ansys CoDesigner パネルで Push ボタンをクリックします。パネル上部に編集ウィンドウが表示されます。設計変更に関するメッセージを入力し、Send をクリックします。Ansys CoDesigner パネルの Latest from Altium Designer 領域が、このPushの詳細で更新されます。

その後、設計を AEDTにインポート できます。すでにインポート済みの設計については、変更を AEDTにPull できます。

Ansys CoDesign機能を使用する場合、Engineering Change Orderの適用時に、シミュレーションモデル(SPICE、IBISなど)に関する情報が回路図からPCBへ転送される点に注意してください。回路図とPCB間のシミュレーションモデルの差異を検出する設定には、Project OptionsダイアログのComparatorタブにある Changed Simulation Model 比較タイプを使用し、それらの差異に対するECOを作成する設定には、Project OptionsダイアログのECO Generationタブにある Change Component Simulation Model 変更タイプを使用します。

Keeping the Schematics & PCB Synchronized の詳細をご覧ください。

Pushして共有し、シミュレーションエンジニアを招待する

Ansys CoDesigner パネルで Push をクリックすると、Comment フィールドの下にある Share オプションを有効にして、Send ボタンをクリックした後に開く Share with a Simulation Engineer ダイアログを使用し、シミュレーションエンジニアに招待メールを送信することもできます。

シミュレーションエンジニアのメールアドレスと、必要に応じて任意のメモを入力し、Share ボタンをクリックします。共有相手は、すでにWorkspaceチームのメンバーであるユーザー、自組織内外の登録済みAltiumユーザー、またはAltiumアカウントを持っていないユーザーでも構いません。入力したメールアドレスのユーザーが組織外の可能性があることを知らせる通知ダイアログが表示される場合がありますが、その場合は OK  をクリックしてそのまま招待してください。

しばらくすると、招待が正常に送信されたことを示す別のダイアログが表示されます。

招待プロセスでは、次のようになります。

  • すでにWorkspaceチームのメンバーであるユーザーには、View権限でプロジェクトが共有され、Workspace内のプロジェクトにアクセスするための招待メールが送信されます。
  • WorkspaceチームのメンバーではないがAltiumアカウントを持っているユーザー(組織内外を問わず)は、Workspaceチームのメンバーとして追加され、View権限でプロジェクトが共有されます。Workspace内のプロジェクトにアクセスするための招待メールが送信されます。
  • Altiumアカウントを持っていないユーザーには、Altiumアカウントのサインアップ/登録用の中間フォームへ案内するメールが送信されます。サインアップ後、そのユーザーはWorkspaceチームのメンバーとして追加され、View権限でプロジェクトが共有されます。
  • 招待を実行できるのは、そのWorkspaceの管理者のみです。
  • プロジェクトが共有されていない場合、シミュレーションエンジニアはAEDTで基板設計をインポートできません。
  • ブラウザでWorkspaceにサインインし、招待したシミュレーションエンジニアに、プロジェクトの Edit permissions ダイアログで Share が割り当てられていることを確認してください。シミュレーションエンジニアはView権限だけでも設計をPullできますが、the project がEdit権限で共有されていない場合、設計変更をPushすることはできません。
  • Altiumアカウントを持っていないユーザーは、サインアップ後、自身の個人組織を持つユーザーとして扱われます。あなたの組織に追加されることはありません。

Altium Designerに変更をPullする

AEDTから新しい変更が PushされるとAnsys CoDesigner パネルに New changes have been detected バナーが自動的に表示されます。パネルには、Pushを実行したシミュレーションエンジニアの名前と、Push時に入力された任意コメントが表示されます。

Pull ボタンをクリックし、かつAEDTからのPushにEDBファイルが含まれている場合、Workspace上のスナップショットと同期させるために作業中ファイルへ適用する必要がある各変更が一覧表示されます。検出された各差異は、パネルの Changes リストに表示されます。適用したくない変更については、それぞれのチェックボックスをオフにしてください。準備ができたら、Apply ボタンをクリックして、有効なすべての変更を設計に適用します。

AEDTからのPushにシミュレーション結果が含まれている場合、パネルに Design Summary コントロールが表示されます。このコントロールをクリックすると、Design Summary ダイアログにシミュレーション結果が表示されます。

シミュレーション結果は、Altium 365のブラウザインターフェースにおけるプロジェクト表示でも、Simulation areaAnsys フォルダからアクセスできます。

設計をAEDTにインポートする

AEDTでPCB設計の作業を開始するには、まずAEDTにインポートする必要があります。手順は次のとおりです。

  1. Layout Links ダイアログ(Tools » Layout Links)で、Layout Links タブ上の Altium リンクの [Action] セルをクリックし、Projects を選択します。あるいは、プロジェクトを開いた状態でリボンの Desktop タブにある Projects ボタンをクリックします。すると、Altium ダイアログが開きます。
  2. Altiumアカウントにサインインします。ダイアログ上部のドロップダウンで Altium Account エントリが選択されていることを確認し、Sign In ボタンをクリックします。既定のブラウザでページが開き、Altiumアカウントの資格情報を入力するか、SSOを使用してAltiumアカウントにサインインできます。– show example

    • SSO認証方式は AEDT 2024 R1でサポートされています。
    • 接続後、現在接続されているAltiumアカウントからサインアウトするには、Altium ダイアログ上部の Sign Out ボタンを使用します。 
  3. 必要なプロジェクトが保存されているWorkspaceを、Workspace ドロップダウンリストから選択します。
  4. Projects リストでプロジェクトを選択し、Import ボタンをクリックします。

    インポート可能にするには、プロジェクトが Altium DesignerからPushされている 必要がある点に注意してください。
  5. 開いた Save As ダイアログを使用してAEDTプロジェクトファイルを保存し、その後 Altium ダイアログを閉じます。

  • Altium ダイアログの Refresh ボタンを使用すると、接続中のWorkspaceから最新データを取得してダイアログを更新できます。
  • 後で作業を再開する場合は、インポート済み設計のAEDTプロジェクトの作業コピー(File » Open)を再度開いて続行できます。

AEDTから変更をPushする

AEDTから設計をPushするには、次の手順を行います。

  1. Layout Links ダイアログ(Tools » Layout Links)で、Layout Links タブ上の Altium リンクの [Action] セルをクリックし、Push/Pull を選択します。あるいは、プロジェクトを開いた状態でリボンの Desktop タブにある Push/Pull ボタンをクリックします。
  2. 開いたダイアログ上部の Comment フィールドを使用して、Pushに含まれる内容を説明するコメントを追加します。
  3. Include EDB file(設計変更をPush)および/または Include the Simulation Result (シミュレーション結果をPush)オプションを有効にします。
  4. Push to Altium 365 ボタンをクリックします。ダイアログの Latest from Ansys 領域が、このPushの詳細で更新されます。

このPushはAltium Designerで検出され、上記の説明どおりAltium DesignerにPullできます。

AEDTに変更をPullする

設計変更が Altium DesignerからPushされると、AEDTでPullできます。

  1. Layout Links ダイアログ(Tools » Layout Links)で、Layout Links タブ上の Altium リンクの [Action] セルをクリックし、Push/Pull を選択します。あるいは、プロジェクトを開いた状態でリボンの Desktop タブにある Push/Pull ボタンをクリックします。
  2. 開いたダイアログの Latest From Altium 領域で、Altium Designerからの最新Pushに関する情報を確認し、Show Changes ボタンをクリックして、Workspace上の設計とAEDT内の現在の設計との差異を示すダイアログを開きます。ダイアログの各タブにあるチェックボックスを使用して、AEDTの設計に適用したい変更を選択します。

    Refresh ボタンを使用すると、Latest From Altium 領域を最新データで更新できます。
  3. 変更内容を確認したら、Apply changes ボタンをクリックして、その変更をAEDTの設計に適用します。

すべての 対応AEDTバージョン において、all の変更をAEDTにPullするには、EDB Diff ダイアログの各タブで Apply changes ボタンをクリックする必要があります。

交換履歴を確認する

設計のPush/Pull履歴は保持されます。

Altium Designerで履歴を確認するには、Ansys Codesigner パネルの Latest from the Ansys 領域タイトルの右側にある History コントロールをクリックします。Altium DesignerとAnsys 双方からのPush/Pull一覧が開きます。最新の変更に戻るには、パネル上部の ボタンを使用します。

AEDTで履歴を確認するには、Layout Links ダイアログ(Tools » Layout Links)の Layout Links タブで Altium リンクの [Action] セルをクリックし、Push/Pull または Comment を選択するか、リボンの Desktop タブにある Push/Pull または Comment  ボタンをクリックします。開いたダイアログの History タブを選択します。Push/Pullの各エントリを展開すると詳細を確認できます。Refresh ボタンを使用すると、最新データでタブを更新できます。

Altium DesignerとAEDTでコメントを追加する

電気設計エンジニアとシミュレーションエンジニアは、特定のコンポーネントに関連付けられたコメントスレッドを作成することで、Workspaceのコメント機能を活用できます。

Altium Designerでは、既存のコメントは Comments and Tasks パネルから利用できます。

  • PCB上のコンポーネントに新しいコメントを追加するには、パネル上部の Comments ボタンをクリックし、デザインスペース内のコンポーネントの上にカーソルを合わせて青い枠でハイライトされたらクリックします。開いたコメント入力ダイアログでコメントを入力し、Post をクリックします。

  • コメントに返信するには、Comments and Tasks パネルでコメントエントリを選択し、コメント入力ダイアログのテキストフィールドに返信内容を入力して Reply をクリックします。返信はそのコメントスレッドに追加されます。

詳細については、 Document Commenting ページを参照してください。

AEDTでは、コメントスレッドは Layout Links ダイアログ(Tools » Layout Links)の Layout Links タブで Altium リンクの [Action] セルをクリックし、Comment を選択して開く Altium ダイアログの Comments タブで管理します。ダイアログ上部の一覧には、プロジェクトの既存のコメントスレッドが表示されます。

AEDTでコンポーネントにコメントを追加するには、次の手順を行います。

  1. Components パネル(View » Components)またはデザインスペースで特定のコンポーネントを選択します。
  2. Layout Links ダイアログ(Tools » Layout Links)で、Layout Links タブ上の Altium リンクの [Action] セルをクリックし、Comment を選択します。
  3. 開いたダイアログ下部の Comment フィールドにコメントを入力します。 Create Thread ボタンをクリックします。新しいスレッドが一覧に追加されます。

AEDTから既存スレッドに返信するには、次の手順を行います。

  1. Altium ダイアログの Comments タブで、一覧内の番号付きコメントエントリを選択します。
  2. ダイアログ下部の Comment フィールドに返信を入力します。
  3. Reply Thread ボタンをクリックします。関連するコメントスレッドのエントリの下に、新しい返信が一覧表示されます。

  • 追加後、AEDTから追加された新しいスレッドと返信は、Altium Designerの Comments and Tasks パネルでも利用可能になります。
  • Altium Designerから追加された新しいコメントと返信で Altium ダイアログの Comments タブを更新するには、Refresh ボタンをクリックします。
  • 解決済みとしてマークされたコメントスレッド(Altium Designerで設定)を一覧から非表示にするには、Altium ダイアログで Unresolved Only オプションを有効にします。
  • Altium ダイアログ内のコメントまたはコメントスレッドの選択エントリで右クリックメニューを使用すると、そのエントリの削除、関連コンポーネントの選択、またはデザインスペース内でそのコンポーネントへのズームが行えます。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content