回路図とPCBの同期の保持
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- 双方向比較と直接更新のワークフローの違い、およびそれぞれを使用する場面を学びます。
- コンポーネント、接続情報、クラス、一部の設計ルールなど、Altium Designerで回路図とPCBの間で同期できる内容を理解します。
- 比較機能(Comparator)やECO生成(ECO Generation)の設定などのプロジェクトオプションが、同期処理や適用可能な変更にどのように影響するかを確認します。
回路図からPCBへの設計作業で最も一般的なのは、回路図とPCBの整合性を維持すること、つまり同期を保つことです。作成した設計を初めて新しいPCBに転送する場合でも、既存の設計の回路図側またはPCB側を変更する場合でも、両者を同期させる手段が必要です。Altium Designerには強力な設計同期機能が備わっており、設計の同期を維持する作業を簡素化することで、設計者が設計プロセスの創造的な側面に集中できるようにします。
同期プロセスでは、回路図とPCBの差異を検出し、解消します。
設計の同期は回路図エディターとPCBエディターの間で直接実行され、ネットリストのような中間ドキュメントは使用しません。ソフトウェアは比較エンジンを使用して設計のあらゆる側面を比較し、その結果を差異のリストとして出力します。設計者が差異を解消するためにどちら側を変更するかを決定すると、一連の設計変更指示(ECO)が作成されます。これらを適用すると、設計の両側が再び同期した状態になります。
同期できる内容
同期プロセスにより、回路図の部品データおよび接続データが、PCBの部品データおよび接続データと一致するようになります。部品データと接続データに加えて、ネットクラス、部品クラス、設計ルールなどのその他の設計制約も同期されます。
比較オプションの設定
Dialog page: Options for PCB ProjectのComparatorタブ
比較する回路図とPCBのデータのwhat詳細は、Options for PCB ProjectダイアログのComparatorタブで設定します。Project » Project Optionsを選択してダイアログを開きます。

比較エンジンは、Options for ProjectダイアログのComparatorタブで定義された設定に従います。
ダイアログのメイン領域には、Different DesignatorsやChanged Net Nameなど、5つのカテゴリに分類された比較タイプの一覧が表示されます。右側のMode列には各項目のドロップダウンがあり、Find DifferencesやIgnore Differencesなどの比較モードを選択できます。テキスト形式の比較には、大文字と小文字を区別せずに比較するための3つ目のオプションがあります。
新しいプロジェクトでは、すべての比較タイプで差異を検出するように初期設定されています。プロジェクトの要件に合わせてオプションを設定してください。
ダイアログの下部には、Object Matching Criteriaを設定するためのオプションがあります。照合は、単純な文字列の完全一致には依存しない、高度な複数段階のプロセスです。詳細については、ネットとクラスの照合 セクションを参照してください。
ダイアログ下部のIgnore Rules Defined in the PCB Onlyオプションに注目してください。これを有効にすると、PCBで定義したルールを比較プロセスから除外できます。
ネットクラスと部品クラスの同期
Dialog page: Options for PCB ProjectのClass Generationタブ
Design » Update PCBを実行すると、部品データと接続データに加えて、クラスと設計ルールも生成および同期できます。
設計ルールの同期
設計ルールは、パラメーターセットオブジェクトを使用して回路図で定義できます。パラメーターセットオブジェクトを選択すると、PropertiesパネルまたはモーダルダイアログにRules領域が表示されます。Addドロップダウンをクリックして、設計ルールを追加します。ルールは、パラメーターセットオブジェクトが接触しているネット/バス/ハーネス、またはブランケットの下にあるオブジェクトに適用されます。
下図では、幅制約の設計ルールがUSB_dataネットクラスに適用されています(このネットクラスも、Parameters ドロップダウンのClasses領域で、このパラメーターセットの一部として定義されています)。

パラメーターセットを使用して、回路図のブランケットオブジェクトの下にあるネットに対し、ネットクラスと設計ルールを定義します。必要な測定単位は、Edit PCB Ruleダイアログの下部で設定することに注意してください。
回路図での設計ルールの追加
- ネット/バス/ハーネス/ブランケットにパラメーターセットを接続します(必要に応じて、パラメーターセットにネットクラスの定義を追加します)。
- Addパラメーターセットにルール定義を追加します。これにより、上図のようにChoose Design Rule Typeダイアログが開きます。
- 必要なRule Typeを選択します。
- OKボタンをクリックして、Edit PCB Ruleダイアログを開きます。
- 必要に応じてPCBルールの要件を設定します。このPCBルールに必要な測定単位は、ダイアログの下部で選択することに注意してください。
上図と下図のどちらでも、設計ルールはブランケットに接続されたパラメーターセットオブジェクトで定義されています。パラメーターセットオブジェクトにクラス定義を含めると、PCBネットクラスも作成されます。また、クラス定義が存在するため、PCBルールの適用範囲はInNetClass('<PCB_NetClassName >')に設定されます。
下図では、パラメーターセットオブジェクトが差動ペアディレクティブとして表示されています。これは、Place » Directives » Differential Pairコマンドを使用して配置する、特殊なタイプのパラメーターセットオブジェクトです。

差動ペアディレクティブを使用してネットクラスと設計ルールを定義し、それらを対象の差動ペアに適用します。
ECO生成オプションの設定
Options for Project ダイアログには、ECO生成 タブもあります。このタブでは、ECOを作成できる設計変更の種類を定義します。通常はこれらをすべて有効にし、ダイアログの 比較 タブのオプションを使用して、回路図とPCBの間で同期する設計変更を設定します。

ECO生成タブでは、ECOを作成できる変更の種類を定義します。
差分の検出
設計同期機能では、回路図からPCBへ、またはPCBから回路図へという双方向の差分を検出し、解消できます。
ソフトウェアでは、両側に変更を同時に適用して、これらの差分を解消できます。たとえば、回路設計者がコンデンサの値を変更し、PCB設計者が同じコンデンサのフットプリントを変更した場合を考えてみましょう。この2つの差分は、コメントの変更を回路図からPCBへの更新として適用し、フットプリントの変更をPCBから回路図への更新として適用することで、1回の更新処理で解消できます。
比較エンジンが回路図プロジェクトとPCBを比較すると、差分の完全な一覧が作成されます。この段階では、同期を回復するためにどちら側を変更すべきかは決定されていません。
差分の一覧は、Differences between ダイアログで確認できます。
Differences betweenダイアログのオプションとコントロール
このダイアログは、主に Differences、 Update、 Change Order の3つの領域に分かれています。
差分
この領域には、選択したドキュメント間で比較機能が検出したすべての差分が表示されます。各差分は、その差分が存在するドキュメントの列に表示されます。差分は、Project Options ダイアログの 比較タブ に表示され、有効になっている比較タイプごとにグループ化されます。グループレベルの項目には、そのタイプの差分数が表示されます。
項目をダブルクリックすると、該当するソースドキュメント上のオブジェクトにクロスプローブできます。
更新
この領域では、差分を解消するために更新するドキュメントを指定します。デフォルトでは、すべての Decision 項目に、初期設定として No Change が適用されます。
各差分の更新方法は、Decision 列の該当項目をクリックし、続いて表示される ECO Decisionダイアログ で必要な更新操作を選択することで、個別に指定できます。更新方向(比較対象のどちらのドキュメントを更新するか)を選択するか、更新を行わない場合は No Updates を選択します。
変更指示
この領域には、対処することを決定した差分ごとに、実行する操作、その操作の対象となるオブジェクト、および操作を実行するドキュメントが表示されます。この情報を基に、更新を実施するためのECOが作成されます。この領域に表示される主な操作は次のとおりです。
- Remove - 差分の原因となっているオブジェクトを含むドキュメントの方向に更新する場合、そのオブジェクトは削除されます。
- Add - 差分の原因となっているオブジェクトを含まないドキュメントの方向に更新する場合、そのオブジェクトは追加されます。
- Update - 両方のドキュメントに同じオブジェクトがあり、その内容に何らかの差分がある場合、選択した方向に応じて変更対象のオブジェクトが決まります。
右クリックメニュー
- Create Change Order - 設計変更指示(ECO)を作成します。
- Generate Report - 比較機能が検出した差分のレポートを生成します。生成されるECOには、指定した更新方法と操作が含まれます。レポートは Report Preview ダイアログに読み込まれます。このダイアログでレポートを確認してから、サポートされている各種形式のいずれかにエクスポートするか、直接印刷できます。
- << Update All in - すべての差分の更新方向を、左側のドキュメントに設定します(適用可能な場合)。
- Update All in >> - すべての差分の更新方向を、右側のドキュメントに設定します(適用可能な場合)。
- Reverse Direction For All - すべての差分の更新方向をすばやく反転します(適用可能な場合)。差分の更新方向を変更できない場合、その項目は No Change に設定されます。
- Set No Action For All - すべての差分の更新方法を、すばやく No Change に設定します。
- << Update Same Kind in - 現在フォーカスされている差分と同じ比較タイプのすべての差分について、更新方向を左側のドキュメントに設定します(適用可能な場合)。
- Update Same Kind in >> - 現在フォーカスされている差分と同じ比較タイプのすべての差分について、更新方向を右側のドキュメントに設定します(適用可能な場合)。
- Reverse Direction For Same Kind - 現在フォーカスされている差分と同じ比較タイプのすべての差分について、更新方向をすばやく反転します(適用可能な場合)。差分の更新方向を変更できない場合、その項目は No Change に設定されます。
- Set No Action For Same Kind - 現在フォーカスされている差分と同じ比較タイプのすべての差分について、更新方向を No Change にすばやく設定します。
- << Update Selected in - 選択したすべての差分について、更新方向を左側のドキュメントに設定します(適用可能な場合)。
- Update Selected in >> - 選択したすべての差分について、更新方向を右側のドキュメントに設定します(適用可能な場合)。
- Reverse Direction For Selected - 選択したすべての差分について、更新方向をすばやく反転します(適用可能な場合)。差分の更新方向を変更できない場合、その項目は No Change に設定されます。
- Set No Action For Selected - 選択したすべての差分について、更新の判断を No Change にすばやく設定します。
- Invert Selection - リスト内で現在選択されていないすべての差分を選択し、選択されている差分の選択を解除します。
その他のコントロール
ダイアログの下部には、次のボタンがあります。
- Create Engineering Change Order - このボタンをクリックすると、ECO が生成されます。Engineering Change Order ダイアログが表示され、更新内容を検証して実行し、ドキュメントを同期できます。
- Report Differences - このボタンをクリックすると、Comparator が検出した差分のレポートが生成されます。指定した更新の判断とアクションは、生成される ECO に含まれます。レポートは Report Preview ダイアログに読み込まれます。このダイアログでレポートを確認してから、サポートされている各種形式にエクスポートするか、直接印刷できます。
- Explore Differences - このボタンをクリックすると、ECO を生成する前に、Comparator が検出した差分をさらに詳しく調べることができます。Differences between ダイアログが閉じ、Differences パネル が開いた状態でメインワークスペースに戻ります。パネルには、Comparator が列挙したすべての差分が、同じカテゴリに分類されて表示されます。このパネルを使用すると、差分の原因となっているオブジェクトを、そのオブジェクトが属するドキュメント上でクロスプローブできます。
Difference between ダイアログを開いて差分のリストを表示するには:
-
下の画像に示す Choose Documents to Compare ダイアログを開くには、Project » Show Differences コマンドを実行するか、Projects パネルで対象のプロジェクト(またはそのソースドキュメントのいずれか)の項目を右クリックし、コンテキストメニューから Show Differences コマンドを選択します。Choose Documents to Compare ダイアログでは、比較する 2 つのドキュメントまたはドキュメントセットを選択します。通常は、回路図プロジェクトと PCB を比較します。また、Advanced Mode オプションをオンにすると、任意のドキュメント同士を比較できます。たとえば、ネットリストと PCB、または PCB 同士を比較できます。
通常、ソースドキュメントとターゲットの PCB 設計を同期するために比較する場合は、基本モードでも詳細モードでも、ダイアログのデフォルト設定でほとんどの設計比較のニーズに対応できます。このダイアログでは他のドキュメントも比較できるため、プロジェクトの異なるバージョンを読み込み、対応するソースドキュメント間の差分を比較する際にも役立ちます。

回路図プロジェクトと比較する PCB を選択します。 - ダイアログのメイン領域で PCB を選択し、OK をクリックすると、下に示す Difference between ダイアログが開きます。PCB ドキュメントがすでにソースドキュメントと同期されている場合は、差分が検出されなかったことを知らせるダイアログが表示されます。
Differences between ダイアログが開きます。Synchronizer は双方向に対応しています。つまり、同じ ECO 内で両方のドキュメントへの更新を指定できます。比較したドキュメントを同期するには、各差分について、アクションを実行するかどうかと、どちらの方向に変更するかを決める必要があります。つまり、差分を解消するためにどちらのドキュメントを更新するかを指定します。そのため、次のステップでは各差分に更新方向を割り当てます。
- 個々の差分については、Update 列をクリックすると、下の画像に示すように方向セレクターが表示されます。
- 同じ種類の複数の差分については、「フットプリントの相違」などの見出しを右クリックし、必要な Update Same Kind コマンドを選択します。
- すべての差分については、ダイアログ内の任意の場所を右クリックし、必要な Update All コマンドを選択します。

各差分を解消するための ECO を作成するには、その差分の更新方向を設定する必要があります。
Explore Differences ボタンをクリックすると、Differences パネルにアクセスし、以下の Differences パネルを使用した設計変更の確認 セクションで説明する方法で差分を調べることができます。
Report Differences をクリックすると、Comparator が検出した差分、指定した更新の判断、および生成される ECO に含まれるアクションのレポートを設定し、印刷またはエクスポートできます。
更新方向を割り当てたら、Create Engineering Change Order ボタンをクリックして Engineering Change Order ダイアログを開きます。このダイアログについては、以下の 差分の解消 - ECO の適用 セクションで説明します。
Differences パネルを使用した設計変更の確認

Differences パネルには、ドキュメント間の差分が階層表示されます。
概要
Differences パネルは、ソフトウェアに内蔵された差分コンパレーターが設計ドキュメントを比較した際に検出した、論理的または物理的な差異を表示するために使用します(たとえば、プロジェクトのソースドキュメント階層(回路図)とPCB設計ドキュメントを比較する場合など)。このパネルでは、プロジェクトのドキュメントを同期するための設計変更指示(ECO)を作成するかどうかを決定する前に、差異を対話的に確認できます。
パネルへのアクセス
Differences パネルを開くには:
- メインメニューから View » Panels » Differences を選択します。
- 設計ワークスペースの右下にある Panels ボタンをクリックし、続いて Differencesをクリックします。
差異の表示
Differences パネルの使用方法は、目的が次のどちらであるかによって異なります。
- プロジェクト階層内の論理的な差異を検出し、内容と構造の観点からプロジェクト全体の整合性を分析する。
- 同じ回路図ドキュメントまたはPCBドキュメントの2つのバージョンを比較し、グラフィカルな(物理的な)差異を検出する。
論理的な差異の表示
プロジェクトドキュメントの論理的な差異の比較は、Choose Documents To Compareダイアログで行います。このダイアログは、Projectsパネルでプロジェクト(またはプロジェクトドキュメント)を右クリックし、表示されるコンテキストメニューからShow Differencesを選択すると開きます。

プロジェクト名を右クリックし、Show Differencesを選択してChoose Documents To Compareダイアログを開きます。
通常は、PCBドキュメントと親プロジェクトのソースドキュメント階層を比較し、回路図設計の内容とPCB設計の内容の間にある論理的な差異を検出します。
OKをクリックした後、指定したドキュメント間に差異がある場合は、差異の比較対象ダイアログが開きます。Differences パネルに情報が表示されるのは、Differences betweenダイアログのExplore Differences ボタンをクリックした後です。
Differences パネルには、Differences betweenダイアログに一覧表示されている差異のみが表示されます。これらの差異は、Project Options ダイアログ(Project » Options)のComparatorタブで行った選択によって決まります。このタブには、コンポーネント、ネット、パラメーターに関連する差異など、すべての比較タイプが一覧表示されます。各比較カテゴリのModeをFind DifferencesまたはIgnore Differencesに設定することで、差分コンパレーターの結果をDifferences between ダイアログに渡すかどうかが決まります。

Project Options ダイアログで、差異の検出方法と報告方法を設定します。
Differences パネルには、ソースドキュメント間で検出された差異がツリー構造で表示され、最上位のフォルダーには検出された差異の総数が表示されます。その下には、差異の比較対象ダイアログに表示される比較タイプごとにサブフォルダーが作成されます。各サブフォルダーには、検出された具体的な差異が一覧表示され、さらに、それらの差異の原因となっているドキュメント上のオブジェクトに細分化されます。
関連するドキュメントが開いている場合(開いているものの非表示になっている場合も含む)、パネル内のオブジェクト項目をクリックすると、ドキュメント上の該当オブジェクトにクロスプローブします。
オブジェクトの表示にはズームと減光効果が使用され、ほかのすべてのオブジェクトを暗くすることで、対象のオブジェクトが強調表示されます。減光のコントラストは、Preferences ダイアログのSystem - NavigationページにあるHighlight Methods領域の Dimming スライダーで調整できます。
物理的な差異の表示
同じ回路図ドキュメントまたはPCBドキュメントの2つのバージョンをグラフィカルに(物理的に)比較する場合も、基本的には前述の論理比較と同じ方法で行いますが、Choose Documents To CompareダイアログのAdvanced Modeも使用します。
ドキュメントの物理比較を行うには、Show Differencesコマンド(Projectsパネルの右クリックメニュー)を使用してChoose Documents To Compareダイアログを開き、Advanced Modeチェックボックスをオンにします。ダイアログにすべてのプロジェクトファイルが表示されたら、比較するドキュメントの2つのバージョンを選択します。

Advanced ModeのChoose Documents To Compareダイアログで、物理比較するドキュメントを選択します。
OKをクリックするとグラフィカルな比較が実行され、前述のとおり差異の比較対象ダイアログが開きます。 Explore Differencesをクリックすると、Differencesパネルに対話的な差異の一覧が表示されます。
パネルには、ドキュメント間で検出された差異がツリー構造で表示されます。最上位のフォルダーには、検出された差異の総数が表示されます。差異の種類ごとに項目が作成され、その中に各差異の具体的な参照情報と、関連するオブジェクト(ポート、部品など)が表示されます。
検出された差異のオブジェクト項目を選択すると、エディターの設計領域で対象のオブジェクトが強調表示され、ズーム表示されます。
注記
- パネル内のオブジェクトが現在非表示のドキュメント上にある場合、関連する項目をクリックすると、そのドキュメントが自動的に開かれ、設計エディターウィンドウのアクティブなドキュメントになります。
- Differences パネルからのクロスプローブ時に適用されるフィルターは一時的なものです。そのため、フィルターの範囲外にある設計オブジェクトも選択や編集が可能です。
- 新しいドキュメント比較を実行するか、親プロジェクトをコンパイルすると、Differences パネルの情報はクリアされます。
- メインメニューの Project » Show Physical Differencesコマンドを使用すると、回路図ドキュメントまたはPCBドキュメントの2つのバージョン間にある物理的な差異を検出し、設計領域に2つのドキュメントを並べて表示して、その差異をグラフィカルに確認できます。 この物理的な差異の表示機能は、視覚的な比較のみを提供するもので、比較対象のどちらのドキュメントもECOの生成によって更新することはできません。同じドキュメントの2つのバージョンを比較するための機能ですが、プロジェクトのソース階層とPCBなど、異なるドキュメントを比較した場合は、Differences パネルが表示され、検出された論理的な差異が一覧表示されます。
直接更新の実行
通常、設計者は更新をどちらの方向に適用するかを把握しており、すべての更新を同じ方向に適用するため、ここまで説明した差異の検出と更新方向の指定の手順を省略することもできます。
ProjectメニューからShow Differences コマンドを選択する代わりに、回路図エディターまたはPCBエディターのDesignメニューからUpdateコマンドを選択します。コマンドを実行するエディターによって、変更を反映する方向、つまりthisエディターからthatエディターへの方向が決まります。たとえば、回路図のすべての変更をPCBに反映するには、回路図エディターでDesign » Updateを選択します。
Differences betweenダイアログはスキップされ、Engineering Change Orderダイアログに直接進みます。
すべての更新を同じ方向に適用する場合は、Design » Updateコマンドを使用します。
差異の解決 - ECOの適用
各差異は、設計変更指示(ECO)を適用することで解決します。ECOはEngineering Change Orderダイアログに1行ずつ表示され、それぞれにEnableチェックボックスがあります。
Engineering Change Orderダイアログを使用する場合:
- ダイアログを開くと、すべての変更が有効になっています。現時点で保留したい変更は無効にしてください。このダイアログは複数選択に対応しており、右クリックのコンテキストメニューを使用して、選択したECOの有効/無効を切り替えられます。
- 右クリックメニューのCross Probeコマンドを使用すると、そのECOの影響を受けるオブジェクトを確認できます。
- Validate Changesボタンを使用して、変更を実行できるか確認します。ECOが失敗する一般的な原因は、オブジェクトが利用できないことです。たとえば、指定されたPCBフットプリントが利用可能なファイルベースのライブラリに存在しない、または指定されたパッドがフットプリント上に存在しない場合などです。
- 特定のECOに必要なオブジェクトが当初は存在せず、現在のECOの処理中に追加された場合にも、ECOが失敗することがあります。この場合は、Updateコマンドを再度実行して、そのECOを完了してください。

各設計変更はECOとして表示されます。必要なものを有効にしてください。
Engineering Change Orderダイアログのオプションとコントロール
このダイアログは、ModificationsとStatusの2つの主要な領域に分かれています。
変更内容
この領域には、同期に必要な変更を実施するためのすべての変更項目が表示されます。変更項目は、Project Options - ECO Generationダイアログで一覧表示され、有効になっている変更タイプごとにグループ化されます。グループレベルの項目には、そのタイプの変更件数が表示されます。この領域の各変更項目には、次の情報が表示されます。
- Enable - ECOの実行時に、その変更を含めるかどうかを指定するオプションです。チェックボックスを直接クリックすると、有効/含める(チェックあり)と無効/除外する(チェックなし)を切り替えられます。スペースキーを使用して、Enableチェックボックスのオン/オフを切り替えることもできます。
- Action - 実行する具体的な操作です。操作の種類は、実施するECOの種類によって異なります。
- Affected Object - 操作の対象となるオブジェクトです。
- Affected Document - 操作を実行するドキュメントです。
右クリックメニュー
デフォルトでは、すべての変更項目が有効になっており、ECOの実行対象に含まれます。必要に応じて各変更項目を個別に有効/無効にするか、右クリックメニューの次のコマンドを使用して、複数の変更項目の有効/無効を切り替えます。
- Validate Changes - クリックすると、ECOの実行対象として有効になっている変更項目の検証を実行します。検証結果は、ダイアログのStatus 領域にあるCheck 列に表示されます。
- Execute Changes - クリックすると、ECOを実行します。実行結果は、ダイアログのStatus 領域にあるDone 列に表示されます。検証に合格した変更のみが実行されることに注意してください。
- Create Report - クリックすると、ECOに含まれる変更項目のレポートを生成します。レポートはReport Previewダイアログに読み込まれます。
- Cross Probe - クリックすると、関連する回路図およびPCBドキュメント上で、変更操作に関わる対象オブジェクトと参照オブジェクトにクロスプローブします。
- Expand All - クリックすると、リスト内のすべての変更項目を展開して表示します。
- Contract All - クリックすると、リスト内のすべての変更項目を折りたたんで表示します。
- Enable All - すべての変更項目を有効にします。
- Disable All - すべての変更項目を無効にします。
- Enable Selected - 選択したすべての変更項目を有効にします。
- Disable Selected - 選択したすべての変更項目を無効にします。
- Enable all of same Kind - 現在フォーカスされている変更項目と同じ変更タイプのすべての変更項目を有効にします。
- Disable all of same Kind - 現在フォーカスされている変更項目と同じ変更タイプのすべての変更項目を無効にします。
- Invert Selection - リスト内で現在選択されていないすべての変更項目を選択し、選択されている項目の選択を解除します。
ステータス
この領域には、有効になっている各変更項目について、次のステータス情報が表示されます。
-
Check - このフィールドには、変更項目の検証結果が表示されます。緑色のチェックマーク(
)は、提案された変更がサポートされており、ECOの実行時に適用されることを示します。赤色の×印(
)は、提案された変更が無効であり、ECOの実行時に適用されないことを示します。
-
Done - このフィールドには、変更の実行結果が表示されます。緑色のチェックマーク(
)は、有効な変更が正常に実行されたことを示します。
- Message - 変更が検証段階で不合格になった場合、このフィールド(およびMessagesパネル)に、その原因を示す項目が表示されます。
その他の操作
ダイアログの下部と右クリックメニューでは、次の操作を利用できます。
- Validate Changes - クリックすると、ECOに含めるように有効化された変更の検証チェックを実行します。検証結果は、ダイアログのStatus 領域にあるCheck 列に表示されます。
- Execute Changes - クリックするとECOを実行し、そこに含まれる有効な変更を適用します。実行結果は、ダイアログのStatus 領域にあるDone 列に表示されます。検証段階に合格した変更のみが実行されることに注意してください。
- Report Changes - クリックすると、ECOに含まれる変更のレポートを生成します。レポートはReport Previewダイアログに読み込まれます。
- Only Show Errors - このオプションをオンにすると、Engineering Change Orderのエラーのみが表示されます。検証済みの変更は表示されません。エラーの一覧のみを表示することで、内容をすばやく確認し、生成されるECOがすべて検証に合格するよう、設計に必要な変更を加えることができます。
回路図とPCBのリンクについて
一意の識別子によるコンポーネントの対応付け
各回路図コンポーネントは、一意の識別子(UID)を介してPCBコンポーネントにリンクされます。UIDは回路図コンポーネントをシートに配置したときに割り当てられ、設計をPCBエディターに転送する際に、この値がPCBコンポーネントに引き継がれます。Synchronizerを使用して、回路図のソースドキュメントから空のPCB設計ドキュメントへコンポーネント情報を初めて転送すると、すべてのコンポーネントが一意のIDによって自動的にリンクされます。このとき、各回路図コンポーネントのID情報が、対応するコンポーネントフットプリントに割り当てられます。
この仕組みは単純な設計には十分ですが、マルチチャネル設計には対応できません。マルチチャネル設計では、同じ回路図コンポーネントが各物理チャネルで繰り返し使用されるため、繰り返し配置されるPCBコンポーネントが同じUIDを持つことになります。これに対応するため、PCBコンポーネントのUIDは、親シートシンボルのUIDと回路図コンポーネントのUIDを組み合わせて生成されます。PCBのUIDの構文は、マルチチャネル設計の作成方法によって若干異なります。
同じ回路図シートを参照する複数のシートシンボルを配置して作成したマルチチャネル設計では、各シートシンボルが一意のIDを持つため、PCBのUIDは次の形式になります。
\SheetSymbolUID\SchComponentUID
Repeatキーワードを使用して作成したマルチチャネル設計では、使用できるシートシンボルのUIDが1つしかないため、PCBのUIDにはChannelIndexの値も含まれ、次の形式になります。
\ChannelIndex+SheetSymbolUID\SchComponentUID
コンポーネントがリンクされていない場合
UIDを使用して回路図とPCBのコンポーネントを対応付ける利点は、デジグネーターが非同期の状態になっても(例えば、PCBでリアノテーションを何度か実行した場合)、回路図とPCBを再同期できなくなるリスクがないことです。
回路図またはPCBに存在するコンポーネントに対し、もう一方のエディターに対応するコンポーネント(同じUIDを持つコンポーネント)が存在しない場合、次のように処理されます。
- 余分なコンポーネントがソースエディターにのみ存在する場合、そのコンポーネントをターゲットエディターに追加するECOが生成されます。
- 余分なコンポーネントがターゲットエディターにのみ存在する場合、そのコンポーネントを削除するECOが生成されます。
- 両方のエディターに対応付けられていないコンポーネントが存在する場合、ソフトウェアはそれらの処理方法について指示を必要とするため、Failed to Match Unique Identifiersダイアログが開きます。
e Failed to Match Unique Identifiers ダイアログ
ダイアログの各ボタンでは、次の操作を選択できます。
- Automatically Create Component Links - 対応付けられていないコンポーネントのデジグネーターがすでに一致していることがわかっている場合は、このボタンをクリックします。ソフトウェアはコンポーネントのデジグネーターを使用して、これらの余分なコンポーネントに一致するUIDを割り当てます。デジグネーターによって対応付けできるコンポーネントについては、その他のプロパティに相違がある場合(パラメーターの不一致など)、ECOが生成されます。デジグネーターで対応付けできないコンポーネントがある場合は、それらを追加または削除するECOが生成されます(ソースエディターに存在する余分なコンポーネントは追加され、ターゲットエディターに存在する余分なコンポーネントは削除されます)。
-
Manual Component Links - 対応するコンポーネントが存在することはわかっていても、それらのデジグネーターの状態が不明な場合は、このボタンをクリックします。Edit Component Linksダイアログ(後述)が開き、ソースとターゲットの各コンポーネントを手動で選択して、対応付け済みコンポーネントの一覧に移動し、一致するUIDを割り当てることができます。その後、デジグネーター(およびその他の一致していないコンポーネントプロパティ)を同期するECOが生成されます。
- Cancel - このボタンをクリックすると、ソースエディターに存在する余分なコンポーネントを追加し、ターゲットエディターから余分なコンポーネントを削除するECOが生成されます。
コンポーネントを手動でリンクする
回路図コンポーネントと、対応するPCBコンポーネントフットプリントとのリンク状態は、Edit Component Linksダイアログ(PCBエディターのProjects » Component Linksコマンド)でいつでも確認、管理できます。

Edit Component Linksダイアログは、UIDの不一致を検出して解消するために使用し、PCBエディターから開きます。
ダイアログの主な機能は次のとおりです。
- 対応付けられていないコンポーネントは左側の2つのUn-Matched Components列に表示され、一致するUIDを持つコンポーネントはダイアログ右側のMatched Components領域に表示されます。
- ダイアログ中央の矢印ボタンを使用して、選択したコンポーネントを手動で対応付け(または対応付けを解除)したり、現在対応付けられているすべてのコンポーネントの対応付けを解除したりできます。
- ダイアログ下部のAdd Pairs Matched Byボタンとオプションを使用して、現在対応付けられていないコンポーネントの一覧をスキャンし、有効化されたプロパティ(デジグネーター、コメント、フットプリント)に基づく対応付けを試みます。
- Perform Updateボタンをクリックすると、新たに対応付けられた各PCBコンポーネントに、対応する回路図コンポーネントのUIDが割り当てられます。 項目を移動した場合は、 Matched ダイアログのセクションから Unmatched セクションに戻すと、続行すると既存のコンポーネントの関連付けが解除されることを知らせる確認ダイアログが表示されます。 Yes をクリックすると更新が実行され、PCBドキュメントで変更されたコンポーネントリンクの概要を示す情報ダイアログが表示されます。 Matched セクションの新しいエントリは Link Modifiedとして、以前はリンクされていたものの、今回対応付けを解除したエントリは Link Removedとして表示されます。
- このダイアログでコンポーネントを手動でリンクした後は、同期状態を確認することをお勧めします(Design » Updateコマンドを実行します)。
ネットとクラスの対応付け
ネットとクラスには、親(ネットまたはクラス)と子(そのネットまたはクラスのメンバー)があります。これらの対応付けでは、親、子、または親と子の両方の変更に対応するため、コンポーネントのリンクに使用されるUID方式とは異なる方法が必要です。たとえば、回路図上のネット名を変更するだけの単純な操作で、そのネットとすべての子ピンをPCBから削除し、新しい名前のネットを追加してから、すべての子ピンをその新しいネットに追加し直す必要があってはなりません。
これに対応するため、ソフトウェアには、メンバーによってネットとクラスを対応付けるアルゴリズムと、名前によって対応付けるアルゴリズムがそれぞれ用意されています。対応付け処理は、Options for ProjectダイアログのComparatorタブにあるObject Matching Criteriaセクションで設定します。

デフォルトでは、最初にメンバーで対応付けを行い、次にオブジェクトタイプの名前で対応付けを行います。
これらのタイプのオブジェクトの対応付けは、次のように処理されます。
- 設計の同期中、デフォルトでは、Min Match %およびMin Match Memberの設定に従い、最初にメンバーによる対応付けを試みます。
- メンバーによる対応付けに失敗した場合、ソフトウェアは名前による対応付けを試みます(Use Name Matchingオプションが有効な場合)。
- いずれかの対応付け処理が成功すると、Engineering Change Orderダイアログに進みます。
-
両方の対応付け方法が失敗した場合(またはUse Name Matchingオプションが
Neverに設定されている場合)、Match Manuallyダイアログが開きます。
- Match ManuallyダイアログでNoをクリックすると、ユーザーによる対応付け処理をスキップし、Engineering Change Orderダイアログに直接進みます。未対応のオブジェクトの対応付けを試みていないため、ソフトウェアは参照オブジェクトとターゲットオブジェクトが無関係であると判断し、基板からUnmatched Reference Objectsを削除して、Unmatched Target Objectsを新しいオブジェクトとして追加するECOを生成します。
- ダイアログでYesをクリックして手動で対応付けを行うと、以下に示すMatchダイアログが開きます(ダイアログのタイトルは、未対応のオブジェクトタイプに応じて変わります)。
Match ダイアログでは、対応していることが分かっているオブジェクトを手動で対応付けます。確信が持てない場合は、右側を空のままにしてContinueをクリックしてください。
Matchダイアログのオプションとコントロール
-
Unmatched <Object>
- Unmatched Reference Objects - 未対応のオブジェクトを一覧表示します。展開/折りたたみコントロールを使用してリストを開閉します。
- Unmatched Target Objects - ターゲットオブジェクトを一覧表示します。展開/折りたたみコントロールを使用してリストを開閉します。
-
- クリックすると、選択した参照オブジェクトとターゲットオブジェクトを対応付け、選択したオブジェクトをUnmatched領域からMatched Pairs領域に移動します。
-
- クリックすると、選択したオブジェクトを Matched Pairs領域からUnmatched領域に移動します。この操作により、移動したオブジェクトの対応付けが解除されます。
-
- クリックすると、すべてのオブジェクトを Matched Pairs領域からUnmatched領域に移動します。この操作により、移動したオブジェクトの対応付けが解除されます。
- Matched Pairs - 現在対応付けられているReference Object とTarget Object を一覧表示します。
- Continue - クリックすると、対応付けの更新を確定し、Engineering Change Orderダイアログを開きます。
- このダイアログで、Unmatched Reference ObjectsとUnmatched Target Objectsから対応付けたいオブジェクトを選択し、ダイアログのMatched Pairsセクションに移動します。これらのオブジェクトに対して、ソフトウェアは名前を一致させるための更新ECOと、メンバーも一致させるための削除/追加ECOを生成します。
- 確信が持てない場合は、オブジェクトを手動で対応付ける必要はありません。未対応のオブジェクトについては、ソフトウェアは参照オブジェクトとターゲットオブジェクトが無関係であると判断し、基板からUnmatched Reference Objectsを削除して、Unmatched Target Objectsを新しいオブジェクトとして追加するECOを生成します。
- 対応していることが分かっているオブジェクトを対応付けたら、ContinueをクリックしてEngineering Change Orderダイアログを開きます。
- Cancelをクリックすると、更新処理が終了します。
デザインルールの対応付け
回路図で定義されたデザインルールも、PCB上の対応するルールにリンクする必要があります。リンクの仕組みがなければ、回路図上のルールを更新して、その変更をPCBに反映することはできません。回路図のデザインルールとPCBのデザインルールのリンクには、UIDを使用します。
UIDは、回路図上のルール定義を保持するパラメーターセットに自動的に割り当てられ、設計の同期時にPCBに転送されます。
デザインルールでは、UIDを使用して、回路図のデザインルール定義とPCBのデザインルールを対応付けます。
通常、PCBエディターのPCB Rules and ConstraintsダイアログでUIDを手動で編集していない限り、ルールの対応付けを手動で管理する必要はありません。UIDが一致しない場合、対応するPCBルールがない回路図ルールについては、ソフトウェアがPCBに新しいルールを追加します。また、対応する回路図の設計ルールがないPCBの設計ルールは削除されます。
