KeysightによるSI Analyzer
概略
- Altium DesignerでSI Analyzer by Keysight拡張機能が果たす役割と、対応するシグナルインテグリティチェックの種類を学びます。
- 拡張機能のインストール、SI Analyzerドキュメントの表示、ネットやクラスの追加、組み込み仕様やカスタム仕様の割り当て方法を確認します。
- 設計のシグナルインテグリティチェックの実行に向けて、制約と解析データを準備する基本的なワークフローを理解します。
最新の電子機器では高速PCB設計の採用がますます増えており、技術の 進化に伴って 信号速度も向上しています(DDR6では17 GHz、QSFP++では400 Gbpsなど)。高速設計において、シグナルインテグリティ(SI)の確保は極めて重要なステップです。インターフェース開発元の要件を満たせない場合、その後の設計段階や製造、性能に問題が生じる可能性が非常に高くなります。
Altium Designer環境内で直接 シグナルインテグリティ解析を実行するために、SI Analyzer by Keysight ソリューションが用意されています。 ソフトウェア拡張機能として提供される SI Analyzer by Keysightは、Altium Designerと直接統合されており、高速設計の最も重要なパラメーターを対象に、レイアウト後の各種SIチェックを実行できます。
-
インピーダンス
-
遅延
-
挿入損失(IL)
-
反射損失(RL)
SI Analyzer by Keysightの機能へのアクセス
Altium DesignerでSI Analyzer by Keysightの機能にアクセスするには、 SI Analyzer by Keysight ソフトウェア 拡張機能 をインストールする必要があります。この拡張機能は手動でインストールまたは削除できます。
拡張機能の管理について詳しくは、 Extending Your Installation ページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。
SI Analyzer by Keysight ソフトウェア 拡張機能をインストールすると、次の操作が可能になります。
-
SI Analyzer by Keysightドキュメントを新規作成する、または既存のドキュメントを開く。
-
SI解析用のネットを追加し、設定する。
-
既存のSI解析結果を確認する。
-
SI解析レポートを生成する。
ただし、新しいSI解析を実行するには、SI Analyzer by Keysightの有効なサブスクリプションが必要です。有効なサブスクリプションがない状態でSI解析を開始しようとすると、Analyze Your Netsダイアログが開き、無料トライアルを申し込むことができます(
)。
SI Analyzer by Keysightの起動
シグナルインテグリティ解析を開始するには、プロジェクトのPCBドキュメントを開き、メインメニューから Tools » SI Analyzer by Keysight を選択します。
SI Analyzer by Keysightドキュメント(<ProjectName> [SIK])が開き、プロジェクトの Source Documents 領域( Projects パネル内)に追加されます。この時点では、ドキュメントは未保存です。メインメニューのFile » Save As コマンドを使用して、任意の場所にドキュメントを保存してください。
解析の準備
解析対象のネットの追加
SI Analyzer by Keysightを起動すると、PCBデータがODB++形式でソルバーにインポートされます。この段階で、解析対象のネットのリストを定義し、それらに仕様を割り当てることができます。これを行うには、SI Analyzer by Keysightドキュメントの上部にあるManage Netsボタンをクリックするか、メインメニューのEdit » Manage Netsコマンドを使用します(ドキュメントにネットがない場合は、ドキュメント中央の Manage Netsボタンも使用できます)。Manage Netsダイアログが開き、PCBのネットクラス、差動ペアクラス、xSignalクラスのリストが表示されます。
必要な各クラスのチェックボックスをオンにします(または、表のヘッダーにあるチェックボックスを使用してすべてのクラスを選択します)。 必要に応じて、Specifications列のセルをクリックしてポップアップを表示し、選択したクラスの制約を定義する仕様を選択します(必要であれば後から再定義できます – 詳細はこちら)。組み込み仕様またはユーザー定義仕様から選択することも(ポップアップのSpecificationsタブ)、クラスに必要な制約値を手動で定義することもできます(ポップアップのCustom Constraintsタブ)。
組み込み仕様またはユーザー定義仕様の管理について詳しくは、 仕様の管理セクションを参照してください。
ダイアログの下部にあるAll Netsリストを展開し、設計内の個々のネットに対して仕様を選択して割り当てることもできます。
ダイアログでOKをクリックすると、選択したクラスがSI Analyzer by Keysightドキュメントに表示されます。Manage NetsダイアログのAll Nets領域でネットを選択した場合、そのネットはAll Netsクラスの項目内に表示されます。 クラスの項目を展開すると、そのクラスのネット/xSignalを確認できます。
ネット/xSignalまたは差動ペアのエントリを展開すると、Transmission Line領域に構成オブジェクト(パッド、トラック、円弧、ビア)が表示されます。オブジェクトのタイルにカーソルを合わせて
アイコンをクリックすると、PCB内のそのオブジェクトにクロスプローブできます。
クラスまたは個別に追加したネットをドキュメントから削除するには、そのエントリの右側にある
ボタンをクリックします。
仕様の管理
SI Analyzer by Keysightドキュメント上部のManage Specificationsボタンをクリックして開くManage Specificationsダイアログでは、組み込み仕様とユーザー定義仕様の両方を管理できます。前のセクションで説明したように、仕様をクラスまたはネットに割り当てることで、その制約をすばやく定義できます。
-
ダイアログの左側には、現在定義されている仕様の一覧が表示されます。各仕様には、その名前と、その仕様で定義されている1つ以上の制約の種類が表示されます。
- 一覧で仕様を選択すると、ダイアログの右側にその詳細(名前、Built-In仕様かUser-Defined仕様か、および制約)が表示されます。
-
新しい仕様を作成するには、仕様一覧の左下にあるAdd Newボタンをクリックします。ダイアログの右側に、仕様を定義するためのコントロールが表示されます。
-
Specification Nameフィールドで新しい制約の名前を定義します。
-
チェックボックスを使用して、この仕様で定義する制約の種類(Impedance、Delay、Insertion Losses (IL)、Return Losses (RL))を選択します。
-
有効にした制約の種類ごとに、制約値を定義します。ImpedanceおよびDelayの種類の制約には、用意されているテキストフィールドを使用します。Insertion Losses (IL)およびReturn Losses (RL)の種類の制約では、境界を追加、編集、削除して、必要な周波数範囲内で損失値を制限する領域と許容する領域を設定できます。
-
仕様を必要に応じて定義したら、ダイアログ右側の上部にあるSaveボタンをクリックして作成するか、Cancelをクリックして作成せずに終了します。
-
-
既存の仕様(ユーザー定義仕様または組み込み仕様)を複製して、新しい仕様を作成することもできます。一覧で複製する仕様を選択し、仕様一覧の左下にあるDuplicateボタンをクリックします。初期名が
<OriginalSpecificationName>(Copy)で、元の仕様と同じ制約を持つ新しい仕様が作成され、ダイアログの右側で編集できる状態になります。必要に応じて変更し、上部のSaveボタンをクリックして仕様を作成するか、Cancelをクリックして作成せずに終了します。 -
ユーザー定義仕様を編集するには、一覧でその仕様を選択した状態で、ダイアログの右側にある
ボタンをクリックします。必要に応じて変更し、上部のSaveボタンをクリックして変更を保存するか、Cancelをクリックして変更を適用せずに終了します。
-
仕様(ユーザー定義仕様または組み込み仕様)を削除するには、一覧でその仕様を選択した状態で、ダイアログの右側にある
ボタンをクリックします。
- 削除した組み込み仕様は、仕様一覧内を右クリックしてRestore Built-In Specコマンドを選択すると復元できます。このコマンドはユーザー定義仕様には影響しません。
制約の定義
各ネットは、指定された制約を満たしているかどうかを判定するために解析されます。親クラスに仕様が選択されている場合、制約はその仕様によって定義されます。
ネット/xSignalまたは差動ペアの現在の制約を確認するには、そのエントリを展開し、Constraintsタブを選択します。
制約値をクリックすると、表示されるポップアップでその制約を編集できます。
制約値を手動で変更した場合、対応するエントリにCustom constraints are used警告メッセージが表示されます。
解析の実行
設定が完了したら、追加したすべてのネット、特定のクラス、または特定のネットに対して解析を実行できます。すべてのネットを解析するには、SI Analyzer by Keysightドキュメントの右上にあるAnalyze Allボタンをクリックします。特定のクラス/ネットのみを解析するには、そのクラスまたはネットのエントリにあるAnalyzeボタンをクリックします。
結果の確認
解析が完了すると、SI Analyzer by Keysightドキュメントに結果が表示されます。ドキュメントの右上にはAnalyzedメッセージが表示されます。解析したすべてのネットが制約を満たしている場合、メッセージの横にAll Passedというテキストが表示されます。それ以外の場合は、制約を満たしていないネットの数とともにFailedというテキストが表示されます。
クラス内のすべてのネットが解析に合格した場合、そのエントリにはSuccessというテキストが表示されます。それ以外の場合は、Failedというテキストが表示されます。
クラスのエントリを展開すると、そのクラス内の解析対象ネットごとに計算値(インピーダンス、遅延、挿入損失、反射損失)が表示されます。制約を満たす値は緑色で、制約を満たさない値は赤色で表示されます。
ネットのエントリを展開すると、Resultsタブにそのネットの計算値が表示されます。また、Transmission Line領域では、制約を満たさないネットオブジェクトのタイルが赤い枠で表示され、不合格となった値が赤色で表示されます。
PCB内のクラスまたはネット/xSignal/差動ペアの解析結果を表示するには、対応するShow on PCBボタンをクリックします。
SI Analyzer by Keysightパネル
PCBエディターでは、解析プロセスと結果をSI Analyzer by Keysightパネルで管理します。このパネルは、シグナルインテグリティ解析を実行し、 Show on PCBボタンをクリックした後に、使用可能なパネルの一覧(Panelsボタンから表示)に追加されます。
シミュレーション対象の信号
- Simulated Signal – デザインスペースにヒートマップとして表示するクラスまたはネット/xSignal/差動ペアを選択します。
- Only nets with violations – このオプションをオンにすると、現在違反があるエンティティのみがドロップダウンに表示されます。解析済みのすべてのエンティティを表示するには、このオプションをオフにします。
- Show Heatmap – このオプションをオンにすると、Simulated Signalドロップダウンで現在選択されているエンティティのヒートマップがデザインスペースに表示されます。
これらのコントロールの下には、GeneralとHeatmapの2つのタブがあります。これらのタブのオプションは、Simulated Signalドロップダウンで現在選択されているエンティティに適用されます。
ヒートマップ
SI Analyzer by KeysightパネルのHeatmapタブでは、ヒートマップに表示するデータ(インピーダンスまたは遅延)と、インピーダンス/遅延に適用する色を設定します。これらのヒートマップ設定コントロールは、Show Heatmapオプションが有効な場合にのみ使用できます。
ImpedanceボタンとDelayボタンを使用して、2つのモードを切り替えます。ネット全体は、ネット上の各位置のインピーダンス/遅延を反映して、次のように色分けされます。
- インピーダンスの場合、Z0の目標値に近いほど緑に、目標値から離れるほど赤に近い色になります。最小値未満および最大値を超える計算値は赤で表示されます。
- 遅延の場合、遅延が大きいほど暖色(赤)に、小さいほど寒色になります。最小値未満の計算値は青で、最大値を超える計算値は赤で表示されます。
カラースケールは、色の適用方法を示しています。最小値と最大値は、スライダーをクリックしてドラッグするか、その下のフィールドに新しい値を入力して調整できます。このスケールは、デザインスペース内のPCBの下にもカラーバーとして表示されます。
Color focus on resultsオプションを有効にすると、Simulated Signalドロップダウンで現在選択されているエンティティがハイライト表示され、PCB内の他のオブジェクトがフィルタリングされます。
違反の検出
Simulated Signalドロップダウンで現在選択されているエンティティに対して、解析で制約違反が検出された場合、それらはSI Analyzer by KeysightパネルのGeneralタブにあるViolations領域に一覧表示されます。
- 領域の上部にあるボタンを使用して、一覧に表示する違反の種類を指定します。
- 領域の下部にあるAnalyzeボタンを使用して、SI解析を再実行します。これにより、SI Analyzer by Keysightドキュメントに戻ることなく、PCBエディターでの変更後にエンティティが制約を満たしているかをすばやく確認できます。
プローブ
SI Analyzer by KeysightパネルのProbes領域では、測定プローブをPCB上に直接配置できます。プローブはインピーダンスまたは遅延を測定でき、測定の種類は基板の現在のヒートマップモードによって決まります。
プローブには、プローブ位置の絶対値を測定する単一プローブと、2つのプローブ位置の差を測定する差分プローブがあります。どちらの種類のプローブも、パネルのProbes領域にあるAddボタンをクリックして配置します。単一プローブを配置するには、目的の位置をクリックしてから、右クリックします(またはEscを押します)。差分プローブを配置するには、1回目のクリックで最初のプローブ位置を指定し、2回目のクリックで2つ目のプローブ位置を指定します。プローブを定義すると、測定結果がパネルに表示されます。
パネル内のプローブ項目をクリックすると、PCB上のその位置が表示されます。プローブを削除するには、パネル内のプローブ項目を選択し、領域の下部にある
ボタンをクリックします。
Add to Reportボタンをクリックすると、選択したプローブ位置でのPCBの画像が作成されます。画像はパネルのImage Captures領域に表示され、Probeバッジで識別されます。スクリーンショットにカーソルを合わせると、プローブの詳細が表示されます。
画像キャプチャ
SI Analyzer by Keysightパネルの画像キャプチャ機能を使用すると、設計固有のスクリーンショットを取得して、レポートに含めることができます。
基板の特定の領域を撮影するには、まず、キャプチャに含めたい要素が表示されるように、デザインスペース内の基板の表示を調整します。準備ができたら、パネルのImage Captures領域にあるAddボタンをクリックして、スクリーンショットを取得します。引き続き基板の表示を変更し、画像を追加できます。
画像を削除するには、画像にカーソルを合わせると表示される
ボタンをクリックします。
結果のレポート作成
解析レポート全体を生成するには、SI Analyzer by Keysightドキュメントの上部にあるFull Reportボタンをクリックします。レポート全体には、各クラスのセクション(およびネットクラスに属さず、個別に追加されたネットのAll Nets項目)が含まれます。
レポート全体でネットクラス名(またはAll Netsリスト内のネット名)をクリックすると、以下を含む詳細レポートが表示されます。
- ネットクラス名またはネット名。
- 割り当てられた仕様。
- 制約チェックの概要。失敗したチェック項目をクリックすると、関連する問題を修正するための推奨事項が表示されます。
- 基板のレイヤースタックアップ。
- 各ネットの制約チェック。ネットの項目を展開すると、そのネットの各オブジェクトに対する制約チェックが表示されます。
- 挿入損失チャート。
- 反射損失チャート。
詳細レポートを確認しているときに、Show on PCBボタンをクリックすると、PCBとSI Analyzer by Keysightパネルが開き、クラスやネットを詳しく確認できます。
チャートの操作
挿入損失チャートと反射損失チャートには、確認中のクラスに属する各ネットの対応する波形が表示されます。チャート内の赤い領域は、制約で定義された禁止領域を示します。
-
挿入損失チャートまたは反射損失チャートの右上にあるドロップダウンを使用して、チャートに表示するネットを管理します。すべてのネット、チェックに失敗したネット、または特定のネットを表示できます。
-
チャートの右側にある波形名をクリックすると、他の波形が薄く表示され、選択した波形が強調表示されます。波形名をもう一度クリックすると、強調表示が解除されます。
-
マウスホイールをスクロールすると、チャート上のマウスポインターの位置を基準にズームできます。マウスポインターがチャートの軸上にある場合は、マウスホイールをスクロールすると、その軸上のポインター位置を基準に、その軸のみがズームされます(もう一方の軸のスケールは変わりません)。
-
測定カーソルを使用してデータを測定できます。2つのカーソルを使用でき、チャート上の同じ波形にも、異なる波形にも追加できます。チャートの右側にある波形名を右クリックし、コンテキストメニューのCursor AおよびCursor Bコマンドを使用して、カーソルの有効/無効を切り替えます。カーソルのタブをクリックしてドラッグすると、カーソルを移動できます。有効なカーソルの測定データは、チャートの下部に表示されます。

同じ波形にカーソルAとBを追加した例。
レポートのエクスポート
Save Reportボタンをクリックすると、レポートをHTML形式で保存できます。続いて表示されるReport Settingsダイアログで、レポートに含めるネット(レポート全体からダイアログを開いた場合)と具体的なデータを設定します。
Generate Reportボタンをクリックすると、レポートはプロジェクトフォルダー内の\SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime>という名前のサブフォルダーに保存されます。レポート内のすべての画像は、\Imagesサブフォルダーに保存されます。
)。 Accept をクリックすると、EULAの利用規約に同意したことになり、インストールが続行されます。 Close をクリックすると、EULAの利用規約に同意しないことになり、インストール処理が中止されます。


)。
アイコンによって示されます。ネットが差動ペアの一部である場合、そのネットは対となるネットとともに差動ペアとしてSI Analyzer by Keysightドキュメントに追加され、そのエントリには
アイコンが表示されます。
















