Signal Integrity Analysis(Altium 提供)
概略
- 回路図のみのプロジェクトとPCBプロジェクトで、シグナルインテグリティ解析の実行方法がどのように異なるかを学びます。
- Altium Designerが設計の各段階で、反射、インピーダンス、クロストークの解析をどのようにサポートするかを確認します。
- シグナルインテグリティチェックと設計ルールの連携、および解析エンジンにアクセスするための要件を理解します。
Altium Designerには、レイアウト前およびレイアウト後のシグナルインテグリティ解析機能が搭載されています。Altium Designerのシグナルインテグリティアナライザーは、高度な伝送線路計算とI/Oバッファーのマクロモデル情報をシミュレーションの入力として使用します。高速な反射・クロストークシミュレーターモデルを基盤とし、業界で実績のあるアルゴリズムを用いて正確なシミュレーションを実行します。
基板の最終的なレイアウトと配線を行う前に、元の回路図から予備的なインピーダンスおよび反射シミュレーションを実行できます。これにより、基板レイアウトに着手する前に、ネットのインピーダンス不整合など、シグナルインテグリティに関する潜在的な問題に対処できます。
完成した基板(または配線途中の基板)に対して、インピーダンス、信号反射、クロストークの詳細な解析を実行し、設計の実環境での性能を確認できます。シグナルインテグリティのスクリーニング機能はAltium Designerのデザインルールシステムに組み込まれており、通常の基板DRC(デザインルールチェック)の一環として、シグナルインテグリティ違反を確認できます。シグナルインテグリティの問題が見つかった場合、Altium Designerで各種終端方法の効果を確認できるため、設計を変更する前に最適な解決策を見つけることができます。
回路図のみのプロジェクトからシグナルインテグリティ解析を実行する
プロジェクトにPCBが含まれていない場合は、回路図のみを使用して設計のシグナルインテグリティ解析を実行できます。Free Documentsとして開いたドキュメントでは解析を実行できないため、回路図はプロジェクトに含まれている必要があります。クロストーク解析には配線済みのネットが必要なため、この場合は実行できません。
回路図のみのモードで実行する場合、シグナルインテグリティの設定オプションを使用して、デフォルトの平均配線長とインピーダンスを定義できます。また、シグナルインテグリティアナライザーは、回路図から励振ネットと電源ネットのPCBデザインルールを読み取ります。これらのルールは、回路図内のネットにPCB LayoutディレクティブまたはParameter Setディレクティブとして追加できます。
回路図エディターで回路図を開いた状態で、メニューからTools » Signal Integrityを選択します。まず、必要なシグナルインテグリティモデルを設定でき、その後、Signal Integrityパネルが表示されます。このパネルで初期結果を確認し、さらに解析を進めることができます。
PCBプロジェクトからシグナルインテグリティ解析を実行する
PCBドキュメントからシグナルインテグリティ解析を実行する場合、PCBは関連する回路図とともにプロジェクトに含まれている必要があります。プロジェクト内の任意の回路図ドキュメントからシグナルインテグリティ解析を実行することもでき、PCBから実行した場合と同じ結果が得られます。この場合は、反射解析とクロストーク解析の両方を実行できます。
PCBエディターでTools » Signal Integrityを選択すると、上記の回路図のみのモードと同じ処理が実行されます。
PCBには回路図のコンポーネントの一部だけが配置されていても、まったく配置されていなくてもかまいません。ただし、配置済みのコンポーネントはすべて、Component Linksでリンクされている必要があります。これは、Project » Component Linksを選択して確認できます。また、未配線のネットについては、ピン間のマンハッタン距離を使用して、解析用の推定配線長が計算されます。
Altium Designerでのシグナルインテグリティ解析の実行について詳しくは、以下のページを参照してください。
