回路シミュレーションによる設計の解析
概略
- 回路動作の確認、設計の調整、実機では困難または現実的でない測定に、シミュレーションが役立つ理由を学びます。
- Altium Designerが、アナログ回路、デジタル回路、アナログとデジタルが混在する回路を含め、SPICEベースのミックスドシグナルシミュレーションをどのようにサポートしているかを確認します。
- Altium Designerでのシミュレーションの流れを把握し、手順に沿った例を通じて、回路図の準備から解析の開始までの方法を学びます。
回路シミュレーションを使用すると、製造に進む前にアイデアを検討できます。構想を検証し、回路を迅速かつ正確に調整できます。また、回路シミュレーションでは、実際の作業台では物理的に不可能な測定を行うこともできます。
電子機器の動作をシミュレーションする主な目的は、設計の性能を再現し、解析することです。シミュレーションが提供する機能なしでは、最も単純な機器でさえ設計は考えられません。 シミュレーションソフトウェアを使用すれば、設計中の機器を損傷させることなく、すべての動作モードを解析できます。また、実環境では測定が難しいパラメーターや特性を求めたり、通常は高価な測定機器が必要となる測定を行ったりすることもできます。
SPICE(Simulation Program with Integrated Circuit Emphasis)は、オープンソースのソフトウェアパッケージとして開発され、広く普及するとともに、継続的な開発が行われてきました。Altium DesignerのMixed Simulation(MixedSim)テクノロジーは、SPICEアルゴリズムを基に改良されたコアを使用し、アナログ、デジタル、またはアナログとデジタルが混在する機器の電気回路をシミュレーションできるように設計されています。これは真のミックスドシグナルシミュレーターであり、アナログデバイスとデジタルデバイスの両方を含む回路を解析できます。SPICE3f5に完全準拠しているほか、さまざまなPSpice®およびLTspice®デバイスモデルもサポートしています。
Altium Designerでのシミュレーションプロセスは、次の段階に分けられます。
- シミュレーションに向けたプロジェクトの検証と準備 – 適切なシミュレーション結果を得るには、シミュレーション対象の設計を検証し、十分に準備する必要があります。これには、シミュレーションモデルを持つコンポーネントの配置、信号源の設定、プローブを使用した回路内の測定点の指定が含まれます。検証プロセスでは、解析対象の回路図に問題がある場合にフィードバックが提供されます。
- シミュレーションの設定と実行 – シミュレーションは回路図から直接実行でき、シミュレーション波形を解析しながら再実行することもできます。必要な解析の種類とプロットする出力式を手早く設定してから、シミュレーションを実行します。
- シミュレーション結果の操作 – シミュレーション結果はSimDataエディターに表示されます。この多機能な環境では、シミュレーション結果を迅速かつ効率的に解析できるため、設計を評価、デバッグし、最終的にその動作への確信を得ることができます。
Mixed Simulation – サンプルガイド
以下の折りたたみセクションでは、シミュレーション可能なフィルター回路の回路図を作成し、その回路図を使用していくつかの回路シミュレーション解析を実行する手順を説明します。
新しい設計プロジェクトの作成
- メインメニューからFile » New » Projectコマンドを選択します。
-
Create Projectダイアログが開きます。
- Locationsリストで、使用するWorkspaceの項目を選択します(Workspaceを使用しない場合は、Local Projectsの項目を選択します)。
- Project Typeリストで、PCBタイプの下にある<Empty>の項目を選択します。
-
Project Nameフィールドに
Filterを入力します。 - 必要に応じてダイアログの右側にあるその他のオプション(保存先フォルダーなど)を設定し、Createボタンをクリックします。
新しいプロジェクトが作成され、Projectsパネルにプロジェクトの項目が表示されます。
-
Projectsパネルでプロジェクトの項目を右クリックし、コンテキストメニューからAdd New to Project » Schematicコマンドを選択します。
-
新しい回路図ドキュメントの空白のシートが表示されます。Projectsパネルでその項目を右クリックし、コンテキストメニューからSave Asコマンドを選択して、ハードドライブに保存します。 Save Asダイアログが開き、プロジェクトファイルと同じ場所にドキュメントを保存できる状態になります。File nameフィールドに
Filterと入力し、Saveをクリックします(拡張子は自動的に追加されるため、入力する必要はありません)。 - プロジェクトに新しいドキュメントを追加したため、プロジェクトファイルが変更されています。Projectsパネルでプロジェクトの項目を右クリックし、Saveを選択してプロジェクトの変更を保存します。
回路図の作成
シミュレーションするフィルター回路を以下に示します。 このセクションでは、必要なコンポーネントを探し、コンポーネントのプロパティを設定してから、回路図を配線します。

フィルター回路の回路図
シミュレーション対応コンポーネントの配置
-
回路図に使用するコンポーネントは、Altium Designerのインストールにデフォルトで含まれている
Simulation Generic Componentsライブラリから取得します。 -
オペアンプを配置します。
-
コンポーネントリストで OpAmp with power terminals コンポーネントを見つけ、その項目を右クリックして、メインメニューから Place コマンドを選択します。デザインスペース内でコンポーネントがカーソルに追従する状態になりますが、まだ配置しないでください。
- オペアンプがカーソルに追従している状態で Tab キーを押して Properties パネルを開きます。このパネルで、回路図にコンポーネントを配置する前にプロパティを編集できます。
-
Properties パネルの General 領域で、Designator を
U1に変更します。
-
デザインスペース内の一時停止ボタン(
)をクリックして、コンポーネントの配置に戻ります。
- デザインスペース内をクリックして、オペアンプのインスタンスを配置します。
- 引き続きコンポーネント配置モードになっているため、さらにインスタンスを配置できます。この回路に必要なオペアンプは1つだけなので、右クリックしてコンポーネント配置モードを終了します。
-
-
抵抗を配置します:
- Components パネルで Resistor コンポーネントを見つけ、その項目を右クリックして、メインメニューから Place コマンドを選択します。
- 抵抗がカーソルに追従している状態で、Tab キーを押します。
-
開いた Properties パネルで、コンポーネントのプロパティを次のように変更します。
-
General 領域で、Designator を
R1に変更します。 -
Parameters 領域で、
Valueパラメーターの Value を100Kに変更します。
-
General 領域で、Designator を
-
デザインスペース内の一時停止ボタン(
)をクリックして、コンポーネントの配置に戻ります。
-
デザインスペース内をクリックして、抵抗のインスタンスを配置します。
-
カーソルを移動してデザインスペース内をクリックし、同じ値の抵抗をもう1つ配置します。新しいインスタンスのデジグネータは自動的にインクリメントされます(
R2)。
- 右クリックしてコンポーネント配置モードを終了します。
-
コンデンサを配置します:
- Components パネルで Capacitor コンポーネントを見つけ、その項目を右クリックして、メインメニューから Place コマンドを選択します。
- コンデンサがカーソルに追従している状態で、Tab キーを押します。
-
開いた Properties パネルで、コンポーネントのプロパティを次のように変更します。
-
General 領域で、Designator を
C1に変更します。 -
Parameters 領域で、
Valueパラメーターの Value を112pに変更します。
-
General 領域で、Designator を
-
デザインスペース内の一時停止ボタン(
)をクリックして、コンポーネントの配置に戻ります。
-
デザインスペース内をクリックして、コンデンサのインスタンスを配置します。
- コンデンサが引き続きカーソルに追従し、次のインスタンスを配置できる状態で、Tab キーを押します。
-
Properties パネルの Parameters 領域で、
Valueパラメーターの Value を56pに変更します。 -
デザインスペース内の一時停止ボタン(
)をクリックして、コンポーネントの配置に戻ります。
- Spacebar を押して、正しい向きになるまでコンポーネントを90°ずつ回転させます。
-
カーソルを移動してデザインスペース内をクリックし、コンデンサをもう1つ配置します。新しいインスタンスのデジグネータは自動的にインクリメントされます(
C2)。
- 右クリックしてコンポーネント配置モードを終了します。
電圧源の追加
シミュレーション時に回路に電力を供給するには、電圧源が必要です。
-
VDD電圧源を配置します:
- メインメニューから Simulate » Place Sources » Voltage Source コマンドを選択します。
- 電圧源がカーソルに追従している状態で、Tab キーを押します。
-
開いた Properties パネルで、電圧源のプロパティを次のように変更します。
-
General 領域で、Designator を
VDDに変更し、電圧源の Stimulus Type として DC Source を選択します。 -
Parameters 領域で、パラメーターの値を次のように変更します。
DC Magnitude=5
AC Magnitude=0
AC Phase=0
-
General 領域で、Designator を
-
デザインスペース内の一時停止ボタン(
)をクリックして、電圧源の配置に戻ります。
-
デザインスペース内をクリックして、電圧源のインスタンスを配置します。
-
VSS電圧源を配置します:
- 電圧源が引き続きカーソルに追従し、次のインスタンスを配置できる状態で、Tab キーを押します。
-
開いた Properties パネルで、電圧源のプロパティを次のように変更します。
-
General 領域で、Designator を
VSSに変更し、電圧源の Stimulus Type として DC Source を選択します。 -
Parameters 領域で、パラメーターの値を次のように変更します。
DC Magnitude=-5
AC Magnitude=0
AC Phase=0
-
General 領域で、Designator を
-
デザインスペース内の一時停止ボタン(
)をクリックして、電圧源の配置に戻ります。
-
カーソルを移動してデザインスペース内をクリックし、電圧源をもう1つ配置します。
-
正弦波電圧源を配置します:
- 電圧源が引き続きカーソルに追従し、次のインスタンスを配置できる状態で、Tab キーを押します。
-
開いた Properties パネルで、電圧源のプロパティを次のように変更します。
-
Properties パネルの General 領域で、Designator を
VINに変更し、電圧源の Stimulus Type として Sinusoidal を選択します。 -
Properties パネルの Parameters 領域で、パラメーターの値を次のように変更します。
DC Magnitude=0
AC Magnitude=1
AC Phase=0
Offset=0
Amplitude=5
Frequency=50K
Delay=0
Dampling Factor=0
Phase=0
-
Properties パネルの General 領域で、Designator を
-
デザインスペース内の一時停止ボタン(
)をクリックして、電圧源の配置に戻ります。
-
カーソルを移動し、デザインスペース内をクリックして、電圧源をもう1つ配置します。
- 右クリックして、部品配置モードを終了します。
回路の配線
配線とは、回路内のさまざまな部品間に接続を作成する作業です。このセクションでは、下の画像に従って回路を配線します。
- メインメニューから Place » Wire コマンドを選択します。
- オペアンプの「+」ピンのホットスポットにカーソルを合わせると、カーソル位置に赤い接続マーカー(赤い十字)が表示されます。これは、カーソルが部品の有効な電気的接続点にあることを示します。
- クリックして、ワイヤの始点を固定します。
-
R2の最も近いピンのホットスポットにカーソルを合わせ、カーソルが赤い接続マーカーに変わることを確認します。 - クリックして、ワイヤをピンに接続します。カーソルがそのワイヤから離れます。
- 下の動画に示すように、回路の残りの部分を配線します。
- すべてのワイヤの配置が完了したら、右クリックして配置モードを終了します。
電源ポートの追加
-
GND電源ポートを配置します。
- メインメニューから Place » Power Port コマンドを選択します。
- 電源ポートがカーソルに追従している状態で、 Tab キーを押します。
-
Properties パネルの Properties 領域で、Name =
GND、Style = Power Ground に設定します。
-
デザインスペース内の一時停止ボタン(
)をクリックして、電源ポートの配置に戻ります。
-
下の画像に示すように、電圧源部品の各「-」ピンに1つずつ、計3つの電源ポートを配置します。
-
VDD電源ポートを配置します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Properties パネルで Name =
VDD、Style = Bar に設定します。 -
デザインスペース内の一時停止ボタン(
)をクリックして、電源ポートの配置に戻ります。
-
下の画像に示すように、2つの電源ポートを配置します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Properties パネルで Name =
-
VSS電源ポートを配置します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Properties パネルで Name =
VSS、Style = Bar に設定します。 -
デザインスペース内の一時停止ボタン(
)をクリックして、電源ポートの配置に戻ります。
-
下の画像に示すように、3つの電源ポートを配置します。
- 右クリックして配置モードを終了します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Properties パネルで Name =
ネットラベルの追加
-
入力ネットにネットラベルを配置します。
- メインメニューから Place » Net Label コマンドを選択します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Net Name =
INに設定します。
-
デザインスペース内の一時停止ボタン(
)をクリックして、ネットラベルの配置に戻ります。
-
クリックして、
VINとR1の間のワイヤ上にネットラベルを配置します。ネットラベルの左下隅がホットスポットであり、この点がワイヤに接触している必要があります。
-
出力ネットにネットラベルを配置します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Net Name =
OUTに設定します。 -
クリックして、オペアンプの出力ピンから出ているワイヤ上にネットラベルを配置します。
- 右クリックして配置モードを終了します。
-
電源ポートがカーソルに追従している状態で、 Tab キーを押し、Net Name =
- Projects パネルで回路図ドキュメントの項目を右クリックし、コンテキストメニューから Save を選択して保存します。
シミュレーションに向けたプロジェクトの準備
Altium Designerでは、回路図から直接回路シミュレーションを実行できます。シミュレーションの設定と実行は、 Simulation Dashboard パネルから行います。
- デザインスペースの右下にある Panels ボタンをクリックし、表示されるメニューから Simulation Dashboard を選択して、 Simulation Dashboard パネルを開きます。
-
パネルの Verification 折りたたみ領域を展開し、Start Verification ボタンをクリックします。この領域の Electrical Rule Check と Simulation Models の両方の項目に、緑色のチェックマークが表示されることを確認します。
- 違反が検出された場合は、違反箇所を見つけて修正してから続行します。
-
パネルの Preparation 折りたたみ領域を展開し、回路図に追加した3つの電圧源がすべて Simulation Sources リストに表示され、有効になっていることを確認します。
解析の設定
過渡解析の設定
過渡解析では、ユーザーが指定した時間間隔にわたって、過渡出力変数(電圧、電流、電力)を時間の関数として計算し、通常オシロスコープに表示されるような出力を生成します。
-
Simulation Dashboard パネルの Analysis Setup & Run 折りたたみ領域を展開し、その中の Transient 領域を展開します。
-
Interval オプションが選択されていること(
)を確認し、次の値を入力します。
-
From =
0 -
To =
60u -
Step =
100n
-
From =
-
入力信号の新しい式を追加します。この式は、シミュレーション結果ドキュメントに波形として出力されます。
-
Output Expressions 見出しの下にある Add コントロールをクリックして、シミュレーション結果ドキュメントに波形として出力する新しい式のフィールドを追加します。
-
をクリックします。追加したフィールドの右側にある ボタンをクリックして、出力式を設定できるAdd Output Expressionダイアログを開きます。
-
Add Output Expressionダイアログで、Waveform 領域のドロップダウンからNode Voltagesを選択し、その下のリストでv(IN)の項目をクリックします。ダイアログのExpression Yフィールドに
v(IN)式が追加されます。 -
Add Output ExpressionダイアログでCreateをクリックします。Simulation Dashboard パネルに式が表示されます。
-
-
出力信号の出力式を追加します:
-
Simulation DashboardパネルのAddコントロールをクリックして、別の出力式用のフィールドを追加し、追加したフィールドの右側にある
ボタンをクリックします。
- Add Output Expressionダイアログで、Waveform 領域のドロップダウンからNode Voltagesを選択し、その下のリストでv(OUT)の項目をクリックします。
-
Plot NumberドロップダウンでNew Plotを選択すると、この式の波形がシミュレーション結果ドキュメント内の別のプロットに描画されます。選択後、ドロップダウンには2が表示されます。
- Add Output ExpressionダイアログでCreateをクリックして、Simulation Dashboard パネルに式を追加します。
-
Simulation DashboardパネルのAddコントロールをクリックして、別の出力式用のフィールドを追加し、追加したフィールドの右側にある
-
これで過渡解析の設定は完了です。Simulation Dashboard パネルのオプションは、以下のようになります。
ACスイープ解析の設定
ACスイープ解析では、小信号AC出力変数を周波数の関数として計算し、回路の周波数応答を示す出力を生成します。AC小信号解析で求める出力は、通常、電圧利得などの伝達関数です。
- Simulation Dashboardパネルで、Analysis Setup & Run 折りたたみ領域内のAC Sweep領域を展開します。
-
スイープのTypeとしてDecadeを選択し、次の値を入力します:
-
Start Frequency =
100m -
End Frequency =
1meg -
Points/Dec =
100
-
Start Frequency =
-
入力信号の振幅をデシベルで表す出力式を追加します:
-
Output Expressionsヘッダーの下にあるAddコントロールをクリックして、新しい式用のフィールドを追加し、追加したフィールドの右側にある
ボタンをクリックします。
- Add Output Expressionダイアログで、Waveform 領域のドロップダウンからNode Voltagesを選択し、その下のリストでv(IN)の項目をクリックします。
- Add Output Expressionダイアログの Complex FunctionsドロップダウンからMagnitude (dB)を選択し、Createをクリックします。
-
Output Expressionsヘッダーの下にあるAddコントロールをクリックして、新しい式用のフィールドを追加し、追加したフィールドの右側にある
-
出力信号の振幅をデシベルで表す出力式を追加します:
-
Output Expressionsヘッダーの下にあるAddコントロールをクリックして、新しい式用のフィールドを追加し、追加したフィールドの右側にある
ボタンをクリックします。
- Add Output Expressionダイアログで、Waveform 領域のドロップダウンからNode Voltagesを選択し、その下のリストでv(OUT)の項目をクリックします。
- Add Output Expressionダイアログの Complex FunctionsドロップダウンからMagnitude (dB)を選択し、Createをクリックします。
-
Output Expressionsヘッダーの下にあるAddコントロールをクリックして、新しい式用のフィールドを追加し、追加したフィールドの右側にある
-
入力信号の位相を度単位で表す出力式を追加します:
-
Simulation DashboardパネルのAddコントロールをクリックして、別の出力式用のフィールドを追加し、追加したフィールドの右側にある
ボタンをクリックします。
- Add Output Expressionダイアログで、Waveform 領域のドロップダウンからNode Voltagesを選択し、その下のリストでv(IN)の項目をクリックします。
- Add Output Expressionダイアログの Complex FunctionsドロップダウンからPhase (Deg)を選択します。
- Plot NumberドロップダウンでNew Plotを選択し、Add Output ExpressionダイアログでCreateをクリックします。
-
Simulation DashboardパネルのAddコントロールをクリックして、別の出力式用のフィールドを追加し、追加したフィールドの右側にある
-
出力信号の位相を度単位で表す出力式を追加します:
-
Simulation DashboardパネルのAddコントロールをクリックして、別の出力式用のフィールドを追加し、追加したフィールドの右側にある
ボタンをクリックします。
- Add Output Expressionダイアログで、Waveform 領域のドロップダウンからNode Voltagesを選択し、その下のリストでv(OUT)の項目をクリックします。
- Add Output Expressionダイアログの Complex FunctionsドロップダウンからPhase (Deg)を選択します。
-
Simulation DashboardパネルのAddコントロールをクリックして、別の出力式用のフィールドを追加し、追加したフィールドの右側にある
-
これでACスイープ解析の設定は完了です。Simulation Dashboard パネルのオプションは、以下のようになります。
-
シミュレーション設定ファイル(
project_sim_config.simcfg)が、Projectsパネルのプロジェクト構造内にあるSettings\Simulation Documentsフォルダーに表示されます。Projects パネルでこのドキュメントの項目を右クリックし、コンテキストメニューから Save As コマンドを選択して保存します。Save As ダイアログが開き、ハードドライブ上のプロジェクトフォルダーにドキュメントを保存できる状態になります。Save をクリックして、デフォルトの場所にデフォルトの名前でドキュメントを保存します。
- Projects パネルでプロジェクトファイルの項目を右クリックし、コンテキストメニューから Save コマンドを選択して、プロジェクトファイルを保存します。
解析の実行と結果の確認
-
Simulation Dashboard パネルのTransient領域ヘッダーの右側にあるRun ボタンをクリックして、過渡解析を実行します。
- シミュレーションが成功すると、Messagesパネルにシミュレーションが正常に完了したことが表示されます。このパネルは閉じてもかまいません。
-
Filter.sdfという名前の新しいシミュレーション結果ドキュメントが、SimDataエディターのドキュメントタブとして自動的に開きます。このドキュメントには、1つのTransient Analysisチャート(ドキュメント下部のタブで示されます)が含まれており、チャートには2つのプロットがあります。それぞれのプロットには、v(IN)とv(OUT)の波形が1つずつ含まれています。 - 設計スペース上部のタブをクリックして、回路図ドキュメントに切り替えます。
-
Simulation Dashboard パネルの AC Sweep 領域のヘッダー右側にある Run ボタンをクリックして、ACスイープ解析を実行します。
- Messages パネルを閉じます。
-
単一の AC Analysis チャートを含むシミュレーション結果ドキュメントが開きます。このチャートには2つのプロットがあり、それぞれに2つの波形が表示されます。
-
測定カーソルを使用して3dBポイントを求めます。
-
dB(v(OUT))波形を右クリックし、Cursor A を選択します。 -
マーカーをドラッグして、カーソルAをローパス領域に配置します(ローパス領域内であれば、正確な位置は問いません)。
-
dB(v(OUT))波形を再度右クリックし、Cursor B を選択します。 - Sim Data パネルを使用して、カーソルの位置を調整します(パネルが表示されていない場合は、設計スペースの右下にある Panels ボタンをクリックし、表示されるメニューから Sim Data を選択して表示します)。
- Sim Data パネルの Measurement Cursors 領域にある B-A Measurement の値を確認しながら、カーソルBをクリックしてドラッグし、Y(ゲイン)の値を-3にします。
-
Wave Name BのXの値は約20kとなり、フィルター回路の3dBポイントが20kHzであることがわかります。
- カーソルを消去するには、各カーソルマーカーを右クリックし、Cursor Off を選択します。
- ドキュメントのフィルタリングを解除するには、設計スペースの右下にある Clear ボタンをクリックします。
-
-
シミュレーション結果ドキュメント(
Filter.sdf)が、Projects パネルのプロジェクト構成内にあるGenerated\Simulation Documentsフォルダーに表示されます。ドキュメントを保存するには、Projects パネルでそのエントリを右クリックし、コンテキストメニューから Save As コマンドを選択します。Save As ダイアログが開き、ハードドライブ上のプロジェクトフォルダー内にある
Simulationサブフォルダーにドキュメントを保存できる状態になります。Save をクリックして、既定の場所に既定の名前でドキュメントを保存します。 - 設計スペース上部のタブをクリックして、回路図ドキュメントに切り替えます。
-
Simulation Dashboard パネルで、Results 折りたたみ可能な領域を展開します。この領域には、実行済みのシミュレーションの一覧(この例では Transient Analysis と AC Analysis)が表示されます。
-
以前に実行した過渡解析の結果を表示するには、Transient Analysis エントリの右側にある
ボタンをクリックし、Show Results を選択します。
シミュレーション結果ドキュメントが開き、過渡解析の結果が表示されます。
- 変更したプロジェクトドキュメントとプロジェクト自体を保存するには、Projects パネルでそれぞれのエントリを右クリックし、コンテキストメニューから Save コマンドを選択します。
- 接続先のWorkspaceにプロジェクトを作成した場合は、Projects パネルでプロジェクトのエントリを右クリックし、コンテキストメニューから Save to Server コマンドを選択して、表示される Save to Server ダイアログで OK をクリックします。




























