Altium Designer Documentation

Add

Created: May 11, 2019 | Updated: May 11, 2019

Parent page: UnifiedComponent Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Component

Summary

This command is used to add a single, new component definition to the active Component Library document.

Access

This command can be accessed from the Component Library Editor when configured in Batch Editor mode by:

  • Choosing the Edit » Add Component command from the main menus.
  • Right-clicking anywhere within the lower grid region, and choosing the Add Component command from the context menu.
If the Component Library Editor is currently in Single Component Editor mode, switch to the Batch Editor mode using the Tools » Switch to Batch Editor command.

Use

After launching the command, a new component definition will be added to the component definitions grid, at the bottom of the current list of component definitions.

Tips

  1. A new component definition can also be added by clicking the Add Component control, located below the definitions region.
  2. The new component definition's FolderPath and Item ID will adhere to defined options for the Default Folder and Component Naming, specified for the Component Library document through the Document Options dialog. If the Component Library document references a Component Template, these settings will come from that template (if defined).
  3. The software will automatically assign the next available unique ID, based on the Component Naming scheme applied, having scanned the entire server and identifiers of existing Items.
  4. The component definition will contain any default values for parameters defined in any referenced component template.


Applied Parameters: ObjectKind=Components

Summary

This command is used to add multiple new component definitions to the active Component Library document. In concert with multi-cell editing support, and copy/paste features, you can quickly build an impressive array of component definitions in quick time.

Access

This command can be accessed from the Component Library Editor, when configured in Batch Editor mode, by:

  • Choosing the Edit » Operations » Add Components command from the main menus.
  • Right-clicking anywhere within the lower grid region, and choosing the Operations » Add Components command from the context menu.
If the Component Library Editor is currently in Single Component Editor mode, switch to the Batch Editor mode using the Tools » Switch to Batch Editor command.

Use

After launching the command, the Add Components dialog will appear. Enter the number of components you wish to add and click OK - new component definitions for the specified number of components will be added to the component definitions grid, at the bottom of the current list of component definitions.

Tips

  1. Be advised that entering too large a number in the Add Components dialog can have an impact on performance, and may 'tie' the software for a considerable time while the request is processed.
  2. The new component definitions' FolderPath and Item ID will adhere to defined options for the Default Folder and Component Naming, specified for the Component Library document through the Document Options dialog. If the Component Library document references a Component Template, these settings will come from that template (if defined).
  3. The software will automatically assign the next available unique ID, based on the Component Naming scheme applied, having scanned the entire server and identifiers of existing Items.
  4. The component definitions will contain any default values for parameters defined in any referenced component template.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。