Altium NEXUS Documentation

PlaceOLEObject

Modified by Susan Riege on Aug 1, 2018

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to place an OLE object onto the active document. This is made possible through Object Linking and Embedding (OLE) technology in the PCB Editor, which allows data supplied by Windows OLE applications to be embedded in a PCB design while actively linked back to the source application. In many cases, this allows the embedded PCB data to be edited from within the application that created it.

Typical objects that might be placed in a PCB document include common Excel documents, Word documents or graphics objects from a suitable OLE image application. The supported file types include universal formats such as CSV and XLS format spreadsheets, DOC and RTF word documents, and BMP image files.

For detailed information about this object type, see OLE Object.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the Place » Object From File command from the main menus.
  • Right-clicking and choosing the Place » Object From File command from the context menu.

Use

First, make the layer on which you wish to place the OLE Object data the active layer in the workspace. After launching the command, the standard Windows Choose file dialog will open. Use this dialog to browse to the required OLE file - making sure it is a supported format! After clicking Open, the data from the chosen file will appear floating on the cursor. Position as required within the workspace then click or press Enter to effect placement.

Press the Tab key to access the Properties panel, from where properties for the OLE object can be changed on-the-fly. Pressing Tab pauses placement, allowing you to interact with the panel (or other area of the software) directly. To resume, click the pause symbol that appears over the workspace.

Tips

  1. Altium NEXUS’s Smart Paste capability also allows a selection in an OLE application to be copied and pasted (Edit » Paste) into the PCB document as an OLE object.
  2. To paste copied text from an OLE application as pure PCB text string primitive objects rather than a single OLE object, use the Edit » Paste Text command.
  3. An OLE Object can be converted to a collection of free primitive objects using the Tools » Convert » Explode OLE Object To Free Primitives command. This will break the object into appropriate Regions and/or Text objects. A convert to free primitives option is also offered if the matching OLE application cannot be found when attempting to edit an OLE Object.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。