Ansys CoDesigner
Ze względu na złożoność nowoczesnych produktów elektronicznych zawierających obwody wysokich częstotliwości i RF, podczas procesu projektowania PCB wymagana jest intensywna komunikacja między inżynierami PCB i symulacji, a komunikacja ta powinna być możliwie jak najbardziej przejrzysta i prosta dla obu stron. Nie wystarczy wyeksportować projektu zmienionego przez inżyniera PCB lub zoptymalizowanego przez inżyniera symulacji i przekazać go drugiej stronie – należy również poinformować, co zostało zmienione, co zwykle odbywa się e-mailem lub ustnie. Takie podejście nie jest idealne, ponieważ wymaga śledzenia wszystkich żądań i ręcznego porównywania danych w celu podjęcia decyzji o zmianach w projekcie lub rozpoczęcia nowej analizy. Te i inne powiązane wyzwania można pokonać dzięki Ansys CoDesigner, interfejsowi do przesyłania projektów płytek drukowanych między obszarem projektowania PCB a obszarem symulacji.
Obsługiwane oprogramowanie
Obecnie obsługiwana jest następująca platforma symulacyjna oraz jej wersje:
Ansys Electronics Desktop (AEDT) – wersja 2023 R1, 2023 R2, 2024 R1, 2024 R2, 2025 R1, 2025 R2, 2026 R1
Instalacja i konfiguracja
Aby uzyskać dostęp do Ansys CoDesigner w Altium Designer, należy zainstalować rozszerzenie programowe Ansys CoDesigner. To rozszerzenie można zainstalować lub usunąć ręcznie.
Aby uzyskać więcej informacji na temat zarządzania rozszerzeniami, zobacz stronę Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Aby uzyskać dostęp do Ansys CoDesigner w Ansys Electronics Desktop, należy zainstalować rozszerzenie Altium Link. Proces wygląda następująco:
-
Pobierz i rozpakuj archiwum rozszerzenia Altium Link. Można je uzyskać, kontaktując się z ansyscollaboration@altium.com (podaj używaną wersję AEDT).
-
Upewnij się, że aplikacja AEDT jest zamknięta.
-
W rozpakowanym folderze znajdź plik
install_altiumlink.bat, kliknij go prawym przyciskiem myszy i wybierz Run as administrator. -
Otwórz AEDT i wybierz polecenie Tools » Layout Links z menu głównego.
-
Na karcie Config w otwartym oknie dialogowym Layout Links kliknij przycisk Add Link, przejdź do folderu
\AnsysEM\<version>\Win64plików programu AEDT i otwórz plikaltiumlink.dll. -
Na karcie Layout Links okna dialogowego Layout Links upewnij się, że łącze Altium jest widoczne na liście, a następnie zamknij to okno.
Jak to działa
Po dodaniu funkcji Ansys CoDesigner do oprogramowania do projektowania PCB i symulacji możliwe jest przekazywanie zmian projektu w obie strony. Zmiany projektu są przekazywane za pośrednictwem Altium 365 Workspace, który działa jako pomost między tymi dwoma obszarami. Zaletą przekazywania zmian projektu przez Workspace jest to, że proces aktualizacji staje się stateless. Oznacza to, że każda ze stron może kontynuować pracę niezależnie; nie trzeba się martwić, na jakim etapie procesu projektowania/symulacji jest drugi zespół.
Ansys CoDesigner ułatwia dwukierunkowe przesyłanie i pobieranie zmian projektu między tymi dwoma obszarami. W Altium Designer wykrywane są zmiany w stosie warstw i materiałach, komponentach oraz elementach pierwotnych, które można zastosować w AEDT. Z AEDT proponowane zmiany stosu warstw i materiałów mogą zostać przesłane przez plik EDB i wykryte/zastosowane w Altium Designer. Inżynierowie ECAD i symulacji mogą komunikować się za pomocą systemu komentarzy, przy czym każdy wątek komentarzy jest przypisany do konkretnego komponentu w projekcie. Wyniki symulacji mogą być przesyłane z AEDT do Altium 365 Workspace i powiązane z rewizją projektu, z możliwością przeglądania ich w interfejsie przeglądarkowym Workspace oraz podglądu w Altium Designer.
Interfejs współpracy
-
W Altium Designer panel Ansys CoDesigner służy do przesyłania i pobierania zmian projektu w obie strony oraz wyświetlania komunikatów.
Panel Ansys CoDesigner jest dostępny z poziomu edytora PCB w Altium Designer po kliknięciu przycisku Panels w prawym dolnym rogu obszaru projektowego i wybraniu opcji Ansys CoDesigner z wyświetlonego menu. Pamiętaj, że aby uzyskać dostęp do panelu, musisz być połączony z Workspace, a dokument PCB musi być częścią projektu PCB przechowywanego w tym Workspace, aby można było korzystać z tej funkcji.
-
W AEDT okna dialogowe dostępne z poziomu okna Layout Links (Tools » Layout Links) lub z karty Desktop na wstążce po otwarciu projektu służą do:
- Połączenia z Altium 365 Workspace i importowania z niego projektu PCB.
- Przesyłania projektu do Workspace i pobierania go z Workspace.
- Przeglądania historii wymiany danych między Altium Designer i AEDT.
- Dodawania komentarzy do komponentów w projekcie.
Przesyłanie zmian z Altium Designer
Aby przesłać projekt z Altium Designer, kliknij przycisk Push w panelu Ansys CoDesigner . U góry panelu pojawi się okno edycji. Wprowadź komunikat dotyczący zmiany projektu, a następnie kliknij Send. Obszar Latest from Altium Designer panelu Ansys CoDesigner zostanie zaktualizowany o szczegóły tego przesłania.
Następnie projekt można zaimportować do AEDT. W przypadku projektu, który został już zaimportowany, zmiany można pobrać do AEDT.
Prześlij i udostępnij, aby zaprosić inżyniera symulacji
Po kliknięciu Push w panelu Ansys CoDesigner możesz również włączyć opcję Share poniżej pola Comment , aby wysłać zaproszenie e-mail do inżyniera symulacji za pomocą otwieranego po kliknięciu przycisku Send okna dialogowego Share with a Simulation Engineer.
Wprowadź adres e-mail inżyniera symulacji i opcjonalną notatkę (jeśli jest wymagana), a następnie kliknij przycisk Share. Możesz udostępnić projekt osobie, która jest już członkiem zespołu Workspace, innemu zarejestrowanemu użytkownikowi Altium wewnątrz lub poza Twoją organizacją albo użytkownikowi, który nie ma konta Altium. Może pojawić się okno dialogowe powiadomienia informujące, że użytkownik, którego adres e-mail został wprowadzony, może znajdować się poza Twoją organizacją – kliknij OK , aby mimo to go zaprosić.
Po krótkiej chwili pojawi się kolejne okno dialogowe informujące, że zaproszenie zostało pomyślnie wysłane.
W ramach procesu zapraszania:
- Użytkownik, który jest już członkiem zespołu Workspace, otrzyma udostępniony projekt z uprawnieniami View oraz wiadomość e-mail z zaproszeniem, dzięki której uzyska dostęp do projektu w Workspace.
- Użytkownik, który nie jest członkiem zespołu Workspace, ale ma konto Altium (niezależnie od tego, czy znajduje się w Twojej organizacji, czy poza nią), zostanie dodany jako członek zespołu Workspace, a projekt zostanie mu udostępniony z uprawnieniami View. Otrzyma wiadomość e-mail z zaproszeniem, dzięki której uzyska dostęp do projektu w Workspace.
- Użytkownik bez konta Altium otrzyma wiadomość e-mail kierującą do pośredniego formularza rejestracji założenia konta Altium. Po zarejestrowaniu zostanie dodany jako członek zespołu Workspace, a projekt zostanie mu udostępniony z uprawnieniami View.
Pobieranie zmian do Altium Designer
Gdy nowe zmiany zostaną przesłane z AEDT, baner New changes have been detected automatycznie pojawi się w panelu Ansys CoDesigner . Panel pokaże nazwę inżyniera symulacji, który wykonał przesłanie, oraz opcjonalny komentarz, który wprowadził podczas przesyłania.
Po kliknięciu przycisku Pull , jeśli plik EDB został dołączony do przesłania z AEDT, każda zmiana, którą trzeba wprowadzić do pliku roboczego w celu zsynchronizowania go ze zrzutem w Workspace, zostanie wyszczególniona. Każda wykryta różnica jest wymieniona na liście Changes w panelu. Wyczyść pole wyboru przy każdej zmianie, której nie chcesz zastosować. Gdy wszystko będzie gotowe, kliknij przycisk Apply, aby zastosować wszystkie włączone zmiany do projektu.
Jeśli wyniki symulacji zostały dołączone do przesłania z AEDT, w panelu zostanie pokazany element sterujący Design Summary . Kliknij ten element, aby wyświetlić wyniki symulacji w oknie dialogowym Design Summary.
Importowanie projektu do AEDT
Aby rozpocząć pracę nad projektem PCB w AEDT, należy najpierw zaimportować go do AEDT. W tym celu:
- W oknie dialogowym Layout Links (Tools » Layout Links) kliknij komórkę [Action] dla łącza Altium na karcie Layout Links i wybierz Projects. Alternatywnie kliknij przycisk Projects na karcie Desktop na wstążce po otwarciu projektu. Otworzy się okno dialogowe Altium.
-
Zaloguj się na swoje konto Altium. Upewnij się, że na liście rozwijanej u góry okna dialogowego wybrano pozycję Altium Account, a następnie kliknij przycisk Sign In. W domyślnej przeglądarce otworzy się strona, na której możesz wprowadzić dane logowania do konta Altium lub użyć SSO, aby się zalogować – pokaż przykład.
- Wybierz Workspace, w którym znajduje się wymagany projekt, z listy rozwijanej Workspace.
-
Wybierz projekt z listy Projects i kliknij przycisk Import.
- Zapisz plik projektu AEDT, korzystając z otwartego okna dialogowego Save As, a następnie zamknij okno dialogowe Altium.
Przesyłanie zmian z AEDT
Aby przesłać projekt z AEDT:
- W oknie dialogowym Layout Links (Tools » Layout Links) kliknij komórkę [Action] dla łącza Altium na karcie Layout Links i wybierz Push/Pull. Alternatywnie kliknij przycisk Push/Pull na karcie Desktop na wstążce, gdy projekt jest otwarty.
- Użyj pola Comment u góry otwartego okna dialogowego, aby dodać komentarz opisujący, co zawiera przesłanie.
- Włącz opcje Include EDB file (aby przesłać zmiany projektu) i/lub Include the Simulation Result (aby przesłać wyniki symulacji).
- Kliknij przycisk Push to Altium 365. Obszar Latest from Ansys okna dialogowego zostanie zaktualizowany o szczegóły tego przesłania.
Przesłanie zostanie wykryte w Altium Designer i będzie można je pobrać do Altium Designer zgodnie z opisem powyżej.
Pobieranie zmian do AEDT
Gdy zmiany projektu zostaną przesłane z Altium Designer, można je pobrać w AEDT.
- W oknie dialogowym Layout Links (Tools » Layout Links) kliknij komórkę [Action] dla łącza Altium na karcie Layout Links i wybierz Push/Pull. Alternatywnie kliknij przycisk Push/Pull na karcie Desktop na wstążce, gdy projekt jest otwarty.
-
Sprawdź obszar Latest From Altium otwartego okna dialogowego, aby uzyskać informacje o najnowszym przesłaniu z Altium Designer, i kliknij przycisk Show Changes, aby otworzyć okno dialogowe, w którym opisano różnice między projektem w Workspace a bieżącym projektem w AEDT. Użyj pól wyboru dostępnych na kartach tego okna dialogowego, aby wskazać zmiany, które chcesz zastosować do projektu w AEDT.
- Po przejrzeniu zmian kliknij przycisk Apply changes, aby zastosować zmiany do projektu w AEDT.
Przeglądanie historii wymiany
Historia przesłań i pobrań projektu jest zachowywana.
Aby przejrzeć historię w Altium Designer, kliknij element sterujący History po prawej stronie tytułu obszaru Latest from the Ansys w panelu Ansys Codesigner . Otworzy się lista przesłań i pobrań zarówno z Altium Designer, jak i Ansys . Użyj przycisku
u góry panelu, aby wrócić do najnowszych zmian.
Aby przejrzeć historię w AEDT, kliknij komórkę [Action] dla łącza Altium na karcie Layout Links okna dialogowego Layout Links (Tools » Layout Links) i wybierz Push/Pull lub Comment albo kliknij przycisk Push/Pull lub Comment na karcie Desktop na wstążce. Wybierz kartę History w otwartym oknie dialogowym. Rozwiń wpis dotyczący przesłania/pobrania, aby zobaczyć jego szczegóły. Użyj przycisku Refresh, aby odświeżyć kartę najnowszymi danymi.
Dodawanie komentarzy w Altium Designer i AEDT
Zarówno inżynierowie elektrycy, jak i inżynierowie symulacji mogą również skorzystać z obsługi komentarzy w Workspace, tworząc wątki komentarzy przypisane do konkretnych komponentów.
W Altium Designer istniejące komentarze są dostępne w panelu Comments and Tasks.
-
Aby dodać nowy komentarz do komponentu na PCB, kliknij przycisk Comments u góry panelu, przesuń kursor nad komponentem w obszarze projektowym, tak aby został podświetlony niebieską ramką, i kliknij. W otwartym oknie wprowadzania komentarza wpisz komentarz i kliknij Post.
-
Aby odpowiedzieć na komentarz, wybierz wpis komentarza w panelu Comments and Tasks, wpisz odpowiedź w udostępnionym polu tekstowym w oknie wprowadzania komentarza i kliknij Reply. Odpowiedź zostanie dodana do wątku komentarza.
Zobacz stronę Document Commenting , aby dowiedzieć się więcej.
W AEDT wątki komentarzy są zarządzane na karcie Comments okna dialogowego Altium, dostępnego po kliknięciu komórki [Action] dla łącza Altium na karcie Layout Links okna dialogowego Layout Links (Tools » Layout Links) i wybraniu Comment. Lista w górnej części okna dialogowego przedstawia istniejące wątki komentarzy dla projektu.
Aby dodać komentarz do komponentu w AEDT:
- Wybierz konkretny komponent w panelu Components (View » Components) lub w obszarze projektowym.
- W oknie dialogowym Layout Links (Tools » Layout Links) kliknij komórkę [Action] dla łącza Altium na karcie Layout Links i wybierz Comment.
- Wpisz komentarz w polu Comment w dolnej części otwartego okna dialogowego.
- Kliknij przycisk Create Thread. Do listy zostanie dodany nowy wątek.
Aby odpowiedzieć na istniejący wątek z AEDT:
- Wybierz ponumerowany wpis komentarza na liście na karcie Comments okna dialogowego Altium.
- Wpisz odpowiedź w polu Comment w dolnej części okna dialogowego.
- Kliknij przycisk Reply Thread. Nowa odpowiedź zostanie dodana pod wpisem powiązanego wątku komentarza na liście.












