Building & Maintaining Your Components and Libraries
W skrócie
- Dowiedz się, jak symbole schematowe, footprinty PCB i inne modele odwzorowują rzeczywiste komponenty.
- Porównaj dostępne rodzaje bibliotek i poznaj funkcje obszaru roboczego, takie jak współdzielenie danych komponentów, ponowne wykorzystywanie modeli, informacje o łańcuchu dostaw i śledzenie cyklu życia.
- Dowiedz się, jak rozpocząć tworzenie komponentu w obszarze roboczym za pomocą edytora komponentów i szablonów komponentów.
Projekt elektroniczny to zbiór połączonych ze sobą komponentów. Satysfakcjonującą częścią opracowywania produktu jest wymyślanie ciekawych sposobów rozwiązywania wyzwań inżynierskich oraz łączenie komponentów w celu stworzenia unikalnego projektu.
Jednak znaczną część pracy — dla wielu projektantów tę bardziej żmudną — stanowi tworzenie komponentów. Choć może to nie być ekscytujące, komponenty stają się cennym zasobem firmy i muszą dokładnie odwzorowywać rzeczywiste elementy.
Element, który kupujesz i lutujesz na płytce lub wykorzystujesz w wiązce przewodów, jest elementem rzeczywistym, ale musi on zostać odwzorowany w każdej dziedzinie projektowania elektroniki, w której zamierzasz go używać.
W zależności od planowanego sposobu realizacji projektu komponent może zawierać symbol na schemat, model symulacyjny do symulatora obwodów, model IBIS do analizy integralności sygnałów, wzorzec lub footprint do projektowania PCB oraz model 3D do wizualizacji, sprawdzania odstępów w 3D i eksportu do mechanicznego środowiska CAD.
Zarządzanie komponentami
Skuteczne zarządzanie danymi komponentów ma kluczowe znaczenie w projektowaniu elektroniki, a zarządzanie komponentami używanymi w projekcie od zawsze było podstawowym elementem oprogramowania projektowego Altium. Wraz z rozwojem oprogramowania na przestrzeni lat metody zarządzania komponentami przeszły długą drogę: od prostych, oddzielnych bibliotek modeli schematowych i PCB, przez biblioteki bazodanowe, aż po komponenty obszaru roboczego, które udostępniają reprezentację komponentów projektowych szerszemu gronu uczestników procesu rozwoju produktu, wraz z nowoczesnymi i łatwymi w obsłudze funkcjami zapewniającymi wyjątkowe możliwości współpracy podczas całego procesu projektowania.
| Biblioteka obszaru roboczego | Komponenty przechowywane w połączonym obszarze roboczym, który stanowi jedno źródło aktualnych i ustandaryzowanych danych komponentów dla całego zespołu projektowego. Wyszukiwanie parametryczne i fasetowe pozwala szybko i sprawnie znajdować oraz umieszczać potrzebne elementy. Komponenty te są ściśle powiązane z rzeczywistymi produkowanymi elementami i danymi łańcucha dostaw dostępnymi już podczas projektowania, co umożliwia znaczne ograniczenie kosztów i czasu zaopatrzenia na etapie produkcji i montażu produktu. |
|
| Biblioteka bazodanowa | Chcesz ściśle powiązać komponenty projektowe z firmową bazą danych? Poznaj biblioteki bazodanowe. Każdy rekord jest komponentem i zawiera odwołania do wymaganych modeli oraz danych parametrycznych komponentu. Powiązania z modelami i parametry są dodawane do symbolu podczas jego umieszczania, przekształcając go w komponent Altium Designer. | |
| Biblioteka bazodanowa SVN | Biblioteka bazodanowa SVN jest rozszerzeniem modelu biblioteki bazodanowej, z tą różnicą, że źródłowy symbol i modele są objęte kontrolą wersji. Biblioteki źródłowe są tworzone, rozbudowywane i utrzymywane w repozytorium opartym na systemie Subversion. Powiązanie z repozytorium oraz z zewnętrzną bazą danych jest definiowane w pliku biblioteki bazodanowej SVN (*.SVNDbLib). |
|
| Łącze do bazy danych | W tej metodzie plik łącza do bazy danych (*.DbLink) definiuje powiązanie między komponentem na schemacie a pasującym rekordem w bazie danych. Dopasowanie rekordu jest ustalane za pomocą powiązania pól kluczowych: może to być jedno pole kluczowe (na przykład numer części) lub wiele pól kluczowych (poprzez zdefiniowanie klauzuli WHERE). |
|
| Biblioteka zintegrowana | Wolisz mieć komponenty przygotowane i zweryfikowane w jednym pliku? Skompiluj źródłowe modele schematowe, PCB i symulacyjne, aby wygenerować bibliotekę zintegrowaną (*.IntLib). |
|
| Biblioteka schematowa | Biblioteka schematowa (*.SchLib) może być biblioteką modeli zawierającą symbole komponentów. Jeśli jednak do każdego symbolu zostaną dodane powiązania z modelami i dane parametryczne, staje się biblioteką komponentów. |
|
| Biblioteka PCB | Biblioteka do przechowywania modeli footprintów PCB (*.PcbLib). W razie potrzeby do każdego footprintu można dodać model 3D. Modele 3D tworzy się z obiektów brył 3D lub z modelu STEP zaimportowanego do obiektu bryły 3D. |
Biblioteka obszaru roboczego
Komponenty są przechowywane w Twoim obszarze roboczym — jednej centralnej, bezpiecznej lokalizacji na wszystkie dane projektowe, dostępnej dla całego zespołu projektowego. Korzyści z korzystania z komponentów przechowywanych w obszarze roboczym są ogromne. Oto niektóre z nich:
-
Single source of component data – dzięki obszarowi roboczemu dostępnemu dla całego zespołu inżynierowie mogą pobierać aktualne i ustandaryzowane komponenty z jednej bezpiecznej lokalizacji, uzyskiwać dane łańcucha dostaw w czasie rzeczywistym oraz korzystać z wyszukiwania parametrycznego i fasetowego, aby znaleźć dokładnie te komponenty, których potrzebują.
-
Design-time choice of physical components – dla każdego komponentu można wybrać, które części producentów mogą zostać użyte do jego realizacji podczas montażu płytki.
-
Real-time supply-chain information – informacje zwrotne z agregowanej bazy części Altium Parts Provider (która z kolei łączy się z aktywnymi dostawcami i gromadzi oferowane przez nich części) pozwalają projektantowi poznać aktualne ceny i dostępność wybranych części u wszystkich sprzedawców oferujących te części (zgodnie z definicją w lokalnym katalogu części obszaru roboczego). Informacje te można dodać do komponentu w dowolnym momencie, również po zapisaniu go w obszarze roboczym — bez bezpośredniej edycji komponentu, a tym samym bez wpływu na projekty, w których jest już używany — a następnie wykorzystać w zestawieniu materiałowym.
-
Concurrent editing of the library – ponieważ biblioteka obszaru roboczego jest zasadniczo zbiorem elementów komponentów przechowywanych w tym obszarze, wielu użytkowników może niezależnie edytować lub tworzyć nowe komponenty biblioteki, bez konieczności czekania, aż inni użytkownicy zakończą swoją pracę.
-
Component Models Reuse – komponent można traktować jako „pojemnik”, w którym przechowywane są wszystkie informacje parametryczne i modele dziedzinowe, w tym symbol schematowy, footprinty PCB oraz modele połączeń wiązek przewodów i modele symulacyjne. Komponent nie zawiera samych modeli dziedzinowych, lecz powiązania z odpowiednimi elementami modeli, które również znajdują się w obszarze roboczym. Dzięki temu jeden model dziedzinowy może być używany przez wiele komponentów. Jeśli model się zmieni, otrzymasz sugestię zaktualizowania wszystkich komponentów, które z niego korzystają, co pozwala zadbać o to, aby żaden komponent nie używał nieaktualnego modelu.
-
Direct Component Editing – jeśli komponent wymaga edycji, możesz otworzyć go do edycji bezpośrednio z obszaru roboczego. Tymczasowa instancja edytora komponentów umożliwia edycję wszystkich aspektów komponentu, w tym modyfikowanie powiązanych z nim modeli dziedzinowych, bez konieczności pracy z dokumentami plikowymi.
-
Use of Component Templates – stosuj szablony oparte na parametrach i klasyfikacji komponentów, aby każdy nowy typ komponentu automatycznie otrzymywał właściwy zestaw parametrów zgodny z wymaganiami BOM, a także automatyzować stosowanie odpowiednich schematów nazewnictwa, rewizji i cyklu życia.
-
Component Lifecycle Validation – jeśli komponent ma stan „koniec cyklu życia”, „wycofany” lub „porzucony”, otrzymasz ostrzeżenie przed próbą wyprodukowania płytek, które go wykorzystują.
-
Where-used Component Traceability – można prześledzić wszystkie miejsca użycia komponentów: jeśli część zostanie wycofana, możesz sprawdzić, w których projektach została użyta, aby ustalić, które z nich wymagają aktualizacji. Jeśli symbol lub footprint zawiera błąd, możesz wyświetlić wszystkie komponenty korzystające z tego symbolu i footprintu, aby je poprawić.
-
Requests of new components – inżynier może przesyłać zgłoszenia dotyczące nowych lub brakujących komponentów do wyznaczonych opiekunów bibliotek i otrzymywać powiadomienia, gdy dany komponent będzie dostępny do wykorzystania w projektach przez zgłaszającego i innych inżynierów w firmie.
Tworzenie nowego komponentu biblioteki przestrzeni roboczej
Fizyczny komponent montowany na płytce lub używany do produkcji wiązki przewodów jest reprezentowany przez symbol schematowy podczas tworzenia schematu oraz przez obudowę PCB podczas projektowania płytki (opcjonalnie z modelem 3D do wizualizacji, sprawdzania odstępów w 3D i eksportu do środowiska mechanicznego CAD). Komponent projektowy może również zawierać model symulacyjny dla symulatora obwodów oraz model IBIS do analizy integralności sygnałów. Aby zapewnić reprezentację komponentów projektowych w szerszym procesie rozwoju produktu, można dodać do komponentu co najmniej jeden wariant części.
Komponenty do projektu można tworzyć i umieszczać w bibliotece przestrzeni roboczej firmy. Umieszcza się je za pośrednictwem panelu Components, który korzysta z zaawansowanej wyszukiwarki komponentów Altium Designer.
Nowy komponent biblioteki przestrzeni roboczej tworzy się w edytorze komponentów, w którym można ręcznie zdefiniować wszystkie dane komponentu (modele dziedzinowe, parametry, warianty części itp.) lub skorzystać z danych pobranych z panelu Manufacturer Part Search.
Aby utworzyć nowy komponent biblioteki przestrzeni roboczej:
-
Wybierz polecenie tworzenia komponentu. Dostęp do niego można uzyskać w następujący sposób:
-
Wybierz polecenie File » New » Component z menu głównego.
-
Wybierz File » New » Library z menu głównego, a następnie w otwartym oknie dialogowym New Library wybierz Create Library Content » Component w obszarze Workspace tego okna.
-
W panelu Komponenty kliknij prawym przyciskiem myszy obszar listy komponentów i wybierz polecenie Create z menu kontekstowego.
-
-
W otwartym oknie dialogowym Create new component wybierz typ komponentu. Jeśli z wybranym typem komponentu jest powiązany szablon komponentu, dane z tego szablonu zostaną użyte do wstępnego zdefiniowania komponentu.

Otwórz okno dialogowe Create new component, aby wybrać typ tworzonego komponentu. -
Po kliknięciu OK otworzy się edytor komponentów w trybie edycji pojedynczego komponentu. Udostępnia on uproszczony interfejs do definiowania i edytowania pojedynczego komponentu.
-
Zdefiniuj komponent, dodając jego szczegóły w edytorze komponentów:
- W obszarze Component edytora komponentów zdefiniuj Name i Description komponentu. Te informacje są niezbędne do późniejszego wyszukiwania komponentów, gdy zechcesz użyć potrzebnego komponentu w projekcie.
-
Kliknij element sterujący Advanced Settings, aby zdefiniować lub zmienić inne szczegóły komponentu, takie jak Id używany dla komponentu zapisanego w przestrzeni roboczej oraz Folder w docelowej przestrzeni roboczej, w której komponent zostanie zapisany.
-
W obszarze Parameters edytora komponentów zdefiniuj dodatkowe szczegóły komponentu: standardowe parametry, łącza URL do stron internetowych (na przykład witryny producenta) oraz łącza do kart katalogowych (w dowolnym formacie).
-
W obszarze Part Choices edytora komponentów określ co najmniej jeden wariant części dla komponentu – „dozwolone” części producentów, których można użyć do realizacji komponentu na zmontowanej płytce.
-
W obszarze Models edytora komponentów dodaj łącza do zapisanych (lub tworzonych na bieżąco) modeli dziedzinowych, z których komponent będzie korzystać. Komponent może mieć jeden symbol schematowy oraz wiele obudów PCB i modeli symulacyjnych albo jeden model okablowania wiązki. Komponent musi mieć co najmniej jeden model.
-
Zweryfikuj zdefiniowany komponent, aby upewnić się, że spełnia wymagania zgodnie z ustawieniami na stronie Zarządzanie danymi – Sprawdzanie reguł komponentów w oknie dialogowym Preferences. Zapisz komponent lokalnie (File » Save), a następnie wybierz polecenie Tools » Component Rule Check z menu głównego. Wszystkie wykryte naruszenia zostaną wyświetlone w panelu Messages.
-
Po zdefiniowaniu komponentu wybierz polecenie File » Save to Server z menu głównego, aby zapisać komponent w przestrzeni roboczej. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać uwagi do wydania. Po zapisaniu edytor zostanie zamknięty.
Nowy komponent będzie można wyszukiwać i wykorzystywać za pośrednictwem panelu Komponenty.
Uwagi
-
Aby utworzyć nowy komponent podobny do istniejącego komponentu w przestrzeni roboczej, możesz utworzyć jego kopię. W panelu Components znajdź odpowiedni komponent, kliknij go prawym przyciskiem myszy i wybierz polecenie Operations » Make a copy. Otworzy się edytor komponentów z komponentem wstępnie zdefiniowanym na podstawie danych wybranego komponentu.
-
Komponent można zdefiniować przy użyciu danych udostępnianych przez funkcję wyszukiwania części producentów. Zacznij wpisywać tekst w polu Name i wybierz pasującą część producenta lub dodaj wariant części do definiowanego komponentu, a otworzy się okno dialogowe Use Component Data z opcjami wyboru danych, które chcesz zastosować do aktualnie tworzonego lub edytowanego komponentu: nazwy, opisu, parametrów, modeli i kart katalogowych.

Dane komponentu można pobrać za pomocą funkcji wyszukiwania części producentów. Pokazano tutaj przykład dostępu do tej funkcji przez wpisanie nazwy komponentu w polu Name i wybranie pasującej pozycji z listy podręcznej. -
Edytor komponentów może również działać w trybie edycji zbiorczej komponentów, który udostępnia interfejs do definiowania i edytowania wielu komponentów. Gdy edytor komponentów działa w trybie Single Component Editing, dostęp do trybu edycji zbiorczej można uzyskać, wybierając polecenie Tools » Switch to Batch Editor z menu głównego edytora.
-
Aby szybko zaimportować istniejące biblioteki plikowe i bazodanowe (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) do przestrzeni roboczej, można użyć narzędzia Library Importer. Library Importer to rozwiązanie umożliwiające import jednym kliknięciem, które automatycznie analizuje wybrane biblioteki i importuje je do przestrzeni roboczej, z którą aktualnie masz połączenie.
-
Nowy komponent można również utworzyć, klikając prawym przyciskiem myszy pozycję połączonej przestrzeni roboczej w panelu Projects i wybierając z menu polecenie Create Component.
-
Aby edytować komponent przestrzeni roboczej, kliknij prawym przyciskiem myszy pozycję komponentu w panelu Components i wybierz polecenie Edit z menu kontekstowego. Otworzy się edytor komponentów w trybie Single Component Editing, z definicją komponentu otwartą do edycji. Wprowadź wymagane zmiany, a następnie zapisz definicję komponentu jako kolejną rewizję komponentu przestrzeni roboczej.
-
W ten sam sposób można zaznaczyć wiele komponentów w panelu Components i wybrać polecenie Edit z menu kontekstowego. Jeśli wybrane komponenty odwołują się do tego samego szablonu komponentu, otworzy się jedna instancja edytora komponentów w trybie edycji zbiorczej komponentów. W przeciwnym razie dla każdej grupy komponentów korzystających z tego samego szablonu komponentu otworzy się osobna instancja edytora komponentów.
-
Komponenty przestrzeni roboczej otwarte do edycji są wyświetlane pod pozycją Workspace Components w panelu Projects.
Z menu kontekstowego pozycji Workspace Component, dostępnego po kliknięciu prawym przyciskiem myszy, można otworzyć komponenty w grupie, zamknąć je, zapisać lokalnie, zapisać w połączonej przestrzeni roboczej lub odrzucić zmiany (zamknąć bez wprowadzania zmian)
. Jeśli podczas korzystania z polecenia Close All zmodyfikowano wiele komponentów w grupie, zostanie wyświetlone okno dialogowe potwierdzenia zapisu z opcjami dotyczącymi pracy z obiektem przestrzeni roboczej otwartym do edycji
-
Przy próbie otwarcia komponentu przestrzeni roboczej do edycji przez użytkownika z uprawnieniami tylko do odczytu otworzy się edytor komponentów, umożliwiając dostęp do szczegółów komponentu, ale bez możliwości zapisania jakichkolwiek zmian w przestrzeni roboczej. W takim przypadku pozycja tego komponentu przestrzeni roboczej w panelu Projects jest wyświetlana z etykietą Local Edits Only
-
Podczas zapisywania edytowanego komponentu w bibliotece przestrzeni roboczej można zachować bieżący stan cyklu życia komponentu. Umożliwia to opcja Preserve lifecycle state (not recommended) dostępna w oknie dialogowym Edit Revision podczas ponownego zapisywania (pokaż ilustrację). Gdy opcja ta jest włączona, nowej rewizji komponentu zostanie automatycznie przypisany stan cyklu życia poprzedniej rewizji. Ta możliwość jest dostępna dla osób z przypisanym uprawnieniem do operacji Allow to skip lifecycle state change for new revisions (dowiedz się więcej o ustawianiu globalnych uprawnień do operacji w przestrzeni roboczej).
Biblioteki bazodanowe
Altium Designer umożliwia umieszczanie komponentów bezpośrednio z firmowej bazy danych przez utworzenie i używanie Database Library. Umieszczanie odbywa się z poziomu panelu Components, który po zainstalowaniu biblioteki bazodanowej pełni funkcję przeglądarki bazy danych.
Po umieszczeniu komponentów informacje o parametrach projektu można synchronizować między umieszczonymi komponentami a odpowiadającymi im powiązanymi rekordami w bazie danych. Można przeprowadzać pełne aktualizacje komponentów, obejmujące symbol graficzny, odwołania do modeli i parametry. Informacje o parametrach z bazy danych można również uwzględnić w końcowym zestawieniu materiałowym (BOM), gotowym do wykorzystania przy zakupie komponentów.
Przeczytaj o bibliotekach bazodanowych.
Biblioteki plikowe
Jeśli chcesz przechowywać komponenty lokalnie w swoim systemie plików, możesz uporządkować je w bibliotekach plikowych.
Biblioteka plikowa Altium Designer to dowolny zbiór modeli lub komponentów. Sposób organizacji modeli lub komponentów w bibliotekach zależy od Ciebie. Możesz uporządkować biblioteki według dostawców elementów lub pogrupować komponenty według funkcji, na przykład tworząc bibliotekę wszystkich mikrokontrolerów używanych w Twojej firmie.
Symbole schematowe komponentów są tworzone w bibliotekach schematowych (*.SchLib). Komponenty w tych bibliotekach odwołują się następnie do footprintów i innych modeli zdefiniowanych w osobnych bibliotekach footprintów (*.PcbLib) oraz plikach modeli. Jako projektant możesz umieszczać komponenty z tych oddzielnych bibliotek komponentów lub skompilować biblioteki symboli, biblioteki footprintów i pliki modeli w biblioteki zintegrowane (*.IntLib).
Przeczytaj o plikowych bibliotekach komponentów.
Modele
Z perspektywy projektanta komponent skupia w jednym obiekcie wszystkie informacje potrzebne do jego reprezentacji we wszystkich dziedzinach projektowania. Pod tym względem można go więc traktować jako kontener.
Każdy komponent jest zbiorem powiązanych modeli i danych parametrycznych komponentu. To właśnie modele zawierają szczegółowe informacje wymagane w każdej dziedzinie projektowania.
Można używać następujących typów modeli:
| Symbol schematowy | Symbol reprezentuje komponent na arkuszu schematu. Symbol jest tworzony przy użyciu standardowych obiektów rysunkowych, a wyprowadzenia nadają mu właściwości elektryczne. |
| Model SPICE | Symuluj działanie połączonych komponentów za pomocą symulatora SPICE. Modele SPICE są zwykle pozyskiwane od dostawców elementów. |
| Model integralności sygnałów | Wraz ze wzrostem szybkości przełączania elementów i układów połączenia na PCB stają się częścią obwodu. Modele IBIS opisują zachowanie wyprowadzeń, umożliwiając symulatorowi integralności sygnałów w Altium Designer analizowanie ścieżek. |
| Footprint PCB | Każdy komponent musi mieć zdefiniowane miejsce na PCB, w którym jest montowany i podłączany — footprint jest modelem definiującym ten obszar PCB. Footprint PCB jest tworzony ze zbioru standardowych obiektów, a pola lutownicze zapewniają połączenia elektryczne. |
| Model 3D | Współczesne produkty elektroniczne są kompaktowe, mają gęsto upakowane elementy i nietypowe kształty, a ich płytki PCB mogą być zginane, aby zmieściły się w obudowie. Aby zaprojektować taki produkt, potrzebujesz możliwości modelowania płytki PCB w 3D — dzięki temu możesz zwizualizować gotową płytkę, sprawdzić odstępy w 3D i przenieść płytkę z zamontowanymi komponentami do środowiska mechanicznego CAD. W tym celu potrzebny będzie model 3D każdego komponentu. |
Przeczytaj o tworzeniu i zarządzaniu symbolami, modelami obudów PCB, modelami symulacyjnymi oraz modelami 3D w swojej przestrzeni roboczej.
Panel Components
Panel Components zapewnia bezpośredni dostęp do wszystkich dostępnych komponentów w Altium Designer, w tym komponentów z przestrzeni roboczej, baz danych i bibliotek plikowych.
Panel pobiera komponenty z przestrzeni roboczej oraz wszystkich otwartych lub zainstalowanych plików bibliotek. Udostępnia pełne informacje o wybranym komponencie (parametry, modele, warianty części, dane dostawców itp.), umożliwia porównywanie komponentów, a w przypadku komponentów z przestrzeni roboczej oferuje wyszukiwanie parametryczne oparte na filtrach, pozwalające określić docelowe parametry komponentu. Dzięki kontekstowym filtrom dynamicznym funkcja wyszukiwania w panelu pozwala szybko znaleźć dokładnie tę część, której potrzebujesz, w połączonej przestrzeni roboczej Twojej firmy.
Przeczytaj o panelu Components.
Panel Manufacturer Part Search
Możesz także wyszukiwać rzeczywiste części oferowane przez producentów za pomocą panelu Manufacturer Part Search, który wykorzystuje podstawowe funkcje wyszukiwarki i widok stosowane w panelu Components. Wybrana część producenta może posłużyć jako podstawa do utworzenia nowego komponentu w połączonej przestrzeni roboczej, a jej parametry i karty katalogowe można dodać do umieszczonego komponentu.
Ikona
przy pozycji części oznacza, że do tego komponentu przypisano modele (symbole schematowe, obudowy PCB, modele symulacyjne). Podczas tworzenia nowego komponentu na podstawie tej części producenta zostaną również pobrane jej modele. Możesz też pobrać tę część lokalnie lub umieścić ją bezpośrednio na schemacie.
Przeczytaj o panelu Manufacturer Part Search.
Co dalej?
Tworzenie symbolu schematowego
Tworzenie komponentu połączeń wiązki przewodów



).
).



