SI Analyzer da Keysight

Num relance

Este artigo apresenta o SI Analyzer by Keysight para o Altium Designer e explica como ele ajuda a realizar verificações de integridade de sinal após o layout para parâmetros essenciais de projetos de alta velocidade, como impedância, atraso, perdas de inserção e perdas de retorno. Ele mostra como acessar e iniciar a extensão, adicionar e gerenciar redes, atribuir ou criar especificações, definir restrições e preparar um projeto para análise. Também destaca requisitos importantes, como a instalação, o acesso por assinatura para executar novas análises e o comportamento de atualização do documento quando os dados da PCB são alterados. Se você quer entender melhor como configurar e gerenciar a análise de integridade de sinal diretamente no seu ambiente de projeto, este guia ajudará você a começar com confiança. Continue lendo.

- Saiba o que a extensão SI Analyzer by Keysight faz no Altium Designer e quais tipos de verificação de integridade de sinal ela oferece.
- Veja como instalar a extensão, abrir um documento do SI Analyzer, adicionar redes ou classes e atribuir especificações predefinidas ou personalizadas.
- Entenda o fluxo de trabalho básico para preparar restrições e dados de análise, permitindo que você avance para a execução de verificações de integridade de sinal no seu projeto.
Aprofunde-se com a IA:

Cada vez mais dispositivos eletrônicos modernos incorporam projetos de PCB de alta velocidade, e as velocidades dos sinais aumentam à medida que as tecnologias evoluem (17 GHz em DDR6, 400 Gbps em QSFP++ etc.). Garantir a integridade de sinal (SI) é uma etapa crucial no projeto de alta velocidade. O não cumprimento dos requisitos do desenvolvedor da interface tem grande probabilidade de causar problemas nas etapas posteriores do projeto, na fabricação e no desempenho.

Para realizar uma análise de integridade de sinal diretamente no ambiente do Altium Designer, a solução SI Analyzer by Keysight está disponível. Fornecido como uma extensão de software, o SI Analyzer by Keysight integra-se diretamente ao Altium Designer para permitir a realização de uma série de verificações de SI pós-layout que abrangem os parâmetros mais importantes do projeto de alta velocidade:

  • Impedância

  • Atraso

  • Perdas de inserção (IL)

  • Perdas de retorno (RL)

O SI Analyzer by Keysight está em beta aberto.

Se você prefere aprender assistindo a vídeos, confira a playlist de vídeos de tutoriais do Signal Analyzer by Keysight na Altium Academy.

Acessando a funcionalidade do SI Analyzer by Keysight

Para acessar a funcionalidade do SI Analyzer by Keysight no Altium Designer, a extensão de software SI Analyzer by Keysight  deve estar instalada. Essa extensão pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Ao clicar para baixar e instalar a extensão, a End-User License Agreement é aberta (). Clicar em Accept indica sua aceitação dos termos e condições do EULA; ao fazer isso, a instalação continuará. Clicar em Close indica que você não aceita os termos e condições do EULA, e o processo de instalação será interrompido.

Quando a extensão de software SI Analyzer by Keysight está instalada, ela permite:

  • Criar um novo documento do SI Analyzer by Keysight ou abrir um existente.

  • Adicionar e configurar nets para uma análise de SI.

  • Revisar os resultados de análises de SI existentes.

  • Gerar um relatório de análise de SI.

No entanto, para realizar uma nova análise de SI, você precisa ter uma assinatura válida do SI Analyzer by Keysight. Caso contrário, uma tentativa de iniciar uma análise de SI abrirá a caixa de diálogo Analyze Your Nets, na qual você poderá solicitar uma avaliação gratuita ().

Iniciando o SI Analyzer by Keysight

Para iniciar a análise de integridade de sinal, abra o documento de PCB do projeto e selecione Tools » SI Analyzer by Keysight nos menus principais.

O documento do SI Analyzer by Keysight (<ProjectName> [SIK]) será aberto e adicionado à área Source Documents do projeto (no painel Projects). Inicialmente, o documento não está salvo. Use o comando File » Save As nos menus principais para salvar o documento no local desejado.

  • Após salvar um documento do SI Analyzer by Keysight, executar o comando Tools » SI Analyzer by Keysight nos menus principais do editor de PCB criará outro documento do SI Analyzer by Keysight, que poderá ser usado para configurar outra análise de integridade de sinal. Para trabalhar em um documento do SI Analyzer by Keysight criado anteriormente, abra-o clicando duas vezes em sua entrada no painel Projects.

  • Se o projeto de PCB for alterado após a criação do documento do SI Analyzer by Keysight, o documento ficará desatualizado, e a mensagem de aviso PCB data is outdated será exibida no canto superior direito do documento. Nesse caso, não será possível gerenciar as nets do documento nem executar uma análise. Para atualizar o documento do SI Analyzer by Keysight com os dados da PCB, clique no controle Refresh ao lado da mensagem de aviso.

Preparando para a análise

Adicionando nets a serem analisadas

Após iniciar o SI Analyzer by Keysight, os dados da PCB são importados (no formato ODB++) para o solver. Nessa etapa, você pode definir a lista de nets a serem analisadas e atribuir especificações a elas. Para isso, clique no botão Manage Nets na parte superior do documento do SI Analyzer by Keysight ou use o comando Edit » Manage Nets nos menus principais (como alternativa, se não houver nets no documento, o botão Manage Nets também estará disponível no centro do documento). A caixa de diálogo Manage Nets é aberta, apresentando a lista de classes de nets, pares diferenciais e xSignals da PCB.

As classes de pares diferenciais e xSignals do projeto de PCB são adicionadas automaticamente ao documento quando ele é criado.
Se uma classe não contiver objetos, ela não estará disponível para seleção na caixa de diálogo Manage Nets.

Marque a caixa de seleção de cada classe necessária (ou use a caixa de seleção no cabeçalho da grade para selecionar todas as classes). Opcionalmente, clique na célula da coluna Specifications para exibir uma janela pop-up e selecionar as especificações necessárias que definirão as restrições para a classe selecionada (que poderão ser redefinidas posteriormente, se necessário – saiba mais). Você pode selecionar especificações predefinidas ou definidas pelo usuário (na aba Specifications da janela pop-up) ou, para uma classe, definir manualmente os valores de restrição necessários (na aba Custom Constraints da janela pop-up).  

Não é possível aplicar especificações que definam restrições do mesmo tipo. Por exemplo, não é possível aplicar duas especificações se ambas definirem restrições de Impedance ().

Consulte a seção Gerenciando especificações para saber mais sobre o gerenciamento de especificações predefinidas ou definidas pelo usuário.

Você também pode expandir a lista All Nets na parte inferior da caixa de diálogo para selecionar e atribuir especificações a nets individuais do projeto.

Após clicar em OK na caixa de diálogo, as classes selecionadas serão exibidas no documento do SI Analyzer by Keysight. Se uma net tiver sido selecionada na região All Nets da caixa de diálogo Manage Nets, ela será exibida na entrada da classe All Nets. Expanda a entrada de uma classe para ver suas nets/xSignals.

  • O controle à direita de uma net na região All Nets ou de uma classe reflete o(s) nome(s) da(s) especificação(ões) atribuída(s) a essa classe/net (ou, se tiverem sido atribuídas restrições personalizadas, o controle terá o nome Constraints Set e refletirá os tipos de restrição definidos). Se nenhuma especificação tiver sido atribuída, o controle terá o nome Assign Specification. Clique no controle para alterar a atribuição da especificação conforme necessário, de modo semelhante ao que é feito na caixa de diálogo Manage Nets, conforme descrito acima.

  • Uma net/xSignal individual é identificada no documento pelo ícone . Se uma net fizer parte de um par diferencial, ela será adicionada ao documento SI Analyzer by Keysight como um par diferencial, junto com a outra net do par, e sua entrada terá o ícone .

Expanda uma entrada de net/xSignal ou par diferencial para ver os objetos que a compõem (pads, trilhas, arcos e vias) na região Transmission Line. Passe o cursor sobre o bloco de um objeto e clique no ícone  para localizar esse objeto na PCB por meio de sondagem cruzada.

Para remover do documento uma classe ou uma net adicionada individualmente, clique no botão  à direita da entrada correspondente.

Gerenciamento de especificações

A caixa de diálogo Manage Specifications, acessada ao clicar no botão Manage Specifications na parte superior do documento SI Analyzer by Keysight, permite gerenciar tanto as especificações integradas quanto as definidas pelo usuário. As especificações podem então ser atribuídas a uma classe ou net para definir rapidamente suas restrições, conforme descrito na seção anterior.

  • O lado esquerdo da caixa de diálogo apresenta a lista de especificações definidas atualmente. Cada especificação é listada com seu nome e um ou mais tipos de restrição que ela define.

    Use o campo Search na parte superior da lista de especificações para encontrar as especificações desejadas. À medida que você digita o texto de pesquisa, a lista é filtrada para apresentar apenas as especificações com nomes relevantes.
  • Selecione uma especificação na lista para exibir seus detalhes (nome, se é uma especificação Built-In ou User-Defined e restrições) no lado direito da caixa de diálogo.
  • Para criar uma nova especificação, clique no botão Add New na parte inferior esquerda da lista de especificações. O lado direito da caixa de diálogo apresentará controles para definir a especificação:
    • Defina o nome da nova restrição usando o campo Specification Name.

    • Selecione os tipos de restrição que você deseja que esta especificação defina usando as caixas de seleção: Impedance, Delay, Insertion Losses (IL) e/ou Return Losses (RL).

    • Para os tipos de restrição habilitados, defina os valores das restrições. Para restrições dos tipos Impedance e Delay, use os campos de texto fornecidos. Para restrições dos tipos Insertion Losses (IL) e Return Losses (RL), você pode adicionar, editar e remover limites para formar uma área de valores de perda restritos e permitidos na faixa de frequência desejada.

    • Após definir a especificação conforme necessário, clique no botão Save na parte superior do lado direito da caixa de diálogo para criá-la ou clique em Cancel para sair sem criá-la.

      Observe que não é possível criar uma nova especificação com um nome já utilizado ou com valores de restrição inválidos nas restrições habilitadas.
  • Uma nova especificação também pode ser criada duplicando uma existente (definida pelo usuário ou integrada). Selecione na lista a especificação a ser duplicada e clique no botão Duplicate na parte inferior esquerda da lista de especificações. Uma nova especificação, inicialmente chamada <OriginalSpecificationName>(Copy) e com as mesmas restrições da original, será criada e estará pronta para edição no lado direito da caixa de diálogo. Faça as alterações necessárias e clique no botão Save na parte superior para criar a especificação ou clique em Cancel para sair sem criá-la.
  • Para editar uma especificação definida pelo usuário, clique no botão  no lado direito da caixa de diálogo quando a especificação estiver selecionada na lista. Faça as alterações necessárias e clique no botão Save na parte superior para salvar as alterações ou clique em Cancel para sair sem aplicar nenhuma alteração.
  • Para remover uma especificação (definida pelo usuário ou integrada), clique no botão  no lado direito da caixa de diálogo quando a especificação estiver selecionada na lista.
  • As especificações integradas removidas podem ser restauradas clicando com o botão direito do mouse na lista de especificações e selecionando o comando Restore Built-In Spec. As especificações definidas pelo usuário não serão afetadas por esse comando.

Definição de restrições

Cada net será analisada para determinar se atende às restrições especificadas. Se uma especificação tiver sido selecionada para a classe à qual a net pertence, as restrições serão definidas por essa especificação.

Para examinar as restrições atuais de uma net/xSignal ou de um par diferencial, selecione a aba Constraints quando a entrada correspondente estiver expandida.

Clique no valor de uma restrição para editá-la na janela pop-up exibida.

Observe que, se o valor de uma restrição tiver sido alterado manualmente, a mensagem de aviso Custom constraints are used será exibida na entrada correspondente.

Execução de uma análise

Com a configuração concluída, você pode executar uma análise de todas as nets adicionadas, de uma classe específica ou de uma net específica. Clique no botão Analyze All no canto superior direito do documento SI Analyzer by Keysight para analisar todas as nets ou no botão Analyze da entrada de uma classe ou net específica para analisar apenas essa classe/net.

Exploração dos resultados

Após a conclusão da análise, os resultados são apresentados no documento SI Analyzer by Keysight. A mensagem Analyzed será exibida no canto superior direito do documento. Se todas as nets analisadas atenderem às restrições, o texto All Passed será exibido ao lado da mensagem. Caso contrário, será exibido o texto Failed, com o número de nets que não atendem às restrições.

Se todas as nets de uma classe passarem na análise, o texto Success será exibido na entrada correspondente. Caso contrário, será exibido o texto Failed.

Expanda a entrada de uma classe para ver os valores calculados (impedância, atraso, perdas de inserção e perdas de retorno) para cada net analisada nessa classe. Os valores que atendem às restrições são exibidos em verde; os valores que não atendem às restrições são exibidos em vermelho.

Expanda a entrada de uma net para ver os valores calculados para essa net na aba Results. Além disso, os blocos dos objetos da net que não atendem às restrições apresentam uma borda vermelha na região Transmission Line, e o valor que não atendeu à restrição é exibido em vermelho.

  • Se o projeto da PCB for alterado após a análise, os dados da análise ficarão desatualizados. Após atualizar o próprio documento SI Analyzer by Keysight com os novos dados da PCB (clicando em Refresh ao lado da mensagem de aviso PCB data is outdated no canto superior direito do documento), a mensagem de aviso Analysis data is outdated, please re-analyze será exibida. Clique no botão Analyze All para atualizar os dados da análise com os dados atualizados do projeto.
  • Observe que os valores de especificações ou restrições atribuídos podem ser alterados após a execução de uma análise. Nesse caso, os valores calculados serão comparados com as novas restrições, e seu status de aprovação/reprovação será atualizado de acordo.

Para ver os resultados da análise de uma classe ou de uma net/xSignal/par diferencial na PCB, clique no botão Show on PCB correspondente.

O painel SI Analyzer by Keysight

No editor de PCB, o processo de análise e os resultados são controlados pelo painel SI Analyzer by Keysight. Observe que o painel é adicionado à lista de painéis disponíveis (por meio do botão Panels) após a execução de uma análise de integridade de sinal e após clicar no botão Show on PCB.

Sinal simulado

  • Simulated Signal – use para selecionar a classe ou a net/xSignal/par diferencial que deseja exibir como um mapa de calor na área de projeto.
  • Only nets with violations – quando esta opção está ativada, apenas as entidades que apresentam uma violação no momento ficam disponíveis na lista suspensa. Desmarque esta opção para listar todas as entidades analisadas.
  • Show Heatmap – quando esta opção está ativada, um mapa de calor é exibido na área de projeto para a entidade atualmente selecionada na lista suspensa Simulated Signal.

Abaixo desses controles, o painel tem duas abas, General e Heatmap. As opções dessas abas se aplicam à entidade atualmente selecionada na lista suspensa Simulated Signal.

Mapa de calor

A aba Heatmap do painel SI Analyzer by Keysight é usada para controlar quais dados são apresentados como um mapa de calor, seja a impedância ou o atraso, e como as cores são aplicadas à impedância/ao atraso. Observe que esses controles de configuração do mapa de calor só ficam disponíveis quando a opção Show Heatmap está ativada.

Use os botões Impedance e Delay para alternar entre os dois modos. Toda a net é colorida para refletir a impedância/o atraso em cada ponto ao longo da net, da seguinte forma:

  • Para a impedância, quanto mais próxima ela estiver do valor-alvo Z0, mais verde será a cor; quanto mais distante estiver do valor-alvo Z0, mais vermelha será a cor. Os valores calculados abaixo do mínimo e acima do máximo são exibidos em vermelho. 
  • Para o atraso, quanto maior ele for, mais quente (mais vermelha) será a cor; quanto menor for, mais fria será a cor. Os valores calculados abaixo do mínimo são exibidos em azul, e os valores acima do máximo são exibidos em vermelho.

A escala de cores reflete como as cores são aplicadas. Os valores mínimo e máximo podem ser ajustados clicando e arrastando o controle deslizante ou inserindo um novo valor nos campos abaixo. A escala também é exibida como uma barra colorida na área de projeto, abaixo da PCB.

Ative a opção Color focus on results para destacar a entidade atualmente selecionada na lista suspensa Simulated Signal e filtrar os demais objetos da PCB.

Um exemplo de mapa de calor exibido para cálculos de impedância.
Um exemplo de mapa de calor exibido para cálculos de impedância.

Um exemplo de mapa de calor exibido para cálculos de atraso.
Um exemplo de mapa de calor exibido para cálculos de atraso.

Detecção de violações

Se a análise detectar violações de restrições para a entidade atualmente selecionada na lista suspensa Simulated Signal, elas serão listadas na região Violations da aba General do painel SI Analyzer by Keysight.

  • Use os botões na parte superior da região para definir quais tipos de violação devem ser exibidos na lista.
  • Use o botão Analyze na parte inferior da região para executar novamente a análise de integridade de sinal. Isso permite verificar rapidamente se a entidade atende à restrição após a aplicação de alterações no editor de PCB, sem retornar ao documento SI Analyzer by Keysight.

Sondas

A região Probes do painel SI Analyzer by Keysight é usada para posicionar sondas de medição diretamente na PCB. As sondas podem medir a impedância ou o atraso; o tipo de medição é determinado pelo modo atual do mapa de calor da placa.

As sondas podem ser do tipo simples, para medir um valor absoluto no local da sonda, ou do tipo diferencial, para medir a diferença entre os dois locais das sondas. Ambos os tipos são posicionados clicando no botão Add na região Probes do painel. Para posicionar uma sonda simples, clique no local desejado e depois clique com o botão direito do mouse (ou pressione Esc). Para posicionar uma sonda diferencial, clique uma vez para definir o local da primeira sonda e, em seguida, clique uma segunda vez para definir o local da segunda sonda. Após a definição de uma sonda, os resultados da medição serão exibidos no painel.

Um exemplo de sonda simples
Um exemplo de sonda simples

Um exemplo de sonda diferencial
Um exemplo de sonda diferencial

Clique em uma entrada de sonda no painel para mostrar seu local ou seus locais na PCB. Selecione uma entrada de sonda no painel e clique no botão  na parte inferior da região para remover a sonda.

Clique no botão Add to Report para criar uma imagem da PCB no local da sonda selecionada. A imagem será exibida na região Image Captures do painel, identificada por um indicador Probe. Passe o cursor sobre a captura de tela para exibir os detalhes da sonda.

Capturas de imagem

A funcionalidade de captura de imagem do painel SI Analyzer by Keysight pode ser usada para fazer uma captura de tela específica do projeto, que pode então ser incluída em um relatório.

Para capturar uma área específica da placa, primeiro ajuste a visualização da placa na área de projeto para que os elementos que deseja incluir na captura fiquem visíveis. Quando estiver pronto, clique no botão Add na região Image Captures do painel para fazer a captura de tela. Você pode continuar alterando a visualização da placa e adicionando mais imagens.

Para excluir uma imagem, passe o cursor sobre ela para revelar o botão  e clique nele para excluí-la.

As capturas de imagem são armazenadas com o documento SI Analyzer by Keysight. Para salvar as imagens, salve o documento.

Relatório dos resultados

Para gerar um relatório completo da análise, clique no botão Full Report na parte superior do documento SI Analyzer by Keysight. O relatório completo inclui uma seção para cada classe (e a entrada All Nets para nets adicionadas individualmente fora das classes de nets).

No relatório completo, clique no nome de uma classe de redes (ou no nome da rede na lista All Nets) para ver um relatório detalhado correspondente, incluindo:

  • Nome da classe de redes ou da rede.
  • Especificações atribuídas.
  • Resumo da verificação de restrições. Clique em uma entrada de verificação com falha para ver recomendações para corrigir os problemas relacionados.
  • Empilhamento de camadas da placa.
  • Verificações de restrições para cada rede. Expanda a entrada de uma rede para ver as verificações de restrições de cada objeto dessa rede.
  • Gráfico de perdas de inserção.
  • Gráfico de perdas de retorno.

Ao explorar um relatório detalhado, clique no botão Show on PCB para abrir a PCB e o painel SI Analyzer by Keysight para explorar a classe/rede.

Como trabalhar com gráficos

Os gráficos de perdas de inserção e de perdas de retorno mostram as formas de onda correspondentes a cada rede da classe em análise. A área vermelha no gráfico indica a zona restrita definida pelas restrições.

  • Use a lista suspensa no canto superior direito do gráfico de perdas de inserção ou de perdas de retorno para gerenciar as redes exibidas no gráfico. É possível exibir todas as redes, as redes com falhas ou redes específicas.

  • Clique no nome de uma forma de onda à direita do gráfico para destacá-la, esmaecendo as demais formas de onda. Clique novamente no nome de uma forma de onda para remover o destaque.

  • Gire a roda do mouse para ajustar o zoom em relação à posição do ponteiro no gráfico. Quando o ponteiro do mouse estiver sobre um eixo do gráfico, gire a roda do mouse para ajustar o zoom em relação à posição do ponteiro apenas nesse eixo (a escala do outro eixo não será alterada).

  • É possível realizar medições de dados usando cursores de medição. Estão disponíveis dois cursores, que podem ser adicionados à mesma forma de onda ou a formas de onda diferentes em um gráfico. Clique com o botão direito no nome de uma forma de onda à direita do gráfico e use os comandos Cursor A e Cursor B do menu de contexto para ativar/desativar os cursores. Mova o cursor clicando e arrastando sua aba. Os dados medidos por um cursor ativado são exibidos na parte inferior do gráfico.

    Um exemplo dos cursores A e B adicionados à mesma forma de onda.
    Um exemplo dos cursores A e B adicionados à mesma forma de onda.

Como exportar o relatório

Clique no botão Save Report para salvar o relatório no formato HTML. Use a caixa de diálogo Report Settings exibida em seguida para configurar quais redes (quando a caixa de diálogo é acessada a partir do relatório completo) e quais dados específicos serão incluídos no relatório.

Após clicar no botão Generate Report, o relatório é armazenado em uma subpasta da pasta do projeto chamada \SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime>. Todas as imagens do relatório são armazenadas em uma subpasta \Images.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents