Criando um modelo de simulação
Num relance
- Como os modelos de simulação são criados ou obtidos, incluindo arquivos baixados de fabricantes, modelos copiados em formato de texto e arquivos de subcircuitos escritos manualmente.
- Como criar, salvar, vincular e editar modelos de simulação no Altium Designer e em um Workspace conectado.
- Quais informações são necessárias para definir corretamente um modelo de simulação, incluindo nomes de modelos, arquivos referenciados e parâmetros no nível do modelo.
Para simular um projeto de circuito usando o Simulador de Circuitos de Sinal Misto do Altium Designer, todos os componentes do circuito precisam estar prontos para simulação — ou seja, cada um deles precisa ter um modelo de simulação vinculado.
O tipo de modelo e a forma de obtê-lo dependerão, em grande parte, do componente e, até certo ponto, da preferência pessoal do projetista. Muitos fabricantes de dispositivos fornecem modelos de simulação correspondentes aos dispositivos que fabricam. Normalmente, basta baixar o arquivo de modelo necessário e vinculá-lo ao componente do esquemático. Saiba mais sobre Como adicionar modelos de simulação ao projeto.
Alguns modelos podem precisar ser escritos do zero — por exemplo, usando a sintaxe de subcircuito hierárquico para criar o arquivo de modelo de subcircuito necessário (*.ckt).
Como criar um novo modelo de simulação
Alguns modelos são fornecidos por fabricantes e fornecedores como arquivos de texto para download. Às vezes, os detalhes do modelo são apresentados como texto em uma página do navegador, em vez de um arquivo para download; nessa situação, você pode criar um novo arquivo de modelo no Altium Designer e copiar/colar o conteúdo da página do navegador no novo arquivo de modelo. Use o comando correspondente no submenu File » New » Mixed Simulation, conforme mostrado abaixo.

Comandos para criar um novo arquivo de modelo vazio.
Em seguida, você pode copiar/colar as informações do arquivo de modelo no editor de modelos.

Exemplo de conteúdo de texto de um modelo de simulação.
Como criar um modelo de simulação do Workspace
O Altium Designer, em conjunto com um Workspace conectado, permite criar e gerenciar modelos de simulação do Workspace. Depois que um modelo de simulação do Workspace é criado, ele pode ser usado na criação de um ou mais componentes do Workspace.
Embora os modelos de simulação do Workspace sejam criados automaticamente quando você adiciona um arquivo de modelo de simulação a um componente que está sendo definido no Editor de Componentes em seu modo de edição de componente único e depois salva esse componente no Workspace, você também pode criar modelos de simulação do Workspace diretamente no Workspace, conforme descrito abaixo.
-
Abra o painel Components e habilite a visibilidade dos modelos clicando no botão
na parte superior do painel e selecionando Models.
-
Navegue até a categoria Simulations e selecione Create Component no menu do botão
.

Navegue até os modelos de simulação no painel Components e selecione o comando para criar um novo modelo -
Na caixa de diálogo Create New Item que se abre, insira as informações necessárias, certifique-se de que a opção Open for editing after creation esteja habilitada e clique em OK. O modelo de simulação do Workspace será criado e o editor temporário SimModel será aberto, apresentando um documento
.SimModelcomo documento ativo na área de projeto. Esse documento será nomeado de acordo com o item e sua revisão, no formato:<Item><Revision>.SimModel(por exemplo,SIM-001-0001-1.SimModel).
Exemplo de edição da revisão inicial de um modelo de simulação do Workspace — o editor temporário SimModel fornece o documento no qual definir seu modelo de simulação. - Use o documento para definir o modelo de simulação do Workspace conforme necessário. Para obter mais informações sobre como fazer isso, consulte Como definir o modelo de simulação.
- Salve o modelo no Workspace usando o controle Save to Server à direita da entrada do modelo de simulação no painel Projects. A caixa de diálogo Edit Revision será exibida, na qual você poderá alterar o nome e a descrição, além de adicionar notas de versão conforme necessário. O documento e o editor serão fechados após o salvamento.
-
O documento que contém a definição de origem do modelo de simulação,
*.SimModel, será armazenado na revisão do modelo de simulação do Workspace. O modelo de simulação será apresentado no painel Components, na categoria Simulations.
Um modelo de simulação do Workspace salvo no painel ComponentsOs dados salvos no Workspace consistem na definição do modelo no arquivo
.SimModel, bem como em qualquer arquivo.mdlou.cktreferenciado. No painel Explorer, alterne para a guia de visualização de aspecto Preview e clique em um arquivo referenciado para visualizar uma prévia de seu conteúdo. Os parâmetros no nível do modelo também serão apresentados, quando aplicável.
Navegue pelo modelo de simulação do Workspace salvo no painel Explorer. Alterne para a guia de visualização de aspecto Preview para ver os dados salvos.
Um modelo de simulação do Workspace salvo pode então ser vinculado a um componente do Workspace ao definir o componente no Editor de Componentes em seu modo de edição de componente único ou edição de componentes em lote.
Como definir o modelo de simulação
As informações necessárias para definir o modelo em um arquivo SimModel são as seguintes:
-
Model Name – use este campo para especificar o nome do modelo. Ao salvar no Workspace, esta entrada será usada como Name da revisão do item de modelo de simulação.
Ao referenciar um arquivo MDL, o nome deve ser aquele que aparece na linha
.MODELda definição do modelo. Considere um modelo de diodo com a seguinte definição:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )O nome do modelo aqui é
1N4002. Este é o nome que deve ser inserido no campo Model Name.Ao referenciar um arquivo CKT, o nome deve ser aquele que aparece na linha
.SUBCKTda definição do modelo. Considere um modelo de fusível com a seguinte definição:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSEO nome do modelo aqui é
FUSE. Este é o nome que deve ser inserido no campo Model Name. -
Model File – para um modelo definido usando um arquivo
.mdlou.ckt, use o botão Browse para selecionar o arquivo necessário em uma biblioteca disponível. - Description – insira uma descrição do modelo, por exemplo, sua finalidade. Ao salvar no Workspace, esta entrada será usada como Description da revisão do modelo de simulação.
- Parameters – parâmetros no nível do modelo (consulte Parâmetros no nível do modelo).
-
Model Preview – exibição somente leitura do conteúdo do arquivo
.mdlou.cktreferenciado.
Parâmetros no nível do modelo
Quando aplicável, os parâmetros no nível do modelo podem ser definidos diretamente no arquivo SimModel, pois fazem parte da definição de um modelo. A região Parameters do documento será preenchida automaticamente com os parâmetros aplicáveis ao modelo escolhido. Os valores dos parâmetros podem ser editados no próprio local - clique no campo Parameter Value associado a um parâmetro na lista e insira diretamente o valor necessário.

Defina os parâmetros do modelo como parte de sua definição, editando-os diretamente no próprio local.
Editar um modelo de simulação do Workspace
A qualquer momento, você pode retornar a qualquer modelo de simulação do Workspace e editá-lo diretamente. Selecione a categoria Simulations no painel Components (a opção Models deve estar habilitada no menu
do painel para acessar esta categoria), clique com o botão direito na entrada de um modelo de simulação e escolha o comando Edit no menu de contexto. Novamente, o editor temporário será aberto, com o arquivo (que contém a definição de origem do modelo de simulação) contido no modelo de simulação do Workspace aberto para edição. Faça as alterações necessárias e salve o documento na próxima revisão do modelo de simulação do Workspace.
Gerar arquivos SimModel
Os arquivos SimModel podem ser gerados a partir do documento de biblioteca de esquemáticos ou de biblioteca de banco de dados ativo usando o comando Tools » Generate SimModel Files.
Após executar o comando, a caixa de diálogo Generate SimModel Files será exibida. Cada arquivo SimModel (e a definição do modelo de simulação que o compõe) é criado com base no vínculo do modelo de simulação de um componente de esquemático na biblioteca de esquemáticos ativa (ou nas informações de simulação de um registro de componente na biblioteca de banco de dados ativa). Use os controles da caixa de diálogo para configurar a geração de um ou mais arquivos SimModel conforme necessário. Por padrão, será criada uma subpasta chamada Sim Models. Altere esse nome para algo mais adequado, se necessário. Se a pasta especificada existir, ela será usada; caso contrário, será criada.

A caixa de diálogo Generate SimModel Files
Após definir as opções conforme necessário, clique em OK. A geração será iniciada e, quando o processo for concluído, uma caixa de diálogo de confirmação será exibida, informando quantos arquivos SimModel foram gerados. Todos os arquivos .mdl, .ckt ou .scb referenciados também serão armazenados junto aos arquivos SimModel.
Se estiver migrando de uma biblioteca integrada, as bibliotecas de esquemáticos de origem (SchLib) podem ser obtidas abrindo a IntLib no Altium Designer e optando por extrair as bibliotecas de origem. Ao gerar arquivos SimModel a partir de uma biblioteca de banco de dados, apenas os componentes em tabelas atualmente habilitadas serão considerados.
A nomenclatura dos arquivos SimModel depende do tipo de biblioteca de origem:
- Schematic Library - cada arquivo SimModel recebe o nome do modelo de simulação. Quando vários componentes de esquemático incluem a mesma implementação de modelo de simulação (modelo de simulação com o mesmo nome), apenas um arquivo SimModel será gerado, usando esse nome.
- Database Library - cada arquivo SimModel recebe o nome do modelo de simulação, conforme especificado no campo Sim Model Name de um registro de componente. Quando vários registros de componentes (nas tabelas habilitadas) incluem a mesma implementação de modelo de simulação (mesma entrada no campo Sim Model Name), apenas um arquivo SimModel será gerado, usando esse nome.
Assistente de modelos SPICE
Certos modelos de dispositivos analógicos integrados ao SPICE permitem associar um arquivo de modelo (*.mdl) no qual é possível definir parametricamente características comportamentais avançadas (por exemplo, resistor semicondutor, diodo, BJT). Criar esse arquivo de modelo manualmente e depois vinculá-lo ao componente esquemático desejado pode ser bastante trabalhoso. O SPICE Model Wizard facilita essa tarefa. Usando o Assistente, as características desse tipo de dispositivo podem ser definidas com base em dados obtidos pelo usuário. Os parâmetros — inseridos diretamente ou extraídos dos dados fornecidos — são gravados automaticamente em um arquivo de modelo, que é vinculado ao componente esquemático indicado.
O SPICE Model Wizard oferece uma solução prática e semiautomatizada para criar e vincular um modelo de simulação SPICE para diversos dispositivos analógicos — dispositivos integrados ao SPICE que exigem um arquivo de modelo vinculado (*.mdl). As características comportamentais do modelo são definidas com base nas informações fornecidas ao Assistente. A quantidade de informações necessárias depende do tipo de dispositivo para o qual você deseja criar um modelo — desde a simples inserção de parâmetros do modelo até a inserção de dados do dispositivo obtidos na folha de dados do fabricante ou por medições realizadas no próprio dispositivo físico.
As seções a seguir abordam o uso do Assistente — do acesso à verificação.
Acessando o Assistente
O Assistente é acessado no editor de símbolos esquemáticos, selecionando o comando Tools » XSpice Model Wizard nos menus principais.

A página inicial do SPICE Model Wizard
Nas duas páginas seguintes do Assistente, você poderá escolher:
- Qual dispositivo específico deseja modelar, na lista de tipos de dispositivos compatíveis.
- Se deseja adicionar o modelo SPICE gerado posteriormente a um componente existente no documento de biblioteca ou a um novo componente criado pelo Assistente e adicionado a esse documento.
Tipos de dispositivos compatíveis
O Assistente pode ser usado para criar modelos SPICE para os seguintes tipos de dispositivos analógicos:
- Diodo
- Capacitor semicondutor
- Resistor semicondutor
- Chave controlada por corrente
- Chave controlada por tensão
- Transistor bipolar de junção
- Linha de transmissão com perdas
- Linha de transmissão RC uniformemente distribuída
Nomeando o modelo
Uma das etapas mais importantes ao percorrer as páginas do Assistente é fornecer um nome para o modelo que você está criando. Na verdade, você não poderá avançar para a etapa de definição de parâmetros do Assistente até inserir um nome.
Após a criação, esse nome aparecerá no campo Model Name da caixa de diálogo Sim Model. O próprio arquivo de modelo também é criado com esse nome (<ModelName>.mdl). Ao usar o Assistente para adicionar um modelo a um novo componente de biblioteca, o nome especificado para o modelo também será usado para nomear o componente.
Ao nomear o modelo, você também tem a opção de inserir uma breve descrição. Ela pode indicar a função do modelo (por exemplo, Semiconductor Resistor) ou uma referência mais específica a um valor ou configuração (por exemplo, NPN BJT).
Características a serem modeladas
Após dar um nome ao modelo, você avançará para uma ou mais páginas que tratam das características a serem modeladas. Os tipos de modelos compatíveis com o Assistente podem ser classificados nos dois grupos a seguir:
- Modelos que exigem a inserção direta de valores para vários parâmetros do modelo. Para obter mais informações, consulte a seção Modelos de dispositivos criados por inserção direta de parâmetros.
- Modelos que exigem a inserção de dados dos quais serão extraídos os parâmetros que definem as características escolhidas do dispositivo. Os dados inseridos são obtidos por medições diretas no dispositivo físico ou na folha de dados do fabricante. Para obter mais informações, consulte a seção Modelos de dispositivos criados por extração de parâmetros a partir de dados.
Gerando o modelo
Após a definição dos dados/parâmetros necessários, o Assistente exibirá o modelo gerado. Esse é o conteúdo que será salvo no arquivo MDL.

Prévia do conteúdo do arquivo de modelo gerado.
O modelo pode ser editado diretamente nesta página, proporcionando controle total sobre sua especificação.
Quando estiver satisfeito com a definição do modelo, clique em Next para avançar até o final do Assistente. Clicar em Finish permitirá salvar o modelo. Use a caixa de diálogo Save SPICE Model File para determinar onde o arquivo MDL resultante deve ser salvo. Por padrão, o arquivo será salvo no mesmo diretório do documento de biblioteca de esquemáticos. Você também pode alterar o nome do arquivo nesta etapa, se desejar.
Se você tiver solicitado que o modelo seja associado a um novo componente, esse componente será criado e adicionado ao documento de biblioteca.
Modelos de dispositivos criados por inserção direta de parâmetros
Para os modelos de dispositivos a seguir, o Assistente não extrai informações de parâmetros dos dados inseridos. Em vez disso, os modelos são criados com base na inserção direta de valores para os parâmetros associados a eles. Ao inserir valores de parâmetros, há alguns pontos a considerar:
- Se o valor de um parâmetro não for especificado, não haverá uma entrada para ele no arquivo de modelo criado. Nesse caso, será usado o valor padrão armazenado internamente no SPICE. Em outras palavras, se o valor de um parâmetro for especificado em um arquivo de modelo, o valor do arquivo substituirá o valor padrão desse parâmetro.
- Se a entrada padrão de um parâmetro no Assistente for '-' e um valor para esse parâmetro não for inserido explicitamente, será usado um valor padrão de zero (interno ao SPICE) nos cálculos.
Capacitor semicondutor
Os parâmetros a seguir podem ser definidos para este modelo de dispositivo usando o Assistente. A inserção de um valor fará com que esse parâmetro seja gravado no arquivo MDL gerado.
CJ |
Capacitância do fundo da junção (em F/m²). |
|
CJSW |
Capacitância da parede lateral da junção (em F/m). |
|
DEFW |
Largura padrão do dispositivo (em metros). (Padrão = 1e-6). |
|
NARROW |
Estreitamento devido à corrosão lateral (em metros). (Padrão = 0). |
Resistor semicondutor
Os parâmetros a seguir podem ser definidos para este modelo de dispositivo usando o Assistente. Ao inserir um valor, o parâmetro correspondente será gravado no arquivo MDL gerado.
TC1 |
Coeficiente de temperatura de primeira ordem (em Ohms/˚C). (Padrão = 0) |
|
TC2 |
Coeficiente de temperatura de segunda ordem (em Ohms/˚C2). (Padrão = 0) |
|
RSH |
Resistência de folha (em Ohms). |
|
DEFW |
Largura padrão (em metros). (Padrão = 1e-6). |
|
NARROW |
Estreitamento devido à corrosão lateral (em metros). (Padrão = 0). |
|
TNOM |
Temperatura de medição dos parâmetros (em ˚C). Se nenhum valor for especificado, será usado o valor padrão atribuído a TNOM na aba Advanced da caixa de diálogo Advanced Analyses Settings (Padrão = 27). |
Chave controlada por corrente
Os parâmetros a seguir podem ser definidos para este modelo de dispositivo usando o Assistente. Ao inserir um valor, o parâmetro correspondente será gravado no arquivo MDL gerado.
IT |
Corrente de limiar (em amperes). (Padrão = 0). |
|
IH |
Corrente de histerese (em amperes). (Padrão = 0). |
|
RON |
Resistência no estado ligado (em Ohms). (Padrão = 1). |
|
ROFF |
Resistência no estado desligado (em Ohms). Por padrão, é definida como 1/GMIN. GMIN é um parâmetro avançado do SPICE, especificado na aba Advanced da caixa de diálogo Advanced Analyses Settings. Ele define a condutância mínima (resistência máxima) de qualquer dispositivo no circuito. Seu valor padrão é 1e-12 mhos, resultando em um valor padrão de 1000G Ohms para ROFF. |
Chave controlada por tensão
Os parâmetros a seguir podem ser definidos para este modelo de dispositivo usando o Assistente. Ao inserir um valor, o parâmetro correspondente será gravado no arquivo MDL gerado.
VT |
Tensão de limiar (em volts). (Padrão = 0). |
|
VH |
Tensão de histerese (em volts). (Padrão = 0). |
|
RON |
Resistência no estado ligado (em Ohms). (Padrão = 1). |
|
ROFF |
Resistência no estado desligado (em Ohms). Por padrão, é definida como 1/GMIN. GMIN é um parâmetro avançado do SPICE, especificado na aba Advanced da caixa de diálogo Advanced Analyses Settings. Ele define a condutância mínima (resistência máxima) de qualquer dispositivo no circuito. Seu valor padrão é 1e-12 mhos, resultando em um valor padrão de 1000G Ohms para ROFF. |
Linha de transmissão com perdas
Os parâmetros a seguir podem ser definidos para este modelo de dispositivo usando o Assistente. Ao inserir um valor (ou ativar uma opção), o parâmetro correspondente será gravado no arquivo MDL gerado.
R |
Resistência por unidade de comprimento (em Ohms/unidade). (Padrão = 0). |
|
L |
Indutância por unidade de comprimento (em henrys/unidade). (Padrão = 0). |
|
G |
Condutância por unidade de comprimento (em mhos/unidade). (Padrão = 0). |
|
C |
Capacitância por unidade de comprimento (em farads/unidade). (Padrão = 0). |
|
LEN |
Comprimento da linha de transmissão. |
|
REL |
Controle de pontos de quebra (em unidades arbitrárias). (Padrão = 1). |
|
ABS |
Controle de pontos de quebra (em unidades arbitrárias). (Padrão = 1). |
|
NOSTEPLIMIT |
Uma opção que, quando ativada, remove a restrição que limita os passos de tempo a valores menores que o atraso da linha. (Padrão = desativada). |
|
NOCONTROL |
Uma opção que, quando ativada, impede a limitação do passo de tempo com base em critérios de erro de convolução. (Padrão = desativada). |
|
LININTERP |
Uma opção que, quando ativada, utiliza interpolação linear em vez da interpolação quadrática padrão para o cálculo de sinais atrasados. (Padrão = desativada). |
|
MIXEDINTERP |
Uma opção que, quando ativada, utiliza uma métrica para determinar se a interpolação quadrática é aplicável e, caso não seja, utiliza interpolação linear. (Padrão = desativada). |
|
COMPACTREL |
Uma grandeza específica usada para controlar a compactação dos valores do histórico usados na convolução. Por padrão, essa grandeza utiliza o valor especificado para o parâmetro de tolerância de erro relativo da simulação (RELTOL), definido na aba Advanced da caixa de diálogo Advanced Analyses Settings. |
|
COMPACTABS |
Uma grandeza específica usada para controlar a compactação dos valores do histórico usados na convolução. Por padrão, essa grandeza utiliza o valor especificado para o parâmetro de tolerância de erro absoluto de corrente (ABSTOL), definido na aba Advanced da caixa de diálogo Advanced Analyses Settings. |
|
TRUNCNR |
Uma opção que, quando ativada, habilita o uso do método de iteração de Newton-Raphson para determinar um passo de tempo adequado nas rotinas de controle do passo de tempo. (Padrão = desativada, caso em que é usado um método de tentativa e erro, reduzindo o passo de tempo anterior à metade a cada tentativa). |
|
TRUNCDONTCUT |
Uma opção que, quando ativada, remove a redução padrão do passo de tempo usada para limitar erros no cálculo efetivo de grandezas relacionadas à resposta ao impulso. (Padrão = desativada). |
Linha de transmissão RC uniformemente distribuída
Os parâmetros a seguir podem ser definidos para este modelo de dispositivo usando o Assistente. Ao inserir um valor, o parâmetro correspondente será gravado no arquivo MDL gerado.
K |
Constante de propagação. (Padrão = 2). |
|
FMAX |
Frequência máxima de interesse (em hertz). (Padrão = 1.0G). |
|
RPERL |
Resistência por unidade de comprimento (em Ohms/metro). (Padrão = 1000). |
|
CPERL |
Capacitância por unidade de comprimento (em farads/metro). (Padrão = 1.0e-15). |
|
ISPERL |
Corrente de saturação por unidade de comprimento (em amperes/metro). (Padrão = 0). |
|
RSPERL |
Resistência do diodo por unidade de comprimento (em Ohms/metro). (Padrão = 0). |
Modelos de dispositivos criados por extração de parâmetros a partir de dados
Para diodos e transistores BJT, o Assistente extrai informações de parâmetros dos dados inseridos. Os parâmetros específicos extraídos para inclusão no arquivo de modelo dependerão das características específicas do diodo ou BJT que você escolheu modelar.
O método de entrada de dados varia conforme a característica. Em alguns casos, será necessário inserir valores diretamente; em outros, dados de gráficos. Em todos os casos, os dados serão obtidos de medições diretas no dispositivo, de uma folha de dados do fabricante ou de uma combinação das duas fontes.
Quando for necessário inserir dados de gráficos, insira uma série de pontos de dados obtidos do gráfico de origem na grade fornecida pelo Assistente. Se os dados estiverem armazenados no formato de valores separados por vírgulas (*.csv), você poderá importá-los usando o botão Import Data disponível. O Assistente utilizará os dados inseridos para extrair os parâmetros necessários do modelo. Os resultados da extração são apresentados em uma página subsequente do Assistente, na forma dos próprios valores dos parâmetros extraídos e de um gráfico comparativo entre os dados inseridos e os valores calculados usando os parâmetros extraídos. A imagem abaixo ilustra um exemplo dessa apresentação dos resultados dos parâmetros.

Insira os dados de origem para que o Assistente possa extrair os parâmetros necessários do modelo.
Você pode editar os valores dos parâmetros extraídos para aprimorar ainda mais a precisão do modelo do diodo. A comparação gráfica será atualizada para refletir as alterações.
Diodo
As seções a seguir detalham cada uma das características que você pode escolher modelar para um diodo. Cada seção aborda os parâmetros extraídos e os dados de origem necessários para que o Assistente realize a extração.
Fluxo de corrente em polarização direta
Os seguintes parâmetros são usados para descrever as características de corrente-tensão CC do diodo na região de polarização direta:
IS |
Corrente de saturação (em amperes). |
|
N |
Coeficiente de emissão. |
|
RS |
Resistência ôhmica (em ohms). |
Para extrair esses parâmetros, é necessário um gráfico da corrente direta do diodo (IF) em função da tensão direta do diodo (VF). Esse gráfico pode ser obtido de uma folha de dados do fabricante ou por meio de medições realizadas em um dispositivo físico.
A imagem abaixo mostra um exemplo desse tipo de gráfico, obtido de uma folha de dados, e também um exemplo de circuito de teste no qual poderiam ser realizadas medições diretas para obter os dados de origem necessários.

Exemplo de gráfico e circuito para as características I-V do diodo na região de polarização direta.
Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem.
Capacitância de junção em polarização reversa
Os seguintes parâmetros são usados para descrever a capacitância do diodo ao operar na região de polarização reversa:
CJO |
Capacitância de junção com polarização nula (em farads). |
|
M |
Coeficiente de graduação. |
|
VJ |
Potencial de junção (em volts). |
Para extrair esses parâmetros, é necessário um gráfico da capacitância sob polarização reversa (Cd) em função da tensão reversa do diodo (VR). Esse gráfico pode ser obtido de uma folha de dados do fabricante ou por meio de medições realizadas em um dispositivo físico.
A imagem mostra um exemplo desse tipo de gráfico, obtido de uma folha de dados, e também um exemplo de circuito de teste no qual poderiam ser realizadas medições diretas para obter os dados de origem necessários. Esse circuito pode ser usado caso não haja um medidor de capacitância disponível.

Exemplo de gráfico e circuito para a capacitância do diodo na região de polarização reversa.
Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem.
O circuito de exemplo na imagem acima se baseia na equação:
I = C * (dv/dt)
Isolando C nessa equação, obtemos:
C = I/(dv/dt)
O circuito produz uma rampa de tensão a partir da fonte V1. Ao calcular a inclinação dessa rampa de tensão, é possível obter a parte dv/dt da equação. Dividindo a corrente medida no diodo pela inclinação da rampa de tensão, é possível obter a curva de capacitância do diodo.
Fluxo de corrente em polarização reversa
Os seguintes parâmetros são usados para descrever o fluxo de corrente em polarização reversa do dispositivo após a ruptura:
BV |
Tensão de ruptura reversa (em volts). |
|
IBV |
Corrente na tensão de ruptura (em amperes). |
Para extrair esses parâmetros, o Assistente exige a inserção dos dois valores a seguir:
-
Valor da tensão de ruptura reversa.
-
Valor da corrente que passa pelo diodo no ponto de ruptura reversa.
Esses valores podem ser obtidos de uma folha de dados do fabricante ou por meio de medições realizadas em um dispositivo físico. As folhas de dados normalmente contêm as características elétricas (CC) de um diodo em formato de tabela; portanto, basta localizar esses valores e inseri-los exatamente como são apresentados.
Se os dados de origem estiverem em formato gráfico — o que é típico de medições realizadas diretamente em um dispositivo físico —, será necessário fazer a leitura desses dois valores no ponto em que o diodo começa a entrar em ruptura. A imagem abaixo mostra um exemplo desse tipo de gráfico.

Obtenção gráfica dos valores de corrente e tensão no ponto de ruptura reversa.
Embora os valores possam ser negativos conforme apresentados no gráfico, eles devem ser inseridos nos respectivos campos do Assistente apenas como valores positivos.
Características de recuperação reversa
O seguinte parâmetro é usado para modelar o tempo de recuperação reversa do diodo durante a comutação da polarização direta para a reversa:
TT |
Tempo de trânsito (em segundos). |
Para extrair esse parâmetro, o Assistente exige a inserção do tempo de recuperação reversa do diodo (Trr), no ponto em que a corrente direta é igual à corrente reversa (isto é, IR/IF=1). Esses dados normalmente são encontrados nas folhas de dados dos fabricantes de diodos de comutação na forma de dados numéricos simples.
A imagem abaixo ilustra como essas informações são apresentadas em uma folha de dados do fabricante. O valor de interesse na imagem — a ser inserido no Assistente — é 4ns.

Obtenção do tempo de recuperação reversa de um diodo.
Transistor bipolar de junção (BJT)
Ao criar um modelo de transistor bipolar de junção (BJT), o Assistente de Modelos SPICE exige que você escolha a fonte de dados da qual as informações dos parâmetros serão extraídas:
- Dados medidos – selecione esta opção se os dados de origem forem provenientes de medições no dispositivo físico e você desejar desenvolver um modelo preciso que descreva todos os aspectos do comportamento em CC.
- Folha de dados do fabricante – selecione esta opção se os dados de origem forem provenientes de uma folha de dados. Em geral, as folhas de dados não contêm o nível de informação necessário para modelar todos os aspectos do dispositivo BJT. No entanto, normalmente contêm informações suficientes para criar um modelo de dispositivo para uso apenas na região ativa direta.
As diferenças entre essas duas opções afetam principalmente a forma como são extraídos os parâmetros que modelam as características de corrente-tensão em CC do BJT. Com relação às capacitâncias das junções com polarização reversa e aos tempos de trânsito, a forma de extração dos parâmetros é idêntica nas duas opções.
As seções a seguir detalham cada uma das características que você pode optar por modelar para um dispositivo BJT, de acordo com o tipo de dados de origem (dados medidos ou folha de dados). São discutidos os parâmetros extraídos em cada caso e os dados de origem exigidos pelo Assistente para permitir sua extração.
Características modeladas usando dados medidos
As características a seguir podem ser modeladas usando dados obtidos por medições diretas no dispositivo físico.
-
Forward-Bias Parameters
Os parâmetros a seguir são usados para descrever as características de corrente-tensão em CC do BJT na região de polarização direta:
IS
Corrente de saturação de transporte (em amperes).
BF
Beta direto máximo ideal.
NF
Coeficiente de emissão da corrente direta.
RB
Resistência de base com polarização nula (em ohms).
RC
Resistência do coletor (em ohms).
RE
Resistência do emissor (em ohms).
IKF
Corrente de início da queda do beta direto em altas correntes (em amperes).
ISE
Corrente de saturação de fuga B-E (em amperes).
NE
Coeficiente de emissão de fuga B-E.
VAF
Tensão Early direta (em volts).
As seções a seguir detalham os dados de medição necessários, cuja inserção permitirá ao Assistente extrair esses parâmetros.
-
Base-Emitter Voltage versus Base Current
Esses dados são usados para a extração inicial do parâmetro RC. A imagem abaixo mostra um exemplo de gráfico da tensão base-emissor (VBE) em função da corrente de base (IB), além de um exemplo de circuito de teste no qual poderiam ser realizadas medições para obter os dados. O circuito força uma corrente na base enquanto mede a tensão base-emissor em circuito aberto.

Exemplo de gráfico e circuito para VBE em função de IB.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem.
-
Collector-Emitter Voltage versus Base Current
Esses dados são usados para a extração inicial do parâmetro RE. A imagem abaixo mostra um exemplo de gráfico da tensão coletor-emissor (VCE) em função da corrente de base (IB), além de um exemplo de circuito de teste no qual poderiam ser realizadas medições para obter os dados. O circuito força uma corrente na base enquanto mede a tensão coletor-emissor em circuito aberto.

Exemplo de gráfico e circuito para VCE em função de IB.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem.
-
Forward Gummel Plot
Esses dados são usados principalmente para extrair os parâmetros IS, BF, NF, RB, IKF, ISE e NE. Também são usados para otimizar os parâmetros RC, RE e VAF. A imagem abaixo mostra um exemplo de gráfico de Gummel, além de um exemplo de circuito de teste no qual poderiam ser realizadas medições para obter os dados. O gráfico de Gummel ilustra:
-
Corrente de base em função da tensão base-emissor (IB em função de VBE).
-
Corrente de coletor em função da tensão base-emissor (IC em função de VBE).
A tensão base-coletor (VBC) é mantida em zero volts.

Exemplo de gráfico de Gummel direto e circuito de teste.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de Gummel de origem. Os valores brutos de IB e IC devem ser inseridos – o Assistente aplicará a função LN aos dados da curva.
-
-
Collector Current versus Base-Emitter Voltage
Esses dados são usados para a extração inicial do parâmetro VAF. A imagem abaixo mostra um exemplo de gráfico da corrente de coletor (IC) em função da tensão base-emissor (VBE), além de um exemplo de circuito de teste no qual poderiam ser realizadas medições para obter os dados. O circuito é usado para gerar duas curvas de IC em função de VBE, para dois valores diferentes de tensão base-coletor (VBC). As curvas devem ser medidas com correntes tão baixas quanto possível e com VBC tão próxima de zero volts quanto viável.

Exemplos de gráficos e circuito para VBE em função de IC.Os dados são inseridos no Assistente como uma série de pontos de dados em duas tabelas — uma para cada curva de dados de origem. O valor usado para VBC também deve ser inserido em cada caso.
-
-
Reverse-Bias Parameters
Os parâmetros a seguir são usados para descrever as características de corrente-tensão em CC do BJT na região de polarização reversa:
IS
Corrente de saturação de transporte (em amperes).
BR
Beta reverso máximo ideal.
NR
Coeficiente de emissão da corrente reversa.
RB
Resistência de base com polarização nula (em ohms).
RC
Resistência do coletor (em ohms).
RE
Resistência do emissor (em ohms).
IKR
Corrente de início da queda do beta reverso em altas correntes (em amperes).
ISC
Corrente de saturação de fuga B-C (em amperes).
NC
Coeficiente de emissão de fuga B-C.
VAR
Tensão Early reversa (em volts).
As seções a seguir detalham os dados de medição necessários, cuja inserção permitirá ao Assistente extrair esses parâmetros.
-
Reverse Gummel Plot
Esses dados são usados principalmente para extrair os parâmetros IS, BR, NR, RB, IKR, ISC e NC. Também são usados para otimizar os parâmetros RC, RE e VAR. A imagem abaixo mostra um exemplo de gráfico de Gummel e um exemplo de circuito de teste, no qual podem ser realizadas medições para obter os dados. O gráfico de Gummel ilustra:
-
Corrente de base em função da tensão base-coletor (IB vs. VBC).
-
Corrente de emissor em função da tensão base-coletor (IE vs. VBC).
A tensão base-emissor (VBE) é mantida em zero volts.

Exemplo de gráfico de Gummel reverso e circuito de teste.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de Gummel de origem. Os valores brutos de IB e IE devem ser inseridos — o Assistente aplicará a função LN aos dados da curva.
-
-
Emitter Current versus Base-Collector Voltage
Esses dados são usados para a extração inicial do parâmetro VAR. A imagem abaixo mostra um exemplo de gráfico da corrente de emissor (IE) em função da tensão base-coletor (VBC), além de um exemplo de circuito de teste, no qual podem ser realizadas medições para obter os dados. O circuito é usado para gerar duas curvas de IE vs. VBC, para dois valores diferentes de tensão base-emissor (VBE). As curvas devem ser medidas com correntes tão baixas quanto possível e com VBE tão próxima de zero volts quanto for viável.

Exemplos de gráficos e circuito para IE vs. VBC.Os dados são inseridos no Assistente como uma série de pontos de dados em duas tabelas — uma para cada curva de dados de origem. O valor usado para VBE também deve ser inserido em cada caso.
-
Características modeladas usando dados da folha de dados do fabricante
As características a seguir podem ser modeladas usando dados obtidos da folha de dados de um fabricante.
-
Forward-Bias Parameters
Os parâmetros a seguir são usados para descrever as características de corrente-tensão em CC do BJT na região de polarização direta:
IS
Corrente de saturação de transporte (em amperes).
BF
Beta direto máximo ideal.
NF
Coeficiente de emissão de corrente direta.
RE
Resistência do emissor (em ohms).
IKF
Corrente de início da queda do beta direto em altas correntes (em amperes).
ISE
Corrente de saturação de fuga B-E (em amperes).
NE
Coeficiente de emissão de fuga B-E.
As seções a seguir detalham os dados necessários, cuja inserção permitirá que o Assistente extraia esses parâmetros.
-
Base-Emitter Voltage versus Collector Current
Esses dados são usados para extrair os parâmetros IS, NF, RE e IKF. A imagem abaixo mostra um exemplo de gráfico da tensão base-emissor (VBE) em função da corrente de coletor (IC), obtido de uma folha de dados.
Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem. Os valores brutos de IC devem ser inseridos — o Assistente aplicará a função LN aos dados da curva.
O valor da razão de beta forçado da curva (β = IC/IB) também precisa ser inserido. No exemplo de gráfico da imagem acima, esse valor é mostrado no canto superior esquerdo do gráfico; portanto, deve-se inserir o valor 10.
-
DC Current Gain versus Collector Current
Esses dados são usados para extrair os parâmetros BF, NE, ISE e IKF. A imagem abaixo mostra um exemplo de gráfico do ganho de corrente em CC (hFE) em função da corrente de coletor (IC), obtido de uma folha de dados.
Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem. Para garantir a precisão, devem ser inseridos valores de ganho de corrente em CC para valores baixos, médios e altos de corrente de coletor.
-
-
Forward Early Voltage
O parâmetro a seguir é usado para modelar o efeito da modulação da largura da base no modelo de transistor Gummel-Poon:
VAF
Tensão Early direta (em volts).
Para extrair esse parâmetro, será necessário inserir um ponto da curva de admitância de saída (hOE) em função da corrente de coletor (IC). A imagem abaixo mostra um exemplo dessa curva.
Leia qualquer valor na curva. No exemplo da imagem acima, podemos ler IC = 1mA e hOE = 30μmhos.
Normalmente, os dados são apresentados em formato de tabela, como no exemplo mostrado na imagem abaixo.

Exemplo de entrada em tabela para a admitância de saída.Os valores de interesse na imagem — e os valores a serem inseridos no Assistente — são 1mA para a corrente de coletor e 30μmhos para a admitância de saída (normalmente é usado o valor máximo).
Características modeladas usando dados medidos ou fornecidos pelo fabricante
As características a seguir podem ser modeladas usando dados obtidos da folha de dados de um fabricante ou de medições diretas realizadas em um dispositivo físico.
-
Base-Emitter Capacitance
Os parâmetros a seguir são usados para descrever a capacitância de junção sob polarização reversa da junção base-emissor:
CJE
Capacitância de depleção B-E com polarização zero (em farads).
MJE
Fator exponencial da junção B-E.
VJE
Potencial interno B-E (em volts).
Para extrair esses parâmetros, é necessário um gráfico da capacitância da junção B-E sob polarização reversa (Cj) em função da tensão (VBE). Se não houver um medidor de capacitância disponível, o exemplo de circuito de teste da imagem abaixo poderá ser usado para obter os dados. A imagem também mostra exemplos de gráficos obtidos com esse circuito — representando, respectivamente, VBE e Cj em função do tempo. A partir desses gráficos, é possível ler facilmente os valores de VBE e Cj em instantes correspondentes.

Exemplo de circuito e gráficos para a capacitância da junção B-E sob polarização reversa.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos dos gráficos de origem.
O circuito de exemplo da imagem acima é baseado na equação:
I = C * (dv/dt)Isolando C nessa equação, obtemos:
C = I/(dv/dt)O circuito produz uma rampa de tensão a partir da fonte V1. Calculando a inclinação dessa rampa de tensão, pode-se obter a parte
dv/dtda equação. Dividindo a corrente medida do diodo pela inclinação da rampa de tensão, pode-se obter a curva de capacitância do diodo. Os dois gráficos na imagem acima se relacionam com o circuito da seguinte forma:-
Gráfico superior – VBE é V1.
-
Gráfico inferior – Cj é q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Os seguintes parâmetros são usados para descrever a capacitância da junção base-coletor sob polarização reversa:
CJC
Capacitância de depleção B-C com polarização nula (em farads).
MJC
Fator exponencial da junção B-C.
VJC
Potencial interno B-C (em volts).
Para extrair esses parâmetros, é necessário um gráfico da capacitância da junção B-C sob polarização reversa (Cj) em função da tensão (VBC). Se não houver um medidor de capacitância disponível, o circuito de teste de exemplo da imagem abaixo poderá ser usado para obter os dados. A imagem também mostra exemplos de gráficos obtidos com esse circuito, representando VBC e Cj em função do tempo, respectivamente. Nesses gráficos, os valores de VBC e Cj em instantes correspondentes podem ser lidos facilmente.

Exemplo de circuito e gráficos para a capacitância da junção B-C sob polarização reversa.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem.
O circuito de exemplo na imagem acima se baseia na equação:
I = C * (dv/dt)Isolando C nessa equação, obtém-se:
C = I/(dv/dt)O circuito produz uma rampa de tensão a partir da fonte V1. Calculando a inclinação dessa rampa de tensão, pode-se obter a parte
dv/dtda equação. Dividindo a corrente medida do diodo pela inclinação da rampa de tensão, pode-se obter a curva de capacitância do diodo. Os dois gráficos na imagem acima se relacionam com o circuito da seguinte forma:-
Gráfico superior – VBC é V1.
-
Gráfico inferior – Cj é q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Os seguintes parâmetros são usados para descrever a capacitância da junção coletor-substrato sob polarização reversa:
CJS
Capacitância coletor-substrato com polarização nula (em farads).
MJS
Fator exponencial da junção do substrato.
VJS
Potencial interno da junção do substrato (em volts).
Para extrair esses parâmetros, é necessário um gráfico da capacitância da junção C-S sob polarização reversa (Cj) em função da tensão (VCS). Se não houver um medidor de capacitância disponível, o circuito de teste de exemplo da imagem abaixo poderá ser usado para obter os dados. A imagem também mostra exemplos de gráficos obtidos com esse circuito, representando VCS e Cj em função do tempo, respectivamente. Nesses gráficos, os valores de VCS e Cj em instantes correspondentes podem ser lidos facilmente.

Exemplo de circuito e gráficos para a capacitância da junção C-S sob polarização reversa.Os dados são inseridos no Assistente como uma série de pontos de dados obtidos do gráfico de origem.
O circuito de exemplo na imagem acima se baseia na equação:
I = C * (dv/dt)Isolando C nessa equação, obtém-se:
C = I/(dv/dt)O circuito produz uma rampa de tensão a partir da fonte V1. Calculando a inclinação dessa rampa de tensão, pode-se obter a parte
dv/dtda equação. Dividindo a corrente medida do diodo pela inclinação da rampa de tensão, pode-se obter a curva de capacitância do diodo. Os dois gráficos na imagem acima 24 se relacionam com o circuito da seguinte forma:-
Gráfico superior – VCS é V1.
-
Gráfico inferior – Cj é q1[is]/(dV1/dt).
-
-
Transit Times
Os seguintes parâmetros são usados para descrever o tempo de trânsito do BJT:
TF
Tempo de trânsito direto ideal (em segundos).
TR
Tempo de trânsito reverso ideal (em segundos).
Para extrair esses parâmetros, o Assistente exige a inserção da frequência de ganho unitário (fT) do transistor. Essa é a frequência na qual o ganho de corrente do transistor se torna unitário. Esse dado normalmente é encontrado nas folhas de dados dos fabricantes na forma de dados numéricos simples.
A imagem abaixo ilustra como essa informação aparece na folha de dados de um fabricante. O valor de interesse na imagem — o valor a ser inserido no Assistente — é 100 MHz.

Exemplo de entrada em tabela para o produto ganho de corrente-largura de banda.
Parâmetros não extraídos pelo Assistente
Os seguintes parâmetros são difíceis de extrair de dados de medição e geralmente não estão presentes nas folhas de dados dos fabricantes. Eles não são extraídos pelo Assistente nem adicionados ao arquivo de modelo resultante para um BJT. Embora não estejam presentes no arquivo MDL, o SPICE ainda usa esses parâmetros ao simular o dispositivo BJT, utilizando seus valores padrão inerentes. Esses valores padrão estão incluídos abaixo para facilitar a consulta.
IRB |
Corrente na qual a resistência de base cai até o ponto intermediário entre seu valor inicial e seu valor mínimo (em amperes). (Padrão = infinito). |
|
RBM |
Resistência mínima de base em correntes elevadas (em ohms). (Padrão = RB). |
|
XTF |
Coeficiente da dependência de TF em relação à polarização. (Padrão = 0). |
|
VTF |
Tensão que descreve a dependência de TF em relação a VBC (em volts). (Padrão = infinito). |
|
ITF |
Parâmetro de alta corrente para o efeito sobre TF (em amperes). (Padrão = 0). |
|
PTF |
Excesso de fase em freq=1.0/(TF*2PI)Hz (em graus). (Padrão = 0). |
|
XCJC |
Fração da capacitância de depleção B-C conectada ao nó interno da base. (Padrão = 1). |
|
XTB |
Expoente de temperatura do beta direto e reverso. (Padrão = 0). |
|
EG |
Energia de banda proibida para o efeito da temperatura sobre IS (em eV). (Padrão = 1,11). |
|
XTI |
Expoente de temperatura para o efeito sobre IS. (Padrão = 3). |
|
KF |
Coeficiente de ruído de cintilação. (Padrão = 0). |
|
AF |
Expoente de ruído de cintilação. (Padrão = 1). |
|
FC |
Coeficiente da fórmula da capacitância de depleção sob polarização direta. (Padrão = 0,5). |
|
TNOM |
Temperatura de medição do parâmetro (em ˚C). (O valor padrão deste parâmetro é igual ao valor inserido para o parâmetro TNOM na página Opções SPICE da caixa de diálogo Configuração da análise. Por padrão, esse valor é 27 ˚C). |
Você pode, é claro, adicionar manualmente qualquer um desses parâmetros ao arquivo MDL, especificando os valores que deseja utilizar conforme necessário.
