Tạo Mẫu Pad & Via và Thư viện
Sơ lược
- Tìm hiểu cách tạo thư viện từ đầu hoặc từ các pad và via trong PCB hiện có.
- Nắm được cách thêm, xóa và chỉnh sửa các mẫu pad và via.
- Khám phá các tùy chọn cấu hình kích thước lỗ, lớp mặt nạ, cấu trúc pad và via theo lớp, cùng các thiết lập kết nối giảm nhiệt.
Cùng với các đối tượng đường mạch, pad và via là những thành phần cơ bản của mọi thiết kế bo mạch. Để nâng cao khả năng tái sử dụng và quản lý thiết kế đối với pad và via trong thiết kế PCB, Altium Designer hỗ trợ các thư viện mẫu pad và via.
Khái niệm mẫu pad và via có thể được tập hợp trong một thư viện cũng tương tự như thư viện footprint PCB, dù đơn giản hơn đôi chút. Thư viện mẫu pad/via không lưu trữ pad và via thực tế mà lưu trữ các định nghĩa được cấu hình sẵn để áp dụng cho từng pad hoặc via khi đặt chúng. Các thư viện mẫu pad/via đã lưu có thể được tải và sử dụng để đặt các pad và via được định nghĩa sẵn vào bất kỳ thiết kế PCB hoặc footprint PCB nào.
Thư viện mẫu pad/via là một loại tài liệu thiết kế khác có thể được tạo trong Altium Designer và có phần mở rộng tệp là *.PvLib. Thư viện mẫu pad/via có thể được đưa vào dưới dạng tài liệu của dự án. Khi đó, các mẫu này luôn có sẵn cho dự án đó thông qua bảng PCB Pad Via Templates. Thư viện mẫu cũng có thể được cài đặt trong bảng để sử dụng cho tất cả các dự án đang mở. Tìm hiểu thêm về cách đưa các mẫu vào sử dụng trên trang Làm việc với mẫu pad/via.
Mẫu pad và via được tạo và chỉnh sửa bằng cách mở tệp PvLib. Các mẫu pad và via trong PvLib được liệt kê trong bảng Pad Via Library, còn mẫu pad hoặc via được chọn sẽ hiển thị trong Trình chỉnh sửa mẫu pad/via, như minh họa bên dưới.
|
Cả mẫu pad và mẫu via đều được chỉnh sửa bằng cách mở tệp PvLib. Các tùy chọn của trình chỉnh sửa sẽ thay đổi cho phù hợp với loại đối tượng đang được chỉnh sửa. Hình này hiển thị Trình chỉnh sửa mẫu pad. Cả mẫu pad và mẫu via đều được chỉnh sửa bằng cách mở tệp PvLib. Các tùy chọn của trình chỉnh sửa sẽ thay đổi cho phù hợp với loại đối tượng đang được chỉnh sửa. Hình này hiển thị Trình chỉnh sửa mẫu via. |
Tạo thư viện mẫu pad/via
Có thể tạo thư viện mẫu pad/via mới theo các cách sau:
-
Chọn lệnh File » New » Library từ các menu chính rồi chọn tùy chọn Pad Via Library trong vùng File của hộp thoại New Library vừa mở, sau đó nhấp vào Create. Thư viện mẫu pad/via mới được đặt tên mặc định là
PvLib1.PvLib. Ở giai đoạn này, tệp chưa được lưu vào ổ cứng; tệp chỉ tồn tại trong bộ nhớ máy tính. Vì tệp chưa được lưu nên vào lần lưu đầu tiên, hộp thoại Save As sẽ mở ra, đề xuất lưu tệp vào Default Location được xác định trên trang Hệ thống – Vị trí mặc định của hộp thoại Preferences. -
Cũng có thể thêm thư viện mẫu pad/via mới vào dự án hiện tại bằng cách nhấp chuột phải vào dự án trong bảng Projects rồi chọn Add New to Project » Pad Via Library từ menu ngữ cảnh. Tệp sẽ xuất hiện trong thư mục
Libraries/Pad Via Library Documentscủa cấu trúc dự án. Khi lưu tệp, vị trí mặc định sẽ là thư mục dự án. -
Có thể tạo thư viện mẫu pad/via từ các pad và via trong một PCB đang mở ở chế độ Pad & Via Templates của bảng PCB. Sử dụng các kỹ thuật chọn tiêu chuẩn của Windows để chọn các mẫu pad/via cần lưu vào thư viện, sau đó nhấp vào nút Save as Library. PvLib mới sẽ mở ra và sẵn sàng để chỉnh sửa nhưng chưa được lưu vào ổ cứng. Lưu tệp vào vị trí phù hợp và đặt tên theo yêu cầu. Khi thư viện mẫu pad/via mở lần đầu trong Trình chỉnh sửa mẫu, bảng Pad Via Library có thể chỉ hiển thị một mẫu pad (mẫu mặc định). Nếu xảy ra trường hợp này, hãy lưu, đóng rồi mở lại tệp để làm mới danh sách mẫu trong bảng Pad Via Library.

Có thể tạo thư viện mẫu pad/via từ các pad/via được chọn trong PCB hiện tại.
Bảng thư viện pad/via
Bảng Pad Via Library cho phép truy cập các mẫu có trong thư viện pad/via đang hoạt động. Bảng Pad Via Library có trong trình chỉnh sửa mẫu pad/via liệt kê các mẫu pad và via có trong thư viện mẫu pad/via hiện tại. Đơn vị ưu tiên cho phiên chỉnh sửa này được chọn từ menu thả xuống Display Units ở đầu bảng.
Truy cập bảng
Có thể truy cập bảng từ Trình chỉnh sửa mẫu pad/via (khi tài liệu *.PvLib đang mở là tài liệu hiện hoạt trong không gian thiết kế) theo các cách sau:
- Nhấp vào nút Panels ở góc dưới bên phải của không gian thiết kế rồi chọn Pad Via Library.
- Nhấp vào View » Panels » Pad Via Library từ các menu chính.
Tạo mẫu pad hoặc via
Để tạo mẫu pad hoặc via mới, nhấp chuột phải bên trong bảng rồi chọn Add Pad template hoặc Add Via template từ menu ngữ cảnh. Sử dụng Delete để xóa một mẫu khỏi thư viện.

Bảng cho phép truy cập các mẫu có trong thư viện pad/via hiện tại. Nhấp chuột phải để thêm mẫu mới.
Trình chỉnh sửa mẫu pad/via
Pad Template Editor được dùng để thiết lập các tùy chọn cấu hình cơ bản cho mẫu pad hoặc via, sau đó có thể áp dụng mẫu này cho pad hoặc via trong tài liệu PCB hoặc footprint PCB. Các tùy chọn này bao gồm những thuộc tính chính của cấu hình pad/via, còn các thuộc tính riêng của tài liệu (như vị trí, hướng, lớp, v.v.) được xác định khi đặt pad hoặc via vào tài liệu thiết kế.

Trình chỉnh sửa mẫu được dùng để cấu hình mẫu pad hoặc via hiện được chọn trong bảng Pad Via Library.
Phần lớn các tùy chọn cấu hình pad/via là những thiết lập pad và via tiêu chuẩn, quen thuộc của Altium Designer (kích thước, lỗ và lớp mặt nạ, v.v.). Trình chỉnh sửa mẫu pad có chung thiết kế giao diện và nhiều tùy chọn với Trình chỉnh sửa mẫu via. Từng vùng của trình chỉnh sửa mẫu được mô tả bên dưới, trong đó các tùy chọn chỉ dành riêng cho pad hoặc via được ghi chú rõ.
Thông tin chung
-
Name – mặc định là tên tự động dựa trên các thuộc tính của pad/via, tuân theo IPC-7251/7351 Padstack naming conventions (được mô tả tại đây). Bạn có thể đặt tên thủ công nếu cần và xóa tên đó bằng cách nhấp vào nút
. Nếu một mẫu được đặt tên thủ công đã được sử dụng trong thiết kế bo mạch và sau đó bị hủy liên kết khỏi thư viện mẫu (để có thể chỉnh sửa các thuộc tính của mẫu), tên thủ công sẽ được thay bằng tên tự động.
- Description – mô tả tùy chọn.
- Pad Type (chỉ dành cho pad) – Gắn bề mặt hoặc xuyên lỗ.
Thông tin lỗ
- Hole Size – được biểu thị bằng h<Value> trong tên, là đường kính của lỗ.
- Tolerance – được biểu thị bằng Tol trong tên, nhập dung sai lỗ + và - nếu cần. Nhập N/A nếu không áp dụng.
- Hole Type (chỉ dành cho pad) – Tròn, vuông hoặc rãnh.
- Length (chỉ dành cho pad) – được biểu thị bằng _<Value> thêm vào sau kích thước lỗ trong tên, là chiều dài của lỗ vuông hoặc rãnh.
- Rotation (chỉ dành cho pad) – góc xoay của lỗ vuông hoặc rãnh.
- Plated (chỉ dành cho pad) – có mạ hoặc không mạ (không mạ được biểu thị bằng n trong tên).
Mặt nạ kem hàn (chỉ dành cho pad)
- Manual Expansion – chọn ô này để xác định thủ công giá trị mở rộng, ghi đè giá trị của quy tắc thiết kế khi đặt pad vào thiết kế PCB. Giá trị này được biểu thị bằng p<Value> trong tên mẫu pad.
- Expansion – mức mở rộng (giá trị dương) hoặc thu hẹp (giá trị âm) của cửa mở trên mặt nạ kem hàn. Có thể xác định dưới dạng giá trị tuyệt đối (mil/mm) hoặc phần trăm diện tích pad. Khi xác định giá trị tuyệt đối, tỷ lệ phần trăm sẽ hiển thị ở bên phải trường này và ngược lại. Bỏ chọn ô Use Paste ở bên trái trường để tắt mặt nạ kem hàn cho mẫu pad.
Mặt nạ hàn
- Manual Expansion – được biểu thị bằng m<Value> trong tên, trong đó m<Value> là kích thước tổng thể của cửa mở trên mặt nạ hàn. Thành phần tên này trở thành m<Value>mx<Value> nếu các giá trị mở rộng ở mặt trên và mặt dưới không được liên kết.
- Top/Bottom – mức mở rộng, được đo từ mép pad/via trừ khi tùy chọn Solder mask from the hole edge được bật.
-
– các giá trị ở mặt trên và mặt dưới được liên kết (giống nhau), nhấp để xác định các giá trị khác nhau cho mặt trên và mặt dưới.
- Tented – bật để đóng cửa mở trên mặt nạ hàn (kích thước cửa mở được đặt về 0).
- Solder mask from the hole edge – bật để lấy mép lỗ làm mốc cho giá trị mở rộng, thay vì mép pad/via.
Loại và đặc tính via (chỉ dành cho via)
- IPC 4761 Via Type – sử dụng danh sách thả xuống để chọn loại via theo tiêu chuẩn IPC 4761, Design Guide for Protection of Printed Board Via Structures.
-
Grid – xuất hiện khi chọn loại via khác với
Nonetrong danh sách thả xuống IPC 4761 Via Type. Chọn Side của bo mạch và nhập Material cho các đặc tính khả dụng tương ứng với loại via đã chọn.
Kích thước và hình dạng
- Offset From Hole Center (X/Y) (chỉ dành cho pad) – được biểu thị bằng o<Xvalue>_<Yvalue> trong tên, là độ lệch của lỗ pad so với tâm pad.
-
Mode – kiểu cấu trúc lớp pad/via, các tùy chọn gồm
Simple,Top-Middle-BottomhoặcFull Stack(đối với pad, tùy chọn này chỉ khả dụng khi Pad Type là lỗ xuyên). Cho phép pad/via có các thuộc tính kích thước và hình dạng khác nhau trên những lớp khả dụng trong chế độ đó. Thành phần tên x<Xvalue_Yvalue> được thêm vào khi xác định kích thước/hình dạng khác cho lớp dưới. Thành phần tên z<Xvalue_Yvalue> được thêm vào khi xác định kích thước/hình dạng khác cho các lớp giữa. -
Attributes on Layer – các thuộc tính tiêu chuẩn của pad/via.
-
Shape (chỉ dành cho pad) – được biểu thị bằng c<SizeValue> (hình tròn); s<SizeValue> (hình vuông) hoặc r<xSizeValue_ySizeValue> (hình chữ nhật) tùy theo kích thước X/Y giống hay khác nhau; s<SizeValue>c<Value> (hình bát giác); s<Sizevalue>r<Radius%Value> hoặc r<xSizeValue_ySizeValue>r<Radius%Value> (hình chữ nhật bo góc).
-
X & Y Size (chỉ dành cho pad) – kích thước pad trong mặt phẳng X & Y.
-
Corner Radius (chỉ dành cho pad) – giá trị tuyệt đối của bán kính bo góc pad. Giá trị này phải nhỏ hơn hoặc bằng một nửa cạnh ngắn nhất của pad. Nhập một giá trị theo sau bởi ký hiệu
%để xác định bán kính theo tỷ lệ phần trăm của một nửa cạnh ngắn nhất của pad, trong đó100%sẽ bo tròn hoàn toàn cạnh ngắn nhất của pad. Tùy chọn này chỉ khả dụng nếu Rounded Rectangle được chọn cho Shape của pad. -
Diameter (chỉ dành cho via) – đường kính via (via chỉ có thể có dạng tròn).
-
-
Thermal Relief – các thiết lập kết nối tản nhiệt từ pad này đến vùng đổ đồng bao quanh thuộc cùng net; bỏ chọn ô From Rule để chỉnh sửa và sử dụng các thiết lập cục bộ này.
- From Rule – các thiết lập cục bộ không được áp dụng khi tùy chọn này được bật; bỏ chọn để thiết lập và sử dụng các thiết lập cục bộ.
- Connect Style – kiểu kết nối tản nhiệt.
- Air Gap – khoảng cách từ mép pad đến vùng đổ đồng bao quanh.
- Conductors – số lượng nhánh dẫn từ pad đến vùng đổ đồng bao quanh.
- Width – chiều rộng của các nhánh dẫn từ pad đến vùng đổ đồng bao quanh.
- Angle – cách bố trí góc của các nhánh dẫn tản nhiệt.
- Layer – các lớp trong cấu trúc lớp pad/via này; các lớp khả dụng phụ thuộc vào thiết lập Mode hiện tại; nhấp chuột phải để thêm, xóa hoặc đặt lại các lớp khi Mode là Full Stack.


