Đồng bộ hóa dữ liệu cơ sở dữ liệu chuỗi cung ứng vào Workspace
Thông qua khái niệm Lựa chọn linh kiện, các linh kiện được lưu trữ trong Workspace Altium 365 hoặc Workspace Enterprise Server có thể được liên kết với các linh kiện thực tế của nhà cung cấp (nhà bán hàng), dựa trên linh kiện của nhà sản xuất đã được chỉ định. Theo mặc định, dữ liệu chuỗi cung ứng này được lấy từ dịch vụ đám mây Altium Parts Provider và bao gồm thông tin linh kiện của nhà cung cấp theo thời gian thực, chẳng hạn như mức tồn kho, đơn giá và các ngưỡng số lượng áp dụng mức giá khác nhau.
Tuy nhiên, đối với nhiều tổ chức, dữ liệu nhà cung cấp linh kiện được (và phải được) lấy từ hệ thống doanh nghiệp nội bộ của công ty, nơi cung cấp bộ dữ liệu nhà cung cấp linh kiện riêng — có thể dựa trên danh sách nhà cung cấp được phê duyệt nghiêm ngặt và/hoặc các cơ cấu giá đặc biệt. Nhu cầu này được đáp ứng bằng giải pháp thay thế của Altium Custom Parts Provider; khi được cấu hình để đồng bộ hóa thông qua Altium Designer, giải pháp này cho phép ánh xạ dữ liệu nhà cung cấp từ một nguồn cơ sở dữ liệu được chỉ định sang dữ liệu chuỗi cung ứng của Workspace.
Sử dụng tính năng Custom Parts Provider Synchronization của Altium Designer như mô tả bên dưới, dữ liệu nhà cung cấp từ một bảng được chọn trong cơ sở dữ liệu chính được ánh xạ để trở thành nguồn dữ liệu thay thế cho các Lựa chọn linh kiện được thiết lập trong Altium Designer. Trên thực tế, cấu hình ánh xạ bạn tạo được dùng để đồng bộ hóa cơ sở dữ liệu nguồn với dữ liệu nhà cung cấp trong Workspace theo lịch hoặc đơn giản là theo yêu cầu. Kết quả là các cập nhật dữ liệu nhà cung cấp trong cơ sở dữ liệu chính sẽ được truyền sang dữ liệu nhà cung cấp của linh kiện tương ứng trong Workspace đã kết nối.
Tính năng này cho phép các công ty quản lý tập trung dữ liệu nhà cung cấp linh kiện trong cơ sở dữ liệu của hệ thống doanh nghiệp tận dụng các lợi ích của Workspace Altium, đồng thời duy trì đồng bộ hóa với hệ thống doanh nghiệp của họ (PLM, PDM, ERP, v.v.) — hoặc đơn giản là với một cơ sở dữ liệu dùng chung hay tệp CSV. Ở chế độ đồng bộ hóa tự động, tác vụ được lên lịch trong Windows sẽ thực hiện việc cập nhật dữ liệu từ cơ sở dữ liệu sang Workspace độc lập với ứng dụng thiết kế Altium Designer.
-
Xem Nhập thư viện hiện có vào Workspace đã kết nối của bạn để biết thông tin về cách nhập thư viện cơ sở dữ liệu vào Workspace.
-
Xem Đồng bộ hóa dữ liệu giữa cơ sở dữ liệu linh kiện và Workspace để biết thông tin về quy trình liên quan nhằm đồng bộ hóa dữ liệu tham số linh kiện trong Workspace với một nguồn cơ sở dữ liệu.
Tạo cấu hình đồng bộ hóa nhà cung cấp linh kiện tùy chỉnh
Việc đồng bộ hóa dữ liệu nhà cung cấp linh kiện từ cơ sở dữ liệu sang Workspace được thiết lập bằng cách tạo và cấu hình một tài liệu Custom Parts Provider Synchronization Configuration (*.PrtSync) trong Altium Designer. Giao diện và chức năng của tài liệu này tương tự như Components Synchronizer. Khi đã kết nối với Workspace Altium, hãy tạo tài liệu mới bằng lệnh menu File » New » Custom Parts Provider Synchronization Configuration.
Thêm nguồn dữ liệu chính mong muốn vào cấu hình đồng bộ hóa bằng nút
, hoặc kéo và thả các tệp dữ liệu tương thích vào vùng Data Sources của giao diện. Cấu hình hỗ trợ các nguồn dữ liệu tham số linh kiện sau:
-
Tệp cơ sở dữ liệu Access (
*.mdb,*.accdb) -
Bảng tính Excel (
*.xlsx) -
Tệp CSV (
*.csv) -
Các nguồn dữ liệu khác, chẳng hạn như giao diện tương thích OLE DB trên máy chủ (bao gồm cơ sở dữ liệu PostgreSQL), thông qua một chuỗi kết nối riêng. Xem phần Cấu hình MySQL bên dưới để biết quy trình kết nối ODBC cho MySQL.
Trong ví dụ minh họa ở đây, một cơ sở dữ liệu lưu trữ dữ liệu nhà cung cấp linh kiện (cho các linh kiện điốt Zener) đã được thêm vào cấu hình. Cơ sở dữ liệu nguồn (SupplierData.mdb) chứa hai bảng — CustomSupplierParts1 và CustomSupplierParts2 — trong đó bảng đầu tiên được bật để ánh xạ và đồng bộ hóa.
Quy trình cấu hình ODBC cho MySQL
Việc đồng bộ hóa nhà cung cấp linh kiện tùy chỉnh với cơ sở dữ liệu MySQL được thiết lập bằng Microsoft OLE DB Provider for ODBC cùng với ứng dụng MySQL Connector/ODB. Quy trình kết nối và thiết lập như sau:
-
Tải xuống và cài đặt MySQL Connector, có thể lấy thông qua tùy chọn cài đặt Custom của MySQL Installer 8. Sau đó, chạy ứng dụng ODB Data Sources của Windows để thêm loại MySQL ODBC ANSI Driver, chỉ định nguồn MySQL và cơ sở dữ liệu của bạn trong MYSQL Connector, rồi xác nhận Nguồn dữ liệu ODB vừa thêm.
-
Tạo cấu hình Parts Sync mới trong Altium Designer (File » New » Custom Parts Provider Synchronization Configuration) và chọn tùy chọn Use Connection String từ menu
.
-
Trong hộp thoại Data Link Properties tiếp theo, chọn tùy chọn
Microsoft OLER DB Provider for ODBC Driverstrong tab Provider, nhấp vào Next, rồi trong tab Connection của hộp thoại, nhập thông tin nguồn dữ liệu đã thiết lập ở Step 1 bên trên. -
Bật bảng cơ sở dữ liệu MySQL mong muốn trong bảng điều khiển Properties của Altium Designer.
-
Chọn bảng cơ sở dữ liệu trong cây phân cấp Data Source rồi ánh xạ các cột dữ liệu sang các tham số Altium trong bảng điều khiển Properties theo nhu cầu.
Ánh xạ tham số dữ liệu nhà cung cấp
Cấu hình nhà cung cấp linh kiện tùy chỉnh mới truy cập bảng cơ sở dữ liệu dưới dạng nguồn dữ liệu tham số. Khi bảng được chọn trong cây Data Sources của cấu hình, dữ liệu của bảng có thể được ánh xạ sang các tham số dữ liệu nhà cung cấp tiêu chuẩn mà Altium Designer và Workspace Altium sử dụng.
Các tham số dữ liệu nhà cung cấp được ánh xạ từ cơ sở dữ liệu nguồn sang cấu hình Parts Provider trong vùng Parameter Mapping của bảng điều khiển Properties. Sử dụng các tùy chọn trong menu thả xuống của mục Column để chọn một tham số trong cơ sở dữ liệu nguồn khớp chính xác với tham số dữ liệu nhà cung cấp, hoặc để loại bỏ một tham số khỏi quá trình đồng bộ hóa (<Skip>). Mỗi bộ dữ liệu tham số được thêm vào danh sách Components Preview khi được ánh xạ. Bạn có thể sắp xếp lại các cột này bằng cách kéo tiêu đề cột và bật/tắt chúng thông qua menu Select Columns (truy cập bằng cách nhấp chuột phải vào tiêu đề cột).
Hệ thống hỗ trợ một số tham số dữ liệu nhà cung cấp, bao gồm Manufacturer Name, Manufacturer Part Number, Category, Datasheet, v.v. Bạn cũng có thể thêm và xóa các tham số dữ liệu nhà cung cấp tùy chỉnh bằng các nút
và
trong vùng Parameter Mapping của bảng Properties.
Các ngưỡng giá linh kiện biểu thị số lượng linh kiện cần đặt mua từ nhà cung cấp để được giảm đơn giá. Số lượng đặt hàng yêu cầu thường được chia thành các mức tăng theo bội số của 10 – 10 đơn vị, 100 đơn vị, v.v. – và được hỗ trợ trong các mục lựa chọn linh kiện thuộc dữ liệu nhà cung cấp của Altium.
Dữ liệu dạng số này có thể được ánh xạ từ các mục trong cơ sở dữ liệu nguồn sang dữ liệu nhà cung cấp của Workspace bằng cách thêm các mục Quantity cho ngưỡng giá trong phần Price Breaks của bảng Properties – với số lượng tăng lần lượt theo bội số của 10 – rồi ánh xạ các mục đó tới những trường cơ sở dữ liệu thích hợp. Lưu ý rằng tham số chi phí unit thông thường (Price) nằm trong phần Parameter Mapping chung.
Đồng bộ hóa cơ sở dữ liệu với Workspace
Khi đã hài lòng với thiết lập ánh xạ dữ liệu nhà cung cấp, hãy lưu tài liệu cấu hình nhà cung cấp linh kiện tùy chỉnh (File » Save) và thực hiện đồng bộ hóa dữ liệu từ cơ sở dữ liệu nguồn lên máy chủ bằng nút
, hoặc thiết lập đồng bộ hóa theo lịch Lần đồng bộ hóa đầu tiên sẽ tải dữ liệu nhà cung cấp đã ánh xạ từ cơ sở dữ liệu của công ty lên Altium Workspace, và các chu kỳ đồng bộ hóa tiếp theo sẽ cập nhật dữ liệu đó.
Trong ví dụ minh họa ở đây, dữ liệu nhà cung cấp cho các linh kiện điốt Zener đã được đồng bộ hóa từ cơ sở dữ liệu nguồn lên Workspace sẽ xuất hiện dưới dạng dữ liệu Custom Parts Provider cho các linh kiện đó – bên cạnh dữ liệu nhà cung cấp linh kiện thông thường do dịch vụ đám mây Altium Parts Provider cung cấp.
Bạn có thể thấy ngay điều này trong bảng Manufacturer Part Search khi chọn danh mục Custom Parts Provider: bảng sẽ hiển thị các phương án cung ứng linh kiện từ dịch vụ Custom Parts Provider, được đồng bộ hóa từ cơ sở dữ liệu nhà cung cấp của tổ chức bạn.
Hợp nhất dữ liệu nhà cung cấp
Nếu tên nhà sản xuất và mã linh kiện của nhà sản xuất cho một linh kiện trong cơ sở dữ liệu nhà cung cấp mà bạn đã đồng bộ hóa trùng với tên nhà sản xuất và mã linh kiện của nhà sản xuất cho một linh kiện do Altium Parts Provider cung cấp, thì dữ liệu nhà cung cấp từ Custom Parts Provider mà bạn đã cấu hình sẽ được hợp nhất với dữ liệu từ Altium Parts Provider để hiển thị toàn bộ thông tin nhà cung cấp ở bất kỳ nơi nào dữ liệu nhà cung cấp (SPN) được hiển thị trong giao diện phần mềm, bao gồm bảng Manufacturer Part Search, ActiveBOM và mỗi khi thêm lựa chọn linh kiện.
Lựa chọn linh kiện từ dữ liệu nhà cung cấp tùy chỉnh
Khi thêm thông tin Lựa chọn linh kiện vào các mục linh kiện trong bảng Components (nhấp chuột phải, Operations » Create/Edit PCL), dữ liệu nhà cung cấp do Custom Parts Provider cung cấp sẽ xuất hiện ở đầu danh sách trong hộp thoại Add Part Choices – như minh họa ở đây cho mục điốt Zener 1N4747A. Mục được chọn (được tô sáng) sẽ được thêm làm lựa chọn linh kiện cho linh kiện đang chọn trong bảng Components.
Tương tự dịch vụ Altium Parts Provider, Custom Parts Provider cũng hỗ trợ dữ liệu nhà cung cấp cho nhiều nhà sản xuất và từ nhiều nhà cung cấp – dữ liệu này được lấy từ nhiều mục riêng biệt trong bảng cơ sở dữ liệu nguồn. Cũng lưu ý rằng dữ liệu nhà cung cấp tùy chỉnh sẽ bao gồm thông tin về ngưỡng giá và lượng hàng tồn kho được đồng bộ hóa từ cơ sở dữ liệu nguồn.
Ngoài bảng Components như minh họa ở đây, các Lựa chọn linh kiện từ nhà cung cấp có thể được gắn vào một tham chiếu linh kiện trong các giao diện Altium Designer sau:
- Bảng Explorer.
- Tài liệu ActiveBOM.
- Trình chỉnh sửa linh kiện đơn lẻ.
- Trình chỉnh sửa linh kiện hàng loạt.
Đồng bộ hóa theo lịch
Các cấu hình đồng bộ hóa linh kiện đã lưu được thiết lập để xử lý tự động dữ liệu từ cơ sở dữ liệu lên Workspace thông qua hộp thoại Auto Synchronization Schedule, được mở bằng nút
trong giao diện chính.
Đồng bộ hóa theo lịch, theo hồ sơ cấu hình hiện tại, có thể được đặt vào một thời điểm cụ thể mỗi ngày, vào một thời điểm nhất định trong các ngày được chọn trong tuần, hoặc khi bạn đăng nhập vào Windows. Bạn cũng có thể tắt đồng bộ hóa khi chưa đăng nhập. Khi bạn xác nhận các thiết lập bằng nút
, cấu hình sẽ được thêm dưới dạng tác vụ lặp lại trong Windows Task Scheduler. Đặt thành No automatic synchronization để xóa lịch đồng bộ hóa hiện có.
Việc đồng bộ hóa dữ liệu từ cơ sở dữ liệu sang dữ liệu linh kiện cũng có thể được thực hiện thủ công từ dòng lệnh bằng ứng dụng ComponentSync.Executor.exe, nằm trong thư mục \System của bản cài đặt phần mềm. Cú pháp lệnh là ComponentSync.Executor.exe [configuration file name]. Cấu hình MyPrtSyncConfig trong ví dụ này đã được chạy như trong hình bên dưới, sử dụng chuỗi lệnh:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync








).


