Xây dựng & Duy trì Thành phần và Thư viện của Bạn
Sơ lược
- Hiểu cách các ký hiệu sơ đồ nguyên lý, dấu chân PCB và các mô hình khác biểu diễn linh kiện thực tế.
- So sánh các tùy chọn thư viện và khám phá những tính năng của Workspace như chia sẻ dữ liệu linh kiện, tái sử dụng mô hình, thông tin chuỗi cung ứng và theo dõi vòng đời.
- Tìm hiểu cách bắt đầu tạo linh kiện trên Workspace bằng trình biên tập linh kiện và các mẫu linh kiện.
Một thiết kế điện tử là tập hợp các linh kiện được kết nối với nhau. Điều thú vị trong quá trình phát triển sản phẩm là nghĩ ra những cách sáng tạo để giải quyết các thách thức kỹ thuật đó và kết nối các linh kiện để tạo nên thiết kế độc đáo của riêng bạn.
Tuy nhiên, một phần lớn công việc, và với nhiều nhà thiết kế cũng là phần tẻ nhạt hơn, là tạo linh kiện. Dù có thể không thú vị, các linh kiện này sẽ trở thành nguồn tài nguyên quý giá cho công ty, và điều thiết yếu là chúng phải thể hiện chính xác linh kiện thực tế.
Linh kiện bạn mua và hàn lên bo mạch hoặc sử dụng trong bộ dây điện là linh kiện thực tế, nhưng linh kiện đó phải được mô hình hóa trong từng miền thiết kế điện tử mà bạn muốn sử dụng.
Tùy thuộc vào hình thức triển khai thiết kế dự định thực hiện, linh kiện của bạn có thể bao gồm một ký hiệu cho sơ đồ nguyên lý, một mô hình mô phỏng cho trình mô phỏng mạch, một mô hình IBIS để phân tích tính toàn vẹn tín hiệu, một mẫu bố trí chân hoặc footprint để bố trí PCB, và một mô hình 3D để trực quan hóa, kiểm tra khoảng hở 3D và xuất sang môi trường CAD cơ khí.
Quản lý linh kiện
Quản lý hiệu quả dữ liệu linh kiện là yếu tố thiết yếu trong thiết kế điện tử, và việc quản lý các linh kiện được sử dụng trong thiết kế luôn là một yếu tố nền tảng của phần mềm thiết kế Altium. Cùng với sự phát triển của phần mềm qua nhiều năm, các phương pháp quản lý linh kiện đã trải qua một chặng đường dài, từ các thư viện riêng lẻ đơn giản chứa mô hình sơ đồ nguyên lý và PCB, qua các thư viện cơ sở dữ liệu, đến các linh kiện Workspace giúp đưa dữ liệu biểu diễn linh kiện thiết kế vào phạm vi phát triển sản phẩm rộng hơn, cùng các tính năng tiên tiến, dễ sử dụng, mang lại khả năng cộng tác vượt trội trong suốt quá trình thiết kế.
| Thư viện Workspace | Các linh kiện được lưu trữ trong một Workspace được kết nối, cung cấp một nguồn dữ liệu linh kiện cập nhật và được chuẩn hóa duy nhất cho toàn bộ nhóm thiết kế. Khả năng tìm kiếm theo tham số và theo bộ lọc phân loại cho phép bạn tìm và đặt các linh kiện cần thiết một cách hiệu quả, nhanh chóng. Các linh kiện này được liên kết chặt chẽ với linh kiện được sản xuất thực tế và dữ liệu chuỗi cung ứng có thể truy cập ngay trong quá trình thiết kế, giúp cải thiện đáng kể chi phí và thời gian thu mua khi sản xuất sản phẩm lắp ráp hoàn chỉnh. |
|
| Thư viện cơ sở dữ liệu | Bạn muốn liên kết chặt chẽ các linh kiện thiết kế với cơ sở dữ liệu của công ty? Hãy khám phá thư viện cơ sở dữ liệu. Mỗi bản ghi là một linh kiện, tham chiếu đến các mô hình cần thiết và dữ liệu tham số của linh kiện. Các liên kết mô hình và tham số được thêm vào ký hiệu khi đặt, biến ký hiệu đó thành một linh kiện Altium Designer. | |
| Thư viện cơ sở dữ liệu SVN | Thư viện cơ sở dữ liệu SVN là phần mở rộng của mô hình Thư viện cơ sở dữ liệu, với điểm khác biệt là ký hiệu và mô hình nguồn được lưu trữ dưới sự kiểm soát phiên bản. Các thư viện nguồn được tạo, bổ sung và duy trì trong một kho lưu trữ dựa trên Subversion. Liên kết đến kho lưu trữ và cơ sở dữ liệu bên ngoài được xác định trong tệp Thư viện cơ sở dữ liệu SVN (*.SVNDbLib). |
|
| Liên kết cơ sở dữ liệu | Với phương pháp này, tệp Liên kết cơ sở dữ liệu (*.DbLink) xác định liên kết giữa linh kiện trên sơ đồ nguyên lý và một bản ghi tương ứng trong cơ sở dữ liệu. Việc đối chiếu bản ghi được thiết lập thông qua liên kết trường khóa, có thể là một trường khóa đơn lẻ (ví dụ: mã linh kiện) hoặc nhiều trường khóa (bằng cách xác định mệnh đề Where). |
|
| Thư viện tích hợp | Bạn muốn các linh kiện được đóng gói sẵn và xác minh trước trong một tệp duy nhất? Hãy biên dịch các mô hình nguồn sơ đồ nguyên lý/PCB/mô phỏng để tạo thư viện tích hợp (*.IntLib). |
|
| Thư viện sơ đồ nguyên lý | Thư viện sơ đồ nguyên lý (*.SchLib) có thể là thư viện mô hình chứa các ký hiệu linh kiện; hoặc nếu liên kết mô hình và dữ liệu tham số được thêm vào từng ký hiệu, thư viện đó sẽ trở thành thư viện linh kiện. |
|
| Thư viện PCB | Thư viện dùng để lưu trữ các mô hình footprint PCB (*.PcbLib). Nếu cần, có thể thêm mô hình 3D vào từng footprint. Các mô hình 3D được tạo từ các đối tượng khối 3D hoặc từ mô hình STEP được nhập vào một đối tượng khối 3D. |
Thư viện Workspace
Các linh kiện được lưu trữ trong Workspace của bạn – một vị trí tập trung, bảo mật dành cho toàn bộ dữ liệu thiết kế mà cả nhóm thiết kế đều có thể truy cập. Việc sử dụng các linh kiện được lưu trữ trong Workspace mang lại rất nhiều lợi ích. Một số ưu điểm bao gồm:
-
Single source of component data – với Workspace mà cả nhóm đều có thể truy cập, các kỹ sư có thể lấy các linh kiện cập nhật và được chuẩn hóa từ một vị trí bảo mật duy nhất, nhận dữ liệu chuỗi cung ứng theo thời gian thực và sử dụng tính năng tìm kiếm theo tham số và theo bộ lọc phân loại để tìm chính xác linh kiện cần thiết.
-
Design-time choice of physical components – với mỗi linh kiện, bạn có thể chọn những linh kiện của nhà sản xuất nào được phép dùng để hiện thực hóa linh kiện đó khi lắp ráp bo mạch.
-
Real-time supply-chain information – được phản hồi từ cơ sở dữ liệu linh kiện tổng hợp của Altium Parts Provider (bản thân cơ sở dữ liệu này kết nối với và thu thập linh kiện từ các Nhà cung cấp đã được kích hoạt) để nhà thiết kế biết giá và tình trạng sẵn có hiện tại của các linh kiện đã chọn từ tất cả các nhà cung cấp bán những linh kiện đó (như được xác định trong Danh mục linh kiện cục bộ của Workspace). Thông tin này có thể được thêm vào linh kiện bất kỳ lúc nào, kể cả sau khi lưu linh kiện vào Workspace – mà không cần chỉnh sửa trực tiếp linh kiện, do đó không ảnh hưởng đến các thiết kế đang sử dụng linh kiện đó – rồi được sử dụng trong danh sách vật tư (BOM).
-
Concurrent editing of the library – vì thư viện Workspace về bản chất là tập hợp các mục Linh kiện được lưu trữ trong Workspace này, nhiều người dùng có thể chỉnh sửa hoặc tạo linh kiện mới cho thư viện Workspace một cách độc lập, mà không phải chờ người dùng khác hoàn tất công việc của họ.
-
Component Models Reuse – có thể xem linh kiện như một “vùng chứa” lưu trữ toàn bộ thông tin tham số và mô hình theo miền thiết kế, bao gồm ký hiệu sơ đồ nguyên lý, footprint PCB, mô hình đi dây bộ dây điện và mô hình mô phỏng. Linh kiện không chứa trực tiếp các mô hình theo miền thiết kế mà chứa liên kết đến các mục mô hình tương ứng cũng nằm trong Workspace, nhờ đó một mô hình theo miền thiết kế có thể được nhiều linh kiện sử dụng. Nếu mô hình thay đổi, bạn sẽ được đề xuất cập nhật tất cả linh kiện sử dụng mô hình này, qua đó bảo đảm không linh kiện nào sử dụng mô hình lỗi thời.
-
Direct Component Editing – nếu cần chỉnh sửa linh kiện, bạn có thể mở linh kiện để chỉnh sửa ngay trong Workspace. Một phiên bản tạm thời của Trình chỉnh sửa linh kiện cho phép bạn chỉnh sửa mọi khía cạnh của linh kiện đó, bao gồm sửa đổi các mô hình theo miền thiết kế mà linh kiện tham chiếu đến mà không cần thao tác với bất kỳ tài liệu dạng tệp nào.
-
Use of Component Templates – áp dụng các mẫu dựa trên tham số và hệ thống phân loại linh kiện, để mỗi loại linh kiện mới tự động có bộ tham số phù hợp với BOM, đồng thời tự động hóa việc áp dụng đúng các quy tắc đặt tên, phiên bản sửa đổi và vòng đời.
-
Component Lifecycle Validation – nếu linh kiện ở trạng thái “hết vòng đời”, “lỗi thời” hoặc “ngừng duy trì”, bạn sẽ nhận được cảnh báo trước khi tiến hành sản xuất các bo mạch sử dụng linh kiện đó.
-
Where-used Component Traceability – có thể truy vết linh kiện xuyên suốt các nơi sử dụng: nếu một linh kiện trở nên lỗi thời, bạn có thể tìm hiểu linh kiện đó đã được sử dụng trong những thiết kế nào để biết thiết kế nào cần cập nhật. Nếu ký hiệu hoặc footprint có lỗi, bạn có thể xem tất cả linh kiện sử dụng ký hiệu và footprint đó để khắc phục.
-
Requests of new components – kỹ sư có thể gửi yêu cầu tạo linh kiện mới (hoặc còn thiếu) đến những người chuyên quản lý thư viện và nhận thông báo khi linh kiện đó sẵn sàng để người yêu cầu cũng như các kỹ sư khác trong công ty sử dụng trong thiết kế.
Tạo linh kiện thư viện Workspace mới
Linh kiện thực tế được gắn lên bo mạch hoặc sử dụng trong sản xuất bộ dây điện được biểu diễn dưới dạng ký hiệu nguyên lý khi thiết kế sơ đồ nguyên lý và dưới dạng footprint PCB khi thiết kế bo mạch (có thể kèm theo mô hình 3D để trực quan hóa, kiểm tra khoảng hở 3D và xuất sang môi trường CAD cơ khí). Linh kiện thiết kế cũng có thể bao gồm mô hình mô phỏng cho trình mô phỏng mạch và mô hình IBIS để phân tích tính toàn vẹn tín hiệu. Để cung cấp thông tin đại diện cho linh kiện thiết kế trong phạm vi phát triển sản phẩm rộng hơn, có thể thêm một hoặc nhiều Lựa chọn linh kiện vào linh kiện đó.
Các linh kiện cho dự án thiết kế có thể được tạo và lưu trong thư viện Workspace của công ty bạn. Chúng được đặt vào thiết kế thông qua bảng Components, sử dụng công cụ tìm kiếm linh kiện nâng cao của Altium Designer.
Linh kiện thư viện Workspace mới được tạo bằng Trình chỉnh sửa linh kiện, nơi bạn có thể tự xác định toàn bộ dữ liệu linh kiện (mô hình theo miền, tham số, lựa chọn linh kiện, v.v.) hoặc sử dụng dữ liệu lấy từ bảng Manufacturer Part Search.
Để tạo linh kiện thư viện Workspace mới:
-
Chọn lệnh tạo linh kiện. Bạn có thể truy cập lệnh này theo các cách sau:
-
Chọn lệnh File » New » Component từ các menu chính.
-
Chọn File » New » Library từ các menu chính, sau đó trong hộp thoại New Library mở ra, chọn Create Library Content » Component từ vùng Workspace của hộp thoại.
-
Trong bảng Components, nhấp chuột phải vào vùng danh sách linh kiện và chọn lệnh Create từ menu ngữ cảnh.
-
-
Trong hộp thoại Create new component mở ra, chọn một loại linh kiện. Nếu có mẫu linh kiện được liên kết với loại linh kiện đã chọn, mẫu đó sẽ được dùng để xác định trước linh kiện bằng dữ liệu trong mẫu.

Truy cập hộp thoại Create new component để chọn loại linh kiện cần tạo. -
Sau khi nhấp vào OK, Trình chỉnh sửa linh kiện ở chế độ Chỉnh sửa một linh kiện sẽ mở ra. Chế độ này cung cấp giao diện tinh gọn để xác định/chỉnh sửa một linh kiện.
-
Xác định linh kiện bằng cách thêm thông tin chi tiết trong Trình chỉnh sửa linh kiện:
- Trong vùng Component của Trình chỉnh sửa linh kiện, xác định Name và Description của linh kiện. Những thông tin này rất cần thiết cho việc tìm kiếm linh kiện sau này khi bạn cần sử dụng linh kiện trong dự án thiết kế.
-
Nhấp vào điều khiển Advanced Settings để xác định hoặc thay đổi một số thông tin khác của linh kiện, chẳng hạn như Id được dùng cho linh kiện đã lưu trong Workspace và Folder trong Workspace đích nơi linh kiện sẽ được lưu.
-
Trong vùng Parameters của Trình chỉnh sửa linh kiện, xác định thêm thông tin chi tiết về linh kiện: các tham số tiêu chuẩn, liên kết URL đến các trang web (ví dụ: trang web của nhà sản xuất) và liên kết đến tài liệu thông số kỹ thuật (ở bất kỳ định dạng nào).
-
Trong vùng Part Choices của Trình chỉnh sửa linh kiện, chỉ định một hoặc nhiều Lựa chọn linh kiện cho linh kiện – các mã linh kiện của nhà sản xuất 'được phép' sử dụng để hiện thực hóa linh kiện trên bo mạch đã lắp ráp.
-
Trong vùng Models của Trình chỉnh sửa linh kiện, thêm liên kết đến các mô hình theo miền đã lưu (hoặc được tạo ngay trong quá trình thao tác) để linh kiện sử dụng. Một linh kiện có thể có một ký hiệu nguyên lý và nhiều mô hình footprint PCB và mô phỏng, hoặc có một mô hình đấu dây bộ dây điện. Linh kiện phải có ít nhất một mô hình.
-
Kiểm tra linh kiện đã xác định để đảm bảo linh kiện đáp ứng các yêu cầu theo thiết lập trên trang Data Management – Component Rule Checks của hộp thoại Preferences. Lưu linh kiện vào máy cục bộ (File » Save), sau đó chọn lệnh Tools » Component Rule Check từ các menu chính. Mọi vi phạm được phát hiện sẽ được liệt kê trong bảng Messages.
-
Sau khi xác định xong linh kiện, chọn lệnh File » Save to Server từ các menu chính để lưu linh kiện vào Workspace. Hộp thoại Edit Revision sẽ xuất hiện, trong đó bạn có thể thay đổi Tên và Mô tả, đồng thời thêm ghi chú phát hành nếu cần. Trình chỉnh sửa sẽ đóng sau khi lưu.
Bạn có thể tìm và làm việc với linh kiện mới thông qua bảng Components.
Lưu ý
-
Để tạo linh kiện mới tương tự một linh kiện hiện có trong Workspace, bạn có thể tạo bản sao của linh kiện đó. Trong bảng Components, tìm đến linh kiện cần thiết, nhấp chuột phải vào linh kiện và chọn lệnh Operations » Make a copy. Trình chỉnh sửa linh kiện sẽ mở ra với linh kiện được xác định sẵn bằng dữ liệu từ linh kiện đã chọn.
-
Có thể định nghĩa linh kiện bằng dữ liệu do chức năng Manufacturer Part Search cung cấp. Bắt đầu nhập vào trường Name và chọn một mã linh kiện phù hợp của nhà sản xuất hoặc thêm một lựa chọn linh kiện vào linh kiện đang được định nghĩa. Hộp thoại Use Component Data sẽ mở ra, cung cấp các tùy chọn để chọn dữ liệu bạn muốn áp dụng cho linh kiện đang được tạo/chỉnh sửa: tên, mô tả, tham số, mô hình và bảng dữ liệu.

Có thể lấy dữ liệu linh kiện từ chức năng tìm kiếm linh kiện của nhà sản xuất. Ví dụ minh họa ở đây cho thấy cách truy cập chức năng này bằng cách nhập tên linh kiện vào trường Name rồi chọn một mục phù hợp từ danh sách bật lên. -
Trình chỉnh sửa linh kiện cũng có thể hoạt động ở chế độ chỉnh sửa linh kiện hàng loạt, cung cấp giao diện để định nghĩa/chỉnh sửa nhiều linh kiện. Khi trình chỉnh sửa linh kiện đang ở chế độ Single Component Editing, hãy truy cập chế độ chỉnh sửa hàng loạt bằng cách chọn lệnh Tools » Switch to Batch Editor từ các menu chính của trình chỉnh sửa.
-
Để nhập nhanh các thư viện dựa trên tệp và thư viện cơ sở dữ liệu hiện có (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) vào Workspace, bạn có thể sử dụng Library Importer. Library Importer cung cấp giải pháp chỉ với một cú nhấp chuột, tự động phân tích các thư viện đã chọn và nhập chúng vào Workspace mà bạn đang kết nối.
-
Bạn cũng có thể tạo linh kiện mới bằng cách nhấp chuột phải vào mục của Workspace đang kết nối trong bảng Projects và chọn lệnh Create Component từ menu.
-
Để chỉnh sửa một linh kiện Workspace, hãy nhấp chuột phải vào mục của linh kiện trong bảng Components và chọn lệnh Edit từ menu ngữ cảnh. Trình chỉnh sửa linh kiện sẽ mở ở chế độ Single Component Editing, với định nghĩa linh kiện được mở để chỉnh sửa. Thực hiện các thay đổi cần thiết, sau đó lưu định nghĩa linh kiện vào bản sửa đổi tiếp theo của linh kiện Workspace.
-
Tương tự, bạn có thể chọn nhiều linh kiện trong bảng Components và chọn lệnh Edit từ menu ngữ cảnh. Nếu các linh kiện được chọn tham chiếu đến cùng một mẫu linh kiện, một cửa sổ trình chỉnh sửa linh kiện duy nhất sẽ mở ở chế độ chỉnh sửa linh kiện hàng loạt. Nếu không, một cửa sổ trình chỉnh sửa linh kiện riêng sẽ mở cho từng nhóm linh kiện dùng chung một mẫu linh kiện.
-
Các linh kiện Workspace được mở để chỉnh sửa sẽ hiển thị bên dưới mục Workspace Components trong bảng Projects.
Từ menu ngữ cảnh khi nhấp chuột phải vào mục Workspace Component, bạn có thể mở các linh kiện trong nhóm, đóng, lưu cục bộ, lưu vào Workspace đang kết nối hoặc hủy bỏ thay đổi (đóng mà không lưu thay đổi)
. Khi sử dụng lệnh Close All và có nhiều linh kiện trong nhóm đã được sửa đổi, một hộp thoại xác nhận lưu sẽ xuất hiện, với các lựa chọn phù hợp khi làm việc với một đối tượng Workspace đã được mở để chỉnh sửa
-
Khi bạn mở một linh kiện Workspace để chỉnh sửa bằng tài khoản chỉ có quyền xem, trình chỉnh sửa linh kiện sẽ mở và cho phép bạn truy cập thông tin chi tiết của linh kiện, nhưng không thể lưu bất kỳ thay đổi nào vào Workspace. Trong trường hợp này, mục của linh kiện Workspace này trong bảng Projects sẽ hiển thị với nhãn Local Edits Only
-
Khi lưu một linh kiện đã chỉnh sửa vào thư viện Workspace, bạn có thể giữ nguyên trạng thái vòng đời hiện tại của linh kiện. Bạn có thể kiểm soát việc này bằng tùy chọn Preserve lifecycle state (not recommended) có trong hộp thoại Edit Revision khi lưu lại (xem hình ảnh). Khi tùy chọn này được bật, bản sửa đổi mới của linh kiện sẽ tự động được đặt về trạng thái vòng đời của bản sửa đổi trước đó. Khả năng này dành cho những người được cấp quyền thao tác Allow to skip lifecycle state change for new revisions (tìm hiểu thêm về Thiết lập quyền thao tác toàn cục cho Workspace).
Thư viện cơ sở dữ liệu
Altium Designer cho phép đặt linh kiện trực tiếp từ cơ sở dữ liệu của công ty bằng cách tạo và sử dụng Database Library. Việc đặt linh kiện được thực hiện từ bảng Components; sau khi cài đặt thư viện cơ sở dữ liệu, bảng này đóng vai trò là trình duyệt cơ sở dữ liệu của bạn.
Sau khi đặt linh kiện, thông tin tham số thiết kế có thể được đồng bộ hóa giữa các linh kiện đã đặt và các bản ghi liên kết tương ứng trong cơ sở dữ liệu. Bạn có thể cập nhật toàn bộ linh kiện – bao gồm ký hiệu đồ họa, các tham chiếu mô hình và tham số. Thông tin tham số từ cơ sở dữ liệu cũng có thể được đưa vào bảng kê vật tư (BOM) cuối cùng, sẵn sàng cho việc mua sắm linh kiện.
Đọc thêm về Thư viện cơ sở dữ liệu.
Thư viện dựa trên tệp
Nếu cần lưu giữ linh kiện cục bộ trên hệ thống tệp của mình, bạn có thể tổ chức các linh kiện thành các thư viện dựa trên tệp.
Thư viện dựa trên tệp của Altium Designer là một tập hợp tùy ý các mô hình hoặc linh kiện. Cách tổ chức các mô hình hoặc linh kiện thành thư viện là do bạn quyết định. Bạn có thể tổ chức thư viện theo nhà cung cấp thiết bị hoặc nhóm các linh kiện theo chức năng, chẳng hạn như tạo một thư viện cho tất cả các vi điều khiển mà công ty bạn sử dụng.
Ký hiệu linh kiện trên sơ đồ nguyên lý được tạo trong các thư viện sơ đồ nguyên lý (*.SchLib). Sau đó, các linh kiện trong những thư viện này tham chiếu đến footprint và các mô hình khác được định nghĩa trong các thư viện footprint riêng biệt (*.PcbLib) và các tệp mô hình. Là người thiết kế, bạn có thể đặt linh kiện từ các thư viện linh kiện riêng lẻ này hoặc biên dịch các thư viện ký hiệu, thư viện footprint và tệp mô hình thành thư viện tích hợp (*.IntLib).
Đọc thêm về Thư viện linh kiện dựa trên tệp.
Mô hình
Từ góc nhìn của người thiết kế, một linh kiện tập hợp tất cả thông tin cần thiết để biểu diễn linh kiện đó trên mọi miền thiết kế vào một đối tượng duy nhất. Vì vậy, về khía cạnh này, có thể xem linh kiện như một vùng chứa.
Mỗi linh kiện là một tập hợp các mô hình được liên kết và dữ liệu tham số linh kiện. Chính các mô hình chứa thông tin chi tiết cần thiết cho từng miền thiết kế.
Có thể sử dụng các loại mô hình sau:
| Ký hiệu sơ đồ nguyên lý | Ký hiệu biểu diễn linh kiện trên trang sơ đồ nguyên lý. Ký hiệu được tạo bằng các đối tượng vẽ tiêu chuẩn, còn các chân bổ sung các thuộc tính điện. |
| Mô hình SPICE | Mô phỏng hoạt động của các linh kiện được kết nối bằng trình mô phỏng SPICE. Các mô hình SPICE thường được lấy từ nhà cung cấp thiết bị. |
| Mô hình toàn vẹn tín hiệu | Các đường kết nối trên PCB đang trở thành một phần của mạch khi tốc độ chuyển mạch của thiết bị và mạch tăng lên. Các mô hình IBIS mô tả đặc tính hoạt động của chân, cho phép trình mô phỏng toàn vẹn tín hiệu của Altium Designer phân tích các đường mạch. |
| Footprint PCB | Mỗi linh kiện cần được xác định một vị trí trên PCB để gắn và kết nối – footprint là mô hình xác định vùng không gian đó trên PCB. Footprint PCB được tạo từ một tập hợp các đối tượng tiêu chuẩn, trong đó các pad đảm nhiệm việc kết nối. |
| Mô hình 3D | Các sản phẩm điện tử ngày nay có kích thước nhỏ gọn, linh kiện bố trí dày đặc, hình dạng khác biệt và thậm chí có thể sử dụng PCB được gập lại để vừa với vỏ máy. Để thiết kế một sản phẩm như vậy, bạn cần có khả năng mô hình hóa PCB trong không gian 3D – nhờ đó có thể hình dung bo mạch hoàn thiện, kiểm tra khoảng hở 3D và chuyển bo mạch đã gắn linh kiện sang môi trường CAD cơ khí. Để làm được điều này, bạn sẽ cần mô hình 3D của từng linh kiện. |
Tìm hiểu cách tạo và quản lý Ký hiệu, Mô hình footprint, Mô hình mô phỏng và Mô hình 3D trong Workspace của bạn.
Bảng Components
Bảng Components cho phép truy cập trực tiếp vào tất cả các linh kiện có sẵn trong Altium Designer, bao gồm linh kiện trong Workspace, thư viện cơ sở dữ liệu và thư viện dựa trên tệp.
Bảng này lấy linh kiện từ Workspace và mọi tệp thư viện đang mở hoặc đã được cài đặt. Bảng cung cấp thông tin chi tiết đầy đủ về linh kiện được chọn (tham số, mô hình, lựa chọn mã linh kiện, dữ liệu nhà cung cấp, v.v.), chức năng so sánh linh kiện và khả năng tìm kiếm theo tham số dựa trên bộ lọc để xác định các tham số linh kiện mong muốn đối với linh kiện trong Workspace. Dựa trên các bộ lọc động theo ngữ cảnh, khả năng tìm kiếm của bảng cho phép bạn nhanh chóng tìm thấy chính xác linh kiện cần dùng trong Workspace được kết nối của công ty.
Tìm hiểu về bảng Components.
Bảng Manufacturer Part Search
Bạn cũng có thể tìm kiếm các linh kiện được sản xuất thực tế bằng bảng Manufacturer Part Search, sử dụng chức năng công cụ tìm kiếm cơ bản và chế độ xem được áp dụng trong bảng Components. Một linh kiện của nhà sản xuất được chọn có thể dùng làm cơ sở để tạo linh kiện mới trong Workspace được kết nối của bạn, hoặc bạn có thể thêm các tham số và bảng dữ liệu của linh kiện đó vào một linh kiện đã được đặt.
Biểu tượng
trong một mục linh kiện cho biết linh kiện này đã được gán các mô hình (ký hiệu sơ đồ nguyên lý, footprint PCB, mô hình mô phỏng). Khi tạo linh kiện mới dựa trên linh kiện của nhà sản xuất này, các mô hình đi kèm cũng sẽ được lấy về. Ngoài ra, bạn có thể tải linh kiện này về máy hoặc đặt trực tiếp vào sơ đồ nguyên lý.
Tìm hiểu về bảng Manufacturer Part Search.
Tiếp theo là gì?
Tạo linh kiện đấu dây bộ dây dẫn



).
).



