Điều hướng trong tài liệu

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Khi làm việc với tài liệu đồ họa, chẳng hạn như trang sơ đồ nguyên lý, tài liệu PCB hoặc tài liệu Draftsman, bạn có thể thu phóng và di chuyển khung nhìn để tập trung vào một vùng cụ thể của tài liệu. Các phím tắt cơ bản có thể dùng để thực hiện việc này gồm:

  • Ctrl+Mouse Wheel để phóng to và thu nhỏ
  • Right-Click, Hold&Drag để di chuyển tài liệu trong khung nhìn

Menu chính View có một số lệnh dùng để điều khiển khung nhìn của tài liệu hiện tại.

Sử dụng các lệnh trong menu chính View để điều khiển khung nhìn của tài liệu. Hình trên hiển thị menu View của trình chỉnh sửa sơ đồ nguyên lý. Hình dưới hiển thị menu View của trình chỉnh sửa PCB.

Sử dụng các lệnh trong menu chính View để điều khiển khung nhìn của tài liệu. Hình trên hiển thị menu View của trình chỉnh sửa sơ đồ nguyên lý. Hình dưới hiển thị menu View của trình chỉnh sửa PCB.

Các lệnh này gồm:

  • Fit Document - hiển thị toàn bộ vùng của tài liệu hiện tại.

  • Fit All Objects - hiển thị tất cả đối tượng thiết kế trên tài liệu hiện tại.

  • Area - phóng to một vùng do người dùng xác định trong tài liệu hiện tại.

  • Around Point - xác định lại vùng hiển thị quanh một điểm được chỉ định trong tài liệu hiện tại.

  • Selected Objects - thay đổi khung nhìn trong không gian thiết kế để tất cả đối tượng được chọn đều hiển thị.

  • Zoom In - phóng to thiết kế trong tài liệu hiện tại, lấy vị trí con trỏ làm mốc.

  • Zoom Out - thu nhỏ thiết kế trong tài liệu hiện tại, lấy vị trí con trỏ làm mốc.

  • Zoom Last - đưa màn hình trở về khung nhìn trước đó trong tài liệu hiện tại.

Bạn cũng có thể dùng phím tắt Z để truy cập menu bật lên chứa các lệnh thu phóng.

Trong trình chỉnh sửa PCB và footprint PCB, menu này cho phép bạn truy cập lệnh Select để mở hộp thoại Zoom Value (0.001x..4x), nơi bạn có thể thay đổi độ phóng đại hiển thị của tài liệu hiện tại theo một giá trị cụ thể. Nhập giá trị lớn hơn 1 để phóng to hơn nữa (tăng độ phóng đại). Dùng giá trị nhỏ hơn 1 để thu nhỏ hơn nữa (giảm độ phóng đại).

Hộp thoại Zoom Value
Hộp thoại Zoom Value

Khi xem tài liệu PCB hoặc footprint PCB ở chế độ 3D, bạn có thể sử dụng thêm các lệnh, phím tắt và công cụ điều khiển để điều hướng khung nhìn một cách mượt mà. Tham khảo trang Điều khiển khung nhìn 3D để tìm hiểu thêm.

Chuyển đến một điểm cụ thể trong tài liệu

Sử dụng các lệnh trong menu con Edit » Jump thuộc menu chính của trình chỉnh sửa sơ đồ nguyên lý, ký hiệu sơ đồ nguyên lý, PCB hoặc footprint PCB, bạn có thể chuyển đến một điểm cụ thể trong tài liệu đang hoạt động. Bạn cũng có thể truy cập menu bật lên Jump bằng cách nhấn phím J trong không gian thiết kế. Ví dụ, bạn có thể chuyển đến:

  • tọa độ gốc của tài liệu:
    • điểm gốc của trang sơ đồ nguyên lý (tương ứng với góc dưới bên trái) - Origin;

    • gốc tọa độ tuyệt đối của tài liệu PCB - Absolute Origin;

    • gốc tọa độ tương đối của tài liệu PCB hiện tại - Current Origin;

    • vị trí điểm tham chiếu của linh kiện trong tài liệu footprint PCB - Reference;

  • bất kỳ vị trí nào trong tài liệu hiện tại, dựa trên tọa độ XY do người dùng chỉ định - chọn lệnh New Location để nhập giá trị tọa độ X và Y trong không gian thiết kế cho vị trí bạn muốn con trỏ chuyển đến, trong hộp thoại Jump To Location xuất hiện. Trong trình chỉnh sửa PCB, bạn cũng có thể dùng các trường Delta X và Delta Y để chỉ định độ lệch tọa độ X và Y cho vị trí cần chuyển đến.

    Hộp thoại Jump To Location - trong trình chỉnh sửa sơ đồ nguyên lý (hình thứ nhất) và trình chỉnh sửa PCB (hình thứ hai)
    Hộp thoại Jump To Location - trong trình chỉnh sửa sơ đồ nguyên lý (hình thứ nhất) và trình chỉnh sửa PCB (hình thứ hai)

  • một đối tượng trong tài liệu. Sử dụng các lệnh sau để chuyển đến đối tượng bạn quan tâm:
    • một linh kiện trên trang sơ đồ nguyên lý - Jump Component. Sau khi thực thi lệnh, hộp thoại Component Designator sẽ xuất hiện. Nhập định danh của linh kiện bạn muốn chuyển đến. Nếu định danh hợp lệ và linh kiện tồn tại trong một tài liệu sơ đồ nguyên lý nguồn thuộc dự án đang hoạt động, tài liệu sơ đồ nguyên lý tương ứng sẽ trở thành tài liệu đang hoạt động, đồng thời linh kiện đích sẽ được phóng to và đưa vào giữa không gian thiết kế (nếu có thể). Linh kiện tìm được (hoặc tất cả các phần của linh kiện nhiều phần) cũng được liệt kê trong bảng Messages . Nhấp đúp vào một mục thông báo để chuyển đến linh kiện đó (hoặc phần tương ứng của linh kiện) trong không gian thiết kế.

      Hộp thoại Component Designator
      Hộp thoại Component Designator

      Khi tìm đến một linh kiện nhiều phần, chỉ nhập định danh gốc. Không thêm hậu tố của phần. Ví dụ, để chuyển đến một linh kiện IC gồm 2 phần có định danh là IC1_CPA và IC1_CPB, hãy nhập IC1_CP vào hộp thoại Component Designator. Đối với linh kiện nhiều phần, phần đầu tiên sẽ được tô sáng và hộp thoại Find Text - Jump sẽ mở ra. Sử dụng hộp thoại này để chuyển giữa các phần của linh kiện.
      Bật tùy chọn Physical trong hộp thoại Component Designator để giới hạn tính năng chuyển đến chỉ áp dụng cho định danh linh kiện vật lý - những định danh xuất hiện trên các khung nhìn dạng tab Compiled Document của tài liệu sơ đồ nguyên lý nguồn. Khi tắt tùy chọn này, tính năng chuyển đến sẽ chỉ xét các định danh logic - những định danh xuất hiện trên các khung nhìn dạng tab Editor của tài liệu sơ đồ nguyên lý nguồn.
    • một linh kiện cụ thể trong tài liệu PCB - Component. Sau khi thực thi lệnh, hộp thoại Component Designator sẽ xuất hiện. Nhập định danh linh kiện để chuyển đến linh kiện đó. Nếu không chắc về định danh, hãy nhập ? rồi nhấp OK để mở hộp thoại Components Placed, trong đó liệt kê tất cả linh kiện trong thiết kế. Nhập văn bản vào trường Mask để tìm linh kiện mong muốn. Khi bạn nhập, danh sách sẽ được lọc để chỉ hiển thị các chuỗi khớp với chuỗi mẫu lọc. Bạn có thể dùng các ký tự đại diện ? (bất kỳ một ký tự nào) và * (bất kỳ chuỗi ký tự nào) trong chuỗi. Con trỏ sẽ chuyển đến điểm tham chiếu của linh kiện bạn chọn.

      Nhập ? trong hộp thoại Component Designator để truy cập hộp thoại Components Placed liệt kê tất cả linh kiện trong PCB.
      Nhập ? trong hộp thoại Component Designator để truy cập hộp thoại Components Placed liệt kê tất cả linh kiện trong PCB.

    • một net cụ thể trong tài liệu PCB - Net. Sau khi thực thi lệnh, hộp thoại Net Name sẽ xuất hiện. Nhập tên net bạn muốn chuyển đến, hoặc nhập ? rồi nhấn OK để mở hộp thoại Nets Loaded, trong đó chứa danh sách tất cả net đã được tải của thiết kế. Nhập văn bản vào trường Mask để tìm net mong muốn. Khi bạn nhập, danh sách sẽ được lọc để chỉ hiển thị các chuỗi khớp với chuỗi mẫu lọc. Bạn có thể dùng các ký tự đại diện ? (bất kỳ một ký tự nào) và * (bất kỳ chuỗi ký tự nào) trong chuỗi mẫu lọc. Nếu net đích đã hiển thị trong cửa sổ thiết kế chính, con trỏ sẽ chuyển đến đối tượng thiết kế gần nhất thuộc net đó. Nếu net nằm ngoài khung nhìn, con trỏ sẽ được đặt tại đối tượng thiết kế gần nhất thuộc net đó, đồng thời vị trí này sẽ được đưa vào giữa không gian thiết kế (nếu có thể).

      Nhập ? trong hộp thoại Net Name để truy cập hộp thoại Nets Loaded liệt kê tất cả net trong PCB.Nhập ? trong hộp thoại Net Name để truy cập hộp thoại Nets Loaded liệt kê tất cả net trong PCB.

    • một pad cụ thể của linh kiện trong tài liệu PCB - Pad. Sau khi khởi chạy lệnh, hộp thoại Jump To Pad Number sẽ xuất hiện. Nhập pad cần tìm của linh kiện mong muốn theo định dạng ComponentDesignator-PadDesignator (ví dụ: U1-6) rồi nhấp vào OK. Nếu pad đích đã hiển thị trong không gian thiết kế, con trỏ sẽ nhảy thẳng đến tâm của pad đó. Nếu pad nằm ngoài vùng hiển thị, con trỏ sẽ được đặt tại tâm pad và vị trí này sẽ được đưa vào giữa không gian thiết kế (nếu có thể).

      Hộp thoại Jump To Pad Number
      Hộp thoại Jump To Pad Number

    • một chuỗi ký tự cụ thể trong tài liệu PCB - String. Sau khi khởi chạy lệnh, hộp thoại Jump To String sẽ xuất hiện. Nhập chuỗi ký tự mà bạn muốn nhảy đến, hoặc nhập ? rồi nhấp vào OK để mở hộp thoại Strings, chứa danh sách tất cả các chuỗi ký tự có trong tài liệu bo mạch đang hoạt động (các chuỗi độc lập và các chuỗi là đối tượng con của những đối tượng nhóm khác). Sử dụng hộp thoại này để nhanh chóng tìm chuỗi ký tự mà bạn muốn nhảy đến. Nếu chuỗi đích đã hiển thị trong không gian thiết kế, con trỏ sẽ nhảy thẳng đến điểm neo của chuỗi — điểm dùng để giữ chuỗi khi di chuyển hoặc làm tâm xoay. Nếu chuỗi nằm ngoài vùng hiển thị, con trỏ sẽ được đặt tại điểm neo của chuỗi và vị trí này sẽ được đưa vào giữa không gian thiết kế (nếu có thể).

      Nhập ? trong hộp thoại Jump To String để truy cập hộp thoại Strings liệt kê tất cả các net trong PCB.
      Nhập ? trong hộp thoại Jump To String để truy cập hộp thoại Strings liệt kê tất cả các net trong PCB.

      Hệ thống sẽ thực hiện ba lượt tìm kiếm: trước tiên tìm chuỗi khớp với chuỗi đã chỉ định về chữ hoa/chữ thường, ký tự và độ dài; tiếp theo tìm chuỗi chứa cùng các ký tự nhưng có thể có thêm ký tự; và cuối cùng tìm chuỗi chứa cùng các ký tự, không phân biệt chữ hoa/chữ thường.

    • nhảy đến và lần lượt duyệt qua tất cả các dấu đánh dấu lỗi trong tài liệu thiết kế hiện tại - Error Marker. Sau khi khởi chạy lệnh, con trỏ sẽ nhảy đến dấu đánh dấu lỗi Kiểm tra quy tắc thiết kế (DRC) đầu tiên, được đưa vào giữa cửa sổ thiết kế chính. Sử dụng lệnh nhiều lần sẽ lần lượt nhảy đến dấu đánh dấu lỗi thứ hai, rồi các dấu tiếp theo. Lệnh này sẽ nhảy đến dấu đánh dấu lỗi bất kể vi phạm có được miễn trừ hay không.

      Kiểm tra các vi phạm liên quan đến đối tượng dưới con trỏ bằng cách nhấp chuột phải và chọn lệnh tương ứng từ menu con Violations .

  • nhảy đến và lần lượt duyệt qua tất cả các đối tượng thiết kế đang được chọn trong tài liệu hiện tại - Selection. Sau khi khởi chạy lệnh, con trỏ sẽ nhảy đến đối tượng được chọn đầu tiên; đối tượng này sẽ được phóng to và đưa vào giữa cửa sổ thiết kế chính. Sử dụng lệnh nhiều lần sẽ nhảy đến đối tượng được chọn thứ hai, rồi các đối tượng tiếp theo, lần lượt duyệt qua tất cả các đối tượng đang được chọn trong tài liệu hiện tại. Lệnh duyệt qua các đối tượng theo thứ tự chúng được thêm vào tập hợp lựa chọn ban đầu.

  • một vị trí trong tài liệu sơ đồ nguyên lý hoặc PCB hiện tại, có tọa độ đã được lưu trước đó trong dấu đánh dấu vị trí được chỉ định - chọn lệnh Location Marks » n để nhảy đến vị trí đã được lưu trong dấu đánh dấu vị trí được chỉ định bằng lệnh Set Location Marks » n.

    Đối với tài liệu sơ đồ nguyên lý, vị trí đã lưu chỉ khả dụng khi tài liệu vẫn đang mở (dù đang hoạt động hay không). Nếu đóng tài liệu rồi mở lại, dấu đánh dấu vị trí sẽ trống. Đối với tài liệu PCB, các dấu đánh dấu vị trí được lưu cùng thiết kế, vì vậy vẫn có thể truy cập các vị trí do người dùng xác định trong những dấu này giữa các phiên thiết kế.
AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.