Erstellen eines Simulationsmodells
Auf einen Blick
- Wie Simulationsmodelle erstellt oder beschafft werden, etwa durch heruntergeladene Herstellerdateien, kopierte textbasierte Modelle und manuell geschriebene Teilschaltungsdateien.
- Wie Sie Simulationsmodelle in Altium Designer und einem verbundenen Workspace erstellen, speichern, verknüpfen und bearbeiten.
- Welche Informationen erforderlich sind, um ein Simulationsmodell korrekt zu definieren, einschließlich Modellnamen, referenzierter Dateien und Parameter auf Modellebene.
Um einen Schaltungsentwurf mit dem Mixed-Signal-Schaltungssimulator von Altium Designer zu simulieren, müssen alle Bauteile in der Schaltung simulationsbereit sein – das heißt, mit jedem Bauteil muss ein Simulationsmodell verknüpft sein.
Die Art des Modells und seine Beschaffung hängen weitgehend vom Bauteil und bis zu einem gewissen Grad auch von den persönlichen Vorlieben des Entwicklers ab. Viele Bauteilhersteller stellen Simulationsmodelle für ihre Bauteile bereit. In der Regel müssen Sie lediglich die benötigte Modelldatei herunterladen und mit dem Schaltplanbauteil verknüpfen. Erfahren Sie mehr über das Hinzufügen von Simulationsmodellen zum Design.
Manche Modelle müssen unter Umständen von Grund auf neu erstellt werden – beispielsweise mithilfe der hierarchischen Teilschaltungssyntax, um die erforderliche Teilschaltungsmodelldatei (*.ckt) zu erstellen.
Erstellen eines neuen Simulationsmodells
Einige Modelle werden von Herstellern und Lieferanten als herunterladbare Textdateien bereitgestellt. Manchmal werden die Modelldaten statt als Download-Datei als Text auf einer Webseite angezeigt. In diesem Fall können Sie in Altium Designer eine neue Modelldatei erstellen und den Inhalt der Webseite in diese kopieren und einfügen. Verwenden Sie dazu den entsprechenden Befehl im Untermenü File » New » Mixed Simulation, wie unten gezeigt.

Befehle zum Erstellen einer neuen, leeren Modelldatei.
Anschließend können Sie die Informationen aus der Modelldatei kopieren und in den Modelleditor einfügen.

Beispiel für den Textinhalt eines Simulationsmodells.
Erstellen eines Workspace-Simulationsmodells
Altium Designer bietet in Verbindung mit einem verbundenen Workspace die Möglichkeit, Workspace-Simulationsmodelle zu erstellen und zu verwalten. Sobald ein Workspace-Simulationsmodell erstellt wurde, kann es zum Erstellen eines oder mehrerer Workspace-Bauteile verwendet werden.
Workspace-Simulationsmodelle werden automatisch erstellt, wenn Sie einem Bauteil, das im Component Editor im Einzelbauteil-Bearbeitungsmodus definiert wird, eine Simulationsmodelldatei hinzufügen und das Bauteil anschließend in Ihrem Workspace speichern. Sie können Workspace-Simulationsmodelle jedoch auch direkt im Workspace erstellen, wie nachfolgend beschrieben.
-
Öffnen Sie das Panel Components und blenden Sie die Modelle ein, indem Sie oben im Panel auf die Schaltfläche
klicken und Models auswählen.
-
Navigieren Sie zur Kategorie Simulations und wählen Sie Create Component aus dem Menü der Schaltfläche
aus.

Navigieren Sie im Panel Components zu den Simulationsmodellen und wählen Sie den Befehl zum Erstellen eines neuen Modells aus. -
Geben Sie im daraufhin geöffneten Dialogfeld Create New Item die erforderlichen Informationen ein, stellen Sie sicher, dass die Option Open for editing after creation aktiviert ist, und klicken Sie auf OK. Das Workspace-Simulationsmodell wird erstellt und der temporäre SimModel-Editor wird geöffnet. Dabei wird ein
.SimModelDokument als aktives Dokument im Designbereich angezeigt. Dieses Dokument wird entsprechend der Elementrevision im folgenden Format benannt:<Item><Revision>.SimModel(z. B.SIM-001-0001-1.SimModel).
Beispiel für die Bearbeitung der ersten Revision eines Workspace-Simulationsmodells – der temporäre SimModel-Editor stellt das Dokument bereit, mit dem Sie Ihr Simulationsmodell definieren. - Verwenden Sie das Dokument, um das Workspace-Simulationsmodell nach Bedarf zu definieren. Weitere Informationen hierzu finden Sie unter Definieren des Simulationsmodells.
- Speichern Sie das Modell im Workspace mithilfe des Bedienelements Save to Server rechts neben dem Eintrag des Simulationsmodells im Panel Projects. Das Dialogfeld Edit Revision wird angezeigt. Darin können Sie den Namen und die Beschreibung ändern sowie bei Bedarf Freigabehinweise hinzufügen. Nach dem Speichern werden das Dokument und der Editor geschlossen.
-
Das Dokument mit der Quelldefinition des Simulationsmodells,
*.SimModel, wird in der Revision des Workspace-Simulationsmodells gespeichert. Das Simulationsmodell wird im Panel Components in der Kategorie Simulations angezeigt.
Ein gespeichertes Workspace-Simulationsmodell im Panel ComponentsDie im Workspace gespeicherten Daten umfassen die Modelldefinition in der Datei
.SimModelsowie alle referenzierten.mdl- oder.ckt-Dateien. Wechseln Sie im Explorer-Panel zur Registerkarte der Aspektansicht Preview und klicken Sie dann auf eine referenzierte Datei, um eine Vorschau ihres Inhalts anzuzeigen. Gegebenenfalls werden auch Parameter auf Modellebene angezeigt.
Sehen Sie sich das gespeicherte Workspace-Simulationsmodell im Panel Explorer an. Wechseln Sie zur Registerkarte der Aspektansicht Preview, um die gespeicherten Daten anzuzeigen.
Ein gespeichertes Workspace-Simulationsmodell kann anschließend mit einem Workspace-Bauteil verknüpft werden, wenn Sie das Bauteil im Component Editor im Modus Einzelbauteilbearbeitung oder Stapelbearbeitung von Bauteilen definieren.
Definieren des Simulationsmodells
Zum Definieren des Modells in einer SimModel-Datei sind die folgenden Informationen erforderlich:
-
Model Name – verwenden Sie dieses Feld, um den Namen des Modells anzugeben. Beim Zurückspeichern in den Workspace wird dieser Eintrag als Name der Revision des Simulationsmodell-Items verwendet.
Bei der Referenzierung einer MDL-Datei muss der Name dem Namen in der Zeile
.MODELder Modelldefinition entsprechen. Betrachten Sie ein Diodenmodell mit der folgenden Definition:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )Der Modellname lautet hier
1N4002. Dieser Name muss in das Feld Model Name eingegeben werden.Bei der Referenzierung einer CKT-Datei muss der Name dem Namen in der Zeile
.SUBCKTder Modelldefinition entsprechen. Betrachten Sie ein Sicherungsmodell mit der folgenden Definition:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSEDer Modellname lautet hier
FUSE. Dieser Name muss in das Feld Model Name eingegeben werden. -
Model File – bei einem Modell, das mithilfe einer
.mdl- oder.ckt-Datei definiert wurde, verwenden Sie die Schaltfläche Browse, um die benötigte Datei aus einer verfügbaren Bibliothek auszuwählen. - Description – geben Sie eine Beschreibung des Modells ein, beispielsweise seinen Zweck. Beim Zurückspeichern in den Workspace wird dieser Eintrag als Description der Simulationsmodellrevision verwendet.
- Parameters – Parameter auf Modellebene für das Modell (siehe Parameter auf Modellebene).
-
Model Preview – schreibgeschützte Anzeige des Inhalts der referenzierten
.mdl- oder.ckt-Datei.
Parameter auf Modellebene
Sofern zutreffend, können Parameter auf Modellebene direkt in der SimModel-Datei definiert werden, da sie Bestandteil der Modelldefinition sind. Der Bereich Parameters des Dokuments wird automatisch mit den für das gewählte Modell relevanten Parametern gefüllt. Parameterwerte können direkt bearbeitet werden – klicken Sie in der Liste auf das zu einem Parameter gehörende Feld Parameter Value und geben Sie den gewünschten Wert direkt ein.

Definieren Sie Parameter für das Modell als Teil seiner Definition – durch direkte Bearbeitung.
Bearbeiten eines Workspace-Simulationsmodells
Sie können jederzeit zu einem beliebigen Workspace-Simulationsmodell zurückkehren und es direkt bearbeiten. Wählen Sie die Kategorie Simulations im Components-Panel aus (die Option Models muss im Menü
des Panels aktiviert sein, damit diese Kategorie zugänglich ist), klicken Sie mit der rechten Maustaste auf den Eintrag eines Simulationsmodells und wählen Sie im Kontextmenü den Befehl Edit aus. Der temporäre Editor wird erneut geöffnet. Dabei wird die im Workspace-Simulationsmodell enthaltene Datei mit der Quelldefinition des Simulationsmodells zur Bearbeitung geöffnet. Nehmen Sie die gewünschten Änderungen vor und speichern Sie das Dokument anschließend in der nächsten Revision des Workspace-Simulationsmodells.
Erzeugen von SimModel-Dateien
SimModel-Dateien können mit dem Befehl Tools » Generate SimModel Files aus dem aktiven Schaltplanbibliotheks- oder Datenbankbibliotheksdokument erzeugt werden.
Nach dem Aufrufen des Befehls wird das Dialogfeld Generate SimModel Files angezeigt. Jede SimModel-Datei samt der enthaltenen Simulationsmodelldefinition wird auf Grundlage der Simulationsmodellverknüpfung eines Schaltplanbauteils in der aktiven Schaltplanbibliothek erstellt (bzw. anhand der Simulationsinformationen eines Bauteildatensatzes in der aktiven Datenbankbibliothek). Verwenden Sie die Bedienelemente im Dialogfeld, um die Erzeugung einer oder mehrerer SimModel-Dateien nach Bedarf zu konfigurieren. Standardmäßig wird ein Unterordner mit dem Namen Sim Models erstellt. Ändern Sie diesen Namen bei Bedarf in einen geeigneteren Namen. Wenn der angegebene Ordner bereits vorhanden ist, wird er verwendet; andernfalls wird er erstellt.

Das Dialogfeld Generate SimModel Files
Nachdem Sie die Optionen wie gewünscht festgelegt haben, klicken Sie auf OK. Die Erzeugung wird gestartet. Nach Abschluss des Vorgangs wird ein Bestätigungsdialogfeld angezeigt, das angibt, wie viele SimModel-Dateien erzeugt wurden. Alle referenzierten .mdl-, .ckt- oder .scb-Dateien werden ebenfalls zusammen mit den SimModel-Dateien gespeichert.
Bei der Migration aus einer integrierten Bibliothek können Sie die Quell-Schaltplanbibliotheken (SchLib) erhalten, indem Sie die IntLib in Altium Designer öffnen und die Option zum Extrahieren der Quellbibliotheken wählen. Beim Erzeugen von SimModel-Dateien aus einer Datenbankbibliothek werden nur Bauteile in aktuell aktivierten Tabellen berücksichtigt.
Die Benennung der SimModel-Dateien hängt vom Typ der Quellbibliothek ab:
- Schematic Library – jede SimModel-Datei wird nach dem Namen des Simulationsmodells benannt. Wenn mehrere Schaltplanbauteile dieselbe Simulationsmodellimplementierung enthalten (gleichnamiges Simulationsmodell), wird nur eine einzige SimModel-Datei mit diesem Namen erzeugt.
- Database Library – jede SimModel-Datei wird nach dem Namen des Simulationsmodells benannt, der im Feld Sim Model Name eines Bauteildatensatzes angegeben ist. Wenn mehrere Bauteildatensätze (über aktivierte Tabellen hinweg) dieselbe Simulationsmodellimplementierung enthalten (gleicher Eintrag im Feld Sim Model Name), wird nur eine einzige SimModel-Datei mit diesem Namen erzeugt.
SPICE-Modell-Assistent
Bestimmte in SPICE integrierte Modelle analoger Bauelemente unterstützen eine zugehörige Modelldatei (*.mdl), in der sich erweiterte Verhaltenseigenschaften parametrisch definieren lassen (z. B. Halbleiterwiderstand, Diode, BJT). Diese Modelldatei von Hand zu erstellen und anschließend manuell mit dem gewünschten Schaltplanbauteil zu verknüpfen, kann recht aufwendig sein. Der SPICE Model Wizard erleichtert diese Aufgabe. Mit dem Assistenten lassen sich die Eigenschaften eines solchen Bauelements anhand der vom Benutzer erfassten Daten definieren. Die Parameter – entweder direkt eingegeben oder aus bereitgestellten Daten extrahiert – werden automatisch in eine Modelldatei geschrieben, die anschließend mit dem ausgewählten Schaltplanbauteil verknüpft wird.
Der SPICE Model Wizard bietet eine komfortable, teilautomatisierte Lösung zum Erstellen und Verknüpfen eines SPICE-Simulationsmodells für eine Reihe analoger Bauelemente, die in SPICE integriert sind und eine verknüpfte Modelldatei (*.mdl) benötigen. Die Verhaltenseigenschaften des Modells werden anhand der Informationen definiert, die Sie im Assistenten bereitstellen. Der Umfang dieser Informationen hängt vom Bauelementtyp ab, für den Sie ein Modell erstellen möchten – von der einfachen Eingabe von Modellparametern bis hin zur Eingabe von Bauelementdaten aus einem Herstellerdatenblatt oder aus Messungen am physischen Bauelement.
Die folgenden Abschnitte erläutern die Verwendung des Assistenten – vom Aufrufen bis zur Überprüfung.
Assistenten aufrufen
Der Assistent wird im Schaltplansymboleditor über den Befehl Tools » XSpice Model Wizard in den Hauptmenüs aufgerufen.

Die Startseite des SPICE Model Wizard
Auf den beiden folgenden Seiten des Assistenten können Sie Folgendes auswählen:
- Welches Bauelement Sie aus der Liste der unterstützten Bauelementtypen modellieren möchten.
- Ob das anschließend erzeugte SPICE-Modell einem vorhandenen Bauteil im Bibliotheksdokument oder einem neuen Bauteil hinzugefügt werden soll, das der Assistent erstellt und diesem Dokument hinzufügt.
Unterstützte Bauelementtypen
Mit dem Assistenten lassen sich SPICE-Modelle für die folgenden analogen Bauelementtypen erstellen:
- Diode
- Halbleiterkondensator
- Halbleiterwiderstand
- Stromgesteuerter Schalter
- Spannungsgesteuerter Schalter
- Bipolartransistor
- Verlustbehaftete Übertragungsleitung
- Übertragungsleitung mit gleichmäßig verteilten RC-Parametern
Modell benennen
Einer der wichtigsten Schritte beim Durchlaufen der Seiten des Assistenten ist die Vergabe eines Namens für das zu erstellende Modell. Erst nachdem Sie einen Namen eingegeben haben, können Sie mit der Parameterdefinition im Assistenten fortfahren.
Nach der Erstellung wird dieser Name im Feld Model Name des Dialogs Sim Model angezeigt. Auch die Modelldatei selbst wird unter diesem Namen erstellt (<ModelName>.mdl). Wenn Sie mit dem Assistenten einem neuen Bibliotheksbauteil ein Modell hinzufügen, wird der angegebene Modellname auch als Bauteilname verwendet.
Bei der Benennung des Modells können Sie außerdem eine kurze Beschreibung eingeben. Diese kann die Funktion des Modells (z. B. Semiconductor Resistor) oder einen konkreteren Hinweis auf einen Wert oder eine Konfiguration (z. B. NPN BJT) enthalten.
Zu modellierende Eigenschaften
Nachdem Sie dem Modell einen Namen gegeben haben, gelangen Sie zu einer oder mehreren Seiten, auf denen die zu modellierenden Eigenschaften festgelegt werden. Die vom Assistenten unterstützten Modelltypen lassen sich in die folgenden zwei Gruppen unterteilen:
- Modelle, bei denen die Werte für verschiedene Modellparameter direkt eingegeben werden müssen. Weitere Informationen finden Sie im Abschnitt Durch direkte Parametereingabe erstellte Bauelementmodelle.
- Modelle, bei denen Daten eingegeben werden müssen, aus denen die Parameter zur Definition der gewählten Bauelementeigenschaften extrahiert werden. Die eingegebenen Daten stammen entweder aus direkten Messungen am physischen Bauelement oder aus einem Herstellerdatenblatt. Weitere Informationen finden Sie im Abschnitt Durch Parameterextraktion aus Daten erstellte Bauelementmodelle.
Modell erzeugen
Nachdem Sie die erforderlichen Daten bzw. Parameter definiert haben, zeigt der Assistent das erzeugte Modell an. Dieser Inhalt wird in der MDL-Datei gespeichert.

Vorschau des Inhalts der erzeugten Modelldatei.
Sie können das Modell direkt auf dieser Seite bearbeiten und haben damit die volle Kontrolle über die Modellspezifikation.
Wenn Sie mit der Modelldefinition zufrieden sind, klicken Sie auf Next, um zur letzten Seite des Assistenten zu gelangen. Durch Klicken auf Finish können Sie das Modell speichern. Legen Sie im Dialog Save SPICE Model File fest, wo die erzeugte MDL-Datei gespeichert werden soll. Standardmäßig wird die Datei im selben Verzeichnis wie das Schaltplanbibliotheksdokument gespeichert. Bei Bedarf können Sie an dieser Stelle auch den Dateinamen ändern.
Wenn Sie festgelegt haben, dass das Modell einem neuen Bauteil zugeordnet werden soll, wird dieses Bauteil erstellt und dem Bibliotheksdokument hinzugefügt.
Durch direkte Parametereingabe erstellte Bauelementmodelle
Bei den folgenden Bauelementmodellen extrahiert der Assistent keine Parameterinformationen aus eingegebenen Daten. Stattdessen werden die Modelle durch direkte Eingabe der Werte für die zugehörigen Parameter erstellt. Bei der Eingabe von Parameterwerten sind einige Punkte zu beachten:
- Wenn für einen Parameter kein Wert angegeben wird, enthält die erstellte Modelldatei keinen entsprechenden Eintrag. In diesem Fall wird der intern in SPICE hinterlegte Standardwert verwendet. Anders ausgedrückt: Wird in einer Modelldatei ein Wert für einen Parameter angegeben, überschreibt dieser Wert den Standardwert des Parameters.
- Wenn der Standardeintrag für einen Parameter im Assistenten „-“ lautet und kein Wert für diesen Parameter eingegeben wird, verwendet SPICE intern für Berechnungen den Standardwert null.
Halbleiterkondensator
Die folgenden Parameter lassen sich für dieses Bauelementmodell mit dem Assistenten definieren. Wenn Sie einen Wert eingeben, wird der betreffende Parameter in die erzeugte MDL-Datei geschrieben.
CJ |
Sperrschichtkapazität der Bodenfläche (in F/m²). |
|
CJSW |
Sperrschichtkapazität der Seitenwand (in F/m). |
|
DEFW |
Standardbreite des Bauelements (in Metern). (Standardwert = 1e-6). |
|
NARROW |
Verengung durch seitliches Ätzen (in Metern). (Standardwert = 0). |
Halbleiterwiderstand
Die folgenden Parameter können für dieses Bauteilmodell mit dem Assistenten definiert werden. Wenn Sie einen Wert eingeben, wird der entsprechende Parameter in die generierte MDL-Datei geschrieben.
TC1 |
Temperaturkoeffizient erster Ordnung (in Ohm/˚C). (Standardwert = 0) |
|
TC2 |
Temperaturkoeffizient zweiter Ordnung (in Ohm/˚C²). (Standardwert = 0) |
|
RSH |
Flächenwiderstand (in Ohm). |
|
DEFW |
Standardbreite (in Metern). (Standardwert = 1e-6). |
|
NARROW |
Verengung durch seitliches Unterätzen (in Metern). (Standardwert = 0). |
|
TNOM |
Messtemperatur der Parameter (in ˚C). Wenn kein Wert angegeben wird, wird der Standardwert verwendet, der TNOM auf der Registerkarte Advanced des Dialogfelds Advanced Analyses Settings zugewiesen ist (Standardwert = 27). |
Stromgesteuerter Schalter
Die folgenden Parameter können für dieses Bauteilmodell mit dem Assistenten definiert werden. Wenn Sie einen Wert eingeben, wird der entsprechende Parameter in die generierte MDL-Datei geschrieben.
IT |
Schwellenstrom (in Ampere). (Standardwert = 0). |
|
IH |
Hysteresestrom (in Ampere). (Standardwert = 0). |
|
RON |
Widerstand im eingeschalteten Zustand (in Ohm). (Standardwert = 1). |
|
ROFF |
Widerstand im ausgeschalteten Zustand (in Ohm). Dieser ist standardmäßig auf 1/GMIN eingestellt. GMIN ist ein erweiterter SPICE-Parameter, der auf der Registerkarte Advanced des Dialogfelds Advanced Analyses Settings angegeben wird. Er legt den minimalen Leitwert (maximalen Widerstand) jedes Bauteils in der Schaltung fest. Sein Standardwert beträgt 1e-12 Siemens, woraus sich für ROFF ein Standardwert von 1000 GOhm ergibt. |
Spannungsgesteuerter Schalter
Die folgenden Parameter können für dieses Bauteilmodell mit dem Assistenten definiert werden. Wenn Sie einen Wert eingeben, wird der entsprechende Parameter in die generierte MDL-Datei geschrieben.
VT |
Schwellenspannung (in Volt). (Standardwert = 0). |
|
VH |
Hysteresespannung (in Volt). (Standardwert = 0). |
|
RON |
Widerstand im eingeschalteten Zustand (in Ohm). (Standardwert = 1). |
|
ROFF |
Widerstand im ausgeschalteten Zustand (in Ohm). Dieser ist standardmäßig auf 1/GMIN eingestellt. GMIN ist ein erweiterter SPICE-Parameter, der auf der Registerkarte Advanced des Dialogfelds Advanced Analyses Settings angegeben wird. Er legt den minimalen Leitwert (maximalen Widerstand) jedes Bauteils in der Schaltung fest. Sein Standardwert beträgt 1e-12 Siemens, woraus sich für ROFF ein Standardwert von 1000 GOhm ergibt. |
Verlustbehaftete Übertragungsleitung
Die folgenden Parameter können für dieses Bauteilmodell mit dem Assistenten definiert werden. Wenn Sie einen Wert eingeben (oder ein Flag setzen), wird der entsprechende Parameter in die generierte MDL-Datei geschrieben.
R |
Widerstand pro Längeneinheit (in Ohm/Einheit). (Standardwert = 0). |
|
L |
Induktivität pro Längeneinheit (in Henry/Einheit). (Standardwert = 0). |
|
G |
Leitwert pro Längeneinheit (in Siemens/Einheit). (Standardwert = 0). |
|
C |
Kapazität pro Längeneinheit (in Farad/Einheit). (Standardwert = 0). |
|
LEN |
Länge der Übertragungsleitung. |
|
REL |
Steuerung der Stützpunkte (in beliebigen Einheiten). (Standardwert = 1). |
|
ABS |
Steuerung der Stützpunkte (in beliebigen Einheiten). (Standardwert = 1). |
|
NOSTEPLIMIT |
Ein Flag, das bei Aktivierung die Beschränkung aufhebt, nach der Zeitschritte kleiner als die Leitungslaufzeit sein müssen. (Standardmäßig nicht gesetzt). |
|
NOCONTROL |
Ein Flag, das bei Aktivierung die Begrenzung des Zeitschritts anhand von Faltungsfehlerkriterien verhindert. (Standardmäßig nicht gesetzt). |
|
LININTERP |
Ein Flag, das bei Aktivierung für die Berechnung verzögerter Signale die lineare Interpolation anstelle der standardmäßigen quadratischen Interpolation verwendet. (Standardmäßig nicht gesetzt). |
|
MIXEDINTERP |
Ein Flag, das bei Aktivierung anhand eines Kriteriums bestimmt, ob die quadratische Interpolation anwendbar ist, und andernfalls die lineare Interpolation verwendet. (Standardmäßig nicht gesetzt). |
|
COMPACTREL |
Eine spezifische Größe zur Steuerung der Verdichtung vergangener Werte, die für die Faltung verwendet werden. Standardmäßig wird hierfür der Wert des Parameters für die relative Simulationsfehlertoleranz (RELTOL) verwendet, der auf der Registerkarte Advanced des Dialogfelds Advanced Analyses Settings definiert ist. |
|
COMPACTABS |
Eine spezifische Größe zur Steuerung der Verdichtung vergangener Werte, die für die Faltung verwendet werden. Standardmäßig wird hierfür der Wert des Parameters für die absolute Stromfehlertoleranz (ABSTOL) verwendet, der auf der Registerkarte Advanced des Dialogfelds Advanced Analyses Settings definiert ist. |
|
TRUNCNR |
Ein Flag, das bei Aktivierung die Verwendung des Newton-Raphson-Iterationsverfahrens zur Bestimmung eines geeigneten Zeitschritts in den Routinen zur Zeitschrittsteuerung einschaltet. (Standardmäßig nicht gesetzt; stattdessen wird ein Versuch-und-Irrtum-Verfahren verwendet, bei dem der vorherige Zeitschritt jedes Mal halbiert wird). |
|
TRUNCDONTCUT |
Ein Flag, das bei Aktivierung die standardmäßige Verkürzung des Zeitschritts zur Fehlerbegrenzung bei der eigentlichen Berechnung impulsantwortbezogener Größen aufhebt. (Standardmäßig nicht gesetzt). |
RC-Übertragungsleitung mit gleichmäßig verteilten Parametern
Die folgenden Parameter können für dieses Bauteilmodell mit dem Assistenten definiert werden. Wenn Sie einen Wert eingeben, wird der entsprechende Parameter in die generierte MDL-Datei geschrieben.
K |
Ausbreitungskonstante. (Standardwert = 2). |
|
FMAX |
Maximale relevante Frequenz (in Hertz). (Standardwert = 1.0G). |
|
RPERL |
Widerstand pro Längeneinheit (in Ohm/Meter). (Standardwert = 1000). |
|
CPERL |
Kapazität pro Längeneinheit (in Farad/Meter). (Standardwert = 1.0e-15). |
|
ISPERL |
Sättigungsstrom pro Längeneinheit (in Ampere/Meter). (Standardwert = 0). |
|
RSPERL |
Diodenwiderstand pro Längeneinheit (in Ohm/Meter). (Standardwert = 0). |
Durch Parameterextraktion aus Daten erstellte Bauelementmodelle
Bei Dioden und Bipolartransistoren (BJT) extrahiert der Assistent Parameterinformationen aus den von Ihnen eingegebenen Daten. Welche Parameter für die Aufnahme in die Modelldatei extrahiert werden, hängt von den jeweiligen Eigenschaften der Diode oder des Bipolartransistors ab, die bzw. den Sie modellieren möchten.
Die Art der Dateneingabe variiert je nach Eigenschaft. In einigen Fällen müssen Sie konkrete Zahlenwerte eingeben, in anderen Fällen Kennliniendaten. In jedem Fall stammen alle Daten aus direkten Messungen am Bauelement, aus einem Herstellerdatenblatt oder aus einer Kombination beider Quellen.
Wenn Sie Kennliniendaten eingeben müssen, tragen Sie eine Reihe von Datenpunkten aus der zugrunde liegenden Kennlinie in die vom Assistenten bereitgestellte Tabelle ein. Wenn die Daten im Format mit kommagetrennten Werten (*.csv) vorliegen, können Sie sie über die verfügbare Schaltfläche Import Data importieren. Der Assistent verwendet die eingegebenen Daten, um die erforderlichen Modellparameter zu extrahieren. Die Ergebnisse der Extraktion werden auf einer nachfolgenden Seite des Assistenten angezeigt – sowohl als extrahierte Parameterwerte als auch in einem Vergleichsdiagramm mit den eingegebenen Daten und den anhand der extrahierten Parameter berechneten Werten. Die folgende Abbildung zeigt ein Beispiel für eine solche Darstellung der Parameterergebnisse.

Geben Sie Quelldaten ein, damit der Assistent die erforderlichen Modellparameter extrahieren kann.
Sie können die extrahierten Parameterwerte bearbeiten, um die Genauigkeit des Diodenmodells weiter zu verbessern. Der grafische Vergleich wird entsprechend den Änderungen aktualisiert.
Diode
Die folgenden Abschnitte beschreiben die einzelnen Eigenschaften, die Sie für eine Diode modellieren können. Jeder Abschnitt erläutert die extrahierten Parameter sowie die Quelldaten, die der Assistent für deren Extraktion benötigt.
Stromfluss in Durchlassrichtung
Die folgenden Parameter beschreiben die Gleichstrom-Spannungs-Kennlinie der Diode im Durchlassbereich:
IS |
Sättigungsstrom (in Ampere). |
|
N |
Emissionskoeffizient. |
|
RS |
Ohmscher Widerstand (in Ohm). |
Zur Extraktion dieser Parameter wird eine Kennlinie des Diodendurchlassstroms (IF) in Abhängigkeit von der Diodendurchlassspannung (VF) benötigt. Diese Kennlinie kann entweder einem Herstellerdatenblatt entnommen oder durch Messungen an einem realen Bauelement ermittelt werden.
Die folgende Abbildung zeigt ein Beispiel für eine solche Kennlinie aus einem Datenblatt sowie eine beispielhafte Testschaltung, an der direkte Messungen zur Ermittlung der erforderlichen Quelldaten durchgeführt werden können.

Beispielkennlinie und -schaltung für die Strom-Spannungs-Kennlinie einer Diode im Durchlassbereich.
Die Daten werden als eine Reihe von Datenpunkten aus der Ausgangskennlinie in den Assistenten eingegeben.
Sperrschichtkapazität in Sperrrichtung
Die folgenden Parameter beschreiben die Kapazität der Diode beim Betrieb in Sperrrichtung:
CJO |
Sperrschichtkapazität ohne Vorspannung (in Farad). |
|
M |
Gradierungskoeffizient. |
|
VJ |
Diffusionsspannung (in Volt). |
Zur Extraktion dieser Parameter wird eine Kennlinie der Kapazität in Sperrrichtung (Cd) in Abhängigkeit von der Diodensperrspannung (VR) benötigt. Diese Kennlinie kann entweder einem Herstellerdatenblatt entnommen oder durch Messungen an einem realen Bauelement ermittelt werden.
Die Abbildung zeigt ein Beispiel für eine solche Kennlinie aus einem Datenblatt sowie eine beispielhafte Testschaltung, an der direkte Messungen zur Ermittlung der erforderlichen Quelldaten durchgeführt werden können. Letztere kann verwendet werden, wenn kein Kapazitätsmessgerät verfügbar ist.

Beispielkennlinie und -schaltung für die Diodenkapazität in Sperrrichtung.
Die Daten werden als eine Reihe von Datenpunkten aus der Ausgangskennlinie in den Assistenten eingegeben.
Die Beispielschaltung in der obigen Abbildung basiert auf der folgenden Gleichung:
I = C * (dv/dt)
Nach C aufgelöst ergibt diese Gleichung:
C = I/(dv/dt)
Die Schaltung erzeugt mithilfe der Quelle V1 eine Spannungsrampe. Durch Berechnung der Steigung dieser Spannungsrampe lässt sich der Term dv/dt der Gleichung bestimmen. Wird der gemessene Diodenstrom durch die Steigung der Spannungsrampe dividiert, ergibt sich die Kapazitätskennlinie der Diode.
Stromfluss in Sperrrichtung
Die folgenden Parameter beschreiben den Stromfluss des Bauelements in Sperrrichtung nach dem Durchbruch:
BV |
Sperrdurchbruchspannung (in Volt). |
|
IBV |
Strom bei Durchbruchspannung (in Ampere). |
Zur Extraktion dieser Parameter müssen die folgenden beiden Werte in den Assistenten eingegeben werden:
-
Wert der Sperrdurchbruchspannung.
-
Wert des Stroms durch die Diode am Sperrdurchbruchpunkt.
Diese Werte können entweder einem Herstellerdatenblatt entnommen oder durch Messungen an einem realen Bauelement ermittelt werden. Datenblätter enthalten die elektrischen Gleichstromkenndaten einer Diode in der Regel in Tabellenform. Sie müssen diese Werte daher lediglich ausfindig machen und genau wie angegeben eingeben.
Wenn die Quelldaten grafisch vorliegen – wie es bei direkten Messungen an einem realen Bauelement üblich ist –, müssen Sie diese beiden Werte an dem Punkt ablesen, an dem der Durchbruch der Diode beginnt. Die folgende Abbildung zeigt ein Beispiel für eine solche Kennlinie.

Grafische Ermittlung der Strom- und Spannungswerte am Sperrdurchbruchpunkt.
Auch wenn die Werte im Diagramm als negative Werte dargestellt werden, dürfen sie in die entsprechenden Felder des Assistenten nur als positive Werte eingegeben werden.
Sperrerholverhalten
Der folgende Parameter dient zur Modellierung der Sperrerholzeit der Diode beim Umschalten von Durchlass- auf Sperrrichtung:
TT |
Transitzeit (in Sekunden). |
Zur Extraktion dieses Parameters muss die Sperrerholzeit der Diode (Trr) für den Fall, dass der Durchlassstrom gleich dem Sperrstrom ist (d. h. IR/IF=1), in den Assistenten eingegeben werden. Diese Angabe findet sich üblicherweise als einfacher Zahlenwert in den Herstellerdatenblättern für Schaltdioden.
Die folgende Abbildung zeigt, wie diese Information in einem Herstellerdatenblatt dargestellt wird. Der relevante Wert in der Abbildung – der in den Assistenten einzugeben ist – beträgt 4 ns.

Ermittlung der Sperrerholzeit einer Diode.
Bipolartransistor (BJT)
Beim Erstellen eines Modells für einen Bipolartransistor (BJT) müssen Sie im SPICE-Modellassistenten die Quelldaten auswählen, aus denen die Parameterinformationen extrahiert werden:
- Messdaten – wählen Sie diese Option, wenn Ihre Quelldaten aus Messungen am realen Bauelement stammen und Sie ein präzises Modell entwickeln möchten, das alle Aspekte des Gleichstromverhaltens beschreibt.
- Herstellerdatenblatt – wählen Sie diese Option, wenn Ihre Quelldaten aus einem Datenblatt stammen. Datenblätter enthalten in der Regel nicht genügend Informationen, um alle Aspekte des BJT-Bauelements zu modellieren. Sie enthalten jedoch normalerweise ausreichend Informationen, um ein Bauelementmodell zu erstellen, das ausschließlich für den vorwärtsaktiven Bereich geeignet ist.
Die Unterschiede zwischen diesen beiden Optionen betreffen hauptsächlich die Extraktion der Parameter, die die Gleichstrom-Spannungs-Kennlinien des BJT modellieren. Bei den Sperrschichtkapazitäten in Sperrrichtung und den Transitzeiten ist die Parameterextraktion bei beiden Optionen identisch.
Die folgenden Abschnitte beschreiben die einzelnen Eigenschaften, die Sie für ein BJT-Bauelement modellieren können, jeweils in Bezug auf die Art der Quelldaten (Messdaten oder Datenblatt). Dabei werden die jeweils extrahierten Parameter und die Quelldaten erläutert, die der Assistent für deren Extraktion benötigt.
Mit Messdaten modellierte Eigenschaften
Die folgenden Eigenschaften können mithilfe von Daten modelliert werden, die durch direkte Messungen am realen Bauelement erfasst wurden.
-
Forward-Bias Parameters
Die folgenden Parameter beschreiben die Gleichstrom-Spannungs-Kennlinien des BJT im Vorwärtsbetrieb:
IS
Transportsättigungsstrom (in Ampere).
BF
Ideale maximale Vorwärtsstromverstärkung Beta.
NF
Emissionskoeffizient des Vorwärtsstroms.
RB
Basiswiderstand ohne Vorspannung (in Ohm).
RC
Kollektorwiderstand (in Ohm).
RE
Emitterwiderstand (in Ohm).
IKF
Eckstrom für den Abfall der Vorwärtsstromverstärkung Beta bei hohen Strömen (in Ampere).
ISE
B-E-Lecksättigungsstrom (in Ampere).
NE
Emissionskoeffizient des B-E-Leckstroms.
VAF
Early-Spannung im Vorwärtsbetrieb (in Volt).
Die folgenden Abschnitte beschreiben die erforderlichen Messdaten, deren Eingabe dem Assistenten die Extraktion dieser Parameter ermöglicht.
-
Base-Emitter Voltage versus Base Current
Diese Daten dienen zur anfänglichen Extraktion des Parameters RC. Die folgende Abbildung zeigt ein beispielhaftes Diagramm der Basis-Emitter-Spannung (VBE) in Abhängigkeit vom Basisstrom (IB) sowie eine beispielhafte Testschaltung, mit der die entsprechenden Messdaten erfasst werden können. Die Schaltung speist einen Strom in die Basis ein, während die Basis-Emitter-Leerlaufspannung gemessen wird.

Beispieldiagramm und -schaltung für VBE in Abhängigkeit von IB.Die Daten werden als Reihe von Datenpunkten aus dem Quelldiagramm in den Assistenten eingegeben.
-
Collector-Emitter Voltage versus Base Current
Diese Daten dienen zur anfänglichen Extraktion des Parameters RE. Die folgende Abbildung zeigt ein beispielhaftes Diagramm der Kollektor-Emitter-Spannung (VCE) in Abhängigkeit vom Basisstrom (IB) sowie eine beispielhafte Testschaltung, mit der die entsprechenden Messdaten erfasst werden können. Die Schaltung speist einen Strom in die Basis ein, während die Kollektor-Emitter-Leerlaufspannung gemessen wird.

Beispieldiagramm und -schaltung für VCE in Abhängigkeit von IB.Die Daten werden als Reihe von Datenpunkten aus dem Quelldiagramm in den Assistenten eingegeben.
-
Forward Gummel Plot
Diese Daten dienen hauptsächlich zur Extraktion der Parameter IS, BF, NF, RB, IKF, ISE und NE. Sie werden außerdem zur Optimierung der Parameter RC, RE und VAF verwendet. Die folgende Abbildung zeigt ein beispielhaftes Gummel-Diagramm sowie eine beispielhafte Testschaltung, mit der die entsprechenden Messdaten erfasst werden können. Das Gummel-Diagramm zeigt:
-
Den Basisstrom in Abhängigkeit von der Basis-Emitter-Spannung (IB über VBE).
-
Den Kollektorstrom in Abhängigkeit von der Basis-Emitter-Spannung (IC über VBE).
Die Basis-Kollektor-Spannung (VBC) wird auf null Volt gehalten.

Beispiel eines Gummel-Diagramms im Vorwärtsbetrieb mit Testschaltung.Die Daten werden als Reihe von Datenpunkten aus dem ursprünglichen Gummel-Diagramm in den Assistenten eingegeben. Die Rohwerte für IB und IC müssen eingegeben werden – der Assistent wendet die LN-Funktion auf die Kurvendaten an.
-
-
Collector Current versus Base-Emitter Voltage
Diese Daten dienen zur anfänglichen Extraktion des Parameters VAF. Die folgende Abbildung zeigt ein beispielhaftes Diagramm des Kollektorstroms (IC) in Abhängigkeit von der Basis-Emitter-Spannung (VBE) sowie eine beispielhafte Testschaltung, mit der die entsprechenden Messdaten erfasst werden können. Mit der Schaltung werden zwei Kurven von IC über VBE für zwei verschiedene Werte der Basis-Kollektor-Spannung (VBC) erzeugt. Die Kurven sollten bei möglichst niedrigen Strömen und mit einem VBC-Wert gemessen werden, der so nahe wie praktisch möglich bei null Volt liegt.

Beispieldiagramme und -schaltung für VBE in Abhängigkeit von IC.Die Daten werden als Reihe von Datenpunkten in zwei Tabellen in den Assistenten eingegeben – eine für jede Quelldatenkurve. Der jeweils verwendete VBC-Wert muss ebenfalls eingegeben werden.
-
-
Reverse-Bias Parameters
Die folgenden Parameter beschreiben die Gleichstrom-Spannungs-Kennlinien des BJT im Rückwärtsbetrieb:
IS
Transportsättigungsstrom (in Ampere).
BR
Ideale maximale Rückwärtsstromverstärkung Beta.
NR
Emissionskoeffizient des Rückwärtsstroms.
RB
Basiswiderstand ohne Vorspannung (in Ohm).
RC
Kollektorwiderstand (in Ohm).
RE
Emitterwiderstand (in Ohm).
IKR
Eckstrom für den Abfall der Rückwärtsstromverstärkung Beta bei hohen Strömen (in Ampere).
ISC
B-C-Lecksättigungsstrom (in Ampere).
NC
Emissionskoeffizient des B-C-Leckstroms.
VAR
Early-Spannung im Rückwärtsbetrieb (in Volt).
Die folgenden Abschnitte beschreiben die erforderlichen Messdaten, deren Eingabe dem Assistenten die Extraktion dieser Parameter ermöglicht.
-
Reverse Gummel Plot
Diese Daten werden hauptsächlich zur Extraktion der Parameter IS, BR, NR, RB, IKR, ISC und NC verwendet. Sie dienen außerdem zur Optimierung der Parameter RC, RE und VAR. Die folgende Abbildung zeigt ein beispielhaftes Gummel-Diagramm sowie eine beispielhafte Testschaltung, mit der die zur Ermittlung der Daten erforderlichen Messungen durchgeführt werden können. Das Gummel-Diagramm zeigt:
-
Basisstrom in Abhängigkeit von der Basis-Kollektor-Spannung (IB über VBC).
-
Emitterstrom in Abhängigkeit von der Basis-Kollektor-Spannung (IE über VBC).
Die Basis-Emitter-Spannung (VBE) wird auf null Volt gehalten.

Beispiel für ein inverses Gummel-Diagramm und eine Testschaltung.Die Daten werden als Reihe von Datenpunkten aus dem zugrunde liegenden Gummel-Diagramm in den Assistenten eingegeben. Die IB- und IE-Werte müssen als Rohwerte eingegeben werden – der Assistent wendet die LN-Funktion auf die Kurvendaten an.
-
-
Emitter Current versus Base-Collector Voltage
Diese Daten werden zur anfänglichen Extraktion des Parameters VAR verwendet. Die folgende Abbildung zeigt ein beispielhaftes Diagramm des Emitterstroms (IE) in Abhängigkeit von der Basis-Kollektor-Spannung (VBC) sowie eine beispielhafte Testschaltung, mit der die zur Ermittlung der Daten erforderlichen Messungen durchgeführt werden können. Mit der Schaltung werden zwei Kurven von IE über VBC für zwei unterschiedliche Werte der Basis-Emitter-Spannung (VBE) erzeugt. Die Kurven sollten bei möglichst niedrigen Strömen und mit einer VBE gemessen werden, die so nahe bei null Volt liegt, wie es praktisch möglich ist.

Beispieldiagramme und Schaltung für IE über VBC.Die Daten werden als Reihe von Datenpunkten in zwei Tabellen im Assistenten eingegeben – eine für jede Ausgangsdatenkurve. Der verwendete Wert für VBE muss ebenfalls jeweils eingegeben werden.
-
Mit Daten aus einem Herstellerdatenblatt modellierte Eigenschaften
Die folgenden Eigenschaften können anhand von Daten aus einem Herstellerdatenblatt modelliert werden.
-
Forward-Bias Parameters
Die folgenden Parameter beschreiben die Gleichstrom-Spannungs-Kennlinien des Bipolartransistors im Vorwärtsbetrieb:
IS
Transportsättigungsstrom (in Ampere).
BF
Ideale maximale Vorwärtsstromverstärkung Beta.
NF
Emissionskoeffizient des Vorwärtsstroms.
RE
Emitterwiderstand (in Ohm).
IKF
Eckstrom für den Abfall der Vorwärtsstromverstärkung Beta bei hohen Strömen (in Ampere).
ISE
B-E-Lecksättigungsstrom (in Ampere).
NE
Emissionskoeffizient des B-E-Leckstroms.
Die folgenden Abschnitte erläutern die erforderlichen Daten, anhand deren Eingabe der Assistent diese Parameter extrahieren kann.
-
Base-Emitter Voltage versus Collector Current
Diese Daten werden zur Extraktion der Parameter IS, NF, RE und IKF verwendet. Die folgende Abbildung zeigt ein beispielhaftes Diagramm der Basis-Emitter-Spannung (VBE) in Abhängigkeit vom Kollektorstrom (IC) aus einem Datenblatt.
Die Daten werden als Reihe von Datenpunkten aus dem zugrunde liegenden Diagramm in den Assistenten eingegeben. Die IC-Werte müssen als Rohwerte eingegeben werden – der Assistent wendet die LN-Funktion auf die Kurvendaten an.
Der Wert für das erzwungene Beta-Verhältnis der Kurve (β = IC/IB) muss ebenfalls eingegeben werden. Im Beispieldiagramm der obigen Abbildung ist dieser Wert oben links im Diagramm angegeben; dementsprechend wäre der Wert 10 einzugeben.
-
DC Current Gain versus Collector Current
Diese Daten werden zur Extraktion der Parameter BF, NE, ISE und IKF verwendet. Die folgende Abbildung zeigt ein beispielhaftes Diagramm der Gleichstromverstärkung (hFE) in Abhängigkeit vom Kollektorstrom (IC) aus einem Datenblatt.
Die Daten werden als Reihe von Datenpunkten aus dem zugrunde liegenden Diagramm in den Assistenten eingegeben. Für eine hohe Genauigkeit sollten Werte der Gleichstromverstärkung für niedrige, mittlere und hohe Kollektorströme eingegeben werden.
-
-
Forward Early Voltage
Der folgende Parameter wird verwendet, um den Effekt der Basisweitenmodulation im Gummel-Poon-Transistormodell zu modellieren:
VAF
Early-Spannung im Vorwärtsbetrieb (in Volt).
Zur Extraktion dieses Parameters müssen Sie einen Punkt aus der Kurve der Ausgangsadmittanz (hOE) in Abhängigkeit vom Kollektorstrom (IC) eingeben. Die folgende Abbildung zeigt ein Beispiel für eine solche Kurve.
Lesen Sie einen beliebigen Wert auf der Kurve ab. Im Beispiel der obigen Abbildung lassen sich IC = 1mA und hOE = 30μmhos ablesen.
In der Regel liegen die Daten in Tabellenform vor. Ein Beispiel dafür zeigt die folgende Abbildung.

Beispiel für einen Tabelleneintrag zur Ausgangsadmittanz.Die relevanten Werte in der Abbildung – und die im Assistenten einzugebenden Werte – sind 1mA für den Kollektorstrom und 30μmhos für die Ausgangsadmittanz (üblicherweise wird der Maximalwert verwendet).
Mit Mess- oder Herstellerdaten modellierte Eigenschaften
Die folgenden Eigenschaften können anhand von Daten aus einem Herstellerdatenblatt oder aus direkten Messungen an einem physischen Bauteil modelliert werden.
-
Base-Emitter Capacitance
Die folgenden Parameter beschreiben die Sperrschichtkapazität des Basis-Emitter-Übergangs bei Sperrpolung:
CJE
B-E-Sperrschichtkapazität bei null Vorspannung (in Farad).
MJE
Exponent des B-E-Übergangs.
VJE
Diffusionsspannung des B-E-Übergangs (in Volt).
Zur Extraktion dieser Parameter wird ein Diagramm der Sperrschichtkapazität des in Sperrrichtung gepolten B-E-Übergangs (Cj) in Abhängigkeit von der Spannung (VBE) benötigt. Falls kein Kapazitätsmessgerät verfügbar ist, kann die beispielhafte Testschaltung in der folgenden Abbildung zur Ermittlung der Daten verwendet werden. Die Abbildung zeigt außerdem beispielhafte Diagramme, die mit einer solchen Schaltung erstellt wurden – jeweils mit VBE bzw. Cj über der Zeit. Aus diesen Diagrammen lassen sich die Werte für VBE und Cj zu den entsprechenden Zeitpunkten leicht ablesen.

Beispielschaltung und Diagramme für die B-E-Sperrschichtkapazität bei Sperrpolung.Die Daten werden als Reihe von Datenpunkten aus dem bzw. den zugrunde liegenden Diagrammen in den Assistenten eingegeben.
Die Beispielschaltung in der obigen Abbildung basiert auf der Gleichung:
I = C * (dv/dt)Nach C aufgelöst ergibt diese Gleichung:
C = I/(dv/dt)Die Schaltung erzeugt eine Spannungsrampe aus der Quelle V1. Durch Berechnung der Steigung dieser Rampenspannung lässt sich der Term
dv/dtder Gleichung bestimmen. Durch Division des gemessenen Diodenstroms durch die Steigung der Rampenspannung erhält man die Kapazitätskurve der Diode. Die beiden Diagramme in der obigen Abbildung beziehen sich wie folgt auf die Schaltung:-
Oberes Diagramm – VBE ist V1.
-
Unteres Diagramm – Cj ist q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Die folgenden Parameter beschreiben die Sperrschichtkapazität des Basis-Kollektor-Übergangs bei Sperrpolung:
CJC
B-C-Sperrschichtkapazität ohne Vorspannung (in Farad).
MJC
Exponent des B-C-Übergangs.
VJC
B-C-Diffusionsspannung (in Volt).
Zur Extraktion dieser Parameter wird eine Kennlinie der Sperrschichtkapazität (Cj) des in Sperrrichtung gepolten B-C-Übergangs in Abhängigkeit von der Spannung (VBC) benötigt. Falls kein Kapazitätsmessgerät verfügbar ist, kann die Beispiel-Testschaltung in der folgenden Abbildung zur Ermittlung der Daten verwendet werden. Die Abbildung zeigt außerdem beispielhafte Diagramme, die mit einer solchen Schaltung ermittelt wurden – jeweils VBC und Cj über der Zeit. Aus diesen Diagrammen lassen sich die Werte für VBC und Cj zu den jeweiligen Zeitpunkten leicht ablesen.

Beispielschaltung und Diagramme zur Sperrschichtkapazität des B-C-Übergangs bei Sperrpolung.Die Daten werden als eine Reihe von Datenpunkten aus dem Ausgangsdiagramm in den Assistenten eingegeben.
Die Beispielschaltung in der obigen Abbildung basiert auf der Gleichung:
I = C * (dv/dt)Nach C aufgelöst ergibt diese Gleichung:
C = I/(dv/dt)Die Schaltung erzeugt eine Spannungsrampe aus der Quelle V1. Durch Berechnung der Steigung dieser Rampenspannung lässt sich der Term
dv/dtder Gleichung bestimmen. Durch Division des gemessenen Diodenstroms durch die Steigung der Rampenspannung erhält man die Kapazitätskurve der Diode. Die beiden Diagramme in der obigen Abbildung beziehen sich wie folgt auf die Schaltung:-
Oberes Diagramm – VBC ist V1.
-
Unteres Diagramm – Cj ist q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Die folgenden Parameter beschreiben die Sperrschichtkapazität des Kollektor-Substrat-Übergangs bei Sperrpolung:
CJS
Kollektor-Substrat-Kapazität ohne Vorspannung (in Farad).
MJS
Exponent des Substratübergangs.
VJS
Diffusionsspannung des Substratübergangs (in Volt).
Zur Extraktion dieser Parameter wird eine Kennlinie der Sperrschichtkapazität (Cj) des in Sperrrichtung gepolten C-S-Übergangs in Abhängigkeit von der Spannung (VCS) benötigt. Falls kein Kapazitätsmessgerät verfügbar ist, kann die Beispiel-Testschaltung in der folgenden Abbildung zur Ermittlung der Daten verwendet werden. Die Abbildung zeigt außerdem beispielhafte Diagramme, die mit einer solchen Schaltung ermittelt wurden – jeweils VCS und Cj über der Zeit. Aus diesen Diagrammen lassen sich die Werte für VCS und Cj zu den jeweiligen Zeitpunkten leicht ablesen.

Beispielschaltung und Diagramme zur Sperrschichtkapazität des C-S-Übergangs bei Sperrpolung.Die Daten werden als eine Reihe von Datenpunkten aus dem Ausgangsdiagramm in den Assistenten eingegeben.
Die Beispielschaltung in der obigen Abbildung basiert auf der Gleichung:
I = C * (dv/dt)Nach C aufgelöst ergibt diese Gleichung:
C = I/(dv/dt)Die Schaltung erzeugt eine Spannungsrampe aus der Quelle V1. Durch Berechnung der Steigung dieser Rampenspannung lässt sich der Term
dv/dtder Gleichung bestimmen. Durch Division des gemessenen Diodenstroms durch die Steigung der Rampenspannung erhält man die Kapazitätskurve der Diode. Die beiden Diagramme in der obigen Abbildung 24 beziehen sich wie folgt auf die Schaltung:-
Oberes Diagramm – VCS ist V1.
-
Unteres Diagramm – Cj ist q1[is]/(dV1/dt).
-
-
Transit Times
Die folgenden Parameter beschreiben die Transitzeit des BJT:
TF
Ideale Vorwärtstransitzeit (in Sekunden).
TR
Ideale Rückwärtstransitzeit (in Sekunden).
Zur Extraktion dieser Parameter muss im Assistenten die Transitfrequenz (fT) des Transistors eingegeben werden. Dies ist die Frequenz, bei der die Stromverstärkung des Transistors auf eins fällt. Diese Angabe findet sich üblicherweise als einfacher Zahlenwert in den Datenblättern der Hersteller.
Die folgende Abbildung zeigt, wie diese Information im Datenblatt eines Herstellers dargestellt wird. Der relevante Wert in der Abbildung – der in den Assistenten einzugebende Wert – beträgt 100 MHz.

Beispiel eines Tabelleneintrags für das Stromverstärkungs-Bandbreiten-Produkt.
Vom Assistenten nicht extrahierte Parameter
Die folgenden Parameter lassen sich nur schwer aus Messdaten extrahieren und sind üblicherweise nicht in den Datenblättern der Hersteller enthalten. Sie werden vom Assistenten weder extrahiert noch der resultierenden Modelldatei für einen BJT hinzugefügt. Obwohl sie in der MDL-Datei nicht enthalten sind, verwendet SPICE diese Parameter dennoch bei der Simulation des BJT-Bauelements – und zwar mit ihren integrierten Standardwerten. Diese Standardwerte sind im Folgenden zur schnellen Orientierung aufgeführt.
IRB |
Strom, bei dem der Basiswiderstand auf die Hälfte des Weges zu seinem Minimalwert abgesunken ist (in Ampere). (Standardwert = unendlich). |
|
RBM |
Minimaler Basiswiderstand bei hohen Strömen (in Ohm). (Standardwert = RB). |
|
XTF |
Koeffizient für die Vorspannungsabhängigkeit von TF. (Standardwert = 0). |
|
VTF |
Spannung zur Beschreibung der VBC-Abhängigkeit von TF (in Volt). (Standardwert = unendlich). |
|
ITF |
Hochstromparameter für den Einfluss auf TF (in Ampere). (Standardwert = 0). |
|
PTF |
Zusätzliche Phasenverschiebung bei freq=1.0/(TF*2PI)Hz (in Grad). (Standardwert = 0). |
|
XCJC |
Anteil der B-C-Sperrschichtkapazität, der mit dem internen Basisknoten verbunden ist. (Standardwert = 1). |
|
XTB |
Temperaturexponent der Vorwärts- und Rückwärtsstromverstärkung Beta. (Standardwert = 0). |
|
EG |
Bandlückenenergie für den Temperatureinfluss auf IS (in eV). (Standardwert = 1,11). |
|
XTI |
Temperaturexponent für den Einfluss auf IS. (Standardwert = 3). |
|
KF |
Koeffizient des Funkelrauschens. (Standardwert = 0). |
|
AF |
Exponent des Funkelrauschens. (Standardwert = 1). |
|
FC |
Koeffizient für die Formel der Sperrschichtkapazität bei Vorwärtspolung. (Standardwert = 0,5). |
|
TNOM |
Messtemperatur der Parameter (in ˚C). (Der Standardwert dieses Parameters entspricht dem Wert, der für den Parameter TNOM auf der Seite „SPICE Options“ des Dialogfelds „Analysis Setup“ eingegeben wurde. Dieser Eintrag beträgt standardmäßig 27 ˚C). |
Sie können selbstverständlich jeden dieser Parameter manuell in die MDL-Datei einfügen und dabei die gewünschten Werte nach Bedarf angeben.
