Validieren einer Komponente
Bevor eine in der Komponentenbearbeitung definierte/bearbeitete Workspace-Bibliothekskomponente (im Modus Single Component Editing oder Batch Component Editing) im connected Workspace gespeichert und damit für die Verwendung in Designs verfügbar gemacht wird, muss unbedingt sichergestellt werden, dass diese Komponente die Anforderungen gemäß den konfigurierten Einstellungen erfüllt. Wenn Sie versuchen, eine Komponente zurück in den Workspace zu speichern, führt die Komponentenbearbeitung eine Validierung aus – eine Component Rule Check. Diese Funktion kann auch jederzeit manuell ausgeführt werden, indem Sie den Befehl Tools » Component Rule Check in den Hauptmenüs wählen. Stellen Sie sicher, dass Sie Ihre Komponente zuvor lokal gespeichert haben (File » Save).
Genau wie ein Board-Projekt über einen Validierungsprozess zum Erkennen von Verstößen verfügt, besitzt auch die Komponentenbearbeitung eine Funktion zur Komponentenvalidierung. Alle gefundenen Verstöße werden im Fenster Messages aufgelistet.
Die Komponentenvalidierung prüft auf eine Reihe potenzieller Probleme mit der Komponente und ihren definierten Modellen – sowohl fest integrierte Prüfungen als auch eine Reihe von Verstoßtypen, die vom Benutzer global definiert werden können.
Die folgenden fest integrierten Validierungsprüfungen haben alle einen Berichtsmodus von
:
Folder path not specified for component
Zusammenfassung
Dieser Verstoß tritt auf, wenn kein Ordner im Ziel-Workspace angegeben ist, in dem eine im Component Editor definierte Komponente gespeichert werden soll.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Folder path not specified for component <ItemID>
dabei gilt:
- ItemID ist die für die Komponente im Workspace verwendete ID.
Empfehlung zur Behebung
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode das Feld Folder im Bereich Component, um einen Ordner im Ziel-Workspace anzugeben, in dem die Komponente gespeichert wird. Um einen Zielordner manuell anzugeben, klicken Sie auf die Schaltfläche
, um das Dialogfeld Choose Folder zu öffnen. Navigieren Sie zu einem vorhandenen Ordner und wählen Sie ihn aus oder erstellen Sie direkt einen neuen.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode das Feld FolderPath (in der Spaltengruppe Component) im Bereich für die Komponentendefinition des Editors, um einen Ordner im Ziel-Workspace anzugeben, in dem die Komponente gespeichert wird. Um einen Zielordner manuell anzugeben, klicken Sie einmal in das Feld FolderPath einer Komponente, damit die Schaltfläche
angezeigt wird, und klicken Sie darauf, um das Dialogfeld Choose Folder zu öffnen. Navigieren Sie zu einem vorhandenen Ordner und wählen Sie ihn aus oder erstellen Sie direkt einen neuen.
Component not having a unique Id
Zusammenfassung
Dieser Verstoß tritt auf, wenn die Item-ID einer im Component Editor definierten Komponente mit der Item-ID eines anderen Elements im connected Workspace identisch ist.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Duplicate Component Id: "<ItemID>"
dabei gilt:
- ItemID ist die für die Komponente im Workspace verwendete ID.
Empfehlung zur Behebung
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode das Feld Id im Bereich Component, um eine andere ID anzugeben, die innerhalb des Inhalts des verbundenen Workspace eindeutig ist.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode das Feld Item ID in der Spaltengruppe Component des Bereichs für die Komponentendefinition, um eine andere ID anzugeben, die innerhalb des Inhalts des verbundenen Workspace eindeutig ist.
Hinweis
Dieser Verstoß tritt typischerweise auf, wenn ein automatisch zugewiesener Item-ID-Wert einer Komponente manuell überschrieben wird. Bei einer neuen Komponente, die über den Befehl File » New » Component oder das Fenster Components panel erstellt wird, wird dieses Feld entsprechend der Komponentenvorlage gefüllt, die für den im Dialogfeld Create new component dialog gewählten Komponententyp definiert ist. Wenn keine Vorlage vorhanden ist oder im Dialogfeld der Eintrag <Undefined> gewählt wird, wird ein Standardschema für die Benennung verwendet; CMP-{00000}. Bei einer neuen Komponente, die über das Fenster Explorer panel erstellt wird, wird dieses Feld entsprechend dem Standardschema für die Benennung gefüllt, das für den übergeordneten Ordner dieser Komponente festgelegt ist. Wenn dem übergeordneten Ordner eine Komponentenvorlage zugeordnet ist, wird die darin definierte Component Naming übernommen. Die Software weist automatisch die nächste verfügbare eindeutige ID basierend auf diesem Schema zu, nachdem der gesamte Workspace und die Kennungen vorhandener Inhalte durchsucht wurden.
Benutzerdefinierbare Prüfungen werden auf der Seite Data Management – Component Rule Checks page des Dialogfelds Preferences konfiguriert.
Alle fest integrierten Prüfungen, die fehlschlagen, oder benutzerdefinierten Prüfungen auf der Stufe Fatal Error verhindern das Speichern der Komponente im Workspace.
Die Standardeinstellungen der benutzerdefinierten Prüfungen passen möglicherweise nicht zu Ihren Komponenten. Daher ist es wichtig, sich mit den Optionen und deren Konfiguration vertraut zu machen, damit sie zu Ihren Designs passen. Informationen zu jeder benutzerdefinierten Fehlerprüfung finden Sie weiter unten.
Mit Komponenten verknüpfte Verstöße
Duplicate component by Name
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn der Name einer im Component Editor definierten Komponente mit dem Namen einer Komponente im connected Workspace identisch ist.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Duplicate component by Name
Empfehlung zur Behebung
Weisen Sie den Komponenten nach Bedarf unterschiedliche und eindeutige Namen zu.
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode das Feld Name im Bereich Component , um einen anderen Namen anzugeben, der für die Komponenten im verbundenen Workspace eindeutig ist.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode das Feld Item ID in der Spaltengruppe Component des Bereichs für die Komponentendefinition, um einen anderen Namen anzugeben, der für die Komponenten im verbundenen Workspace eindeutig ist.
Duplicate component by PCL
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn eine im Component Editor definierte Komponente eine Part Choice besitzt, die bereits von einer anderen Komponente im connected Workspace verwendet wird.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Duplicate component by Part Choice list
Empfehlung zur Behebung
Weisen Sie den Komponenten nach Bedarf unterschiedliche und eindeutige Part Choices zu.
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode den Bereich Part Choices , um die Liste der Component Part Choices so zu ändern, dass sie für die Komponenten im verbundenen Workspace eindeutig ist.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode die Spaltengruppe Part Choice n des Bereichs für die Komponentendefinition, um die Liste der Component Part Choices so zu ändern, dass sie für die Komponenten im verbundenen Workspace eindeutig ist.
Invalid pin mappings
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn eine im Component Editor definierte Komponente eine mehrdeutige Zuordnung zwischen Komponentensymbol und Footprint(s) aufweist. Beispielsweise tritt der Verstoß auf, wenn das Symbol in seinen Feldern Designator Pins mit 1, 2, 3 definiert, während der Footprint in seinen Feldern Designator Pads mit B, C, E definiert, oder wenn die Anzahl der Symbol-Pins größer ist als die Anzahl der Footprint-Pads.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)
dabei gilt:
-
PinDesignatorist das Designator des Symbol-Pins. -
SymbolNameist der Name des Symbols. -
SymbolRevisionIDist die Item-Revision-ID des Symbols. -
PadDesignatorist das Designator des Footprint-Pads. -
FootprintNameist der Name des Footprints. -
FootprintRevisionIDist die Item-Revision-ID des Footprints.
Empfehlung zur Behebung
Bearbeiten Sie das aktuell hinzugefügte Modell oder wählen Sie ein anderes Modell aus, um sicherzustellen, dass Symbol-Pins eine Eins-zu-eins-Zuordnung zu Footprint-Pads haben.
-
Im Component Editor im Modus Single Component Editing mode:
-
klicken Sie auf das Steuerelement
oben rechts in der Modellvorschau, um das aktuell von der Komponente verwendete (referenzierte) Modell im entsprechenden temporären Editor für diesen Modelltyp zu ändern;
-
klicken Sie auf das Steuerelement
oben rechts in der Modellvorschau und wählen Sie im Menü den Eintrag Select Model, um nach einem anderen Modell oder einer anderen Revision desselben Modells zu suchen und dieses bzw. diese auszuwählen;
-
klicken Sie auf das Steuerelement
oben rechts in der Symbolvorschau, um auf das Fenster Pins panel zuzugreifen und die zugeordneten Pad-/Pin-Ziele direkt zu ändern, indem Sie auf eine Zelle des Modells klicken und den gewünschten Wert eingeben.
-
-
Im Component Editor im Modus Batch Component Editing mode:
-
klicken Sie mit der rechten Maustaste auf den Modelleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit, um das aktuell von der Komponente verwendete (referenzierte) Modell im entsprechenden temporären Editor für diesen Modelltyp zu ändern;
-
klicken Sie im Bereich Model Links auf das Feld Item ID des Modells und dann auf die Schaltfläche
, um nach einem anderen Modell oder einer anderen Revision desselben Modells zu suchen und dieses bzw. diese auszuwählen.
-
Missing Component Description
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn die Beschreibung einer im Component Editor definierten Komponente nicht angegeben ist.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Component Description is not specified
Empfehlung zur Behebung
Geben Sie für die betroffene(n) Komponente(n) nach Bedarf eine Beschreibung an.
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode das Feld Description im Bereich Component , um eine Beschreibung anzugeben.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode das Feld Description in der Spaltengruppe Component des Bereichs für die Komponentendefinition, um für die betroffene(n) Komponente(n) eine Beschreibung anzugeben.
Missing Component Name
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn der Name einer im Component Editor definierten Komponente nicht angegeben ist.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Component Name is not specified
Empfehlung zur Behebung
Geben Sie für die betroffene(n) Komponente(n) nach Bedarf einen Namen an.
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode das Feld Name im Bereich Component , um einen Namen anzugeben.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode das Feld Name in der Spaltengruppe Component des Bereichs für die Komponentendefinition, um für die betroffene(n) Komponente(n) einen Namen anzugeben.
Missing Component Type
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn der Typ einer im Component Editor definierten Komponente nicht angegeben ist.
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
Component Type is not specified
Empfehlung zur Behebung
Geben Sie für die betroffene(n) Komponente(n) nach Bedarf einen Typ an.
-
Verwenden Sie im Component Editor im Modus Single Component Editing mode das Feld Type im Bereich Component , um einen Typ anzugeben.
-
Verwenden Sie im Component Editor im Modus Batch Component Editing mode das Feld Type in der Spaltengruppe Component des Bereichs für die Komponentendefinition, um für die betroffene(n) Komponente(n) einen Typ anzugeben.
Model revision is in Inapplicable State
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn festgestellt wird, dass sich ein verknüpftes Modell, das von einer Komponentendefinition verwendet (referenziert) wird, in einem nicht anwendbaren Zustand befindet. Beispielsweise ist das Modell derzeit Obsolete und sollte daher nicht verwendet werden. Die Anwendbarkeit wird über die Option Allowed to be used in designs im Dialogfeld State Properties dialog bestimmt. Innerhalb des Dialogfelds Edit Lifecycle Definitions dialog öffnen Sie dieses Dialogfeld für den gewünschten Zustand, indem Sie entweder auf den Zustandseintrag innerhalb der übergeordneten Lifecycle-Definition doppelklicken oder den Eintrag auswählen und auf das dann angezeigte Bearbeitungssymbol klicken Wenn diese Option aktiviert ist, darf ein Modell in diesem Zustand in einer Komponente verwendet werden. Es gilt dann als Applicable. Wenn diese Option deaktiviert ist, kann ein Modell in diesem Zustand nicht gültig verwendet werden und gilt als Inapplicable (oder nicht anwendbar).
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
<ModeName> (<ModelRevisionID>) revision is in inapplicable state
dabei gilt:
-
ModelNameist der Name des Modells. -
ModelRevisionIDist die Item-Revision-ID des Modells.
Empfehlung zur Behebung
Wählen Sie ein Ersatzmodell oder eine andere Revision desselben Modells, die für die Verwendung in der Komponente gültig ist.
-
Im Component Editor im Modus Single Component Editing mode klicken Sie auf das Steuerelement
oben rechts in der Modellvorschau und wählen Sie im Menü den Eintrag Select Model, um nach einem anderen Modell oder einer anderen Revision desselben Modells zu suchen und dieses bzw. diese auszuwählen.
-
Im Component Editor im Modus Batch Component Editing mode klicken Sie im Bereich Model Links auf das Feld Item ID des Modells und dann auf die Schaltfläche
, um nach einem anderen Modell oder einer anderen Revision desselben Modells zu suchen und dieses bzw. diese auszuwählen.
Model revision is Out Of Date
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn festgestellt wird, dass ein verknüpftes Modell, das von einer Komponentendefinition verwendet (referenziert) wird, veraltet ist. Wenn eine neuere Revision des Modells verfügbar ist, zeigt das Feld Revision State dies mit dem Text Out of date rechts neben dem Lifecycle-Status der aktuellen Revision unter der Modellvorschau an (im Component Editor im Modus Single Component Editing), oder das Feld Revision Status im Bereich Model Links wird mit dem fett dargestellten Text Out of date gekennzeichnet (im Component Editor im Modus Batch Component Editing).
Benachrichtigung
Im Fenster Messages wird eine Benachrichtigung im folgenden Format angezeigt:
<ModelName> (<ModelRevisionID>) revision is Out of Date
dabei gilt:
-
ModelNameist der Name des Modells. -
ModelRevisionIDist die Item-Revision-ID des Modells.
Empfehlung zur Behebung
Aktualisieren Sie die veralteten Verknüpfungen zu Komponentenmodellen, damit die neueste Revision der Modelle verwendet wird.
-
Im Component Editor im Modus Single Component Editing mode klicken Sie auf das Steuerelement
oben rechts in der Modellvorschau und wählen Sie im Menü den Eintrag Update to Latest.
-
Im Component Editor im Modus Batch Component Editing mode klicken Sie mit der rechten Maustaste irgendwo auf den Modelleintrag im Model Links Bereich und wählen Sie Update to Latest Revision aus dem Menü aus.
Number of Pads exceeds Number of Pins
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein Footprint-Modell, das von einer Komponentendefinition verwendet (referenziert) wird, mehr Pads (auf Kupferlagen platzierte SMD-Pads und metallisierte Durchkontaktierungs-Pads) enthält als Pins in seinem referenzierten Schaltplansymbol.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Number of pads in the footprint <FootprintName> (<FootprintRevisionID>) (<FootprintNumberOfPads>) exceeds number of pins in the symbol <SymbolName> (<SymbolRevisionID>) (<SymbolNumberOfPins>)
dabei gilt:
-
FootprintNameist der Name des Footprints. -
FootprintRevisionIDist die Item-Revision-ID des Footprints. -
FootprintNumberOfPadsist die Anzahl der Pads im Footprint. -
SymbolNameist der Name des Symbols. -
SymbolRevisionIDist die Item-Revision-ID des Symbols. -
SymbolNumberOfPinsist die Anzahl der Pins im Symbol.
Empfehlung zur Behebung
Bearbeiten Sie das aktuell hinzugefügte Symbol bzw. den aktuell hinzugefügten Footprint oder wählen Sie ein anderes Symbol-/Footprint-Modell aus, um sicherzustellen, dass die Anzahl der Pads im Footprint die Anzahl der Symbol-Pins nicht überschreitet.
-
Im Component Editor im Single Component Editing mode:
-
klicken Sie oben rechts in der Modellvorschau auf das Steuerelement
, um das Modell, das aktuell von der Komponente verwendet (referenziert) wird, im entsprechenden temporären Editor für diesen Modelltyp zu ändern;
-
klicken Sie oben rechts in der Modellvorschau auf das Steuerelement
und wählen Sie im Menü den Eintrag Select Model, um ein anderes Modell oder eine andere Revision desselben Modells zu suchen und auszuwählen.
-
-
Im Component Editor im Batch Component Editing mode:
-
klicken Sie mit der rechten Maustaste auf den Modelleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit, um das Modell, das aktuell von der Komponente verwendet (referenziert) wird, im entsprechenden temporären Editor für diesen Modelltyp zu ändern;
-
klicken Sie im Bereich Model Links auf das Feld Item ID des Modells und anschließend auf die Schaltfläche
, um ein anderes Modell oder eine andere Revision desselben Modells zu suchen und auszuwählen.
-
Revision that is being edited is not latest
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn die bearbeitete Komponentenrevision nicht die neueste im verbundenen Workspace verfügbare Revision ist.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
<ComponentName> (<ComponentRevisionID>) revision is Out of Date
dabei gilt:
-
ComponentNameist die Name der Komponente. -
ComponentRevisionIDist die Item-Revision-ID der Komponente.
Empfehlung zur Behebung
Wählen Sie zur Bearbeitung die neueste Komponentenrevision aus. Suchen Sie dazu die Komponente im Components panel, klicken Sie mit der rechten Maustaste auf ihren Eintrag im Bereich und wählen Sie Edit.
Unrecognized combination of Manufacturer+Part Number in Part Choice
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein falscher Eintrag für die Part Choice einer Komponente hinzugefügt wird und das Teil vom Workspace nicht abgerufen werden kann.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")
dabei gilt:
-
nist die laufende Nummer der fehlerhaften Part Choice.
Empfehlung zur Behebung
Geben Sie für die betroffene(n) Komponente(n) eine gültige Part Choice an.
-
Im Component Editor im Single Component Editing mode entfernen Sie ungültige Part Choices aus dem Bereich Part Choices und fügen neue, korrekte Part Choices hinzu.
-
Im Component Editor im Batch Component Editing mode geben Sie in der Komponentendefinitionsregion in die Felder Part Choice n die korrekten Werte ein. Beachten Sie, dass der Text einer Part-Choice-Feldwerts grau und kursiv angezeigt wird, solange der Eintrag fehlerhaft ist. Sobald beide Einträge korrekt sind, wird der Text normal und weiß angezeigt.
Verstöße im Zusammenhang mit Footprints
Duplicate Pad Designator
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell mehrere Pad-Objekte mit demselben Wert der Eigenschaft Designator aufweist.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
dabei gilt:
-
Identifier1ist die Kennung der ersten Instanz des Pads mit doppelter Bezeichnung, dargestellt durch die Netz-Bezeichner-Paarung und die Pad-Koordinaten. -
Layer1ist die Lage, auf der die erste Instanz des Pads mit doppelter Bezeichnung platziert ist. -
Identifier2ist die Kennung der zweiten Instanz des Pads mit doppelter Bezeichnung, dargestellt durch die Netz-Bezeichner-Paarung und die Pad-Koordinaten. -
Layer2ist die Lage, auf der die zweite Instanz des Pads mit doppelter Bezeichnung platziert ist.
Empfehlung zur Behebung
Weisen Sie den Pads des verknüpften Footprint-Modells unterschiedliche und eindeutige Bezeichner zu.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Wählen Sie die betroffenen Pads aus und ändern Sie die Werte ihrer Eigenschaft Designator im Pad mode of the Properties panel.
Duplicate Primitives
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell identische Objekte enthält, die an derselben Position auf derselben Lage platziert sind.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>
dabei gilt:
-
ObjectType1ist der Typ der ersten Instanz des doppelten Objekts. -
Identifier1ist die Kennung der ersten Instanz des doppelten Objekts; die Darstellung der Kennung hängt vom Objekttyp ab. -
Layer1ist die Lage, auf der die erste Instanz des doppelten Objekts platziert ist. -
ObjectType2ist der Typ der zweiten Instanz des doppelten Objekts. -
Identifier2ist die Kennung der zweiten Instanz des doppelten Objekts; die Darstellung der Kennung hängt vom Objekttyp ab. -
Layer2ist die Lage, auf der die zweite Instanz des doppelten Objekts platziert ist.
Empfehlung zur Behebung
Entfernen Sie doppelte Objekte aus dem Footprint-Modell.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Wählen Sie die doppelten Objekte aus und entfernen Sie sie mit dem Kurzbefehl Delete.
Mirrored Footprint (designed on bottom layer)
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell wesentliche Primitive (Pads, Leiterbahnen, Bögen, Füllungen, Regionen, Rechtecke, Textzeichenfolgen, Keepout-Objekte) auf der Bottom Layer enthält, aber keine solchen Primitive auf der Top Layer.
Im PCB-Footprint-Editor wird der Footprint für die Oberseite der Platine erstellt; falls erforderlich, kann er während des PCB-Designprozesses auf die Unterseite gespiegelt werden.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Bottom Layer Component
Empfehlung zur Behebung
Spiegeln Sie die Footprint-Primitive von der Bottom Layer auf die Top Layer.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Wählen Sie Primitive auf der Bottom Layer aus und ändern Sie ihre Eigenschaft Layer im entsprechenden Modus des Bereichs Properties auf Top Layer.
Missing Pad Designator
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell ein Pad-Objekt ohne angegebenen Wert für die Eigenschaft Designator enthält.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Missing Pad Designator on Pad: Pad <Identifier> on <Layer>
dabei gilt:
-
Identifierist die Kennung des Pads ohne angegebene Bezeichnung, dargestellt durch das Pad-Netz und die Koordinaten. -
Layerist die Lage, auf der das Pad ohne angegebene Bezeichnung platziert ist.
Empfehlung zur Behebung
Geben Sie Bezeichnerwerte für die Pads des verknüpften Footprint-Modells an.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
, um den Footprint, der aktuell von der Komponente verwendet (referenziert) wird, im temporären PCB-Footprint-Editor zu öffnen.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Wählen Sie ein betroffenes Pad aus und geben Sie den Wert seiner Eigenschaft Designator im Pad mode of the Properties panel an.
Offset Footprint Reference
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell seinen Referenzpunkt (Ursprung) außerhalb des von den Footprint-Objekten gebildeten Begrenzungsrechtecks hat.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Offset Component Origin
Empfehlung zur Behebung
Ändern Sie die Position des Referenzpunkts so, dass er sich innerhalb des von den Footprint-Objekten gebildeten Begrenzungsrechtecks befindet.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
, um den Footprint, der aktuell von der Komponente verwendet (referenziert) wird, im temporären PCB-Footprint-Editor zu öffnen.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Verwenden Sie die Befehle des Untermenüs Edit » Set Reference in den Hauptmenüs, um die aktuelle Position der Footprint-Referenz zu ändern.
Shorted Copper
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell Pad-Objekte enthält, die durch Objekte auf einer Kupferlage miteinander verbunden sind.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>
dabei gilt:
-
Identifier1ist die Kennung der ersten Instanz des Pads im kurzgeschlossenen Pad-Paar, dargestellt durch die Netz-Bezeichner-Paarung und die Pad-Koordinaten. -
Layer1ist die Lage, auf der die erste Instanz des Pads im kurzgeschlossenen Pad-Paar platziert ist. -
Identifier2ist die Kennung der zweiten Instanz des Pads im kurzgeschlossenen Pad-Paar, dargestellt durch die Netz-Bezeichner-Paarung und die Pad-Koordinaten. -
Layer2ist die Lage, auf der die zweite Instanz des Pads im kurzgeschlossenen Pad-Paar platziert ist.
Empfehlung zur Behebung
Entfernen Sie die Objekte auf der Kupferlage, die die Pads des verknüpften Footprint-Modells verbinden.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Wählen Sie die Objekte auf der Kupferlage aus, die die Pads verbinden, und ändern Sie sie so, dass sie die Pads nicht verbinden, oder entfernen Sie diese Objekte.
Unconnected Copper
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn ein mit einer im Component Editor definierten Komponente verknüpftes Footprint-Modell Objekte auf einer Kupferlage enthält und diese Objekte mit keinen Pad-Objekten verbunden sind. Wenn ein solcher Footprint in einem PCB-Design platziert wird, wird diesen Objekten auf der Kupferlage kein Netz zugewiesen, und sie werden zu isoliertem Kupfer.
Benachrichtigung
Im Messages-Bereich wird eine Benachrichtigung im folgenden Format angezeigt:
Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>
dabei gilt:
-
ObjectTypeist der Typ der Instanz des Objekts, das mit keinem Pad-Objekt im Footprint-Modell verbunden ist. -
Identifierist die Kennung des Objekts, das mit keinem Pad-Objekt im Footprint-Modell verbunden ist; die Darstellung der Kennung hängt vom Objekttyp ab. -
Layerist die Lage, auf der die Instanz des Objekts platziert ist, das mit keinem Pad-Objekt im Footprint-Modell verbunden ist.
Empfehlung zur Behebung
Ändern Sie das Footprint-Modell so, dass die Objekte, die derzeit mit keinem Pad-Objekt im Footprint-Modell verbunden sind, mit Pads verbunden werden.
-
Im Component Editor im Single Component Editing mode klicken Sie oben rechts in der Footprint-Vorschau auf das Steuerelement
.
-
Im Component Editor im Batch Component Editing mode klicken Sie mit der rechten Maustaste auf den Footprint-Eintrag im Bereich Model Links und wählen im Kontextmenü den Befehl Edit.
Das Footprint-Modell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären PCB-Footprint-Editor geöffnet. Platzieren Sie Objekte auf der/den Kupferlage(n), um eine Verbindung zwischen Footprint-Pads und Objekten herzustellen, die derzeit mit keinem Pad-Objekt verbunden sind, oder entfernen Sie diese unverbundenen Objekte.
Mit Symbolen verknüpfte Verstöße
Different pins between modes
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn einer der Anzeigemodi für ein Symbol einen zusätzlichen Pin besitzt.
Benachrichtigung
Im Panel Messageswird eine Benachrichtigung im folgenden Format angezeigt:
Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"
wobei:
-
DisplayModeder spezifische grafische Darstellungsmodus für das Symbol ist, in dem die zusätzlichen Pins gefunden wurden. Ein Symbol hat einen Modus Normal und kann bis zu 255 definierte Modi Alternate haben. Weitere Informationen finden Sie unter Erstellen mehrerer grafischer Anzeigemodi desselben Komponentensymbols. -
SymbolRevisionIDist die Item-Revision-ID des Symbols. -
PartDesignatorist der Designator des Symbolteils. -
PinNameist der Name des betroffenen Pins.
Empfehlung zur Behebung
Dieser Verstoß tritt typischerweise auf, wenn für ein Symbol ein alternativer grafischer Modus definiert wird und entweder:
- ein zusätzlicher Pin zu einem Anzeigemodus hinzugefügt wurde, der in einem anderen Anzeigemodus nicht angegeben ist, oder
- ein Pin mit einem anderen Designator und/oder Namen als ein in einem anderen Anzeigemodus angegebener Pin definiert wurde.
Zwischen grafischen Anzeigemodi muss nicht nur dieselbe Anzahl von Pins vorhanden sein, sondern die Pins müssen auch hinsichtlich Designator und Name identisch sein. Weitere Informationen finden Sie unter Erstellen mehrerer grafischer Anzeigemodi desselben Komponentensymbols.
Ändern Sie den Designator und/oder Namen der betroffenen Pins, sodass Anzahl der Pins sowie deren Eigenschaften Designator und Name zwischen den Anzeigemodi des Symbols übereinstimmen, oder entfernen Sie einen zusätzlichen Pin aus einem Anzeigemodus.
-
Klicken Sie im Component Editor im Modus Single Component Editing oben rechts in der Symbolvorschau auf das Steuerelement .
-
Klicken Sie im Component Editor im Modus Batch Component Editing mit der rechten Maustaste auf den Symboleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit.
Das Symbolmodell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären Schematic Library Editor geöffnet. Wählen Sie die betroffenen Pins aus und ändern Sie die Werte ihrer Eigenschaft Designator und/oder Name im Pin-Modus des Properties-Panels, oder entfernen Sie diese Pins mit dem Kürzel Delete.
Duplicate Pin Designators
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn zwei oder mehr Pins im Symbolmodell der Komponente denselben Designator haben.
Benachrichtigung
Im Panel Messageswird eine Benachrichtigung im folgenden Format angezeigt:
Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>
wobei:
-
DisplayModeder spezifische grafische Darstellungsmodus für das Symbol ist, in dem die doppelten Pins gefunden wurden. Ein Symbol hat einen Modus Normal und kann bis zu 255 definierte Modi Alternate haben. -
PinDesignatorListist die kommagetrennte Liste der Pin-Designatoren, die im betroffenen Symbol doppelt vorkommen.
Empfehlung zur Behebung
Ändern Sie den Designator der betroffenen Pins entsprechend, sodass jeder eine eindeutige Zuweisung hat.
-
Klicken Sie im Component Editor im Modus Single Component Editing oben rechts in der Symbolvorschau auf das Steuerelement .
-
Klicken Sie im Component Editor im Modus Batch Component Editing mit der rechten Maustaste auf den Symboleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit.
Das Symbolmodell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären Schematic Library Editor geöffnet. Wählen Sie die betroffenen Pins aus und ändern Sie die Werte ihrer Eigenschaft Designator im Pin-Modus des Properties-Panels, oder entfernen Sie diese Pins mit dem Kürzel Delete.
Missing Default Designator
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn für das Symbolmodell der Komponente kein Standard-Designator angegeben ist.
Benachrichtigung
Im Panel Messageswird eine Benachrichtigung im folgenden Format angezeigt:
Missing Default Designator
Empfehlung zur Behebung
Geben Sie für das betroffene Symbolmodell einen Standard-Designator an.
-
Klicken Sie im Component Editor im Modus Single Component Editing oben rechts in der Symbolvorschau auf das Steuerelement .
-
Klicken Sie im Component Editor im Modus Batch Component Editing mit der rechten Maustaste auf den Symboleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit.
Das Symbolmodell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären Schematic Library Editor geöffnet. Öffnen Sie den Symbol-Modus des Properties-Panels (aktiv, wenn im Designbereich kein Objekt ausgewählt ist) und geben Sie das erforderliche Designator-Präfix gefolgt vom Zeichen '?' im Feld Designator an (z. B. C?). Die Fragezeichen in den Designatoren von auf einem Schaltplanblatt platzierten Komponenten werden während des Prozesses Design Annotation durch tatsächliche Nummern ersetzt.
Missing Pin Designator
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn für einen Pin im Symbolmodell der Komponente kein Designator angegeben ist.
Benachrichtigung
Im Panel Messageswird eine Benachrichtigung im folgenden Format angezeigt:
Missing Pin Designator of the symbol <SymbolRevisionID>
wobei:
-
SymbolRevisionIDdie Item-Revision-ID des betroffenen Symbols ist.
Empfehlung zur Behebung
Geben Sie für jeden Pin im betroffenen Symbolmodell einen Designator an.
-
Klicken Sie im Component Editor im Modus Single Component Editing oben rechts in der Symbolvorschau auf das Steuerelement .
-
Klicken Sie im Component Editor im Modus Batch Component Editing mit der rechten Maustaste auf den Symboleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit.
Das Symbolmodell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären Schematic Library Editor geöffnet. Wählen Sie die betroffenen Pins aus und geben Sie die Werte ihrer Eigenschaft Designator im Pin-Modus des Properties-Panels an, oder entfernen Sie Pins mit dem Kürzel Delete.
Missing Pin Name
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn für einen Pin im Symbolmodell der Komponente kein Name angegeben ist.
Benachrichtigung
Im Panel Messageswird eine Benachrichtigung im folgenden Format angezeigt:
Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".
wobei:
-
SymbolRevisionIDdie Item-Revision-ID des betroffenen Symbols ist. -
PinDesignatorder Designator des betroffenen Pins ist.
Empfehlung zur Behebung
Geben Sie für jeden Pin im betroffenen Symbolmodell einen Namen an.
-
Klicken Sie im Component Editor im Modus Single Component Editing oben rechts in der Symbolvorschau auf das Steuerelement .
-
Klicken Sie im Component Editor im Modus Batch Component Editing mit der rechten Maustaste auf den Symboleintrag im Bereich Model Links und wählen Sie im Kontextmenü den Befehl Edit.
Das Symbolmodell, das aktuell von der Komponente verwendet (referenziert) wird, wird im temporären Schematic Library Editor geöffnet. Wählen Sie die betroffenen Pins aus und geben Sie die Werte ihrer Eigenschaft Name im Pin-Modus des Properties-Panels an, oder entfernen Sie diese Pins mit dem Kürzel Delete.
Hinweis
Im Panel Messageswird für jede einzelne Komponente nur eine Verstoßinstanz aufgeführt. Eine Komponente kann durchaus ein Symbol mit mehr als einem Pin ohne definierten Namen haben.
Missing Pins in Sequence
Default report mode:
Zusammenfassung
Dieser Verstoß tritt auf, wenn in der numerischen Folge der Pin-Designatorwerte des betroffenen Symbols fehlende Pins erkannt wurden. Zum Beispiel, wenn das Symbol Pins mit den Designatoren 1, 2, 5 hat und keine Pins mit den Designatoren 3 und 4 vorhanden sind.
Benachrichtigung
Im Panel Messageswird eine Benachrichtigung im folgenden Format angezeigt:
Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]
wobei:
-
PinDesignatorListdie kommagetrennte Liste der fehlenden Pin-Designatoren in der im betroffenen Symbol erkannten numerischen Folge ist. -
LowerPinDesignatorder minimale numerische Wert der im betroffenen Symbol erkannten Pin-Designatoren ist. -
UpperPinDesignatorder maximale numerische Wert der im betroffenen Symbol erkannten Pin-Designatoren ist.
Empfehlung zur Behebung
Fügen Sie im betroffenen Symbolmodell Pins mit den fehlenden Pin-Designatoren in der Folge hinzu oder ändern Sie die Pin-Designatoren so, dass sie eine lückenlose Folge ganzzahliger Werte bilden.
-
Klicken Sie im Component Editor im Modus Single Component Editing oben rechts in der Symbolvorschau auf das Steuerelement .
-
Im Komponenten-Editor im Modus „Batch Component Editing“ klicken Sie im Bereich Model Links mit der rechten Maustaste auf den Symboleintrag und wählen im Kontextmenü den Befehl Edit.
Das Symbolmodell, das derzeit von der Komponente verwendet (referenziert) wird, wird im temporären Schaltplanbibliotheks-Editor geöffnet. Fügen Sie über den Befehl Place » Pin in den Hauptmenüs die erforderliche Anzahl von Pins hinzu und geben Sie im Pin-Modus des Eigenschaftenbereichs Werte für deren Eigenschaft Designator an, sodass die Pin-Bezeichner im Symbol eine fortlaufende Sequenz ganzzahliger Werte bilden. Sie können auch die Eigenschaft Designator von Pins bearbeiten, die bereits im Symbol platziert sind.
Hinweis
Es gibt Komponenten, die keine fortlaufende Pin-Nummerierung verwenden, zum Beispiel ein BGA mit nicht fortlaufender Pin-Nummerierung; A1, A3, A5 (usw.). In diesem Fall wird empfohlen, die Komponente mit diesem Verstoß freizugeben und den Grund in den Release Notes zu vermerken. Alternativ setzen Sie die Prüfung Missing Pins in Sequence auf der Seite Data Management – Component Rule Checks im Dialog Preferences auf No Report.


