Erstellen eines PCB-Footprints

Die Fläche, die das Bauteil auf der gefertigten Leiterplatte einnimmt, wird durch den Bauteil-Footprint definiert. Ein typischer Footprint umfasst Pads und einen Bauteil-Bestückungsdruck und kann außerdem alle weiteren erforderlichen mechanischen Details enthalten. Im folgenden Footprint-Beispiel ist der größte Teil der Bauteilkontur auf einer mechanischen Lage (die grünen Linien) statt im (gelben) Bestückungsdruck definiert, da dieses Bauteil so montiert wird, dass es über einen Ausschnitt in der Leiterplatte hinausragt.

Der Footprint definiert den Platzbedarf des Bauteils und stellt die Verbindungspunkte zwischen den Pins/Pads des Bauteils und den Leiterbahnen auf der Leiterplatte bereit. 
Der Footprint definiert den Platzbedarf des Bauteils und stellt die Verbindungspunkte zwischen den Pins/Pads des Bauteils und den Leiterbahnen auf der Leiterplatte bereit.

Das auf diesem Footprint montierte Bauteil kann mithilfe von 3D-Körper-Objekten modelliert werden. Das 3D-Körper-Objekt dient als Container, in den ein Modell in einem gängigen MCAD-Format importiert werden kann, wie in der folgenden Abbildung gezeigt.

Ein geeignetes MCAD-Modell kann in ein 3D-Körper-Objekt importiert werden.
Ein geeignetes MCAD-Modell kann in ein 3D-Körper-Objekt importiert werden.

Auch wenn zahlreiche Ressourcen mit fertigen PCB-Bauteilen verfügbar sind (wie beispielsweise das Panel „Manufacturer Part Search“), werden Sie im Laufe Ihrer beruflichen Tätigkeit wahrscheinlich irgendwann ein benutzerdefiniertes PCB-Bauteil erstellen müssen. PCB-Bauteil-Footprints werden im PCB-Footprint-Editor mit denselben Grundobjekten erstellt, die auch im PCB-Editor verfügbar sind. Neben Footprints können auch Firmenlogos, Fertigungsdefinitionen und andere für das Leiterplattendesign erforderliche Objekte als PCB-Bauteile gespeichert werden.

Erstellen eines neuen PCB-Footprints

Footprints können direkt in Ihrem verbundenen Workspace erstellt werden. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie File » New » Library in den Hauptmenüs und anschließend im sich öffnenden Dialog New Library die Option Create Library Content » Footprint im Bereich Workspace des Dialogs.

    Erstellen Sie einen neuen Workspace-Footprint über den Dialog New Library
    Erstellen Sie einen neuen Workspace-Footprint über den Dialog New Library

  2. Geben Sie im sich öffnenden Dialog Create New Item die erforderlichen Informationen ein, stellen Sie sicher, dass die Option Open for editing after creation aktiviert ist, und klicken Sie auf OK. Der Workspace-Footprint wird erstellt und der temporäre PCB-Footprint-Editor geöffnet. Dabei wird ein .PcbLib Dokument als aktives Dokument angezeigt. Dieses Dokument wird entsprechend der Item-Revision im folgenden Format benannt: <Item><Revision>.PcbLib (z. B. PCC-001-0001-1.PcbLib). Verwenden Sie das Dokument, um den Footprint wie unten beschrieben zu definieren.

    Beispiel für die Bearbeitung der ersten Revision eines Workspace-Footprints – der temporäre PCB-Footprint-Editor stellt das Dokument bereit, in dem Sie Ihren Footprint definieren.
    Beispiel für die Bearbeitung der ersten Revision eines Workspace-Footprints – der temporäre PCB-Footprint-Editor stellt das Dokument bereit, in dem Sie Ihren Footprint definieren.

  3. Wenn der Footprint wie gewünscht definiert ist, speichern Sie ihn im Workspace. Verwenden Sie dazu das Bedienelement Save to Server rechts neben dem Footprint-Eintrag im Panel Projects. Der Dialog Edit Revision wird angezeigt. Darin können Sie bei Bedarf den Namen und die Beschreibung ändern sowie Freigabehinweise hinzufügen. Das Dokument und der Editor werden nach dem Speichern geschlossen.

Ein gespeicherter Workspace-Footprint kann beim Definieren eines Bauteils im Component Editor im Einzelbauteil-Bearbeitungsmodus oder im Stapelbearbeitungsmodus für Bauteile verwendet werden.

Workspace-Footprints können über das Panel Components durchsucht werden. Aktivieren Sie die Anzeige von Modellen, indem Sie oben im Panel auf die Schaltfläche  klicken und Models auswählen. Wählen Sie anschließend die Kategorie Footprints.

Um einen Workspace-Footprint zu bearbeiten, klicken Sie im Panel Components mit der rechten Maustaste auf dessen Eintrag und wählen Sie den Befehl Edit. Der temporäre Editor wird erneut geöffnet und der Footprint zur Bearbeitung geladen. Nehmen Sie die gewünschten Änderungen vor und speichern Sie das Dokument anschließend als nächste Revision des Workspace-Footprints.

 
 
 
 
 

Beim Speichern eines bearbeiteten Footprints in Ihrem Workspace können Sie dessen aktuellen Lebenszyklusstatus beibehalten. Dies wird über die Option Preserve lifecycle state (not recommended) gesteuert, die beim erneuten Speichern () im Dialog Create Revision verfügbar ist. Wenn diese Option aktiviert ist, wird die neue Footprint-Revision automatisch auf den Lebenszyklusstatus der vorherigen Revision gesetzt. Diese Funktion steht Benutzern zur Verfügung, denen die Berechtigung für die Operation Allow to skip lifecycle state change for new revisions zugewiesen wurde (weitere Informationen unter Festlegen globaler Operationsberechtigungen für einen Workspace).

  • Wenn Sie einen Workspace-Footprint ändern und diese Änderung als neue Revision des Footprints speichern, sind alle Workspace-Bauteile, die diesen Footprint verwenden, faktisch veraltet, da sie weiterhin die vorherige Revision verwenden. In den meisten Fällen werden Sie diese Workspace-Bauteile erneut speichern wollen, wobei die jeweiligen Modellverknüpfungen auf die neuesten verfügbaren Revisionen aktualisiert werden. Um diesen Prozess zu vereinfachen, ermöglicht ein Workspace in Verbindung mit Altium Designer das Aktualisieren übergeordneter Bauteile beim erneuten Speichern eines Workspace-Footprints, nachdem dieser über die Direktbearbeitungsfunktion geändert wurde.

    Weitere Informationen zum Aktualisieren übergeordneter Bauteile beim Speichern eines Domänenmodells finden Sie auf der Seite Erstellen & Bearbeiten von Inhalten.

  • Sie können den von einem Workspace-Bauteil verwendeten Workspace-Footprint auch direkt während der Bearbeitung dieses Workspace-Bauteils im Component Editor aktualisieren, und zwar im Einzelbauteil-Bearbeitungsmodus oder im Stapelbearbeitungsmodus für Bauteile.

  • Aus Sicht eines Entwicklers bündelt ein Workspace-Bauteil alle Informationen, die zur Darstellung dieses Bauteils in sämtlichen Designdomänen erforderlich sind, in einer einzigen Einheit. In dieser Hinsicht kann es als Container betrachtet werden – als „Sammelbehälter“, in dem alle Domänenmodelle und parametrischen Informationen gespeichert werden. Für seine Darstellung in den verschiedenen Domänen enthält ein Workspace-Bauteil jedoch nicht die Workspace-Domänenmodelle selbst, sondern Verknüpfungen zu diesen Modellen. Diese Verknüpfungen werden beim Definieren des Bauteils festgelegt.

  • PCB-Footprints können auch im Workspace erstellt werden, indem vorhandene Bauteilbibliotheken älterer Generationen (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) importiert werden. Die Benutzeroberfläche für diesen Prozess – Library Importer – bietet einen intuitiven Ablauf, der die zunächst ausgewählten Bibliotheken in Ihren Workspace importiert. Weitere Informationen finden Sie unter Library Importer.

  • Ein neuer Workspace-Footprint kann auch beim Definieren eines Workspace-Bauteils im Component Editor im Einzelbauteil-Bearbeitungsmodus erstellt werden.

  • Ein Footprint kann auch als Teil einer dateibasierten PCB-Footprint-Bibliothek erstellt werden.

Definieren eines PCB-Footprints

Footprints werden immer auf der Oberseite erstellt, unabhängig davon, auf welcher Seite der Leiterplatte sie letztendlich platziert werden. Dabei stehen dieselben Werkzeuge und Designobjekte wie im PCB-Editor zur Verfügung. Lagenspezifische Attribute, beispielsweise SMD-Pads und Lötstoppmaskendefinitionen, werden automatisch auf die entsprechenden Lagen der Unterseite übertragen, wenn Sie den Footprint während der Bauteilplatzierung auf die andere Seite der Leiterplatte spiegeln.

Designobjekte können auf jeder beliebigen Lage platziert werden. Die Kontur wird jedoch normalerweise auf der Lage Top Overlay (Bestückungsdruck) erstellt, die Pads auf der Multilayer-Lage (für die Anschlüsse von Durchsteckbauteilen) oder der oberen Signallage (für die Anschlüsse von SMD-Bauteilen). Wenn Sie den Footprint auf einer Leiterplatte platzieren, werden alle Objekte, aus denen er besteht, den jeweils definierten Lagen zugewiesen.

2D- und 3D-Ansichten eines Footprints für ein Joystick-Bauteil. Die 3D-Abbildung zeigt das importierte STEP-Modell des Bauteils. Beachten Sie, dass die Pads und der Bestückungsdruck des Bauteils unter dem STEP-Modell zu sehen sind.
2D- und 3D-Ansichten eines Footprints für ein Joystick-Bauteil. Die 3D-Abbildung zeigt das importierte STEP-Modell des Bauteils. Beachten Sie, dass die Pads und der Bestückungsdruck des Bauteils unter dem STEP-Modell zu sehen sind.

Die auf dieser Seite gezeigten Footprints dienen lediglich zur Veranschaulichung der erforderlichen Arbeitsschritte; ihre Abmessungen sind nicht exakt. Prüfen Sie die Spezifikationen eines neuen Footprints stets anhand des Datenblatts des Herstellers.

Die typische Vorgehensweise zum manuellen Erstellen eines Bauteil-Footprints ist:

  1. Bereiten Sie den Arbeitsbereich vor: Definieren Sie Fangoptionen und konfigurieren Sie Raster und Hilfslinien – mehr erfahren.

  2. Footprints sollten um den Referenzpunkt des Arbeitsbereichs in der Mitte des PCB-Footprint-Editors herum erstellt werden. Dieser Referenzpunkt ist der relative Ursprung des Arbeitsbereichs und der Punkt, an dem der Cursor den Bauteil-Footprint beim Platzieren und Verschieben aufnimmt (abhängig von der aktuellen Einstellung Object Snap Options auf der Seite PCB Editor – General des Dialogs Preferences). Verwenden Sie die Tastenkombination J, R, um direkt zum Referenzpunkt zu springen. Falls Sie vor dem Erstellen Ihres Footprints vergessen haben, zum Referenzpunkt zu wechseln, können Sie den Referenzpunkt mithilfe der Befehle im Untermenü Edit » Set Reference zu Ihrem Footprint verschieben:
    • Pin 1 – legt Pin 1 des Bauteil-Footprints als Bauteilreferenzpunkt fest.

    • Center – legt die Mitte des Bauteil-Footprints als Bauteilreferenzpunkt fest.

    • Location – legt eine benutzerdefinierte Position als Bauteilreferenzpunkt fest.

    Der gewählte Punkt wird auf 0,0 gesetzt – er wird zum neuen relativen Ursprung, und die Positionen aller Grundobjekte werden relativ zu diesem Punkt aktualisiert.

  3. Platzieren Sie die Pads (Place » Pad) entsprechend den Anforderungen des Bauteils. Nachdem Sie den Befehl „Place Pad“ ausgeführt haben, drücken Sie vor dem Platzieren des ersten Pads die Taste Tab, um das Panel Properties zu öffnen und sämtliche Pad-Eigenschaften festzulegen, darunter Designator, Size and Shape, Layer und Hole Size (bei einem Durchsteck-Pad). Die Pad-Bezeichnung wird bei jedem weiteren platzierten Pad automatisch hochgezählt. Setzen Sie bei einem SMD-Pad Layer auf Top Layer. Setzen Sie bei einem Durchsteck-Pad Layer auf Multi-Layer.

    Einige Footprints erfordern Pads mit unregelmäßiger Form. Diese lassen sich mit Pad-Objekten mit benutzerdefinierter Form erstellen. Weitere Informationen finden Sie auf der Seite Anpassen eines Padstacks.
    • Einer der wichtigsten Schritte beim Erstellen eines neuen Bauteil-Footprints ist das Platzieren der Pads, über die das Bauteil auf die Leiterplatte gelötet wird. Diese müssen exakt an den richtigen Positionen platziert werden, damit sie mit den Anschlüssen des physischen Bauteils übereinstimmen.
    • Auch bei der Vergabe der Pad-Bezeichnungen ist Sorgfalt geboten, da Altium Designer diese Eigenschaft verwendet, um die Pin-Nummern des Schaltplansymbols den Pads zuzuordnen.
  4. Um die Pads präzise zu platzieren, empfiehlt es sich, ein speziell für diese Aufgabe geeignetes Raster einzurichten. Verwenden Sie die Tastenkombination Ctrl+G, um den Dialog Editor für kartesische Raster zu öffnen, und die Taste Q, um das Raster von imperialen auf metrische Einheiten umzuschalten.

  5. Um ein Pad beim Verschieben mit der Maus präzise zu platzieren, verwenden Sie die Pfeiltasten, um den Cursor in Schritten des aktuellen Rasters zu bewegen. Wenn Sie zusätzlich Shift gedrückt halten, erfolgt die Bewegung in Schritten des zehnfachen Rasterabstands. Die aktuelle X-/Y-Position wird in der Statusleiste und im Heads-up-Display angezeigt. Das Heads-up-Display zeigt sowohl die Position als auch die Differenz zwischen der Position des letzten Klicks und der aktuellen Cursorposition an. Verwenden Sie die Tastenkombination Shift+H, um das Heads-up-Display ein- oder auszublenden. Alternativ können Sie ein bereits platziertes Pad per Doppelklick bearbeiten und die gewünschten X- und Y-Positionen im Panel Properties eingeben.

  6. Um den Abstand zwischen zwei Punkten im Arbeitsbereich zu prüfen, verwenden Sie Reports » Measure Distance (Tastenkombination Ctrl+M). Folgen Sie den Anweisungen in der Statusleiste.

  7. Pad-spezifische Attribute wie Lötstoppmaske und Pastenmaske werden automatisch anhand der Pad-Abmessungen und der geltenden Designregeln für Masken berechnet. Maskeneinstellungen lassen sich zwar für jedes Pad manuell festlegen, dies erschwert jedoch spätere Änderungen während des Leiterplattendesigns. Üblicherweise wird dies nur dann gemacht, wenn sich die betreffenden Pads nicht über Designregeln gezielt ansprechen lassen. Beachten Sie, dass die Regeln während des Leiterplattendesigns im PCB-Editor definiert werden.

  8. Verwenden Sie Leiterbahnsegmente, Kreisbögen und andere Grundobjekte, um die Bauteilkontur zu definieren, die auf der Lage Top Overlay im Bestückungsdruck der Leiterplatte erscheint. Wird das Bauteil beim Platzieren auf die Unterseite der Leiterplatte gespiegelt, wird der Bestückungsdruck automatisch auf die Lage Bottom Overlay übertragen.

  9. Platzieren Sie Leiterbahnsegmente und andere Grundobjekte auf einer mechanischen Lage, um zusätzliche mechanische Details wie einen Platzierungsfreiraum (Courtyard) zu definieren. Mechanische Lagen sind universell verwendbare Lagen. Sie sollten die Funktion dieser Lagen festlegen und sie für alle Footprints einheitlich verwenden.

  10. Platzieren Sie 3D-Körperobjekte, um die dreidimensionale Form des physischen Bauteils zu definieren, das auf der Leiterplatte montiert werden soll.

    Ein einem Footprint hinzugefügtes 3D-Körperobjekt kann auf ein 3D-Modell verweisen, das in den verbundenen Workspace hochgeladen wurde.
  11. Die Zeichenfolgen für Bauteilbezeichnung und Kommentar werden beim Platzieren im PCB-Arbeitsbereich automatisch zur Overlay-Lage des Footprints hinzugefügt. Zusätzliche Zeichenfolgen für Bauteilbezeichnung und Kommentar können durch Platzieren der speziellen Zeichenfolgen .Designator und .Comment auf einer mechanischen Lage eingefügt werden.

    Beim Platzieren von Zeichenfolgen für Bauteilbezeichnung und Kommentar muss im PCB-Editor ein Lagenpaar definiert werden. Dadurch wird sichergestellt, dass die Zeichenfolgen der Leiterplattenseite zugeordnet sind, auf der das Bauteil montiert ist, und beim Spiegeln des Bauteils ebenfalls auf die andere Seite der Leiterplatte wechseln. Weitere Informationen finden Sie im folgenden Abschnitt Umgang mit besonderen lagenspezifischen Anforderungen .
  12. Definieren Sie die Eigenschaften des Footprints (z. B. seinen Namen und seine Beschreibung) auf der Registerkarte Footprint des Panels Properties im Modus Library Options (aktiv, wenn im Arbeitsbereich kein Objekt ausgewählt ist; erreichbar über Tools » Footprint Properties Befehl aus den Hauptmenüs). Weitere Informationen zu den Optionen und Steuerelementen auf der Registerkarte Footprint des Panels finden Sie im folgenden Abschnitt.

  • Für eine einheitliche Pad-/Via-Definition über alle Footprints hinweg kann die Pad-/Via-Bibliothek (*.PvLib) zur Platzierung von Pads und Vias verwendet werden – mehr erfahren.
  • Der PCB-Footprint-Editor bietet außerdem einige Assistenten, um die Erstellung von Footprints zu beschleunigen:
    • Der IPC Compliant Footprint Wizard – erzeugt einen PCB-Footprint, der vollständig der Revision B der IPC-Norm 7351 entspricht – Generic Requirements for Surface Mount Design and Land Pattern Standard – mehr erfahren.
    • Der IPC Compliant Footprints Batch Generator – Verwenden Sie bei der Arbeit mit einer dateibasierten PCB-Footprint-Bibliothek den IPC Compliant Footprints Batch Generator, um schnell mehrere Footprints mit unterschiedlichen Dichtestufen zu erzeugen – mehr erfahren.
    • Der Footprint Wizard – ermöglicht es Ihnen, aus verschiedenen Gehäusetypen auszuwählen und die entsprechenden Informationen einzugeben. Anschließend erstellt er den Bauteil-Footprint für Sie – mehr erfahren.

Vorbereiten des Designbereichs

Standardmäßig werden Raster als Punkte angezeigt. Wenn Sie möchten, können Raster auch als Linien dargestellt werden. Dies wird im Dialog Grid Editor konfiguriert, den Sie durch Klicken auf die Schaltfläche Properties im Panel Properties öffnen, wie im folgenden Bild gezeigt. Alternativ können Sie das Tastenkürzel Ctrl+G verwenden, um den Dialog zu öffnen.

Im Bild wird das feine Raster als Punkte und das grobe Raster als Linien dargestellt.
Im Bild wird das feine Raster als Punkte und das grobe Raster als Linien dargestellt.

Eigenschaften-Panel

Wenn Sie einen Footprint im PCB-Footprint-Editor bearbeiten und im Designbereich gerade kein Designobjekt ausgewählt ist, zeigt das Panel Properties die Library Options an.

Die folgenden aufklappbaren Abschnitte enthalten Informationen zu den Optionen und Steuerelementen auf der Registerkarte General des Panels:

Die folgenden aufklappbaren Abschnitte enthalten Informationen zu den Optionen und Bedienelementen auf der Registerkarte Footprint des Panels:

Die Möglichkeit, Footprint-Eigenschaften über die Registerkarte Footprint des Panels Properties zu definieren, ist verfügbar, wenn die Option PCB.FootprintParameters im Dialog „Erweiterte Einstellungen“ aktiviert ist. Wenn diese Option deaktiviert ist, werden Footprint-Eigenschaften über den Dialog PCB Library Footprint () definiert. Diesen öffnen Sie, indem Sie den Befehl Tools » Footprint Properties in den Hauptmenüs auswählen, einen Footprint-Eintrag im Bereich Footprints des Panels PCB Library auswählen und auf die Schaltfläche Edit klicken oder auf einen Footprint-Eintrag im Bereich Footprints des Panels PCB Library doppelklicken.

Wenn ein Designobjekt ausgewählt ist, zeigt das Panel Optionen an, die für diesen Objekttyp spezifisch sind. Die folgende Tabelle führt die Objekttypen auf, die im PCB-Footprint-Designbereich platziert werden können. Klicken Sie auf einen Link, um die Eigenschaftenseite des jeweiligen Objekts aufzurufen.

3D-Körper Kreisbogen
Kreisbogen-Sperrfläche Füllfläche
Füllflächen-Sperrfläche Pad
Region Regions-Sperrfläche
Text (Zeichenfolge, Textrahmen) Leiterbahn
Leiterbahn-Sperrfläche Via

Lötstopp- und Pastenmaskenerweiterungen

Um zu prüfen, ob die Lötstopp- und/oder Pastenmasken im PCB-Footprint-Editor korrekt definiert wurden, öffnen Sie das Panel „Ansichtskonfiguration“ und aktivieren Sie für jede Maskenlage die Anzeigeoption () .

Der Ring, der am Rand jedes Pads in der Farbe der oberen Lötstoppmaskenlage erscheint, stellt den Rand der Lötstoppmaskenform dar, die um den Erweiterungswert unter dem mehrlagigen Pad hervorsteht. Dies liegt daran, dass multi-layer in der Zeichenreihenfolge der Lagen ganz oben steht und daher zuletzt gezeichnet wird. Die Layer Drawing Order wird auf der Seite „PCB-Editor – Anzeige“ des Dialogs Preferences festgelegt).

Die folgende Abbildung zeigt einen PCB-Footprint mit einem violetten Rand (der Farbe der oberen Lötstoppmaskenlage), der um jedes Pad herum erscheint.

Um die Lagen schnell durchzugehen, verwenden Sie den Einzellagenmodus (Shift+S) in Kombination mit Ctrl+Shift+Wheel roll.

Standardmäßig entspricht die auf den Maskenlagen erzeugte Form der Padform, erweitert oder verkleinert um den Wert, der durch die Designregeln Lötstoppmaskenerweiterung und Pastenmaskenerweiterung auf der Leiterplatte festgelegt ist, auf der der Footprint platziert wird. In manchen Fällen müssen Sie möglicherweise die Designregeln für die Erweiterung überschreiben und eine Maskenerweiterung als Padattribut angeben, eine Form aus einer Reihe vordefinierter Standardmaskenformen auswählen oder eine eigene benutzerdefinierte Form erstellen. In diesen Fällen können Sie die Pasten-/Lötstoppmasken für ein ausgewähltes Pad in dessen Properties-Panel konfigurieren – mehr erfahren. Alternativ können Sie geeignete Grundelemente (Regionen, Leiterbahnen usw.) auf der gewünschten Maskenlage platzieren.

In einer PCB-Bibliothek haben alle Objekte mit regelgesteuerter Lötstoppmaskenerweiterung einen Erweiterungswert von 0 mil. Diese Funktion ist verfügbar, wenn die Option PCB.SolderMaskZeroExpansion im Dialog „Erweiterte Einstellungen“ aktiviert ist. Wenn diese Option deaktiviert ist, beträgt der Wert der Lötstoppmaskenerweiterung für solche Objekte in einer PCB-Bibliothek 4 mil.

Parameterunterstützung

Parameter, die Objekten in Altium Designer zugewiesen werden, bieten eine leistungsstarke und flexible Möglichkeit, einem PCB-Design zusätzliche Informationen hinzuzufügen. Als Eigenschaften des übergeordneten Objekts können Parameter auf verschiedenen Ebenen zugewiesen werden, darunter Projekte, Dokumente, Vorlagen und einzelne Objekte innerhalb eines Designdokuments.

Weitere Informationen finden Sie unter Parameterobjekt.

Parameter, die im PCB-Designbereich verfügbar werden, können zum Filtern von Abfragen, Designregeln, Skripten und Varianten verwendet werden. Außerdem lassen sie sich in PCB-Bauteil-Footprints einsetzen, um benutzerdefinierte Zeichenfolgen in platzierten Footprints aufzurufen.

Parameter über einen Engineering Change Order

Die PCB-Parameterfunktionen basieren auf Funktionen des ECO-Mechanismus und des PCB-Dokuments, mit denen benutzerdefinierte Bauteilparameter in den PCB-Designbereich übertragen und dort beibehalten werden können. Diese Übertragung erfolgt nur in eine Richtung, und die übertragenen Parameter sind im PCB-Bereich schreibgeschützt.

Die Parameterübertragung erfolgt durch das Erstellen eines ECO vom Schaltplan zur Leiterplatte mit dem Menübefehl Design » Update PCB Document .

Wenn der ECO ausgeführt wird (über die Schaltfläche Execute Changes ), werden alle neuen benutzerdefinierten Schaltplan-Bauteilparameter an die entsprechende Footprint-Referenz im PCB-Design übertragen. 

Die Erkennung und Übertragung von Parametern auf die Leiterplatte wird durch die Projekteinstellungen (Project » Project Options) bestimmt. Legen Sie im Dialog Project Options das Verhalten für die Erkennung von Unterschieden und für Änderungen im Abschnitt Differences Associated with Parameters der Registerkarte Comparator und im Abschnitt Modifications Associated with Parameters der Registerkarte ECO Generation fest.

Um die übertragenen Parameter im PCB-Editor anzuzeigen, doppelklicken Sie auf ein Bauteil, um das Properties -Panel zu öffnen, und wählen Sie dann die Registerkarte Parameters . Auf dieser Registerkarte werden die aktuellen Benutzerparameter aufgeführt, die dem ausgewählten Bauteil-Footprint zugewiesen wurden. Die Parameter eines ausgewählten Bauteil-Footprints sind auch im Components -Panel verfügbar.

Links zu Referenzinformationen

Der PCB-Bereich übernimmt automatisch die vordefinierten ComponentLink Parameter aus dem Schaltplan. Diese werden als Parameterpaare (Beschreibung und Link-URL) definiert, die normalerweise Verweise auf bestimmte Dateien oder Internetadressen herstellen – in der Regel auf die Website eines Herstellers oder die URL eines Datenblatts.

Informationen zu Referenzlink-Parametern finden Sie unter Klickbare Links zu Referenzinformationen definieren in einer Schaltplanbibliothek und Auf klickbare Links zu Referenzinformationen zugreifen in einem PCB-Dokument.

Sowohl im Schaltplan- als auch im PCB-Designbereich werden die Links über das Rechtsklick-Kontextmenü aufgerufen, wenn sich der Mauszeiger über einem Bauteil befindet (unter den Optionen des Untermenüs References ). Die speziellen Parameter werden im Properties -Panel hinzugefügt und erscheinen nach der Übertragung in den PCB-Designbereich als Parameter des Bauteil-Footprints. 

Parameter in Quell-Footprints

Auf die Leiterplatte übertragene Parameter können verwendet werden, um über Bauteil-Footprints zusätzliche Informationen zur Leiterplattenfertigung oder zur Funktion bereitzustellen. Wenn Sie Footprints in der Quellbibliothek spezielle Parameterzeichenfolgen hinzufügen, werden die benutzerdefinierten Zeichenfolgen auf der mechanischen Ziellage oder der Bestückungsdrucklage interpretiert.

Eine spezielle Zeichenfolge, die einen benutzerdefinierten Parameter repräsentiert, kann dem Quell-Footprint des Bauteils über die Schaltfläche für spezielle Zeichenfolgen und das zugehörige Dropdown-Menü () im Properties -Panel hinzugefügt werden.

Im unten gezeigten Bibliotheks-Footprint wurde die spezielle Zeichenfolge .Designator auf der Lage „Mechanical 2“ platziert.

Eine spezielle Zeichenfolge, die einen Benutzerparameter repräsentiert, kann dem Bauteil-Footprint hinzugefügt werden.

Wenn dieser benutzerdefinierte Parameter auch Schaltplanbauteilen zugewiesen wurde und die Parameterdaten auf die Leiterplatte übertragen wurden, erscheinen die interpretierten Footprint-Zeichenfolgen sowohl in der Leiterplattenansicht als auch in den erzeugten Ausgabedateien. In diesem Fall enthält die spezielle Parameterzeichenfolge eine benutzerdefinierte Bauteilkennung, die die Bestückung erleichtert.

Die Verwendung von Benutzerparametern als spezielle Zeichenfolgen in Bauteil-Footprints kann eine Reihe weiterer benutzerdefinierter PCB-Anforderungen erfüllen, darunter Funktionsbeschriftungen für Schalter und Steckverbinder. Hierfür kann beispielsweise eine Parameterzeichenfolge „function“ auf der oberen Bestückungsdrucklage in den Footprints dieser Bauteiltypen platziert werden.

Um den interpretierten Wert spezieller Zeichenfolgen im Leiterplattenlayout anzuzeigen, aktivieren Sie die Option Special Strings im Bereich Additional Options der Registerkarte View Options im View Configuration Panel. Sonderzeichenfolgen werden in generierten Ausgabedateien immer umgewandelt.
Aktivieren Sie im Schaltplaneditor bei Bedarf die Option Display Names of Special Strings that have No Value Defined auf der Seite Schematic – Graphical Editing des Dialogs Preferences.

Parameterabfragen

Parameterzeichenfolgen im PCB-Bereich sind auch über die Abfragesprache von Altium Designer zugänglich und stehen daher für Objektfilterfunktionen zur Verfügung, einschließlich der Funktion „Ähnliche Objekte suchen“.

Um ähnliche Objekte auszuwählen, klicken Sie mit der rechten Maustaste auf ein Bauteil und wählen Sie anschließend Find Similar Objects im Kontextmenü, um den Dialog Find Similar Objects zu öffnen.

Der Dialog „Ähnliche Objekte suchen“ enthält einen Abschnitt Parameters, in dem die Filteroptionen nach Bedarf ausgewählt werden können.

Das Panel PCB Filter kann parameterspezifische Abfragebegriffe als Filterkriterien anwenden und zum Erstellen von Designregeln auf Basis von PCB-Parametern verwendet werden.

Für die Arbeit mit PCB-Footprint-Parametern stehen mehrere Abfragebegriffe zur Verfügung, darunter spezielle Funktionen zum Umwandeln von Zeichenfolgenwerten in Zahlen (wie StrToNumber). Bei der Umwandlung von Zeichenfolgenwerten werden Einheiten berücksichtigt (V, mA, mV, kOhm usw.), sodass das Abfrageergebnis durch die numerische Verarbeitung einer Parameterwert-Zeichenfolge bestimmt werden kann.

Folgende Einheitentypen werden unterstützt und können in den Abfragen angegeben werden:

  • % – Prozent
  • A – Strom
  • C – Temperatur
  • dB – Dezibel
  • F – Kapazität
  • G – Leitwert
  • H – Induktivität
  • Hz – Frequenz
  • Kg – Masse
  • m – Länge
  • Ohm – Widerstand
  • Q – Ladung
  • s – Zeit
  • V – Spannung
  • W – Leistung
  • Z – Impedanz

Für die Arbeit mit Footprint-Parametern von PCB-Bauteilen stehen mehrere Parameter-Abfragebegriffe zur Verfügung.

Das im obigen Dialog Query Helper gezeigte Beispiel verarbeitet den Parameter für die Nennspannung jedes Bauteils (mithilfe der Zeichenfolge-zu-Zahl-Umwandlung – StrToNumber(Unit Value, Unit Type)),  um festzustellen, ob sein Wert größer als 50 V ist. Bei Anwendung im Panel PCB Filter wird im Beispiel-Platinenlayout ein einzelnes Hochspannungsbauteil angezeigt, C1 (dessen Nennspannung 3 kV beträgt).

Die wissenschaftliche E-Notation wird ebenfalls unterstützt. Eine Abfrage zum Filtern von Kondensatorwerten über 1 nF würde beispielsweise wie folgt aussehen:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
Alternativ könnte die Zahlenumwandlungsfunktion sowohl für den zurückgegebenen ParameterValue and den Vergleichswert verwendet werden:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Regeln und Skripte

PCB-Parameterabfragen können auch in Skripten und Designregeln von Altium Designer verwendet werden. Letztere können Prüfungen zur Layoutvalidierung durchführen, etwa Footprint-Parameter erkennen, um die Bauteilplatzierung oder die Layerzuweisung zu bewerten. Beachten Sie, dass die im obigen Dialog Query Helper aufgeführten Funktionen in der Skriptsprache verfügbar sind.

Das folgende Beispiel zeigt die Abfrage zur Nennspannung von Kondensatoren (siehe Filterabfrage oben), angewendet auf eine Bauteilplatzierungsregel. Bei ihrer Ausführung werden bestimmte Mindestabstände für Bauteile geprüft, die als Hochspannungsbauteile (>50V) erkannt wurden.

Designregeln, die durch bestimmte, aus dem Schaltplanbereich übertragene Footprint-Parameter definiert werden, können zur Erkennung benutzerdefinierter Layoutbedingungen verwendet werden.

Ebenso können benutzerdefinierte PCB-Parameter verwendet werden, um die Kompatibilität von Bauteilen mit bestimmten Layern zu prüfen, beispielsweise wenn ein Bauteil nicht für das Wellenlöten und somit nicht für die Platzierung auf dem Bottom Layer geeignet ist. Hier könnte eine Abfrage zur Objektzuordnung, die einen benutzerdefinierten Parameter „WaveSoldering“ (Yes/No) verarbeitet, auf die Regel für zulässige Layer angewendet werden.

Die (Batch-)Regel prüft anschließend den Wert dieses Bauteilparameters und erzeugt einen Regelverstoß, wenn ein Bauteil nicht mit der Platzierung auf dem Bottom Layer kompatibel ist.

Varianten

Auf die PCB übertragene Parameter, die in Varianten des Designs (Designvarianten) enthalten sind, werden bei der Variantenauswahl verarbeitet.

In der Praxis wird ein variierter Bauteilparameter im PCB-Bereich dynamisch durch eine Abfragezeichenfolge erkannt oder beispielsweise über eine Sonderzeichenfolge auf einem Platinenlayer angezeigt. 

Benutzerdefinierte Footprint-Parameter

Diese Funktion ist verfügbar, wenn die Option PCB.FootprintParameters im Dialog „Erweiterte Einstellungen“ aktiviert ist.

Benutzerdefinierte Parameter für Footprints werden in Altium Designer unterstützt. Im Bereich Parameters auf der Registerkarte Footprint des Panels Properties  im Modus Library Options  können Footprint-Parameter angezeigt und bearbeitet werden, wenn im Designbereich des PCB-Footprint-Editors kein Objekt ausgewählt ist.

Wenn das Bauteil auf der PCB platziert ist, können Sie diese Parameter im Panel Properties  im Modus Component  auf der Registerkarte Parameters  sehen.

  • Footprint-Parameter von Bauteilen, die auf einer PCB platziert sind, werden an Footprints in Bibliotheken weitergegeben, die mit dem Befehl Make PCB Library oder Make Integrated Library im Hauptmenü des PCB-Editors erzeugt werden.
  • Footprint-Parameter werden von der Vergleichsfunktion von Altium Designer sowie für die generierten Pick-and-Place- und ODB++-Ausgaben unterstützt.
Altium MCAD CoDesigner unterstützt die Platzierung nativer MCAD-Bauteile in der MCAD-Umgebung gemäß der konfigurierten Verknüpfung. In einigen Fällen sind mehrere Footprints mit unterschiedlichen Modellen mit einem Bauteil verknüpft (z. B. eine LED, die auf zwei Arten auf einer PCB montiert werden kann: vertikal mit geraden Anschlussbeinchen oder horizontal mit abgewinkelten Anschlussbeinchen). Mithilfe der Footprint-Parameter können Sie nun von diesen unterschiedlichen Footprints auf die jeweiligen MCAD-Modelle verweisen. Erfahren Sie mehr über das Verknüpfen nativer ECAD- und MCAD-Designbauteile.

Bezeichner- und Kommentarzeichenfolgen

Standard-Bezeichner- und Kommentarzeichenfolgen

Wenn ein Footprint auf einer Platine platziert wird, erhält er einen Bezeichner und einen Kommentar auf Basis der Informationen aus der Schaltplanansicht des Designs. Platzhalter für die Bezeichner- und Kommentarzeichenfolgen müssen nicht manuell definiert werden, da sie beim Platzieren des Footprints auf einer Platine automatisch hinzugefügt werden. Die Positionen dieser Zeichenfolgen werden durch die Autoposition Option für Bezeichner- und Kommentarzeichenfolgen im Panel Properties im Modus Parameter bestimmt, wenn die Bezeichner- oder Kommentarzeichenfolge im Designbereich ausgewählt ist. Die Standardposition und -größe von Bezeichner- und Kommentarzeichenfolgen werden im jeweiligen Grundelement auf der Seite „PCB-Editor – Standardwerte“ des Dialogs Preferences konfiguriert.

Zusätzliche Bezeichner- und Kommentarzeichenfolgen

Es kann Situationen geben, in denen Sie zusätzliche Kopien der Bezeichner- oder Kommentartexte benötigen. Beispielsweise möchte Ihr Bestückungsdienstleister eine detaillierte Bestückungszeichnung, in der der Bezeichner innerhalb jeder Bauteilkontur angezeigt wird, während Ihr Unternehmen verlangt, dass der Bezeichner auf dem Bestückungsdruck der fertigen Leiterplatte direkt oberhalb des Bauteils steht. Diese Anforderung an einen zusätzlichen Bezeichner lässt sich erfüllen, indem Sie die spezielle Zeichenfolge .Designator in den Footprint aufnehmen. Die spezielle Zeichenfolge .Comment ist ebenfalls verfügbar, um die Position des Kommentartexts auf anderen Lagen oder an anderen Stellen festzulegen.

Um die Anforderungen des Bestückungsdienstleisters zu erfüllen, wird die Zeichenfolge .Designator im PCB-Footprint-Editor auf einer mechanischen Lage platziert. Anschließend können Ausdrucke, die diese Lage enthalten, als Teil der Bestückungsunterlagen erstellt werden.

Besondere lagenspezifische Anforderungen berücksichtigen

Für ein Leiterplattenbauteil können verschiedene besondere Anforderungen gelten, beispielsweise ein Klebepunkt oder eine Definition für eine abziehbare Lötstoppmaske. Viele dieser besonderen Anforderungen sind an die Leiterplattenseite gebunden, auf der das Bauteil montiert ist, und müssen beim Wenden des Bauteils auf die andere Leiterplattenseite wechseln.

Anstatt eine große Anzahl spezieller Lagen bereitzustellen, die möglicherweise nur selten verwendet werden, unterstützt der PCB-Editor von Altium Designer diese Anforderung durch eine Funktion namens Lagenpaare. Ein Lagenpaar besteht aus zwei mechanischen Lagen, die als Paar definiert wurden. Wenn ein Bauteil von einer Leiterplattenseite auf die andere gewendet wird, werden alle Objekte auf einer gepaarten mechanischen Lage auf die andere mechanische Lage dieses Paars übertragen. Bei diesem Ansatz wählen Sie eine geeignete mechanische Lage für den Klebepunkt (oder andere besondere Anforderungen) und definieren dessen Form mit den verfügbaren Objekten. Wenn Sie diesen Footprint auf einer Leiterplatte platzieren, müssen Sie die Lagenpaarung einrichten. Dadurch weiß die Software, auf welche Lage sie die Objekte übertragen muss, wenn dieses Bauteil auf die andere Leiterplattenseite gewendet wird. Lagenpaare können nicht im PCB-Footprint-Editor definiert werden; dies erfolgt im PCB-Editor.

Die Lagenpaarung muss definiert werden, before das Bauteil gewendet wird. Wenn die Paarung erst definiert wird, nachdem das Bauteil auf die Unterseite verschoben wurde, werden die Inhalte der mechanischen Lage zwar gespiegelt, bleiben aber auf ihrer ursprünglichen Lage. Wenn Sie vergessen haben, vor dem Wenden Lagenpaare zu erstellen, können Sie die auf der Leiterplatte platzierte Bauteilinstanz durch eine Aktualisierung aus der Bibliothek auffrischen.

Die Namen der mechanischen Lagen können direkt im Panel View Configurations bearbeitet werden, indem Sie mit der rechten Maustaste klicken und anschließend Edit Layer auswählen.

Ein gängiger Ansatz zur Verwaltung mechanischer Lagen besteht darin, jeder benötigten Funktion einer mechanischen Lage eine feste Lagennummer zuzuweisen. Dieser Ansatz erfordert, dass sich alle Entwickler an dasselbe Zuordnungs- und Nummerierungsschema halten. Außerdem kann er zu Schwierigkeiten führen, wenn Bauteile aus anderen Quellen bezogen werden, die nicht demselben Zuordnungs- und Nummerierungsschema folgen. Wenn ein anderes Schema verwendet wurde, müssen die Designobjekte von ihrer aktuellen mechanischen Lage auf die mechanische Lage verschoben werden, die dieser Funktion zugewiesen ist.

Dieses Problem wird durch die Einführung der Eigenschaft Layer Type gelöst. Wenn ein Bauteil aus einer Bibliothek im PCB-Editor platziert, von einer Bibliothek in eine andere kopiert oder durch IPC Footprint Wizard erstellt wird, werden vorhandene Zuweisungen von Lagentypen automatisch abgeglichen, unabhängig von den mechanischen Lagennummern, die diesen Lagentypen zugewiesen sind. Die Objekte werden entsprechend ihrem Lagentyp auf die richtigen Lagen verschoben. Wenn die Software keine Zuordnung anhand des Lagentyps vornehmen kann, greift sie auf die Zuordnung anhand der Lagennummer zurück.

Sowohl für einzelne mechanische Lagen als auch für Bauteil-Lagenpaare können Sie einen Lagentyp aus einer vordefinierten Liste auswählen. Die unten gezeigten Dialoge öffnen Sie, indem Sie mit der rechten Maustaste auf eine einzelne Lage klicken und anschließend den Befehl Edit Layer oder Add Component Layer aus dem Menü auswählen.

Ausführliche Informationen zu bauteilbezogenen mechanischen Lagentypen finden Sie auf der Seite Arbeiten mit mechanischen Lagen.

Einem PCB-Footprint eine Höhe hinzufügen

Für die einfachste Form der 3D-Darstellung können einem PCB-Footprint Höheninformationen hinzugefügt werden. Öffnen Sie dazu das Panel Properties im Modus Library Options (aktiv, wenn im Designbereich kein Objekt ausgewählt ist) und geben Sie die empfohlene Höhe des Bauteils im Feld Height auf der Registerkarte Footprint des Panels ein.

Während des Leiterplattenentwurfs können Designregeln für die Höhe definiert werden (klicken Sie im PCB-Editor auf Design » Rules). Diese prüfen typischerweise die maximale Bauteilhöhe innerhalb einer Bauteilklasse oder eines definierten Raums.

Eine bessere Möglichkeit zur Definition von Höheninformationen besteht darin, dem PCB-Footprint 3D-Körper hinzuzufügen.

Bauteile mit Routing-Primitiven verwalten

Wenn ein Design übertragen wird, wird der für jedes Bauteil angegebene Footprint aus den verfügbaren Bibliotheken abgerufen und auf der Leiterplatte platziert. Anschließend wird die Netzeigenschaft jedes Pads im Footprint auf den Namen des Netzes gesetzt, das im Schaltplan mit dem entsprechenden Bauteilpin verbunden ist. Alle Objekte, die ein Pad berühren, werden mit demselben Netz wie das Pad verbunden.

Der PCB-Editor enthält ein umfassendes Werkzeug zur Netzverwaltung. Wählen Sie zum Starten Design » Netlist » Configure Physical Nets aus den Hauptmenüs, um den Dialog Physische Netze konfigurieren zu öffnen. Klicken Sie auf die Schaltfläche Menu, um ein Menü mit Optionen aufzurufen. Klicken Sie auf das Dropdown-Menü in der Kopfzeile New Net Name, um das Netz auszuwählen, das den nicht zugewiesenen Primitiven zugeordnet werden soll.

Footprints mit mehreren Pads, die mit demselben Pin verbunden sind

Der unten gezeigte Footprint eines SOT223-Transistors besitzt mehrere Pads, die mit demselben logischen Pin des Schaltplanbauteils verbunden sind – Pin 2. Um diese Verbindung herzustellen, wurden zwei Pads mit demselben Bezeichner hinzugefügt – „2“. Wenn im Schaltplan-Editor der Befehl Design » Update PCB verwendet wird, um Designinformationen auf die Leiterplatte zu übertragen, zeigt die daraus resultierende Synchronisierung im PCB-Editor Verbindungslinien zu beiden Pads an, d. h., sie gehören zum selben Netz. Beide Pads können geroutet werden.

SOT223-Footprint mit zwei Pads mit dem Bezeichner 2.
SOT223-Footprint mit zwei Pads mit dem Bezeichner 2.

Bestückungsdruck vorbereiten

Um häufige Probleme bei der fertigungsgerechten Gestaltung (Design for Manufacture, DFM) zu beheben, die durch die Überlappung des Bestückungsdrucks mit freiliegendem Kupfer und Bohrungen entstehen, enthält der PCB-Footprint-Editor eine spezielle Funktion zur Vorbereitung des Bestückungsdrucks Ihrer Footprints. Diese Probleme lassen sich durch folgende Maßnahmen wirksam beheben:

  • automatisches Kürzen von Linien und Kreisbögen des Bestückungsdrucks;
  • automatisches Beschneiden oder Verschieben von Füllflächen und Regionen;
  • automatisches Verschieben von Texten des Bestückungsdrucks.
Das Werkzeug zur Vorbereitung des Bestückungsdrucks ist auch beim Leiterplattenentwurf verfügbar – mehr erfahren.

Um das Werkzeug zur Vorbereitung des Bestückungsdrucks im PCB-Footprint-Editor aufzurufen, verwenden Sie den Befehl Tools » Silkscreen Preparation aus den Hauptmenüs. Der Dialog Silkscreen Preparation wird geöffnet.

Verwenden Sie den Dialog, um die Einstellungen für das Beschneiden und Verschieben der Bestückungsdruckobjekte zu konfigurieren. Folgende Optionen stehen zur Verfügung:

  • Clip to Exposed Copper – aktivieren Sie diese Option, um Objekte an freiliegendem Kupfer automatisch zu beschneiden.
  • Clip to Solder Mask Openings – aktivieren Sie diese Option, um Objekte an Lötstoppmaskenöffnungen automatisch zu beschneiden.
  • Silkscreen Clearance – definieren Sie den minimal zulässigen Abstand zwischen Bestückungsdruckobjekten und freiliegendem Kupfer bzw. Lötstoppmaskenöffnungen und Bohrungen.
  • Min Remaining Length – wenn die Länge der Linie/des Bogens nach dem Beschneiden kleiner als der festgelegte Wert ist, werden die Objekte aus dem Footprint entfernt. Beachten Sie, dass diese Länge von Endpunkt zu Endpunkt und nicht von Kante zu Kante gemessen wird – Bild anzeigen.
  • Move Text – aktivieren Sie diese Option, um Texte des Bestückungsdrucks von freiliegendem Kupfer / Lötstoppmaskenöffnungen und Bohrungen wegzubewegen, wenn der Abstand zwischen ihnen kleiner als Silkscreen Clearance ist. Die Verschiebung wird durch den Wert Max Distance begrenzt.
  • Fill & Region – wählen Sie eine Aktion für Füllflächen und Regionen aus, wenn deren Abstand zu freiliegendem Kupfer / Lötstoppmaskenöffnungen und Bohrungen kleiner als Silkscreen Clearance ist:
    • None – Füllflächen und Regionen bleiben unverändert.
    • Clip – Füllflächen und Regionen werden beschnitten, um Silkscreen Clearance einzuhalten. Füllflächen werden gegebenenfalls in Regionen umgewandelt.
    • Move – Füllflächen und Regionen werden von freiliegendem Kupfer / Lötstoppmaskenöffnungen und Bohrungen wegbewegt. Die Verschiebung wird durch den Wert Max Distance begrenzt.
  • Max Distance – legen Sie die maximale Entfernung fest, um die Texte, Bauteilbezeichner, Füllflächen und Regionen verschoben werden können, um Silkscreen Clearance einzuhalten.

Klicken Sie auf OK, um Objekte des Bestückungsdrucks gemäß den Einstellungen im Dialog zu beschneiden und/oder zu verschieben.

Wenn eine Aktion für ein Objekt nicht ausgeführt werden kann (z. B. wenn ein Text aufgrund der Begrenzung durch Max Distance nicht verschoben werden kann), wird im Panel Messages eine Meldung für dieses Objekt angezeigt.

Nachfolgend wird ein Beispiel für die Funktionsweise des Werkzeugs zur Vorbereitung des Bestückungsdrucks gezeigt.

Javascript

Erstellen eines Footprints mit dem IPC-konformen Footprint-Assistenten

Der IPC Compliant Footprint Wizard erzeugt einen Leiterplatten-Footprint, der vollständig der Revision B des IPC-Standards 7351 entspricht – Generic Requirements for Surface Mount Design and Land Pattern Standard. Anstatt direkt mit den Footprint-Abmessungen zu arbeiten (wie der Footprint-Assistent ), verwendet der IPC Compliant Footprint Wizard die Abmessungen des Bauteils selbst und berechnet anschließend geeignete Pad- und weitere Footprint-Eigenschaften gemäß den vom IPC veröffentlichten Algorithmen.

Anstatt die Eingabe der Eigenschaften der Pads und Leiterbahnen zu verlangen, die zur Definition des Footprints verwendet werden, nutzt der Wizard die tatsächlichen Bauteilabmessungen als Eingabewerte. Auf Grundlage der für den Standard IPC-7351 entwickelten Formeln erzeugt der Wizard anschließend den Footprint mit Standardobjekten von Altium Designer, beispielsweise Pads und Leiterbahnen.

  • Dieser Dialog entspricht der Revision B des IPC-Standards 7351 – Allgemeine Anforderungen an das Design und die Anschlussflächenmuster oberflächenmontierter Bauteile. IPC-7351B wurde 2010 veröffentlicht und ersetzt IPC-7351A (veröffentlicht 2007).

  • Um in Altium Designer auf den IPC Compliant Footprint Wizard zuzugreifen, muss die Softwareerweiterung IPC Footprint Generator installiert sein. Diese Erweiterung wird standardmäßig zusammen mit Altium Designer installiert. Sie kann manuell installiert oder entfernt werden.

    Weitere Informationen zur Verwaltung von Erweiterungen finden Sie auf der Seite Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Um den IPC Compliant Footprint Wizard zu starten, wählen Sie Tools » IPC Compliant Footprint Wizard in den Hauptmenüs eines PCB-Bibliotheksdokuments.

Wählen Sie auf der Seite Select Component Type die Bauteilfamilie aus, für die Sie auf der Seite Select Component Type einen Footprint erstellen möchten. Der Vorschaubereich auf der rechten Seite des Assistenten passt sich dynamisch an und zeigt das aktuell ausgewählte Bauteil sowie die Gehäusetypen an, die erzeugt werden können. Die folgende Tabelle enthält die vom Assistenten unterstützten Bauteil- und Gehäusetypen.

Name Beschreibung Enthaltene Gehäuse
BGA Ball Grid Array BGA, CGA
BQFP Quad-Flat-Gehäuse mit Schutzvorsprüngen BQFP
CAPAE Aluminium-Elektrolytkondensator CAPAE
CFP Keramisches Dual-Flat-Gehäuse – gekürzte und geformte Gullwing-Anschlüsse CFP
Chip-Array Chip-Array Chip-Array
DFN Dual-Flat-Gehäuse ohne Anschlussbeinchen DFN
CHIP Chip-Bauteile, 2 Anschlüsse Kondensator, Induktivität, Widerstand
CQFP Keramisches Quad-Flat-Gehäuse – gekürzte und geformte Gullwing-Anschlüsse CQFP
DPAK Transistorgehäuse DPAK
LCC Chipträger ohne Anschlussbeinchen LCC
LGA Land Grid Array LGA
MELF MELF-Bauteile, 2 Anschlüsse Diode, Widerstand
MOLDED Vergossene Bauteile, 2 Anschlüsse Kondensator, Induktivität, Diode
PLCC Quadratischer Kunststoff-Chipträger mit J-förmigen Anschlüssen PLCC
PQFN Quad-Flat-Gehäuse ohne Anschlussbeinchen mit zurückgesetzten Kontaktflächen PQFN
PQFP Quad-Flat-Kunststoffgehäuse PQFP, PQFP mit freiliegendem Pad
PSON Small-Outline-Gehäuse ohne Anschlussbeinchen mit zurückgesetzten Kontaktflächen PSON
QFN Quad-Flat-Gehäuse ohne Anschlussbeinchen QFN, LLP
QFN-2ROW Quadratisches Quad-Flat-Gehäuse ohne Anschlussbeinchen, 2 Reihen Zweireihiges QFN
SODFL Small-Outline-Diode mit flachen Anschlüssen SODFL
SOIC Small-Outline-IC-Gehäuse, Rastermaß 1,27 mm – Gullwing-Anschlüsse SOIC, SOIC mit freiliegendem Pad
SOJ Small-Outline-Gehäuse – J-förmige Anschlüsse SOJ
SON Small-Outline-Gehäuse ohne Anschlussbeinchen SON, SON mit freiliegendem Pad
SOP, TSOP Small-Outline-Gehäuse – Gullwing-Anschlüsse SOP, TSOP, TSSOP
SOT143/343 Small-Outline-Transistor SOT143, SOT343
SOT223 Small-Outline-Transistor SOT223
SOT23 Small-Outline-Transistor 3 Anschlüsse, 5 Anschlüsse, 6 Anschlüsse
SOT89 Small-Outline-Transistor SOT89
SOTFL Small-Outline-Transistor mit flachen Anschlüssen 3 Anschlüsse, 5 Anschlüsse, 6 Anschlüsse
DRAHTGEWICKELT Präzisions-Drahtwickelinduktivität, 2 Anschlüsse Induktivität

Die nachfolgenden Seiten des Assistenten ändern sich je nach ausgewähltem Bauteiltyp. Folgen Sie den intuitiven Seiten des Assistenten, um den jeweiligen Bauteil-Footprint nach Bedarf einzurichten. Einige Hinweise zur Arbeit mit dem IPC Compliant Footprint Wizard:

  • Alle Abmessungen werden im Assistenten in metrischen Einheiten (mm) eingegeben.

  • Gesamtabmessungen des Gehäuses, Anschlussinformationen, Abstände zwischen den Anschlussfersen, Lötkehlen und Toleranzen können eingegeben und sofort angezeigt werden.

    Änderungen an den IPC-Toleranzen können zu Leiterplatten-Footprints führen, die nicht IPC-konform sind.

  • Mechanische Abmessungen, wie Informationen zu Courtyard, Bestückung und Bauteilkörper (3D), können eingegeben werden.

  • Der Wizard kann erneut aufgerufen werden und erleichtert so die Überprüfung und Anpassung.

  • In jeder Phase wird eine Vorschau des Footprints angezeigt. Für jeden Bauteiltyp wird der Bereich Preview bei verschiedenen Einstellungen dynamisch aktualisiert, um neue Positionen, Größen usw. anzuzeigen. Im Bereich Preview können Sie auf  oder  klicken, um zwischen der 2D- und der 3D-Vorschau umzuschalten.

  • Bei Bedarf können Sie vor dem Erzeugen des Modells eine Vorschau des 3D-STEP-Modells anzeigen. Klicken Sie nach der Auswahl des Bauteiltyps auf einer beliebigen Seite im Wizard auf Generate STEP Model Preview, um im Bereich Preview eine Vorschau des 3D-STEP-Modells anzuzeigen.

  • Bei Gehäusen mit einem großen Wärmeableitungspad (ab einer Größe von 2,1 mm × 1,6 mm) werden die Pastenmasken in kleine Füllflächen aufgeteilt.

  • Bei Gehäusen mit Gullwing-Anschlüssen werden die Pads gekürzt, damit sie nicht unter den Gehäusekörper reichen.

  • Bei kleinen Gehäusen mit einem großen zentralen Wärmeableitungspad werden die außenliegenden Pads gekürzt, um den gemäß IPC-Norm erforderlichen Abstand zwischen den Pads sicherzustellen.

  • Wenn Pads gekürzt werden, wird im Dialog eine Warnung angezeigt.

  • Name und Beschreibung des Footprints werden anhand der Informationen, die Sie im Wizard  eingeben, automatisch vorgeschlagen, können aber an die Anforderungen Ihrer Organisation angepasst werden.

  • Gemäß der IPC-Norm unterstützt der Assistent drei Footprint-Varianten (_L, _N, _M), die jeweils auf eine unterschiedliche Bestückungsdichte der Leiterplatte abgestimmt sind.

  • Die Schaltfläche Finish kann jederzeit angeklickt werden, um den aktuell in der Vorschau angezeigten Footprint zu erzeugen. Wenn Sie auf Finish klicken, bevor Sie den gesamten Wizard durchlaufen haben, wird der Footprint mit den Systemstandardeinstellungen für den ausgewählten Bauteiltyp erstellt.

  • Wenn Sie mit einer dateibasierten PCB-Footprint-Bibliothek arbeiten, verwenden Sie den Batch-Generator für IPC-konforme Footprints, um schnell mehrere Footprints mit unterschiedlichen Bestückungsdichten zu erzeugen.

Wenn der Assistent aus einer dateibasierten PCB-Footprint-Bibliothek aufgerufen wird, steht die Seite Footprint Destination zur Verfügung. Dort können Sie den Speicherort für den neu erstellten Footprint auswählen – Bild anzeigen:

  • Wählen Sie Existing PcbLib File, wenn der Footprint in einer vorhandenen PCB-Bibliotheksdatei gespeichert werden soll. Sie können die Datei direkt im Textfeld angeben oder über  einen Dialog öffnen, um nach der gewünschten Datei zu suchen.
  • Wählen Sie New PcbLib File, wenn Sie den Footprint in einer neuen PCB-Bibliotheksdatei speichern möchten. Geben Sie den Namen der neuen PCB-Bibliotheksdatei in das Textfeld ein. Das System ergänzt den Namen der neuen Bibliotheksdatei um die Erweiterung .PcbLib.
  • Wählen Sie Current PcbLib File, um den Footprint in der angezeigten PCB-Bibliotheksdatei zu speichern.
  • Aktivieren Sie Produce 3D/STEP model, um ein 3D-STEP-Modell zu erzeugen.
  • Wenn Sie über eine gültige Lizenz für „MCAD Co-Designer - SOLIDWORKS(R)“ verfügen, können Sie das Modell als Dateityp Parasolid speichern. Klicken Sie auf das Dropdown-Menü rechts neben Format und wählen Sie anschließend Parasolid. Die im Textfeld External File angezeigte Datei ist nun eine *.x_t-Datei. Hier werden Name und Speicherort der zu speichernden Datei angegeben.
  • Wählen Sie entweder Embedded (Standard) oder External File. Wählen Sie External File, um Ihr 3D-STEP-Modell als externe Datei zu speichern. Der standardmäßige Dateityp ist STEP, und der Dateiname wird im Textfeld External File mit *.step als Dateierweiterung angezeigt. Klicken Sie bei Bedarf auf , um den Ordner zu suchen und auszuwählen, in dem das erzeugte 3D-STEP-Modell gespeichert werden soll.

Erstellen eines Footprints mit dem Footprint-Assistenten

Der PCB-Footprint-Editor enthält einen Footprint Wizard. Mit diesem Wizard können Sie aus verschiedenen Gehäusetypen auswählen und die entsprechenden Informationen eingeben. Anschließend wird der Bauteil-Footprint für Sie erstellt. Beachten Sie, dass Sie im Footprint Wizard die erforderlichen Abmessungen für die Pads und den Bauteil-Bestückungsdruck eingeben.

Um den Footprint Wizard zu starten, wählen Sie Tools » Footprint Wizard aus den Hauptmenüs oder klicken Sie mit der rechten Maustaste in den Designbereich und wählen Sie den Befehl Tools » Footprint Wizard aus dem Kontextmenü.

Verwenden Sie die Seite Component patterns, um das Muster des zu erstellenden Bauteils festzulegen. Wählen Sie das gewünschte Muster aus der Liste und anschließend über das Dropdown-Menü die Einheit für das Bauteil (Imperial (mil) oder Metric (mm)). Folgende Muster stehen zur Verfügung:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Die nachfolgenden Seiten des Assistenten ändern sich je nach ausgewähltem Bauteilmuster. Folgen Sie den intuitiven Seiten des Assistenten, um den jeweiligen Bauteil-Footprint wie benötigt einzurichten.

Klicken Sie beim Festlegen des Pad-Benennungsschemas für einen Footprint mit dem Muster Edge Connectors, Leadless Chip Carriers (LCC) oder Quad Packs (QUAD) auf den grünen Pfeil, um die Reihenfolge bzw. Richtung der Benennung zu ändern – Bild anzeigen.

Erstellen eines Bauteilberichts

Um einen Bericht für den aktiven PCB-Footprint zu erstellen, wählen Sie den Befehl Reports » Component aus den Hauptmenüs. Nach dem Aufruf des Befehls wird der Bericht (<PCBLibraryDocumentName>.CMP) im selben Ordner wie das zugrunde liegende PCB-Bibliotheksdokument erstellt und automatisch als aktives Dokument im Hauptdesignfenster geöffnet. Der Bericht enthält unter anderem die Footprint-Abmessungen sowie eine Aufschlüsselung der primitiven Objekte, aus denen der Footprint besteht, und der Lagen, auf denen sie sich befinden.

Der Bericht wird dem Panel Projects als freies Dokument im Unterordner Documentation\Text Documents hinzugefügt.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents