Freigabe in einen Workspace
Auf einen Blick
- Ermitteln Sie, welche Quell-, Fertigungs-, Bestückungs-, Varianten- und benutzerdefinierten Datensätze einbezogen werden sollen und wie Sie die erforderlichen Output Jobs zuweisen.
- Lernen Sie die Optionen für Freigabeziele, die Benennungsschemata für Workspace-Elemente und die Einstellungen für Zielrevisionen kennen.
- Durchlaufen Sie die Freigabephasen und erfahren Sie, wie sich automatisierte Freigabebefehle auf die Prüfung, die Berichterstellung und die Veröffentlichung in PLM-Systemen auswirken.
Mit der Ansicht Release in Online Mode erfolgt der Freigabeprozess in mehreren Phasen. Die Einträge auf der linken Seite der Ansicht zeigen Ihnen auf einen Blick, in welcher Phase Sie sich gerade befinden:
-
Configure Server Release – In dieser Phase des Freigabeprozesses legen Sie fest, welche Datentypen Sie generieren möchten: Quelldaten (werden immer generiert), Fertigungsdaten und Bestückungsdaten (für das Basisdesign und jede erkannte Variante).
-
Validate Project – Diese nächste Phase des Freigabeprozesses wird automatisch ausgeführt, wenn in den zugewiesenen OutJob-Dateien mindestens ein Bericht vom Typ „Validation“ erkannt wird. Alle Generatoren für Validierungsausgaben, die in einer dem freizugebenden Datenelement zugewiesenen Output-Job-Datei definiert sind, werden ausgeführt.
-
Generate Data – Diese nächste Phase des Freigabeprozesses wird automatisch ausgeführt. Hier werden alle anderen Ausgaben ausgeführt, die in den OutJob-Dateien für die enthaltenen Datenelemente definiert sind. Dabei werden die Daten generiert, die in den entsprechenden Zielelementen im Workspace freigegeben werden sollen.
-
Review Data – Nachdem alle Validierungsprüfungen bestanden und die Ausgabedaten generiert wurden, können Sie in dieser Phase des Freigabeprozesses die generierten Daten überprüfen.
-
Upload Data – Nachdem Sie die Freigabe in der vorherigen Phase bestätigt haben, wird diese nächste Phase automatisch gestartet. Sie zeigt lediglich den Fortschritt beim Hochladen der Daten in die Revisionen der entsprechenden Datenelemente im Ziel-Workspace an.
-
Execution Report – Dies ist die letzte Phase des Prozesses, die eine Zusammenfassung der Freigabe liefert. Über Navigationslinks können Sie schnell zu den generierten Elementrevisionen im Explorer-Panel wechseln. Wenn Sie Project Releaser im Rahmen eines Prozesses zur Freigabe und Veröffentlichung in einem PLM aufgerufen haben, wird die Schaltfläche
angezeigt. Klicken Sie darauf, um den zugrunde liegenden Workflow des Prozesses fortzusetzen und die Daten im PLM zu veröffentlichen.
-
Publish to PLM – Diese Phase ist nur vorhanden, wenn die Freigabe im Rahmen des entsprechenden aktivierten Prozesses erfolgt (zur Freigabe und anschließenden Veröffentlichung in einem PLM). Diese Phase wird automatisch gestartet, wenn Sie in der vorherigen Phase auf die Schaltfläche
klicken (oder direkt aufgerufen, wenn der Befehl Prepare & Release & Publish to PLM aus dem Menü der Schaltfläche
verwendet wurde). Der Dialog Login Credentials wird angezeigt. Geben Sie Username und Password für Ihre PLM-Instanz ein und wählen Sie die gewünschte PLM-Vorlage aus (die in der Form <PLMInstance>:<PublishingTemplate>angezeigt wird).
Online-Phase 1 – Serverfreigabe konfigurieren
In dieser Phase des Freigabeprozesses legen Sie fest, welche Datentypen Sie generieren möchten. Folgende Datenelemente können freigegeben werden:
- Source Data – eine Momentaufnahme des Quelldesigns.
- Fabrication Data – die Daten, die ein Leiterplattenfertiger zur Herstellung der unbestückten Leiterplatte benötigt.
- Assembly Data for the Base Design (no variations) – die Daten, die ein Bestückungsdienstleister benötigt, um die unbestückte Leiterplatte gemäß einer Stückliste für das unveränderte Basisdesign vollständig zu bestücken.
-
Assembly Data for Design
Variant n– die Daten, die ein Bestückungsdienstleister benötigt, um die unbestückte Leiterplatte gemäß einer Stückliste fürVariant ndes Basisdesigns zu bestücken.
Die Anzahl der Bestückungsdatensätze entspricht dem Basisdesign (ohne Varianten) und allen für dieses Design definierten und erkannten Varianten.

Phase 1 des Projektfreigabeprozesses – Festlegen, was in der Freigabe enthalten sein soll (welche Daten generiert werden sollen).
Das Element Source Data ist immer in einer Freigabe enthalten. Die anderen Datenelemente können optional einbezogen werden.
Zuweisung von Output Jobs
Damit die Elemente Fabrication Data und Assembly Data in einer Freigabe enthalten sind, muss ihnen mindestens eine Output-Job-Datei zugewiesen sein. Wenn die Namen Ihrer Output-Job-Dateien mit den Zeichenfolgen „fab“ und „ass“ beginnen, werden diese OutJobs beim ersten Aufrufen der Ansicht Release automatisch den Abschnitten Fabrication Data bzw. Assembly Data zugewiesen. Andernfalls müssen Sie die entsprechenden OutJobs jeweils manuell zuweisen. Dies ist auf der Registerkarte Release Options des Dialogs Project Release Options möglich (klicken Sie zum Öffnen auf die Schaltfläche
unten links in der Ansicht).

Weisen Sie den jeweiligen Datensätzen nach Bedarf OutJobs zu.
Freigabeziel wechseln
Auf der Registerkarte Release Options des Dialogs Project Release Options können Sie auch das Freigabeziel ändern und zwischen dem verwalteten (Online) und dem nicht verwalteten (Offline) Betriebsmodus wechseln. Drei Optionen stehen zur Verfügung:
-
Unmanaged - Folder(Offline): Wählen Sie diese Option, um die generierten Daten in einem lokalen Ordner freizugeben. Der Pfad des Stammordners wird auf der Registerkarte Output Path des Dialogs angegeben. Standardmäßig ist er auf[OutputPath]festgelegt (unter Verwendung des Pfads, der im Feld Output Path auf der Registerkarte „Options“ des Dialogs „Project Options“ definiert ist). -
Unmanaged - Zip(Offline): Wählen Sie diese Option, um die generierten Daten in einem lokalen Ordner freizugeben. Die Daten werden in eine einzelne ZIP-Datei gepackt. Pfad und Name der ZIP-Datei werden auf der Registerkarte Output Path des Dialogs angegeben. Standardmäßig ist dies auf[OutputPath][ProjectName].zipfestgelegt (unter Verwendung des Pfads, der im Feld Output Path auf der Registerkarte Options des Dialogs Project Options definiert ist). -
Managed - <WorkspaceName>(Online): Wählen Sie diese Option, um die Daten im Workspace (mitWorkspaceName) freizugeben, mit dem Sie aktuell verbunden sind.

Wechseln Sie im Rahmen der Freigabeoptionen für das Projekt das Freigabeziel – also den Ort, an den die generierten Daten gesendet werden sollen.
Benennungsschemata für Workspace-Items festlegen
Wenn Sie ein Projekt zum ersten Mal im Ziel-Workspace freigeben, können Sie festlegen, wie die Zieldaten-Items in diesem Workspace benannt werden, deren Revisionen die generierten Daten aufnehmen. Dies erfolgt auf der Registerkarte Item Naming des Dialogs Project Release Options, den Sie über die Schaltfläche
unten links in der Ansicht öffnen (oder indem Sie auf den Link Target Revision für einen freizugebenden Datensatz klicken und im Kontextmenü Edit wählen). Auf dieser Registerkarte können Sie:
- Den Namen für das Projekt festlegen. Standardmäßig ist hier der tatsächliche Projektname eingetragen.
-
Standard-Benennungsschemata für die verschiedenen Daten-Items festlegen, die im Rahmen der Freigabe generiert werden können. Klicken Sie in ein Feld in der Spalte Item ID und anschließend auf die Schaltfläche
rechts im Feld, um den Dialog Choose Item (eine Variante des Panels Explorer) zu öffnen. Darin können Sie ein vorhandenes Item im aktuell verbundenen Workspace als Ziel auswählen.
Um eines der Benennungsschemata zu ändern, klicken Sie auf die Schaltfläche Settings, um den Dialog Naming Template Settings zu öffnen.

Legen Sie den Projektnamen und die Benennung der generierten Daten-Items im Ziel-Workspace fest. Hier können die Felder bearbeitet werden, da das Projekt noch nicht freigegeben wurde.
Die folgenden Makroformate werden in einer Benennungsvorlage unterstützt:
-
Parameter-based – unterstützt die Verwendung von Parametern in eckigen Klammern (z. B.
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based – unterstützt die Verwendung numerischer Quantifizierer in geschweiften Klammern (z. B.
{0000},{9000}).
Zielrevision steuern
Klicken Sie zurück in der Hauptansicht auf den Link neben einem Eintrag Target Revision, um ein Befehlsmenü zu öffnen, das in der folgenden Abbildung dargestellt ist:

Zugriff auf die Steuerelemente zum Festlegen der Zielrevision für einen Datensatz, der im Rahmen der Freigabe generiert werden soll – bewegen Sie den Mauszeiger über die Abbildung, um sie anzuzeigen.
Welche Befehle verfügbar sind, hängt davon ab, ob das Item bereits erstmals freigegeben wurde. Nachfolgend sind alle möglichen Befehle aufgeführt:
-
Auto <RevisionID> – mit diesem Eintrag überlassen Sie die Verwaltung der Revisionen dem System, sodass Sie keine geplanten Revisionen erstellen müssen, wenn noch keine vorhanden sind.
RevisionIDzeigt die nächste Revision des Items auf derselben Ebene innerhalb des zugewiesenen Revisionsbenennungsschemas an (wenn die aktuelle Revision beispielsweiseA.1ist, zeigt dieser BefehlA.2als Ziel an). -
Next <RevisionID> – dieser Eintrag ist erst nach der ersten Freigabe des Items verfügbar. Damit können Sie die Zielrevision schnell auf der nächsthöheren Ebene innerhalb des zugewiesenen Revisionsbenennungsschemas erhöhen.
RevisionIDzeigt die nächste Revision an (wenn die aktuelle Revision beispielsweiseA.1ist, würde dieser Befehl das Ziel aufB.1ändern). -
Custom – mit diesem Eintrag können Sie eine bestimmte Revision eines Ziel-Items auswählen, indem Sie im Dialog Custom Revision ID eine benutzerdefinierte Revisions-ID festlegen. Je nach verwendetem Revisionsbenennungsschema kann der Dialog bis zu drei Felder für Ebenen-IDs enthalten. Beachten Sie, dass die ID der ersten geplanten Revision des Items nach dessen Erstellung und vor der Freigabe von Daten in dieser ersten Revision jederzeit geändert werden kann (d. h., solange sie sich noch im Zustand
Plannedbefindet). - Browse – mit diesem Eintrag wählen Sie eine vorhandene Ziel-Item-Revision aus, in der die Daten freigegeben werden sollen. Dazu wird der Dialog Choose Target Item (eine Variante des Explorer-Panels) geöffnet.
- Edit – mit diesem Eintrag öffnen Sie die Registerkarte Item Naming des Dialogs Project Release Options, auf der Sie den Namen des zu erstellenden Ziel-Items (und der ersten Revision) ändern können.
- Navigate – mit diesem Eintrag navigieren Sie schnell zum Item im Panel Explorer (wenn es bereits freigegeben wurde und die nächste Revision im geplanten Zustand vorhanden ist).
Der Eintrag oben im Menü zeigt die aktuell ausgewählte bzw. festgelegte Zielrevision an.
Details zur Datengenerierung aufrufen
Klicken Sie auf das Steuerelement Details ganz rechts in der Kopfzeile eines Datensatzes, um Details dazu aufzurufen, was genau von diesem Datensatz generiert wird. Klicken Sie auf das Steuerelement Hide Details, um diese erweiterte Ansicht wieder einzuklappen. Mit Ausnahme des Datensatzes Source Data stammen die generierten Daten aus einer oder mehreren zugewiesenen Output-Job-Dateien. Über das Steuerelement Configure können Sie schnell auf den zugrunde liegenden OutJob zugreifen.

Öffnen Sie die Detailansicht eines Datensatzes, um zu sehen, welche Daten generiert werden – bewegen Sie den Mauszeiger über die Abbildung, um sie anzuzeigen.
Zusätzliche Einstellungen
Auf der Seite Data Management – Servers des Dialogs Preferences können Sie zusätzliche Einstellungen für die Projektfreigabe festlegen:
-
Der Ordner, in dem generierte Dateien vor dem Hochladen in den aktuell verbundenen Workspace zwischengespeichert werden, kann auf den automatisch festgelegten Speicherort (
\Users\<ProfileName>\AppData\Local\Temp\Releasesbei einer Standardinstallation) eingestellt oder manuell durch einen Ordner Ihrer Wahl ersetzt werden. - Aktivieren Sie die Option Delete contents after exiting release mode, damit der temporäre Speicherordner nach Abschluss des Freigabeprozesses geleert wird.
- Dem Namen jeder generierten Ausgabe können optional die Item-ID und die Revisions-ID vorangestellt werden (z. B.
[FAB-Kame_FMU-A.1] Validation.PDF). Aktivieren Sie dazu die Option Prepend revision HRID to file names.
Nachdem Sie die Datenelemente, die im Rahmen der Freigabe erstellt werden sollen, wie gewünscht konfiguriert haben, klicken Sie unten rechts in der Ansicht auf die Schaltfläche
, um fortzufahren.
Im Rahmen der Vorbereitung werden vor der Freigabe mehrere Prüfungen durchgeführt. Dazu gehören:
- Sicherstellen, dass das Projekt und alle Dateien gespeichert wurden.
- Sicherstellen, dass das Projekt und alle relevanten Dateien gegebenenfalls in das Versionskontrollsystem (VCS) eingecheckt wurden.
- Sicherstellen, dass jedes aktivierte Datenelement einen Namen erhalten hat.
- Sicherstellen, dass der Benutzer berechtigt ist, das Ziel-Item und dessen Revision zu erstellen.
- Erstellen der erforderlichen Ziel-Items und geplanten Revisionen im Workspace, sofern sie noch nicht vorhanden sind, und Sicherstellen, dass für bereits vorhandene Items die nächste Revision verwendet wird.
Falls Probleme festgestellt werden, werden Ihnen Lösungsmöglichkeiten angeboten, um diese zu beheben, beispielsweise das Speichern lokal geänderter Dateien und deren Einchecken in das VCS.
Zu diesem Zeitpunkt wird das Item Source Data generiert. Dabei wird eine Momentaufnahme der Quelldateien des Designprojekts für die Ziel-Item-Revision freigegeben.
Online-Phase 2 – Projekt validieren
Nachdem Phase 1 ohne Probleme abgeschlossen wurde, wird diese nächste Phase des Freigabeprozesses automatisch ausgeführt, wenn in den zugewiesenen OutJob-Dateien mindestens ein Validierungsbericht erkannt wird. Alle definierten Generatoren für Validierungsausgaben, die in einer dem freizugebenden Datenelement zugewiesenen Output-Job-Datei festgelegt sind, werden ausgeführt. Dazu können folgende Prüfungen gehören:
- Differences Report – Mithilfe des Vergleichswerkzeugs wird ermittelt, ob die Quell- und PCB-Designdokumente korrekt synchronisiert sind.
- Electrical Rules Check – Prüfung der elektrischen und zeichnerischen Korrektheit des erfassten Quelldesigns.
- Design Rules Check – Prüfung der Gültigkeit des PCB-Dokuments hinsichtlich der festgelegten Designvorgaben auf Leiterplattenebene.
-
BOM Checks – Prüfung auf mögliche Verstöße im Zusammenhang mit Design-Items oder der Bauteilauswahl im Quell-BOM-Dokument (
*.BomDoc), sofern vorhanden. - Footprint Comparison Report – Vergleich der Footprints auf der Leiterplatte mit ihrer Quellbibliothek, um sicherzustellen, dass sie aktuell sind und übereinstimmen.
- Component State Checking – Prüfung auf Bauteile, die sich in eingeschränkten Zuständen befinden. Im Rahmen der Konfiguration legen Sie für jeden aktuell definierten Zustand jeder aktuell definierten Lebenszyklusdefinition im Ziel-Workspace fest, welche Aktion ausgeführt werden soll: keine Aktion, eine Warnung oder das Generieren eines Fehlers. Letzteres verhindert die Freigabe des Designs. Außerdem wird bei der Prüfung ein praktischer HTML-Bericht generiert, mit dem Sie auf einen Blick erkennen können, welche Bauteile im Design keinen gültigen Zustand aufweisen.
- Environment Configuration Compliance Check – Prüfung, ob ausschließlich Datenelemente verwendet werden, die durch die für Ihre zugewiesene Rolle verfügbare Umgebungskonfiguration zugelassen sind, sofern zutreffend. Diese Prüfung kann auch sicherstellen, dass alle Design-Items aus einem Workspace stammen.
Bei erfolgreicher Validierung wird das Symbol
mit dem Text Passed angezeigt. Andernfalls wird das Symbol
mit dem Text Failed angezeigt.
Online-Phase 3 – Daten generieren
Nachdem Phase 2 ohne Probleme abgeschlossen wurde, wird diese nächste Phase des Freigabeprozesses automatisch ausgeführt. Hier werden alle übrigen Ausgaben ausgeführt, die in den den enthaltenen Datenelementen zugewiesenen OutJob-Dateien definiert sind. Dabei werden die Daten generiert, die in die jeweiligen Ziel-Items im Workspace freigegeben werden sollen.
Wie in den anderen Phasen wird der Fortschritt der Generierung durch Symbole angezeigt. In dieser Phase fällt dies aufgrund der längeren Ausführungsdauer deutlicher auf:
– noch nicht ausgeführt/generiert.
– wird ausgeführt/generiert.
– erfolgreich generiert.
– Generierung fehlgeschlagen.
Online-Phase 4 – Daten überprüfen
Nachdem alle Validierungsprüfungen bestanden und die Ausgabedaten generiert wurden, können Sie in dieser Phase des Freigabeprozesses die generierten Daten überprüfen.

Überprüfen Sie die generierten Daten und stellen Sie sicher, dass alles den Erwartungen entspricht, bevor Sie die Freigabe bestätigen und die Daten in den Workspace hochladen.
Standardmäßig zeigt die Seite eine einfache, kompakte Ansicht der generierten Daten an. Wechseln Sie zu einer detaillierteren Ansicht, indem Sie auf das Steuerelement Details des gewünschten Abschnitts klicken.

Klicken Sie auf ein Steuerelement Details, um für den zugehörigen Abschnitt von der einfachen zur detaillierten Ansicht der generierten Daten zu wechseln. Durch Klicken auf das Steuerelement Hide Details wechseln Sie wieder zurück.
Zustände der Ausgabegenerierung in der Detailansicht
Die folgende Tabelle enthält die möglichen Ausgabezustände, die während der Datengenerierung in der Detailansicht angezeigt werden:
Zustand |
Beschreibung |
|---|---|
|
Die Ausgabe wurde noch nicht generiert bzw. ist nicht vorhanden. |
|
Die Ausgabe wurde generiert, seitdem wurden jedoch Änderungen am Design vorgenommen, sodass diese Daten nicht mehr aktuell sind. |
|
Die Ausgabe wird derzeit generiert. |
|
Die Ausgabe basiert auf einer Validierung und hat einen fehlerfreien Bericht erzeugt. Bei einem ERC-Bericht liegen entweder keine Fehler vor, oder deren Schweregrad liegt innerhalb der für diesen Bericht festgelegten maximal tolerierten Fehlerstufe. |
|
Die Ausgabe wurde erfolgreich generiert. Dies gilt nicht für validierungsbasierte Ausgaben. |
|
Die Ausgabe wurde nicht erfolgreich generiert. Bei einer validierungsbasierten Ausgabe bedeutet dies, dass Fehler in den Quelldesigndokumenten vorliegen, aufgrund derer bestimmte Prüfungen fehlschlagen. Bei einer Standardausgabe konnte die Ausgabe nicht erfolgreich generiert werden. Möglicherweise treten bei einer Validierung vor der Generierung schwerwiegende Fehler auf, oder die Konfiguration des zugehörigen Ausgabegenerators in der Output-Job-Datei ist fehlerhaft. |
Klicken Sie in der kompakten Ansicht der generierten Daten auf einen View-Link, um die zugehörige Datendatei oder den zugehörigen Dateisatz zu öffnen – entweder im entsprechenden Editor in Altium Designer (z. B. im CAM-Editor für Gerber-Dateien oder komprimierte/unkomprimierte ODB++-Dateien) oder in der entsprechenden externen Anwendung (z. B. Microsoft Excel für eine Stückliste). Doppelklicken Sie in der Detailansicht auf einen Eintrag, um nur diese Datei anzuzeigen.
Ein von vielen Entwicklern verwendeter Test zur Prüfung der Freigabereife besteht darin, die für die aktuelle Freigabe generierten Gerber-Dateien mit denen der vorherigen Freigabe zu vergleichen. Klicken Sie auf den Compare Gerber-Link neben einer Gerber-Ausgabe und wählen Sie eine frühere Freigabe aus dem Dropdown-Menü aus, um die vorbereiteten Gerber-Daten mit denen der ausgewählten Freigabe zu vergleichen. Ihr Standardbrowser öffnet Ihren Unternehmens-Workspace und zeigt die Ergebnisse an.

Zugriff auf die Gerber-Vergleichsfunktion über Project Releaser, bevor die Daten in einem Workspace freigegeben werden.
► Erfahren Sie mehr über die Funktion Gerber Comparison (Altium 365 Workspace, Enterprise Server Workspace).
Wenn Sie nach der Prüfung der Daten Änderungen vornehmen müssen, klicken Sie unten rechts in der Ansicht auf die Schaltfläche
. Ein Bestätigungsdialog weist Sie darauf hin, dass alle generierten Daten verloren gehen. Wenn Sie auf OK klicken, wird die Freigabe abgebrochen und Sie kehren zu Phase 1 des Prozesses zurück.
Wenn alle generierten Daten korrekt sind, setzen Sie die Freigabe fort, indem Sie auf die Schaltfläche
klicken (ebenfalls unten rechts in der Ansicht). Der Dialog Confirm Release wird angezeigt und fasst die Konfigurationen des Projekts zusammen, die im Workspace freigegeben werden. Hier können Sie außerdem Name (standardmäßig lautet der Eintrag hier [ProjectName]), Description sowie relevante Freigabehinweise hinzufügen.

Bestätigung der freizugebenden Daten anhand der generierten Item-Revisionen sowie die Möglichkeit, Name/Beschreibung zu ändern und Freigabehinweise hinzuzufügen.
Online-Phase 5 – Daten hochladen
Nach der Bestätigung der Freigabe in der vorherigen Phase wird diese nächste Phase automatisch aufgerufen. Sie zeigt lediglich den Fortschritt beim Hochladen der Daten in die Revisionen der entsprechenden Daten-Items im Workspace an.

Diese Phase zeigt lediglich den Fortschritt beim Hochladen der generierten Daten in die verknüpften Item-Revisionen im Workspace an.
Online-Phase 6 – Ausführungsbericht
Dies ist die letzte Phase des Prozesses, die eine Zusammenfassung der Freigabe bereitstellt.

Der Abschlussbericht zur Freigabe.
Verwenden Sie die Navigationslinks, um im Explorer-Panel – Ihrem Portal zu Ihrem Workspace – schnell auf die zugehörige Item-Revision mit den freigegebenen Daten (Fertigungsdaten, Bestückungsdaten und benutzerdefinierte Datensätze) zuzugreifen.

Anzeige der freigegebenen Projektdaten direkt im Workspace mithilfe des Panels Explorer.
Anzeigen des freigegebenen Projekts
Bei einem Workspace-Projekt steht Ihnen nach Abschluss der Freigabe eine zusätzliche Funktion zur Verfügung. Wenn Sie auf den Project Page-Link klicken, den letzten Navigationslink oben auf der Seite Execution Report, wird das Panel Explorer geöffnet. Es zeigt das Projekt in Project View an – diese Funktion ist nur für Workspace-Projekte verfügbar.

Mithilfe von Project View können Sie ein Workspace-Projekt im Panel Explorer genauer untersuchen.
Der Bereich Releases (unten links in der Ansicht) zeigt eine Zusammenstellung der zum Projekt gehörenden Projektfreigaben an, einschließlich einer Zusammenfassung jeder Freigabe und der zugehörigen Pakete. Klicken Sie in diesem Bereich auf die Schaltfläche
, um den Dialog zur Stapeländerung des Status zu öffnen. Damit können Sie den Lebenszyklusstatus mehrerer Items derselben Freigabe gleichzeitig in einem einzigen Stapelprozess ändern.
Weitere Informationen zu Projektfreigaben finden Sie im Web Viewer des Ziel-Workspace, den Sie über die Schaltfläche
im Explorer-Panel öffnen. Im Web Viewer eines Workspace können Sie in der Ansicht Releases auf alle zum Projekt gehörenden Freigaben zugreifen – bei einem von einem lokalen Server bereitgestellten Workspace in der Ansicht Manufacture. Die Seite listet alle Projektfreigaben auf, wobei der neueste Eintrag oben steht. Über die Schaltfläche zum Öffnen lässt sich eine einzelne Freigabe in Manufacturing Portal des Workspace öffnen. Die Ansicht Manufacturing Portal bietet detailliertere Informationen zur ausgewählten Freigabe, darunter die zugehörigen Freigabepaketdateien, den vollständigen Satz an Designdokumenten sowie Angaben zu Herstellern und Lieferanten der Bauteile. Beachten Sie, dass die Funktion Send to Manufacturer nur in einem Altium 365 Workspace verfügbar ist. ► Weitere Informationen finden Sie auf der Seite Freigabeansicht im Altium 365 Workspace.
Das war's – nach der Freigabe Ihres Projekts können Sie die Ansicht Release einfach schließen (über die Schaltfläche
unten rechts in der Ansicht). Wenn Sie dasselbe Projekt später erneut freigeben müssen, ermöglicht Project Releaser dies schnell und einfach und erhöht die Ziel-Item-Revisionen automatisch.
Veröffentlichen in einer PLM-Instanz
Related pages: PLM-Integration (Altium 365 Workspace, Enterprise Server Workspace), Veröffentlichen in einem PLM-System
Sie können ein Design im Rahmen der Ausführung von Project Releaser in Altium Designer in einer PLM-Instanz veröffentlichen. Der Veröffentlichungsvorgang verwendet eine Veröffentlichungsvorlage, die als Teil der Integrationskonfiguration dieser PLM-Instanz definiert ist und steuert, wie Daten an das PLM-System übertragen werden. Diese Funktion steht über einen entsprechend konfigurierten Prozess zur Verfügung. Im Lieferumfang der Installation ist eine Beispielprozessdefinition enthalten – Project Releaser with Publish –, deren zugrunde liegender Workflow die Veröffentlichung in der integrierten PLM-Instanz als zusätzliche Phase des Project Releaser ermöglicht. Das Workflow-Diagramm ist unten dargestellt.

Das Workflow-Diagramm der standardmäßigen Beispielprozessdefinition Project Releaser with Publish
Nach der Aktivierung kann der Prozess zur Veröffentlichung in einer PLM-Instanz im Rahmen von Project Releaser in Altium Designer über das Untermenü Project » Project Releaser für das aktive Projekt oder über das Kontextuntermenü Project Releaser aufgerufen werden. Letzteres erreichen Sie, indem Sie im Panel Projects mit der rechten Maustaste auf den Eintrag des Designprojekts klicken.

Aufrufen des Prozesses zur Veröffentlichung in einer PLM-Instanz im Rahmen von Project Releaser
Project Releaser wird mit einer zusätzlichen Phase – 7. Publish to PLM – angezeigt. Außerdem steht im Menü der Schaltfläche
der Befehl Prepare & Release & Publish to PLM zur Verfügung, wenn Sie Project Releaser ohne Unterbrechung zur Prüfung der generierten Daten und des Ausführungsberichts ausführen möchten.

Ein zusätzlicher Befehl zum Ausführen von Project Releaser ohne Unterbrechung zur Prüfung der generierten Daten und des Ausführungsberichts
Wenn Sie Project Releaser mit dem Standardbefehl Prepare ausführen, wird nach der Prüfung und Freigabe der Daten in der Phase Execution Report die Schaltfläche
angezeigt. Klicken Sie darauf, um den zugrunde liegenden Workflow des Prozesses fortzusetzen und die Daten im PLM-System zu veröffentlichen. Der Dialog Login Credentials wird angezeigt. Geben Sie Username und Password für Ihre PLM-Instanz ein und wählen Sie die gewünschte PLM-Vorlage aus (die in der Form <PLMInstance>:<PublishingTemplate> angezeigt wird).

Der Dialog Login Credentials, der bei der ersten Veröffentlichung in der PLM-Instanz aufgerufen wird.
Klicken Sie auf die Registerkarte Diagram, um den zugrunde liegenden Workflow des Prozesses anzuzeigen.

Die Registerkarte Diagram des Dialogs Login Credentials
Klicken Sie auf die Schaltfläche
, um den Veröffentlichungsvorgang gemäß diesem Workflow fortzusetzen.

)
