Freigabe des Designprojekts
Auf einen Blick
- Erfahren Sie, wie Quell-, Leiterplattenfertigungs- und Bestückungsdaten organisiert und aufbewahrt werden, einschließlich der Bestückungsausgaben für Designvarianten.
- Lernen Sie, wie Versionskontrolle, Freigaben in einem einzigen Durchlauf und optionale Validierungsprüfungen die Integrität der Freigabe sichern.
- Entdecken Sie, wie Sie den Project Releaser vorbereiten und aufrufen, erzeugte Ausgaben vor dem endgültigen Speichern prüfen und freigegebene Daten über unterstützte Veröffentlichungsoptionen teilen können.
Sobald ein Design bereit für den Einsatz in der Praxis ist, muss es freigegeben werden – ein Prozess, der häufig unterschätzt wird.
Ohne einen geregelten und grundsoliden Freigabeprozess kann die langfristige Nachverfolgung eines stetig weiterentwickelten Produkts zahlreiche Fallstricke bergen. Stellen Sie sich vor, Sie müssten eine frühere Revision Ihres Produkts erneut freigeben und würden feststellen, dass die erforderlichen Design-Quelldateien bei der damaligen Freigabe nie vollständig als Momentaufnahme gesichert wurden! Kein Problem: Nehmen Sie einfach die generierten Ausgabedateien aus den entsprechenden Ordnern dieser Freigabe – die bewährten Gerber-Dateien und alle zusätzlichen Fertigungs- und Bestückungsinformationen. Mehr braucht man ja eigentlich nicht. Doch was, wenn diese „bewährten“ Ausgabedateien überschrieben wurden oder auf irgendeine Weise beschädigt sind? Wäre der Freigabeprozess doch nur robuster gewesen.
Altium Designer erfüllt diesen Anspruch mit einer leistungsstarken, auf hohe Datenintegrität ausgelegten Freigabeverwaltung für Designprojekte. Der Freigabeprozess für Projektdesigns ist automatisiert, sodass Sie Ihre Designprojekte ohne die Risiken manueller Freigabeverfahren freigeben können. Bei der Freigabe eines Projekts wird eine Momentaufnahme der Design-Quelldaten erstellt und zusammen mit sämtlichen generierten Ausgabedaten archiviert. Diese Daten repräsentieren ein physisches Produkt, das auf Grundlage dieses Designprojekts hergestellt und vom Unternehmen verkauft wird. Die Freigabedaten werden im angegebenen Ordner bzw. ZIP-Archiv auf Ihrer Festplatte oder in Revisionen des entsprechenden projektbezogenen Items im Ziel-Workspace gespeichert:
- Source Data (PCB Project Design Item) – eine mit Zeitstempel versehene Kopie (Momentaufnahme) der zentralen Projektdesigndateien einschließlich aller Quelldokumente. Die Freigabe erfolgt in einem separaten Item im Workspace. So können Sie Ihr wertvolles geistiges Eigentum getrennt von den generierten Fertigungs- und Bestückungsdaten aufbewahren, die externe Partner zur Herstellung des Produkts benötigen.
- Fabrication Data (PCB Fabrication Data Item) – der Datensatz, den der Leiterplattenhersteller zur Herstellung der unbestückten Leiterplatte benötigt (Gerber-Dateien, NC-Bohrdateien usw.).
- Assembly Data (PCB Assembly Data Item) – der Datensatz, den der Bestückungsdienstleister benötigt, um die unbestückte Leiterplatte gemäß einer Stückliste mit den angegebenen Bauteilen zu bestücken (Pick-and-Place-Dateien, Bestückungszeichnungen, Stücklisten usw.). Für das Basisdesign (vollständig bestückt) und jede definierte Designvariante (Bestückungsvarianten) wird jeweils ein eigenes Item verwendet.

Die aus einem Designprojekt generierten Daten werden im Workspace sicher in Revisionen projektbezogener Items gespeichert. Diese Daten mit hoher Integrität werden anschließend von der Lieferkette genutzt, um die erforderliche Revision des Produkts herzustellen.
Das Gesamtergebnis ist eine Freigabeverwaltung für Designprojekte mit höchstmöglicher Datenintegrität. Nicht nur Ihr eigentliches Designprojekt wird sorgfältig überwacht, gesichert und unter Versionskontrolle verwaltet, sondern auch die Freigaben seiner Daten werden im Ziel-Workspace auf ähnliche Weise verwaltet – robust, geschützt und sicher.
Wesentliche Vorteile
- Integration mit der Versionskontrolle. Wenn Ihr Projekt unter Versionskontrolle steht, verlangt das System vor der Freigabe, dass alle Dateien eingecheckt und auf dem neuesten Stand sind. Dadurch wird sichergestellt, dass keine „Privatkopie“ eines wichtigen Designdokuments auf der Festplatte eines Entwicklers verbleibt – wo sie möglicherweise verloren gehen könnte. Diese einfache Regel kann später stundenlange, kostspielige Suchen nach genau dem Satz von Designdokumenten ersparen, mit dem ein freigegebenes Produkt erstellt wurde.
- „Einmalige Freigabe“. Das System lässt für jede Revision eines Ziel-Items nur eine einzige Freigabe zu. Bei einer erfolgreichen Freigabe werden die Freigabedaten in der referenzierten Item-Revision festgeschrieben (gespeichert) und die Revision anschließend geschlossen. Es können keine weiteren Daten generiert und in dieselbe Revision freigegeben werden.
- Automatisierter und wiederholbarer Designfreigabeprozess. Freigabe auf Knopfdruck – ohne manuelle Schritte und die damit verbundenen Risiken. Von der Erstellung der Momentaufnahme der Designdateien über die Validierung bis hin zur Generierung der Ausgabedaten sind keine Eingriffe erforderlich. Schlägt ein Teil des Prozesses fehl, schlägt die Freigabe fehl. So einfach ist das. Außerdem können Sie alle generierten Daten überprüfen, bevor die Freigabedaten endgültig in der Item-Revision im Ziel-Workspace gespeichert werden.
-
Möglichkeit zur Validierung des Designs als integraler Bestandteil des Designfreigabeprozesses. Der Freigabeprozess arbeitet mit einer schreibgeschützten Momentaufnahme der Design-Quelldaten einschließlich ihrer Abhängigkeiten. In aller Regel wurde bereits vor dem Start der Freigabe eine Vorabvalidierung durchgeführt. Für zusätzliche Sicherheit und zur Gewährleistung der Integrität der Designdaten können Sie jedoch über entsprechend konfigurierte Output-Job-Konfigurationen optional Validierungsprüfungen in den Freigabeablauf aufnehmen. Dazu gehören standardmäßige ERC-Prüfungen der Quellschaltpläne und DRC-Prüfungen der Leiterplatte. Darüber hinaus lässt sich prüfen, ob Quellprojekt und Leiterplatte synchron sind, und es können die Footprints auf der Leiterplatte mit ihrer Quellbibliothek verglichen werden, um sicherzustellen, dass sie aktuell sind und übereinstimmen. Wird eine der Validierungsprüfungen nicht erfolgreich bestanden, schlägt die Freigabe fehl.
- Allen im Designfreigabeprozess generierten Datendateien können optional die Item-ID und die Item-Revisions-ID vorangestellt werden. Dadurch ist eindeutig ersichtlich, welche Revision welchen Items mit diesen Daten hergestellt werden soll.
- Veröffentlichung. Freigabedaten können direkt aus einem Workspace in einem gemeinsam genutzten Speicher veröffentlicht werden, beispielsweise Amazon S3, auf FTP-Servern, Box.com oder in einem einfachen Netzwerkordner. So lassen sich Workspace-Daten auf sichere Weise unkompliziert weitergeben, ohne externen Partnern Zugriff auf den Workspace gewähren zu müssen.
Der Project Releaser
Altium Designer bietet dank seines Project Releaser eine leistungsstarke Verwaltung von Designprojektfreigaben mit hoher Datenintegrität. Über eine intuitive Benutzeroberfläche können Sie alle Fertigungsdaten für Ihr Projekt gleichzeitig erzeugen – Leiterplattenfertigungsdaten, Bestückungsdaten, Designquelldaten usw. Der Project Releaser bietet zudem die Möglichkeit, Bestückungsdaten für mehrere erkannte Varianten Ihres Leiterplattendesigns gleichzeitig zu erzeugen. Selbst wenn Sie noch keine Output-Job-Dateien erstellt haben, müssen Sie sich keine Sorgen machen – auf Wunsch wird auch das für Sie erledigt!
Mit dem Project Releaser können Sie Ihre Fertigungsdaten besonders einfach und mit höchster Datenintegrität erzeugen. Außerdem können Sie die erzeugten Ergebnisse prüfen, bevor Sie die Freigabe abschließen (beispielsweise durch Anzeigen der Gerber-/ODB++-Daten im CAM-Editor). So stellen Sie sicher, dass die erzeugten Daten genau den Anforderungen entsprechen, um Ihr Design termingerecht und gleich beim ersten Mal erfolgreich fertigen zu lassen.
Für die Freigabe eines Designprojekts an einen Workspace gelten folgende Voraussetzungen:
- Altium Designer ist mit dem Workspace verbunden, der das Ziel-Repository für die Freigabe bereitstellt.
- Das Projekt enthält geeignete Output Jobs – Generatoren für die Ausgabe von Designdaten (beispielsweise als Ausdruck, Datei oder PDF). Wenn keine OutJobs vorhanden sind, bietet der Project Releaser an, geeignete OutJobs zur Durchführung des Prozesses zu erstellen.
- Das dem Freigabeprozess zugrunde liegende Projekt enthält alle erforderlichen Elemente – die Quelldaten sind gültig und aktuell, der Benutzer verfügt über ausreichende Berechtigungen, um das Projekt an den Workspace freizugeben, usw.
Zugriff auf den Project Releaser
Der Freigabeprozess selbst wird mit dem Project Releaser von Altium Designer durchgeführt. Dessen Benutzeroberfläche steht in einer eigenen Ansicht bereit – der Ansicht Release. Sie können diese wie folgt öffnen:
- Wählen Sie den Befehl Project » Project Releaser aus den Hauptmenüs (während ein Quelldokument des gewünschten Projekts als aktives Dokument geöffnet ist).
- Klicken Sie im Projects-Panel mit der rechten Maustaste auf den Eintrag des gewünschten Projekts und wählen Sie im Kontextmenü den Befehl Project Releaser.

Die Ansicht Release – die Benutzeroberfläche des Project Releaser.
Veröffentlichen in einem PLM-System
Related page: PLM-Integration (Altium 365 Workspace, Enterprise Server Workspace)
Wenn Sie einen aktivierten Prozess zum Veröffentlichen in einer PLM-Instanz als Teil des Project Releaser haben, wird dieser im Untermenü Project Releaser des Projekts angezeigt. Beim Starten dieses Prozesses wird der Ansicht eine zusätzliche Phase für diesen Zweck hinzugefügt.
Die Beispielprozessdefinition Publish to PLM (User selects) ist in Ihrem Workspace als Teil des Prozessbereichs Project Activities verfügbar, um diese Standardveröffentlichung durchzuführen (also nicht als Teil des Project Releaser, wie zuvor beschrieben). Dieser Prozess ermöglicht die Veröffentlichung freigegebener Projektausgaben in der integrierten PLM-Instanz. Dabei kann der Benutzer genau auswählen, welche Ausgaben veröffentlicht werden. Das Workflow-Diagramm ist unten dargestellt.

Das Workflow-Diagramm der standardmäßigen Publish to PLM (User selects) Beispielprozessdefinition
Auf Prozesse zur Standardveröffentlichung in einem PLM-System können Sie in Altium Designer über das Untermenü Project » Project Activities des aktiven Projekts zugreifen.

Zugriff auf einen aktivierten Prozess zur Standardveröffentlichung freigegebener Daten eines Workspace-Projekts in einer PLM-Instanz aus Altium Designer heraus.
Freigabemodus/-ziel
Der Project Releaser unterstützt alle Arten von Designprojekten – lokale Projekte ohne Versionsverwaltung, Projekte unter externer Versionsverwaltung (VCS) sowie Projekte unter der nativen Versionsverwaltung eines verbundenen Workspace – und bietet dafür zwei Betriebsmodi:
- Managed (Online) Mode – Freigabe aller erzeugten Daten an Revisionen von Items in einem Ziel-Workspace. Sie müssen nicht einmal daran denken, die Item-Revisionen hochzuzählen – dies wird vollständig für Sie erledigt. Wenn Sie einen Prozess zur Freigabe an eine PLM-Instanz über den Project Releaser definiert haben, wird der Ansicht beim Starten dieses Prozesses eine zusätzliche Phase für diesen Zweck hinzugefügt.
- Unmanaged (Offline) Mode – Freigabe aller erzeugten Daten in eine ordnerbasierte Struktur, die optional in einer einzigen ZIP-Datei zusammengefasst werden kann.
Der Project Releaser versucht, den zu verwendenden Freigabemodus und das Freigabeziel automatisch zu erkennen. Wenn mehrere Möglichkeiten bestehen – typischerweise dann, wenn das Projekt bereits an einen Workspace freigegeben wurde und Sie aktuell mit einem anderen verbunden sind –, zeigt das System die verfügbaren Optionen an.
Erkennen von Output-Job-Dateien
Die grundlegende Methode zum Erzeugen von Designausgaben in Altium Designer besteht in der Verwendung verschiedener verfügbarer Ausgabegeneratoren. Diese erzeugen die Datendateien und Fertigungsvorlagen, die für die physische Umsetzung des Designs benötigt werden – also Schaltplan- und Leiterplattenausdrucke, Gerber- und NC-Bohrdateien für die Leiterplattenfertigung, Stücklisten (BOM), Pick-and-Place-Dateien für die Bestückung, Fertigungszeichnungen usw., die zur Fertigung und Bestückung des Designs erforderlich sind.
Die ausgewählten Ausgabegeneratoren und die spezifischen Ausgabedateien, die sie für ein Design erzeugen, werden gemeinsam mithilfe des Output Job Editor definiert. Dieser speichert die Konfigurationen zur Zuordnung von Generatoren zu Ausgaben in einer Output-Job-Datei (*.OutJob), die über den Befehl File » New » Output Job File erstellt wird.
Als zentraler Mechanismus zur gemeinsamen Erzeugung von Fertigungsdateien für ein Design bieten die Output Jobs von Altium Designer die folgenden zusätzlichen Möglichkeiten:
- Einem Design können beliebig viele OutJobs hinzugefügt werden. Dadurch stehen Konfigurationen für bestimmte Aufgaben zur Verfügung, etwa zum Erzeugen von Ausgaben für Leiterplattenfertigung, Bestückung, Archivierung, Beschaffung und Dokumentation.
-
OutJob-Dateien sind übertragbar und können auf jedes Designprojekt angewendet werden, für das ein standardisierter Satz von Designausgaben benötigt wird. Wählen Sie beispielsweise
[Project]als Option für die Dokumentquelle anstelle einer bestimmten Designdatei, um einen universell verwendbaren (und damit übertragbaren) Output Job zu erstellen. - OutJobs können Dateien für Designvalidierungsprüfungen enthalten, beispielsweise elektrische Prüfungen (ERC), Entwurfsregelprüfungen (DRC) und Vergleiche zwischen Footprints und Quelldaten. Validierungs-Output-Jobs sind somit ein spezieller „aktiver“ Anwendungsfall: Das Design wird geprüft und die eigentliche Ausgabe (beispielsweise ein PDF-Dokument) enthält die Ergebnisse des Validierungsprozesses.
- OutJobs unterstützen Varianten eines bestückten Leiterplattendesigns, bei denen unterschiedliche Sätze von Ausgabedateien zur Fertigung alternativer Designversionen benötigt werden – beispielsweise Standardversionen oder leistungsfähigere Versionen eines Produkts, die zusätzliche Komponenten oder andere Komponententypen verwenden. Weitere Informationen zu Varianten von Leiterplattendesigns finden Sie unter Designvarianten.
Wenn Ihrem Projekt derzeit keine Output-Job-Dateien zugeordnet sind, erkennt der Project Releaser dies und fragt Sie, ob Sie Standarddateien hinzufügen möchten. Wenn Sie zustimmen, werden die folgenden Dateien erstellt:
-
Für ein PCB-Designprojekt:
-
Assembly.OutJob– mit den folgenden definierten Ausgaben:-
Documentation Outputs:
PCB 3D Print,Schematic Prints -
Assembly Outputs:
Generates pick and place files,Assembly Drawings -
Report Outputs:
Bill of Materials -
Export Outputs:
Export STEP
-
Documentation Outputs:
-
Fabrication.OutJob– mit den folgenden definierten Ausgaben:-
Documentation Outputs:
PCB Prints -
Fabrication Outputs:
Gerber Files,NC Drill FilesundIPC-2581 -
Validation Outputs:
Design Rules Check,Footprint Comparison Report -
Export Outputs:
Save As/Export PCB
-
Documentation Outputs:
Diese Standard-Output-Job-Dateien stammen aus dem folgenden Standardinstallationsordner:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs. -
-
Für ein Kabelbaum-Designprojekt:
-
Assembly.OutJob– mit den folgenden definierten Ausgaben:- Documentation Outputs: Draftsman
-
Report Outputs:
Bill of Materials -
Validation Outputs:
Electrical Rules Check
Diese Standard-Output-Job-Datei stammt aus dem folgenden Standardinstallationsordner:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs\Harness. -
Erkennen von Varianten
Bei PCB-Projekten ist eine besonders leistungsfähige Funktion des Project Releaser, dass er die für Ihr Design definierten Varianten erkennt und für jede Variante einen freigabefertigen Bestückungsdatensatz erstellt. Jeder Bestückungsdatensatz wird mit einer standardmäßigen Zielelementbenennung in folgender Form angezeigt:
PCBA-[ProjectName]-[VariantName]
Das Suffix [VariantName] stellt sicher, dass bei der Datengenerierung aus den zugewiesenen OutJob-Dateien die richtige Variante verwendet wird.

Zusätzliche Bestückungsdatensätze, die auf Grundlage der erkannten, für das Design definierten Varianten erstellt wurden.
Der Freigabeprozess
Der Freigabeprozess ist in mehrere Phasen unterteilt. Die Einträge auf der linken Seite der Ansicht Release zeigen Ihnen auf einen Blick, in welcher Phase Sie sich gerade befinden.
Weitere Informationen zum Freigabeprozess im Online-Freigabemodus finden Sie auf der Seite Freigabe in einem Workspace. Weitere Informationen zu den Besonderheiten des Offline-Freigabemodus finden Sie auf der Seite Lokale Freigabe.
Veröffentlichen freigegebener Daten
Related page: Arbeiten mit Veröffentlichungszielen
Freigegebene Daten, die aus einem PCB-Designprojekt generiert wurden (nur PCB-Fertigungsdaten, PCB-Bestückungsdaten und PCB-Projektdesignelemente), können Sie direkt aus Ihrem Workspace oder Output Job an einem Speicherort veröffentlichen, beispielsweise auf Box.com, Amazon S3, einem FTP-Server oder in einem einfachen Ordner in einem gemeinsam genutzten Netzwerk. Für die Verteilung und Zusammenarbeit bietet dies einen unschätzbaren Vorteil in einer Welt, in der die Mitglieder des gesamten „Produktteams“ – das Designteam, das Fertigungsteam und alle anderen, die an der Umsetzung einer Produktidee beteiligt sind – häufig über den ganzen Globus verteilt sind.
Zum Veröffentlichen definieren Sie ein Publishing Destination und laden anschließend die freigegebenen Daten für die gewünschte Elementrevision an dieses Ziel hoch. Vom Fertigungswerk in China über die Designteams in Kiew, Stanstead Abbotts und San Diego bis hin zum Projektleiter, der sich gerade auf einem Flug über den Pazifik befindet: Alle, die über die neue Freigabe informiert sein müssen, können über einen Link zum veröffentlichten Ordner eingeladen werden. So erhalten sie gemeinsamen und kontrollierten Zugriff, um die Daten zur Herstellung des Elements einzusehen, zu besprechen und zu verwenden.

Veröffentlichen Sie Ihre freigegebenen Daten an einem Speicherort und tauschen Sie Informationen mit Teammitgliedern auf der ganzen Welt aus.
Weltweite gemeinsame Nutzung von Fertigungspaketdaten
Ein wesentlicher Aspekt von Designprojekten, die in einem Altium 365 Workspace gespeichert sind, ist die Möglichkeit, ein Freigabe-Build Package zu erstellen und mit anderen zu teilen. Wird es direkt mit Ihrem Hersteller geteilt, kann es als Manufacturing Package betrachtet werden, da der Hersteller dieses Paket durchsuchen, herunterladen und zur Fertigung und Bestückung der Leiterplatte verwenden kann.
Um ein solches Paket mit anderen und mit Ihrem Hersteller teilen zu können, der in der Regel nicht zu Ihrer Organisation gehört, bietet die Altium 365-Plattform einen speziellen Manufacturing Package Viewer als Bestandteil der Global Sharing-Unterstützung der Plattform. Damit können andere ein Fertigungspaket in jedem Webbrowser und von überall auf der Welt aus anzeigen – jedoch außerhalb Ihres Workspace, sodass Ihre Designs selbst und anderes wertvolles geistiges Eigentum geschützt bleiben.
Jeder Benutzer, mit dem das Paket geteilt wurde, erhält eine E-Mail-Einladung mit einem Link, über den er das Fertigungspaket im Manufacturing Package Viewer anzeigen kann. Geteilte Fertigungspakete werden auf der Seite Shared with Me der browserbasierten Benutzeroberfläche der Altium 365-Plattform angezeigt.
Der Manufacturing Package Viewer selbst bietet den wichtigsten Beteiligten – insbesondere dem Fertigungspersonal – eine zusammenfassende Übersicht über das Design mit den wichtigsten Leiterplattendaten. Darüber hinaus können sie die Struktur der Quell-, Fertigungs- und Bestückungsdaten durchsuchen und bei Bedarf einzelne Dateien herunterladen. Der Viewer bietet außerdem Unterseiten für Fertigungs-, Bestückungs- und Stücklistendaten. Die Fertigungsseite enthält einen Gerber-Viewer und ermöglicht es allen Benutzern, mit denen das Paket geteilt wurde, Kommentare hinzuzufügen.
Schließlich kann das Fertigungspersonal von jeder Seite des Viewers aus ein Fertigungspaket der angezeigten Freigabe herunterladen, um diese Revision der Leiterplatte physisch herzustellen.
Web Viewer
Related page: Web Viewer (Altium 365 Workspace, Enterprise Server Workspace)
Die Web Viewer-Oberfläche des Workspace bietet universellen Zugriff auf PCB-Projektdokumente über einen herkömmlichen Webbrowser. Die fortschrittliche Browsertechnologie von Web Viewer's bietet weit mehr als einen webbasierten Viewer: Benutzer können durch die Projektstruktur navigieren, mit Designdokumenten interagieren, Informationen zu Elementen im Design abrufen und Bereiche oder Objekte für Kommentare hervorheben.
Bei der Anzeige von Dokumenten bleibt die Darstellungsqualität von Schaltplänen und Leiterplatten auch im Webformat erhalten. Zudem stehen umfassende Schwenk- und Zoomfunktionen sowie Funktionen zum Suchen, zur Querverfolgung (Cross-Probing), zum Auswählen und zum Untersuchen von Bauteilen und Netzen im gesamten Design zur Verfügung.

Die Web Viewer-Oberfläche des Workspace bietet eine anschauliche und interaktive Umgebung, um beispielsweise die Schaltplan- und PCB-Quelldokumente Ihres Designprojekts zu prüfen. Hier ist ein Schaltplan in der Web Viewer-Oberfläche von Altium 365 dargestellt – bewegen Sie den Mauszeiger über das Bild, um die Leiterplatte in 3D zu sehen.
Als eigenständige, browserbasierte Anzeigeplattform bietet die Web Viewer-Oberfläche interaktiven Lesezugriff auf Designdokumente, ohne dass das Projekt in der Design-Bearbeitungsumgebung geöffnet werden muss. Andere Personen, die am Design arbeiten, beispielsweise der dafür verantwortliche Ingenieur, werden durch Aktionen im Web Viewer-Bereich nicht beeinträchtigt – abgesehen von etwaigen zugehörigen Kommentarbenachrichtigungen.
