Navigator-Bedienfeld
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Erfahren Sie, wie Sie mit dem Navigator-Panel einzelne Schaltplanblätter, das gesamte Projekt und die Designhierarchie durchsuchen, um verbundene Objekte schnell zu finden.
- Lernen Sie, in beide Richtungen zu navigieren – vom Panel zum Schaltplan und vom Schaltplan zurück zum Panel. Erfahren Sie außerdem, wann ein Alt-Klick dabei hilft, zugehörige PCB-Objekte zu lokalisieren.
- Verstehen Sie, wie Hervorhebung, Zoom, Abdunklung und Validierung die Anzeige während der Navigation beeinflussen, damit Sie Verbindungen in komplexen Designs besser nachverfolgen können.
Wenn das Design groß ist und sich über viele Schaltplanblätter erstreckt, kann es schwierig werden, ein Netz zu verfolgen und die Verbindungen im Design allein durch Betrachten der Schaltpläne zu überprüfen. Dieselben Objekte auf der Leiterplatte zu finden, ist eine noch größere Herausforderung. Zur Unterstützung dieses Vorgangs wird das Navigator Panel verwendet.

Verwenden Sie das Navigator Panel, um sich einen Überblick über das gesamte Design zu verschaffen. Halten Sie Alt gedrückt, während Sie im Panel klicken, um das betreffende Objekt auch auf der Leiterplatte zu finden.
Mit dem Navigator Panel können Sie entweder das aktive Quellschaltplandokument oder alle Quellschaltplandokumente im aktiven Projekt durchsuchen. Das Panel verwendet das Verbindungsmodell des Designs, das automatisch im Hintergrund erstellt wird, als Grundlage für die Navigation. Das Panel kann auch verwendet werden, um zu Bauteilen, Pads, Bussen und Netzen auf der Leiterplatte zu navigieren.
Navigation im Design
Die Navigation kann auf zwei Arten erfolgen: entweder durch Klicken im Navigator Panel, um das betreffende Objekt im Schaltplan zu finden, oder durch Klicken auf das Objekt im Schaltplan, um es im Navigator Panel zu finden.
Navigation über das Navigator-Panel
Um das Navigator Panel anzuzeigen, verwenden Sie die Schaltfläche Panels unten rechts in der Software oder wählen Sie View » Panels » Navigator aus den Menüs.
Informationen zu Bauteilen und Verbindungen werden in das Panel geladen, sobald ein Schaltplan geöffnet wird. Klicken Sie auf ein Symbol im Abschnitt Documents, um sie anzuzeigen. Die Software erstellt automatisch ein dynamisches Datenmodell für das gesamte Projekt und hält das Modell während der Bearbeitung auf dem aktuellen Stand. Beachten Sie, dass nicht für alle Schaltplanblätter Dokumentregisterkarten oben im grafischen Bearbeitungsbereich angezeigt werden, da die Blätter im Hintergrund geöffnet werden. Eine Registerkarte erscheint erst, wenn eine Benutzeraktion auf dem betreffenden Blatt ausgeführt wird.
Das dynamische Datenmodell ist für jeden Editor sowie für das Navigator Panel verfügbar. Wenn Sie zu irgendeinem Zeitpunkt nicht sicher sind, ob der Inhalt des Panels dem aktuellen Stand des Designs entspricht, wählen Sie den Befehl Validate Project, um eine Aktualisierung des Modells zu erzwingen (im Menü Project oder im Kontextmenü, das Sie durch Rechtsklick im Navigator Panel öffnen).

Klicken Sie auf ein Objekt im Navigator Panel, um alle Instanzen dieses Objekts im gesamten Design zu finden.
Interaktive Navigation
Sie können nicht nur über die im Panel angezeigten Objektlisten navigieren und durch Klicken ein Objekt im grafischen Bereich finden, sondern auch vom grafischen Bereich zurück zur Liste navigieren. Dieser Modus wird als interaktive Navigation bezeichnet und durch Klicken auf die Schaltfläche Interactive Navigation oben im Navigator Panel gestartet. Der Cursor wird zu einem Fadenkreuz und zeigt damit an, dass Sie sich im Navigationsmodus befinden. Dieser bleibt aktiv, bis Sie mit der rechten Maustaste klicken oder die Taste Esc drücken.
Während Sie durch ein Design navigieren, wird die Blattansicht entsprechend den aktuellen Hervorhebungsoptionen aktualisiert. Das Navigator Panel wird ebenfalls aktualisiert und zeigt Informationen zu Ihrer aktuellen Auswahl im grafischen Bearbeitungsfenster an.

Aktivieren Sie die interaktive Navigation über die Schaltfläche oben im Navigator Panel und klicken Sie anschließend auf ein Objekt auf dem Blatt, um dieses Objekt im Panel und im übrigen Design zu finden.
Tastenkürzel für die interaktive Navigation
Sie können die interaktive Navigation nicht nur über das Navigator Panel starten, sondern auch jederzeit im Schaltplaneditor aufrufen: Halten Sie Alt gedrückt, während Sie auf ein Designobjekt klicken. Sie können auf jedes Objekt klicken, einschließlich einer Leitung, einer Netzbezeichnung, eines Ports, eines Blatteintrags, eines Blattsymbols oder eines Bauteils.
Verwenden Sie Alt+Klick, um durch Ihr Design zu navigieren.
So werden Objekte während der Navigation hervorgehoben
Wenn Sie im Navigator-Panel auf ein Objekt klicken, wird das Objekt im grafischen Bearbeitungsbereich angezeigt. Wie das Objekt dargestellt wird, hängt von den Einstellungen unter System – Navigation im Dialog Preferences ab. Um direkt vom Navigator-Panel aus auf die Einstellungen zuzugreifen, klicken Sie oben im Panel auf die Schaltfläche Navigation Options , um den Dialog zu öffnen.
Der Bereich Highlight Methods des Dialogs Preferences bietet Optionen zur Steuerung der visuellen Darstellung der temporären Filterung, die beim Navigieren über das Panel oder direkt im Dokument auf das Dokument angewendet wird. Diese Optionen können in beliebiger Kombination aktiviert werden. Beispielsweise können Sie alle gefilterten Objekte im Design-Editor vergrößern und auswählen lassen und gleichzeitig die übrigen Designobjekte abdunkeln, um die Darstellung übersichtlicher zu gestalten.
Das Navigator-Panel
Das Panel Navigator bietet einen Einblick in das Verbindungsmodell des Designs. Die Struktur des Designs wird in den vier Bereichen des Panels dargestellt, die im Folgenden beschrieben werden.
Das Navigator-Panel zeigt eine verbindungsorientierte Ansicht des gesamten Designs.
Bereich „Dokumente“
Der Bereich Documents oben im Panel bietet Ihnen drei verschiedene Möglichkeiten, das Design anzuzeigen: die individual sheets, das flattened hierarchy (das gesamte Projekt) oder die Möglichkeit, die full design hierarchy zu durchsuchen. Klicken Sie einmal auf ein Symbol in diesem ersten Bereich, um die Daten in das Panel zu laden. Mit einem Doppelklick werden die Ergebnisse zusätzlich im grafischen Bearbeitungsbereich angezeigt.
Funktionen des Bereichs „Dokumente“
Bereich „Dokumente“ |
|
| Individual Sheets | Zeigt für jedes erfasste Schaltplanblatt ein Symbol an, das durch Klicken Sie einmal, um die Ergebnisse im Panel Navigator anzuzeigen. Mit einem Doppelklick werden die Ergebnisse zusätzlich im grafischen Bearbeitungsbereich angezeigt. |
| Flattened Hierarchy (gesamtes Projekt |
Zeigt alle Objekte und Verbindungen im gesamten Projekt an. Wenn im Design wiederholt verwendete Blätter (Kanäle) vorhanden sind, wird für jede Kanalklasse ein untergeordnetes Symbol angezeigt, das durch den Kanalnamen gekennzeichnet ist (abgeleitet von Klicken Sie einmal, um die Ergebnisse im Panel Navigator anzuzeigen. Mit einem Doppelklick werden die Ergebnisse zusätzlich im grafischen Bearbeitungsbereich angezeigt. |
| Full Design Hierarchy | Zeigt für jedes logische Blatt im Projekt ein Symbol an. Wenn im Design wiederholt verwendete Blätter (Kanäle) vorhanden sind, gibt es für jeden Kanal ein Blattsymbol, das durch Klicken Sie einmal, um die Ergebnisse im Panel Navigator anzuzeigen. Mit einem Doppelklick werden die Ergebnisse zusätzlich im grafischen Bearbeitungsbereich angezeigt. Wenn Sie auf das Symbol eines wiederholt verwendeten Kanals doppelklicken, wird das Blatt für diesen Kanal angezeigt und zusätzlich die Registerkarte für den jeweiligen Kanal am unteren Rand des Schaltplan-Bearbeitungsbereichs ausgewählt. |
Bereich „Bauteile“
Der zweite Bereich im Panel enthält alle Bauteile des Dokuments, das aktuell im ersten Bereich ausgewählt ist. Wenn Sie in der Liste einen Eintrag für eine Bauteilinstanz auf oberster Ebene auswählen, wird auf Grundlage dieses Eintrags ein Filter angewendet. Die visuelle Darstellung wird durch die ausgewählten Hervorhebungsmethoden bestimmt. Wenn die aktivierten Hervorhebungsoptionen die Option Connective Graph umfassen, werden alle anderen Bauteile sichtbar, die mit dem ausgewählten Bauteil verbunden sind (der Filter wird entsprechend erweitert). Die verbundenen Bauteile werden durch grüne Verbindungslinien im Verbindungsgraphen visuell hervorgehoben.
Da der Verbindungsgraph aktiviert ist, wird zu jedem Bauteil, das mit dem im Panel ausgewählten Bauteil verbunden ist, eine grüne Linie gezeichnet.
Funktionen des Bereichs „Bauteile“
Bereich „Bauteile“ |
|
| Information available | Für jeden Bauteileintrag gibt es Unterordner für Parameters und Implementations (Modelle). Wenn die Option Pins in den Hervorhebungsoptionen aktiviert ist, steht außerdem ein Unterordner Pins zur Verfügung |
| When you click | Wenn Sie in der Liste Instance auf einen Pineintrag klicken, wird der entsprechende Eintrag für diesen Pin im Bereich Net / Bus des Panels ausgewählt, und alle Pins des zugehörigen Netzes werden im unteren Bereich des Panels aufgelistet. Außerdem wird auf Grundlage des ausgewählten Pineintrags ein Filter angewendet. Die visuelle Darstellung wird durch die aktivierten Hervorhebungsmethoden bestimmt. |
| Connective Graph | Wenn Sie die Option Connective Graph aktiviert haben, werden alle anderen Pins sichtbar, die mit dem Netz des ausgewählten Pins verbunden sind (der Filter wird entsprechend erweitert). Das zugehörige Netz der verbundenen Pins wird durch rote Verbindungslinien im Verbindungsgraphen visuell hervorgehoben |
Bereich „Net / Bus“
Der dritte Bereich des Panels listet alle Netze und Busse im durchsuchten Dokument (oder in der abgeflachten Hierarchie) auf. Wenn Sie auf einen Eintrag klicken, werden alle mit dem Netz/Bus verbundenen Objekte – Pins, Netzbezeichnungen, Ports, Schaltplanblatteinträge und blattübergreifende Verbinder – im Fenster des Designeditors gemäß den aktivierten Hervorhebungsmethoden angezeigt.
Funktionen des Bereichs „Net / Bus“
Bereich „Net / Bus“ |
|
| Information available | Die verschiedenen Objekttypen, die dem ausgewählten Netz/Bus zugeordnet sind, werden in Unterordnern aufgelistet. Dies hängt von den aktuell aktivierten Hervorhebungsoptionen und davon ab, ob der jeweilige Objekttyp im aktuell ausgewählten Netz/Bus vorhanden ist. Für jedes Netz/jeden Bus kann ein weiterer Unterordner angezeigt werden, der alle grafischen Linien auflistet, die zum Verbinden der zugehörigen Pins/Ports/Netzbezeichnungen/Schaltplanblatteinträge/blattübergreifenden Verbinder verwendet werden. Klicken Sie auf einen Linieneintrag, um nur dieses Linienobjekt zu filtern und die Einstellungen für die visuelle Darstellung anzuwenden. |
| When you click | Alle Netzobjekte, deren Anzeige im Panel aktiviert wurde (mit Ausnahme grafischer Linien), werden im unteren Bereich des Panels angezeigt. Auch hier wird beim Klicken auf einen Eintrag die Filterung gemäß den aktivierten Hervorhebungsmethoden angewendet. |
Bereich „Bus Nets – Net Pins“
Der Inhalt des vierten Bereichs des Panels hängt von zwei Faktoren ab: dem Objekt, zu dem Sie navigieren, und den Objekten, deren Anzeige Sie aktiviert haben. Wenn Sie im Bereich „Net / Bus“ auf einen bus klicken, werden die Netze dieses Busses in diesem Bereich des Panels aufgelistet. Wenn Sie im Bereich „Net / Bus“ auf ein net klicken, werden die Pins dieses Netzes aufgelistet. Die diesem Netz zugeordneten Netzkennungen werden ebenfalls aufgelistet, sofern deren Anzeige aktiviert ist.
Bereich „Signal“
Das Navigator-Panel unterstützt eine signalorientierte Ansicht des Designs anstelle der objektorientierten Ansicht, in der es das Design normalerweise darstellt. Wenn im Bereich Documents des Panels ein Schaltplandokument ausgewählt ist, wird durch Aktivieren der Option Show Signals oben im Panel der dritte Bereich des Panels in den Modus Signal umgeschaltet.
Klicken Sie auf einen Signaleintrag, um einen Filter anzuwenden. Die Knoten dieses Signals (Pins/Ports/Netzbezeichnungen/Schaltplanblatteinträge/blattübergreifende Verbinder) werden dann im Fenster des Designeditors gemäß den aktivierten Hervorhebungsmethoden angezeigt. Für jedes Signal in der Liste werden die zugehörigen Knoten-Pins, Schaltplanblatteinträge oder blattübergreifenden Verbinder aufgelistet. Diese Einträge werden unabhängig davon angezeigt, ob die entsprechende Anzeigeoption für diesen Objekttyp aktiviert ist oder nicht.
Funktionen des Bereichs „Signal“
Bereich „Signal“ |
|
| Signal | Name des Signals (Bus- oder Netzname). |
| Width | Anzahl der einzelnen Netze innerhalb dieses Signals. |
| Click on a top-level signal entry | Klicken Sie auf einen Signaleintrag der obersten Ebene, um im unteren Bereich des Panels alle Signalknoten anzuzeigen, die diesem Signal zugeordnet sind. Dazu können Pins, Netzbezeichnungen, Ports, Schaltplanblatteinträge und blattübergreifende Verbinder gehören. Einträge werden nur angezeigt, wenn die entsprechende Option zur Anzeige dieses Objekttyps aktiviert ist. |
| Click on a sub-entry | Klicken Sie auf einen Untereintrag in der Hauptliste „Signal“, um im unteren Bereich des Panels alle Netzobjekte anzuzeigen, die dem übergeordneten Netz dieses Signals zugeordnet sind. |
| SignalName Driven By Pin X | Wird angezeigt, wenn ein einem Signal zugeordneter Knoten-Pin ein Ausgangs-Pin oder ein E/A-Pin ist. X steht für die Bauteil-Pin-Kennung, die das Signal treibt. |
| Driving Node Pin X | Wird angezeigt, wenn ein einem Signal zugeordneter Knoten-Pin ein Eingangs-Pin ist. X steht für die Bauteil-Pin-Kennung, die vom Signal angesteuert wird. |
| Driven By Node Sheet Entry SignalName | Wird angezeigt, wenn der elektrische Typ eines Schaltplanblatteintragsknotens „Ausgang“ oder „E/A“ ist; der Eintrag treibt das Signal. |
| Driving Node Sheet Entry X | Wird angezeigt, wenn der elektrische Typ des Schaltplanblatteintrags „Eingang“ ist; der Eintrag wird dann vom Signal angesteuert. |
Navigation auf der Leiterplatte
Wenn Sie im Panel Navigator klicken, können Sie nicht nur zu Objekten im Schaltplan navigieren, sondern gleichzeitig auch zu diesen Objekten auf der Leiterplatte. Wenn Sie die Taste Alt gedrückt halten, während Sie im Panel Navigator auf ein Objekt klicken, werden die Zielobjekte sowohl im Schaltplan als auch auf der Leiterplatte hervorgehoben.
Da die Navigation immer im Schaltplan erfolgt, müssen Sie den Schaltplan und die Leiterplatte gleichzeitig anzeigen, um zu Objekten auf der Leiterplatte zu navigieren. Dazu können Sie entweder die Leiterplatte in einem separaten Fenster anzeigen oder den grafischen Arbeitsbereich mithilfe der Funktion Split Vertical oder Split Horizonal teilen (unten ist die vertikale Aufteilung dargestellt). Die entsprechenden Befehle sind im Kontextmenü verfügbar, wenn Sie mit der rechten Maustaste auf eine Dokumentregisterkarte klicken.
Halten Sie beim Navigieren durch Ihr Design die Alt-Taste gedrückt, um die jeweiligen Objekte auch auf der Leiterplatte zu finden.
Altium Designer bietet mehrere Funktionen für das Arbeiten zwischen Schaltplan und Leiterplatte, darunter:
| Cross probe | Cross-Probing – Klicken Sie zum Starten mit der rechten Maustaste und anschließend in einem Editor auf ein Objekt (Bauteil, Pin, Netz), um zu diesem Objekt im anderen Editor zu springen. Es gibt zwei Modi: continuous (im Quelleditor bleiben) oder jump-to (den Zieleditor/das Zieldokument zum aktiven Dokument machen). Halten Sie beim Cross-Probing Ctrl gedrückt, um den Modus jump-to aufzurufen. Cross-Probing wird von folgenden Editoren und Panels aus unterstützt: Schaltplan-, Leiterplatten- und BOM-Editoren, Constraint Manager sowie die Panels Project, Navigator und Messages. |
| Cross select | Klicken Sie, um ein Bauteil in einem Editor auszuwählen und es gleichzeitig im anderen Editor auswählen zu lassen. Dies wird zwischen dem Schaltplan- und dem Leiterplatteneditor unterstützt und im Menü View aktiviert. |
Erfahren Sie mehr über Cross-Probing und Cross-Selection
Kontextmenü des Navigator-Panels
Das per Rechtsklick aufrufbare Kontextmenü des Panels Navigator enthält die folgenden Befehle:
)
)
)


).
).
).

)
