FAQs

Modified by Phil Loughhead on Jan 30, 2018

A useful aid in getting up and running with a particular area of a software solution, is to consult a list of frequently asked questions. These might range from the general questions, such as "Where do I find this or that functionality?", to the more specific, such as "How can I export my design in format xyz?".

In some cases, we try to pre-empt the questions we think might be asked, or to highlight and reinforce important aspects of the software that we believe you should be made aware of. In addition, we often lower our bucket into the Altium Design Forums, skimming from a vast pool of knowledge on all aspects of the software, from the very people that are using the software day-in, day-out, in their working lives.

So go ahead and browse through the various FAQ listings, which are conveniently clustered into suitable categories. There just might be an answer to that question you need answering, and which can supply the helping hand to move through a 'road-block', and get you back into the productivity 'fast-lane'.

By no means exhaustive, this listing of FAQs associated to designing with Altium will continue to grow over time, but all the while helping to unlock your full design potential when using the software.

FAQs are clustered into the following areas, and further sub-clustered therein (where it makes sense to do so):


Altium NEXUS Environment

General

As well as having complete freedom to arrange the panels, toolbars and documents being edited anywhere on your multiple monitors, you can also customize the menus, toolbars and shortcuts in Altium NEXUS. To access the customization dialog for the current editor:

  • Right-click on a menu bar, or toolbar, and choose the Customize command from the context menu.
  • Double-click on a blank area of a menu bar or toolbar.
  • Choose the View » Toolbars » Customize command from the main menus.
Altium NEXUS also supports scripting, allowing you to develop your own custom commands, tailored to your company's needs.

To prevent a panel from docking as you move it in floating mode, simply hold the Ctrl key down.


Projects

General

Yes, absolutely. The Altium NEXUS installation includes several example projects that can be found in the Examples folder (\Users\Public\Documents\Altium\AD<VersionNumber>\Examples for a default installation).

Managed Projects

Some key benefits to using Managed Projects are:

  • Simplified storage. No need to make decisions about storage locations. Backup and other basic services are taken care of.
  • Foundation for collaborative features.
  • Enforced version control.
  • Beneficiary of a dedicated commenting system.
  • Notifications and status. Document status including local modifications is visible to entire design teams.
  • Concurrent PCB design works without any complex setup.

The beauty of Managed Projects is that they are version controlled by default, and can be collaboratively worked upon without having to worry about shared drives, servers, agreements etc.

The project will initially only be available to you, the creator, and all Administrators for the managed content server (in which the content is stored). To make it accessible to others simply share it, by configuring its permissions.

If the Convert to Managed Project command is not available, it means that the project is currently under Version Control (in a local or network VCS Design Repository), or has been so in the past.

This can be resolved by creating a 'clean' copy of the project (one not associated with VCS) in another local folder and converting that version to a Managed Project. To do this:

  1. Open the project in Altium NEXUS:
    1. For a project currently under Version Control, use File » Checkout to open (check out) the project from its VCS repository to a local working folder.
    2. For a project that is no longer under Version Control, use File » Open Project to locate and open the project from its local folder.
  2. Use the Project Packager (Project » Project Packager) to create a single zip file of the project, which by default, will be stored in the project's local source directory - typically, a path such as C:\Users\Public\Documents\Altium\Projects\MyProject.
  3. In the operating system, create a local working folder specifically for Managed Projects, for example: C:\Users\Public\Documents\Altium\ManagedProjects.
  4. Move the project's packaged zip file to the new folder (...\ManagedProjects) and extract its contents: right-click - Extract All and rename to suit. The resulting path to the duplicated project folder would therefore be C:\Users\Public\Documents\Altium\ManagedProjects\MyProject.
  5. If the project was previously a Managed Project, open its Project file (*.PrjPcb) in a text editor such as Windows Notepad and delete the ManagedProjectGUID= entry, which can be found under the first [Design] section. Save the edited Project file.
  6. Back in Altium NEXUS, navigate to and open (File » Open Project) the newly duplicated project from its folder – that is, from where the project was unzipped.
  7. Right click on the project file and select the Convert to Managed Project command, which should now be available.

Design Variants

To examine design variations, you must compile the design and then switch to the compiled tab of the schematic. A Variants folder will be presented for a project in the Projects panel - and directly below that project's entry - provided at least one variant has been defined for that project. The folder contains entries for the base design ([No Variations]), as well as all variants you have defined. To make any listed variant the current variant, you can either double-click the desired variant in the panel, or right-click the desired variant and choose the Set as current command from the context menu. This approach also applies to switching to the base design, using the [No Variations] entry.

Note that when you switch to a compiled tab the available menu entries will change, reflecting the commands that can be run when you are viewing the physical design. Click on the logical design tab (Editor) at the bottom of the schematic sheet to return to the standard, editing menus.

There are two ways an Alternate Part is handled on the PCB:

  • If the footprint is the same - if the chosen Alternate Part has the same footprint name as the base part, then only one instance of that footprint will be transferred to the PCB. As multiple footprints can be assigned to a component, you should ensure that the correct footprint is selected in the Variant Management dialog for each variant.
  • If the footprint changes - if the chosen Alternate Part has a different footprint name from the base part, then both footprints are transferred to the PCB. As the designer you must then decide how to position the two footprints on the PCB. Note that both footprints will have the same designator, as only one or the other component is ever fitted.

After selecting an alternate part, the software checks for pin-compatibility between the chosen alternate component, and the original base design component. To be pin-compatible, the alternate must have the same number of pins as the original component, and those pins must be identical in their location, and electrical type. No equality in the graphical primitives used in the symbols for the two components is required.

If the software detects that the alternate component is not pin-compatible, a Confirm dialog will appear, requiring your OK to proceed with the replacement. While you can proceed with the use of a pin-incompatible alternate component, bear in mind the potential impact on the wiring, and that you may also encounter an error violation when performing a subsequent compilation of the design.

Version Control

Altium NEXUS's interface can be configured to work with the following VCS applications:

  • Altium NEXUS's internal copy of the Subversion (SVN) version control system.
  • A managed content server's built in Subversion (SVN) system, when using a centralized version control approach to access both server-based and external Design Repositories.

Components & Libraries

General

Each mode must include the same set of pins, if they do not a warning will be generated when the project is compiled. This is required as you can only define one set of pin-to-pad mappings for each footprint. Pins can be hidden in a mode if required, and do not need to be in the same location in each mode.

Managed Components

Yes and No. It all depends whether the managed component - a Component Item - has associated Part Choices or not. When a source component definition is first released, the resulting Component Item, referred to as a managed component, simply represents the engineering, or design view of that component. It is, in essence, a container into which all information used to model that component in the Design Area is stored. This includes links to all requisite domain models (schematic symbol, PCB 2D/3D component, Sim), as well as parametric information. It has great meaning to the designer using it in a board design, but is not meaningful outside of the design arena. To become a truly 'Unified Component', that unites the Design and Supply Chain areas, the Component Item must be mapped to physical, real-world manufactured parts. This is done by specifying Part Choices for the component.

And it is this intelligent mapping of a component - from the traditional electronics design arena into the bigger 'product arena' as seen by the rest of the organization - that turns the humble managed component into a truly Unified Component!

Each placed component has a link back to the source Component Item in the server. This information can be found while browsing the properties for a selected component, in the Properties panel. At this lowest, individual component level, the placed instance can be updated to a later revision of the same Component Item (or changed to a totally different Component Item) simply by clicking the ... button, to the right of the Design Item ID field. The Choose Item dialog will appear, with the currently linked Item (and revision thereof) focused in the source server. Select the later revision, or browse for another Component Item to use.

For a single, centralized place from which to effect multiple changes in a batch-like manner, use the Item Manager (Tools » Item Manager). It presents all managed components and/or sheet symbols found in a single schematic sheet (free document), or the set of schematics in a board design project. You have full control over which of these managed entities to update, and how. Select an entry and choose a later revision of the linked Item to be used. Select a group of entries that utilize the same linked Item and choose the next revision in one hit. All proposed changes are reflected back in the manager.

Once changes have been set up as required, simply generate and execute an Engineering Change Order (ECO) to effect those changes.

Database Libraries

Yes - if the target database has been created using multiple Excel spreadsheet files (*.xls), there is a limit of 64 sheets that can connect, due to ODBC driver limitations.

When using Microsoft Access as the backend database for your components, there is one important difference between using 32-bit and 64-bit versions of Altium Design Software:

  • 64-bit Altium Design Software (Altium NEXUS 1.0 and later) - requires 64-bit Microsoft Access Database Engine to be able to use MS Access DbLibs.
  • 32-bit Altium Design Software (Altium NEXUS 17.1 and earlier) - requires 32-bit Microsoft Access Database Engine to be able to use MS Access DbLibs.

Typically, the appropriate version of Microsoft Office would be installed, of which Access is a constituent part. However, it is likely that many users will have both 32-bit and 64-bit versions of Altium Design Software running on the same computer. The issue is that Microsoft does not officially support, nor endorse, the coexistence of both 32-bit and 64-bit Office applications and drivers on the same computer. For information on three possible solutions, see Using Database Libraries with 32-bit and 64-bit Altium Design Software on the same Computer.

Linking to Supplier Data

Use of the Live Links to Supplier Data feature does not require you to be signed in to your Altium account. Searching is conducted directly with the Suppliers through web services. However, when displaying pricing information in alternate currencies, exchange rates for currency conversion are refreshed daily, provided you are signed in to your account.

This will happen when you are signed in to your company's managed content server. The server dictates centrally which Suppliers are to be used in an organization. While connected to it, the list of Suppliers on the Data Management - Suppliers page of the Preferences dialog will be disabled. It will simply be a read-only reflection of this centrally-defined list, which itself is defined on the Suppliers page of the server's browser based interface.

Pad & Via Templates and Libraries

The Libraries panel is not used for managing and accessing Pad Via Libraries. Instead, it is the PCB Pad Via Templates panel that provides the required specialized ability to handle both local (within the PCB document) and external (from a Pad Via Library) templates.


Schematics

Multi-Sheet & Multi-Channel Design

You can think of a flat design as if a large schematic sheet has been cut up into a number of smaller sheets - in a flat design all sheets exist on the same level. The connectivity in a flat design is created directly from any sheet to any another sheet - this type of connectivity is referred to as horizontal connectivity.

A hierarchical design is one which has Sheet Symbols to create the parent-child type relationships between the sheets, and, the connectivity is through the Sheet Entries in those Sheet Symbols - not directly from the Ports on one sheet to the Ports on another sheet.

It is The Net Identifier Scope that defines how you want the sheet-to-sheet connectivity to be created. This is set in the Options tab of the Options for Project dialog.

A design is flat when the connectivity is directly from one sheet to another - this connective behavior is defined by setting the Net Identifier Scope to Automatic, Flat or Global. Note that if you choose to use a mixture of Ports and Net Labels to create sheet-to-sheet connectivity, you cannot use the Automatic option, in this situation you must manually set the Net Identifier Scope to Global.

A design is hierarchical when the sheet-to-sheet connectivity is only between Sheet Entries on the parent sheet and matching Ports on the child sheet - this connective behavior is defined by setting the Net Identifier Scope to Automatic, Hierarchical or Strict Hierarchical.

No. A multi-channel design must be hierarchical because the software uses this structural model to instantiate the channels in memory when the design is compiled.

For a multi-channel design, set the Net Identifier Scope to Automatic, Hierarchical or Strict Hierarchical.

The duplication of components and nets is resolved by the software, using the naming scheme selected on the Multi-Channel tab of the Options for Project dialog.

Annotation

By default, positional annotation is based on the location of the component's designator. If your positional annotation is not performing according to your expectations, ensure that the designators are positioned correctly. Alternatively, you can opt to use the part - more specifically the center of the part - as the reference for component location.

Choice of using Designator or Part is specified within the Annotate dialog.


PCB Design

General

Here are 2 ways of getting a graphic onto your PCB design:

Pasting from the Windows Clipboard

The PCB Editor supports pasting a metafile directly from the Windows clipboard, onto the current PCB layer, using the standard Windows CTRL+V Paste command. Note that not all image editors place the image data into the clipboard as metafile data. One approach to ensure that this happens, is to first paste the image into Microsoft Word, then copy it from there and paste it into Altium NEXUS.

Supported metafile data includes bitmaps, lines, arcs, simple fills, and true type text - allowing you to easily paste logos and other graphical symbols. Imported data will be put onto the current layer, adopting the color you have chosen for that layer. The PCB objects created during the paste process are automatically added to a Union. After pasting, the Union's editing handles can be used to fine-tune the size of the pasted image. Unions resulting from a paste can also be resized at any time using the Resize Union command from the right-mouse menu (click to select the required union after launching the command).

The Paste from other applications option, on the PCB Editor - General page of the Preferences dialog, is used to set the Preferred Format to Metafile or Text. For a graphic this option has no impact - each independent shape in the graphic is converted to a region object. When pasting a text string, each character is converted to a text string if the option is set to Metafile, whereas the entire string is pasted as an Altium NEXUS string, if the option is set to Text.


The Altium logo being pasted as a graphic, each letter in the graphic is converted into a region object.

Placing a Graphic as a Font

It is possible to create a custom TrueType font that contains a graphic as a glyph (one of the characters in the font) and then place a string on the PCB board that uses that font. As well as the ease of use, another great advantage of this method is that if the font glyphs are created from vector graphic images, then they can be accurately scaled.

A font of many standard symbols used in PCB design, including: lead free, recycle, static sensitive, Earth, C-Tick, UL, CE, FCC, and many others, has been created by one of the leading experts in designing with Altium NEXUS, Darren Moore from Mooretronics. The font is available for download here (dated June 2015), and you can also check the Altium NEXUS forum thread, for more recent versions in the latest posts.

The font is licensed as Cardware, refer to the Readme.txt included in the download ZIP for conditions of use. The readme also includes a list of the available graphics. Note that many are available with text or without text, the preferred version is chosen by using the upper or lower case letter. The image below shows a sample of the graphics available in the font.


A sample of some of the useful graphics in the Mooretronics font.

The Board

The Split Line will remain blue while dragging to a permitted location that will still result in a valid split. If the new location for the end being moved is invalid, for example on the same edge of the board shape as the anchored end, the Split Line will turn red. Attempting to place while the line is red will result in the removal of the Split Line.

You can only fold a board if one of the rigid sections has the 3D Locked option enabled, in the Board Region dialog. Altium NEXUS needs this to know which section of the board must remain fixed during the folding process.

Design Rules & DRC

The most common reason for a polygon clearance rule to fail is that it is targetting the polygon as a single entity, rather than the rule targetting the primitives that make up the polygon. To target the primitives within the polygon, Clearance rules for polygons must use the InPolygon, InPoly, or InNamedPolygon keyword, as opposed to IsPolygon.

Polygon Pours should be thought of as containers for either Region or Track objects, which are regenerated as needed when the polygon pour is repoured. The tracks and regions constitute the physical copper that is created in the PCB manufacturing process. Other objects that correspond to physical copper are arcs, fills, strings, pads and vias. The clearance rule will only operate on these so called 'copper objects'. A clearance rule query will not work if it targets Polygon Pour objects, for example if the query IsPolygon is used. The query needs to target the regions or tracks that are part of the polygon pour by using, for example, InPolygon.

Another thing to ensure is that Polygon clearance rules have a higher priority than the general clearance rule (between All and All). 1 is the highest priority.

Examples:

Set the Clearance between Polygon Pours and all other objects:

First Query InPolygon
Second Query All

Set the Clearance between Polygon Pours attached to nets in the net class Power, and all other objects:

First Query InPolygon and InNetClass('Power')
Second Query All

Set the Clearance between Polygon Pours and objects on the Top Layer:

First Query InPolygon
Second Query OnTopLayer

Set the Clearance between a Polygon Pour named PolyPower_VCC_1 and vias in the GND net:

First Query InNamedPolygon('PolyPower_VCC_1')
Second Query InNet('GND') And IsVia

Routing

To always display the connection lines, enable the All Connections in Single Layer Mode option, in the Additional Options section, on the View Options tab of the View Configurations panel.

During interactive routing, for the net currently being routed the track segments are either displayed as hatched, or hollow (empty). All hatched segments are placed with the next mouse click. The hollow segment is called the Look Ahead segment. Its purpose it to allow you to plan ahead - to consider where the next segment might be placed, without needing to commit to it.

The Look Ahead mode can be toggled on and off, while routing, using the 1 keyboard shortcut.

3D

All 3D navigation is performed by clicking and holding on the right mouse button. RMB on its own to pan, add Ctrl to zoom, or add Shift to rotate.

Board motion is always around the current cursor location, position the cursor before invoking a motion command.

Press 0 (zero) to return the board to its default, flat zero rotation, or 9 to orient it to flat and vertical (90 Degree rotation).

Use the Ctrl+F keyboard shortcut to flip to show the other side of the board.

The main tool used for navigation in 3D layout mode is the rotational sphere, as shown below. Hold Shift down to display the rotational sphere, it will appear at the current cursor location. Then while holding the Shift key down, right-click to engage one of the modes of motion. The selected mode of motion is determined by which of the motion selectors is highlighted when you right-clicked, in the image below you can see that the center dot is highlighted, meaning that as you move the mouse around, the board will rotate around the sphere in all directions, tracking the motion of the mouse. The other modes of motion are flat rotation, X-axis rotation, and Y-axis rotation. Position the cursor over the required motion selector before you right-click, to select that mode.


Shift+right-click and hold to rotate the board around the rotational sphere.

The alternative to using the rotational sphere is to use a 3D mouse, such as the Space Navigator from 3Dconnexion, which greatly simplifies the process of moving and rotating the board in 3D layout mode.

The reference points available in an imported 3D model may not provide a suitable handle to use for positioning that object in Altium NEXUS. Typical reference points that a designer will want to use are the center of a hole, or the center of a pin.

Snap points can be added to any 3D Body, irrespective of model type - extruded, cylinder, sphere, linked/embedded models (STEP, Parasolid, SOLIDWORKS), or a 3D Model Item referenced from a managed content server.

The process of adding a snap point to the center of a circle (hole), or a pin is the same:

  1. Orient and zoom in on the model so the pin or hole is easily accessed.
  2. Select the Tools » 3D Body Placement » Add Snap Points from Vertices command.
  3. Keeping an eye on the Status Bar, position the cursor anywhere over the required target 3D model and click, or press Enter to select. The cursor will change to the 3D positional cursor (blue, six-pointed).
  4. Now press the Spacebar, this toggles the command to its second mode, which is to define a Snap Point half way between 2 selected vertices (as detailed on the Status Bar).
  5. Position the cursor on one edge of the pin or hole, then click to choose that vertex.
  6. Position the cursor on the second vertex, on the opposite side of the pin or hole, then click to choose that vertex.
  7. A Snap Point will be shown in the center of the pin or hole.

Outputs

General

Altium NEXUS data is mapped into an Excel BOM by entering Field=XXXX and Column=YYYY entries into the Excel template used to generate the BOM. For example, Column=LibRef adds a column listing all the components' library references, and Field=Title adds the value defined in the Title parameter. To learn more, see Including Design Data in the Excel BOM.

This error appears when the primitives in the PCB document do not fit into the area specified in the Gerber export settings. This may be because the board/panel is too big for that area, or because there are off-board objects that are making the extents larger than expected.

To enlarge the film size:

  1. Choose the File » Fabrication Outputs » Gerber Files command from the main menus.
  2. In the Gerber Setup dialog that appears, go to the Advanced tab.
  3. Enter appropriate X (horizontal) and Y (vertical) values for the film size; Try generating the gerbers again.
  4. If these values already seem large enough for your PCB, return to the PCB editor, and check for off-board objects.

Finding and removing off-board objects:

Use the View » Fit Document command (keyboard shortcut Ctrl+Page Down). If the PCB file contains objects outside of the board's edges, the screen will resize to contain these objects. If these are far away, the board will appear very small. To remove these objects, go through the following steps:

  1. Deselect everything using the Edit » Deselect » All command from the main menus (keyboard sequence X, A).
  2. Use the Edit » Select » Outside Area, command from the main menus (keyboard sequence S, O) and drag around the whole board.
  3. The off board objects are now selected, and can be deleted. Before deleting, it may be a good idea to open the PCB List panel (by pressing Shift+F12, or choosing View » Panels » PCB List), and review the selected objects. Right-click for the option to Remove Non-Selected objects from the list.

Once these objects are deleted, or otherwise returned to their rightful place within the extents of the PCB, regenerate the gerber files. The error message should not appear.

The Drill Table is automatically updated during output generation, and can be manually updated at any time by clicking the  button in the Properties panel, when the table is selected.

In Altium NEXUS 1.0, automatic updating of the drill table was made available as an Advanced Setting, with a default state of off. Note that enabling the auto-update option may result in performance degradation.


System Installation, Licensing & Management

General

Yes, Altium NEXUS provides you with the ability to send a crash report through to the Altium Developers, should you encounter an error in the software. In the error/exception dialog that appears, simply click the Send Report button and add a description of what you were doing at the time of the error. The more information, the better the chance of the cause of the crash being reproduced and addressed.

Note - if there is a crash that does not raise an exception dialog, and the software hangs in an apparent frozen state, use the Ctrl+Alt+Insert keyboard shortcut to force a crash report. This dialog may pop-up behind the Altium NEXUS application window.

Installation

While you can update your installation of Altium NEXUS to the next primary (or secondary) point release within the same major version stream, it is not possible to update from the previous major version release to the next.

So if you have Altium NEXUS x.0.1 installed, you can validly update to x.y.z, but you could not update to x+1.y.z,

where:

  • x is the current major version.
  • x+1 is the next major version.
  • y is the current primary point release within the current major version stream.
  • z is the current secondary point release within the current major version stream.

So depending on the next version of the software you are considering, you have two choices:

  • An update is available within same major release stream - you can update your current installation, or install the new update as a seperate instance, having both installed side-by-side, and using the version that best suits your needs.
  • The next major version is available - you have the choice to continue with your current version, or to install the next to access the latest features. Alternatively, have both installed side-by-side, and use the version that best suits your needs.
The beauty of installing different version instances is that it enables you to quickly access a previous version directly, and independently, whereas an update effectively replaces the earlier version with the later one.
Each version of the software has its own dedicated installer.

There are two important factors that facilitate the installation of multiple individual version instances of the software:

  • The ability to specify different destination folders during the install, in terms of both the Program Files and Shared Documents install locations.
  • The system's use of a Globally Unique Identifier (GUID) for each independent instance. This identifier - which uses the standard 128-bit URN model and is displayed as a 32-character hexadecimal number - is used to uniquely distinguish the application data folders, as well as entries in the registry. When you run a particular instance of Altium NEXUS, the system handles, through use of this identifier, only those files and registry entries specific to that instance.

For the main program installation and shared documents folders, you have the ability to give those folders meaningful names, which can come in very handy for a machine containing multiple different version instances of the software. But for other folders, they are only distinguished by their GUID. Being able to tell you have the right folder for the right version instance suddenly becomes more difficult. However, help is at hand. By using the Preferences dialog, you can quickly identify the GUID used for the currently open instance of the software and, armed with that knowledge, can pick the right folder through Windows Explorer.

The GUID can be identified on the follow pages of the Preferences dialog (in a standard default installation of Altium NEXUS):

Licensing

No, and that's the beauty of On-Demand licensing - it hides the activation process from the user. There is no activation procedure, nor adding license files in a manual fashion - with On-Demand licensing, just sign in to your account and all applicable licenses, designated for your use, will be presented.

Absolutely. Altium NEXUS continues to support the use of Standalone-type licenses. Standalone licensing allows you to effectively manage your own license through use of a Standalone licensing file (*.alf). This file can be saved, copied and backed-up as required. The .alf file is reusable on a home computer (in accordance with the EULA) simply by copying the file to a specific folder on that computer and then adding the file into your software installation, from the License Management view (accessed by clicking on the  control at the top-right of the workspace and choosing the License Management command from the menu).

With a Standalone license, the only time you need to sign in to your Altium account (through the Altium portal), is when:

  • You are activating the license for the first time.
  • You are reactivating the license (required for example when you have deleted the license and don't have a backup of the license file).
A Group Administrator for your Altium Account can also activate Standalone licensing directly through a Web browser, using the Altium Dashboard. This is especially useful where client computers cannot access the internet for whatever reason. An Admin user - who does have connection to the internet - simply accesses and activates the licenses, then passes the relevant .alf file to each client user in the organization.

Yes, this is possible and depends on the license type you are using. If using an On-Demand license in On-Demand mode, simply use your seat at the office and release it before you go home. Then, at home, access your license, use it, and release it when finished.

If using a Standalone license, simply take a copy of the license file onto your home computer and work away - remembering of course, that you can not run the two installations of Altium NEXUS simultaneously.

You are in no way forced to stay connected to the internet (logged into the Altium portal) to use an On-Demand license. This is just one method in which you can use an On-Demand license - in On-Demand mode - for example where multiple users share the same license and they do not use Altium NEXUS all the time. To use an On-Demand license in an 'offline' (not signed in) mode, you can choose to roam with the license (Roaming mode).

The roaming aspect of an On-Demand license allows you to go 'offline' - you can take your computer where you like and whether there is an internet connection or not, you will still be licensed. You need only sign-in to your account if you wish to return the license ahead of time, or if you want to extend the 'roam time'.

The maximum time that you can roam with an On-Demand license is the life of the actual license itself. This is particularly relevant to timed licenses.

If you are roaming with a seat of an On-Demand license and the roaming period elapses, use of that seat will stop, with no grace period.

Activation of Standalone and Private Server licenses can be performed directly from your web browser using the Altium Dashboard. Access the Dashboard on a non work-critical PC (not running Altium NEXUS). Once you have obtained the required license file(s) (*.alf), you can take the file(s) to your normal, non-net-connected (and work-critical) PC. For more information, see License Activation.

Note that only Group Administrators for an Altium Account can access and use the Altium Dashboard.

Sign-in to your account - the Standalone license available to you will be presented in the Available Licenses region, shown as no longer being used. To use it again, simply reactivate the license, using the Reactivate option.

Alternatively, if you are a Group Administrator for your account, activate and acquire the license file through the Altium Dashboard.

The Altium Portal provides the possibility to deliver our users facilities that are linked securely to their account with Altium. On-Demand licensing is just one example of a portal-delivered feature. Access to the SUPPORTcenter and installation management are two others. All of these elements are attainable through your secure (and unique) login to the portal using your Altium Account (AltiumLive) credentials.

All communication with the Altium Account Management servers, through the applicable Altium Portal, is secure over https.

When you use a feature that connects Altium NEXUS to the on-demand services, Altium may collect the following information:

  • MAC Addresses: Altium uses a computer's MAC address to identify a PC. If you sign in on multiple computers, each sign in request will be recorded uniquely.
  • HDD serial numbers: Along with the MAC addresses, this information provides a robust way to identify a PC for licensing purposes.
  • Altium NEXUS version: Altium uses the software version to differentiate between products so that the correct services can be delivered for each product.

This information, along with your sign-in credentials, allows the Account Management server to confirm valid license usage.

Altium does not, and shall not, read or gather any information about the designs or files you use within Altium NEXUS. All connections to the Altium Portal through Altium NEXUS are secure. Along with the information that is gathered, information that you enter will also be communicated in requests to Altium's Portal. When data is recorded with Altium's Portal, the data will include a time stamp showing when the data was recorded.

If you or your company are concerned about Altium knowing your license usage, you are more than welcome to roam with the licenses, or use Standalone licenses.

You do not remain permanently connected to the Server. Altium NEXUS communicates with the Account Management server, through the secure Altium Portal, by making a request and receiving a response. At that point the connection is closed. There will be numerous requests to sign in, request the available licenses to display, and so on, but each request is independent and then the connection closes.

While using an On-Demand license, Altium NEXUS will make a request to the Account Management server, through the secure Altium Portal, at regular intervals to renew the license, and also to see if someone has forced the release of your license remotely. If the Account Management server is unreachable for any reason, you will not lose your license and can continue to use it. Altium NEXUS will regularly try to restore the connection. Initially Altium NEXUS does this silently, though you may notice error indications in the title bar which go away once connection is re-established. If the Account Management Server is unreachable for an extended period (say, a few hours or more) you will see message dialogs reminding you to re-establish your Internet connection to the Altium Portal. You will still not lose your license.

It is possible to force-release a seat of an On-Demand license that is being used in either On-Demand, or Roaming modes, directly from within Altium NEXUS. For example, if you forget to release your seat at work when you leave for the day, you can release it from your home computer then use the open seat at home. The extent of your 'release powers' depends on whether or not you have administrative rights to your licenses:

  • Have Administrative Rights - you can remotely release a seat used by any user. The seat they are using will be released and they will lose the license.
  • No Administrative Rights - you can only release a seat that you are using (on another computer). The seat will be available again.
When force-releasing a seat of a license currently Roaming on another computer, you will be required to promise, under the Altium Honor Code, that you will not use, or allow others to use, the roaming license on that other computer after its release.
An administrator for your Altium Account can also force release any seat of an On-Demand license, that is currently being used, from within the Altium Dashboard.

From the remote user perspective, if you are Roaming and your license has been released remotely, then you will not notice anything until you sign in. If you are currently using the license in On-Demand mode (or if you sign in while Roaming), then at some point in the next 20 minutes, a warning dialog will appear alerting you to the fact that your license has been released remotely, and by whom, and asking you to use another license to continue using Altium NEXUS. You will then have a further 20 minutes 'grace' use of the license, during which time you should select and use another license. After this time has elapsed, a second warning dialog will appear and use of the 'released' license will cease. Note that if using the license in On-Demand mode, and you sign out and back in again, the license will be released directly, with no grace periods.

All On-Demand licenses have a count of one or more seats that can be used concurrently. Users can acquire the seats to use the license until the count is reached. Subsequent users will not be able to freely use the license, but are able to use it 'over the limit'. The system will regularly check to see if a seat has become available, and will continue to notify the users that they are over the seat limit, until such time as a seat becomes available and is subsequently acquired.

Each instance of Altium NEXUS will maintain a seat of the license where, in each case, that license is an On-Demand license and is being used in On-Demand mode.

On-Demand licenses will not expire. If, for some reason, there are errors during background license validation checks or license renewal, you can continue to use the license and save your work, but you will receive a message of some sort. The message will depend on the situation:

  • If you have lost your internet connection, a message will be displayed in Altium NEXUS's title bar alerting you to the fact that there is an "error signing in".
  • If your session in the portal has timed out for some reason, you may see a sign in dialog.
  • In other situations you may see a message that says "The Altium portal was not able to renew your license. Altium NEXUS will retry shortly."

A session can timeout in several ways. If no requests are made to the portal for an hour or more, the session will timeout. The session will also timeout after about 12 hours, regardless of previous activity. If the portal gets restarted while you are signed in, this will also register as a session timeout.

You can view license usage from the License Management view within Altium NEXUS. Simply click on the plus (+) symbol to the left of a license entry in the Available Licenses grid - the expanded details show who is using a seat of the license, and in which mode.

Alternatively, and if you are an administrator for your account with Altium, access the Reports page of the Altium Dashboard. This page provides a range of license usage monitoring and reporting features for On-Demand licensing. These reports can be used to audit how your licenses are used within your organization. This is useful for ensuring that the best use is being made of the available license seats, for anticipating future license requirements, and to determine the usage of individual users.

Extending Altium NEXUS

Within Altium NEXUS, management of extensions for the software is performed from within the dedicated Extensions & Updates view, accessed by clicking on the  control at the top-right of the workspace and choosing the Extensions and Updates command from the menu.

The Extensions & Updates view can also be accessed directly from the License Management view, by clicking on the Extensions and Updates control, below the available licenses listing.

For each installed extension, its associated installation files are stored in a dedicated folder, named after that extension. Extension folders can be found along the following path: \ProgramData\Altium\Altium NEXUS <GUID>\Extensions. In addition, the root Extensions folder contains a registry file - ExtensionsRegistry.xml - which is used to keep track of all extensions currently installed for that instance of Altium NEXUS.

Altium Dashboard

Only those with administrative privileges (users in the account who are members of the Group Administrators group) will have access to the Dashboard, and the ability to view and modify their organization's account.

A user is an administrator for the account if they are added as a member to the Group Administrators group. Admission to this group occurs in two ways:

  • When a new license is purchased for the account, the Notification Contact for that license is added automatically to the group.
  • A user can be manually added to the group by another account administrator. In other words, a member of the Group Administrators group has the power to bestow administrator powers to another user, simply by making them a member of this group.

The uploaded image of your company's Logo can be 220x220 pixels or less, and either JPG or PNG format.

An organization's profile can be accessed by clicking the related link to that profile, on the profile page of any of its users. A link to an organization's profile page can also be accessed from other areas within the AltiumLive community, typically located in the vicinity of a user's name. For example in a Forum post, or in a BugCrunch report.

To make your organization's profile private - hidden from viewing by the wider AltiumLive community - ensure the Public option is disabled, in the General Information region of the Dashboard's Profile page.

A new user can only be added to the account, provided the email address supplied is not already in use by an existing user. If you attempt to create a new user with a duplicate email address, an error dialog will appear, alerting you to this fact.

This is performed by deactivating, then reactivating the required user. It is the act of activation that triggers the password reset and issuance of an email to that user containing a new, temporary password.

Outside of the Dashboard, a user can reset their own password. This is performed from the AltiumLive Sign-In page, by clicking the Forgot Password link. An email will be sent to that user containing a new, temporary password.

Your password must be at least 8 characters long. It must contain only English letters, one digit, one upper case character, and one lower case character. It cannot contain spaces.

The delete operation cannot be undone. If you delete a user by mistake, you will need to add that user back, in the same way that you would add any new user to the account.

A user can be added as a member to any number of defined groups for an Altium Account.

To remove a user from the list of members for the group, simply uncheck the associated Member checkbox - they will be removed from the list upon updating.

No. You cannot add licenses to, nor delete licenses from, your account using the Dashboard. You will need to contact Altium Sales to discuss purchase of licenses for your account.

This is the expiry date for Subscription on the license, the date on which your right to access content and updates for the software ends.

In terms of license allocation within the Dashboard, you can either browse to a particular license and allocate which groups can use it, or you can browse to a specific group and allocate one or more licenses to it. This applies only to On-Demand and Standalone type licenses.

Both On-Demand and Standalone type licenses can be allocated (targeted) for use by specific groups within the account. This allows you to control exactly who has access to, and use of, your licenses. For a multi-seat On-Demand License, you can assign seats across one or more defined groups. This provides global floating license capability - within the geographic scope of your license and the conditions set out in the EULA - without needing to implement your own server.

Yes. Simply drill down to the management page for such a license and click the Activate button.

When activating a Standalone License, you can activate for any of the supported releases of Altium NEXUS, but only one at a time. When activating a Private Server License, you must repeat the activation process for each supported release of Altium NEXUS that you wish the license to serve.


 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: