Altium Designer Documentation

Draftsman Enhancements

Modified by Rob Evans on Dec 11, 2018

The comprehensive set of electronics design CAD features offered by Draftsman, combined with its deep integration with the Altium Designer PCB design space, has allowed it to become a single solution for the generation of advanced board fabrication and assembly documentation.

Draftsman has been progressively updated to provide additional capabilities and improve performance, and this release continues that trend. Along with the addition of the new features outlined below, the performance of Draftsman’s processes have been substantially increased, resulting in an editing environment that functions smoother and faster.

Board Realistic View

A new level of purely visual information can now be added to the Assembly and Fabrication data in a Draftsman drawing document with the new Board Realistic View.

Placed as a separate and configurable view object, the Realistic View provides a scalable 3D rendering of the current board design. The 3D view is generated by the software’s 3D rendering engine – as applied in the PCB Editor and for 3D print outputs – and may be set to adopt the PCB Editor’s current view angle and configuration.

The new Realistic View is available for placement from the Place » Additional Views » Board Realistic View command on the main menu, or from the additional views drop down menu on the Active Bar.

Use the Properties panel options (View » Panels » Properties) to set the visual properties of a placed and selected view.

Note that the Size setting initially defaults to 100mm for the board’s maximum side dimension. Enter a new dimension, or scale the view in the workspace by dragging its resize handles (located at each vertex).

The Properties section of the panel includes a Custom view setting that allows the view display properties to be set from the current PCB Editor 3D view.

  • Use the button for the view to adopt the PCB Editor’s current 3D view.
  • Use the button to adopt the view settings that are currently applied in the PCB Editor 3D view – as defined in the editor’s View Configuration panel (set to Layer colors in the below example).
  • Since a Board Realistic View is able to adopt the current settings of the PCB Editor 3D view, multiple Realistic View objects can be placed in a Draftsman document where each takes a different configuration/view 'snapshot' from the PCB Editor's 3D view.

Enable Board Layers

Additional layer based information can now be added to both board Assembly and Fabrication views in the Properties panel via a new Layers tab and Show additional data section. The features provide a flexible arrangement for including relevant layer topology and specific mechanical layer information for Draftsman production documents.

Board Assembly View

For a Board Assembly View, the new Show additional data section in the Properties panel allows the selection of layers associated with the current view (Top or Bottom).

With a Top side view for example, the panel’s Topology option displays the board Top Layer – and enables SMD/through-hole pads, which may be selected independently.  The Mask and Paste options select the Top solder mask and paste layers, as determined by the current view side.

A board that has multiple Layer Stack regions, such as a Rigid-Flex design, is likely to have a different Topology (outer layers) in each region. Draftsman allows for this by displaying the appropriate outer layer for each region – say, the Top Layer for the Rigid region and Mid-Layer 2 for the Flex region.

The panel’s new Layers tab is populated with the mechanical layers available in the board design. Multiple layers can be selected for display, where their draw order determined by the listed order. Use the and buttons to specify a layer’s relative list/draw order.

To change the color of a layer overlay on a view, select its associated color icon to open the color selector drop down, which offers standard color shades plus definable RGB levels. The transparency level of a layer color, such as might be used for the solder Mask overlay, is available in the Define Custom Color part of the selector as a percentage slider.

Board Fabrication View

For a Board Fabrication View, the Layers tab offers all board layers for selection. As with the Board Assembly view, the graphic draw order of selected layers is determined by their listed order, which may be modified using the and buttons.

Board Region View

The new Board Region View allows a Draftsman document to include an accurate representation of multiple Layer Stack regions in a board design, such as those applied in Rigid-Flex PCB designs. The Region View is available for placement from the Place » Additional Views » Board Region View command on the main menu, or from the additional views drop down menu on the Active Bar.

A Callout placed in the Region View will automatically identify a board Layer Stack region, and dimensions may be added to the view to provide details of the stack region areas and divisions.

Layer Stack naming and data applied in the Region View is drawn from the PCB design, as represented in the PCB editor’s Board Planning Mode view and Layer Stack Manager – and the new Layerstack visualizer, shown below.

Center Mark

Draftsman now offers a Center Mark object that can be placed on Circle and Arc objects in a drawing document. When placed, the Center Mark object detects and locks to the center point (radius origin) of the Circle or Arc, and is then available as a reference location for placed dimension objects such as Linear and Ordinate dimensions.

The Center Mark object is available for placement from the Place » Annotations » Center Mark command on the main menu, or from the Annotation objects drop down menu on the Active Bar.

When the command is launched, the cursor will change to a crosshair indicating Center Mark placement mode. Hover the cursor over a Circle or Arc outline to snap the crosshair to its center, and then click the highlighted outline to confirm the placement of the Center Mark object.

Center Marks placed on a drawing document are available for dimension bindings. When placing Linear or Ordinate dimensions, select the highlighted dot at intersection of the Center Mark cross as a dimension reference node.

The line style and color of a Center Mark’s indicator cross are available as settings in the Properties panel. The panel also includes a marker Rotation property that can be used to document the angular placement of circles/arcs in a drawing. In this case, a placed Angular Dimension uses one line of a Center Mark cross as an angle dimension reference.

Format Painter

The new Format Painter feature offers a simple and fast way to transfer an existing text style to other Draftsman text elements.

As shown in the above animation, select an existing text element that has the style properties (as defined in the Properties panel) that you would like to propagate, and then choose the Format Painter tool from the Drawing Document Standard toolbar – or Edit » Format Painter from the main menu. This action effectively captures the text style properties.

Use the cursor, which changes to the Format Painter tool icon (), to locate and select other text elements that will adopt the style properties. Compatible text objects include editable text elements such as object Titles and Note items.

Transmission Line Structure Table

The calculations applied in controlled impedance routing result in trace structures that aim to satisfy a target transmission line impedance, and therefore the board design’s high-speed and/or EMF requirements.

Board layers and their specified or calculated properties are accessed through the Layer Stack Manager, where impedance controlled routing layers are associated with definable Impedance Profiles. The board materials and dimensions in each profile are applied to its Transmission Line impedance calculations, which results in a given trace structure. The structure accommodates both single traces and differential pairs, and Stripline (internal) or Microstrip (surface) board layer formats.

► See the new Layer Stack Manager features for more information.

Since the structure and associated data for each Transmission Line definition in the board Layer Stack is important information for the PCB manufacturing process, Draftsman now includes a dedicated Transmission Line Structure Table object to document this information.

The table is populated by data drawn from the Layer Stack Manager and its Transmission Line impedance calculations.

The Transmission Line Table object is available for placement from the Place » Transmission Line Table command on the main menu, or from the Table objects drop down menu on the Active Bar. Use the Properties panel to set the table style (colors, lines, font etc), and under its Columns tab, which data columns are displayed.

Move Callout and Dimension target

The starting/target point for a Draftsman Callout or Linear Dimension can now be moved to a new location through a simple drag and drop action.

When moved, the starting node binds to the new object and causes the Callout or Dimension data to update accordingly, as shown below.

Solder and Glue joint Symbols

Further increasing the mechanical information that can be included in Draftsman design production documents is the addition of GOST defined symbols for Soldered and Glued joints.

The symbols for indicating glued and soldered mechanical joints are governed by the GOST 2.313-82 drawing standard for mechanical connections, and are available as special options in Draftsman’s Callout object. When a Callout has been placed to indicate a glued or soldered mechanical connection, the special symbols may be selected from the Symbol drop down menu in the Properties panel.

The Symbols and options are defined as follows:

  • Gluing – indicates mechanical joint areas for gluing.
  •  Soldering – indicates mechanical joint areas for soldering.
  •  Processing of the contour option – check when a glue or solder joint seam is to be made in a closed area. Places a circle symbol at the end or elbow of the Callout line.

Special Strings in Table cells

Draftsman’s custom Table now supports the inclusion of document Parameters as Special Strings

Project, System, PCB and User Parameters will be converted to their Values when entered as a Special String in the Table cells. Draftsman document Parameters are accessible under the Parameters tab in the Properties panel, when in Document Options mode.

Special Strings to and from Spreadsheets

When pasting Special Strings into a spreadsheet from Draftsman, the target cells will be populated with the string’s interpreted Value.

Similarly, when pasting Special String data from a spreadsheet into Draftsman, the pasted text will be interpreted as a Special String Value – providing the Special String is matched to an available System, Project or User parameter.

When preparing Special String entries in a spreadsheet you will need to prefix each Value entry with an apostrophe, so the cell content will be treated as text data. For example the special string for the Units parameter would be entered as:  ‘=DocumentUnits

Alternatively, all spreadsheet cells could be set to Text format.

Additional updates

Text Object placement

A Text object can now be placed on a Draftsman document with a single mouse click, without the need to manually define its container text box – which is automatically sized to the default text.

Assembly Layer assignment

Mechanical layer pairs that have been specified as Assembly Layers in the PCB design are now automatically detected by Draftsman, and no longer need to be manually selected as Top/Bottom Assembly Layers in the Draftsman Document Options.

Assembly type Component Layer Pairs are specified in the PCB design, under the Layers & Colors tab of the View Configuration panel – the mechanical layer pair containing component data is set to the Assembly Layer Type in the associated Edit Layers Pair dialog.

In a Draftsman Board Assembly View, data from the Assembly Layer are available as an alternative source for Component Body geometry and Designator size/positioning – see the Component Display Properties options in the Board Assembly View properties.

Use the Tools » Update Board command to load any changes made in the source PCB design such as an updated assignment of Assembly type Layer Pairs in the View Configuration panel. When opening a document from a previous version of Draftsman its existing Assembly layer assignments will be retained.

Sheet Numeration

A new sheet numeration parameter that complies with the GOST 2.104-2006 drawing standard is now available.

Unlike the existing SheetNumber parameter, the new SheetNumber_OneSheet parameter will not report the current sheet number when only one sheet exists in the Draftsman document. When multiple sheets exist, the SheetNumber_OneSheet parameter resolves to the same sheet numeration as the standard SheetNumber parameter. The numeration parameters are typically used in a Draftsman Sheet Template.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.