Altium Designer Documentation

Additional Features and Enhancements

Modified by Phil Loughhead on Mar 11, 2019

Unlimited PCB Mechanical Layers with Layer Types

PCB Mechanical Layers have been improved:

  • Define any number of Mechanical Layers, which can be used as individual Mechanical Layers, or paired to create Component Layer Pairs.
  • Improved mechanical layer editing, double-click on a Mechanical Layer or a Component Layer Pair to open the Edit Layer(s) dialog, where the Name, Number and Type can be configured.
  • User-assignable Layer Type, with a range of pre-defined types.
  • Automatic mapping and creation of layers by Layer Type then Layer Number if Type not defined, when a component footprint is placed on a PCB or copied to a library.
  • Supports loading new designs with more than 32 mechanical layers, in older versions of the software.

The introduction of Layer Types helps solve a long-term problem for designers when they are transferring components from one design environment to another, un-aligned mechanical layer usage. If the mechanical objects are placed in the PCB library on layers with a Layer Type assigned, when the component is copied to another library or placed on a board with those Layer Types defined, the mechanical layer contents are automatically mapped to the correct layer in the target library or board, regardless of the layer numbers. This makes it easy for designers to source footprints from different locations, as they no longer need to shuffle mechanical layer contents to suit their pre-defined layer assignments.

Assign Layer Types to both individual mechanical layers and Layer Pairs in your PCB libraries to benefit from automatic layer type mapping when you place component from, or copy components into these libraries.

Learn more about Working with Mechanical Layers

Pad and Via Defined Polygon Thermal Connections

The Thermal Relief style for Polygon connections can now be specified in the Properties panel for placed Pads and Vias. Thermal Relief settings for an individual pad/via will take precedence over the styles defined in the active Polygon Connect Style rule(s).

Reposition PCB Overlay Strings in 3D View Mode

As well as component strings, free text strings can now be repositioned in 3D View Mode.

Include Dimensions in PCB Footprints

Dimensions can now be placed in the PCB library editor. Dimensions are not transferred to the PCB editor when that component footprint is used on a board.

New Sign In Menu

The new account/server menu allows you to sign in to your Altium Account and an available Altium server from one location, and also provides access to the software’s License Management and Extensions & Updates views.

Access the Sign In menu from the icon at the top right of the work area. When signed in to your account, all available local and cloud server services will be listed – click on a server entry to connect. Disconnect from a server by selecting the icon, and when neccessary, manually connect to a server from the menu's Custom option.

New Open Project Dialog

The updated Open Project dialog (File » Open Project) now provides a single location to search, browse and open Managed or unmanaged Projects.

Select File » Open Project to access the dialog, which presents a list of selectable source options in the left pane:

  • Recent – List of recently opened projects from local or server sources. The icon for server-based projects is shaded red where its source server is not connected/available ().
  • [Server] – Managed Projects available in a connected managed content server.
  • Local Projects – Projects stored in the current default location, as specified in the System – Default Locations page of the Preferences dialog.

The button is available for browsing to and opening a project through the standard Windows Open dialog.

Use the dialog’s information button () to view additional details for the selected project, which include the basic project information and for server-based Managed Projects, all project Parameters.

When viewing Managed Projects, the default view shows all projects available within the server’s top level project folder and its subfolders. To view and navigate through the project folder hierarchy, select the folder view button () to access project folders and the breadcrumb path in the dialog’s Search bar.

New Create Project Dialog

The functionality and UI of the dialog used to create a new project has been simplified and enhanced. Formerly the New Project dialog, the new Create Project dialog (File » New » Project) provides the following updated features:

  • Direct selection of the project target location (server, version controlled repository or local folder) in the LOCATIONS pane. The selection inherently determines the type of project that will be created (Managed, VCS or file).
  • The ability to add custom Parameters to the project, through the Parameters drop down box, as the project is being created. Added Project Parameters can be accessed in the Options for Project dialog (Project » Project Options) – in the Server Parameters tab for a managed project (read only), or in the Parameters tab for a local or Version Control project.

  • The available Templates are now shown in a hierarchical format with the type of projects in the Project Type list.

Script and Integrated Library projects are now created through the File » New » Script and File » New » Library menus, respectively.

Improved Component Types Management

The Component Type parameter associated with Managed Components facilitates both the search and categorization of components in multiple locations through Altium Designer. The Component Type for a selected component is assigned or edited through the Component type dialog, which available from a range of editors and panels.

The functionality of the Component type dialog has been updated to correctly detect components with an unassigned Type, and the list of available Component Types – for the currently connected server – is now managed through the software Preferences.

To manage the list of available Component Types, open the Data Management – Component Types page of the Preferences dialog, which can be accessed directly from the button in the Component type dialog.

Within the Preferences, the alphabetically ordered Component Types listing is managed with the following features:

  • Use the and buttons to include (and name) a new Type entry or delete and existing entry. Component Types that are in use – assigned to a server component – cannot be deleted, and duplicate Component Types are not permitted.
  • Use the and buttons to arrange the hierarchical position of an entry. An Indented entry will become a subtype of the next (lower) entry in the list.
  • Drag and drop a Component Type entry to a new location to change its position in the hierarchy. An entry becomes a subtype of another when dropped onto it.
  • Close and reopen the dialog to restore the alphabetical listing order if it has been disrupted.

The Data Management – Component Type preference settings apply to the currently connected managed content server.

The Component type dialog is available from:

  • The Components panel – right click on a component entry in the list and select Operations » Change Component Type from the context menu.
  • The Explorer panel – right click on a component entry Revision and select Operations » Change Component Type from the context menu.
  • The Manufacturer Part Search panel – when acquiring a selected component to the connected managed content server (Acquire selected from the right-click menu) the Component type dialog automatically opens so an appropriate Component Type may be selected. The component is then opened in the Single Component Editor, prior to its release to the server.
  • The Single Component Editor – when a component is open in the editor, its Component Type setting is specified in the Type drop down menu under the Advanced Settings options. Select the associated button to open and manage the Component Types list in the software Preferences.

Ranking Part Choices

Part Choices provide a mechanism to decouple the design component from the manufacturer part that is purchased through the supply chain. By adding multiple Part Choices the designer can add supply chain details for multiple parts, without needing to edit that information into the design component parameters.

Part Choices can now be ranked where ever Part Choices are added or edited. For example, Part Choices can be ranked in the Single Component Editor, setting their preferred order in the BOM. If there are multiple Part Choices defined, their order is automatically updated to suit the current ranking.

Component Part Choice ranking is also available through the Components panel, and also in the ActiveBOM BomDoc.

Configure the Cache Location for SVN Libraries

The SVN Database Libraries cache folder location can now be specified in the Data Management - SVN Libraries page of the Preferences dialog.

Project Groups

This release sees a change in the name of the Design Workspace (*.DsnWrk) to Project Group (*.DsnWrk). This name change (the extension remains unchanged) is reflected throughout the GUI, wherever Workspaces were presented, examples of which are shown in the following image:

Creating 3D Bodies from Objects

The ability to create 3D Bodies from selected tracks, arcs, and regions had been added in this release. This feature is accessed by choosing Tools » Convert » Create 3D Body From selected primitives from the main menus.

Layer Numbers Displayed in Layer Tabs

Layer numbers are now displayed for layer tabs by default. To hide/show the layer numbers, toggle the Show Layer Numbers option accessed by right-clicking on a layer tab.

Rules Added to Properties

A Rules region has been added to the Parameters tab of the Properties panel when a placed component on a schematic document is selected, or when accessing the properties for the schematic document itself (when no objects are selected). This region allows design rules to be specified at the component and/or document level on the schematic side, prior to layout.

   

 

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.