PCB Libraries

The real-world component that gets mounted on the board is represented as a schematic symbol during design capture and as a PCB footprint for board design. Altium Designer components can be:

  • Created in and placed from local libraries or
  • Placed directly from a connected Workspace, accessible for the entire design team.
This document outlines the creation and management of PCB libraries (*.PcbLib). To learn more about creating a PCB footprint itself, refer to the Creating a PCB Footprint page.

Footprints can be copied from the PCB editor into a PCB library, copied between PCB libraries, or created from scratch using the Footprint Wizard or drawing tools.

Creating a New PCB Library

To create a new PCB library, select the File » New » Library command from the main menus and select the PCB Library option from the File region of the New Library dialog.

After clicking Create, a new PCB library document named PcbLib1.PcbLib is created and shown in the Projects panel, and an empty component sheet called PCBComponent_1 displays.

The content of the library is shown in the PCB Library panel.

You are now ready to add, remove, or edit the footprint components in the new PCB library using the PCB footprint editor commands.

Creating a PCB Library from a PCB Document

If you have a PCB design with all the footprints already placed, you could use the Design » Make PCB Library command in the PCB editor to generate a PCB library that includes only those footprints. This is very useful if you want to create an exact working library, or archive, of your finished design.

After launching the command, a library document (<PCBDocumentName>.PcbLib) will be automatically created (and stored in the same location as the PCB document from which it was created) and added to the project. The created file will appear in the Projects panel as part of the project, under the Libraries\PCB Library Documents sub-folder. The document will open as the active document in the PCB footprint editor. Each unique PCB component detected on the PCB will then be added to the library.

Creating a New PCB Footprint

Any number of PCB footprints can be created in a PCB library. To create a new PCB footprint in an existing library, select the Tools » New Blank Footprint command from the main menus, right-click in the design space then choose the Tools » New Blank Footprint command from the context menu, or right-clicking in the Footprints region of the  PCB Library panel then choosing New Blank Footprint from the context menu.

Since a new library always contains one empty PCB footprint, you can also rename Component_1 to get started on creating a footprint. To do this, select PCBComponent_1 from the Footprints list in the panel then click the Edit button in the panel or double-click PCBComponent_1 to open the Footprint tab of the Properties panel in its Library Options mode. Type the new footprint name that uniquely identifies it in the Name field.

To remove the active footprint from the current PCB Library document, choose the Tools » Remove Footprint command from the main menus or right-click in the design space then choose the Tools » Remove Footprint command from the context menu. After launching the command, a confirmation dialog will appear asking whether you want to proceed with the deletion. After clicking Yes, the footprint will be removed from the library document and the previous footprint in the Footprints list will be made active. One or more library footprints can also be deleted directly in the PCB Library panel. Select the required footprint(s) in the Footprints list, right-click then choose the Delete command from the context menu. A confirmation dialog will appear asking whether you want to proceed with the deletion of n footprints. After clicking Yes, the footprint(s) will be removed from the library document and the subsequent footprint in the Footprints list will be made active.

Creating a Footprint Using the IPC Footprint Batch Generator

In addition to the techniques described on the Creating a PCB Footprint page, the IPC Footprint Batch Generator can be used to generate multiple footprints at multiple density levels. The generator reads the dimensional data of electronic components from an Excel spreadsheet or comma-delimited file then applies the IPC equations to build PCB footprints that are truly compliant with Revision B of the IPC standard 7351 - Generic Requirements for Surface Mount Design and Land Pattern Standard.

Functionality is provided courtesy of the IPC Footprint Generator extension (a Software Extension).

The IPC Footprint Generator extension
The IPC Footprint Generator extension

The IPC Footprint Batch Generator functionality can only be accessed provided the IPC Footprint Generator extension is installed as part of your Altium Designer installation. This extension is installed by default when installing the software, but in case of inadvertent uninstall can be found on the Purchased tab of the Extensions and Updates page (click on the  control at the top right of the design space then choose Extensions and Updates from the menu). If reinstalling, remember to restart Altium Designer once the extension has been successfully downloaded and installed.

The batch generator can create the following footprint types: BGABQFPCAPAECFPCHIPChip ArrayCQFPDFNDIPDPAKFMLCCLGAMELF DIODE/RESISTORMOLDED CAP/IND/DIODEPLCCPQFNPQFPPSONQFNQFN-2ROWSIPSODFLSOICSOJSONSOPSOT143/343SOT223SOT23SOT89SOTFLWIRE WOUND, and ZIP.

Support for the IPC Footprints Batch Generator includes:

  • Package type blank template files are included in the \Templates folder in the Altium Designer installation.
  • Package input files can contain the information for one or more footprints of a single package type and can be either an Excel or comma-delimited (CSV) format file.

Select the Tools » IPC Compliant Footprints Batch Generator command from the main menus to access the IPC Compliant Footprints Batch Generator dialog. Use the dialog to add the footprint package files that you need to process, and set generation options as required.

The IPC Footprints Batch Generator has options to either create all the footprints in the open PCB footprint library or generate a single library based on either an input file or footprint name.
The IPC Footprints Batch Generator has options to either create all the footprints in the open PCB footprint library or generate a single library based on either an input file or footprint name.

The process is summarized as follows:

  1. Add files to be processed to the list. These can be Excel-based, or CSV-based. Use the Add Files/Remove Files buttons to craft the list, or simply drag and drop files into the list area.
  2. Specify an output folder for generated output (if generating new PCB Library files as part of the process).
  3. Use the options to determine how the footprints are generated. All footprints can be generated in the active PCB Library document. Alternatively, generate one PCB Library document per input file (named the same as the input file), or one PCB Library document per footprint name (named using the FootprintName field specified in the file, or using IPC naming if this is blank). Generated library files will be stored in accordance with the nominated Output Folder.
  4. Optionally, choose to have a HTML-based report created (and optionally opened after processing completes). This lists the date, time, and processing time, along with all the files processed, and any related fatal errors, errors, and warnings.
  5. If you have opted to generate new PCB libraries, you can also opt to have these opened after generation is complete.

After defining the list of files to be processed and all other options as required, click Start. Processing will proceed, with progress reflected in the dialog. You can cancel at any time by clicking Stop, or Close. Once the generation of all footprints has finished, click Close to leave the dialog, and enjoy the fruits of the generator's labor.

  • Paste masks are split into small fills for packages with a large thermal pad (sized 2.1mm x 1.6mm, or larger).
  • For packages involving gullwing leads, pads are trimmed to prevent them from otherwise extending under the package's body.
  • For small packages having a large central thermal pad (PQFP, QFN, SOIC, and SOP), the peripheral pads are trimmed to ensure required clearance between the pads in accordance with the IPC Standard.
  • All dimensions are entered into the Wizard in metric (mm) units.
  • Consult the legends in the underlying Excel templates (accessed from the Open Template menu in the IPC Compliant Footprints Batch Generator dialog), for the current data sets for each of the supported packages. The templates for package type files are located in the \ProgramData\Altium\Altium Designer <GUID>\Extensions\IPC Footprint Generator\Templates folder, for a default installation of the IPC Footprint Generator extension. Use these as a basis for creating the package files to 'feed' into the generator.
  • To quickly generate a single IPC-compliant footprint, use the IPC Compliant Footprint Wizard.

Adding Footprints from Other Sources

PCB components can be copied from other PCB libraries and then renamed and modified within the destination library to match the specifications required. There are a number of ways to execute this function.

  • Select placed footprint(s) in a PCB document then copy (Edit » Copy) and paste them into an open PCB library using Edit » Paste Component. If multiple components have been copied to the clipboard from the PCB editor, all will be pasted into the library document as separate component footprints.
  • Select Edit » Copy Component when the footprint to be copied is active in the PCB Library Editor, change to the open PCB destination library then select Edit » Paste Component.
  • Select one or more footprints in the list in the PCB Library panel using the standard Shift+Click or Ctrl+Click, right-click then choose Copy. Switch to the target library, right-click in the list of footprint names then choose Paste n Components, where n is the number of components.
If the same component is pasted into the library more than once, it is highlighted by the suffix DUPLICATE or DUPLICATEn, where n is the number of the duplicate when more than one duplicate exists.

Note that if the component was placed on the PCB from your connected Workspace or from the Manufacturer Part Search panel, a link to the source Workspace remains. You can clear the Workspace links for all components within the open library by choosing the Tools » Clear Server Links command from the main menus. After launching the command, the Confirm Clear Vault Links dialog opens. Click Yes to clear the Workspace links specified in the dialog and save the library; click No to exit from the dialog with no action.

The clipboard can store a number of objects that can be added (pasted) to various document types within Altium Designer. The clipboard supports a variety of data formats, depending on the origin and object type, and can be set to store either only objects copied or cut from within the Altium Designer environment or the entire Windows clipboard - using the Monitor clipboard content within this application only option on the System - General page of the Preferences dialog. Be aware that not all data types are supported by each design editor and that objects that are not supported will not be pasted.

Checking the Footprints and Generating Reports

To check that the new footprints have been created correctly, there are several reports that can be generated.

Library List

To generate a report listing all PCB footprints in the current PCB Library document, choose the Reports » Library List command from the main menus. After launching the command, the report will be generated (<PCBLibraryDocumentName>.REP) in the same folder as the source PCB Library document and will automatically be opened as the active document in the main design window. The report summarizes the total number of component models in the library and lists all of the component models by name.

The report will be added to the Projects panel as a free document under the Documentation\Text Documents sub-folder.

Library Report

You can generate a report from the active library document, containing information about the components stored within that library. The report can be configured to include component previews (drawn in color or left black and white). The report can be generated as a Microsoft Word document (*.doc), or as a standard HTML document (*.html).

Select the Reports » Library Report command from the main menus to open the Library Report Settings dialog. Use this dialog to configure the content and style of the report, and also where (and by what name) the report is to be generated. By default, the report will be named after the PCB library, and stored in the same location.

The Library Report Settings dialog
The Library Report Settings dialog

After clicking OK the report will be generated. If you have opted to have the report opened after generation, this will happen provided you have either Microsoft Word (if generating a Doc style report), or Microsoft Internet Explorer (if generating a HTML style report) installed on your computer.

If you have chosen to add the generated report to the project after generation, it will appear in the Projects panel under the Generated\Documents sub-folder (for a HTML style report), or the Generated\Text Documents sub-folder (for a Doc style report).

Component Rule Checker

To validate all components in the active library, the PCB footprint editor provides a Component Rule Checking feature. This feature offers a number of checks, including checking for duplicate primitives, missing pad designators, floating copper and an inappropriate component reference. The result is a text-based report that lists any violations of these checks. To run the Component Rule Check:

  1. Save your library file.
  2. Select Reports » Component Rule Check (shortcut R, R) to open the Component Rule Check dialog.

  3. Check all the boxes available then click OK. A report titled <LibraryName>.ERR is generated and opens in the Text Editor. Any errors will be noted. Each component footprint that is found to be in error is listed, along with the specific tests that it failed.
  4. Close the report to return to the PCB footprint editor.
A Component Report can be generated for the active PCB footprint - learn more.

Updating a PCB Footprint

Updating a PCB Footprint from a PCB Library can be done in two ways: "Pushing" the PCB from the PCB Library, or by "Pulling" from the PCB editor. Pushing a PCB Footprint update takes a selected footprint(s) from the PCB Library and uses it to update all open PCB documents containing that footprint. This first method is the best option when a complete replacement is desired. The second option allows you to review all the differences between the existing footprint and the footprint in the library before the update is performed. You can also select which objects are to be updated from the library. This second method is the best option when you need to figure out exactly what has changed between the footprint on the board and the footprint in the library.

Pushing Footprint Updates from the PCB Library

From the PCBLIB Editor, use the Tools » Update PCB with Current Footprint (when the footprint whose changes you want to pass to the PCB document(s) is the active footprint) or Tools » Update PCB With All Footprints command. From the PCB Library panel, right-click in the Components region of the PCB Library panel then select Update PCB with [Component] or Update PCB with All. Running these commands opens the Component(s) Update Options dialog from where you can select the primitives/attributes to be updated. Use this dialog to determine which aspects of the footprint are to be updated. After clicking OK, all placed instances of this footprint on all open PCB documents will be updated with any changes made in accordance with specified update options.

The selected updates will be pushed to correlating footprints in all open PCB documents (regardless to which project they belong).

Pulling Footprint Updates from the PCB Editor

From the PCB editor, use the Tools » Update From PCB Libraries command, which, in turn, opens the Update From PCB Libraries - Options. Click OK to open the Update From PCB Libraries dialog.

PCB Library Panel

The PCB Library panel enables you to browse footprints stored in the active PCB library document and edit their properties. When a PCB Library document is active, the panel becomes populated with information pertaining to the constituent footprints of that library. The panel also offers the ability to pass on any changes made to them directly to the PCB design document.

The PCB Library panel
The PCB Library panel

If you find an issue, select the text/image and pressCtrl + Enterto send us your feedback.
Note

The features available depend on your Altium product access level. Compare features included in the various levels of Altium Designer Software Subscription and functionality delivered through applications provided by the Altium 365 platform.

If you don’t see a discussed feature in your software, contact Altium Sales to find out more.

Content