Tutorial - Capturing the Schematic in Altium Designer

Created: July 12, 2022 | Updated: July 12, 2022

Parent page: Tutorial - A Complete Design Walkthrough with Altium Designer

Placing from the Components Panel onto the Schematic

When Altium Designer is connected to a Workspace, the Components panel will list all components available for use in a project design, from this Workspace. For such components, the Components panel supports the same search features that are available in the Manufacturer Part Search panel, including string-based searching, faceted searching, or a combination of both, and also the Find Similar Components feature.

To open the Components panel, click the Panels button button at the bottom right of the application window and select Components from the menu.

The panel’s Categories pane (or the drop-down menu in panel's compact mode) lists available Workspace library components under the All category entry. When the panel is in its normal mode, click the Categories list icon or the « icon to collapse or expand the display of the list. The structure of categories reflects component types currently defined on the connected Workspace (use the Data Management – Component Types page of the Preferences dialog for viewing and managing Component Types).

Components panel
The Components panel being used to browse components stored in a Workspace.

To place a component from the panel, you can:

  • Click the Place button in the Component Details pane – the cursor automatically moves to be within the bounds of the schematic sheet and the component appears floating on the cursor; position it and click to place. After placing a component, another instance of the same component will appear on the cursor; right-click to drop out of placement mode.

    Components panel, placing from component details pane

  • Right-click on the component and select Place from the context menu. The component appears floating on the cursor; position it and click to place. Note that if the panel is floating over the design space, it will fade to allow you to see the schematic and place the component. After placing a component, another instance of the same component will appear on the cursor; right-click to drop out of placement mode.
  • Click, Hold&Drag – click and drag the component from the grid region of the panel onto a schematic sheet. This mode requires that the cursor is held down; the component is placed when the cursor is released. Using this technique only one component is placed. After placing the component, you are free to select another component or another command.

Placement Tips

While the component is floating on the cursor, you can:

  • Press Spacebar to rotate it counterclockwise in 90º increments.
  • Press X to flip it along the X-axis; press Y to flip it along the Y-axis.
  • Press Tab to display the Properties panel and edit the properties of an object prior to placement. The values entered become the defaults. If the designator has the same prefix, it will be auto-incremented.
  • During component placement, the software will automatically pan if you touch the window edge. Autopanning is configured in the Schematic – Graphical Editing page of the Preferences dialog. If you accidentally pan beyond where you want, while the component is floating on the cursor you can:
    • Ctrl+Mouse Wheel to zoom out and in again, or
    • Right-Click, Hold&Drag to slide the schematic around, or
    • Ctrl+PgDn to display the entire sheet again.
  • If the Components panel is floating over the schematic sheet when you place a part, it will automatically become transparent whenever the cursor+component gets close to it. The transparency of floating panels is configured in the System – Transparency page of the Preferences dialog. Alternatively, all floating panels can be hidden/displayed at any time (while running a command or not) by pressing the F4 shortcut.

Learn more about Schematic Placement & Editing Techniques

Working with the Properties panel during Placement

During object placement, if you press Tab the editing process will pause and the interactive Properties panel in its appropriate mode will open. The default behavior is for the most commonly edited field to be highlighted, ready for editing. Because the editing process is paused, you can use the cursor (or press Tab on the keyboard) to move to another field in the panel.

When you have finished editing, click the Pause button (Pause button) as shown in the image below to return to object placement. Alternatively, press Enter to finish object editing and return to object placement.

Demonstration of pausing to edit the schematic component properties on the fly
Editing is paused when you press Tab during placement – click the Pause icon on the screen to return to placing the component.


Placing the Multivibrator Parts

With the Components panel, components acquired from Manufacturer Part Search will be placed in the Multivibrator circuit. Once you have placed the components, the schematic should look like the image below.

You can proceed to find and place the components. Note that the collapsible sections below include tips on editing during placement, which is more efficient than editing after placement. If you choose to leave the editing until after the components are placed, click to select the component and edit it in the Properties panel.

Multivibrator schematic, parts placed
All the components have been placed, ready for wiring.

  1. Select View » Fit Document from the main menus (shortcut: V, D) to ensure your schematic sheet takes up the full editing window.
  2. Open the Components panel if not already – click the Panels button button at the bottom right of the application window and select Components from the menu.
  3. Click the Components panel menu button at the top of the Components panel and select Refresh from the menu to update the panel's content with the components acquired from Manufacturer Part Search.
  4. Use panel's Search field to search for: transistor BC547.

    Components panel, searching for a transistor

  5. Display the Component Details pane of the panel using the Components panel, component details button (or using the Components panel, compact mode, component details button at the bottom of the panel when the panel is in its compact mode) so that you can explore the properties and models of the selected component.
  6. Click to select the required transistor in the results grid in the panel then click the Place button (as shown below). The cursor will change to a crosshair and you will have a symbol of the transistor floating on your cursor. You are now in part placement mode. If you move the cursor around, the transistor will move with it.

    Do not place the transistor yet!

    Components panel, transistor placement

  7. Before placing the part on the schematic, you can edit its properties, which can be done for any object floating on the cursor. While the transistor is still floating on the cursor, press the Tab key to open the Properties panel. The default behavior is to automatically highlight the most-used field in the panel, ready for editing; in this case, it will be the Designator. Note that each section of the panel can be individually expanded or collapsed, which means your panel might look different.

    Properties panel, edit component designator
    Set the Designator to Q1, and the Comment to be visible.

  8. In the Properties section of the panel, type in the Designator Q1.
  9. Confirm that the visibility control for the Comment field is set to visible (Component Comment visibility button).
  10. Leave all other fields at their default values then click the Pause button (Pause button) to return to part placement.
  11. Move the cursor, with the transistor symbol attached, to position the transistor a little to the left of the middle of the sheet. Note the current snap grid, which is displayed on the left of the Status Bar at the bottom of the application window. It is 100mil; you can press the G shortcut to cycle through the available grid settings during object placement. It is strongly advised to keep the snap grid at 100mil or 50mil to keep the circuit neat and make it easy to attach wires to pins. For a simple design such as this, 100mil is a good choice.
  12. Once you are happy with the transistor's location, click the left mouse button or press Enter on the keyboard to place the transistor onto the schematic. The location can be changed later if required.
  13. Move the cursor and you will find that a copy of the transistor has been placed on the schematic sheet, and you are still in part placement mode with the transistor symbol floating on the cursor. This feature allows you to place multiple parts of the same type.
  14. You are ready to place the second transistor. This transistor is the same as the previous one so there is no need to edit its attributes before you place it. The software will automatically increment the component designator when you place multiple instances of the same part. In this case, the next transistor will automatically be designated Q2.
  15. If you refer to the schematic diagram shown above, you will notice that Q2 is drawn as a mirror of Q1. To horizontally flip the orientation of the transistor floating on the cursor, press the X key on the keyboard. This flips the component along the X axis.
  16. Move the cursor to position the part to the right of Q1. To position the component more accurately, press the PgUp key twice to zoom in two steps. You should now be able to see the grid lines.
  17. Once you have positioned the part, click the click the left mouse button or press Enter to place Q2. Once again a copy of the transistor you are "holding" will be placed on the schematic and the next transistor will be floating on the cursor ready to be placed.
  18. Since both of the transistors have been placed, exit part placement mode by clicking the right mouse button or pressing the Esc key. The cursor will revert back to a standard arrow.
  1. Return to the Components panel and search for: capacitor 22nF 16V 0603.
  2. Select the found capacitor in the search result grid, right-click on it then select Place from the context menu.
  3. While the capacitor is floating on the cursor, press the Tab key to open the Properties panel.
  4. In the General section of the panel, type in the Designator C1.
  5. Expand the Parameters section of the Properties panel and open the Value drop-down of the Footprint entry. Many of the resistors and capacitors have several footprint models, for different density levels. Select the A variety as shown in the image below.

    Properties panel, edit footprint

  6. Using visibility controls in the Parameters section of the panel, enable the visibility of the Capacitance parameter and disable the visibility of other parameters. Value of the Capacitance parameter will be shown next to the component in the design space.

    Click the Show More link in the panel's Parameters region to show the full list of component parameters.
  7. Leave the other fields at their default values and click the Pause button (Pause button) to return to part placement; the capacitor will be floating on the cursor.
  8. Press the Spacebar to rotate the component in 90° increments until it has the correct orientation.
  9. Position the capacitor above the transistors (refer to the schematic diagram shown earlier) and click the left mouse button or press Enter to place the part.
  10. Position and place capacitor C2.
  11. Right-click or press Esc to exit the part placement mode.
  1. In the Components panel, search for: resistor 100K 5% 0805.
  2. Select the found 100K resistor in the search result grid and display the footprint in the Models section of the panel.
  3. Many of the resistors and capacitors have several footprint models, for different density levels. Select the M variety as shown in the image below. This selection can be done before the component is placed on the schematic during schematic placement or after schematic placement.
  4. Right-click on the resistor in the search results grid and select Place from the context menu, as shown below.

    Manufacturer Parts Search panel, right click to place the selected part

  5. While the resistor is floating on the cursor, press the Tab key to open the Properties panel.
  6. In the General section of the panel, type in the Designator R1.
  7. In the Parameters section of the panel, enable the visibility of the Resistance parameter and disable the visibility of other parameters.
  8. Leave all other fields at their default values and click the Pause button (Pause button) to return to part placement; the resistor will be floating on the cursor.
  9. Press the Spacebar to rotate the component in 90° increments until it has the correct orientation.
  10. Position the resistor above and to the left of the base of Q1 (refer to the schematic diagram shown previously) and click the left mouse button or press Enter to place the part.
  11. Next, place the other 100k resistor, R2, above and to the right of the base of Q2. The designator will automatically increment when you place the second resistor.
  12. Exit part placement mode by clicking the right mouse button or pressing the Esc key. The cursor will revert back to a standard arrow.
  13. The remaining two resistors, R3 and R4, have a value of 1K; search for: resistor 1K 5% 0805 fixed in the Components panel.
  14. Select the found 1K resistor in the search result grid and display the footprint in the Models section of the panel.
  15. Many of the resistors and capacitors have several footprint models, for different density levels. Select the M variety.
  16. Right-click on the resistor in the search results grid and select Place from the context menu.
  17. While the resistor is floating on the cursor, press the Tab key to open the Properties panel.
  18. In the General section of the panel, type in the Designator R3.
  19. In the Parameters section of the panel, enable the visibility of the Resistance parameter and disable the visibility of other parameters.
  20. Leave all other fields at their default values and click the Pause button (Pause button) to return to part placement; the resistor will be floating on the cursor.
  21. Press the Spacebar to rotate the component in 90° increments until it has the correct orientation.
  22. Position and place R3 directly above the Collector of Q1, then place R4 directly above the Collector or Q2, as shown in the image above.
  23. Right-click or press Esc to exit part placement mode.
  1. Return to the Components panel and search for: connector male straight.
  2. Select the found connector in the search result grid, right-click on it then select Place from the context menu.
  3. While the header is floating on the cursor, press Tab to open the Properties panel and set the Designator to P1.
  4. Click the Pause button to return to part placement.
  5. Before placing the header, press Spacebar to rotate it to the correct orientation. Click to place the connector on the schematic, as shown in the image above.
  6. Right-click or press Esc to exit part placement mode.
  7. Save your schematic locally.

Editing in the Properties Panel

One of the powerful features of the Properties panel is that it supports editing multiple selected objects at the same time.

  • If all objects share a property, that property will be available for editing.
  • If all objects share the same property value, that value will be displayed.
  • If objects share the same property but have different values, it will display an asterisk (*).
  • The value entered or option chosen is applied to all selected objects.

Demonstration video, editing in the Properties panel
Use the Properties panel to edit the properties of multiple selected objects. The selected components are rotated to force their strings to the default locations.

You have now placed all the components. Note that the components shown in the image above are spaced so that there is plenty of room to wire to each component pin. This is important because you cannot place a wire across the bottom of a pin to get to a pin beyond it. If you do, both pins will connect to the wire. If you need to move a component, click and hold on the body of the component then drag the mouse to reposition it.

Component Positioning Tips

  • To reposition any object, place the cursor directly over the object, click and hold the left mouse button, drag the object to a new position then release the mouse button. Movement is constrained to the current snap grid, which is displayed on the Status Bar. Press the G shortcut at any time to cycle through the current snap grid settings. Remember that it is important to position components on a coarse grid, such as 50 or 100mil.
  • Once a component has been placed on the schematic, the software will attempt to maintain connectivity (keep the wires attached) if the component is moved. This connective-aware movement is referred to as dragging. To move the component without maintaining connectivity, hold Ctrl as you click and drag the component. To switch the default behavior from dragging to moving, disable the Always Drag option in the Schematic – Graphical Editing page of the Preferences dialog.
  • You can also re-position a group of selected schematic objects using the arrow keys on the keyboard. Select the objects then press an arrow key while holding down the Ctrl key. Hold Shift as well to move objects by 10 times the current snap grid.
  • The grid can also be temporarily set to the minimum 10mil value while moving an object with the mouse; hold Ctrl to do this. Use this feature when positioning text.
  • The grids you cycle through when you press the G shortcut are defined in the Schematic – Grids page of the Preferences dialog (Tools » Preferences). The Units controls on the Schematic – General page of the Preferences dialog are used to select the measurement units; select either Mils or Millimeters. Note that Altium Designer components are designed using an imperial grid; if you change to a metric grid, the component pins will no longer fall onto a standard grid. Because of this, it is recommended to use Mils for Units unless you plan on only using your own components.

Wiring up the Circuit

Wiring is the process of creating connectivity between the various components of your circuit. To wire up your schematic, refer to the sketch of the circuit and the animation shown below.

Demonstration video, wiring the multivibrator schematic

Use the Wiring tool to wire up your circuit. Toward the end of the animation, you can see how wires can be dragged.

The Active Bar

The tools most commonly used in each editor are available on the Active Bar, which is displayed at the top of the editing window.

Place a Net Label, using the Active Bar

The buttons on the Active Bar are either single-function or multi-function. Multi-function buttons are indicated by a small white triangle in their bottom-right corner. Click and hold anywhere on a multi-function button for one second or right-click it – a menu will appear listing other available commands. The last-used command will become the default for that button location.

  1. To make sure you have a good view of the schematic sheet, press the PgUp key to zoom in or PgDn to zoom out. Alternatively, hold down the Ctrl key and roll the mouse wheel to zoom in/out, or hold Ctrl + Right Mouse button down and drag the mouse up/down to zoom in/out. There are also a number of useful View commands in the right-click View submenu, such as Fit All Objects (Ctrl+PgDn).
  2. First, wire the lower pin of resistor R1 to the base of transistor Q1 in the following manner. Click the Wiring tools button button on the Active Bar (Place » Wire, or Ctrl+W shortcut) to enter the wire placement mode. The cursor will change to a crosshair.
  3. Position the cursor over the bottom end of R1. When you are in the right position, a red connection marker (red cross) will appear at the cursor location. This indicates that the cursor is over a valid electrical connection point on the component.
  4. Left-click or press Enter to anchor the first wire point. Move the cursor and you will see a wire extend from the cursor position back to the anchor point.
  5. Position the cursor over the base of Q1 until you see the cursor change to a red connection marker. If the wire is forming a corner in the wrong direction, press Spacebar to toggle the corner direction.
  6. Click or press Enter to connect the wire to the base of Q1. The cursor will release from that wire.
  7. Note that the cursor remains a crosshair indicating that you are ready to place another wire. To exit placement mode completely and go back to the arrow cursor, you would right-click or press Esc again – but don't do this just now.
  8. Next, wire from the lower pin of R3 to the collector of Q1. Position the cursor over the lower pin of R3 and click or press Enter to start a new wire. Move the cursor vertically until it is over the collector of Q1 then click or press Enter to place the wire segment. Again, the cursor will release from that wire and you remain in wiring mode, ready to place another wire.
  9. Wire up the rest of your circuit, as shown in the animation above.
  10. When you have finished placing all the wires, right-click or press Esc to exit placement mode. The cursor will revert to an arrow.

Wiring Tips

  • Use the Ctrl+W shortcut to launch the Place » Wire command.
  • Left-click or press Enter to anchor the wire at the cursor position.
  • Press Backspace to remove the last anchor point.
  • Press Spacebar to toggle the direction of the corner. You can observe this in the animation shown above toward the end when the connector is being wired.
  • Press Shift+Spacebar to cycle through the wiring corner modes. Available modes include: 90, 45, Any Angle, and Autowire (place orthogonal wire segments between the click points).
  • Right-click or press Esc to exit wire placement mode.
  • Click, Hold&Drag to drag the component together with any connected wires; Ctrl+Click, Hold&Drag to move a placed component.
  • Whenever a wire crosses the connection point of a component or is terminated on another wire, a junction will automatically be created.
  • A wire that crosses the end of a pin will connect to that pin even if you delete the junction. Check that your wired circuit looks like the figure shown before proceeding.
  • Wiring cross-overs can be displayed as a small arch if preferred. Enable the Display Cross-Overs option in the Schematic – General page of the Preferences dialog.

Nets and Net Labels

Each set of component pins that you have connected to each other now form what is referred to as a net. For example, one net includes the base of Q1, one pin of R1, and one pin of C1. Each net is automatically assigned a system-generated name, which is based on one of the component pins in that net.

To make it easy to identify important nets in the design, you can add Net Labels to assign names. For the multivibrator circuit, you will label the 12V and GND nets in the circuit, as shown below.

Multivibrator schematic, complete
Net Labels have been added to the 12V and GND nets, completing the schematic.

  1. Select the Net Label command (choose the Place Net Label button icon in the Active Bar, or select the Place » Net Label from the main menus). A net label will appear floating on the cursor.
  2. To edit the net label before it is placed, press Tab to open the Properties panel.
  3. Type 12V in the Net Name field, then click the Pause button (Pause button) to return to object placement.
  4. Place the net label so that its hotspot (the bottom left corner) touches the uppermost wire on the schematic, as shown in the images below. The cursor will change to a red cross when the net label is correctly positioned to connect to the wire. If the cross is light gray, it means there will not be a valid connection made.

    Placing a Net Label, not yet touching the wire   Placing a Net Label, touching the wire
    The net label in free space (the first image) and positioned over a wire (the second image), note the red cross.

  5. After placing the first net label, you will still be in net label placement mode; press the Tab key again to edit the second net label in the Properties panel before placing it.
  6. Type GND in the Net Name field and press Enter to return to object placement mode.
  7. Place the net label so that the bottom left of the net label touches the lower-most wire on the schematic (as shown in the completed schematic image above). Right-click or press Esc to exit net label placement mode.
  8. Save your circuit and the project locally – right-click each file in the Projects panel and select Save.

Net Labels, Ports, and Power Ports

  • As well as giving a net a name, Net Labels are also used to create connectivity between two separate points on the same schematic sheet.
  • Ports are used to create connectivity between two separate points on different sheets. Off Sheet Connectors can also be used to do this.
  • Power Ports are used to create connectivity between points on all sheets; for this single sheet design, Net Labels or Power Ports could have been used.
Congratulations! You have just completed your first schematic capture. Before you turn the schematic into a circuit board, you need to configure the project options and check the design for errors.

Setting Up Project Options

Project-specific settings are configured in the Project Options dialog shown below (Project » Project Options). The project options include the error checking parameters, a connectivity matrix, class generation settings, the Comparator setup, Engineering Change Order (ECO) generation, output paths and connectivity options, Multi-Channel naming formats, and project-level Parameters.

Project outputs, such as assembly outputs, fabrication outputs, and reports can be set up from the File and Reports menus. These settings are also stored in the Project file so they are always available for this project. An alternate approach is to use an OutputJob file to configure the outputs, with the advantage that an OutputJob can be copied from one project to the next. See Preparing Your Design for Manufacture to learn more about configuring the outputs.

Dynamic Compilation

The Unified Data Model (UDM) is available from the moment a project is opened and should not require additional compilation, which saves time with increased speed of compilation and persistent listings of nets and components in the Navigator panel. The design connectivity model is incrementally updated after each user operation. This means that manual project compilation is not necessary to see the contents of the Navigator panel, run the Bill of Materials (BOM), or perform an Electronic Rules Check (ERC). Manual compilation is not needed for:

  • Navigator and Projects panels
  • ActiveBOM
  • Cross-probing
  • Net color highlighting
  • Pin swapping
  • Component cross reference

Checking the Electrical Properties of Your Schematic

Schematic diagrams are more than just simple drawings – they contain electrical connectivity information about the circuit. You can use this connectivity awareness to verify your design. When you compile a project (Project » Validate PCB Project), the software checks for logical, electrical, and drafting errors between the UDM and compiler settings. Any violations that are detected will display in the Messages panel.

Setting up the Error Reporting

Dialog page: Error Reporting

The Error Reporting tab in the Project Options dialog is used to set up a large range of drafting and component configuration checks. The Report Mode settings show the level of severity of a violation. If you want to change a setting, click on a Report Mode next to the violation you want to change and choose the level of severity from the drop-down list.

Options for PCB Project dialog, Error Reporting tab
Configure the Error Reporting tab to detect for design errors when the project is compiled.

  1. Select Project » Project Options to open the Options for PCB Project dialog.
  2. Scroll through the list of error checks and note that they are clustered in groups; each group can be collapsed if required.
  3. Click on the Report Mode setting for any error check and note the options available.

Setting Up the Connection Matrix

Dialog page: Connection Matrix

As the design is coming along, a list of the pins in each net is built into memory. The type of each pin is detected (e.g., input, output, passive, etc.), then each net is checked to see if there are pin types that should not be connected to each other, for example, an output pin connected to another output pin. The Connection Matrix tab of the Project Options dialog is where you configure what pin types are allowed to connect to each other. For example, look at the entries on the right side of the matrix diagram and find Output Pin. Read across this row of the matrix until you get to the Open Collector Pin column. The square where they intersect is orange, indicating that an Output Pin connected to an Open Collector Pin on your schematic will generate an error condition when the project is compiled.

You can set each error type with a separate error level, i.e. from No Report to a Fatal Error. Click on a colored square to change the setting; continue to click to move to the next check-level. Set the matrix so that Unconnected – Passive Pin generates an Error, as shown in the image below.

Options for PCB Project dialog, Connection Matrix tab
The Connection Matrix tab defines what electrical conditions are checked for on the schematic; note that the Unconnected – Passive Pin setting is being changed.

  1. To change one of the settings, click the colored box; it will cycle through the four possible settings. Note that you can right-click on the dialog face to display a menu that lets you toggle all settings simultaneously, including an option to restore them all to their Default state (handy if you have been toggling settings and cannot remember their default state).
  2. Your circuit contains only passive pins. Let's change the default settings so that the connection matrix detects unconnected passive pins. Look down the row labels to find the Passive Pin row. Look across the column labels to find Unconnected. The square where these entries intersect indicates the error condition when a passive pin is found to be unconnected in the schematic. The default setting is green indicating that no report will be generated.
  3. Click on this intersection box until it turns orange (as shown in the image above) so that an error will be generated for unconnected passive pins when the project is compiled. You will purposely create an instance of this error later in the tutorial.

Configuring the Class Generation

Dialog page: Class Generation

The Class Generation tab in the Project Options dialog is used to configure what type of classes are generated from the design (the Comparator and ECO Generation tabs are then used to control if classes are transferred to the PCB). By default, the software will generate Component classes and Rooms for each schematic sheet, and Net Classes for each bus in the design. For a simple, single-sheet design such as this, there is no need to generate a component class or a room. Ensure that the Component Classes checkbox is cleared; doing this will also disable the creation of a room for that component class.

Note that this tab of the dialog also includes options for User-Defined Classes.

Options for PCB Project dialog, Class Generation tab
The Class Generation tab is used to configure what classes and rooms are automatically created for the design.

  1. Clear the Component Classes checkbox as shown in the image above. This will automatically disable the creation of a placement room for that schematic sheet.
  2. There are no buses in the design so there is no need to clear the Generate Net Classes for Buses checkbox located near the top of the dialog.
  3. There are no user-defined Net Classes in the design (done through the placement of Net Class directives on the wires) so there is no need to clear the Generate Net Classes checkbox in the User-Defined Classes region of the dialog.

Setting Up the Comparator

Dialog page: Comparator

The Comparator tab in the Project Options dialog sets which differences between files will be reported or ignored when a project is compiled. Generally, the only time you will need to change settings in this tab is when you add extra detail to the PCB, such as design rules, and do not want those settings removed during design synchronization. If you need more detailed control, you can selectively control the comparator using the individual comparison settings.

For this tutorial, it is sufficient to confirm that the Ignore Rules Defined in PCB Only option is enabled as shown in the image below.

Options for PCB Project dialog, Comparator tab
The Comparator tab is used to configure exactly what differences the comparison engine will check for.

For this tutorial, it is sufficient to confirm that the Ignore Rules Defined in PCB Only option is enabled as shown in the image above.

You are now ready to validate the project and check for any errors.

Verifying the Project to Check for Errors

Main page: Verifying Your Design Project

Validation of a project checks for drafting and electrical rules errors in the design documents, and details all warnings and errors in the Messages panel. You have set up the rules in the Error Checking and Connection Matrix tabs of the Project Options dialog, so you are now ready to check the design.

To verify the project and check for errors, select Project » Validate PCB Project Multivibrator.PrjPcb from the main menus.

Schematic error checking, demonstrating how to inspect the error condition
Use the Messages panel to locate and resolve design warnings and errors; double-click on a warning/error to cross probe to that object.

  1. To validate the Multivibrator project, select Project » Validate PCB Project Multivibrator.PrjPcb from the main menus.
  2. When the validation is complete, all warnings and errors are displayed in the Messages panel. The panel will only open automatically if there are errors detected (not when there are only warnings). To open it manually, click the Panels button button at the bottom right and select Messages from the menu.
  3. If your circuit is drawn correctly, the Messages panel should not contain any errors, only the message Compile successful, no errors found. If there are errors, work through each one, checking your circuit, and ensuring that all wiring and connections are correct.

You will now deliberately introduce an error into the circuit and validate the project again:

  1. Click on the Multivibrator.SchDoc tab at the top of the design space to make the schematic sheet the active document.
  2. Click in the middle of the wire that connects P1 to the emitters wire of Q1 and Q2 (the wire of the GND net). Small, square editing handles will appear at each end of the wire and the selected color will display as a dotted line along the wire to indicate that it is selected. Press the Delete key on the keyboard to delete the wire.
  3. Validate the project again (Project » Validate PCB Project Multivibrator.PrjPcb) to check for errors. The Messages panel will display error messages indicating you have unconnected pins in your circuit.
  4. The Messages panel is divided horizontally into two regions as shown in the image above. The upper region lists all messages, which can be saved, copied, cross probed to, or cleared via the right-click menu. The lower region details the warning/error currently selected in the upper region of the panel.
  5. When you double-click on an error or warning in either region of the Messages panel, the schematic view will pan and zoom to the object in error.
  6. When you hover the cursor over the object in error (not the wiggly line), a message describing the error condition will appear.

Before you finish this section of the tutorial, let's fix the error in our schematic.

  1. Make the schematic sheet the active document.
  2. Undo the delete action (Ctrl+Z) to restore the deleted wire.
  3. To check that there are no longer any errors, re-compile the project (Project » Validate PCB Project Multivibrator.PrjPcb); the Messages panel should show no errors.
  4. Save the schematic and the project file to the Workspace – click the Save to Server control next to the project name in the Projects panel, confirm that the Multivibrator.PrjPcb and Multivibrator.SchDoc files are checked in the Save to Server dialog that opens, enter a comment into the Comment field (e.g., Schematic is created and validated), then click the OK button.

When you double-click on an error in the Messages panel:

  • The schematic zooms to present the object in error. The Zoom Precision is set by the upper slider in the Highlight Methods section of the System – Navigation page of the Preferences dialog.
  • The entire schematic fades except for the object in error. The amount that the schematic fades is controlled by the Dimming level, set by the lower slider in the Highlight Methods section of the System – Navigation page of the Preferences dialog. Click anywhere on the schematic to clear the dimming.

    Preferences dialog, setting the zoom level when you double-click on an error in the Messages panel

  • To clear all messages from the Messages panel, right-click in the panel and select Clear All.
Schematic capture is now complete. It's time to create the PCB!
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: