Tutorial - Creating and Configuring the PCB Document in Altium Designer

Created: July 12, 2022 | Updated: July 12, 2022

Parent page: Tutorial - A Complete Design Walkthrough with Altium Designer

Creating a New PCB

Before you transfer the design from the schematic editor to the PCB editor, you need to create the blank PCB, then name and save it as part of the project.

Altium Designer, showing a new PCB added to the project
The blank PCB has been added to the project and saved, and the project has been saved locally.

  1. A new PCB can be added to the project via the Projects panel right-click menu. Select the Add New to Project » PCB command.

    Right-click menu commands to add a new PCB to the project in Altium Designer
    Add a new PCB to your project.

  2. The PCB will appear as a Source Document in the Projects panel as shown in the larger image above. Right-click on the PCB icon in the Projects panel to select the Save As command and name it Multivibrator. Note that you do not need to enter the file extension in the Save As dialog; this is automatically appended.
  3. Adding the PCB has changed the project, so also save the project locally (right-click on the project filename in the Projects panel and select Save).

Configuring the Board Shape and Location

There are a number of attributes of this blank board that need to be changed before transferring the design from the schematic editor, including:

Task Process
Set the origin The PCB editor has two origins: the Absolute Origin, which is the lower left of the design space, and the user-definable Relative Origin, which is used to determine the current design space location – the coordinates shown on the Status Bar are relative to this origin. A common approach is to set the Relative Origin to the lower-left corner of the board shape. Select the Edit » Origin » Set command to set the Relative Origin; use the Edit » Origin » Reset command to reset it back to the Absolute Origin.
Set the units to Imperial or Metric The current design space X / Y location and Grid are displayed on the Status Bar, which is displayed along the bottom of the editor. For this tutorial, metric units will be used. To change the units, either press Q on the keyboard to toggle back and forth between Imperial and Metric units, or select the View » Toggle Units command from the menus.
Select a suitable snap grid You may have noticed that the current snap grid is 5mil (or 0.127mm, which is the default imperial snap grid converted to metric). To change the snap grid at any time, press G to display the Snap Grid menu, from where you can select an imperial or metric value. Note the shortcuts shown in the menu; use Ctrl+Shift+G to open the Snap Grid dialog, which is handy when you want to type in a specific value. The other useful shortcut is Ctrl+G, which opens the Cartesian Grid Editor dialog, in which you can change the grid from dots to lines, and change the grid color. Grids are discussed in more detail later in the tutorial.
Re-define the board shape The board shape is shown by the black region with a grid in it. The default size for a new board is 6x4 inches; the tutorial board is 30mm x 30mm. Details for the process of defining a new shape for the board are available below.
Configure the layers As well as the copper, or electrical layers on which you route, there are also general-purpose mechanical layers and special-purpose layers, such as the component overlays (silkscreens), solder mask, paste mask, and so on. The electrical and other layers will be configured shortly.
  • Press Ctrl+PgDn at any time to zoom to show the entire board.
  • Zoom in/out using:
    • PgUp / PgDn
    • Ctrl+Mouse Wheel
    • Ctrl+Right-click, Hold&Drag
  1. There are two origins used in the software, the Absolute Origin, which is the lower left of the design space, and the user-definable Relative Origin, which is used to determine the current design space location. Before setting the origin, keep zooming in to the lower left of the current board shape until you can easily see the grid. To do this, position the cursor over the lower-left corner of the board shape and press PgUp until both the Coarse and Fine grids are visible as shown in the images below.
  2. To set the Relative Origin, select Edit » Origin » Set then position the cursor over the bottom left corner of the board shape, then left-click to locate it.

    PCB editor, showing the board and cursor before the origin is set PCB editor, showing the board and cursor after the origin is set
    Select the command, position the cursor over the lower-left corner of the board shape (the first image), then click to define the origin (the second image).

  3. The next step is to select a suitable snap grid, as discussed in the table above. During the course of design, it is quite common to change grids, for example, you might use a coarse grid during component placement, and a finer grid for routing. For this tutorial, you will be using a Metric grid. Press Ctrl+Shift+G to open the Snap Grid dialog and enter 5mm, then click OK to close the dialog.
  4. By entering the units as you entered a value you have also instructed the software to switch to a Metric grid, you can check this on the Status Bar.
  1. The default board shape is 6x4 inches; for this tutorial, you will change the board size to 30mm x 30mm.
  2. To zoom back out and show all of the board, select View » Fit Board from the main menus (Ctrl+PgDn).
  3. The board will exactly fill the PCB editor. To manipulate the size you need to be able to see the edges of the board, use Ctrl+Mouse Wheel to zoom out a bit more or press PgDn.
  4. The next step is to change the board shape. This is done in Board Planning Mode. Select View » Board Planning Mode from the main menus to change it (shortcut: 1). The display will change; the board area will now be shown in green.
  5. Your choice now is to either redefine the board shape (draw it again), or edit the existing board shape. For a simple square or rectangle, it is more efficient to edit the existing board shape. To do this, select Design » Edit Board Shape from the menus. Note that you must be in Board Planning Mode for this command to be available.

    Menu command to edit the board shape
    For this design, it is more efficient to edit the existing board shape. These commands are only available in Board Planning Mode.

  6. Editing handles will appear at each corner and the center of each edge as shown on the animation below.

    Note that clicking anywhere other than on an editing handle or an edge of the shape will drop you out of board shape editing mode.
  7. The objective is to resize the shape to create a 30mm by 30mm board. The Coarse visible grid is 25mm (5x the snap grid), and the Fine visible grid is 5mm; these can be used as a guide. You can now either: slide the upper edge down and slide the right edge to the left to create the correct size; or move three of the corners in, leaving the one that is at the origin in its current location.
  8. To slide the upper edge down, position the cursor over the edge (but not over a handle). When the cursor changes to a double-headed arrow, click and hold, then drag the edge to the new location so that the Y cursor location is 30mm on the Status Bar, as shown in the animation below.
  9. Repeat the process to move the right-hand edge in, positioning it when the X cursor location is 30mm on the Status Bar.

    Use the current location information at the bottom left of the Status Bar to guide you as you reshape the board.

    Demonstration video, editing the board shape
    The resize cursor is shown, use the location information on the Status Bar to help you as you drag the upper and right edges to resize the board to 30mm x 30mm.

  10. Click anywhere in the design space to drop out of board shape editing mode.
  11. Press the 2 shortcut to switch back to 2D Layout Mode.
  12. Now that the shape has been defined, you can set the grid to a value suitable for component placement, for example, 1mm. Grids are discussed in detail shortly.
  13. Save the board locally.

Learn more about Defining the Board Shape

PCB editor, the board size has been defined, and the units, origin and grid have been set
The board size has been defined, and the units, origin and grid have been set. The required layers will be configured shortly.

A good approach to defining the shape of a non-rectangular board is to place a series of tracks (and arcs for curved boards) on the keepout layer. As well as being useful as placement and routing keep-away barrier, these tracks and arcs can be selected (Edit » Select » All on Layer) and used to create the board shape using the Design » Board Shape » Define Board Shape from Selected Objects command.

Learn more about Defining the Board Shape

Configuring the Defaults

When you place an object in the PCB editor design space, the software will define the shape and properties of the object based on:

  1. An applicable design rule – if there is a rule defined that applies to that object, the properties object are defined from the rule. For example, during a layer change when you are interactively routing, a via is automatically added with its size and hole size properties taken from the applicable Routing Via Style design rule.
  2. Default settings – if an applicable design rule does not exist or does not apply, the properties of the object are defined from the default settings configured in the PCB Editor – Defaults page of the Preferences dialog. For example, if you run the Place » Via command, the software does not know if that via will be part of a net, so it will present a via at the size defined in the defaults.

Preferences dialog, configuring the default settings for Designator and Comment

  1. To configure the default settings for the designator and comment strings, select Tools » Preferences to open the Preferences dialog, then open the PCB Editor – Defaults page.
  2. Select Designator in the Primitive List; the default Properties will be displayed. Confirm that the:
    • Autoposition option is set to Left-Above for the Designator. This is the default location in which this string is held when the component is rotated. The string can be interactively relocated at any time during the design process.
    • Font Type is set to TrueType, and the Font is set to Arial. Stroke fonts are Gerber-friendly shapes that the software can generate. TrueType gives access to all fonts available on the PC, but the font must be embedded in the PCB file if the board is to be opened on a PC that does not have that font installed (that can be configured on the PCB Editor – True Type Fonts page of the Preferences dialog).
    • Text Height is set to 1.5mm for this tutorial.
  3. Select Comment in the Primitive List and confirm that the:
    • Autoposition option is set to Left-Below.
    • Font Type is set to TrueType and the Font is set to Arial.
    • Text Height is set to 1.5mm for this tutorial.
    • Comment visibility is set to hidden (Visibility button). This is a common default; component Comment strings can be selectively displayed during the design process if required.
  4. Click OK to save the changes and close the dialog.

Transferring the Design

Main page: Managing Design Changes between the Schematic & the PCB

The design is transferred directly between the schematic editor and the PCB editor; there is no intermediate netlist file created. From the schematic editor, select Design » Update PCB Document Multivibrator.PcbDoc, or from the PCB editor, select Design » Import Changes from Multivibrator.PrjPcb.

When you run either of these commands, a set of Engineering Change Orders is created, which:

  • List all components used in the design and the footprint required for each. When the ECOs are executed, the software will attempt to locate each footprint and place each into the PCB design space. If the footprint is not available, an error will occur. For this tutorial, all of the components have been acquired to the connected Workspace from the Manufacturer Part Search panel, so the software can reference back to the Workspace and retrieve each footprint.
  • A list of all nets (connected component pins) is created. When the ECOs are executed, the software will add each net to the PCB then attempt to add the pins that belong to each net. If a pin cannot be added, an error will occur; this most often happens when the footprint was not found or the pads on the footprint do not map to the pins on the symbol.
  • Additional design data is then transferred, such as net and component classes.

    PCB editor, the components have been placed outside the board shape and the nets created
    Once the ECOs have been executed, the components are placed outside the board shape and the nets are created. Note that the default Designator (and Comment) fonts have been changed.

Before transferring the schematic information to the new blank PCB, it is essential that all the related libraries for both schematic symbols and PCB footprints are available. Since all components have been acquired from the Manufacturer Part Search panel with their footprints and placed from the connected Workspace, the footprints required for the tutorial are already available.
  1. Make the schematic document, Multivibrator.SchDoc, the active document.
  2. Select Design » Update PCB Document Multivibrator.PcbDoc from the Schematic editor menus to open the Engineering Change Order dialog.

    Engineering Change Order dialog
    An ECO is created for each change that needs to be made to the PCB so that it matches the schematic.

  3. Click on Validate Changes. If all changes are validated, a green check will appear next to each change in the Status – Check column of the dialog. If the changes are not validated, close the dialog, check the Messages panel and resolve any errors.
  4. If all changes are validated, click on Execute Changes to send the changes to the PCB editor. As each change is performed, a check will appear in the Status – Done column of the dialog.
  5. When all changes have been completed, the PCB will open behind the Engineering Change Order dialog; click to Close the dialog.
  6. The components will have been positioned outside of the board, ready for placing on the board. There are a few steps to complete before starting the component placement process, such as configuring the placement grid, the layers, and the design rules.

    You can create a report of the ECOs by clicking the Report Changes button.

Configuring the Display of Layers

Once all of the ECOs have been executed, the components and nets will appear in the PCB design space to the right of the board outline, as shown in the image above. Before you start positioning the components on the board, you need to configure certain PCB design space and board settings, such as the layers, the grid, and the design rules.

Your view of your board is a bird's-eye view – looking down the Z-axis into the board from above. The PCB editor is a layered design environment; the objects you place on signal layers become copper when the board is fabricated, the strings you place on the Overlay layers are silkscreened onto the board surface, and the notes you place onto mechanical layers become instructions on the assembly drawing that you print.

You design the board looking down into this stack of layers, placing components on the top and bottom sides of the board (Top Layer / Bottom Layer), and other design objects on the copper, overlay, mask, and mechanical layers as you build up the design.

Finished PCB, showing layers used
You design the board looking down into a stack of layers; hover the cursor over the image to show the same board in 3D, stretched in the Z-axis.

As well as the layers used to fabricate the board, which include: signal, power plane, mask, and silkscreen layers, the PCB Editor also supports numerous other non-electrical layers. The layers are often grouped in the following way:

  • Electrical Layers – includes the 32 signal layers and 16 internal power plane layers.
  • Component Layers – layers used in the design of the components including Overlay (silkscreen), Solder, and Paste layers. If an object is placed in a component footprint on one of these layers in the library editor, when the component is flipped from the top side to the bottom side of the board, all objects detected on a Component layer are flipped to their partner Component layer. This includes objects on user-defined Component Layer Pairs (paired mechanical layers).
  • Mechanical Layers – the software supports unlimited general-purpose mechanical layers, which are used for design tasks such as dimensions, fabrication details, assembly instructions, and so on. These layers can be selectively included in print and Gerber output generation if required. Mechanical layers can also be paired; when they are paired, they behave as Component Layers. Paired Component Layers are used for tasks such as 3D body placement, glue dots, and selective gold plating on edge connectors.
  • Other Layers – these include the Keep-Out layer (used to define keepouts that apply on all copper layers), the multi-layer (used for objects present on all signal layers, such as pads and vias), the Drill Drawing layer (used to place drilling information, such as a drill table), and the Drill Guide layer (used to display markers that indicate drill locations and sizes).

The copper layers are added and removed from the design in the Layer Stack, which is discussed shortly. All other layers are enabled and configured in the View Configuration panel.

Displaying Layers – View Configuration

Panel page: View Configuration

The display attributes of all layers are configured in the View Configuration panel. To open the panel:

  • Click the Panels button button at the bottom right of the application window then select View Configuration from the menu, or
  • Select the View » Panels » View Configuration menu entry, or
  • Press the L shortcut, or
  • Click the current layer color PCB editor design space, Layer Set control icon at the bottom-left of the design space.

View Configuration panel, Layers & Colors tab   View Configuration panel, View Options tab
The two tabs of the View Configuration panel

As well as the layer display state and color settings, the View Configuration panel also gives access to other display settings including:

  • Color and visibility of System Colors, such as the Selection color, or if Connection Lines are visible.
  • How each type of object is displayed (solid or draft), and its transparency (Object Visibility section).
  • Various view options, such as if the Origin Marker, Pad Net names, and Pad Numbers are to be displayed (Additional Options section).
  • The amount the display is faded when objects are dimmed or masked (Mask and Dim Settings section).
  • The creation of Layer Sets, which provide a quick way of switching which layers are currently visible, using the PCB editor design space, Layer Set control control (Layers section).
  • The creation and selection of View Configurations, which are used to pre-configure all of the layer properties, such as color, visibility, object transparency, and so on (General Settings section).

Layer Tips

  • The currently enabled layers are shown as a series of tabs across the bottom of the PCB design space. Right-click on a tab to access frequently-used layer display commands.
  • In a busy design, it can help to only display the layer currently being worked on; this is referred to as Single Layer Mode. To toggle the display in/out of single layer mode, press the Shift+S shortcut. The Available Single Layer Modes are configured in the PCB Editor – Board Insight Display page of the Preferences dialog. Each press of Shift+S will cycle to the next enabled single layer mode.
  • To switch the active layer:
    • Click the layer tab at the bottom of the design space, or
    • Press the + or - numeric keys to cycle through all layers, or
    • Press the * numeric key to cycle through signal layers, or
    • Use the Ctrl+Shift+Mouse Wheel shortcuts.
  1. Open the View Configuration panel.
  2. In the Layers and Colors tab, confirm that the Top Layer and Bottom Layer signal layers are visible.
  3. Note that this panel is where you control the display of the mask and silkscreen layers, as well as the system layers, such as DRC and grids.
  4. To have less visual "clutter" during placement and routing, disable the display of the Component Layer Pairs (except for Overlay layers), Mechanical Layers, and the Drill Guide and Drill Drawing layers.
  5. Switch to the View Options tab.
  6. Confirm that the Pad Nets and Pad Numbers options are enabled.

Physical Layers and the Layer Stack Manager

Main page: Defining the Layer Stack

The definition of the PCB layer stack is a critical element of successful printed circuit board design. No longer just a series of simple copper connections that transfer electrical energy, the routing of many modern PCBs is designed as a series of circuit elements, or transmission lines.

There are also numerous other design considerations that come into play when designing a modern, high-speed PCB, including: layer-pairing, careful via design, possible back drilling requirements, rigid/flex requirements, copper balancing, layer stack symmetry, and material compliance.

These layer stack requirements are configured in the Layer Stack Manager, select Design » Layer Stack Manager to open it.

  • The Layer Stack Manager opens in a document view, in the same way as a schematic sheet, the PCB, and other document types.
  • The Layer Stack Manager (LSM) can be left open while the board is being worked on, allowing you to switch back and forth between the board and the LSM. All of the standard View behaviors, such as splitting the screen or opening on a separate monitor, are supported.
  • A Save must be performed in the Layer Stack Manager before changes are reflected in the PCB.

The Layer Stack Manager is used to:

  • Add, remove and order the signal, plane, and dielectric layers.
  • Select the Material properties from the Materials Library, or configure them manually.
  • Add additional user-defined fields to the Layer Stack.
  • Configure the allowed Via Types, defining which layers each Via Type spans.
  • Configure the Impedance profiles, when controlled impedance routing is being used.
  • Configure advanced features, including rigid-flex design, printed electronics, and back drilling.

This tutorial PCB is a simple design and can be routed as a single-sided board, or a double-sided board with thru-hole vias. In the image below, the Material for each layer has been selected.

PCB editor Layer Stack Manager, selecting a material
The properties of the physical layers are defined in the Layer Stack Manager. To configure the allowed via types, click the Via Types tab at the bottom of the Layer Stack Manager.

  1. Open the Layer Stack Manager – select the Design » Layer Stack Manager command from the main menus. For a new board, the default stack comprises: a dielectric core, two copper layers, and the top and bottom soldermask (coverlay) and overlay (silkscreen) layers, as shown in the image above.
  2. To simplify the management of layers, make sure that the Stack Symmetry option is enabled in the Properties panel (as shown in the image above). With this option enabled, layers are added in matching pairs, centered around the mid-dielectric layer.
  3. To use a material for a specific layer (or pair of layers if symmetry is enabled), click the PCB editor Layer Stack Manager, ellipsis control used to select the layer material in the Material cell for the required layer to open the Select Material dialog (shown in the image above).
  4. Using the image above as a guide, select suitable material for the: Solder Mask, Signal, and Core layers. Note that the Core layer has been chosen to define a suitable thickness for the finished board. Values can also be typed directly into the Layer Stack Manager.
  5. Click on the Via Types tab at the bottom of the Layer Stack Manager and confirm that there is a Thru type via defined.
  6. When you have finished exploring the layer stack options, save the stackup (File » Save to PCB), then right-click on the Layer Stack Manager tab and close the Stackup.
The Layer Stack Manager supports Undo / Redo; use Ctrl+Z to undo the previous changes and Ctrl+Y to redo.

Configuring the Grid

The next step is to select a grid that is suitable for placing and routing the components. All the objects placed in the PCB design space are placed on the current snap grid.

Imperial or Metric Grid?

Traditionally, the grid was selected to suit the component pin pitch and the routing technology that you planned to use for the board, i.e. how wide do the tracks need to be, and what clearance is needed between tracks. The basic idea is to have both the tracks and clearances as wide as possible to lower the fabrication costs and improve reliability. Of course, the selection of track/clearance is ultimately driven by what can be achieved on each design, which comes down to how tightly the components and routing must be packed to get the board placed and routed.

Over time, components and their pins have dramatically shrunk in size, as has the spacing of their pins. The component dimensions and the spacing of their pins have moved from being predominantly imperial with thru-hole pins to more-often being metric dimensions with surface mount pins. If you are starting a new board design, unless there is a strong reason, such as designing a replacement board to fit into an existing (imperial) product, you are better off working in metric. Why? Because the older, imperial components have big pins with lots of room between them. On the other hand, the small, surface mount devices are built using metric measurements – they are the ones that need a high level of accuracy to ensure that the fabricated/assembled/functional product works and is reliable. Also, the PCB editor can easily handle routing to off-grid pins, so working with imperial components on a metric board is not onerous.

Suitable Grid Settings

For a design such as this simple tutorial circuit, practical grid and design rule settings should be:

Setting Value Where
Routing width 0.25 mm Routing Width design rule
Clearance 0.25 mm Electrical Clearance design rule
Board definition grid 5 mm Cartesian Grid Editor
Component placement grid 1 mm Cartesian Grid Editor
Routing grid 0.25 mm Cartesian Grid Editor
Via size 1 mm Routing Via Style design rule
Via hole 0.6 mm Routing Via Style design rule

While it might be tempting to select a very fine routing grid so that routing can effectively be placed anywhere, this is not a good approach. Why? Because the point of setting the grid to be equal to or a fraction of the track+clearance is to ensure that the tracks are placed so that they do not waste potential routing space, which can happen if a very fine grid is used.

  • Select View » Toggle Units (or press the Q shortcut key) to toggle the design space units between metric and imperial.
  • When a dialog or panel is active, press Ctrl+Q to toggle the units of all measurements in that dialog or panel.
  • Regardless of the current setting for the units, you can include the units when entering a value in a dialog or panel to force that value to be used.

Support for Multiple Grids

  • Altium Designer allows multiple snap grids to be defined. There are two types of grids supported: Cartesian (traditional vertical/horizontal grid) and Polar (circular grid).
  • As well as defining the type of grid, you also define the area where that grid applies. Note that the Default grid always applies to the entire design space even though it is only displayed over the board shape.
  • Since only one grid can be used at a time, grids also have a priority that is used to determine which grid should be applied when they overlap. There are also controls for defining if a grid is for all objects, components only, or non-components only.
  • Grids are created and managed in the Grid Manager section of the Properties panel. Use the buttons in the panel to add, edit or delete a grid.

Only the default grid is used in this tutorial.

Properties panel, PCB editor Grid Manager section PCB editor, example of different grids
Multiple grids can be configured in the Grid Manager; the second image shows these three grids (click to enlarge).

Setting the Snap Grid

Related pages: Grid Manager, Cartesian Grid Editor, Polar Grid Editor

The value of the snap grid you need for this tutorial can be configured by pressing:

  • G to display the Snap Grid menu, where you can select an imperial or metric value (note the shortcuts shown in the menu).
  • Ctrl+Shift+G to open the Snap Grid dialog, where you can type in a new grid value.
  • Ctrl+G to open the Cartesian Grid Editor dialog, where you can enter the grid value, as well as configure how the grid is displayed (shown below).
  • Editing the grid in the Grid Manager section of the Properties panel.

Cartesian Grid Editor dialog
Set the Snap Grid to 1 mm, ready to position the components.

  1. Press the Ctrl+G shortcut keys to open the Cartesian Grid Editor dialog.
  2. Make sure that the Step X field has the value 1mm. Because the X and Y fields are linked, there is no need to define the Step Y value.
  3. To make the grid visible at lower zoom levels, set the Multiplier to 5x Grid Step; to make it easier to distinguish between the two grids, set the Fine grid to display as lighter-colored Dots and the Coarse grid to display as darker colored Lines.
  4. Click OK to close the dialog.

Learn more about Working with the PCB Grids System

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: