Draftsman Placement & Editing Techniques

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

 

Parent page: Streamlining Board Design Documentation with Draftsman

A variety of objects are available for use in creating a PCB drawing. The Draftsman editor's design space can contain a large number of design objects that make up the drawing. During the course of the drawing creation process, the placement and properties of these objects need to change as you work to achieve the required look of your drawing.

Object Placement and Editing Commonality

In Altium NEXUS's Draftsman, the process of placing an object is roughly the same regardless of the object being placed. At its simplest level, the process is as follows:

  1. Select the object to be placed from one of the following locations:
    • the main Place menu;
    • the Active Bar located at the top of the design space;
    • the Place submenu of the design space right-click menu;
    • the Drawing Views or the Drawing Annotations toolbar.
  2. When an object is selected for placement, drawing data is retrieved from the source PCB file (where applicable), and the cursor will change to a crosshair, indicating that you are in editing mode, and if relevant, the object will appear "floating" under the cursor. Position the cursor then left-click or press Enter to place the object. For some objects, such as dimensions, you must continue the position-and-click procedure to define all relevant locations of the object.
  3. After placing a non-view type object, you will remain in placement mode (indicated by the crosshair cursor), allowing you to immediately place another object of the same type. To end placement mode, right-click or press the Esc key. In some cases such as placing a Region object, you may need to do this twice; once to finish placing the object and once to exit placement mode. When you exit placement mode, the cursor will return to its default shape.

Editing Prior to Placement

The default properties for an object can be changed at any time on the PCB Editor – Defaults page of the Preferences dialog. Most properties of an object, or those that can logically be pre-defined, are available as editable default settings. These properties will be applied when placing subsequent objects. Select an object in the Primitive List to reveal its options on the right.

Use the Primitive List column to access properties for objects and edit default values as required.
Use the Primitive List column to access properties for objects and edit default values as required.

Editing After Placement

Once an object has been placed, there are a number of ways in which it can be edited. These are described below.

The Associated Properties Panel

This method of editing uses the associated Properties panel mode and dialog to modify the properties of a placed object.

The panel automatically changes its mode and content to match the selected drawing view or object.
The panel automatically changes its mode and content to match the selected drawing view or object.

To open the Properties panel and access the properties of a placed object:

  • After selecting the object, select the Properties panel from the button at the bottom right of the design space or select View » Panels » Properties from the main menus.
  • Double-click on the object in the design space.
  • Right-click on the object then select Item Properties from the context menu.

If the Properties panel is already active, click on the object to access its properties in the panel. The panel will automatically populate its content to match the property settings for the currently selected object in the design space.

In practice, the Properties panel changes to that object 'mode', which, along with the changed property options, is indicated by the panel's heading text. For example, selecting a placed Assembly View object will change the panel to its Assembly View mode, or selecting a drawing object such as a Linear Dimension will change the panel to its Linear Dimension mode.

When a drawing view is selected, press F1 to access documentation for that object. For a selected Board Assembly View, for example, this will open the Board Assembly View object documentation, which also includes a section describing Board Assembly View Properties in details.

Each entry in the following list of Draftsman objects links to its associated properties information (Properties panel mode) section.

Graphical Editing

This method of editing allows you to select a placed object directly in the design space and change its size, shape, or location graphically. Modification of shape and/or size (where applicable) is performed through the use of editing 'handles' that appear once the object is selected.

An example editing handle for a selected Board Assembly View object. Drag the handle to change the view's scale.
An example editing handle for a selected Board Assembly View object. Drag the handle to change the view's scale.

Click anywhere on an object away from editing handles (where they exist) to drag the object to reposition it. Press Spacebar to rotate the object counterclockwise or Shift+Spacebar for clockwise rotation with 90-degree increments.

Using Copy and Paste

In Draftsman, you can cut, copy and paste objects within or between Draftsman documents using the commands of the Edit main menu or standard shortcuts.

Note that the software does not use the Windows clipboard for normal copy operations in Draftsman documents. Instead, a separate internal clipboard is maintained for this document type. Also, the internal Draftsman clipboard is entirely independent of the internal clipboards used by any other editors in the software. You can only copy and paste between, or within, Draftsman documents.

Editing Multiple Objects

The Properties panel supports multiple object editing, where the property settings that are identical in all currently selected objects can be modified.

Format Painter

The Format Painter feature offers a simple and fast way to transfer an existing text style to other Draftsman text elements.

As demonstrated in the animation below, select an existing text element that has the style properties (as defined in the Properties panel) that you would like to propagate, and then choose the Format Painter tool from the Drawing Document Standard toolbar – or Edit » Format Painter from the main menu. This action effectively captures the style properties of the currently selected text.

Use the cursor, which changes to the Format Painter tool icon (), to locate and select other text elements that will adopt the style properties. Compatible text objects include editable text elements such as object Titles, Text items and Note items.

DXF Import

Draftsman provides further graphical options through the import of standard DXF files, which are loaded into the drawing space from the File » Import from DXF menu command. Use the Windows file browser to select a *.DXF or *.DWG file then configure the import options from the DXF Import Settings dialog that opens.

Note that the DXF source graphic is interpreted using Draftsman’s standard graphical shape objects – lines, circles, rectangles, text – and each primitive object is therefore editable.

DXF Export

Draftsman documents can be exported in .dxf format. This allows exporting Draftsman documents in a vectorial format.

Select the File » Export to Dxf command from the main menus and use the Save As dialog that opens to define the file name and location.

Content