Trabajar con tablas

De un vistazo

Este artículo explica cómo colocar y configurar tablas de Draftsman en Altium Designer, con especial atención a las tablas de listas de materiales (BOM) y a cómo sus datos proceden directamente del proyecto de PCB, ActiveBOM, las variantes y las vistas de ensamblaje. Repasa los ajustes principales disponibles en el panel Propiedades, como el formato, la selección de la fuente de datos, los modos de visualización, el filtrado por variantes, la gestión de columnas y la distribución de la BOM en varias páginas para diseños de mayor tamaño. Si quieres entender mejor cómo presentar los datos de fabricación y ensamblaje de forma precisa y ordenada en tus documentos de Draftsman, este artículo te mostrará las opciones disponibles y cómo utilizarlas eficazmente. Sigue leyendo para tener un mayor control sobre la documentación de tus PCB.

- Aprenderás de dónde proceden los datos de las tablas BOM y cómo las opciones Proyecto, Placa, variantes y vistas de ensamblaje afectan a lo que se muestra.
- Verás cómo personalizar el aspecto y la estructura de una tabla BOM, incluidos los títulos, las fuentes, los colores de las filas, las columnas, la ordenación y los alias.
- Comprenderás cómo funcionan las tablas BOM divididas para poder presentar listas de materiales extensas en varios objetos de tabla y páginas.
Profundiza con IA:

Un documento de Draftsman permite colocar diversas tablas de datos en el plano y configurarlas según sea necesario. Los datos de las tablas se obtienen directamente del documento de PCB del proyecto y proporcionan una forma sencilla y visual de transmitir información crucial para los procesos de fabricación y ensamblaje de la PCB.

El tipo de tabla que se va a colocar se puede seleccionar en el menú principal Place.

Lista de materiales

Una lista de materiales de Draftsman (Place » Bill Of Materials) es un objeto de tabla generado automáticamente que enumera los elementos físicos de ensamblaje de un diseño de PCB. Los datos de la tabla BOM se obtienen directamente del documento ActiveBOM del proyecto o, si el documento ActiveBOM no está presente en el proyecto actual, directamente de los documentos fuente del proyecto. Una tabla BOM también puede representar los elementos que componen una variante de diseño específica o una vista de ensamblaje de la placa colocada.

Una tabla de lista de materiales dividida en dos objetos BOM. En el ejemplo anterior, el contenido de la BOM se filtra para incluir los elementos de la vista de ensamblaje de la cara superior de la placa.
Una tabla de lista de materiales dividida en dos objetos BOM. En el ejemplo anterior, el contenido de la BOM se filtra para incluir los elementos de la vista de ensamblaje de la cara superior de la placa.

El estilo visual y los datos incluidos en una tabla de lista de materiales colocada se pueden configurar en el panel Properties cuando la tabla está seleccionada en el espacio de diseño. Las propiedades generales de la tabla se configuran en la pestaña General del panel ().

Título

Título

La cadena de texto del título que se mostrará (si está habilitada) con la tabla. Utilice el botón asociado para alternar la visibilidad del título en el plano.

El campo puede incluir texto estático y los parámetros deseados en forma de cadenas especiales. Utilice la sintaxis =<ParameterName> para incluir un parámetro en el título. Los valores de los parámetros incluidos se mostrarán en el título de la hoja de dibujo. Para consultar una lista de los parámetros del sistema y de la PCB disponibles, consulte la página Configuración de un documento de Draftsman.

Location Abra la lista desplegable para elegir entre diversas ubicaciones relativas para el título. La opción Manual se selecciona automáticamente si el título se mueve manualmente (arrastrándolo y soltándolo en una nueva ubicación).
Font

Establece la fuente utilizada para el título.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada para el título es la definida en las opciones del documento (la entrada Document Font de la sección General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está deshabilitada, utilice las opciones disponibles para elegir el tipo de fuente, el tamaño, el color y los atributos de texto deseados.

Propiedades

Table Line Style

Utilice las listas desplegables para seleccionar la línea utilizada para dibujar la tabla. Las opciones disponibles se definen en la sección Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman. Utilice el botón de color asociado para especificar el color de la línea.

Justification Seleccione el punto respecto al cual cambia la posición de la tabla si se actualiza su tamaño.
Even Row Color Seleccione el color de contraste para las filas pares de la tabla.
Non-Even Row Color Seleccione el color de contraste para las filas impares de la tabla.
Font

Establece la fuente utilizada para los datos de la tabla.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada es la definida en las opciones del documento (la entrada Document Font de la sección General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está deshabilitada, utilice las opciones disponibles para elegir el tipo de fuente, el tamaño, el color y los atributos de texto deseados.

La tabla ajustará automáticamente su tamaño para adaptarse al tamaño de fuente seleccionado.

Data Source Esta opción y la posible presencia de un documento ActiveBOM en el proyecto determinan los datos incluidos en la tabla:

 

  • Project – cuando esta opción está seleccionada y el documento ActiveBOM está incluido en el proyecto actual, su configuración y contenido se convierten en la fuente de datos de una tabla BOM de Draftsman. Utilice el comando Tools » Import Changes From <PCBDocumentName>.PcbDoc de Draftsman para incorporar los cambios en tiempo real de un documento ActiveBOM.
    Si el documento ActiveBOM no está incluido en el proyecto actual, los datos de una tabla BOM de Draftsman se obtienen directamente de los documentos fuente del proyecto.

  • Board – cuando esta opción está seleccionada, las entradas de la tabla BOM de Draftsman se limitan a los componentes presentes en la PCB física del proyecto.

Assembly View Utilice las opciones del menú desplegable para filtrar las entradas de la BOM y mostrar únicamente los elementos que aparecen en una vista de ensamblaje de la placa específica.
View Mode
  • Base – se asigna una fila de la tabla a cada tipo de componente único y se enumeran todos los elementos incluidos en la columna Designator.

  • Flat – se asigna una fila de la tabla a cada componente individual.

  • Consolidated – si el proyecto fuente incluye variantes, la tabla incluirá las entradas de componentes de todas las variantes de diseño. Al seleccionar esta opción, la opción Variant se establecerá automáticamente en [No Variations].

Variant

Utilice el menú desplegable para seleccionar una variante de diseño, si está disponible, como fuente de datos para la tabla BOM. La tabla reflejará las entradas que no estén incluidas o que tengan parámetros modificados, según la opción Show Components.

Cuando se selecciona la opción Document : <VariantName> como Variation, se aplica a la tabla una variante especificada para el documento. La variante a nivel de documento se selecciona mediante la lista desplegable Variants de la sección Source de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Show Components

Cuando haya una variante seleccionada, utilice la lista desplegable para seleccionar qué entradas de componentes se incluirán en la lista:

  • Fitted – mostrar solo los componentes que se montan en la variante de diseño seleccionada actualmente.

  • All – mostrar todos los componentes.

  • Not Fitted – mostrar solo los componentes que no se montan en la variante de diseño seleccionada actualmente.

  • Replaced – mostrar solo los componentes para los que se hayan seleccionado piezas alternativas o los componentes montados cuyos valores de parámetros se hayan modificado en la variante de diseño seleccionada actualmente.

Una tabla BOM con las opciones Fitted, Not Fitted o Replaced seleccionadas para Show Components funciona con las opciones Base y Flat seleccionadas para View Mode (no con Consolidated).

Páginasi

BOM Table ID Un identificador numérico para una instancia de tabla BOM. La tabla completa puede dividirse en varios objetos de tabla BOM (páginas), que comparten el mismo identificador.
Limit Page Height Cuando esta opción está marcada, la tabla de BOM se divide en una secuencia de páginas virtuales, cada una con la altura especificada en la propiedad Max Page Height.
Max Page Height Establece la altura y, por tanto, el número de filas incluidas en cada página de la tabla. Un objeto de tabla de BOM colocado solo incluye una página (consulte Page más abajo), y se colocan objetos de tabla de BOM adicionales para abarcar todas las páginas.
Page Indica el número de página de la tabla (1 from 2, 3 from 5, etc.) que se muestra en el objeto de tabla de BOM seleccionado. Utilice el menú desplegable asociado para especificar la página deseada para el objeto de tabla de BOM seleccionado actualmente.
Show Empty Lines Cuando esta opción está marcada, se muestran las filas vacías de la tabla de BOM. Estas suelen aparecer en la última página de una tabla de BOM, cuando la altura de página especificada supera el número de filas de datos de BOM disponibles.

Utilice la pestaña Columns del panel Properties para gestionar las columnas de datos de la tabla de BOM.

Manipule las columnas de una tabla de BOM colocada en la pestaña Columns del panel Properties.
Manipule las columnas de una tabla de BOM colocada en la pestaña Columns del panel Properties.

  • Las entradas se pueden editar para especificar las columnas incluidas (visibles) en la tabla de BOM y la alineación de su texto (Align).

  • Utilice la entrada Width para definir el ancho de la columna en relación con el texto que contiene. Introduzca Auto para que el ancho varíe dinámicamente y se adapte al texto más ancho de las celdas de la columna.

  • Haga clic en la columna Order para alternar entre las opciones de ordenación de los datos de la columna de la tabla (desactivada, ascendente y descendente). La ordenación se puede aplicar a varias columnas por orden de prioridad; las columnas ordenadas situadas a la izquierda de la tabla tienen mayor prioridad.

  • Los encabezados de la tabla de BOM se pueden cambiar introduciendo un Alias para el nombre de parámetro de una columna de la tabla. Esto se aplica si un documento ActiveBOM no determina el contenido de la tabla (consulte Data Source más arriba).

  • Utilice las casillas de filtro por tipo de columna para rellenar la lista de columnas disponibles con los tipos de datos de parámetros correspondientes: BOM (), esquema (), servidor (), PCB (). Desmarque todos los tipos para mostrar únicamente las columnas visibles en la tabla de BOM.

  • Utilice los botones  y  para desplazar la entrada seleccionada una posición hacia arriba o hacia abajo y, por tanto, hacia la izquierda o hacia la derecha en el orden de las columnas de la tabla de BOM. Disponible para las columnas configuradas como visibles.

  • Haga clic en el botón  para restablecer las columnas de la tabla a las entradas predeterminadas (según lo definido por los valores predeterminados del objeto de tabla de BOM en la página Draftsman – Valores predeterminados del cuadro de diálogo Preferences).

Tablas de BOM divididas

La lista de materiales de la mayoría de los proyectos de PCB avanzados suele tener un gran número de entradas, lo que puede dificultar su representación en una tabla que quepa en un documento de dibujo. En lugar de recurrir al ajuste de escala de la fuente y de la tabla, a varias entradas de tabla personalizadas o a un documento externo, la función de división de BOM permite presentar una tabla de BOM en varias «páginas».

Para crear una tabla de BOM de varias páginas, seleccione una BOM colocada (que probablemente supere la altura de la hoja del documento) y marque la casilla Limit Page Height en la sección Pages del panel Properties. Esto limitará la altura de la tabla al valor de altura indicado (Max Page Height, mm) y, por tanto, el número de líneas que se muestran en la tabla de BOM.

Javascript ID: Draftsman_BOM_LimitPageHeight

Draftsman detecta que no se muestra toda la BOM, tal como indica la entrada Page del panel (por ejemplo, Page 1 from 2), y el menú desplegable asociado permite indicar qué página se muestra. Para añadir más páginas de la BOM (aquí, BOM Table ID = 0), coloque otra BOM y especifique el siguiente Page en la sección Pages del panel Properties .

Dado que cada página de la BOM se coloca añadiendo otra tabla de BOM y configurándola según corresponda, las páginas (secciones) individuales de la BOM se pueden colocar en cualquier hoja de un documento de Draftsman. Para colocar otro conjunto different de páginas de BOM divididas, especifique un BOM Table ID alternativo en una BOM colocada; por ejemplo, 1 en lugar de 0.

Tenga en cuenta que la propiedad Max Page Height especifica la altura de la página first de la tabla de BOM. Cuando se selecciona la segunda página (página 2), la propiedad Max Page Height define la altura de la primera página excluida (página 1). Por tanto, la página 2 muestra las entradas restantes de la BOM. Empiece por establecer el mismo valor para la propiedad Max Page Height en todas las páginas.

Tabla de taladros

Una tabla de taladros de Draftsman (Place » Drill Table) es un objeto de tabla generado automáticamente que contiene símbolos y datos de los taladros de la placa. La tabla de taladros, combinada con la vista de dibujo de taladros de Draftsman, proporciona información tanto tabular como gráfica para el proceso de fabricación de la placa. Una fila de símbolos, que representa un tipo específico de taladro, puede incluir diversos datos sobre el orificio, como su tamaño, si está metalizado y el número de orificios. Los tipos de orificios se agrupan bajo símbolos según lo especificado en el cuadro de diálogo Drill Symbol Configurations.

Una tabla de taladros colocada con las entradas de orificios agrupadas por tamaño
Una tabla de taladros colocada con las entradas de orificios agrupadas por tamaño

Cuando la extensión de software GOST 2.701-2008/2.106-1996 está instalada en su instalación de Altium Designer, los valores de la columna Plated de la tabla de taladros se muestran como Есть (para orificios metalizados) y Нет (para orificios no metalizados). 

Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

El estilo visual y el contenido de datos de una tabla de taladros colocada, incluido el símbolo utilizado, se pueden configurar en el panel Properties cuando la tabla está seleccionada en el espacio de diseño. Las propiedades generales de la tabla se configuran en la pestaña General del panel ().

Título

Title

La cadena de texto del título que se mostrará (si está habilitada) con la tabla. Utilice el botón asociado para alternar la visibilidad del título en el dibujo.

El campo puede incluir texto estático y los parámetros que desee en forma de cadenas especiales. Utilice la sintaxis =<ParameterName> para incluir un parámetro en el título. Los valores de los parámetros incluidos se mostrarán en el título de la hoja de dibujo. Para ver una lista de los parámetros de sistema y de PCB disponibles, consulte la página Configuración de un documento de Draftsman.

Location Abra el menú desplegable para elegir entre varias ubicaciones relativas para el título. La opción Manual se selecciona automáticamente si el título se mueve manualmente (arrastrándolo y soltándolo en una nueva ubicación).
Font

Establece la fuente utilizada para el título.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada para el título es la definida en las opciones del documento (la entrada Document Font en General región de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está desactivada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

Propiedades

Layer Pairs Seleccione los orificios del par de capas de taladrado de la PCB que se mostrarán en la vista del dibujo. Utilice el menú desplegable para elegir entre los pares de capas disponibles en el diseño de la placa de origen, que pueden verse y editarse en el editor de PCB, al que se puede acceder desde Layer Stack Manager. Todos los diseños de placa tendrán un par de capas Top - Bottom, mientras que los demás pares representarán orificios de vías que pasan entre otras capas o hasta ellas, como las capas internas o de plano.

Las opciones Counterhole Bottom y Counterhole Top solo están disponibles cuando el documento de PCB incluye pads con funciones de avellanado o cajeado habilitadas en las caras correspondientes de la PCB (más información).

Tenga en cuenta que los avellanados y cajeados se excluyen de los pares de capas distintos de Counterhole Bottom y Counterhole Top. También se excluyen del par de capas All Layers.

Pads / Vias Utilice el menú desplegable para seleccionar el tipo de orificio de taladrado (Pads, Vias o All) que se mostrará en la tabla.
Plated / Non-Plated Utilice el menú desplegable para seleccionar el tipo de metalización de los orificios (Plated, Non-Plated o All) que se mostrará en la tabla.
Border Line Style

Utilice los menús desplegables para seleccionar la línea utilizada para representar el borde o contorno de la tabla. Las opciones disponibles se definen en la región Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman. Utilice el botón de color asociado para especificar el color de la línea.

Justification Seleccione el punto con respecto al cual cambia la posición de la tabla si se actualiza su tamaño.
Even Row Color Seleccione el color de contraste para las filas pares de la tabla.
Non-Even Row Color Seleccione el color de contraste para las filas impares de la tabla.
Font

Establece la fuente utilizada para los datos de la tabla.

  • Cuando la opción Use Document Font está activada, se utiliza la fuente definida en las opciones del documento (la entrada Document Font de la región General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está desactivada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

La tabla se ajustará automáticamente para adaptarse al tamaño de fuente seleccionado.

Show Footer Marque esta casilla para habilitar el pie de la tabla, que muestra el número total de orificios de taladrado.
Seleccione esta opción para abrir el cuadro de diálogo Drill Symbol Configurations, que ofrece una vista tabular de todos los datos de los orificios de taladrado y permite configurar el estilo y el tamaño del símbolo de cada orificio (más información).

Unidades

Primary Units

Seleccione el tipo de unidad de medida principal que se mostrará en la tabla. Utilice el botón  asociado para mostrar u ocultar las unidades de medida.

Cuando se selecciona la opción Document : <Units> como Primary Units, se aplican a la tabla las unidades principales especificadas para el documento. Las unidades principales del documento se seleccionan mediante el menú desplegable Primary Units de la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Dual Units

Seleccione el tipo de unidad de medida secundaria (dual) que se mostrará en la tabla. Utilice el botón  asociado para mostrar u ocultar los valores de las unidades secundarias.

Cuando se selecciona la opción Document : <Units> como Dual Units, se aplican a la tabla las unidades duales especificadas para el documento. Las unidades duales del documento se seleccionan mediante el menú desplegable Dual Units de la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Precisión

Primary Units

Utilice el menú desplegable Value Precision para establecer la precisión (hasta cinco dígitos a la derecha del separador decimal, con redondeo del último dígito) de las entradas de tamaño de orificio en unidades principales de la tabla.

Cuando se selecciona la opción Document : <Precision>, se aplica a la tabla la precisión de los valores y las tolerancias en unidades principales especificada para el documento. La precisión de los valores y las tolerancias en unidades principales del documento se selecciona mediante las opciones Value Precision y Tolerance Precision para Primary Units en la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Dual Units

Utilice el menú desplegable Value Precision para establecer la precisión (hasta cinco dígitos a la derecha del separador decimal, con redondeo del último dígito) de las entradas de tamaño de orificio en unidades duales (secundarias), si están habilitadas.

Cuando se selecciona la opción Document : <Precision>, se aplica a la cota la precisión de los valores y las tolerancias en unidades duales especificada para el documento. La precisión de los valores y las tolerancias en unidades duales del documento se selecciona mediante las opciones Value Precision y Tolerance Precision para Dual Units en la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Utilice la pestaña Columns del panel Properties para gestionar las columnas de datos de la tabla de taladros ().

  • Las entradas pueden editarse para especificar las columnas incluidas (visibles) en la tabla de taladros y su alineación Horizontal y Vertical.

  • Utilice la entrada Width para definir el ancho de la columna en relación con el texto que contiene. Introduzca Auto para que el ancho varíe dinámicamente y se ajuste al texto más ancho de las celdas de la columna.

  • Haga clic dentro de la columna Order para alternar entre las opciones de ordenación de los datos de la columna de la tabla (desactivada, ascendente y descendente). La ordenación se puede aplicar a varias columnas por orden de prioridad; las columnas ordenadas situadas más a la izquierda en la tabla tienen mayor prioridad.

  • Los encabezados de la tabla de taladros pueden cambiarse introduciendo un Caption para el nombre de parámetro de una columna de la tabla.

  • Utilice  y  botones para mover la entrada seleccionada una posición hacia arriba o hacia abajo y, por tanto, hacia la izquierda o hacia la derecha en el orden de las columnas de la tabla de taladros. Disponible para las columnas configuradas como visibles.

Los estilos de los símbolos de la tabla de taladros y la agrupación de los tipos de taladros bajo dichos símbolos se determinan mediante los ajustes del cuadro de diálogo Drill Symbol Configurations, que se abre al hacer clic en el botón del panel Properties (en la sección Properties de la pestaña General) cuando la tabla está seleccionada en el espacio de diseño.

Este es el mismo cuadro de diálogo que se abre desde el panel Properties para una vista del plano de taladrado, pero, en este caso, solo se mostrarán las columnas activadas (visibles) para la tabla de taladros. Tenga en cuenta que las dos versiones del cuadro de diálogo Drill Symbol Configuration tienen el mismo origen y, por tanto, interactúan.

Symbol Graphics Utilice el menú desplegable para seleccionar el gráfico de representación de taladros deseado entre una serie de formas y letras predefinidas.
Sync Symbols with PCB Cuando esta opción está habilitada, los símbolos de la tabla de taladros se sincronizan con los de la PCB.
Symbol Size Table

Introduzca el tamaño deseado del símbolo en la tabla.

  • Tenga en cuenta que el tamaño del símbolo cambiará para los símbolos de taladro seleccionados actualmente en la cuadrícula de la parte superior del cuadro de diálogo. Para seleccionar varios símbolos de taladro en la cuadrícula, utilice la técnica Ctrl+Click o Shift+Click.

  • Tenga en cuenta también que el tamaño está vinculado entre la vista del plano de taladrado y la tabla de taladros si el icono de vínculo aparece como vinculado (). Para establecer el tamaño de los símbolos de taladro de forma independiente, haga clic en el icono de vínculo para desvincular ambos tamaños y establezca el tamaño deseado para cada uno.

Symbol Size View Introduzca el tamaño deseado del símbolo en la vista. Para acceder a este campo y editarlo, el icono de vínculo debe aparecer como desvinculado (). Haga clic en el icono de vínculo para alternar el estado del vínculo.
Symbol Line Style

Utilice los menús desplegables para seleccionar la línea utilizada para dibujar el borde o contorno de los gráficos de los símbolos. Las opciones disponibles se definen en la sección Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman. Utilice el botón de color asociado para especificar el color de la línea.

Grouping Los criterios elegidos agruparán las selecciones bajo un mismo símbolo. Por ejemplo, si solo se selecciona HoleSize, se asignará un símbolo individual a cada tamaño de taladro utilizado en la PCB. A medida que se seleccionen más opciones de agrupación, la asignación de símbolos distinguirá los criterios adicionales mediante un esquema de agrupación más detallado.

Puede definir los ajustes predeterminados de Symbol Size Table, Symbol Size View, Symbol Line Style y Grouping mediante la página Draftsman – Valores predeterminados del cuadro de diálogo Preferences. En esta página, seleccione Drill Table en Primitive List y abra la pestaña Drill Symbol en la sección de propiedades de la derecha ().

Tabla de líneas de transmisión

Los cálculos aplicados en el enrutado con impedancia controlada dan como resultado estructuras de pistas que buscan satisfacer una impedancia objetivo de la línea de transmisión y, por tanto, los requisitos de alta velocidad y/o de campos electromagnéticos del diseño de la placa. Se accede a las capas de la placa y a sus propiedades especificadas o calculadas a través del administrador de apilado de capas, donde las capas de enrutado con impedancia controlada se asocian a perfiles de impedancia configurables. Los materiales y las dimensiones de la placa de cada perfil se aplican a sus cálculos de impedancia de la línea de transmisión, lo que da como resultado una estructura de pistas determinada. Esta estructura admite tanto pistas individuales como pares diferenciales, así como configuraciones de capas de placa de tipo stripline (internas) o microstrip (superficiales).

Para obtener más información sobre la configuración de perfiles de impedancia, consulte la página Definición del apilado de capas.

Dado que la estructura y los datos asociados a cada definición de línea de transmisión del apilado de capas de la placa son información importante para el proceso de fabricación de la PCB, Draftsman incluye un objeto específico de tabla de líneas de transmisión (Place » Transmission Line Table) para documentar esta información. La tabla se rellena con datos extraídos del administrador de apilado de capas y de sus cálculos de impedancia de líneas de transmisión.

Una tabla de líneas de transmisión colocada
Una tabla de líneas de transmisión colocada

El estilo visual y el contenido de datos de una tabla de líneas de transmisión colocada se pueden configurar en el panel Properties cuando la tabla está seleccionada en el espacio de diseño. Las propiedades generales de la tabla se configuran en la pestaña General del panel ().

Título

Title

La cadena de texto del título que se mostrará (si está habilitada) junto con la tabla. Utilice el botón asociado para alternar la visibilidad del título en el plano.

El campo puede incluir texto estático y los parámetros que desee en forma de cadenas especiales. Utilice la sintaxis =<ParameterName> para incluir un parámetro en el título. Los valores de los parámetros incluidos se mostrarán en el título en la hoja de dibujo. Para obtener una lista de los parámetros del sistema y de la PCB disponibles, consulte la página Configuración de un documento de Draftsman.

Location Utilice el menú desplegable para elegir entre varias ubicaciones relativas para el título. La opción Manual se selecciona automáticamente si el título se mueve manualmente (arrastrándolo y soltándolo en una nueva ubicación).
Font

Establece la fuente utilizada para el título.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada para el título es la definida en las opciones del documento (la entrada Document Font de la sección General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está deshabilitada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

Propiedades

Table Line Style

Utilice los menús desplegables para seleccionar la línea utilizada para dibujar las líneas de la tabla. Las opciones disponibles se definen en la sección Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman. Utilice el botón de color asociado para especificar el color de la línea.

Justification Seleccione el punto con respecto al cual cambia la posición de la tabla si se actualiza su tamaño.
Even Row Color Seleccione el color de contraste para las filas pares de la tabla.
Non-Even Row Color Seleccione el color de contraste para las filas impares de la tabla.
Caption Font

Establece la fuente utilizada para los datos de la tabla.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada es la definida en las opciones del documento (la entrada Document Font de la sección General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font opción está desactivada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

La tabla ajustará automáticamente su tamaño para adaptarse al tamaño de fuente seleccionado.

Rows Font

Establece la fuente utilizada para el cuerpo de la tabla (el texto de las filas de la tabla).

  • Cuando la opción Use Document Font está activada, se utiliza la fuente definida en las opciones del documento (la entrada Document Font de la región General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está desactivada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

La tabla ajustará automáticamente su tamaño para adaptarse al tamaño de fuente seleccionado.

Unidades

Primary Units

Seleccione el tipo de unidad de medida principal que se mostrará en la tabla. Utilice el botón  asociado para alternar la visibilidad de las unidades de medida.

Cuando se selecciona la opción Document : <Units>, se aplican a la tabla las unidades principales especificadas para el documento. Las unidades principales del documento se seleccionan mediante el menú desplegable Units de la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Primary Precision

Seleccione la precisión (hasta cinco dígitos a la derecha del separador decimal, con el último dígito redondeado) para los valores de las unidades principales.

Cuando se selecciona la opción Document : <Precision>, se aplica a la tabla la precisión de los valores y las tolerancias de las unidades principales especificada para el documento. La precisión de los valores y las tolerancias de las unidades principales del documento se selecciona mediante las opciones Value Precision y Tolerance Precision para Primary Units en la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Dual Units

Seleccione el tipo de unidad de medida secundaria (dual) que se mostrará en la tabla. Utilice el botón  asociado para alternar la visibilidad de los valores de las unidades secundarias.

Cuando se selecciona la opción Document : <Units>, se aplican a la tabla las unidades duales especificadas para el documento. Las unidades duales del documento se seleccionan mediante el menú desplegable Dual_Units de la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Dual Precision

Seleccione la precisión (hasta cinco dígitos a la derecha del separador decimal, con el último dígito redondeado) para los valores de las unidades secundarias, si están activadas.

Cuando se selecciona la opción Document : <Precision>, se aplica a la cota la precisión de los valores y las tolerancias de las unidades duales especificada para el documento. La precisión de los valores y las tolerancias de las unidades duales del documento se selecciona mediante las opciones Value Precision y Tolerance Precision para Dual Units en la región Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman.

Utilice la pestaña Columns del panel Properties para gestionar las columnas y filas de datos de la línea de transmisión ().

  • La región Columns proporciona una lista de las columnas incluidas en la tabla. Cada entrada de columna puede editarse alternando su visibilidad, cambiando el nombre de su encabezado (Caption), recorriendo sus opciones de alineación del texto (Align) o estableciendo un ancho de columna específico o automático (Width). El orden de las entradas de la lista y, por tanto, el orden de las columnas de la tabla colocada, puede editarse cambiando la posición de una entrada de columna seleccionada mediante los botones  y  asociados.

  • La región Rows proporciona una lista de los datos de las filas de la tabla ordenados por la columna Impedance Id, que corresponde a las capas con nombre de la placa en el apilado de capas de origen. Utilice el control de visibilidad asociado a cada entrada de fila para alternar su visibilidad en la tabla.

Tabla

Un documento de Draftsman permite colocar una tabla genérica en el plano y configurarla posteriormente en el panel Properties y en las propias celdas de la tabla. La disposición y el contenido de la tabla personalizada pueden definirse libremente según su finalidad y ofrecen una forma flexible de incluir información adicional en cualquier documento de Draftsman.

Una tabla colocada con diversos formatos de celda
Una tabla colocada con diversos formatos de celda

  • Mediante las opciones disponibles en las propiedades de la tabla y los comandos de tabla, se puede crear una tabla personalizada que satisfaga una amplia variedad de necesidades de información en un documento de Draftsman. La tabla que se muestra a continuación, por ejemplo, se ha creado para mostrar la información extraída de un informe del apilado de la placa.

    Se puede crear una tabla personalizada para incluir una amplia variedad de información de ensamblaje y fabricación de PCB.
    Se puede crear una tabla personalizada para incluir una amplia variedad de información de ensamblaje y fabricación de PCB.

  • Las tablas pueden incluirse tanto en plantillas de hoja como en plantillas de documento.

Al ejecutar el comando de colocación de tablas (Place » Table), se abrirá el cuadro de diálogo Insert table, donde se puede especificar el número de filas y columnas de la nueva tabla. Tras hacer clic en OK en el cuadro de diálogo Insert table, la nueva tabla queda vinculada al cursor y puede colocarse en la ubicación deseada con un clic adicional.

Especifique el número de celdas de las filas y columnas de la tabla; estos valores pueden modificarse más adelante mediante los comandos Table del menú contextual de una celda.
Especifique el número de celdas de las filas y columnas de la tabla; estos valores pueden modificarse más adelante mediante los comandos Table del menú contextual de una celda.

La posición de una tabla colocada puede cambiarse gráficamente seleccionando el objeto de tabla en el espacio de diseño y arrastrándolo a una nueva ubicación mediante su control de desplazamiento, es decir, el icono  de la esquina superior izquierda.

Arrastre el icono de desplazamiento de una tabla seleccionada para cambiar su posición en el espacio de diseño.
Arrastre el icono de desplazamiento de una tabla seleccionada para cambiar su posición en el espacio de diseño.

Un objeto de tabla se selecciona al hacer clic en una celda o en su título. Sin embargo, el comando Delete se aplicará al elemento específico en el que se haga clic. 

El contenido de una tabla se introduce escribiéndolo (o pegándolo) directamente en las celdas. Utilice Ctrl+Enter para añadir una nueva línea dentro de una celda.

Los atributos gráficos y de texto de la tabla se definen en el panel Properties cuando la tabla está seleccionada en el espacio de diseño (). El objeto de tabla ofrece una amplia variedad de funciones de edición de texto y estructura, que pueden aplicarse por celda, fila o columna mediante los controles estándar Shift+Click o Click, Hold&Drag técnica.

Título

Title

La cadena de texto del título que se mostrará (si está habilitada) junto con la tabla. Utilice el botón asociado para alternar la visibilidad del título en el dibujo.

El campo puede incluir texto estático y los parámetros que desee en forma de cadenas especiales. Utilice la sintaxis =<ParameterName> para incluir un parámetro en el título. Los valores de los parámetros incluidos se mostrarán en el título en la hoja de dibujo. Para obtener una lista de los parámetros de sistema y de PCB disponibles, consulte la página Configuración de un documento de Draftsman.

Location Abra la lista desplegable para elegir entre distintas ubicaciones relativas para el título. La opción Manual se selecciona automáticamente si el título se mueve manualmente (arrastrándolo y soltándolo en una nueva ubicación).
Font

Establece la fuente utilizada para el título.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada para el título es la definida en las opciones del documento (la entrada Document Font en la sección General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está deshabilitada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

Propiedades

Línea exterior

Utilice las listas desplegables para seleccionar la línea utilizada para representar el borde o contorno de la tabla. Las opciones disponibles se definen en la sección Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman. Utilice el botón de color asociado para especificar el color de la línea.

Inner Line Utilice las listas desplegables para seleccionar la línea utilizada para representar las líneas interiores de la tabla que dividen las celdas. Las opciones disponibles se definen en la sección Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configuración de un documento de Draftsman. Utilice el botón de color asociado para especificar el color de la línea.
Column Width

Establece el ancho de las celdas seleccionadas y, por tanto, el ancho de la columna que las contiene. Si se selecciona toda la tabla (haciendo clic en su contorno o título), el ajuste de ancho se aplicará a todas las celdas. Utilice el botón de color asociado para especificar el color de las celdas seleccionadas actualmente.

Row Height Utilice este campo para ajustar la altura de una fila seleccionada en el espacio de diseño. Introduzca la altura deseada, seguida de la unidad imperial o métrica.
Cell Padding Vertical Establece el espacio por debajo y por encima del texto en las celdas seleccionadas.
Cell Padding Horizontal Establece el espacio a la izquierda y a la derecha del texto en las celdas seleccionadas.
Font

Establece la fuente utilizada para el texto en las celdas seleccionadas.

  • Cuando la opción Use Document Font está habilitada, la fuente utilizada es la definida en las opciones del documento (la entrada Document Font en la sección General de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño).

  • Cuando la opción Use Document Font está deshabilitada, utilice las opciones disponibles para elegir el tipo, el tamaño y el color de fuente, así como los atributos de texto deseados.

La tabla se ajustará automáticamente para adaptarse al tamaño de fuente seleccionado.

Alignment Utilice los botones para establecer la alineación y la posición del texto Horizontal (izquierda, centro o derecha) y Vertical (arriba, centro o abajo) en las celdas seleccionadas.
Justification Seleccione el punto con respecto al cual se modifica la posición de la tabla si se actualiza su tamaño.

Cadenas especiales en las celdas de una tabla

Una tabla permite incluir parámetros del documento de Draftsman como cadenas especiales. Los parámetros de proyecto (tanto locales como del espacio de trabajo), de sistema, de PCB y de usuario se convertirán en sus valores cuando se introduzcan como cadenas especiales en las celdas de la tabla. Se puede acceder a los parámetros del documento de Draftsman en la pestaña Parameters del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Consulte la página Configuración de un documento de Draftsman para obtener más información.

El tratamiento de las cadenas de parámetros en la tabla también permite transferir correctamente los datos de cadenas especiales hacia y desde una hoja de cálculo mediante las técnicas estándar de copiar y pegar.

  • Al pegar cadenas especiales de Draftsman en una hoja de cálculo, las celdas de destino se rellenarán con el valor interpretado de la cadena.

  • Al pegar datos de cadenas especiales de una hoja de cálculo en Draftsman, el texto pegado se interpretará como el valor de una cadena especial, siempre que esta corresponda a un parámetro de sistema, de proyecto o de usuario disponible.

    Al preparar entradas de cadenas especiales en una hoja de cálculo, deberá anteponer un apóstrofo (') a cada valor para que el contenido de la celda se trate como datos de texto. Por ejemplo, la cadena especial para el parámetro Units se introduciría como '=DocumentUnits. Como alternativa, se podría establecer el formato de todas las celdas de la hoja de cálculo en Texto.

Estructura de la tabla

Haga clic con el botón derecho en una celda y seleccione el menú Table en el menú contextual para acceder a los comandos de configuración de celdas. Estos proporcionan un conjunto completo de funciones de manipulación de tablas para añadir y eliminar columnas y filas, y combinar celdas.

Los comandos Table del menú contextual ofrecen diversas funciones estándar de manipulación de tablas.
Los comandos Table del menú contextual ofrecen diversas funciones estándar de manipulación de tablas.

  • El comando Merge Cells solo estará disponible si hay dos o más celdas consecutivas seleccionadas en la tabla.

    • Al combinar celdas que contienen texto, solo permanecerá en la celda combinada el texto de la celda situada más a la izquierda o más arriba, según corresponda.

  • El comando Unmerge Cells solo estará disponible si el cursor se encuentra dentro de una celda combinada de la tabla o si el rango de celdas seleccionado incluye al menos una celda combinada.

    • Tenga en cuenta que, si la celda contiene texto, después de separarla ese texto aparecerá en la celda situada más a la izquierda o más arriba, según corresponda.

    • Al separar celdas, si la selección incluye varias celdas combinadas, tenga en cuenta que este comando solo separará la celda combinada situada más a la izquierda o más arriba.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents