Este artículo te guía en la creación de un plano de fabricación de arneses en Altium Designer mediante el editor Draftsman, desde la incorporación del documento al proyecto y su configuración hasta la colocación de vistas de solo lectura del diagrama de cableado y del plano de disposición, la adición de vistas de detalle y de componentes, y el uso de anotaciones, cotas y tablas para documentar el diseño de cara a la fabricación. También explica cómo incorporar al plano de fabricación las actualizaciones del diagrama de cableado y del plano de disposición, y cómo gestionar las propiedades, las unidades, los parámetros y la navegación entre varias hojas dentro del documento. Si quieres tener una idea clara de cómo los datos de diseño de arneses se convierten en documentación de fabricación organizada, este artículo te ayudará a comprender todo el flujo de trabajo. Sigue leyendo.
- Aprende a crear y configurar un documento de plano de fabricación de arneses en Draftsman, incluidas las plantillas, la configuración del documento, las unidades y los parámetros importados del proyecto.
- Descubre qué tipos de vistas, anotaciones, cotas y herramientas de dibujo adicionales puedes añadir para representar con claridad la información del diseño del arnés.
- Comprende qué tablas de fabricación están disponibles, incluidas las listas de materiales (BOM), las listas de cableado y las tablas de conexiones, así como el origen de sus datos y la forma en que se presentan.
Profundiza con IA:
Una vez completados el diagrama de cableado y el plano de disposición, se pueden insertar copias de solo lectura de su contenido en el documento de plano de fabricación (*.HarDwf) y añadir las anotaciones necesarias. El plano de fabricación de un diseño de arnés se crea en el editor Draftsman.
Añada un plano de fabricación al proyecto de arnés desde el panel Projects haciendo clic con el botón derecho en la entrada del proyecto y seleccionando Add New to Project » Draftsman Document en el menú contextual (o utilice el comando File » New » Draftsman Document de los menús principales). En el cuadro de diálogo New Document que se abre, seleccione una plantilla de plano de fabricación disponible según sea necesario y asegúrese de que se hayan seleccionado el Project y el plano de disposición del arnés Document correctos.
Configuración de un documento de plano de fabricación
Las opciones de un documento de plano de fabricación se pueden configurar en el panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño del documento. Consulte la página Configuración de un documento de Draftsman para obtener más información.
Las pestañas del panel Properties cuando no hay ningún objeto seleccionado en el documento de plano de fabricación del arnés
Una vez creado el documento de plano de fabricación, los cambios realizados en el diagrama de cableado o en el plano de disposición se pueden importar al plano de fabricación mediante el comando Tools » Import Changes From <LayoutDrawing.LdrDoc> de los menús principales o del menú contextual del espacio de diseño. Tenga en cuenta que, a pesar de la descripción del comando de menú, se importarán los cambios de both the wiring diagram and the layout drawing.
Las propiedades predeterminadas de los objetos del plano de fabricación se pueden configurar en la página Draftsman – Valores predeterminados del cuadro de diálogo Preferences. Estas propiedades se aplicarán al colocar objetos posteriormente.
El panel Marcadores ofrece una forma práctica de navegar por un plano de fabricación de varias hojas y gestionarlo. El panel presenta una vista de árbol desplegable de la estructura completa del documento e incluye todas las hojas del documento y los objetos de vista principales de dichas hojas.
Mediante las opciones Units y Dual_Units del panel Properties, cuando no hay ningún objeto seleccionado en el espacio de diseño, puede seleccionar las unidades de medida predeterminadas del documento para los valores de cota y los valores de longitud que se muestran en las tablas. Si es necesario, las unidades especificadas a nivel de documento se pueden sustituir por otras en las propiedades de objetos específicos. Las unidades admitidas son Millimeters, Mils, Inches, Centímetros, Metros y Feet.
Los parámetros del documento de plano de disposición se importan al documento de plano de fabricación del arnés asociado. Estos parámetros se enumeran en la pestaña Parameters del panel Properties del documento (la visibilidad de los parámetros de disposición en la lista se puede activar o desactivar mediante la casilla situada junto al icono del panel) y se pueden utilizar en cadenas especiales. Los valores de parámetros calculados, como =ItemRevision y =ItemRevisionLevel1, también se incluyen e interpretan en las salidas generadas durante la publicación.
Trabajo con vistas
En un documento de plano de fabricación, puede colocar vistas de solo lectura del diagrama de cableado del arnés y del plano de disposición del arnés incluidos en este proyecto.
Vista del diagrama de cableado
Una vista del diagrama de cableado (Place » Wiring Diagram View) es una representación gráfica compuesta generada automáticamente a partir del diagrama de cableado del proyecto de diseño de arnés activo.
Ejemplo de una vista del diagrama de cableado
Las propiedades de una vista del diagrama de cableado colocada se pueden configurar en el panel Properties cuando la vista está seleccionada en el espacio de diseño.
El panel Properties cuando hay una vista del diagrama de cableado seleccionada
Si su proyecto de arnés incluye varios documentos de diagrama de cableado (más información), puede elegir el documento de diagrama de cableado a partir del cual se debe generar y actualizar una vista del diagrama de cableado colocada. Con la vista del diagrama de cableado seleccionada, utilice el menú desplegable Document de la sección Properties del panel Properties para elegir el documento de diagrama de cableado para esta vista ().
Cuando Auto Size está activado, la vista del diagrama de cableado ajusta automáticamente su tamaño para eliminar el espacio vacío en los bordes.
Seleccione Justification haciendo clic en la flecha que corresponda a la alineación deseada o en el círculo para centrar. La opción elegida para Justification define el punto respecto al cual cambia la posición de la vista si se actualiza su tamaño.
Vista del plano de disposición
Una vista del plano de disposición (Place » Layout Drawing View) es una representación gráfica compuesta generada automáticamente a partir del plano de disposición del proyecto de diseño de arnés activo.
Ejemplo de una vista del plano de disposición
Las propiedades de una vista del plano de disposición colocada se pueden configurar en el panel Properties cuando la vista está seleccionada en el espacio de diseño.
El panel Properties cuando hay una vista del plano de disposición seleccionada
Cuando Auto Size está activado, la vista del plano de disposición ajusta automáticamente su tamaño para eliminar el espacio vacío en los bordes.
Seleccione Justification haciendo clic en la flecha que corresponda a la alineación deseada o en el círculo para centrar. La opción elegida para Justification define el punto respecto al cual cambia la posición de la vista si se actualiza su tamaño.
Vistas adicionales
Se pueden utilizar vistas adicionales para completar el plano de fabricación: la vista de detalle del arnés y la vista de componente.
Una vista de detalle del arnés permite mostrar un área definida de un plano existente como una vista flotante y ampliada de sus detalles. Hay opciones de área circular y rectangular disponibles para una vista de detalle del arnés. Para colocar la vista deseada, seleccione una opción (Circle area detail view o Rectangle area detail view) en el menú principal Place » Additional Views » Harness Detail View.
Ejemplo de una vista de detalle del arnés con área circular aplicada a una vista del diagrama de cableado
Ejemplo de una vista de detalle del arnés con área rectangular aplicada a una vista del diagrama de cableado
La vista de componente (Place » Additional Views » Component View) es una vista de dibujo de un único componente del diseño de arnés actual.
Ejemplo de una vista de componente
Anotación y acotación del plano
Se proporciona una serie de herramientas adicionales de anotación, acotación y dibujo para añadir información importante a un plano de fabricación. Estas incluyen sistemas automatizados de notas y resaltado, así como herramientas para indicar las longitudes, los tamaños y los ángulos de los contornos de los objetos, o la distancia entre los objetos especificados.
Ejemplo de una vista anotada del plano de disposición
Una llamada asociada a un conector o a un punto de conexión y configurada para mostrar el elemento de la BOM muestra los números de posición en la BOM del propio conector o punto de conexión y de sus piezas asociadas. Una llamada añadida a la vista física de un componente en una vista del plano de disposición también mostrará los números de posición en la BOM de todas las cavidades asignadas a este componente.
Cuando se coloca una cota lineal entre puntos de conexión en una vista del plano de disposición, el Value campo (la longitud de la cota) se rellena automáticamente con la longitud del haz del arnés correspondiente.
Consulte las siguientes páginas para obtener más información:
Un documento de plano de fabricación permite colocar en el plano una lista de materiales (BOM), una lista de cableado, una tabla de conexiones y una tabla genérica. Los datos tabulados se obtienen directamente de los documentos del proyecto y proporcionan una forma sencilla y visual de transmitir información esencial para los procesos de fabricación de arneses.
En las propiedades de las tablas de lista de materiales, lista de cableado y conexiones, puede especificar Length Units y Value Precision de longitud (anulando los valores especificados a nivel de documento). Las opciones seleccionadas se aplicarán a los valores de longitud que se muestran en la tabla correspondiente.
Para los componentes de cableado del arnés, la columna Length de una tabla de lista de materiales presenta la longitud total de los hilos o cables de un mismo elemento de la BOM, en lugar de sus longitudes individuales.
Las cubiertas de hilos, cables y arneses son objetos definidos por su longitud, cuyo valor se muestra en el Length campo. El Quantity campo de estos objetos es As Required.
Cuando se copia cualquier objeto de tabla del documento de plano de fabricación, su contenido puede pegarse en una hoja de cálculo de Microsoft Excel.
Una lista de cableado (Place » Wiring List) es un objeto de tabla generado automáticamente que muestra los puntos de inicio y fin y los valores de los parámetros de cada hilo del arnés.
Ejemplo de una lista de cableado
Las propiedades de una lista de cableado colocada (como los atributos visuales y el contenido de los datos) pueden configurarse en el panel Properties cuando la lista de cableado está seleccionada en el espacio de diseño.
Las pestañas del Properties panel cuando se selecciona una lista de cableado
Los designadores de los objetos de blindaje con conexión se muestran en la lista de cableado cuando hay un hilo conectado al objeto.
Si un hilo tiene el valor No en su parámetro Include Cut, no se mostrará en la lista de cableado.
Los parámetros de los hilos (y sus valores) especificados en el diagrama de cableado se reflejan en la lista de cableado. Se añade una columna adicional a la lista de cableado por cada parámetro de hilo. Estas columnas adicionales están ocultas de forma predeterminada. Utilice los controles de visibilidad de la pestaña Columns del panel Properties cuando la lista de cableado esté seleccionada para mostrar estas columnas en el espacio de diseño (y ocultar las columnas predeterminadas si es necesario).
Las celdas de la columna Color se dividen para mostrar los colores secundario y terciario asignados al hilo.
La columna ColorName incluye los nombres de los colores principal, secundario y terciario.
Se pueden mostrar columnas adicionales para los colores secundario, terciario y de borde.
Para los hilos de un cable, la Length columna de una lista de cableado muestra la longitud individual de cada hilo.
Para el conector pasamuros (el conector con el mayor número de cavidades), se aplica una agrupación automática a la lista de cableado, lo que garantiza que todas sus cavidades queden correctamente agrupadas en la columna From.
Utilice los botones y para desplazar una posición hacia la izquierda o la derecha en la lista de cableado una columna visible cuya entrada esté seleccionada en la pestaña Columns.
Haga clic en una celda de la columna Order para alternar entre las opciones de ordenación de los datos de las columnas de la tabla (desactivada, ascendente y descendente). Se puede aplicar la ordenación a varias columnas por orden de prioridad manteniendo pulsada la tecla Ctrl y haciendo clic en las celdas de la columna Order.
El conector con más hilos (y todas sus cavidades) se agrupa automáticamente en la From columna ().
División de una lista de cableado
La lista de cableado de un diseño de arnés avanzado puede tener un gran número de entradas, lo que puede dificultar su inclusión en un documento de plano como una sola tabla. En lugar de recurrir al escalado de la fuente y de la tabla, a varias entradas de tabla personalizadas o a un documento externo, puede «dividir» una tabla de lista de cableado para que esta se presente en varias «páginas».
En el Properties panel de una lista de cableado colocada, habilite la Limit Page Height opción en la Pages sección para limitar la altura de la tabla al valor de altura especificado (Max Page Height) y, por tanto, el número de líneas que se muestran en la tabla.
El editor detecta que no se muestra toda la lista de cableado, como indica la Page entrada del panel (por ejemplo, Page 1 from 2), y el menú desplegable asociado permite especificar qué página se muestra. Para añadir más páginas de la lista de cableado, coloque otra lista de cableado y especifique la siguiente Page en la Pages sección del Properties panel.
Dado que cada página de la lista de cableado se coloca añadiendo otra tabla de lista de cableado y configurándola según corresponda, las páginas individuales de la lista de cableado pueden colocarse en cualquier hoja del documento de plano de fabricación.
Tenga en cuenta que la Max Page Height propiedad especifica la altura de la first página de la tabla de lista de cableado. Cuando se selecciona la segunda página (página 2), la Max Page Height propiedad define la altura de la primera página excluida (página 1). Por lo tanto, la página 2 muestra las entradas restantes de la lista de cableado. Comience por hacer que la Max Page Height propiedad idéntica para cada página.
Tabla de conexiones
Una tabla de conexiones (Place » Connection Table) es un objeto de tabla generado automáticamente que muestra los cables conectados a cada punto de conexión (pin de conector, empalme, etc.) del arnés.
Ejemplo de una tabla de conexiones (para todos los componentes)
Las propiedades de una tabla de conexiones colocada (como los atributos visuales y el contenido de los datos) se pueden configurar en el panel Properties cuando la tabla de conexiones está seleccionada en el espacio de diseño.
Las pestañas del panel Properties cuando se selecciona una tabla de conexiones
Puede utilizar la opción Component para mostrar en la tabla los datos de todos los componentes del proyecto o los datos de un componente o empalme específico.
Si un cable tiene el valor No en su parámetro Include Cut, no se mostrará en la tabla de conexiones.
Los parámetros de los cables (y sus valores) especificados en el diagrama de cableado se reflejan en la tabla de conexiones. Se añade una columna adicional a la tabla de conexiones por cada parámetro de cable. Estas columnas adicionales están ocultas de forma predeterminada. Utilice los controles de visibilidad de la pestaña Columns del panel Properties cuando la tabla de conexiones esté seleccionada para mostrar estas columnas en el espacio de diseño (y ocultar las columnas predeterminadas si es necesario).
Las celdas de la columna Color se dividen para mostrar los colores secundario y terciario asignados al cable.
La columna ColorName incluye los nombres de los colores principal, secundario y terciario.
Se pueden mostrar columnas adicionales para los colores secundario, terciario y del borde.
Para los hilos de un cable, la columna Length de una tabla de conexiones muestra la longitud individual de cada hilo.
Utilice los botones y para desplazar una posición hacia la izquierda o la derecha, en la tabla de conexiones, una columna visible cuya entrada esté seleccionada en la pestaña Columns.
Haga clic en una celda de la columna Order para alternar entre las opciones de ordenación de los datos de la columna de la tabla (desactivada, ascendente y descendente). Se puede aplicar una ordenación a varias columnas por orden de prioridad manteniendo pulsada la tecla Ctrl y haciendo clic en las celdas de la columna Order.
Utilice la lista desplegable Display del panel Properties para configurar los datos que se muestran en la tabla:
Wires Only – mostrar solo los pines que tengan cables conectados.
Wires & Parts – mostrar los pines que tengan cables conectados y cualquier pieza de cavidad añadida, como un tapón en el caso de un conector sellado sin cable.
All Cavities – mostrar todos los pines de todos los componentes, independientemente de los cables conectados y las cavidades añadidas (por ejemplo, si hay un componente de 10 pines, se mostrarán los 10 pines en la tabla).
No Connect – mostrar solo los objetos de «sin conexión».
Dividir una tabla de conexiones
La tabla de conexiones de un diseño de arnés avanzado puede tener un gran número de entradas, lo que puede dificultar su inclusión en un documento de dibujo como una sola tabla. En lugar de recurrir al escalado de la fuente y de la tabla, a varias entradas de tabla personalizadas o a un documento externo, puede «dividir» una tabla de conexiones en un documento de Harness Draftsman (*.HarDwf) para que se muestre en varias «páginas». En el panel Properties de una tabla de conexiones colocada, active la opción Limit Page Height en la sección Pages para utilizar la nueva función. Esto limitará la altura de la tabla de conexiones al valor de altura especificado (Max Page Height) y, por tanto, el número de líneas que se muestran en la tabla.
El editor detecta que no se muestra toda la tabla de conexiones, tal como indica la entrada Page del panel (por ejemplo, 1 from 2), y el menú desplegable asociado permite especificar qué página se muestra. Para añadir más páginas de la tabla de conexiones, coloque otra tabla de conexiones (Place » Connection Table) y especifique la siguiente Page en la sección Pages del panel Properties .
La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.