Definición del diagrama de cableado

Las conexiones cableadas individuales dentro del arnés se especifican en el diagrama de cableado del arnés (*.WirDoc). Agregue este documento al proyecto de arnés desde el panel Projects haciendo clic con el botón derecho en la entrada del proyecto y luego seleccionando Add New to Project » Harness Wiring Diagram en el menú contextual (o use el comando File » New » Harness Wiring Diagram desde los menús principales).

Configuración de un documento de diagrama de cableado de arnés

Las opciones de un documento de diagrama de cableado de arnés se pueden configurar en el panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño del documento. Los ajustes principales son:

  • En la región General de la pestaña General del panel – seleccione las unidades de medida que se aplican al documento y a sus elementos gráficos, y configure las rejillas para facilitar la colocación. Altium Designer ofrece tres tipos de rejilla: rejilla visible para navegación, rejilla de ajuste para colocación y distancia de ajuste para ayudar en la creación de conexiones.

  • En la región Page Options de la pestaña General del panel – configure el tamaño de la hoja del documento y el bloque de título, o seleccione entre las plantillas disponibles de diagramas de cableado de arnés.

Las pestañas General y Parameters del panel Properties cuando no hay ningún objeto seleccionado en el documento de diagrama de cableado de arnés 
Las pestañas General y Parameters del panel Properties cuando no hay ningún objeto seleccionado en el documento de diagrama de cableado de arnés

  • La configuración de un documento de diagrama de cableado de arnés es similar a la configuración de un documento esquemático (*.SchDoc) de un proyecto de diseño de PCB. Consulte la página Setting Up a Schematic Document para obtener más información.

  • Use el desplegable Length Units para elegir las unidades de longitud del documento. Los valores Strip Length y Pull Off Length de las cavidades del zócalo se mostrarán usando las unidades seleccionadas. Las unidades admitidas son mm, cm, m, in y ft. Las unidades de longitud predeterminadas de los documentos de diagrama de cableado recién creados se pueden definir en la página Harness Design – General page del cuadro de diálogo Preferences .

  • Para obtener más información sobre la creación de plantillas de documentos de cableado de arnés, consulte la página Creating Harness Template Documents.

  • Las propiedades predeterminadas de los objetos del diagrama de cableado de arnés se pueden configurar en la página Harness Design – Defaults page del cuadro de diálogo Preferences . Estas propiedades se aplicarán al colocar objetos posteriores.

  • Al crear un documento de diagrama de cableado de arnés, también puede usar objetos de texto y dibujo. El trabajo con estos objetos en un documento de diagrama de cableado de arnés es similar al trabajo con ellos en un documento esquemático (*.SchDoc) de un proyecto de diseño de PCB. Consulte Working with Text Objects on a SchematicWorking with Drawing Objects on a Schematic para obtener más información sobre estos objetos.

    • Tenga en cuenta que los enlaces activos a objetos del diagrama de cableado de arnés (por ejemplo, cables y componentes) y a objetos del dibujo de disposición del arnés (por ejemplo, haces y puntos de conexión) también son compatibles en marcos de texto y notas. Haga clic en un enlace del marco de texto o nota colocados para realizar cross-probing a ese objeto en el documento asociado.

  • Para comprobar su diagrama de cableado de arnés en busca de infracciones lógicas, eléctricas y de delineación, se admite una serie de verificaciones de infracciones. Consulte la página Validating the Harness Design para obtener más información.

  • Un documento de diagrama de cableado de arnés se puede guardar en formato ASCII, lo cual puede ser beneficioso al compartirlo. Use el comando File » Save As y seleccione Harness Wiring ascii (*.WirDoc) en el desplegable Save as type del cuadro de diálogo Save As que se abre. Al guardar un diagrama de cableado ASCII usando el comando File » Save, se abrirá el cuadro de diálogo File Format, alertándole de que se está usando el formato ASCII. Elija la versión ASCII en el cuadro de diálogo para seguir usando este formato.

Sincronización de proyectos multi-board y de arnés

 
 
 
 
 

Cuando el proyecto de arnés forma parte de un proyecto de diseño multi-board, el diagrama de cableado del arnés se puede sincronizar a partir de los datos del documento esquemático multi-board (*.MbsDoc). Para hacerlo, seleccione el comando Design » Import Changes From <Multi-board Project> en los menús principales.

Para obtener más información sobre cómo agregar un proyecto de diseño de arnés a un proyecto multi-board, consulte la página Harness Design.

Si el documento esquemático multi-board contiene más de una definición de conexión de arnés, se abrirá el cuadro de diálogo Select Harness Definition. Especifique la definición que corresponda al proyecto de arnés actual.

El cuadro de diálogo Select Harness Definition
El cuadro de diálogo Select Harness Definition

Luego se abrirá el cuadro de diálogo Engineering Change Order, que mostrará los componentes conectores del arnés y las redes del arnés definidos en el esquema multi-board, que formarán la base del diagrama de cableado del arnés.

Use el cuadro de diálogo Engineering Change Order para importar datos del proyecto multi-board. 
Use el cuadro de diálogo Engineering Change Order para importar datos del proyecto multi-board. 

Después de ejecutar los cambios (), los datos del documento esquemático multi-board se importan al diagrama de cableado del arnés. Los componentes conectores, cada uno representado por su símbolo esquemático, aparecerán en el documento del diagrama de cableado del arnés, inicialmente en posiciones arbitrarias.

Un ejemplo de un diagrama de cableado de arnés inmediatamente después de la importación.
Un ejemplo de un diagrama de cableado de arnés inmediatamente después de la importación.

Se mostrarán líneas de red entre los pines para representar las conexiones lógicas definidas en el esquema multi-board. Tenga en cuenta que en esta etapa no hay cables físicos en el diseño.

Tenga en cuenta que los datos de conectividad importados del proyecto multi-board al proyecto de arnés dependen de los nombres de pin de los componentes conectores, así que asegúrese de que se asignen nombres únicos y correctos a los pines de los componentes en la biblioteca de origen antes de importar los datos.

Trabajo con componentes

Además de sincronizar desde el documento esquemático multi-board, los componentes también se pueden colocar manualmente en el diagrama de cableado del arnés. Esto permite colocar componentes en un proyecto de arnés independiente (es decir, que no forma parte de un proyecto multi-board), pero también permite colocar componentes adicionales en un diagrama de cableado de arnés que forma parte de un proyecto multi-board.

Use el panel Components para colocar los símbolos de los componentes necesarios. El proceso de colocación de componentes es similar al del editor Schematic; consulte la página Searching for & Placing Components para obtener más información. Tenga en cuenta que no habrá líneas de red para los componentes agregados manualmente, ya que no existe un diseño lógico de nivel superior que las controle.

Para mover un componente colocado (o un componente que se está colocando desde el panel Components) a la posición deseada, haga clic y mantenga presionado el botón izquierdo del ratón sobre él y mueva el ratón. Durante el arrastre, use el Spacebar para girar los componentes 90 grados y las teclas X y Y para voltearlos horizontal y verticalmente, respectivamente.

El diagrama de cableado del arnés después de mover los componentes
El diagrama de cableado del arnés después de mover los componentes

Las propiedades de un componente colocado se pueden configurar en el panel Properties cuando el componente está seleccionado en el espacio de diseño. El panel Properties para un componente incluye las siguientes pestañas:

 
 
 
 
 
  • General – propiedades generales del componente, como designador y comentario, ubicación, parámetros, etc.

  • Pins – la lista de pines del componente.

  • Cavities – permite asignar cavidades de zócalo al componente (más información).

  • Associated Parts – permite asignar piezas adicionales, como tubo termorretráctil, al componente.

Pestañas del panel Properties cuando un componente está seleccionado
Pestañas del panel Properties cuando un componente está seleccionado

Asignación de cavidades de zócalo

 
 
 
 
 

Las cavidades de zócalo y su tipo se pueden asignar a un componente de arnés. Seleccione un componente en el espacio de diseño para agregar una cavidad y un tipo. Seleccione un pin en la pestaña Cavities del panel Properties , luego haga clic en el botón  . Seleccione el tipo deseado del desplegable. Se admiten los siguientes tipos de cavidad:

  • Crimp – se utiliza para proporcionar una conexión eléctrica comprimiendo un barril de contacto alrededor de un conductor.

  • Seal – se utiliza para proporcionar protección ambiental sellando el punto de entrada del cable.

  • Plug – se utiliza para llenar una cavidad de conector abierta (sin usar) para mantener la integridad del sello ambiental.

  • Other – se utiliza para especificar otras piezas o materiales adicionales, p. ej., soldadura.

Para el tipo de cavidad Crimp o para filas a las que no se haya agregado tipo de cavidad, puede especificar los siguientes valores:

  • Strip Length – la longitud a la que se corta el aislamiento del conductor.

  • Pull Off Length – la longitud a la que el aislamiento cortado se retira del conductor. Esto se puede usar en casos en los que el extremo del cable no está completamente pelado y la pieza de aislamiento retirada se mantiene en el cable para evitar daños al filamento.

Las unidades con las que se muestran estos valores en el panel Properties cuando un componente está seleccionado se especifican usando el desplegable Length Units en la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el documento.

En el cuadro de diálogo Select Connector que se abre, busque y seleccione el componente deseado. El tipo específico y la información pertinente se agregarán al pin en la pestaña, como se muestra en las imágenes de abajo, para agregar un crimp al pin 1.

Tenga en cuenta que los pines se presentan en la tabla de la pestaña Cavities por sus nombres (la columna Pins) y la asignación de cavidades depende de los nombres de pin, así que asegúrese de que se asignen nombres únicos y correctos a los pines del componente.

Para un crimp, sello o tapón, solo se puede agregar una cavidad de un tipo determinado a un pin. Una vez que se ha agregado una cavidad de un tipo determinado, la entrada deja de estar disponible (aparece atenuada) en el desplegable. Se puede agregar cualquier número de cavidades del tipo Other a un pin.

Los pines con crimps asignados se indican mediante el símbolo  en el espacio de diseño, como se muestra en la imagen de abajo.

La región de cuadrícula de la pestaña Cavities admite selección múltiple y operaciones de copiar/pegar/eliminar para las entradas seleccionadas.

  • Se pueden seleccionar múltiples entradas de pines usando los atajos Click, Hold&DragCtrl+ClickShift+ClickCtrl+A.

  • Cuando hay varias entradas de pin seleccionadas, haga clic en   para agregar una cavidad a todos los pines seleccionados o haga clic en  o presione Delete para eliminar las cavidades agregadas de los pines seleccionados. 

  • Para cambiar la cavidad de un pin, seleccione su entrada y luego haga clic en  para abrir el cuadro de diálogo Select Connector y seleccionar la nueva cavidad.

  • Seleccione una o más entradas de pin y use los atajos Ctrl+X/Ctrl+C para cortar/copiar las entradas seleccionadas; luego use el atajo Ctrl+V para pegar el contenido cortado/copiado en la entrada seleccionada actualmente.

Creación de conectividad en el diagrama de cableado del arnés

Los cables físicos se colocan en el documento del diagrama de cableado del arnés seleccionando el comando Place » Harness Wire en los menús principales (atajo: Shift+W).

Después de seleccionar el comando, haga clic en el pin de un conector (aparece una cruz roja en el cursor cuando está sobre el punto activo de un pin) para colocar el punto inicial del cable del arnés. Coloque el cursor y haga clic para fijar una serie de puntos de vértice que definan la forma del cable del arnés. Después de colocar el punto de vértice final en el punto activo de otro pin, haga clic con el botón derecho para completar la colocación.

Al colocar un cable del arnés, pulse Shift+Spacebar para alternar entre los modos de colocación. El modo especifica cómo se crean las esquinas al colocar cables y los ángulos en los que pueden colocarse. Mientras esté en el modo 90 Degree o 45 Degree (modos ortogonales reales), pulse Spacebar para alternar entre los submodos de inicio y fin. El modo y submodo actuales se muestran en la barra de estado.

Al colocar un cable del arnés, las líneas de red se rastrean/actualizan “en vivo”, mostrándole dónde cablear en tiempo real, como se demuestra en el video siguiente. Una vez que se completa una conexión, su línea de red desaparece del documento.

Demostración de la función de trazado en vivo

Cuando está colocado y seleccionado, los vértices de un cable del arnés pueden arrastrarse para cambiar el ángulo entre dos secciones adyacentes (Mostrar ejemplo).

Seleccione un cable del arnés en el espacio de diseño para modificarlo en el panel Properties. Desde el panel, puede cambiar el nombre del cable del arnés seleccionado, modificar su ancho y color, y añadir parámetros que pueden mostrarse u ocultarse en el espacio de diseño.

El panel Properties cuando se selecciona un cable del arnés
El panel Properties cuando se selecciona un cable del arnés

  • Un cable del arnés colocado puede sustituirse por un componente de cableado del arnés que incluya un solo cable. Para ello, seleccione el cable del arnés que se va a sustituir y haga clic en el botón  situado a la derecha del campo Design Item ID en el panel Properties. En el cuadro de diálogo Replace Component que se abre, busque y seleccione el componente requerido. El cable colocado se actualizará con las propiedades y parámetros del componente elegido, manteniendo su geometría sin cambios. Consulte la sección Placing a Harness Wiring Component para obtener más información.

  • El color principal de un cable se define mediante el parámetro Color, que se presenta en un cable del arnés colocado de forma predeterminada. Para editar el color, introduzca su nombre (por ejemplo, Red) o su código hexadecimal (escribiendo el carácter # seguido del número hexadecimal, por ejemplo, #9900FF) como valor del parámetro. Como alternativa, haga clic en el botón de color situado a la izquierda del valor del parámetro y use el selector de color que se abre, donde el color del cable puede especificarse mediante un valor RGB o HEX, mediante selección libre o a partir de una gama de ajustes preestablecidos.

  • Los cables del arnés multicolor son compatibles en el diagrama de cableado del arnés eligiendo los colores secundario y terciario de un cable. En el panel Properties, haga clic en la lista desplegable   en la parte inferior de la región Parameters y luego elija Secondary y Tertiary para definir los colores deseados; el parámetro del color elegido aparecerá en la región Parameters . También puede definir el color del borde del cable del arnés usando la misma lista desplegable y seleccionando Border. Tenga en cuenta que el parámetro Color controla la visibilidad del valor combinado de los parámetros Color, Secondary Color y Tertiary Color definidos para el cable. Haga clic por la presentación de diapositivas siguiente para ver ejemplos.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Un cable con solo el color principal definido

    Un cable con el color secundario definido

    Un cable con el color terciario definido

    Un cable con el color del borde definido

    Un cable con todas las opciones de color definidas

    Los cables multicolor son compatibles con tablas en los documentos de plano de fabricación de diseños de arnés (*.HarDwf) – más información.

  • Si un cable del arnés tiene el valor No para su parámetro Include Cut, este cable no se mostrará en una lista de cableado ni en una tabla de conexiones en el plano de fabricación.

  • Los parámetros Color, Min. Bending Radius, Thickness y Units de un cable del arnés se utilizan al sincronizar un proyecto de diseño de arnés con una herramienta MCAD mediante MCAD CoDesigner. Consulte la página Synchronizing a Harness Design Project para obtener más información.

Adición de empalmes y derivaciones

En situaciones de diseño en las que un nuevo cable debe conectarse a un cable ya colocado, primero debe colocarse un objeto de empalme (Place » Splice) o derivación (Place » Tap).

  • Splice – el cable original se divide en dos cables separados mediante el empalme.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Otro cable necesita conectarse al cable seleccionado (W4).

    Un empalme colocado sobre el cable. Tenga en cuenta que el empalme divide el cable original en dos en la ubicación del empalme.

    Otro cable se ha conectado al empalme.

    Cuando dos cables se conectan en forma de T, se coloca un empalme automáticamente en la ubicación de la unión en T (Mostrar ejemplo).

  • Tap – el cable original permanece intacto.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Otro cable necesita conectarse al cable seleccionado (W4).

    Una derivación colocada sobre el cable. Tenga en cuenta que la derivación no divide el cable original.

    Otro cable se ha conectado a la derivación.

Las propiedades de un empalme o derivación colocados (su ubicación y representación visual) pueden configurarse en el panel Properties cuando el objeto está seleccionado en el espacio de diseño.

El panel Properties cuando se selecciona un empalme/derivación
El panel Properties cuando se selecciona un empalme/derivación

La región Associated Parts del panel Properties permite asignar componentes al empalme/derivación seleccionado, y este componente se reflejará en la BOM del proyecto.

Adición de cables

Para definir uno o más hilos como añadidos a un cable, puede colocar un objeto de cable en el diagrama de cableado del arnés (Place » Harness Cable).

Coloque un cable para definir uno o más hilos como añadidos a un cable.
Coloque un cable para definir uno o más hilos como añadidos a un cable.

Cuando se selecciona un objeto de cable, los hilos cubiertos por este cable se resaltan en verde neón en el espacio de diseño ().

Las propiedades de un objeto de cable colocado (su ubicación, representación visual y parámetros) pueden configurarse en el panel Properties cuando el objeto está seleccionado en el espacio de diseño.

 
 
 
 
 

El panel Properties cuando se selecciona un cable
El panel Properties cuando se selecciona un cable

Un cable tiene una relación de aspecto fija de 2:1 durante la colocación o la edición gráfica, y el tamaño final de colocación está determinado por el valor actual de la cuadrícula de ajuste del documento.

  • Si un cable está asociado con hilos en varios lugares del diagrama de cableado del arnés (es decir, cuando se colocan varios objetos de cable con el mismo designador sobre diferentes hilos), al seleccionar un objeto se resaltarán todos los hilos asociados del grupo, y todos estos hilos se enumerarán en la región Cable Objects del panel Properties ().

  • Los parámetros Color, Min. Bending Radius, Thickness y Units de un cable se utilizan al sincronizar un proyecto de diseño de arnés con una herramienta MCAD mediante MCAD CoDesigner. Consulte la página Synchronizing a Harness Design Project para obtener más información.

Blindaje y trenzado de hilos

Se puede adjuntar un blindaje (con o sin una conexión, como una conexión de hilo de drenaje) a un grupo de hilos colocando un objeto de blindaje (Place » Shield) o un blindaje con conexión (Place » Shield with Connection).

En el ejemplo que se muestra a continuación, los hilos W1, W2 y W3 están blindados por un blindaje sin conexión (SH1), y los hilos W4, W8 y W9 están blindados por un blindaje con conexión (SH2). El hilo W10 se coloca para conectar SH2 a un pin de componente.

Coloque un objeto de blindaje o blindaje con conexión para indicar los hilos como blindados.
Coloque un objeto de blindaje o blindaje con conexión para indicar los hilos como blindados.

Cuando se selecciona un objeto de blindaje o blindaje con conexión, los hilos cubiertos se resaltan en verde neón en el espacio de diseño ().

Las propiedades de un objeto de blindaje o blindaje con conexión colocado (ubicación y representación visual) pueden configurarse en el panel Properties cuando el objeto está seleccionado en el espacio de diseño. La región Shield Objects del panel enumera los hilos cubiertos por el objeto seleccionado.

 
 
 
 
 

El panel Properties cuando se selecciona un blindaje
El panel Properties cuando se selecciona un blindaje

  • Un blindaje tiene una relación de aspecto fija de 2:1 durante la colocación o la edición gráfica, y el tamaño final de colocación está determinado por el valor actual de la cuadrícula de ajuste del documento. 

  • Si un blindaje está asociado con hilos en varios lugares del diagrama de cableado del arnés (es decir, cuando se colocan varios objetos de blindaje con el mismo designador sobre diferentes hilos), al seleccionar un objeto se resaltarán todos los hilos asociados del grupo, y todos estos hilos se enumerarán en la región Shield Objects del panel Properties ().

Los hilos pueden indicarse como trenzados entre sí colocando un trenzado (Place » Twist). Un trenzado puede colocarse sobre dos o más hilos.

En el ejemplo siguiente, los hilos W1 y W2 se indican como trenzados entre sí mediante el trenzado Tw1.

Coloque un objeto de trenzado para indicar hilos trenzados entre sí.
Coloque un objeto de trenzado para indicar hilos trenzados entre sí.

Cuando se selecciona un trenzado, los hilos cubiertos se resaltan en verde neón en el espacio de diseño ().

Las propiedades de un trenzado colocado (su ubicación y representación visual) pueden configurarse en el panel Properties cuando el objeto está seleccionado en el espacio de diseño. La región Twist Objects del panel enumera los hilos cubiertos por el trenzado seleccionado.

 
 
 
 
 

El panel Properties cuando se selecciona un trenzado
El panel Properties cuando se selecciona un trenzado

  • Un trenzado tiene una relación de aspecto fija de 1:1 durante la colocación o la edición gráfica, y el tamaño final de colocación está determinado por el valor actual de la cuadrícula de ajuste del documento. 

  • Si un trenzado está asociado con hilos en varios lugares del diagrama de cableado del arnés (es decir, cuando se colocan varios objetos de trenzado con el mismo designador sobre diferentes hilos), al seleccionar un objeto se resaltarán todos los hilos asociados del grupo, y todos estos hilos se enumerarán en la región Twist Objects del panel Properties ().

  • Los parámetros Twists per Unit Length y Thickness de un trenzado se utilizan al sincronizar un proyecto de diseño de arnés con una herramienta MCAD mediante MCAD CoDesigner. Consulte la página Synchronizing a Harness Design Project para obtener más información.

Cables no conectados

Los extremos de cable no conectados se indican con un cuadrado sólido.

Un cable no conectado indicado
Un cable no conectado indicado

No debe dejarse un extremo de cable sin conectar. Si el diseño requiere un extremo de cable sin conectar, debe colocarse un objeto 'no connect' en el extremo (Place » No Connect).

Coloque un objeto 'no connect' en el extremo de un cable que deba permanecer sin conectar.
Coloque un objeto 'no connect' en el extremo de un cable que deba permanecer sin conectar.

Las propiedades de un objeto 'no connect' colocado (su ubicación y representación visual) pueden configurarse en el panel Properties cuando el objeto está seleccionado en el espacio de diseño.

El panel Properties cuando se selecciona un objeto 'no connect'
El panel Properties cuando se selecciona un objeto 'no connect'

Trabajo con múltiples hojas

Un diagrama completo de cableado de arnés puede definirse en varias hojas (con un diseño “plano”, donde todas las hojas existen en el mismo nivel), cada una representada por su propio documento *.WirDoc. La conectividad se crea directamente desde cualquier hoja hacia cualquier otra hoja mediante objetos de interrupción de cable (Place » Wire Break) con el mismo designador de cable.

Después de seleccionar el comando de colocación de la interrupción de cable, sitúe el objeto de modo que su punto activo eléctrico (el extremo sostenido por el cursor) toque el cable al que desea conectarse y, a continuación, haga clic o presione Enter para efectuar la colocación. Una interrupción de cable colocada hereda las propiedades (designador y color) del cable al que está conectada.

Seleccione una interrupción de cable en el espacio de diseño para modificarla en el panel Properties. Desde el panel, puede definir el designador del cable al que está conectada y su estilo: dirección (Left o Right) y color.

Sincronización de cables

Los cables de arnés conectados con una interrupción de cable se reconocen incluso si tienen distintos Design Item IDs. Además, se comparan todos los segmentos de cable con el mismo designador conectados por la misma interrupción de cable (número de pieza, comentario, color y todos los parámetros). Si se encuentra alguna diferencia, se informa de la violación Mismatched parameters in connected wire segments. También aparece una advertencia en el panel Properties del cable y de la interrupción de cable, indicando que se ha detectado un conflicto entre los parámetros. Haga clic en Synchronize dentro de la advertencia para abrir el cuadro de diálogo Conflict Wire Parameters, que le permite elegir qué parámetros usar para el segmento de cable.

Propiedades y parámetros del cable antes de la sincronización

Aparece una advertencia en el panel Properties que indica que existe un conflicto entre parámetros. Después de hacer clic en Synchronize en la advertencia, se abre el cuadro de diálogo Confirm Wire Parameters. Seleccione la opción deseada y luego haga clic en OK para realizar la sincronización.

La violación Mismatched parameters in connected wire segments en el cuadro de diálogo Project Options

Después de la sincronización, las propiedades de los segmentos de cable se han sincronizado. 

 
  • Tenga en cuenta que, al cambiar el color y el designador de una interrupción de cable, el color y el designador del cable al que está conectada la interrupción de cable cambian de forma correspondiente; y viceversa, al cambiar el color y el designador de un cable, el color y el designador de la interrupción de cable conectada a ese cable también cambian de forma correspondiente.

  • También puede cambiar las propiedades de una interrupción de cable mientras la coloca presionando Tab después de seleccionar el comando de colocación. Tenga en cuenta que, si se define un designador para la interrupción de cable antes de su colocación, el cable al que se conecte heredará el designador y el color de la interrupción de cable.

  • Si se define un color de borde para un cable al que está conectada una interrupción de cable, esta interrupción de cable también se mostrará con un borde de ese color. Además, el designador de la interrupción de cable se mostrará con el color del borde del cable conectado.

  • Las interrupciones de cable no tienen propiedades de fuente independientes; utilizan las propiedades Document Font del documento de diagrama de cableado de arnés en el que se colocan.

  • Las interrupciones de cable también pueden usarse para crear conectividad dentro de la misma hoja del diagrama de cableado de arnés. Por ejemplo, en lugar de colocar un cable de un pin de conector a otro, puede colocar un cable corto de arnés y una interrupción de cable en cada uno de esos pines ().

Colocación de un componente de cableado de arnés

Cuando está conectado a su Workspace, puede crear componentes con estructura y propiedades predefinidas según se requiera en el Workspace conectado y luego reutilizar esos componentes en sus diseños de arnés, colocándolos directamente en documentos de diagrama de cableado de arnés.

Consulte la página Creating a Harness Wiring Component para obtener más información.

Estos componentes (cada uno con un modelo de cableado de arnés asignado definido) se obtienen desde el panel Components panel. Cuando el documento de diagrama de cableado de arnés requerido sea el documento activo en el espacio de diseño, coloque un componente haciendo clic con el botón derecho en su entrada en el panel y seleccionando el comando Place <ComponentName> del menú contextual. El comportamiento al colocar un componente difiere según si el componente incluye un único objeto de cable o una estructura de cable (varios cables y/u objetos adicionales: cables, blindajes, etc.).

  • Single wire – al colocar un componente que incluye un único objeto de cable, entrará en el modo de colocación de cable de arnés. El cable que se coloca heredará las propiedades definidas durante la creación del componente. Consulte la sección Creating Connectivity in the Harness Wiring Diagram anterior para obtener más información sobre la colocación de cables de arnés.

  • Cable structure – al seleccionar el comando de colocación para un componente que incluye una estructura de cable, esa estructura de cable aparecerá unida al cursor exactamente como se definió durante la creación del componente. Haga clic en el lugar deseado del documento de diagrama de cableado de arnés para colocar el componente. Después, puede editar individualmente los objetos del componente; por ejemplo, para conectar los cables que componen el cable a los pines de los conectores del arnés.

Actualización del diagrama de cableado desde bibliotecas

Los siguientes objetos pueden actualizarse desde su biblioteca de Workspace de origen:

  • Componentes de arnés

  • Cavidades de componentes de arnés

  • Piezas asociadas con componentes de arnés

  • Cables

Cuando se selecciona un objeto, la información sobre el componente de Workspace vinculado puede encontrarse en el panel Properties (por ejemplo, la pestaña Associated Parts para las piezas asociadas de un componente de arnés).

Si hay disponible una revisión posterior del componente de Workspace, la entrada del estado de revisión lo reflejará usando el texto Out of date. En el nivel de objeto individual, el vínculo puede actualizarse a la revisión más reciente del componente de Workspace haciendo clic en el botón .

Un ejemplo de indicación de una revisión desactualizada de un componente de arnés
Un ejemplo de indicación de una revisión desactualizada de un componente de arnés

La función Update from Libraries (Tools » Update from Libraries) también puede usarse para actualizar componentes desactualizados vinculados a los objetos enumerados anteriormente. Tenga en cuenta que, para que un objeto se incluya en la actualización usando la función Update from Libraries, un componente asignado al objeto debe incluir un vínculo a un símbolo esquemático.

Anotación de objetos del diagrama de cableado de arnés

Use los comandos del menú Tools » Annotation para anotar los siguientes objetos en el documento de diagrama de cableado de arnés:

  • Componentes de arnés

  • Cables

  • Empalmes y derivaciones

  • Cables

  • Blindajes y blindajes con conexión

  • Torsiones

  • Objetos “sin conexión”

Anotar objetos en un documento de diagrama de cableado de arnés es similar a anotar componentes en un documento esquemático (*.SchDoc) de un proyecto de diseño de PCB. Use los siguientes enlaces para obtener más información sobre los comandos de anotación disponibles para un documento de diagrama de cableado de arnés:

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contenido