Inspección de los datos de fabricación con el editor CAM
De un vistazo
- Aprende a seleccionar, ejecutar, repetir y cancelar comandos en el editor CAM.
- Comprende cómo los modos CAM y NC muestran de forma diferente las imágenes de fabricación, los puntos de taladrado y las trayectorias de fresado.
- Descubre cómo gestionar la visibilidad de las capas, seleccionar la capa actual y acceder a los comandos de capa desde el panel CAMtastic.
El editor CAMtastic (CAM) de Altium Designer ofrece diversas herramientas, entre las que destacan las funciones básicas de visualización y edición de datos CAM. Una vez importados los archivos de imagen y taladrado, el editor CAM puede recibir instrucciones que determinen los tipos de capa y el apilado, tras lo cual se puede extraer una lista de redes y compararla con una lista de redes IPC generada por el software de diseño de PCB original. Estas listas de redes no solo incluyen componentes de orificio pasante, sino también vías ciegas y enterradas. El editor CAM también ofrece herramientas de comprobación de reglas de diseño, panelización y fresado NC (además de mecanizado).
Conceptos básicos de las acciones CAM
El entorno del editor CAM utiliza métodos para realizar acciones y procedimientos algo diferentes de aquellos a los que quizá esté acostumbrado.
Acción antes de selección
La forma de realizar acciones en el editor CAM puede parecer invertida a los usuarios nuevos acostumbrados a seleccionar objetos before indicar al programa qué hacer con ellos. Al igual que otras herramientas CAM, el editor CAM invierte este proceso: primero se elige la acción, después se seleccionan los objetos sobre los que se va a actuar y, por último, se da una orden de ejecución.
Si no está acostumbrado a trabajar de esta manera, puede apoyarse en un par de ayudas hasta familiarizarse con el proceso. En primer lugar, observe el cursor. Cuando aparece como una cruz sobre el espacio de trabajo de diseño, significa que no está en modo de selección (durante el modo de selección se muestra un cursor con un recuadro cuadrado). El hecho de que todos los botones de selección estén atenuados puede recordarle que aún no ha elegido ninguna acción; al menos, ninguna que requiera selecciones generales. La barra de estado, situada en la parte inferior de la ventana principal de edición, resulta especialmente útil durante los procesos de varios pasos cuando se pregunta por qué no ocurre nada; esta barra le indicará qué está esperando el editor CAM que haga.
Ejecución con el botón derecho
Primero se elige un comando y después se selecciona un conjunto de objetos. A continuación, el editor CAM espera una orden de ejecución. Esto le permite preparar cuidadosamente la selección en distintas capas y grupos de objetos. La forma básica de enviar la orden de ejecución es hacer clic con el botón derecho. Las indicaciones de Status Bar señalarán cuándo puede utilizarse el botón derecho de esta manera. También puede utilizar el método abreviado de teclado Shift+F9 para ejecutar la función actual una vez seleccionados todos los objetos necesarios.
Es posible que observe que, después de ejecutar una función, el cursor no vuelve a su estado inactivo. En su lugar, se mantiene el recuadro de selección y la barra de estado le indica que vuelva a seleccionar objetos. Esto ocurre cuando la opción Auto Repeat Functions está habilitada en la página CAM Editor - General del cuadro de diálogo Preferences.
En ocasiones, el botón derecho puede utilizarse para cancelar procesos en curso. Esto funciona cuando aún no se ha completado un paso obligatorio, como la selección de objetos. Sin embargo, la tecla Esc es una opción más segura para cancelar operaciones en general.
Modos de edición
El editor CAM admite dos modos de edición: CAM y NC (fresado). Estos modos se habilitan mediante los comandos correspondientes CAM Editor y NC Editor, disponibles al seleccionar View » CAM Editor o View » NC Editor en el menú principal. También puede establecer el modo de edición directamente en la lista desplegable disponible en el panel CAMtastic . Básicamente, estos modos se diferencian en la forma de mostrar los datos. El modo CAM Editor muestra las imágenes exactamente como se dibujarán o expondrán en la película fotográfica que se utilizará para fabricar la PCB. El modo NC Editor añade marcadores a los orificios de taladrado y a las trayectorias de fresado.
Una trayectoria de fresado mostrada en el modo NC Editor.
El CAM Editor siempre estará en uno de estos dos modos de edición. En el modo CAM Editor, las herramientas de fresado aparecerán atenuadas en los menús. Del mismo modo, cuando el modo NC Editor esté activo, las herramientas habituales de edición CAM estarán deshabilitadas. Cuando el modo CAM Editor esté activo, el panel CAMtastic le permitirá acceder rápidamente a los códigos D definidos en la lista de aperturas mediante una lista desplegable. Cuando el modo NC Editor esté activo, esta lista desplegable mostrará, en su lugar, el conjunto de herramientas de taladrado, fresado y mecanizado. Lo más importante es que el espacio de diseño se corresponderá con el modo de edición actual. El modo NC Editor indica los puntos de taladrado y las trayectorias de fresado con marcadores especiales: cada punto de taladrado se marca con una X, mientras que las trayectorias de fresado contienen puntos de penetración y retirada y, cuando es necesario, también marcadores de dirección. Estos marcadores de instrucciones son invisibles cuando se trabaja en el modo CAM Editor.
El panel CAMtastic
El panel, disponible siempre que haya un documento CAM activo, contiene la información principal de ese documento CAM, incluidas las capas, el código D o la herramienta actual, los ajustes de rejilla y unidades, y la posición absoluta del cursor en el espacio de diseño. También puede alternar entre las regiones Info, DRC, Nets y Steps del panel para consultar otra información específica del diseño.
La región Layers muestra todas las capas creadas o importadas y su estado de visibilidad. La capa actual tendrá una X blanca sobre su muestra de color asociada y también se indicará en la parte superior de la región. Puede hacer doble clic en el nombre de otra capa para convertirla en la capa actual.
Cuando hay capas presentes, hacer clic con el botón derecho en cualquier parte de esta región le permite acceder rápidamente a los comandos de capa, incluidas las opciones para bloquear, cambiar el nombre o añadir capas. Si ha creado un documento nuevo y desea empezar a añadir capas, utilice el comando Edit » Layers » Add para añadir la primera capa.
Puede resaltar cualquier capa de esta lista y después utilizar las teclas Up Arrow y Down Arrow del teclado para recorrer los datos CAM en el modo de una sola capa. La tecla Right Arrow hará visibles todas las capas, mientras que la tecla Left Arrow aislará la capa resaltada. Se pueden seleccionar varias capas mediante las funciones estándar Shift+Click y Ctrl+Click, lo que permite mostrar, ocultar o eliminar varias capas a la vez. Puede utilizar las teclas +/- y * del teclado numérico para recorrer todas las capas visibles o solo las capas de señal y de plano, respectivamente.
Se pueden eliminar capas desde el panel, pero esta acción es irreversible. El comando Undo del menú Edit no restaurará las capas eliminadas.
Puede alternar entre el panel CAMtastic y el documento CAM activo mediante el método abreviado de teclado Shift+F5. La tecla F4 alterna la visibilidad de todos los paneles flotantes.
Contenido y uso del panel CAMtastic
Funciones del panel
La lista desplegable de la parte superior del panel permite cambiar rápidamente entre los modos de editor CAM y editor NC. La sección situada justo debajo de este campo muestra todas las capas disponibles en el documento CAM actual (*.cam). Las capas se muestran en el mismo orden en que aparecen en el cuadro de diálogo Layers Table, al que se accede seleccionando Tables » Layers en el menú principal.
Para cada capa de la lista se indican el nombre y el número, junto con una opción para controlar su visibilidad (si está activada o desactivada). También hay un recuadro de color que muestra el color asignado actualmente a la capa. Al hacer clic en el color, se abre el cuadro de diálogo Change Layer Color , que ofrece una variedad de colores para elegir.
En la parte superior de la lista de capas se muestra el nombre de la capa actual. La capa actual es la que se utilizará para colocar cualquier objeto nuevo, como líneas, polilíneas y puntos de taladrado. La capa actual también se distingue por una cruz blanca en el recuadro de color de su entrada. Para convertir cualquier capa en la capa actual, haga doble clic en su entrada de la lista.
Al hacer clic con el botón derecho en una entrada de capa individual de la lista, se abre un menú con los siguientes comandos relacionados con las capas:
- Type - utilice este comando para mostrar el tipo de capa que se le ha asignado en el cuadro de diálogo Layers Table.
- ON - permite alternar la visibilidad de la capa. Cuando la capa está activada (es decir, es visible en el espacio de diseño), aparece una marca de verificación a la izquierda del comando y se activa la opción de visibilidad correspondiente a la capa.
- Current - permite establecer la capa seleccionada como capa actual. Aparece una marca de verificación a la izquierda del comando, el nombre de la capa aparece en el campo Current Layer (en la parte superior de la lista de capas) y se muestra una cruz blanca en el recuadro de color asociado a la capa.
- Lock / Lock Selected - permite bloquear las capas seleccionadas para impedir que se dibuje en ellas. Cuando está activado, aparece una marca de verificación a la izquierda del comando.
- RESCan / RESCan Selected - permite comparar, para la capa seleccionada, las fechas de los datos (Gerber/ODB ++ Feature) existentes en el documento CAM activo y de los últimos datos generados a partir del mismo documento PCB de origen. Si los últimos datos generados son más recientes que los existentes, se habilita el comando Reload .
- Reload / Reload Selected - permite regenerar los datos de la capa seleccionada en la que el proceso Rescan haya detectado cambios. Todos los cambios de la capa se incorporarán al documento CAM activo para volver a sincronizarlo con el documento PCB de origen.
- All On - permite hacer visibles (activar) todas las capas en el espacio de diseño.
- All Off - permite ocultar (desactivar) todas las capas en el espacio de diseño.
- Isolate - permite ocultar (desactivar) todas las capas en el espacio de diseño, excepto la capa elegida, que permanece visible (activada).
- Scroll Up - permite recorrer hacia arriba las capas de la lista, empezando por la capa seleccionada actualmente. A medida que se selecciona cada capa, esta se convierte en la capa actual y todas las demás se ocultan en el espacio de diseño.
- Scroll Down - permite recorrer hacia abajo las capas de la lista, empezando por la capa seleccionada actualmente. A medida que se selecciona cada capa, esta se convierte en la capa actual y todas las demás se ocultan en el espacio de diseño.
- Compare - permite abrir el cuadro de diálogo Compare Layers, donde puede comparar dos capas, cambiar la tolerancia de las capas y modificar la resolución de la capa de mapa.
- Compress Layers - permite combinar en una sola capa las capas que tengan el mismo tipo especificado en la tabla de capas. Esto solo se aplica a las capas de las que debe haber una sola por diseño (por ejemplo, superior, inferior, máscara, serigrafía, taladrado superior y taladrado inferior).
- Rename - permite cambiar el nombre de la capa seleccionada actualmente. Tras ejecutar el comando, aparece el cuadro de diálogo Enter Value. Escriba un nombre nuevo para la capa (solo en minúsculas) y haga clic en OK: el nombre nuevo sustituye al anterior.
-
Add Layer - permite crear una capa nueva y añadirla a la lista. Tras ejecutar el comando, aparece el cuadro de diálogo Enter Value. Introduzca un nombre para la capa nueva (solo en minúsculas) y haga clic en OK: la capa se añade al final de la lista.
Si se seleccionan varias capas en la lista, la entrada Tipo del menú mostrará Selección múltiple y los siguientes comandos no estarán disponibles: Activar, Actual, Bloquear, Desplazar hacia arriba, Desplazar hacia abajo y Añadir capa. - Turn On / Turn On Selected - permite hacer visibles (activar) todas las capas seleccionadas en el espacio de diseño. Este comando solo estará disponible si al menos una de las capas seleccionadas está desactivada.
- Turn Off / Turn Off Selected - permite ocultar (desactivar) todas las capas seleccionadas en el espacio de diseño. Este comando solo estará disponible si al menos una de las capas seleccionadas está activada.
- Lock / Lock Selected - permite bloquear las capas seleccionadas para impedir que se dibuje en ellas. Una vez bloqueada la capa, se indica mediante una marca de verificación a la derecha del comando. Para desbloquear las capas, vuelva a hacer clic en las capas bloqueadas.
- Delete / Delete Selected - permite eliminar las capas seleccionadas del documento CAM.
Pestaña Información
La pestaña Info
La pestaña Info muestra información después de ejecutar cualquiera de los comandos de consulta (Objeto, Grupo, Red, Anillo anular mínimo), disponibles en el menú Analysis .
Pestaña DRC
La pestaña DRC
La pestaña DRC enumera las infracciones que existen después de ejecutar una comprobación de reglas de diseño (DRC) en el documento actual. Cuando existen infracciones, se muestra una carpeta de nivel superior para la comprobación de diseño correspondiente y, debajo, subcarpetas para cada uno de los objetos que presentan infracciones. Al hacer clic en una subcarpeta, los objetos infractores se seleccionan, se amplían y se centran en la ventana del editor de diseño.
Si el error de DRC se puede corregir mediante la función de corrección automática, puede hacer clic con el botón derecho en la subcarpeta del error y seleccionar Corregir error de DRC en el menú emergente.
Pestaña Redes
La pestaña Nets
La pestaña Nets muestra las redes incluidas en el diseño después de extraer la lista de redes mediante el comando Tools » Netlist » Extract. Para cada entrada, también se indica la longitud total de la red. Al hacer clic en la entrada de una red, todos los objetos asociados a ella se seleccionan, se amplían y se centran en la ventana del editor de diseño.
Pestaña Pasos
La pestaña Steps
La pestaña Steps muestra los pasos ODB definidos actualmente para el documento. El nombre del paso actual aparece en la parte superior de la pestaña. Al hacer doble clic en la entrada de un paso, este se convierte en el paso actual.
Haga clic con el botón derecho en la entrada de un paso de la pestaña para acceder a un menú emergente con los siguientes comandos:
- Current - permite establecer el paso seleccionado como paso actual. Aparecerá una marca de verificación a la izquierda de la entrada del comando.
- Delete - permite eliminar el paso seleccionado del documento de diseño. No se puede eliminar el paso actual ni un paso que se haya insertado en otro.
- Rename - permite cambiar el nombre del paso seleccionado. Al ejecutar el comando, aparecerá el cuadro de diálogo Enter Value. Introduzca el nuevo nombre del paso (solo en minúsculas) y haga clic en OK: el nuevo nombre sustituirá todas las apariciones del nombre actual.
-
Add Insert - permite insertar un paso dentro de otro. Aparecerá el cuadro de diálogo Add Insert to ODB Step. Utilice este cuadro de diálogo para seleccionar el paso que desea insertar (de la lista de pasos disponibles) y definir la ubicación, el tamaño de la matriz y la orientación. Al hacer clic en OK, la inserción se añadirá como subpaso del paso principal especificado en la pestaña, con el formato: n: NombreDelPaso (Filas, Columnas), donde [n] es el siguiente número disponible asignado al paso insertado, empezando por 1.
En la ventana del editor de diseño, el paso insertado aparecerá como un conjunto de rectángulos blancos vacíos, cuya cantidad viene determinada por el tamaño de la matriz elegido en el cuadro de diálogo Add Insert to ODB Step. También se muestran cruces blancas, una por cada paso de la matriz, con la cruz inferior izquierda situada en las coordenadas del punto base elegido, también definidas en el cuadro de diálogo. Estas cruces definen dónde se situarán los objetos del paso insertado si decide descomponer la matriz de pasos. El comando para descomponer la matriz de pasos se encuentra haciendo clic con el botón derecho en la entrada del subpaso en la pestaña. El menú emergente que aparece también contiene comandos para modificar y eliminar la matriz de pasos insertada. - Add Step - permite crear un nuevo paso. Aparecerá el cuadro de diálogo Enter Value. Introduzca un nombre para el nuevo paso (solo en minúsculas) y haga clic en OK: el paso se añadirá al final de la lista y se establecerá como paso actual.
-
Move Objects - permite mover objetos de un paso a otro. Este comando solo está disponible si el paso de origen del movimiento es el paso actual.
Al ejecutar el comando, el cursor cambiará a un cuadrado pequeño y se le pedirá que seleccione los objetos que desea mover. Sitúe el cursor sobre cada objeto y haga clic para seleccionarlo, o utilice una de las numerosas herramientas de selección disponibles.
Una vez realizada la selección, al hacer clic con el botón derecho se abrirá el cuadro de diálogo New Step for Objects. Seleccione el paso al que desea mover los objetos y haga clic en OK: los objetos se eliminarán del paso actual y se añadirán al paso de destino. - Copy Objects - permite copiar objetos de un paso a otro. Este comando solo está disponible si el paso de origen de la copia es el paso actual. Este comando es similar al comando Mover objetos, con la única diferencia de que los objetos seleccionados no se eliminan del paso de origen, sino que simplemente se copian.
- Add Venting - permite añadir un patrón de venteo alrededor de las PCB panelizadas en un panel. Este comando solo está disponible si las PCB se panelizaron mediante el comando Tools » Panelize PCB o al cargar datos ODB++ que contienen un panel.
- Remove Venting - permite eliminar cualquier patrón de venteo de una PCB panelizada. Se utilizaría, por ejemplo, si los contornos de la PCB se han modificado después de añadir el venteo.
- Refresh Inserts - permite actualizar las inserciones disponibles para reflejar los cambios.
La zona inferior del panel contiene los siguientes campos:
- 1 - Según esté utilizando el modo Editor CAM o Editor NC, este control permite seleccionar el código D o la herramienta de taladrado actuales, respectivamente.
- 2 - Este control permite seleccionar el modo actual de ajuste a objetos.
- 3 - Este control permite cambiar las unidades actuales del espacio de diseño. Elija entre milímetros o pulgadas.
- 4 - Este campo del panel muestra las coordenadas X-Y de la posición del cursor en el espacio de diseño principal. Utiliza las unidades seleccionadas en el control 3.
Información adicional sobre los pasos
- Cada paso ODB definido en el diseño contiene la misma lista de capas. La diferencia entre los pasos radica en los objetos que contienen en esas capas.
- Deben definirse dos o más pasos para el documento actual antes de poder insertar un paso en otro.
- A diferencia de una matriz normal de repetición por pasos (Step & Repeat), cuando se inserta un paso en otro, la matriz resultante consta únicamente de entradas representadas por sus contornos. La entrada inferior izquierda no muestra todos los objetos del paso. Si hace clic en la entrada de nivel superior del paso insertado (no en su entrada bajo el paso principal definido), los objetos contenidos en el paso insertado se mostrarán en la ubicación marcada por la cruz blanca inferior izquierda. No se mostrarán el paso principal ni los demás elementos de la matriz del paso insertado.
-
La pestaña Steps se actualiza automáticamente cada vez que hace clic en OK en el cuadro de diálogo Steps Table, que se abre al seleccionar Tables » Steps en el menú principal.
El código D, el modo de ajuste a objetos y las unidades del espacio de diseño se pueden cambiar durante la colocación de trazos (por ejemplo, líneas, polilíneas, rectángulos, etc.). Por ejemplo, puede colocar una línea con segmentos dibujados utilizando distintos códigos D, todo ello en la misma sesión de colocación. Puede dibujar una polilínea, cambiar el código D durante su colocación y, cuando finalice la colocación, el código D actual se aplicará a toda la polilínea.
Notas
- De forma predeterminada, los colores de trazado y flash asignados a una capa son idénticos. Al cambiar el color asignado a la capa en el panel, se actualizarán tanto el color de trazado como el de flash en el cuadro de diálogo Layers Table. Si desea cambiar los colores de trazado o flash por separado, deberá editar sus respectivas entradas en el cuadro de diálogo. Al editar los colores mediante el cuadro de diálogo, solo la asignación del color de trazado se reflejará en el panel.
- Seleccione una entrada en la lista de capas y pulse la tecla Left Arrow para ocultar todas las capas excepto esa. Seleccione una entrada en la lista de capas y pulse la tecla Right Arrow para mostrar todas las capas.
- Los comandos basados en volver a explorar y volver a cargar solo estarán disponibles si la opción Reset auto-load options after generation se habilita antes de la generación inicial de los archivos de salida Gerber/ODB++. Esta opción se encuentra en el cuadro de diálogo Output Job Options, al que se accede desde el menú Tools cuando el archivo Output Job asociado (*.OutJob) está activo. Al habilitar esta opción, se evita que los datos de salida se carguen en un nuevo documento CAM cuando se generen posteriormente a partir del documento PCB de origen.
- Tras extraer la lista de conexiones de la información Gerber contenida en el documento actual, las redes aparecen en la pestaña Nets del panel con nombres predeterminados. Estos nombres tienen el formato $Netn (donde n es el siguiente número entero asignado según el orden de extracción). Si ha importado una lista de conexiones en formato IPC-D-356, generada a partir del documento PCB, puede cambiar los nombres de las redes por los nombres más descriptivos que se asignaron en el diseño PCB original. Para ello, seleccione Tools » Netlist » Rename Nets en los menús principales.
- Puede seleccionar varias redes en la pestaña Nets; todas ellas quedarán seleccionadas en la ventana del editor de diseño.
- Al examinar errores de DRC, si selecciona una entrada en la pestaña DRC, solo se mostrarán las capas en las que se encuentren los objetos que infringen las reglas. Todas las demás capas se ocultarán. Al examinar redes, las capas pertinentes deben estar visibles de antemano; de lo contrario, es posible que no vea nada.
