Compatibilidad con panelización
De un vistazo
- Aprende cómo el tamaño del panel, la separación y la opción Calculate determinan cuántas placas caben en un panel.
- Comprende los métodos de separación Offset y Gap, y obtén una vista previa de la distribución antes de aplicarla.
- Descubre cómo Step & Repeat reduce la duplicación de datos y cómo actualizar las matrices después de la panelización.
Tradicionalmente, los ingenieros de diseño han utilizado las herramientas CAM únicamente para la verificación, revisando visualmente sus archivos de salida Gerber y de taladrado antes de enviarlos al fabricante. Los diseñadores experimentados reconocen la importancia del trabajo posterior al diseño que debe realizarse para recibir placas funcionales de forma fiable. Este trabajo exige una comunicación precisa y abierta con los equipos de fabricación y ensamblaje.
El editor CAM de Altium Designer proporciona a los diseñadores todo lo necesario para facilitar esta comunicación, incluidas no solo herramientas de verificación fiables, sino también el conjunto completo de herramientas CAM disponible para los fabricantes de placas y las empresas de ensamblaje. Esto incluye herramientas para panelizar la placa y definir los bordes de fresado.
Muchos diseñadores de placas se preguntarán por qué se incluyen estas herramientas. Nuestra respuesta es que nos resulta difícil determinar dónde termina su trabajo como diseñador. Algunos se conformarán con revisar sus diseños y dejar que el fabricante se encargue de aprovechar al máximo la superficie de sus placas, siempre que reciban lo que han pedido. Otros quizá quieran implicarse más. Por ejemplo, puede que deseen paneles que se adapten lo mejor posible no solo al fabricante, sino también a la empresa de ensamblaje.
Panelización
El cuadro de diálogo Panelization
Un panel se crea mediante un proceso automatizado en el que se determina su tamaño y cómo se distribuirán las múltiples copias de los datos de la placa dentro de él. También se puede indicar cómo se almacenarán los datos. Recomendamos encarecidamente utilizar uno de los códigos de desplazamiento disponibles, ya que mantienen los archivos pequeños y manejables. La información de imagen y taladrado solo se definirá una vez en el panel, seguida de un conjunto de instrucciones de repetición.
Herramientas de posicionamiento
La panelización sigue el procedimiento general de edición del editor CAM. Para empezar, puede ejecutar el comando Tools » Panelize PCB, seleccionar los objetos que desea incluir en el panel (o utilizar los métodos abreviados de teclado E, S, L para seleccionarlo todo) y, a continuación, confirmar el comando haciendo clic con el botón derecho o utilizando el método abreviado de teclado Shift+9. Esta secuencia abrirá el cuadro de diálogo Panelization.
El cuadro de diálogo Panelization
El cuadro de diálogo Panelization que aparece inicialmente contiene información calculada a partir de las dimensiones de la placa que está panelizando (definida por los objetos seleccionados). En la parte superior del cuadro de diálogo, los campos Image Size muestran las dimensiones horizontal y vertical de los objetos seleccionados. A continuación, se muestran los valores de Panel Size, Spacing y Parts Count.
Todos estos campos funcionan de forma dinámica. Si la opción Calculate está activada, se mostrará el número máximo de columnas y filas que caben para los valores de tamaño de panel y separación que introduzca. Puede aumentar el número de columnas o filas del panel acercando las placas entre sí o reduciendo el margen alrededor de los bordes del panel. También puede incluir más placas aumentando el tamaño del panel.
Al desactivar la opción Calculate, puede trabajar a la inversa: introducir el número de columnas y filas que desea colocar en el panel y ver el tamaño de panel resultante según los valores introducidos en los campos Parts Count y Spacing . Dado que el tamaño de panel resultante tendrá valores irregulares, probablemente este método solo se utilice para determinar los requisitos mínimos del panel. Después, convendrá volver a activar la opción Calculate e introducir un tamaño de panel compatible con sus empresas de fabricación y ensamblaje.
La matriz de placas puede centrarse en el panel o situarse en la esquina inferior izquierda.
Al hacer clic en el botón Show Preview se abrirá una ventana de vista previa dentro del cuadro de diálogo, donde podrá ver cómo aparecerán los paneles en la hoja. Los cambios en la separación de los paneles se actualizarán en la ventana de vista previa, lo que le permitirá obtener la separación necesaria antes de continuar.
Una vez definidas todas las opciones según sus necesidades, al hacer clic en OK se realizará la panelización y la matriz de paneles aparecerá en el espacio de trabajo principal de diseño. La matriz comienza con los objetos seleccionados originalmente y se extiende hacia arriba y hacia la izquierda.
Pasos en la dirección correcta
Es lógico que, si coloca ocho copias completas de su placa en un panel, el archivo resultante sea al menos ocho veces más grande. Esto ocurre siempre que los datos se exploded, es decir, se reescriben por completo en el archivo de descripción para cada nueva ubicación. Normalmente, la verdadera carga de un archivo de este tipo no se debe a su tamaño, sino a que cada actualización de la pantalla tarda ocho veces más.
El CAM Editor ofrece dos tipos de códigos de desplazamiento para evitar que los archivos alcancen tamaños inmanejables al panelizar: los comandos tradicionales Step & Repeat y ODB++ Steps.
Step & Repeat
Cuando la opción Use Step & Repeat está activada en el cuadro de diálogo Panelization, los datos seleccionados previamente se desplazan a la esquina inferior izquierda del panel. Todas las demás secciones del panel aparecen de forma muy similar a como se mostraban en la vista previa: como recuadros vacíos que indican las dimensiones vertical y horizontal de los datos copiados. Estos recuadros aparecen en todas las capas que contienen información Step & Repeat.
Dado que los datos almacenados en cada repetición quedan fijados en el momento de la panelización, es mejor posponer el uso de códigos Step & Repeat hasta tener la certeza absoluta de que los datos originales no van a cambiar. Este es, por supuesto, el escenario ideal, ya que la panelización suele realizarse una vez completada la verificación. Pero ¿qué ocurre si descubre que debe realizar pequeños cambios después de haber panelizado la placa?
Es posible editar los datos Step & Repeat , aunque no resulta sencillo. Se pueden añadir nuevos flashes, trazos o textos a los datos visibles en la sección inferior izquierda del panel. Estos objetos adicionales se pueden añadir después a las secciones restantes (repetidas) del panel mediante el comando Edit » Step/Repeat » Add Objects. Tras ejecutar el comando, el cursor cambiará a un cuadrado y se activará el modo de adición de objetos. El procedimiento consiste en realizar la siguiente secuencia de acciones:
- Haga clic en los objetos que desee añadir para seleccionarlos. Si hace clic en un espacio sin objetos, podrá arrastrar un área de selección para incluir varios objetos. La selección es acumulativa.
- Una vez seleccionados todos los objetos necesarios, haga clic con el botón derecho.
- Ahora seleccione la matriz Step & Repeat a la que desee añadir los objetos seleccionados. Basta con situar el cursor sobre cualquier objeto incluido en la selección de la matriz, dentro de su marco original (inferior izquierdo), y hacer clic. El tamaño de los marcos de la matriz se ajustará para incluir tanto los objetos añadidos como los originales. Solo el marco original (inferior izquierdo) de la matriz contendrá los objetos visibles; todos los demás marcos permanecerán vacíos.
- Siga seleccionando objetos para añadirlos a otras matrices Step & Repeat, o haga clic con el botón derecho o pulse Esc para salir.
Es posible que la adición de objetos provoque la superposición de los marcos de la matriz. Puede modificar la distancia (o separación) entre los marcos mediante el cuadro de diálogo Modify Step_Repeat. Para ello, seleccione el comando Edit » Step/Repeat » Modify en los menús principales. Tras ejecutar el comando, el cursor cambiará a un cuadrado y se activará el modo de modificación de matrices. Para modificar una matriz, realice la siguiente secuencia de acciones:
-
Seleccione la matriz Step & Repeat que desee modificar. Basta con situar el cursor sobre cualquier objeto incluido en la selección de la matriz, dentro de su marco original (inferior izquierdo), y hacer clic: aparecerá el cuadro de diálogo Modify Step_Repeat. Utilice este cuadro de diálogo para modificar el número de filas y columnas de la matriz, así como su espaciado, mediante uno de estos dos métodos:
- Distance - este método permite especificar el espaciado entre filas y columnas en relación con el tamaño de la imagen (es decir, la selección de objetos). Al especificar un valor en un campo Distance , debe sumar la separación necesaria al valor del campo Image Size e introducir el valor resultante como distancia. Por ejemplo, si el tamaño de la imagen es de 0,5 pulgadas y necesita una separación de 200 mil, deberá introducir 0.7 en el campo Distance correspondiente.
- Gap - este método permite especificar directamente la separación entre filas y columnas, por lo que no depende del tamaño de la imagen. Por ejemplo, si necesita una separación de 200 mil, deberá introducir 0.2 en el campo Gap correspondiente.
- Tras realizar las modificaciones necesarias en la matriz, haga clic en OK: la matriz Step & Repeat cambiará de acuerdo con las modificaciones especificadas.
- Siga seleccionando y modificando otras matrices Step & Repeat, o haga clic con el botón derecho o pulse Esc para salir.
La eliminación es algo más compleja e implica quitar objetos de las secciones repetidas (no visibles) del panel mediante el comando Edit » Step/Repeat » Remove Objects antes de eliminar esos mismos objetos de la sección visible del panel mediante el comando Edit » Clear. Tras ejecutar el comando Edit » Step/Repeat » Remove Objects, el cursor cambiará a un cuadrado y se activará el modo de eliminación de objetos. Para quitar objetos, realice la siguiente secuencia de acciones:
- Seleccione los objetos que desee quitar dentro del marco original (inferior izquierdo) de la matriz Step & Repeat de destino. Para ello, basta con situar el cursor sobre un objeto existente que desee incluir en la selección y hacer clic. También puede hacer clic en un espacio sin objetos y arrastrar un área de selección para incluir varios objetos. La selección es acumulativa.
- Una vez seleccionados todos los objetos necesarios, haga clic con el botón derecho. Los objetos se quitarán de la matriz y el tamaño de sus marcos se ajustará en función de los objetos restantes.
- Siga seleccionando objetos para quitarlos de otras matrices Step & Repeat, o haga clic con el botón derecho o pulse Esc para salir.
Como es necesario seleccionar el mismo grupo de objetos dos veces, para dos comandos distintos, la probabilidad de error es elevada; sin embargo, el editor CAM permite volver a seleccionar una selección anterior. Esta dificultad se agrava porque los recuadros Step & Repeat de la matriz permanecen vacíos y no ofrecen ninguna pista sobre su contenido hasta que los datos se descomponen en primitivas mediante el comando Edit » Step/Repeat » Explode. Tras ejecutar el comando, el cursor cambiará a un cuadrado y se le pedirá que seleccione la matriz Step & Repeat que desee descomponer. Basta con situar el cursor sobre cualquier objeto incluido en la selección de la matriz, dentro de su marco original (inferior izquierdo), y hacer clic. Todos los marcos de la matriz se rellenarán con información copiada del original y se eliminarán los bordes de los marcos. Siga descomponiendo otras matrices Step & Repeat, o haga clic con el botón derecho o pulse Esc para salir.
Los pasos de ODB++
ODB++ resuelven los problemas que presentan los códigos Step & Repeat. Cada paso que cree se convierte en una nueva columna correspondiente a las filas de las capas actuales. Cuantos más pasos añada, mayor será la matriz en la que se pueden almacenar datos. Un paso puede insertarse una o varias veces dentro de otro, que es exactamente lo que sucede al panelizar con la opción Create ODB++ Step activada. Al utilizar la opción Create ODB++ Step, se crean dos pasos nuevos, además del paso predeterminado para el espacio de diseño (cam_work):
- uno para los datos seleccionados para la panelización (campcb)
-
uno para el propio panel (campanel).
Puede ver el contenido de cada paso haciendo doble clic en su nombre en la pestaña Steps del panel CAM.
El paso que contiene los datos seleccionados se inserta automáticamente como un subpaso del paso del panel y aparece con el formato:
[n]: NombreDelPaso (Filas, Columnas),
donde [n] es el siguiente número disponible asignado al paso insertado, a partir de 1, y Rows y Columns se toman de la región Parts Count del cuadro de diálogo Panelization.
Al visualizar el contenido del paso del panel en el espacio de diseño, el paso insertado (de datos) aparecerá como una matriz de Filas x Columnas de rectángulos blancos vacíos. A diferencia de una matriz Step & Repeat , los datos de los objetos no son visibles en ninguna de las secciones de la matriz. Se muestra una cruz blanca para cada instancia del paso insertado, que define dónde se insertará el contenido de los datos si decide explorar la matriz de pasos.
Antes de terminar su trabajo, haga clic con el botón derecho en el paso del panel y seleccione Refresh Inserts. Esto garantiza que los pasos insertados en el panel reflejen el estado actual de los datos de origen y que cualquier modificación realizada después de la panelización se refleje en el panel terminado.
Para acceder al cuadro de diálogo Steps Table, donde puede consultar la información de los pasos ODB++ del documento actual, seleccione el comando Tables » Steps en los menús principales. Al hacer clic en OK en el cuadro de diálogo Steps Table, se actualizará la pestaña Steps del panel CAMtastic . Desde esta pestaña puede añadir o modificar pasos haciendo clic con el botón derecho y seleccionando el comando correspondiente en el menú contextual. El cuadro de diálogo Steps Table aparecerá automáticamente al importar archivos ODB++ al editor CAMtastic.
Estrategias adicionales de panelización
Las herramientas automáticas pueden ayudarle a maximizar el número de placas idénticas en el panel, pero ¿qué ocurre si los requisitos de su panel son más complejos? ¿Cómo puede añadir cupones de taladrado u orificios de fijación al panel? ¿Y si desea repetir y voltear sus datos para crear un panel que sea igual al darle la vuelta, de modo que pueda montar componentes en ambas caras pasando el panel dos veces por la misma máquina de colocación de componentes? ¿O si desea optimizar el espacio del panel distribuyendo distintas placas en un mismo panel?
Todos estos requisitos pueden satisfacerse mediante el uso de pasos ODB++ en CAM Editor. El punto de partida es la rutina de panelización automática, ya que es la única forma de crear el contorno de un panel utilizando la opción Create ODB++ Step en lugar de la opción Use Step & Repeat.
Inserción de pasos
Los cuadros de diálogo Enter Value y Add Insert to ODB Step
Puede insertar pasos adicionales junto a la matriz de placas del panel. Por ejemplo, un fabricante de placas puede colocar un cupón de taladrado en uno de los bordes separables para comprobar visualmente los tamaños de orificio previstos frente a los de las placas fabricadas. Los orificios de fijación, que se utilizan para sujetar el panel mientras se taladran y fresan sus capas, pueden ser necesarios en otras zonas del panel, en lugar de dentro de las instancias de las placas.
En primer lugar, debe crear un paso nuevo. Para ello, utilice el comando Add Step, disponible en el menú contextual de la pestaña Steps del panel CAM. El nuevo paso tiene las mismas capas, pero todas estarán vacías. Puede copiar o mover datos entre pasos mediante este mismo menú contextual. También puede colocar objetos nuevos en las capas existentes cuando el nuevo paso esté activo; estos objetos solo existirán en ese paso.
Por ejemplo, para crear un cupón de taladrado, puede crear un paso nuevo y, a continuación, colocar en fila, en la capa de taladrado, una impresión de cada una de las herramientas utilizadas en el diseño. En la capa de serigrafía superior, puede colocar texto u otras marcas de identificación para cada diámetro de taladro.
También debe dibujar una polilínea cerrada alrededor de los datos en la capa que haya designado como de tipo Border en la tabla de capas, seleccionando Tables » Layers en el menú principal. Esta se utilizará para generar un profile para ODB++, que es un archivo que permite insertar pasos unos dentro de otros sin que los patrones de ventilación invadan sus límites.
Puede crear otro paso para cada cupón u objeto que necesite añadir al panel. Con el paso del panel activo, puede insertar cada uno de ellos en una posición definida del paso principal del panel, como campanel. Para ello, utilice el comando Add Insert del menú contextual. Si aplicó un patrón de ventilación al crear este panel, debe eliminarlo y volver a aplicarlo. Al hacerlo, el patrón de ventilación respetará el contorno de cada paso.
Repetición y volteo

La panelización por repetición y volteo es una técnica que agiliza los procesos de las empresas de ensamblaje. Normalmente, las placas con componentes en las caras superior e inferior requieren dos máquinas de colocación de componentes: una para los componentes de la cara superior del panel y otra para los de la cara inferior. Sin embargo, si las caras superior e inferior del panel fueran idénticas al darle la vuelta, el panel podría pasar dos veces por la misma máquina de ensamblaje.
Es importante distinguir entre la cara superior de la placa y la cara superior del panel, ya que esta técnica requiere que las placas del lado derecho del panel sean iguales a las del lado izquierdo, pero volteadas. También requiere que el apilado de tipos de capa sea simétrico. La mitad de la cara superior del panel incluirá las imágenes de la cara superior de la placa y la otra mitad incluirá las imágenes de la cara inferior en espejo.
Para conseguirlo en CAM Editor, primero debe copiar todos los datos de la placa a un paso nuevo. Puede utilizar la función Swap Layers Data seleccionando Edit » Layers » Swap Layers Data en el menú principal para determinar dónde se colocarán los datos de las capas volteadas. Como resultado, la capa superior contendrá imágenes tanto de la capa superior como de la inferior, pero estas imágenes permanecerán en pasos separados.
Si aún no ha creado un panel a partir del diseño original, puede hacerlo ahora, asegurándose de que haya un número par de columnas o filas centradas en el panel. Haga clic en el signo más junto al paso campanel generado y, a continuación, haga clic con el botón derecho en el paso insertado para modificarlo. Cambie el valor de filas o columnas para que desaparezca la mitad de las placas. Ahora inserte el nuevo paso que ha creado y panelícelo de forma idéntica, pero utilizando un punto base calculado que sitúe la nueva matriz en la misma posición que los pasos que ha eliminado anteriormente. Asegúrese de que la opción Mirror esté activada para este paso.
El cuadro de diálogo Modify Insert in ODB Step
Distintas placas en un mismo panel
El volteo de placas en un panel es, en realidad, una aplicación muy limitada de la capacidad de los pasos ODB. Las placas se pueden voltear porque una misma capa puede contener datos diferentes en cada uno de sus pasos, que después pueden colocarse uno junto a otro en el mismo espacio de diseño. Esta flexibilidad plantea una pregunta: ¿por qué debe un panel contener una matriz de placas idénticas? La respuesta es que no existe tal restricción en CAM Editor.
Los motivos para incluir distintas placas en un mismo panel son variados. A un fabricante le interesa aprovechar al máximo la superficie del panel, pero cuanto mayor sea la placa, más difícil resulta. Las placas pequeñas, aunque procedan de un origen distinto, podrían ocupar el espacio disponible y reducir los costes de fabricación. Por otro lado, un mismo producto puede constar de varias placas que el diseñador prefiera fabricar juntas en un único panel.
Por supuesto, existen ciertas restricciones. Solo se pueden panelizar placas que compartan el mismo apilado de capas de señal y planos internos. También requieren conjuntos de capas de taladrado compatibles.
El comportamiento predeterminado de CAM Editor consiste en crear nuevas capas al cargar nuevas imágenes o archivos de taladrado. Este método no es suficiente para panelizar distintas placas juntas, porque los datos de las distintas placas deben estar en la misma capa, pero en pasos diferentes. Para facilitarlo, hay una opción disponible en la página CAM Editor - Import/Export del cuadro de diálogo Preferences, que permite importar archivos Gerber y de taladrado adicionales a las capas existentes.
Con esta opción habilitada, aparecerá un cuadro de diálogo de asignación cada vez que importe archivos de datos Gerber, de taladrado o IPC adicionales después de haber importado ya capas de ese tipo.
El cuadro de diálogo Map Layers to Import to Existing Layers
El cuadro de diálogo Maps Layers to Import to Existing Layers contiene los archivos nuevos a la izquierda y las capas existentes a la derecha. Según las extensiones y Layer Types Detection Template, al que se accede seleccionando Tables » Layer Type Detection en el menú principal, el editor CAM propondrá correspondencias, pero puede ajustarlas según sus necesidades. Los archivos que no desee asignar a capas existentes pueden configurarse para crear una nueva capa o excluirse por completo del proceso de importación.
Es necesario crear un nuevo paso ODB y establecerlo como actual antes de continuar con este proceso de asignación. De lo contrario, todos los datos de las capas quedarían superpuestos, sin posibilidad de separar los datos de una placa de los de las demás.
Relleno de equilibrado
El cuadro de diálogo Venting y Edit Pattern - Venting
Puede añadir un patrón de relleno de equilibrado a las partes no utilizadas del panel, lo que puede ayudar a distribuir uniformemente el agente de ataque químico por todo el panel. La panelización automática del editor CAM rellenará todo el espacio entre el borde del panel y las instancias de las placas con el patrón de relleno de equilibrado que elija.
Este patrón puede ser de tipo ráster, vectorial, sólido o basado en formas. Puede elegir entre opciones de formas genéricas con tamaños definidos por el usuario, o seleccionar un DCode existente como base para el patrón de relleno de equilibrado. Este patrón se aplicará únicamente a las capas de señal y de plano (definidas en la columna Layers Table in the Types ).
Si creó un relleno de equilibrado al panelizar los datos originalmente y después añadió pasos ODB++, como cupones de prueba, orificios de utillaje o incluso placas volteadas o alternativas, lo mejor es actualizar el patrón de relleno de equilibrado. Para ello, elimine el relleno y vuelva a añadirlo. Los comandos correspondientes aparecerán al hacer clic con el botón derecho en la entrada del paso del panel (campanel), que se encuentra en la pestaña Steps del panel CAM. Recuerde establecer el paso del panel como paso actual para que estos comandos estén activos.
Para añadir un patrón de relleno de equilibrado a la PCB panelizada actual, seleccione el comando Tools » Venting en los menús principales. El uso de este comando dependerá de si conservó o no la capa vent_border al panelizar la PCB.
-
With a vent_border layer present – tras ejecutar el comando, aparecerá el cuadro de diálogo Venting . De forma predeterminada, todas las capas de señal y de plano estarán seleccionadas para aplicar el relleno de equilibrado. Para deseleccionar una capa, simplemente haga clic en su entrada.
El lado izquierdo del cuadro de diálogo muestra el patrón de relleno de equilibrado definido actualmente que se aplicará. Haga clic en el botón Edit Pattern para abrir el cuadro de diálogo Edit Pattern - Venting, donde podrá definir el patrón de relleno de equilibrado específico que desee utilizar.
Después de definir el patrón de relleno de equilibrado y las capas a las que se aplicará según sus necesidades, haga clic en OK para aplicar el patrón al panel en todas las áreas situadas fuera de vent_border.
-
With no vent_border layer present – sin una capa vent_border, el borde del panel seguirá existiendo, pero las PCB individuales del panel no tendrán un contorno a partir del cual calcular el área de relleno de equilibrado. Por lo tanto, tendrá que añadir contornos a cada una de las PCB del panel, creando así su propia capa vent_border. Una de las formas más rápidas de hacerlo es añadir una nueva capa y utilizar el comando de polilínea para dibujar contornos alrededor de cada PCB del panel.
Tras ejecutar el comando, el cursor cambiará a un pequeño cuadrado y se le pedirá que seleccione los contornos del panel y de las PCB. Simplemente arrastre un cuadro de selección alrededor de todo el panel. Se seleccionarán todos los contornos de las PCB y el contorno del panel. Haga clic con el botón derecho y aparecerá el cuadro de diálogo Venting. Defina el patrón de relleno de equilibrado y las capas a las que se aplicará según sus necesidades y, a continuación, haga clic en OK. El patrón de relleno de equilibrado se aplicará al panel, en el área delimitada por los contornos del panel y de las PCB.
Asistente de fotolitos
Para panelizar las capas Gerber seleccionadas dentro de un único marco de fotolito y poder generar así las capas Gerber en un fotolito para el documento actual, utilice el comando Tools » Film Wizard de los menús principales.
En primer lugar, asegúrese de que solo estén activadas las capas Gerber que desee incluir en el panel.
Tras ejecutar el comando, aparecerá el cuadro de diálogo Film Wizard . Utilice este cuadro de diálogo para definir el tamaño del fotolito y la disposición de las capas en él. Puede seleccionar una de las definiciones preestablecidas de tamaño/disposición en el campo desplegable Film Description , o introducir la suya propia.
La sección Individual Film Size del cuadro de diálogo muestra la superficie de fotolito disponible para cada imagen de la matriz, en función de los ajustes de tamaño/disposición especificados.
Al hacer clic en el botón Neg/Mirror , se abrirá el cuadro de diálogo Film Wizard - Select Layers . Utilice este cuadro de diálogo para elegir qué capas desea reflejar o convertir en negativos en el fotolito.
Después de definir las opciones del fotolito, al hacer clic en OK en el cuadro de diálogo Film Wizard se crearán las capas de fotolito. Aparecerá un cuadro de diálogo que le preguntará si desea eliminar los objetos antiguos. Si elige Yes, se creará el panel de fotolito y se eliminarán las capas originales. Si elige No, se creará el panel de fotolito y se conservarán todas las capas originales, pero quedarán desactivadas.
Bordes de la placa
La forma en que se separarán las placas del panel es un aspecto que deben tener en cuenta tanto los fabricantes como las empresas de ensamblaje. Por ejemplo, una empresa de ensamblaje puede preferir mantener los paneles intactos hasta que se hayan montado los componentes en las placas, lo que implica que los paneles deben ser lo suficientemente resistentes para mantenerse unidos durante el ensamblaje, pero con suficientes perforaciones para que después las placas puedan desprenderse del panel sin dificultad.
Ranurado en V
El ranurado en V es una solución viable que consiste en realizar una ranura en forma de V entre las secciones de las placas, tanto en la cara superior como en la inferior del panel, dejando un fino puente de material que las mantiene unidas. Todos los detalles de este proceso, como el ángulo de la cuchilla y el espesor del puente, así como la necesidad de aplicar un ranurado discontinuo (zonas en las que se interrumpe la ranura para dar mayor resistencia al panel), deben comunicarse al operario de la máquina de ranurado.
Actualmente, las máquinas de ranurado requieren programación. Esta suele obtenerse a partir de formularios ajenos al CAD que debe rellenar indicando los puntos de datos y las líneas de la configuración del panel. Sin embargo, algunas empresas de ranurado pueden extraer información de taladros y líneas de los archivos Gerber, en cuyo caso podría diseñar las líneas de ranurado en CAM Editor exactamente como desee. En cualquier caso, colocar las líneas de ranurado en la capa de serigrafía superior proporcionará indicaciones visuales al operario de la máquina, que las utilizará junto con la información extraída y la que usted proporcione explícitamente.
Fresado NC
Sin embargo, el método tradicional para perfilar los bordes de las placas utiliza fresas. Se pueden crear bordes lisos introduciendo una fresa en la placa en ubicaciones específicas, desplazándola a lo largo de una trayectoria predefinida y retirándola después.

Al preparar la información de fresado, es importante tener en cuenta varios aspectos. Entre ellos se incluyen el tamaño y la forma de la herramienta de taladrado y la trayectoria de fresado, junto con sus puntos de entrada y retirada.
Para generar y revisar estas instrucciones, CAM Editor debe configurarse en el modo de fresado NC, al que se accede desde el menú View o desde el panel CAM. En este modo, puede crear nuevas herramientas de taladrado para su tabla de herramientas seleccionando Tables » NC Tools en el menú principal, a partir de los flashes seleccionados en el diseño. Tras ejecutar el comando, aparecerá el cuadro de diálogo Tool Table. De forma predeterminada, la tabla contendrá una lista de herramientas basada en cualquier archivo de taladrado NC importado; de lo contrario, aparecerá vacía. Utilice la tabla para añadir o editar definiciones de herramientas. Se pueden definir hasta 99 herramientas, cada una con un código D único, empezando por D9500. Utilice los botones Save y Open para guardar la definición actual de la tabla de herramientas o cargar una definición guardada previamente, respectivamente. Los datos de las herramientas se almacenan en un archivo de configuración de tabla de fresado (*.mts). Al situar el cursor sobre las distintas columnas de la tabla, aparecerá una descripción emergente con más información sobre esa entrada.
A continuación, puede utilizar los comandos disponibles en el menú Rout para definir trayectorias de fresado con estas fresas u otras existentes.
Crear trayectorias de fresado
Para crear trayectorias de fresado a partir de las pistas seleccionadas en el documento actual, seleccione el comando Rout » Create Rout Path(s) en los menús principales.
En primer lugar, asegúrese de haber definido las herramientas de taladrado. Si ha cargado previamente un archivo de taladrado NC, las herramientas del diseño se habrán cargado automáticamente y aparecerán en el cuadro de diálogo Tool Table (Tables » NC Tools). Si no hay herramientas definidas, al intentar ejecutar el comando aparecerá un cuadro de diálogo que le avisará de ello, y tendrá que definirlas importando un archivo de taladrado o introduciéndolas manualmente.
Una vez definidas las herramientas necesarias, al ejecutar el comando se abrirá Select Mill/Drill Tool diálogo. El cuadro de diálogo ofrece una lista desplegable de todas las herramientas de taladrado definidas actualmente para el diseño. Seleccione la herramienta que desee utilizar para el fresado y haga clic en OK. El cursor cambiará a un pequeño cuadrado y se le pedirá que seleccione los objetos que desea fresar. Simplemente sitúe el cursor sobre cada objeto y haga clic para añadirlo a la selección, o utilice una de las numerosas herramientas de selección disponibles. Cuando haya seleccionado todos los objetos necesarios, haga clic con el botón derecho.
Los objetos seleccionados se fresarán y se creará una capa de fresado que se añadirá a la lista de capas del panel CAMtastic . Aparecerá el cuadro de diálogo Create Rout Path(s), desde el que podrá cambiar la herramienta utilizada para el fresado y su desplazamiento. También puede invertir la dirección de las trayectorias de fresado: los puntos de penetración pasarán a ser puntos de retirada y viceversa. Estos cambios son virtuales y solo se aplicarán de forma permanente al hacer clic en el botón OK .
Modificar trayectorias de fresado
Para modificar las trayectorias de fresado seleccionadas en el documento actual, elija el comando Rout » Modify Rout Path(s) en los menús principales.
Primero, asegúrese de que la capa de fresado sea la única capa activada y de que sea visible en el espacio de diseño.
Tras ejecutar el comando, el cursor cambiará a un pequeño cuadrado y se le pedirá que seleccione las trayectorias de fresado que desea modificar. Simplemente sitúe el cursor sobre cada objeto y haga clic para añadirlo a la selección, o utilice una de las numerosas herramientas de selección disponibles. Cuando haya seleccionado todos los objetos necesarios, haga clic con el botón derecho.
Aparecerá el cuadro de diálogo Modify Rout Path(s), desde el que podrá cambiar la herramienta utilizada para el fresado y su desplazamiento. También puede invertir la dirección de las trayectorias de fresado: los puntos de penetración pasarán a ser puntos de retirada y viceversa. Estos cambios son virtuales y solo se aplicarán de forma permanente al hacer clic en el botón OK .
Opciones de fresado de pads
En el cuadro de diálogo Rout Pads Options, puede definir las opciones que se aplicarán cuando se encuentren pads a lo largo de una trayectoria de fresado. Para acceder al cuadro de diálogo, elija el comando Rout » Rout Pads Options en los menús principales. Configure las opciones disponibles según sea necesario.
Fresado automático del contorno
Las trayectorias de fresado pueden definirse manualmente, pero deben utilizarse las herramientas automáticas siempre que sea posible. Unir los segmentos del contorno de la placa en una única polilínea cerrada requiere mucho menos trabajo que intentar colocar manualmente una trayectoria de fresado con precisión, especialmente cuando el contorno de la placa contiene arcos.
Primero, asegúrese de que el contorno de la PCB sea un único límite cerrado. Es posible que deba utilizar el comando Unir para conseguirlo.
Utilice el comando Auto-Rout PCB Border del menú Rout para crear una trayectoria de fresado alrededor de toda la placa a partir del contorno de la PCB. Tras ejecutar el comando, el cursor cambiará a un pequeño cuadrado y se le pedirá que seleccione la esquina del contorno en la que desea situar los puntos de penetración y retirada de la trayectoria. Simplemente sitúe el cursor sobre el contorno y haga clic: se seleccionará la esquina más cercana al punto donde haga clic. De nuevo, si en este momento no consigue seleccionar ningún vértice del contorno de la PCB, asegúrese de que el contorno sea un objeto de polilínea cerrada.
A continuación, se le pedirá que elija la dirección de fresado. Se proporciona una línea guía con respecto a la esquina seleccionada del contorno para ayudarle. Sitúe el cursor en la dirección general en la que desea fresar y haga clic: aparecerá el cuadro de diálogo Auto Rout PCB. Utilice este cuadro de diálogo para seleccionar la herramienta con la que desea fresar el contorno y especificar las extensiones de los puntos de penetración y retirada.
Tras definir las opciones de fresado según sea necesario, haga clic en OK. Se creará la trayectoria de fresado y se añadirá a la capa de fresado.
El cuadro de diálogo Auto Rout PCB
El vértice que elija como inicio de la trayectoria de fresado debe estar en la esquina inferior izquierda del diseño; de lo contrario, las líneas de extensión, si decide utilizarlas, podrían llegar a cortar la placa. Puede seguir las instrucciones de la barra de estado y hacer clic en una segunda ubicación del contorno para determinar la dirección de la trayectoria de fresado. Al hacer clic con el botón derecho para finalizar, se abrirá el cuadro de diálogo Auto Rout PCB, donde podrá seleccionar la herramienta de taladrado y los valores de extensión de los puntos de penetración y retirada.
Si no ha definido un valor de desplazamiento de compensación de la fresa para la herramienta seleccionada (en la tabla de herramientas), se puede generar uno automáticamente. Se creará una nueva capa (*.rte) que contendrá la trayectoria de fresado del contorno de la PCB.
Puede continuar añadiendo puentes de sujeción a lo largo de la trayectoria de fresado, que hacen que la herramienta se retire del panel y avance una distancia especificada a lo largo de la trayectoria antes de volver a penetrar. Colocar puentes de fresado es similar a dejar segmentos sin ranurar: mantienen las placas completamente unidas al panel en determinados puntos, listas para separarlas más adelante.
Herramientas de fresado manual
Los círculos pueden crearse como entidades en sentido horario o antihorario que permiten determinar el radio. El punto de penetración estará en el centro del círculo y la herramienta se retirará cuando el círculo esté completamente fresado. Las ranuras son menos automáticas, ya que, para que la ranura quede completa, debe asegurarse de comenzar en el punto de penetración y volver a él cuando desee colocar el punto de retirada haciendo clic con el botón derecho. Las trayectorias de fresado de texto son como las de las ranuras, con trayectorias predefinidas para cada letra (incluidos los puntos de penetración y retirada); solo tiene que proporcionar un mensaje e indicar la altura que desea para las letras.
Por supuesto, las instrucciones de fresado no son necesariamente funciones posteriores a la panelización. Cualquier objeto de fresado definido dentro de una placa que incluya en la panelización, como las ranuras internas, se incluirá junto con todos los demás datos panelizados.
Para colocar manualmente trayectorias de fresado en el documento actual, elija el comando Rout » Manual Rout en los menús principales. El comando se basa en la colocación de polilíneas. Las polilíneas son útiles si necesita cerrar la línea o insertar arcos como parte de ella, dos operaciones que no pueden realizarse con líneas estándar.
Tras ejecutar el comando, aparecerá el cuadro de diálogo Select Mill/Drill Tool. Elija la herramienta que desea utilizar para el fresado en la lista de herramientas disponibles. Después de hacer clic en OK, entrará en el modo de colocación de polilíneas y aparecerá un círculo relleno junto al cursor, que representa el tamaño de la herramienta seleccionada. La colocación se realiza mediante la siguiente secuencia de acciones:
- Sitúe el cursor en la ubicación deseada del área de trabajo y haga clic para fijar el inicio de la polilínea.
- Mueva el cursor y vuelva a hacer clic para colocar el siguiente vértice de la polilínea.
- Continúe colocando más vértices, haciendo clic cada vez, hasta obtener la forma deseada para la polilínea.
-
Haga clic con el botón derecho para abrir un menú emergente con varios comandos que pueden aplicarse en el modo de colocación de polilíneas. En el menú están disponibles los siguientes comandos:
- End - finaliza la colocación de esta polilínea sin cerrarla.
- Close - cierra la línea trazando una línea desde el último punto colocado hasta el punto inicial y finaliza la colocación de esta polilínea.
- Change to Line - cambia el modo de colocación a líneas rectas.
- Change to Arc - cambia el modo de colocación a arcos.
- Draw Arc Clockwise - dibuja un arco desde el vértice anterior en sentido horario.
- Draw Arc C-Clockwise - dibuja un arco desde el vértice anterior en sentido antihorario.
- Undo Polyline Changes - elimina la polilínea actual y permanece en el modo de colocación de polilíneas.
- Snap Change - activa/desactiva el modo de ajuste durante la colocación de polilíneas.
- Cancel Action - elimina la polilínea actual y sale del modo de colocación de polilíneas.
-
Al finalizar o cerrar la polilínea, o al deshacer cambios, permanecerá en el modo de colocación. Continúe colocando más objetos de polilínea o pulse Esc para salir del modo de colocación de polilíneas. También puede hacer clic con el botón derecho y seleccionar Cancel Action en el menú emergente.
Añadir un puente de sujeción a la trayectoria de fresado seleccionada
Para añadir un puente de sujeción a lo largo de la trayectoria de fresado seleccionada en el documento actual, elija el comando Rout » Add Tabs en los menús principales. Tras ejecutar el comando, aparecerá el cuadro de diálogo Enter Value. Utilice este cuadro de diálogo para introducir un valor para el tamaño del puente, en las unidades del área de trabajo seleccionadas actualmente (pulgadas o mm). Después de hacer clic en OK, volverá a la ventana principal de diseño, el cursor cambiará a un pequeño cuadrado y se le pedirá que seleccione una ubicación para el puente. Solo tiene que situar el cursor en el punto de la trayectoria de fresado donde desee insertar el puente y hacer clic.
El puente se insertará, dividiendo la trayectoria de fresado en dos segmentos, cada uno con sus propios puntos de penetración y retirada.
Continúe añadiendo más puentes a lo largo de las trayectorias de fresado, o haga clic con el botón derecho o pulse Esc para salir.
Convertir líneas en un arco
Para convertir líneas en un arco en una trayectoria de fresado específica del documento actual, elija el comando Rout » Convert Lines to Arc en los menús principales. Tras ejecutar el comando, entrará en el modo de conversión, que implica la siguiente secuencia de acciones:
- Seleccione el punto inicial del arco. Solo tiene que situar el cursor sobre un vértice de la trayectoria de fresado y hacer clic para fijar este punto.
- Seleccione el punto final del arco. De nuevo, sitúe el cursor sobre otro vértice de la trayectoria de fresado y haga clic para fijar este segundo punto. A medida que mueva el cursor, aparecerá una línea guía.
- Seleccione un punto intermedio del arco. Sitúe el cursor sobre un tercer vértice de la trayectoria de fresado y haga clic: las líneas se sustituirán por un arco, cuyo tamaño estará determinado por la longitud de la línea guía que conecta los puntos inicial y final y por la distancia del punto intermedio seleccionado a esta línea.
- Continúe convirtiendo líneas en arcos en otras trayectorias de fresado, o haga clic con el botón derecho o pulse Esc para salir.
Conversión de líneas en un círculo
Para convertir una trayectoria de fresado de contorno cerrado en un círculo de fresado dentro del documento actual, seleccione el comando Rout » Convert Lines to Circle en los menús principales. Tras ejecutar el comando, se le pedirá que seleccione un contorno cerrado. Simplemente sitúe el cursor sobre una parte del contorno de la trayectoria de fresado que desee convertir en un círculo y haga clic: la trayectoria de fresado de contorno cerrado se sustituirá por un círculo, cuyo centro se define como el centro del rectángulo delimitador que encierra la forma del contorno cerrado, y cuyo radio se define mediante la distancia horizontal desde ese centro hasta el borde del rectángulo delimitador.
Continúe convirtiendo otras trayectorias de fresado de contorno cerrado en círculos de fresado, o haga clic con el botón derecho o pulse Esc para salir.
Fresado de contornos
Otra herramienta automática, Fresado de contornos, detecta un borde de forma similar (también requiere una polilínea cerrada), pero crea un patrón de ida y vuelta que elimina mediante fresado toda el área, en lugar de cortar a su alrededor y dejar que se desprenda de la placa o del panel. Seleccione el comando Rout » Mill Boundary en los menús principales para crear trayectorias de vaciado por fresado de contornos cerrados en el documento actual. Tras ejecutar el comando, el cursor cambiará a un cuadrado pequeño y se le pedirá que seleccione los objetos de contorno cerrado para los que desee crear trayectorias de fresado. Simplemente sitúe el cursor sobre cada contorno cerrado, uno tras otro, y haga clic. Una vez seleccionados todos los contornos cerrados necesarios, haga clic con el botón derecho.
Aparecerá el cuadro de diálogo Milling. Utilice este cuadro de diálogo para definir en qué capa desea colocar las trayectorias de fresado. Puede seleccionar la capa actual, una capa nueva o una de las capas existentes en el documento. Utilice el campo Select Tool para elegir cuál de las herramientas de taladrado disponibles desea utilizar para fresar las trayectorias. La opción Delete Old Objects le permite conservar los objetos de contorno originales para realizar comparaciones.
Cambie la vista de Relleno a Contorno (Shift+F) para ver la trayectoria real que se ha determinado para el fresado. El fresado en concordancia se produce cuando la trayectoria de fresado avanza en la misma dirección que el lado cóncavo del diente de la herramienta; el fresado en la dirección opuesta se denomina fresado en oposición.
El fresado de un área es una función especialmente útil cuando se ha asignado a la herramienta de fresado un parámetro del eje Z inferior al espesor del panel. De este modo, puede crear un rebaje en la placa, como el que podría necesitar para montar componentes especiales.
