Ansys CoDesigner
En raison de la complexité des produits électroniques modernes intégrant des circuits haute vitesse et RF, une communication intensive entre les ingénieurs PCB et les ingénieurs en simulation est nécessaire pendant le processus de conception PCB, et cette communication doit être aussi claire et simple que possible pour les deux parties. Il ne suffit pas d’exporter une conception modifiée par l’ingénieur PCB ou optimisée par l’ingénieur en simulation et de la transmettre à l’autre partie : il faut également communiquer ce qui a été modifié, ce qui se fait généralement par e-mail ou verbalement. Cette approche est imparfaite, car il faut suivre toutes les demandes et comparer manuellement les données pour décider des modifications à apporter à la conception ou pour lancer une nouvelle analyse. Ces défis, ainsi que d’autres défis connexes, peuvent être surmontés grâce à Ansys CoDesigner, une interface permettant de transférer des conceptions de cartes de circuits imprimés entre les domaines de la conception PCB et de la simulation.
Logiciels pris en charge
La plateforme de simulation suivante, ainsi que ses versions, est actuellement prise en charge :
Ansys Electronics Desktop (AEDT) – version 2023 R1, 2023 R2, 2024 R1, 2024 R2, 2025 R1, 2025 R2, 2026 R1
Installation et configuration
Pour accéder à Ansys CoDesigner dans Altium Designer, l’extension logicielle Ansys CoDesigner doit être installée. Cette extension peut être installée ou supprimée manuellement.
Pour plus d’informations sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Pour accéder à Ansys CoDesigner dans Ansys Electronics Desktop, l’extension Altium Link doit être installée. La procédure est la suivante :
-
Téléchargez et décompressez l’archive de l’extension Altium Link. Elle peut être obtenue en contactant ansyscollaboration@altium.com (indiquez la version d’AEDT utilisée).
-
Assurez-vous que l’application AEDT est fermée.
-
Dans le dossier décompressé, localisez le fichier
install_altiumlink.bat, cliquez dessus avec le bouton droit et sélectionnez Run as administrator. -
Ouvrez AEDT et sélectionnez la commande Tools » Layout Links dans les menus principaux.
-
Dans l’onglet Config de la boîte de dialogue Layout Links qui s’ouvre, cliquez sur le bouton Add Link, recherchez le dossier
\AnsysEM\<version>\Win64des fichiers programme AEDT, puis ouvrez le fichieraltiumlink.dll. -
Dans l’onglet Layout Links de la boîte de dialogue Layout Links, assurez-vous que le lien Altium est répertorié, puis fermez la boîte de dialogue.
Fonctionnement
Une fois la fonctionnalité Ansys CoDesigner ajoutée au logiciel de conception PCB et au logiciel de simulation, elle peut transmettre les modifications de conception dans les deux sens. Les modifications de conception transitent par un Altium 365 Workspace, qui sert de passerelle entre les deux domaines. L’avantage du transit des modifications de conception via un Workspace est que le processus de mise à jour devient stateless. Cela signifie que chaque partie peut continuer à travailler de manière indépendante ; il n’est pas nécessaire de se préoccuper de l’avancement de l’autre équipe dans le processus de conception/simulation.
Ansys CoDesigner facilite l’échange bidirectionnel Push/Pull des modifications de conception entre les deux domaines. Depuis Altium Designer, les modifications de l’empilage des couches et des matériaux, des composants et des primitives sont détectées et peuvent être appliquées dans AEDT. Depuis AEDT, les modifications proposées de l’empilage des couches et des matériaux peuvent être transmises via le fichier EDB et détectées/appliquées dans Altium Designer. Les ingénieurs ECAD et en simulation peuvent communiquer à l’aide du système de commentaires, chaque fil de commentaires étant rattaché à un composant spécifique dans une conception. Les résultats de simulation peuvent être transmis depuis AEDT vers l’Altium 365 Workspace et associés à une révision de la conception, avec possibilité de les consulter via l’interface navigateur du Workspace et de les prévisualiser dans Altium Designer.
L’interface de collaboration
-
Dans Altium Designer, le panneau Ansys CoDesigner est utilisé pour transmettre et récupérer les modifications de conception dans les deux sens et afficher les messages.
Le panneau Ansys CoDesigner est accessible depuis l’éditeur PCB dans Altium Designer en cliquant sur le bouton Panels en bas à droite de l’espace de conception et en sélectionnant l’option Ansys CoDesigner dans le menu qui apparaît. Notez que vous devez être connecté à un Workspace pour accéder au panneau, et que le document PCB doit faire partie d’un projet PCB stocké dans ce Workspace pour pouvoir utiliser cette fonctionnalité.
-
Dans AEDT, les boîtes de dialogue accessibles depuis la boîte de dialogue Layout Links (Tools » Layout Links) ou depuis l’onglet Desktop du ruban lorsqu’un projet est ouvert sont utilisées pour :
- Vous connecter à votre Altium 365 Workspace et y importer une conception PCB.
- Transmettre la conception vers le Workspace et la récupérer depuis celui-ci.
- Explorer l’historique des échanges de données entre Altium Designer et AEDT.
- Ajouter des commentaires aux composants de la conception.
Transmission des modifications depuis Altium Designer
Pour transmettre la conception depuis Altium Designer, cliquez sur le bouton Push dans le panneau Ansys CoDesigner . Une fenêtre d’édition apparaît en haut du panneau. Saisissez un message concernant la modification de conception, puis cliquez sur Send. La zone Latest from Altium Designer du panneau Ansys CoDesigner sera mise à jour avec les détails de cette transmission.
La conception peut ensuite être importée dans AEDT. Pour une conception déjà importée, les modifications peuvent être récupérées dans AEDT.
Transmettre et partager pour inviter un ingénieur en simulation
Lorsque vous cliquez sur Push dans le panneau Ansys CoDesigner , vous pouvez également activer l’option Share sous le champ Comment afin d’envoyer par e-mail une invitation à l’ingénieur en simulation en utilisant la boîte de dialogue Share with a Simulation Engineer qui s’ouvre après avoir cliqué sur le bouton Send.
Saisissez l’adresse e-mail de l’ingénieur en simulation ainsi qu’une note facultative (si nécessaire), puis cliquez sur le bouton Share . Vous pouvez partager avec une personne qui est déjà membre de l’équipe de votre Workspace, avec un autre utilisateur Altium enregistré au sein ou en dehors de votre organisation, ou avec un utilisateur qui ne possède pas de compte Altium. Une boîte de dialogue de notification peut s’afficher pour vous avertir que l’utilisateur dont vous avez saisi l’adresse e-mail se trouve peut-être en dehors de votre organisation – cliquez sur OK pour l’inviter quand même.
Après un court délai, une autre boîte de dialogue apparaîtra pour indiquer que l’invitation a bien été envoyée.
Dans le cadre du processus d’invitation :
- Un utilisateur déjà membre de l’équipe de votre Workspace verra le projet partagé avec lui avec des droits de visualisation, et recevra un e-mail d’invitation lui permettant d’accéder au projet dans le Workspace.
- Un utilisateur qui n’est pas membre de l’équipe de votre Workspace mais qui possède un compte Altium (qu’il soit au sein ou en dehors de votre organisation) sera ajouté comme membre de l’équipe du Workspace, et le projet sera partagé avec lui avec des droits de visualisation. Il recevra un e-mail d’invitation lui permettant d’accéder au projet dans le Workspace.
- Un utilisateur ne disposant pas de compte Altium recevra un e-mail le dirigeant vers un formulaire intermédiaire afin de s’inscrire/créer un compte Altium. Il sera ajouté comme membre de l’équipe du Workspace lors de son inscription, et le projet sera partagé avec lui avec des droits de visualisation.
Récupération des modifications dans Altium Designer
Lorsque de nouvelles modifications sont transmises depuis AEDT, la bannière New changes have been detected apparaît automatiquement dans le panneau Ansys CoDesigner . Le panneau détaillera le nom de l’ingénieur en simulation qui a effectué la transmission, ainsi que le commentaire facultatif qu’il a saisi lors de la transmission.
Lorsque l’on clique sur le bouton Pull et si le fichier EDB a été inclus dans la transmission depuis AEDT, chaque modification à apporter au fichier de travail afin de le synchroniser avec l’instantané présent dans votre Workspace est répertoriée. Chaque différence détectée est listée dans la liste Changes du panneau. Décochez la case correspondant à chaque modification que vous ne souhaitez pas appliquer. Lorsque vous êtes prêt, cliquez sur le bouton Apply pour appliquer toutes les modifications activées à la conception.
Si les résultats de simulation ont été inclus dans la transmission depuis AEDT, le contrôle Design Summary sera présenté dans le panneau. Cliquez sur ce contrôle pour afficher les résultats de simulation dans la boîte de dialogue Design Summary.
Importation d’une conception dans AEDT
Pour commencer à travailler sur une conception PCB dans AEDT, celle-ci doit d’abord être importée dans AEDT. Pour ce faire :
- Dans la boîte de dialogue Layout Links (Tools » Layout Links), cliquez sur la cellule [Action] du lien Altium dans l’onglet Layout Links et sélectionnez Projects. Vous pouvez également cliquer sur le bouton Projects dans l’onglet Desktop du ruban lorsqu’un projet est ouvert. La boîte de dialogue Altium s’ouvrira.
-
Connectez-vous à votre compte Altium. Assurez-vous que l’entrée Altium Account est sélectionnée dans la liste déroulante en haut de la boîte de dialogue, puis cliquez sur le bouton Sign In. Une page s’ouvrira dans votre navigateur par défaut, où vous pourrez saisir les identifiants de votre compte Altium ou utiliser le SSO pour vous connecter à votre compte Altium – afficher un exemple.
- Sélectionnez le Workspace où se trouve le projet requis dans la liste déroulante Workspace.
-
Sélectionnez le projet dans la liste Projects et cliquez sur le bouton Import.
- Enregistrez le fichier de projet AEDT à l’aide de la boîte de dialogue Save As qui s’ouvre, puis fermez la boîte de dialogue Altium.
Transmission des modifications depuis AEDT
Pour transmettre la conception depuis AEDT :
- Dans la boîte de dialogue Layout Links (Tools » Layout Links), cliquez sur la cellule [Action] du lien Altium dans l’onglet Layout Links et sélectionnez Push/Pull. Vous pouvez également cliquer sur le bouton Push/Pull dans l’onglet Desktop du ruban lorsque le projet est ouvert.
- Utilisez le champ Comment en haut de la boîte de dialogue qui s’ouvre pour ajouter un commentaire décrivant ce qui est inclus dans la transmission.
- Activez les options Include EDB file (pour transmettre les modifications de conception) et/ou Include the Simulation Result (pour transmettre les résultats de simulation).
- Cliquez sur le bouton Push to Altium 365. La zone Latest from Ansys de la boîte de dialogue sera mise à jour avec les détails de cette transmission.
La transmission sera détectée dans Altium Designer, et elle pourra être récupérée dans Altium Designer comme décrit ci-dessus.
Récupération des modifications dans AEDT
Lorsque des modifications de conception ont été transmises depuis Altium Designer, elles peuvent être récupérées dans AEDT.
- Dans la boîte de dialogue Layout Links (Tools » Layout Links), cliquez sur la cellule [Action] du lien Altium dans l’onglet Layout Links et sélectionnez Push/Pull. Vous pouvez également cliquer sur le bouton Push/Pull dans l’onglet Desktop du ruban lorsqu’un projet est ouvert.
-
Consultez la zone Latest From Altium de la boîte de dialogue qui s’ouvre pour obtenir des informations sur la dernière transmission depuis Altium Designer, puis cliquez sur le bouton Show Changes pour ouvrir la boîte de dialogue décrivant les différences entre la conception présente dans le Workspace et la conception actuelle dans AEDT. Utilisez les cases à cocher fournies dans les onglets de la boîte de dialogue pour sélectionner les modifications que vous souhaitez appliquer à la conception dans AEDT.
- Une fois les modifications examinées, cliquez sur le bouton Apply changes pour appliquer les modifications à la conception dans AEDT.
Exploration de l’historique des échanges
L’historique des transmissions et récupérations de la conception est conservé.
Pour consulter l’historique dans Altium Designer, cliquez sur le contrôle History à droite du titre de la zone Latest from the Ansys dans le panneau Ansys Codesigner . La liste des transmissions et récupérations provenant à la fois d’Altium Designer et d’Ansys s’ouvrira. Utilisez le bouton
en haut du panneau pour revenir aux dernières modifications.
Pour consulter l’historique dans AEDT, cliquez sur la cellule [Action] du lien Altium dans l’onglet Layout Links de la boîte de dialogue Layout Links (Tools » Layout Links) et sélectionnez Push/Pull ou Comment ou cliquez sur le bouton Push/Pull ou Comment dans l’onglet Desktop du ruban. Sélectionnez l’onglet History de la boîte de dialogue qui s’ouvre. Développez une entrée de transmission/récupération pour en voir les détails. Utilisez le bouton Refresh pour actualiser l’onglet avec les données les plus récentes.
Ajout de commentaires dans Altium Designer et AEDT
Les ingénieurs électriciens comme les ingénieurs en simulation peuvent également tirer parti de la prise en charge des commentaires du Workspace en créant des fils de commentaires rattachés à des composants spécifiques.
Dans Altium Designer, les commentaires existants sont disponibles via le panneau Comments and Tasks.
-
Pour ajouter un nouveau commentaire à un composant sur le PCB, cliquez sur le bouton Comments en haut du panneau, placez le curseur sur un composant dans l’espace de conception afin qu’il soit mis en évidence avec une bordure bleue, puis cliquez. Dans la boîte de dialogue de saisie de commentaire qui s’ouvre, tapez le commentaire et cliquez sur Post.
-
Pour répondre à un commentaire, sélectionnez l’entrée de commentaire dans le panneau Comments and Tasks, saisissez la réponse dans le champ de texte prévu à cet effet dans la boîte de dialogue de commentaire, puis cliquez sur Reply. La réponse sera ajoutée au fil de commentaires.
Consultez la page Commentaires de document pour en savoir plus.
Dans AEDT, les fils de commentaires sont gérés via l’onglet Comments de la boîte de dialogue Altium, accessible en cliquant sur la cellule [Action] du lien Altium dans l’onglet Layout Links de la boîte de dialogue Layout Links (Tools » Layout Links) et en sélectionnant Comment. La liste située dans la partie supérieure de la boîte de dialogue présente les fils de commentaires existants pour le projet.
Pour ajouter un commentaire à un composant dans AEDT :
- Sélectionnez un composant spécifique dans le panneau Components (View » Components) ou dans l’espace de conception.
- Dans la boîte de dialogue Layout Links (Tools » Layout Links), cliquez sur la cellule [Action] du lien Altium dans l’onglet Layout Links et sélectionnez Comment.
- Saisissez le commentaire dans le champ Comment situé dans la partie inférieure de la boîte de dialogue qui s’ouvre.
- Cliquez sur le bouton Create Thread . Un nouveau fil sera ajouté à la liste.
Pour répondre à un fil existant depuis AEDT :
- Sélectionnez une entrée de commentaire numérotée dans la liste de l’onglet Comments de la boîte de dialogue Altium.
- Saisissez la réponse dans le champ Comment situé dans la partie inférieure de la boîte de dialogue.
- Cliquez sur le bouton Reply Thread . Une nouvelle réponse sera ajoutée sous l’entrée du fil de commentaires correspondant dans la liste.












