Accéder aux options du projet, les définir et les gérer
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Les onglets General, Error Reporting et Options de la boîte de dialogue Project Options
Résumé
Un projet existant ou nouvellement créé est associé à un ensemble de paramètres d’options qui lui sont propres. Ceux-ci sont enregistrés dans le fichier du projet (*.PrjPcb, par exemple) et varient selon le type de projet. Les paramètres d’options sont configurés dans la boîte de dialogue Project Options.
Accès
La boîte de dialogue Project Options est accessible de l’une des façons suivantes :
- Faites un clic droit sur l’entrée du projet dans le panneau Projects, puis cliquez sur Project Options dans le menu contextuel.
-
Cliquez sur l’icône
dans le panneau Projects lorsque le projet souhaité est sélectionné dans ce panneau.
- Depuis n’importe quel éditeur, sélectionnez Project » Project Options dans les menus principaux.
Onglets de la boîte de dialogue
Général

L’onglet General de la boîte de dialogue Project Options
L’onglet General de la boîte de dialogue Project Options vous permet de contrôler la disponibilité en ligne et la synchronisation d’un projet d’espace de travail.
Options/Commandes
Lorsque vous ouvrez cette boîte de dialogue pour un projet alors que vous êtes déconnecté de son espace de travail, seul le bouton Turn Off Synchronization est disponible.
Lorsque vous ouvrez cette boîte de dialogue pour un projet qui n’est pas associé à un espace de travail, l’onglet General de la boîte de dialogue Project Options affiche uniquement le bouton Make Project Available Online. Cliquez sur ce bouton pour ouvrir la boîte de dialogue Rendre disponible en ligne, qui ajoutera votre projet à l’espace de travail une fois les étapes nécessaires effectuées. Toutes les options de l’onglet seront alors disponibles.
Général
- Description - utilisez ce champ pour fournir une description facultative du projet, qui apparaîtra dans le champ de description lorsque vous consulterez votre projet dans l’interface Web de l’espace de travail.
Disponibilité en ligne et synchronisation
-
Version Control - l’état de cette case reflète le mode actuel de disponibilité en ligne. Activez cette option pour stocker ce projet sous contrôle de version (VCS) dans le dépôt de conception Git Versioned Storage de l’espace de travail, ou désactivez-la pour utiliser une simple synchronisation. L’activation du contrôle de version permet à plusieurs utilisateurs de travailler sur le projet : celui-ci sera donc partagé avec tous les autres contributeurs connectés à votre espace de travail.
-
Migrate to Altium 365 Versioned Storage - activez cette option pour migrer un projet utilisant un système VCS externe vers le système VCS natif de l’espace de travail Altium 365. Le projet de conception converti, qui conservera l’historique des commits VCS, pourra alors bénéficier des fonctionnalités natives de contrôle de version de l’espace de travail, telles que la chronologie de l’historique basée sur les événements. Cette option est disponible uniquement pour un projet en miroir.
-
Server Folder - le dossier de l’espace de travail dans lequel se trouve le projet.
-
Enable Conflict Prevention Notifications - activez cette option pour gérer l’accès en modification aux fichiers en recevant une alerte lorsqu’un membre de l’équipe modifie le même document d’un projet de l’espace de travail, afin d’éviter tout risque de conflit de données.
-
Turn Off Synchronization - cliquez sur ce bouton pour désactiver la synchronisation ; la copie locale du projet ne sera alors plus liée à celle qui se trouve dans l’espace de travail. Le projet situé dans l’espace de travail restera inchangé.
Exigences
-
Link Requirements – si le bloc de Requirements Portal n’est pas lié au projet de conception, cliquez sur ce bouton pour ouvrir la boîte de dialogue Link Requirements dans laquelle vous pouvez sélectionner le bloc à lier au projet.
-
Linked Requirements – si le bloc de Requirements Portal est lié au projet de conception, cette entrée affiche le bloc lié Cliquez sur le lien pour modifier l’association actuelle entre le projet et le bloc. Cliquez sur le bouton Unlink pour supprimer le lien.
Consultez la page Exigences dans une conception pour en savoir plus.
Signalement des erreurs

L’onglet Error Reporting de la boîte de dialogue Project Options (pour un projet PCB)
L’onglet Error Reporting de la boîte de dialogue Project Options vous permet de définir les niveaux de signalement pour chacune des violations électriques et de dessin susceptibles d’exister dans les documents schématiques sources lors de la validation du projet. Lors de cette validation, ces paramètres de violation seront utilisés conjointement avec ceux de l’onglet Matrice de connexion pour vérifier la présence de violations de connectivité dans les documents sources.
Options/Commandes
Liste des violations
Cette liste présente toutes les violations électriques et de dessin susceptibles d’exister dans les documents sources du projet. Les violations sont regroupées dans les catégories suivantes :
PCB Design:
Multi-board Design:
Harness Design:
Chaque type de violation est présenté avec les champs suivants :
- Violation Type Description - une brève description du type de violation.
-
Report Mode - utilisez ce champ pour spécifier le niveau de gravité associé au non-respect du contrôle. Utilisez la liste déroulante pour choisir parmi les niveaux de signalement suivants :
-
Menu contextuel
Les commandes suivantes sont disponibles dans le menu contextuel :
- All Off - définit Report Mode sur No Report pour tous les types de violations.
- All Warning - définit Report Mode sur Warning pour tous les types de violations.
- All Error - définit Report Mode sur Error pour tous les types de violations.
- All Fatal - définit Report Mode sur Fatal Error pour tous les types de violations.
- Selected Off - définit Report Mode sur No Report pour tous les types de violations sélectionnés.
- Selected To Warning - définit Report Mode sur Warning pour tous les types de violations sélectionnés.
- Selected To Error - définir Report Mode sur Error pour tous les types de violations sélectionnés.
- Selected To Fatal - définir Report Mode sur Fatal Error pour tous les types de violations sélectionnés.
- Default - rétablir les paramètres par défaut de Report Mode pour tous les types de violations.
- Report Suppressed Violations in Messages Panel - activer cette option pour afficher les violations dans le panneau Messages, même si elles ont été désactivées dans cet onglet.
Option supplémentaire
- Set To Installation Defaults - cliquer pour rétablir les paramètres par défaut de l’installation pour les options de cet onglet.
Matrice de connexion

L’onglet Connection Matrix de la boîte de dialogue Project Options
L’onglet Connection Matrix de la boîte de dialogue Project Options présente une matrice permettant de définir les règles de connectivité entre les broches des composants et les identificateurs de nets, tels que les ports et les entrées de feuille. Il définit les conditions logiques ou électriques qui doivent être signalées sous forme d’avertissements ou d’erreurs. Par exemple, une broche de sortie connectée à une autre broche de sortie est normalement considérée comme une erreur, contrairement à deux broches passives connectées entre elles. Lors de la validation du projet, ces paramètres de violation seront utilisés (conjointement avec les paramètres définis dans l’onglet Signalement des erreurs) pour rechercher les violations dans les documents sources.
Options/Commandes
Matrice de connexion
La matrice présente toutes les vérifications possibles des connexions de câblage entre les combinaisons de broches, de ports et d’entrées de feuille, ainsi que les vérifications des entités non connectées. La matrice se lit par lignes et par colonnes, et la couleur de l’élément à l’intersection d’une ligne et d’une colonne indique comment le compilateur réagira lors de la vérification de cette condition particulière.
Pour modifier le mode de signalement d’une vérification de violation dans la matrice, cliquez sur le carré coloré à l’intersection de la ligne et de la colonne des deux entités. Chaque clic fait passer au niveau de signalement suivant. Les niveaux suivants sont pris en charge :
- No Report
- Warning
- Error
- Fatal Error
Menu contextuel
Les commandes suivantes sont disponibles dans le menu contextuel accessible par clic droit :
- All Off - définir toutes les entrées de la matrice sur No Report.
- All Warning - définir toutes les entrées de la matrice sur Warning.
- All Error - définir toutes les entrées de la matrice sur Error.
- All Fatal - définir toutes les entrées de la matrice sur Fatal Error.
- Default - rétablir les valeurs par défaut de toutes les entrées.
Option supplémentaire
- Set To Installation Defaults - cliquer pour rétablir les paramètres par défaut de l’installation pour les options de cet onglet.
Génération des classes

L’onglet Class Generation de la boîte de dialogue Project Options
L’onglet Class Generation de la boîte de dialogue Project Options vous permet de configurer et de contrôler la génération des classes. Les classes sont des ensembles logiques d’objets de conception d’un type donné. Par exemple, des composants associés peuvent être regroupés dans une classe de composants qui leur est propre, laquelle peut ensuite servir de base à la création d’une règle ciblée. Cet onglet propose des commandes permettant de déterminer quelles classes sont générées automatiquement et quelles classes définies par l’utilisateur sont générées lors de la synchronisation des documents schématiques sources avec le document de conception du PCB.
Options/Commandes
Classes générées automatiquement
-
Generate Net Classes for Buses - cocher cette option pour générer automatiquement une classe de nets pour chaque bus de la conception. Les membres d’une classe seront les nets individuels constituant le bus à partir duquel cette classe a été générée.
-
Generate Net Classes for Components - cocher cette option pour générer automatiquement une classe de nets pour chaque composant de la conception. Les membres d’une classe seront les nets associés auxquels sont connectées les broches du composant à partir duquel cette classe a été générée.
-
Generate Separate Net Classes for Bus Sections - cocher cette option pour générer automatiquement une classe de nets distincte pour chaque section de bus. Une section de bus est créée en spécifiant un bus qui constitue en réalité une section d’un bus plus large, par exemple,
D[15..8], à partir du busD[15..0]. -
Generate Net Classes for Named Signal Harnesses - activer cette option pour générer automatiquement une classe de nets pour chaque faisceau de signaux nommé de la conception. Les membres d’une classe seront les nets associés aux signaux regroupés par le faisceau de signaux nommé à partir duquel la classe a été générée.
-
Sheet-Level Class Generation Grid - cette zone vous permet de contrôler la génération automatique des classes de composants et/ou de nets au niveau de chaque feuille de schéma. Toutes les feuilles de schéma sources du projet sont répertoriées, avec les informations suivantes pour chacune :
- Sheet Name - le nom du document schématique.
- Full Path - le chemin absolu du dossier dans lequel se trouve le document.
-
Component Classes - cochez cette option pour générer une classe de composants pour la feuille.
- Generate Rooms - cochez cette option pour générer une chambre pour la classe de composants.
-
Net Classes Scope - utilisez ce champ pour déterminer s’il faut générer une classe de nets pour la feuille et, le cas échéant, définir la portée de cette génération. La liste déroulante du champ propose les choix suivants :
- None - ne pas générer de classe de nets pour cette feuille.
- Local Nets Only - générer une classe de nets pour cette feuille, contenant uniquement les nets membres locaux à la feuille.
- All Nets - générer une classe de nets pour cette feuille, contenant tous les nets membres associés à la feuille (les nets locaux et ceux qui s’étendent à d’autres feuilles).
-
Structure Classes Generate Structure - cochez cette option pour générer une classe de structure pour la feuille.
Une classe de structure est un type particulier de classe dont les membres peuvent être des classes de tout type (classe de nets, classe de composants, etc.). La génération automatique d’une classe de structure à partir de chaque feuille schématique du projet contenant des composants et/ou des nets, lors du transfert de la conception vers le PCB, permet de représenter fidèlement la structure du projet côté PCB. Les classes de structure permettent non seulement de reproduire la structure des documents schématiques dans l’environnement PCB pour une navigation avancée, mais elles peuvent aussi être utilisées dans des requêtes logiques, par exemple pour définir la portée des règles de conception ou effectuer un filtrage.
Classes définies par l’utilisateur
- Generate Component Classes - cochez cette option pour générer les classes de composants définies par l’utilisateur lors du transfert de la conception vers le PCB. Les classes de composants sont définies manuellement sur le schéma en ajoutant un paramètre ClassName aux composants ciblés et en lui attribuant le nom de classe souhaité.
- Generate Rooms for Component Class - cochez cette option pour générer des chambres à partir des classes de composants définies par l’utilisateur. Ces composants doivent posséder un paramètre de composant nommé « ClassName ».
- Generate Net Classes - cochez cette option pour générer les classes de nets définies par l’utilisateur lors du transfert de la conception vers le PCB. Les classes de nets sont définies manuellement sur le schéma à l’aide de la directive Net Class. Pour ajouter un net à une classe de nets, placez une directive Net Class sur le fil ou le bus concerné (ou sur une couverture) et attribuez à son paramètre ClassName le nom de classe souhaité.
► Découvrez comment créer une classe de nets définie par l’utilisateur
► Découvrez comment créer une classe de composants définie par l’utilisateur
Option supplémentaire
- Set To Installation Defaults - cliquez pour rétablir les valeurs par défaut de l’installation pour les options de cet onglet.
Remarques
-
Pour générer des classes (automatiques et/ou définies par l’utilisateur) lors du transfert de la conception vers le PCB, assurez-vous que les paramètres de comparaison correspondants sont réglés sur Find Differences dans l’onglet Comparateur de la boîte de dialogue Project Options, comme suit :
- Classes de nets - réglez le type de comparaison Extra Net Classes (dans la catégorie Differences Associated with Nets) sur Find Differences.
- Classes de composants - réglez le type de comparaison Extra Component Classes (dans la catégorie Differences Associated with Components) sur Find Differences.
-
De plus, dans l’onglet Génération des ECO de la boîte de dialogue Project Options , assurez-vous que les paramètres ECO correspondants sont réglés sur Generate Change Orders.
- Classes de nets - réglez le type de modification Add Net Classes (dans la catégorie Modifications Associated with Nets) sur Generate Change Orders.
- Classes de composants - réglez le type de modification Add Component Classes (dans la catégorie Modifications Associated with Components) sur Generate Change Orders.
Comparateur

L’onglet Comparator de la boîte de dialogue Project Options
L’onglet Comparator de la boîte de dialogue Project Options vous permet de définir les types de différences à rechercher et ceux à ignorer lors de la comparaison des documents. Pour chaque comparaison possible, vous pouvez choisir de rechercher ou d’ignorer les différences à l’aide de la liste déroulante correspondante dans la colonne Mode. Vous pouvez configurer la recherche de différences concernant les composants, les nets, les paramètres et les objets physiques selon vos besoins.
Options/Commandes
Cette boîte de dialogue est divisée en deux zones principales :
- La zone supérieure, intitulée Comparison Type Description/Mode, présente la description et le mode de comparaison de chaque type de comparaison disponible.
- La zone inférieure, intitulée Object Matching Criteria, permet de définir les critères de correspondance pour Net, Net Class, Component Class, Differential Pair et Structure Class.
Description du type de comparaison/Mode
- Comparison Type Description - cette zone répertorie les descriptions de chaque type de comparaison disponible dans le projet. Utilisez la barre de défilement située à l’extrême droite pour accéder à Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical et Differences Associated with Structure Classes afin de consulter ou de modifier les modes de comparaison dans chaque domaine.
-
Mode - cliquez sur une entrée pour modifier le mode de comparaison à l’aide de la liste déroulante :
-
Find Differences- sélectionnez cette option pour rechercher les différences pour ce type de comparaison. -
Ignore Differences- sélectionnez cette option pour ignorer toutes les différences pour ce type de comparaison (aucune comparaison de ce type ne sera effectuée).
-
Critères de correspondance des objets
- Object Type - liste des types d’objets, tels que Net, Net Class, Component Class, Differential Pair et Structure Class.
- Min Match % - saisissez le pourcentage minimal de correspondance souhaité ou cliquez dans la partie droite de la colonne, puis utilisez les touches fléchées haut et bas pour augmenter ou diminuer la valeur.
- Min Matched Members - saisissez le nombre minimal souhaité de membres correspondants ou cliquez dans la partie droite de la colonne, puis utilisez les touches fléchées haut et bas pour augmenter ou diminuer la valeur.
- Use Name Matching - cliquez sur l’entrée ou utilisez la liste déroulante pour sélectionner After member matching ou Never.
- Show Manual Matching Dialog - cliquez sur l’entrée ou utilisez la liste déroulante pour sélectionner For unmatched objects ou Never.
Options supplémentaires
- Ignore Rules Defined in PCB Only - cochez cette option pour ignorer les règles définies uniquement dans le PCB au sein du projet de conception. Par exemple, lorsque vous effectuez un ordre de modification technique, les modifications peuvent être appliquées du schéma au PCB et, si cette option est activée, les règles propres au PCB sont ignorées. Si aucune règle correspondante n’existe dans les feuilles de schéma du même projet, le comparateur ne tentera pas d’ajouter de nouvelles règles.
- Set To Installation Defaults - cliquez pour rétablir les valeurs par défaut de l’installation pour les options de cet onglet.
Génération d’ECO

L’onglet ECO Generation de la boîte de dialogue Project Options
L’onglet ECO Generation de la boîte de dialogue Project Options vous permet de configurer les types de modifications pouvant être inclus lors de la génération d’un ordre de modification technique (ECO) à partir des différences détectées par le comparateur.
Options/Commandes
Liste des types de modifications
Cette liste présente toutes les modifications possibles pouvant être effectuées au moyen d’un ordre de modification technique lors de la synchronisation des documents schématiques sources avec le document de conception du PCB. Les entrées de la liste comprennent des catégories de types de modifications associés à Components, Nets, Parameters, Structure Classes, etc.
Chaque type de modification comprend les champs suivants :
- Modification Type Description – brève description du type de modification (l’action à effectuer par le synchroniseur).
-
Mode – utilisez ce champ pour déterminer si le type de modification est inclus ou non dans les ECO générés. Utilisez la liste déroulante pour choisir parmi les options suivantes :
- Generate Change Orders - inclure le type de modification dans un ECO généré.
- Ignore Differences - exclure le type de modification d’un ECO généré.
Menu contextuel
La commande suivante est disponible dans le menu contextuel accessible par clic droit :
- Report – utilisez cette commande pour générer un rapport des modes de modification actuellement configurés. La boîte de dialogue Report Preview s’affiche avec le rapport déjà chargé. Utilisez cette boîte de dialogue pour examiner le rapport à l’aide des différentes commandes de page et de zoom avant de l’exporter dans un fichier ou de l’imprimer.
Options supplémentaires
- Push Component Designator Changes to Annotation File (if any) – cochez cette option pour inclure les changements de désignateurs de composants dans le fichier d’annotation.
- Set To Installation Defaults – cliquez pour rétablir les valeurs par défaut de l’installation pour les options de cet onglet.
Options

L’onglet Options de la boîte de dialogue Project Options
L’onglet Options de la boîte de dialogue Project Options vous permet de spécifier le chemin de sortie et les options associées pour les fichiers de sortie générés pour le projet. Vous pouvez également définir diverses options de génération de netlist ainsi que la portée des identifiants de nets.
Options/Commandes
-
Output Path – chemin de sortie par défaut pour la génération des fichiers de sortie du projet de conception actuel (
*.PrjPcb). - ECO Log Path – chemin de sortie par défaut pour les fichiers journaux ECO.
-
Schematic Template Location – utilisez ce champ pour spécifier le répertoire contenant les fichiers modèles de schéma (
*.SchDot,*.SchDoc) à utiliser pour le projet.
Options de sortie
- Open outputs after compile – activez cette option pour ouvrir les fichiers générés après la compilation du projet de conception. Pour un projet de package de bibliothèque intégrée, activez cette option pour installer la bibliothèque intégrée après la compilation du projet de package.
-
Timestamp folder – activez cette option pour créer un dossier horodaté pour les fichiers de sortie générés, tels qu’un rapport de nomenclature (Reports » Bill of Materials). Le nom du dossier est au format
<FolderName> Date Time, où<FolderName>est spécifié dans le champ Output Path, etDateetTimeutilisent le même format que les paramètres de votre système. - Archive project document – activez cette option pour archiver le document du projet. Par exemple, lors de la génération des fichiers de fabrication à partir d’une conception de PCB (File » Fabrication Outputs et File » Assembly Outputs), le dossier de sortie cible contiendra une copie du document PCB associé.
- Use separate folder for each output type – activez cette option pour créer des dossiers distincts pour chaque type de sortie généré pour le projet de conception. Cette structure de dossiers sera également représentée dans le panneau Projects.
Options de netlist
- Allow Ports to Name Nets – activez cette option pour nommer un net à l’aide de la propriété Name d’un port câblé plutôt que d’utiliser un nom de net par défaut généré par le système.
- Allow Sheet Entries to Name Nets – activez cette option pour nommer un net à l’aide du nom de l’entrée de feuille plutôt que d’utiliser un nom de net par défaut généré par le système.
- Allow Single Pin Nets – activez cette option pour autoriser l’existence de nets ne contenant qu’une seule broche.
-
Append Sheet Numbers to Local Net – activez cette option pour ajouter la valeur du paramètre Sheet Number d’un document schématique (un paramètre au niveau du document) aux noms des nets locaux à cette feuille. Un net local est un net qui ne sort pas de la feuille. Cette option ne s’applique pas aux nets qui sortent de la feuille et qui ne sont donc pas locaux.
- Higher Level Names Take Priority – activez cette option pour que les étiquettes de net utilisées sur les feuilles de niveau supérieur dans la hiérarchie servent à nommer les nets sur les feuilles de niveau inférieur.
-
Power Port Names Take Priority – le logiciel permet de rendre local un net d’alimentation global en reliant un port d’alimentation à un port normal. Toutes les broches de cette feuille connectées à ce port d’alimentation sont alors regroupées dans un net distinct. L’activation de cette option impose de nommer le net à l’aide du nom du net attribué au port d’alimentation.
Portée des identifiants de nets
Les conceptions multifeuilles sont définies au niveau électrique (ou de la connectivité) par des identificateurs de nets. Les identificateurs de nets (étiquettes de net, ports, entrées de feuille, ports d’alimentation et broches masquées) créent des connexions logiques entre les points d’un même net. Ces connexions peuvent se trouver sur une même feuille ou s’étendre sur plusieurs feuilles. Une connexion physique existe lorsqu’un objet est directement relié à un autre objet électrique par un fil. Une connexion logique est créée lorsque deux identificateurs de nets du même type (par exemple, deux étiquettes de net) ont la même propriété Net .
Lors de la création du modèle de connectivité de la conception, vous devez définir la manière dont les identificateurs de nets se connectent entre eux : il s’agit de définir la Net Identifier Scope. Il existe essentiellement deux façons de relier les feuilles d’une conception multifeuille : horizontalement, directement d’une feuille à une autre, puis à une autre, etc., ou verticalement, d’une sous-feuille au symbole de feuille qui la représente sur la feuille parente. Dans une connectivité horizontale, les connexions s’établissent de port à port (la connexion d’étiquette de net à étiquette de net est également possible). Dans une connectivité verticale, les connexions s’établissent d’une entrée de feuille à un port.
Utilisez la liste déroulante pour choisir parmi les portées suivantes :
-
Automatic (Based on project contents) – ce mode sélectionne automatiquement le mode d’identification des nets à utiliser selon les critères suivants : si la feuille de niveau supérieur comporte des entrées de feuille, Hierarchical est utilisé ; s’il n’y a aucune entrée de feuille, mais que des ports sont présents, Flat est utilisé ; s’il n’y a ni entrée de feuille ni port, Global est utilisé.
- Flat (Only ports global) – les ports se connectent globalement sur toutes les feuilles de la conception. Avec cette option, les étiquettes de net sont locales à chaque feuille, c’est-à-dire qu’elles ne se connectent pas d’une feuille à l’autre. Tous les ports portant le même nom sont connectés sur toutes les feuilles. Cette option peut être utilisée pour les conceptions multifeuilles à plat. Elle n’est pas recommandée pour les conceptions de grande taille, car il peut être difficile de suivre un net à travers les feuilles.
- Hierarchical (Sheet entry <-> port connections, power ports global) – établit une connexion verticale entre un port et l’entrée de feuille correspondante. Cette option établit les connexions entre feuilles uniquement par l’intermédiaire des entrées des symboles de feuille et des ports correspondants des sous-feuilles. Elle utilise les ports des feuilles pour faire remonter les nets ou les bus vers les entrées des symboles de feuille correspondants sur la feuille parente. Les ports sans entrée de feuille correspondante ne seront pas connectés, même si un port portant le même nom existe sur une autre feuille. Les étiquettes de net sont locales à chaque feuille, c’est-à-dire qu’elles ne se connectent pas d’une feuille à l’autre. En revanche, les ports d’alimentation sont globaux : tous les ports d’alimentation portant le même nom sont connectés dans l’ensemble de la conception. Cette option permet de créer des conceptions de n’importe quelle profondeur hiérarchique et de suivre un net dans toute la conception sur le schéma imprimé.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – ce mode de connectivité fonctionne de la même manière que le mode Hierarchical , à la différence que les ports d’alimentation restent locaux à chaque feuille : ils ne se connectent donc pas aux ports d’alimentation du même nom situés sur d’autres feuilles.
- Global (Netlabels and ports global) – les ports et les étiquettes de net se connectent sur toutes les feuilles de la conception. Avec cette option, tous les nets portant la même étiquette de net sont connectés entre eux sur toutes les feuilles. De même, tous les ports portant le même nom sont connectés sur toutes les feuilles. Si un net connecté à un port possède également une étiquette de net, son nom sera celui de l’étiquette de net. Cette option peut également être utilisée pour les conceptions multifeuilles à plat. Toutefois, il est difficile de suivre les connexions d’une feuille à l’autre, car il n’est pas toujours facile de repérer visuellement les noms des nets sur le schéma.
Autoriser la permutation des broches à l’aide de ces méthodes
Dans l’éditeur PCB, les permutations de broches, de paires différentielles et de parties de composants sont effectuées en échangeant les nets sur les pastilles des composants et le cuivre correspondant. Lorsque les modifications sont répercutées dans les schémas, une permutation de broches peut être traitée de deux manières :
-
Adding / Removing Net-Labels – activez cette option pour autoriser la permutation des broches sur un symbole de composant. La permutation sur le schéma par échange des étiquettes de net n’est possible que si la connectivité est établie par ces étiquettes, c’est-à-dire si les broches ne sont pas reliées physiquement par des fils.
-
Changing Schematic Pins – activez cette option pour autoriser la permutation des étiquettes de net sur les fils reliés aux broches d’un composant. La permutation des broches sera la seule option disponible lorsque les nets sont physiquement reliés à un composant par des fils. Cette méthode peut être utilisée sur des composants simples (tels qu’un réseau de résistances) ou lorsqu’il n’existe aucune autre solution en raison de la structure du schéma.
Général
- Automatic Sheet Numbering – activez cette option pour numéroter automatiquement les feuilles de schéma de ce projet. Elle permet de contrôler les désignations des feuilles et de les enregistrer sous forme de paramètres dans les documents schématiques respectifs.
-
Automatic Cross References – activez cette option pour ajouter automatiquement les informations de renvoi des ports, des connecteurs hors feuille et des entrées de feuille à tous les documents schématiques sources du projet actif. Cette fonctionnalité facilite le suivi de la connectivité des nets dans une conception non hiérarchique.
- New Indexing of Sheet Symbols – activez cette option pour utiliser n’importe quel chiffre ou nombre comme premier ou dernier indice d’un symbole de feuille répété, y compris 0. Les nombres négatifs ne sont pas autorisés. Le dernier indice doit toujours être supérieur au premier.
Renvois
-
Sheet Style – choisissez l’un des styles de feuille suivants pour les références croisées des ports sur une ou plusieurs feuilles de schéma d’un projet.
-
None– aucun style de feuille n’est ajouté à la chaîne de référence croisée des ports. -
Name– les noms des feuilles auxquelles les ports sont reliés sont ajoutés aux chaînes de référence croisée. -
Number– les numéros des feuilles auxquelles les ports sont reliés sont ajoutés aux chaînes de référence croisée.
-
-
Location Style – choisissez l’un des styles d’emplacement suivants pour les références croisées des ports sur une ou plusieurs feuilles de schéma d’un projet.
-
None– aucun style d’emplacement n’est ajouté à la chaîne de référence croisée des ports. -
Zone– la numérotation des zones de référence (définies sur les bordures des feuilles) est ajoutée aux chaînes de référence croisée de tous les ports associés aux objets parents, pour indiquer, par exemple, l’emplacement des symboles de feuille. -
Location X,Y– les emplacements des ports sont indiqués entre parenthèses dans les chaînes de référence croisée de tous les ports associés aux objets parents, pour indiquer, par exemple, l’emplacement des symboles de feuille.
-
- Follow Cross References settings in Preferences – lorsque cette option est activée, les valeurs des options Sheet Style et Location Style sont héritées des options de la section Port Cross References de la page Schéma – Général de la boîte de dialogue Preferences.
-
Display Cross References for:
-
Ports – utilisez la liste déroulante pour sélectionner le mode d’affichage des références croisées des ports.
-
Disabled– aucune référence croisée n’est ajoutée aux ports. -
Only Related Sheet Entry– affiche la référence croisée vers l’entrée de feuille associée sur la feuille de schéma parente. -
Only Related Ports– affiche les références croisées vers les ports associés. -
Sheet Entry & Ports– affiche les références croisées vers l’entrée de feuille et les ports.
-
- Off-sheet Connectors – activez cette option pour afficher les références croisées des objets connecteurs hors feuille.
- Sheet Entries – activez cette option pour afficher les références croisées des objets entrées de feuille.
-
Ports – utilisez la liste déroulante pour sélectionner le mode d’affichage des références croisées des ports.
Paires différentielles
-
Custom Diff Pair Suffix Grid – répertorie les suffixes de paire différentielle par défaut (
_P/_N) et tous les suffixes de paire différentielle personnalisés définis, selon les éléments suivants :- Positive Suffix – le suffixe du net positif d’une paire différentielle.
- Negative Suffix – le suffixe du net négatif d’une paire différentielle.
- Add – cliquez pour ajouter une nouvelle paire de suffixes à la liste.
- Remove – cliquez pour supprimer de la liste la ou les paires de suffixes sélectionnées.
Création de xNets
- Sources/Destinations – définissez une liste de préfixes, séparés par des virgules, pour les désignateurs des composants pouvant être utilisés comme composants sources ou destinations dans les xNets.
- Discretes – définissez une liste de préfixes, séparés par des virgules, pour les désignateurs des composants pouvant être utilisés comme composants en série dans les xNets.
Multicanal

L’onglet Multi-Channel de la boîte de dialogue Project Options
L’onglet Multi-Channel de la boîte de dialogue Project Options vous permet de définir la convention de nommage des zones de placement et le format des désignateurs de composants à utiliser dans les conceptions multicanaux. La conception multicanal permet de référencer plusieurs fois la même sous-feuille dans un projet. Pour cela, vous pouvez placer plusieurs symboles de feuille référençant la même sous-feuille, ou inclure le mot-clé Repeat dans le désignateur d’un symbole de feuille pour l’instancier plusieurs fois.
Altium Designer offre une véritable conception multicanal : vous pouvez référencer plusieurs fois une même feuille dans un projet. Toutes les modifications nécessaires peuvent être effectuées au même endroit ; la recompilation du projet les propage ensuite à chaque instance. Altium Designer prend non seulement en charge plusieurs canaux, mais permet également de les imbriquer.
La correspondance entre le composant logique unique sur le schéma et ses multiples instances physiques sur le PCB est contrôlée par la convention de désignation multicanal définie dans cet onglet.
Options/Commandes
Nommage des zones de placement
-
Room Naming Style - utilisez ce champ pour spécifier le style de nommage des zones de placement. Lorsque vous sélectionnez un style dans la liste, l’image ci-dessous est mise à jour pour refléter la convention de nommage qui apparaîtra dans la conception. Lors de la compilation de la conception, une zone de placement est créée pour chaque feuille, y compris chaque groupe et chaque canal de niveau inférieur. Cinq styles sont disponibles : deux à plat et trois hiérarchiques (ceux qui incluent le chemin) :
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - utilisez ce champ pour spécifier le caractère ou le symbole servant à séparer les informations de chemin lorsque vous utilisez les styles de nommage hiérarchiques (ceux qui incluent le chemin). Par défaut, le trait de soulignement (_) est utilisé.
- Preview - lorsque vous modifiez Room Naming Style et/ou Designator Format, l’image de cette section est mise à jour dynamiquement pour refléter la convention de nommage qui apparaîtra dans la conception. L’image présente un exemple de conception à canaux imbriqués 2 x 2. Les grandes zones hachurées représentent les deux canaux de niveau supérieur (ou groupes), et les zones ombrées à l’intérieur représentent les canaux de niveau inférieur (avec deux exemples de composants dans chacun).
Nommage des composants
-
Designator Format - utilisez ce champ pour spécifier le format utilisé lors de l’attribution des repères aux composants de la conception. Les huit formats prédéfinis suivants sont disponibles dans la liste déroulante du champ : cinq formats à plat et trois formats utilisables dans un contexte hiérarchique (incluant le nommage des canaux) :
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Définir votre propre format de repère
Vous pouvez également définir votre propre format de repère de composant en le saisissant directement dans le champ Designator Format. Les mots-clés suivants peuvent être utilisés pour construire la chaîne de format :
- $RoomName - il s’agit du nom du canal associé, déterminé par le style choisi dans le champ Room Naming Style .
- $Component- il s’agit du repère logique du composant.
- $ComponentPrefix - il s’agit du préfixe du repère logique du composant (par exemple, U pour U1).
- $ComponentIndex - il s’agit de l’indice du repère logique du composant (par exemple, 1 pour U1).
- $ChannelPrefix - il s’agit du repère logique du symbole de feuille.
- $ChannelIndex - il s’agit de l’indice du canal.
- $ChannelAlpha - il s’agit de l’indice du canal exprimé sous forme de caractère.
Remarques
- L’indexation alphabétique d’un canal n’est réellement utile que si votre conception contient moins de 26 canaux au total ou si vous utilisez un format de repère de type hiérarchique.
- Pour une conception multicanal, des onglets sont affichés au bas de la feuille de schéma dans la fenêtre de conception, un pour chaque canal (ou groupe). Les noms des onglets sont constitués des noms des symboles de feuille suivis du numéro de canal, par exemple, BANKA. Il s’agit des vues compilées (vues physiques) de la conception, tandis que la conception logique reste inchangée dans l’onglet Editor.
Impressions par défaut

L’onglet Default Prints de la boîte de dialogue Project Options
L’onglet Default Prints de la boîte de dialogue Project Options vous permet de configurer les sorties d’impression par défaut des différents éditeurs d’Altium Designer. Ces paramètres par défaut sont utilisés lors de l’exécution des commandes d’impression suivantes à partir des menus principaux des éditeurs :
- File » Print
- File » Print Preview » Print
L’onglet Default Prints de la boîte de dialogue Project Options est également accessible depuis l’éditeur de schémas et l’éditeur de PCB, en choisissant la commande File » Default Prints dans les menus principaux.
Options/Commandes
La zone principale de l’onglet présente la liste de toutes les sorties d’impression prises en charge pouvant être générées à partir des éditeurs de schémas et de PCB. Les types de sorties sont regroupés dans les catégories suivantes :
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Pour chaque entrée, les informations suivantes sont affichées :
- Output Description – le contenu généré par ce type de sortie d’impression.
- Supports – l’éditeur qui prend en charge ce type de sortie d’impression.
-
Default Print – indique si ce type de sortie d’impression doit être utilisé comme type d’impression par défaut (activé) ou non (désactivé).
Options supplémentaires
-
Configure – cliquez sur ce bouton pour accéder à la boîte de dialogue associée permettant de configurer la sortie d’impression actuellement sélectionnée. Les boîtes de dialogue concernées sont les suivantes :
- Boîte de dialogue Impression – pour configurer les plans d’assemblage, le plan composite, les impressions de PCB, les impressions de bibliothèques de PCB, les impressions de schémas, le plan de perçage composite, les plans/guides de perçage, les impressions des typons définitifs, les impressions des plans d’alimentation et les impressions des masques de soudure/de pâte à braser.
- Boîte de dialogue Paramètres d’impression 3D du PCB – pour configurer les impressions 3D du PCB.
- Boîte de dialogue Vidéo 3D du PCB – pour configurer les sorties vidéo 3D du PCB.
- Boîte de dialogue PDF3D – pour configurer les sorties PDF3D et PDF3D MBA.
- Boîte de dialogue Propriétés avancées d’impression de texte – pour configurer les impressions de rapports et de textes. Définissez les options de la sortie imprimée (par exemple, l’en-tête et la numérotation des pages/lignes). Vous pouvez également spécifier une police particulière.
- Wave Print Properties FormBoîte de dialogue – pour configurer les impressions SimView.
- Boîte de dialogue Configuration du rapport d’empilage des couches – pour configurer les sorties de rapport d’empilage de la carte.
- Boîte de dialogue Gestionnaire de rapports – pour configurer les rapports de nomenclature et de comparaison de nomenclatures.
- Boîte de dialogue Configuration de l’exportation des commentaires – pour configurer un rapport d’exportation des commentaires.
- Boîte de dialogue Configuration des différences – pour configurer un rapport des différences.
- Boîte de dialogue Configuration de la vérification des règles électriques – pour configurer un rapport de validation de la vérification des règles électriques.
- Page Setup – cliquez pour accéder à une boîte de dialogue de mise en page pour la sortie d’impression actuellement sélectionnée. Dans cette boîte de dialogue, vous pouvez configurer l’impression sur l’imprimante choisie en définissant les paramètres de papier, d’échelle et de couleur. Vous pouvez également accéder à la boîte de dialogue de configuration correspondante et à celle de configuration de l’imprimante, afficher un aperçu de l’impression et, enfin, imprimer la sortie sur l’imprimante sélectionnée.
Chemins de recherche

L’onglet Search Paths de la boîte de dialogue Project Options
L’onglet Search Paths de la boîte de dialogue Project Options vous permet de spécifier les chemins de recherche des fichiers de bibliothèques et de modèles du projet.
Options/Commandes
Liste ordonnée des chemins de recherche
Ce tableau affiche la liste ordonnée des chemins de recherche des fichiers de bibliothèques et de modèles (par exemple, les bibliothèques d’empreintes de PCB, les modèles de simulation et d’intégrité du signal). Pour chaque chemin, vous pouvez spécifier le filtre et les paramètres de recherche récursive.
- Path - emplacement du chemin de recherche.
- Filter - le filtre de recherche. Par défaut, le filtre recherche tous les fichiers.
- Recursive - cochez cette option pour rechercher dans tous les sous-dossiers du dossier du chemin de recherche. Double-cliquez sur un chemin de recherche pour le modifier.
- Add - permet d’ouvrir la boîte de dialogue Edit Search Path pour ajouter un nouveau chemin de recherche.
Les types de fichiers suivants sont pris en charge : bibliothèques d’empreintes (*.PcbLib), fichiers de modèles de simulation (*.mdl), fichiers de sous-circuits de simulation (*.ckt), fichiers de modèles IBIS (*.ibs).
- Delete - permet de supprimer le chemin de recherche sélectionné.
- Properties - permet d’accéder à la boîte de dialogue Edit Search Path pour modifier les propriétés du chemin de recherche sélectionné.
- Move Up - permet de déplacer le chemin de recherche sélectionné d’une ligne vers le haut.
- Move Down - permet de déplacer le chemin de recherche sélectionné d’une ligne vers le bas.
Fichiers trouvés dans tous les chemins de recherche
Ce tableau affiche les fichiers de bibliothèques et de modèles trouvés à partir de la liste Ordered List of Search Paths. Utilisez le bouton Refresh List pour afficher une liste actualisée.
Paramètres

L’onglet Parameters de la boîte de dialogue Project Options
L’onglet Parameters de la boîte de dialogue Project Options vous permet de gérer les paramètres définis pour le projet, souvent appelés project-level parameters. Les paramètres définis au niveau du projet peuvent être utilisés dans toutes les feuilles de schéma et tous les documents PCB du projet à l’aide de chaînes spéciales : =<ProjectParameterName> sur un schéma (par exemple, =Project) et .<ProjectParameterName> sur un PCB (par exemple, .Project). Les paramètres peuvent servir à fournir des informations supplémentaires sur la conception. Les paramètres au niveau du projet, par exemple, peuvent être utilisés de manière globale comme source de données paramétriques pour les chaînes spéciales à ajouter aux feuilles de schéma et/ou au document PCB, ce dernier ne prenant pas en charge les paramètres locaux.
Les paramètres de projet côté espace de travail sont enregistrés dans l’espace de travail avec le projet et ne peuvent être modifiés que depuis l’interface Web de l’espace de travail (pour en savoir plus sur Editing a Project dans Altium 356 Workspace ou On-Prem Enterprise Workspace). En revanche, les paramètres de projet côté conception sont enregistrés dans le fichier du projet (*.PrjPcb) et peuvent être modifiés dans Altium Designer. Les paramètres de projet côté espace de travail apparaissent dans l’onglet Parameter de la boîte de dialogue Project Options avec une icône bleue , tandis que les paramètres de projet côté conception apparaissent avec une icône orange
Options/Commandes
-
Parameters Grid – la zone principale répertorie tous les paramètres actuellement définis pour le projet, avec les attributs suivants :
- Name – le nom du paramètre.
- Value – la valeur du paramètre.
-
Add – cliquez pour ouvrir la boîte de dialogue Parameter Properties, dans laquelle vous pouvez ajouter un paramètre. Utilisez les champs Name et Value pour attribuer au paramètre, respectivement, un nom explicite reflétant sa fonction et sa valeur. Les deux champs acceptent un maximum de 255 caractères.
- Remove – cliquez pour supprimer le ou les paramètres sélectionnés de la liste des paramètres. Cette option n’est pas disponible pour les paramètres de projet côté espace de travail, car ceux-ci ne peuvent être supprimés ou modifiés que dans l’espace de travail.
- Edit – cliquez pour ouvrir la boîte de dialogue Parameter Properties, dans laquelle vous pouvez modifier le contenu du paramètre actuellement sélectionné. Cette option n’est pas disponible pour les paramètres de projet côté espace de travail, car ceux-ci ne peuvent être supprimés ou modifiés que dans l’espace de travail.
- Refresh – cliquez pour annuler les dernières modifications apportées au paramètre de projet côté conception. Pour les paramètres de projet côté espace de travail, cliquez pour vous assurer de disposer de la dernière version du paramètre. Les modifications apportées aux paramètres de projet côté espace de travail dans l’espace de travail ne seront pas répercutées dans cette boîte de dialogue tant que cette option n’aura pas été utilisée.
Menu contextuel
Les commandes suivantes sont disponibles dans le menu contextuel :
-
Edit – permet de modifier le paramètre actuellement sélectionné dans la boîte de dialogue Parameter Properties. Cette commande n’est pas disponible pour les paramètres de projet côté espace de travail, car ceux-ci ne peuvent être supprimés ou modifiés que dans l’espace de travail.
-
Add – permet d’ajouter un nouveau paramètre côté conception à la liste dans la boîte de dialogue Parameter Properties.
-
Remove – permet de supprimer les paramètres sélectionnés de la liste. Cette commande n’est pas disponible pour les paramètres de projet côté Workspace, car ils ne peuvent être supprimés ou modifiés que dans le Workspace.
-
Copy – permet de copier les paramètres sélectionnés dans le presse-papiers Windows.
-
Paste – permet de coller les paramètres du presse-papiers Windows dans la liste des paramètres. Cette commande n’est pas disponible pour les paramètres de projet côté Workspace, car ils ne peuvent être supprimés ou modifiés que dans le Workspace.
Feuilles de circuit

L’onglet Device Sheets de la boîte de dialogue Project Options
L’onglet Device Sheets de la boîte de dialogue Project Options vous permet de spécifier les dossiers contenant les feuilles de circuit ainsi que leur ordre.
Options/Commandes
- Main region - répertorie les Device Sheet Folders chemins du projet actuel. Cochez Include Sub-folders pour inclure les sous-dossiers des dossiers parents répertoriés.
- Move Up - permet de faire monter le dossier de feuilles de circuit sélectionné d’un niveau à la fois.
- Move Down - permet de faire descendre le dossier de feuilles de circuit sélectionné d’un niveau à la fois.
- Add - permet d’ouvrir une boîte de dialogue pour rechercher un nouveau dossier à ajouter.
- Remove - permet de supprimer le dossier de feuilles de circuit sélectionné.
Tâches de sortie gérées

L’onglet Managed OutputJobs de la boîte de dialogue Project Options
L’onglet Managed OutputJobs de la boîte de dialogue Project Options vous permet de configurer une liste de modèles de tâches de sortie disponibles dans le Workspace auquel vous êtes connecté, afin de les utiliser avec le projet.
Options/Commandes
- Outputjob List - répertorie toutes les tâches de sortie du Workspace selon les critères Item Revision, Revision State, Description et Name.
- Add - cliquez pour ouvrir la boîte de dialogue Select configuration item (Output Jobs) et sélectionner les tâches de sortie souhaitées.
- Remove - cliquez pour supprimer les tâches de sortie sélectionnées.
Options de bibliothèque

L’onglet Library Options de la boîte de dialogue Project Options
L’onglet Library Options de la boîte de dialogue Project Options vous permet de sélectionner le format d’un projet de bibliothèque intégrée.
Options/Commandes
-
Integrated Library Format
- Original - sélectionnez cette option pour utiliser le format de bibliothèque intégrée d’origine. Ce format assure la compatibilité avec le logiciel Protel DXP (DXP 2002), antérieur à Altium Designer.
-
Altium Designer- sélectionnez cette option pour utiliser Altium Designer comme format de bibliothèque intégrée (utilisé dans toutes les versions du logiciel depuis la version initiale Altium Designer 2004).
).
