SI Analyzer di Keysight
A colpo d'occhio
- Scopri cosa fa l'estensione SI Analyzer by Keysight in Altium Designer e quali tipi di verifiche dell'integrità del segnale supporta.
- Scopri come installare l'estensione, aprire un documento SI Analyzer, aggiungere net o classi e assegnare specifiche predefinite o personalizzate.
- Comprendi il flusso di lavoro di base per preparare i vincoli e i dati di analisi, così da poter procedere con le verifiche dell'integrità del segnale sul tuo progetto.
Sempre più dispositivi elettronici moderni incorporano progetti PCB ad alta velocità e le velocità dei segnali aumentano con l'evolversi delle tecnologie (17 GHz nella DDR6, 400 Gbps in QSFP++, ecc.). Garantire l'integrità del segnale (SI) è un passaggio fondamentale nella progettazione ad alta velocità. Il mancato rispetto dei requisiti dello sviluppatore dell'interfaccia può molto probabilmente causare problemi nelle successive fasi di progettazione, nella produzione e nelle prestazioni.
Per eseguire un'analisi dell'integrità del segnale direttamente nell'ambiente Altium Designer, è disponibile la soluzione SI Analyzer by Keysight. Fornito come estensione software, SI Analyzer by Keysight si integra direttamente con Altium Designer per consentire l'esecuzione di una serie di verifiche SI post-layout sui parametri più importanti della progettazione ad alta velocità:
-
Impedenza
-
Ritardo
-
Perdite di inserzione (IL)
-
Perdite di ritorno (RL)
Accesso alle funzionalità di SI Analyzer by Keysight
Per accedere alle funzionalità di SI Analyzer by Keysight in Altium Designer, è necessario installare l'estensione software SI Analyzer by Keysight . Questa estensione può essere installata o rimossa manualmente.
Per ulteriori informazioni sulla gestione delle estensioni, consulta la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Quando l'estensione software SI Analyzer by Keysight è installata, consente di:
-
Creare un nuovo documento SI Analyzer by Keysight o aprirne uno esistente.
-
Aggiungere e configurare le net per un'analisi SI.
-
Esaminare i risultati delle analisi SI esistenti.
-
Generare un report di analisi SI.
Tuttavia, per eseguire una nuova analisi SI, è necessario disporre di un abbonamento valido a SI Analyzer by Keysight. In caso contrario, il tentativo di avviare un'analisi SI aprirà la finestra di dialogo Analyze Your Nets, in cui puoi richiedere una prova gratuita
Avvio di SI Analyzer by Keysight
Per avviare l'analisi dell'integrità del segnale, apri il documento PCB del progetto e seleziona Tools » SI Analyzer by Keysight dai menu principali.
Il documento SI Analyzer by Keysight (<ProjectName> [SIK]) si aprirà e verrà aggiunto all'area Source Documents del progetto (nel pannello Projects). Inizialmente, il documento non è salvato. Utilizza il comando File » Save As dai menu principali per salvare il documento nella posizione desiderata.
Preparazione dell'analisi
Aggiunta delle net da analizzare
Dopo l'avvio di SI Analyzer by Keysight, i dati del PCB vengono importati nel risolutore (in formato ODB++). In questa fase, puoi definire l'elenco delle net da analizzare e assegnare loro le specifiche. A tale scopo, fai clic sul pulsante Manage Nets nella parte superiore del documento SI Analyzer by Keysight oppure utilizza il comando Edit » Manage Nets dai menu principali (in alternativa, se il documento non contiene net, il pulsante Manage Nets è disponibile anche al centro del documento). Si apre la finestra di dialogo Manage Nets, che presenta l'elenco delle classi di net, coppie differenziali e xSignal del PCB.
Seleziona la casella di controllo per ogni classe necessaria (oppure utilizza la casella di controllo nell'intestazione della griglia per selezionare tutte le classi). Facoltativamente, fai clic sulla cella nella colonna Specifications per visualizzare un popup e selezionare le specifiche desiderate che definiranno i vincoli per la classe selezionata (che potranno essere ridefiniti in seguito, se necessario – scopri di più). Puoi scegliere tra specifiche integrate o definite dall'utente (nella scheda Specifications del popup) oppure, per una classe, definire manualmente i valori dei vincoli richiesti (nella scheda Custom Constraints del popup).
Consulta la sezione Gestione delle specifiche per ulteriori informazioni sulla gestione delle specifiche integrate o definite dall'utente.
Puoi anche espandere l'elenco All Nets nella parte inferiore della finestra di dialogo per selezionare e assegnare specifiche alle singole net del progetto.
Dopo aver fatto clic su OK nella finestra di dialogo, le classi selezionate verranno visualizzate nel documento SI Analyzer by Keysight. Se è stata selezionata una net nell'area All Nets della finestra di dialogo Manage Nets, questa verrà visualizzata nella voce della classe All Nets. Espandi la voce di una classe per visualizzarne le net/gli xSignal.
Espandi la voce di una net/xSignal o di una coppia differenziale per visualizzarne gli oggetti costitutivi (pad, piste, archi e via) nell'area Transmission Line. Passa il cursore sul riquadro di un oggetto e fai clic sull'icona
per individuare l'oggetto nel PCB tramite cross-probing.
Per rimuovere dal documento una classe o una net aggiunta singolarmente, fai clic sul pulsante
a destra della relativa voce.
Gestione delle specifiche
La finestra di dialogo Manage Specifications, accessibile facendo clic sul pulsante Manage Specifications nella parte superiore del documento SI Analyzer by Keysight, consente di gestire sia le specifiche predefinite sia quelle definite dall'utente. Le specifiche possono quindi essere assegnate a una classe o a una net per definirne rapidamente i vincoli, come descritto nella sezione precedente.
-
Il lato sinistro della finestra di dialogo presenta l'elenco delle specifiche attualmente definite. Per ciascuna specifica vengono indicati il nome e uno o più tipi di vincoli che essa definisce.
- Seleziona una specifica nell'elenco per visualizzarne i dettagli (nome, tipologia di specifica Built-In o User-Defined e vincoli) sul lato destro della finestra di dialogo.
-
Per creare una nuova specifica, fai clic sul pulsante Add New in basso a sinistra nell'elenco delle specifiche. Sul lato destro della finestra di dialogo verranno visualizzati i controlli per definire la specifica:
-
Definisci il nome del nuovo vincolo utilizzando il campo Specification Name.
-
Seleziona i tipi di vincoli che desideri definire con questa specifica utilizzando le caselle di controllo: Impedance, Delay, Insertion Losses (IL) e/o Return Losses (RL).
-
Per i tipi di vincoli abilitati, definisci i relativi valori. Per i vincoli di tipo Impedance e Delay, usa i campi di testo disponibili. Per i vincoli di tipo Insertion Losses (IL) e Return Losses (RL), puoi aggiungere, modificare e rimuovere limiti per delimitare un'area di valori di perdita non consentiti e consentiti nell'intervallo di frequenza richiesto.
-
Una volta definita la specifica secondo necessità, fai clic sul pulsante Save nella parte superiore del lato destro della finestra di dialogo per crearla, oppure fai clic su Cancel per uscire senza crearla.
-
-
È possibile creare una nuova specifica anche duplicandone una esistente (definita dall'utente o predefinita). Seleziona nell'elenco la specifica da duplicare, quindi fai clic sul pulsante Duplicate in basso a sinistra nell'elenco delle specifiche. Verrà creata una nuova specifica, inizialmente denominata
<OriginalSpecificationName>(Copy)e con gli stessi vincoli di quella originale, pronta per essere modificata sul lato destro della finestra di dialogo. Apporta le modifiche necessarie e fai clic sul pulsante Save in alto per creare la specifica, oppure fai clic su Cancel per uscire senza crearla. -
Per modificare una specifica definita dall'utente, selezionala nell'elenco e fai clic sul pulsante
sul lato destro della finestra di dialogo. Apporta le modifiche necessarie e fai clic sul pulsante Save in alto per salvarle, oppure fai clic su Cancel per uscire senza applicare alcuna modifica.
-
Per rimuovere una specifica (definita dall'utente o predefinita), selezionala nell'elenco e fai clic sul pulsante
sul lato destro della finestra di dialogo.
- Le specifiche predefinite rimosse possono essere ripristinate facendo clic con il pulsante destro del mouse nell'elenco delle specifiche e selezionando il comando Restore Built-In Spec. Questo comando non influisce sulle specifiche definite dall'utente.
Definizione dei vincoli
Ogni net verrà analizzata per determinare se soddisfa i vincoli specificati. Se è stata selezionata una specifica per la classe di appartenenza, i vincoli sono definiti da tale specifica.
Per esaminare i vincoli attuali di una net/xSignal o di una coppia differenziale, seleziona la scheda Constraints dopo aver espanso la relativa voce.
Fai clic sul valore di un vincolo per modificarlo nella finestra a comparsa visualizzata.
Nota che, se il valore di un vincolo è stato modificato manualmente, nella voce corrispondente verrà visualizzato il messaggio di avviso Custom constraints are used.
Esecuzione di un'analisi
Una volta completata la configurazione, puoi eseguire un'analisi per tutte le net aggiunte, per una classe specifica o per una net specifica. Fai clic sul pulsante Analyze All in alto a destra nel documento SI Analyzer by Keysight per analizzare tutte le net, oppure sul pulsante Analyze nella voce di una classe o net specifica per analizzare solo tale classe/net.
Esame dei risultati
Al termine dell'analisi, i risultati vengono presentati nel documento SI Analyzer by Keysight. Il messaggio Analyzed verrà visualizzato in alto a destra nel documento. Se tutte le net analizzate soddisfano i vincoli, accanto al messaggio verrà visualizzato il testo All Passed. In caso contrario, verrà visualizzato il testo Failed, con il numero di net che non soddisfano i vincoli.
Se tutte le net di una classe superano l'analisi, nella relativa voce verrà visualizzato il testo Success. In caso contrario, verrà visualizzato il testo Failed.
Espandi la voce di una classe per visualizzare i valori calcolati (impedenza, ritardo, perdite di inserzione e perdite di ritorno) per ogni net analizzata della classe. I valori che soddisfano i vincoli sono visualizzati in verde; quelli che non li soddisfano sono visualizzati in rosso.
Espandi la voce di una net per visualizzarne i valori calcolati nella scheda Results. Inoltre, i riquadri degli oggetti della net che non soddisfano i vincoli presentano un bordo rosso nell'area Transmission Line e il valore non conforme viene visualizzato in rosso.
Per visualizzare i risultati dell'analisi per una classe o una net/xSignal/coppia differenziale all'interno del PCB, fai clic sul pulsante Show on PCB associato.
Il pannello SI Analyzer by Keysight
Nell'editor PCB, il processo di analisi e i risultati vengono gestiti tramite il pannello SI Analyzer by Keysight. Tieni presente che il pannello viene aggiunto all'elenco dei pannelli disponibili (tramite il pulsante Panels) dopo aver eseguito un'analisi dell'integrità del segnale e aver fatto clic sul pulsante Show on PCB.
Segnale simulato
- Simulated Signal – consente di selezionare la classe o la net/xSignal/coppia differenziale da visualizzare come mappa termica nell'area di progettazione.
- Only nets with violations – quando questa opzione è attiva, nell'elenco a discesa sono disponibili solo le entità che presentano attualmente una violazione. Deseleziona questa opzione per elencare tutte le entità analizzate.
- Show Heatmap – quando questa opzione è attiva, nell'area di progettazione viene visualizzata una mappa termica per l'entità attualmente selezionata nell'elenco a discesa Simulated Signal.
Sotto questi controlli, il pannello presenta due schede, General e Heatmap. Le opzioni di queste schede si applicano all'entità attualmente selezionata nell'elenco a discesa Simulated Signal.
Mappa termica
La scheda Heatmap del pannello SI Analyzer by Keysight consente di controllare quali dati vengono rappresentati come mappa termica, impedenza o ritardo, e come viene applicato il colore all'impedenza/al ritardo. Tieni presente che questi controlli delle impostazioni della mappa termica sono disponibili solo quando l'opzione Show Heatmap è abilitata.
Usa i pulsanti Impedance e Delay per passare da una modalità all'altra. L'intera net viene colorata per rappresentare l'impedenza/il ritardo in ogni suo punto, come segue:
- Per l'impedenza, quanto più il valore è vicino al valore target Z0, tanto più il colore tende al verde; quanto più si discosta dal valore target Z0, tanto più il colore tende al rosso. I valori calcolati inferiori al minimo e superiori al massimo vengono visualizzati in rosso.
- Per il ritardo, quanto maggiore è il valore, tanto più caldo (rosso) è il colore; quanto minore è il valore, tanto più freddo è il colore. I valori calcolati inferiori al minimo vengono visualizzati in blu, mentre quelli superiori al massimo vengono visualizzati in rosso.
La scala cromatica indica come viene applicato il colore. I valori minimo e massimo possono essere regolati facendo clic e trascinando il cursore oppure inserendo un nuovo valore nei campi sottostanti. La scala viene visualizzata anche come barra colorata nell'area di progettazione, sotto il PCB.
Abilita l'opzione Color focus on results per evidenziare l'entità attualmente selezionata nell'elenco a discesa Simulated Signal ed escludere dalla visualizzazione gli altri oggetti del PCB.

Un esempio di mappa termica per i calcoli dell'impedenza.

Un esempio di mappa termica per i calcoli del ritardo.
Rilevamento delle violazioni
Se l'analisi rileva violazioni dei vincoli per l'entità attualmente selezionata nell'elenco a discesa Simulated Signal, queste vengono elencate nella sezione Violations della scheda General del pannello SI Analyzer by Keysight.
- Usa i pulsanti nella parte superiore della sezione per definire quali tipi di violazione visualizzare nell'elenco.
- Usa il pulsante Analyze nella parte inferiore della sezione per eseguire nuovamente l'analisi SI. Questo consente di verificare rapidamente se l'entità soddisfa il vincolo dopo aver applicato modifiche nell'editor PCB, senza tornare al documento SI Analyzer by Keysight.
Sonde
La sezione Probes del pannello SI Analyzer by Keysight consente di posizionare sonde di misura direttamente sul PCB. Le sonde possono misurare l'impedenza o il ritardo; il tipo di misura è determinato dalla modalità corrente della mappa termica della scheda.
Le sonde possono essere singole, per misurare un valore assoluto nel punto di posizionamento, oppure differenziali, per misurare la differenza tra due punti. Entrambi i tipi di sonda vengono posizionati facendo clic sul pulsante Add nella sezione Probes del pannello. Per posizionare una sonda singola, fai clic nel punto desiderato, quindi fai clic con il pulsante destro del mouse (oppure premi Esc). Per posizionare una sonda differenziale, fai clic una volta per definire il primo punto, quindi una seconda volta per definire il secondo punto. Una volta definita una sonda, i risultati della misura verranno visualizzati nel pannello.

Un esempio di sonda differenziale
Fai clic sulla voce di una sonda nel pannello per visualizzarne la posizione o le posizioni sul PCB. Seleziona la voce di una sonda nel pannello e fai clic sul pulsante
nella parte inferiore della sezione per rimuoverla.
Fai clic sul pulsante Add to Report per creare un'immagine del PCB nella posizione della sonda selezionata. L'immagine verrà visualizzata nella sezione Image Captures del pannello, contrassegnata da un indicatore Probe. Passa il cursore sulla schermata acquisita per visualizzare i dettagli della sonda.
Acquisizione di immagini
La funzione di acquisizione delle immagini del pannello SI Analyzer by Keysight consente di acquisire una schermata specifica del progetto, che può poi essere inclusa in un report.
Per acquisire un'immagine di un'area specifica della scheda, regola innanzitutto la vista della scheda nell'area di progettazione in modo che siano visibili gli elementi da includere nell'acquisizione. Quando sei pronto, fai clic sul pulsante Add nella sezione Image Captures del pannello per acquisire la schermata. Puoi continuare a modificare la vista della scheda e aggiungere altre immagini.
Per eliminare un'immagine, passa il cursore sull'immagine per visualizzare il pulsante
, quindi fai clic su di esso per eliminarla.
Creazione del report dei risultati
Per generare un report completo dell'analisi, fai clic sul pulsante Full Report nella parte superiore del documento SI Analyzer by Keysight. Il report completo include una sezione per ogni classe (e la voce All Nets per le net aggiunte singolarmente al di fuori delle classi di net).
Nel report completo, fai clic sul nome di una classe di net (o sul nome della net nell'elenco All Nets) per visualizzarne un report dettagliato, che include:
- Nome della classe di net o della net.
- Specifiche assegnate.
- Riepilogo della verifica dei vincoli. Fai clic su una voce relativa a una verifica non superata per visualizzare i suggerimenti per risolvere i problemi correlati.
- Stackup dei layer della scheda.
- Verifiche dei vincoli per ciascuna net. Espandi la voce di una net per visualizzare le verifiche dei vincoli per ciascun oggetto di questa net.
- Grafico delle perdite di inserzione.
- Grafico delle perdite di ritorno.
Durante l'esplorazione di un report dettagliato, fai clic sul pulsante Show on PCB per aprire il PCB e sul pannello SI Analyzer by Keysight per esplorare la classe/net.
Lavorare con i grafici
I grafici delle perdite di inserzione e delle perdite di ritorno mostrano le forme d'onda corrispondenti per ciascuna net della classe in esame. L'area rossa sul grafico indica la zona non consentita definita dai vincoli.
-
Usa il menu a discesa in alto a destra del grafico delle perdite di inserzione o delle perdite di ritorno per gestire le net visualizzate nel grafico. Puoi visualizzare tutte le net, quelle che non hanno superato le verifiche oppure net specifiche.
-
Fai clic sul nome di una forma d'onda a destra del grafico per evidenziarla attenuando le altre forme d'onda. Fai nuovamente clic sul nome di una forma d'onda per rimuovere l'evidenziazione.
-
Scorri la rotellina del mouse per ingrandire o ridurre il grafico rispetto alla posizione del puntatore. Quando il puntatore del mouse si trova su un asse del grafico, scorri la rotellina per ingrandire o ridurre rispetto alla posizione del puntatore solo su quell'asse (la scala dell'altro asse non cambierà).
-
È possibile effettuare misurazioni dei dati utilizzando i cursori di misura. Sono disponibili due cursori, che possono essere aggiunti alla stessa forma d'onda o a forme d'onda diverse su un grafico. Fai clic con il pulsante destro del mouse sul nome di una forma d'onda a destra del grafico e usa i comandi Cursor A e Cursor B del menu contestuale per attivare/disattivare i cursori. Sposta il cursore facendo clic sulla relativa linguetta e trascinandola. I dati misurati per un cursore attivo sono visualizzati nella parte inferiore del grafico.

Un esempio dei cursori A e B aggiunti alla stessa forma d'onda.
Esportazione del report
Fai clic sul pulsante Save Report per salvare il report in formato HTML. Usa la successiva finestra di dialogo Report Settings per configurare quali net (quando si accede alla finestra di dialogo dal report completo) e quali dati specifici includere nel report.
Dopo aver fatto clic sul pulsante Generate Report, il report viene salvato in una sottocartella della cartella del progetto denominata \SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime>. Tutte le immagini del report vengono salvate in una sottocartella \Images.
).
).

).
. Se una net fa parte di una coppia differenziale, verrà aggiunta al documento SI Analyzer by Keysight come coppia differenziale, insieme alla net complementare, e la relativa voce presenterà l'icona
.













