Acquisizione della progettazione logica del sistema

A colpo d'occhio

Scopri come acquisire il progetto logico di un sistema multischeda in Altium Designer collegando i progetti PCB figli ai moduli di uno schema multischeda. Questo articolo spiega come preparare i connettori per la connettività a livello di sistema, definire le sorgenti e le proprietà dei moduli e importare i dati dei pin e delle net dei connettori per popolare le voci dei moduli. Continua a leggere per iniziare a creare una rappresentazione chiara delle connessioni tra le schede del tuo sistema.

- Comprendi i passaggi per creare uno schema multischeda e collegare i moduli ai progetti PCB figli.
- Scopri come il parametro `System:Connector` identifica i connettori da includere nel progetto a livello di sistema.
- Scopri come convalidare i progetti PCB figli e importare i relativi dati di connettività nelle voci dei moduli.
Approfondisci con l'IA:

I passaggi essenziali per creare uno schema di sistema multi-scheda a partire dai progetti PCB figli sono:

  1. Creare un progetto multi-scheda e aggiungervi un documento schematico multi-scheda.

  2. Posizionare blocchi grafici (moduli) nello schema multi-scheda per rappresentare logicamente i progetti PCB figli.

  3. Collegare ciascun modulo al progetto figlio corrispondente.

  4. Importare i dati di connettività dei progetti figli nel progetto multi-scheda.

  5. Aggiungere connessioni tra i moduli per creare il progetto logico del sistema.

Per aggiungere un documento schematico multi-scheda (*.MbsDoc) al progetto multi-scheda, fare clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects, quindi selezionare Add New to Project » Multi-board Schematic dal menu contestuale.

Ogni progetto multi-scheda può includere un solo documento schematico multi-scheda.

Abilitazione dei progetti PCB per la progettazione multi-scheda

I progetti PCB di Altium Designer che rappresentano le schede figlie in un progetto multi-scheda contengono connessioni specifiche, come connettori a bordo scheda o connettori a pin maschio/femmina, che costituiscono l'interfaccia elettrica e fisica verso gli altri PCB del sistema.

Queste connessioni e le relative net elettriche devono essere rilevate ed elaborate da un documento schematico multi-scheda (logico) per definire la connettività tra le schede nel progetto a livello di sistema. Questa funzionalità è abilitata dalla presenza di un parametro specifico nei componenti connettore del progetto PCB: un parametro denominato System, con Connector come valore del parametro.

I connettori con la coppia Parametro:Valore System:Connector vengono rilevati quando ciascun modulo a livello di sistema viene sincronizzato con il relativo progetto PCB figlio tramite il comando Import from Child Projects. Questo aspetto è illustrato nella successiva sezione Rappresentazione dei progetti PCB figli nello schema multi-scheda.

Per ogni connettore di un progetto PCB destinato a un'interconnessione a livello di sistema, selezionare il componente connettore, quindi aggiungere il parametro speciale del componente all'elenco nell'area Parameters della scheda General del pannello Properties, con il componente selezionato.

Per ulteriori informazioni sulle proprietà dei componenti, consultare la pagina Lavorare con i componenti posizionati.

La presenza del parametro denominato System, con valore Connector, collega questo connettore PCB allo schema multi-scheda.
La presenza del parametro denominato System, con valore Connector, collega questo connettore PCB allo schema multi-scheda.

Rappresentazione dei progetti figli nello schema multi-scheda

La connettività tra i progetti PCB che compongono un progetto multi-scheda viene definita posizionando blocchi rappresentativi (moduli) sullo schema e collegando tra loro i connettori esposti (ingressi dei moduli) mediante connessioni.

I moduli, che rappresentano i progetti PCB figli e i PCB specifici al loro interno, vengono posizionati nello spazio di progettazione dal menu Place » Module.

Per definire l'origine di un modulo posizionato, selezionarlo nello spazio di progettazione e, nel pannello Properties, utilizzare il pulsante  associato al campo Project nell'area Source della scheda General per aprire la finestra di dialogo Choose Project (una variante della finestra di dialogo Open Project), da cui è possibile individuare e selezionare un progetto PCB o multi-scheda come origine del modulo. Una volta scelto il progetto richiesto, selezionare il PCB o l'assieme multi-scheda desiderato all'interno del progetto utilizzando il menu a discesa Assembly/Board.

Un progetto multi-scheda configurato presenta una struttura gerarchica dei documenti che comprende i documenti sorgente e i sottoprogetti figli collegati ai moduli nello schema di sistema. La struttura di un progetto figlio viene aggiunta immediatamente al progetto multi-scheda quando un modulo del progetto di sistema viene collegato a tale progetto esterno. Espandere la struttura del progetto nel pannello Projects per visualizzare i file che compongono il progetto multi-scheda e i relativi progetti figli.

Per garantire che il progetto multi-scheda estragga ed elabori i dati corretti dai propri sottoprogetti, il PCB di ciascun progetto deve essere sincronizzato con il relativo schema e privo di errori di progettazione o di disegno. Per convalidare un sottoprogetto PCB, fare clic con il pulsante destro del mouse sul suo nome nel pannello e selezionare il comando Validate PCB Project <ProjectName>.PrjPcb: eventuali problemi verranno elencati nel pannello Messages.

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • È possibile aggiungere un progetto PCB, un altro progetto multi-scheda o un progetto di cablaggio alla struttura del progetto multi-scheda facendo clic con il pulsante destro del mouse sulla voce di quest'ultimo nel pannello Projects, selezionando il comando Add Existing to Project, quindi individuando e selezionando il file locale *.PrjPcb, *.PrjMbd o *.PrjHar corrispondente. Se un progetto PCB o di cablaggio da includere nel progetto multi-scheda è già aperto in Altium Designer, è possibile trascinarne la voce nel pannello Projects sulla voce del progetto multi-scheda padre, aggiungendolo alla relativa struttura (). Successivamente, posizionare manualmente un nuovo modulo nel documento schematico multi-scheda (del progetto multi-scheda padre) e, con il modulo selezionato, scegliere come origine del modulo il progetto PCB figlio (e il relativo documento PCB) oppure il progetto multi-scheda figlio (e il relativo documento di assieme multi-scheda) dal menu a discesa del campo Source nel pannello Properties (). Il progetto di cablaggio può essere sincronizzato con il progetto multi-scheda (per ulteriori informazioni, consultare la pagina Definizione dello schema di cablaggio).

  • Per rimuovere un progetto PCB o multi-scheda figlio dalla struttura del progetto multi-scheda padre, rimuovere dal documento schematico multi-scheda di quest'ultimo tutti i moduli che fanno riferimento a tale progetto figlio. Il progetto figlio verrà quindi rimosso automaticamente dalla struttura.

  • È inoltre possibile rimuovere un progetto PCB o di cablaggio figlio dalla struttura del progetto multi-scheda padre trascinando la voce del progetto figlio all'esterno della struttura del progetto multi-scheda. Si noti che in questo caso, e solo per i progetti PCB, i moduli che fanno riferimento al progetto figlio rimarranno nel documento schematico multi-scheda, così come i collegamenti da questi moduli al progetto figlio. Per eliminare completamente dal progetto multi-scheda padre ogni riferimento al progetto figlio rimosso, rimuovere manualmente questi moduli.

Utilizzare il pannello Properties con un modulo posizionato selezionato per definirne le altre proprietà:

  • Utilizzare le proprietà Designator e Title nell'area Properties della scheda General del pannello per specificare, rispettivamente, l'identificatore schematico del modulo e la stringa del titolo. Utilizzare il pulsante  a destra del campo corrispondente per attivarne o disattivarne la visibilità nello schema multi-board e il pulsante  per abilitare o disabilitare la modifica del valore. Utilizzare i controlli del carattere e Other per configurare il carattere della stringa, la sua posizione nel documento e, per la stringa del titolo, la visibilità del nome del parametro.

  • La tabella nell'area Entries della scheda General del pannello Properties, quando il modulo è selezionato, verrà popolata quando verranno aggiunte le porte al modulo – vedere di seguito.

  • Utilizzare i controlli nell'area Graphical della scheda General del pannello per configurare l'aspetto del modulo: le dimensioni (larghezza e altezza), lo spessore, lo stile e il colore della linea del contorno del modulo e il colore di riempimento. Le opzioni disponibili per lo spessore e lo stile della linea sono definite nell'area Line Styles del pannello Properties quando nessun oggetto è selezionato nell'area di progettazione. Per ulteriori informazioni, consultare la pagina Configurazione di un documento schematico multi-board.

  • Utilizzare i controlli nella scheda Parameters del pannello per aggiungere, modificare e rimuovere i parametri del modulo e configurarne la visibilità nell'area di progettazione.  

Aggiungere altri moduli e i relativi collegamenti ai progetti secondari allo schema multi-board, secondo le esigenze del progetto di sistema completo.

I moduli vengono popolati con i dati di progettazione dei progetti collegati importando i dati dei progetti tramite i seguenti comandi dei menu principali o del menu contestuale dell'area di progettazione:

  • Design » Import From Child Projects – propaga i dati di progettazione di tutti i progetti sorgente (secondari) nei rispettivi moduli.

  • Design » Import From Selected Child Projects – propaga i dati di progettazione dei progetti sorgente (secondari) corrispondenti ai moduli attualmente selezionati.

In particolare, questa operazione elabora i dati dei pin e delle net di ciascun connettore dei progetti secondari a cui è associato lo speciale parametro System:Connector (vedere i dettagli sopra). Al termine dell'importazione, per ciascuno di questi connettori viene creata automaticamente una porta sul blocco grafico del rispettivo modulo. La porta del connettore è associata attivamente ai pin e alle net del connettore nel progetto secondario. Selezionare la rappresentazione grafica di una porta del modulo nell'area di progettazione per visualizzarne i dettagli, come i pin e le net del connettore, nel pannello Properties. Finché non viene collegata alla porta di un altro modulo, l'elenco dei componenti/pin della porta nel pannello mostrerà il connettore e i pin come non accoppiati.

 
  • Sebbene le porte vengano posizionate automaticamente durante l'importazione dei dati dai progetti secondari, è possibile posizionare una porta del modulo anche manualmente, selezionando il comando Place » Entry dai menu principali.

  • Selezionare una porta del modulo facendo clic sulla sua rappresentazione grafica, quindi trascinarla lungo il perimetro del modulo fino a una posizione appropriata. Si noti che il designatore della porta può essere trascinato indipendentemente in una posizione diversa.

  • È inoltre possibile spostare un gruppo di porte del modulo selezionando più porte e trascinando il gruppo nella posizione desiderata.

  • La colorazione della porta ne facilita lo spostamento e il posizionamento corretti. Quando si trova all'esterno di un modulo, la porta viene visualizzata parzialmente e in grigio e non può essere posizionata. Quando si trova sopra un modulo, la porta viene visualizzata per intero e a colori, indicando che può essere posizionata in quel punto.

Utilizzare il pannello Properties con una porta selezionata per definirne le proprietà:

  • Utilizzare i controlli nell'area Properties della scheda General del pannello per modificare il valore, la visibilità e lo stile di Designator della porta e scegliere Type della porta (Male/Female). In quest'area del pannello sono riportati anche il numero di pin del connettore della porta (Number of Pins) e il numero identificativo assegnato a questa porta nel modulo principale (Entry Number).

  • Abilitare l'opzione System Entry per contrassegnare la porta come connessione a livello di sistema non collegata a un altro modulo, ad esempio una porta che rappresenta una presa di ingresso dell'alimentazione.

    Un progetto multi-board secondario contiene un modulo la cui porta ha l'opzione System Entry abilitata.

    Quando le modifiche vengono importate nel progetto multi-board principale, questo connettore della porta verrà aggiunto come porta del modulo del progetto secondario.

     
  • Quando la porta viene collegata tramite una connessione con cablaggio o cavo (ulteriori informazioni), l'area Mated Component del pannello viene popolata con i dati del componente accoppiato.

  • Nell'area Mated Pins regione del pannello, la colonna Pin elenca i singoli pin del connettore e le net associate. Una volta collegata questa porta, la colonna Mated Pin viene compilata con un elenco dei pin accoppiati. Inoltre, una volta collegata questa porta, la scheda Addresses del pannello Properties viene compilata con un elenco tabellare dei percorsi di connessione e delle net della porta (scopri di più).

  • Utilizza i controlli nella scheda Parameters del pannello per aggiungere, modificare e rimuovere i parametri della porta e configurarne la visibilità nell'area di progettazione.

Quando si aggiungono porte a un modulo, la tabella nella regione Entries della scheda General del pannello Properties, quando il modulo è selezionato, viene compilata con le porte. La colonna Part(s) elenca ogni porta del modulo riportando il designatore e il nome del connettore della porta nel progetto sorgente. Questi dati possono essere modificati per comodità: la denominazione è locale al progetto multi-board e non influisce sui progetti figli sorgente.

  • La colonna Mated part(s) viene compilata con i dati una volta che la porta viene collegata a un'altra porta del progetto multi-board tramite una connessione. Per ulteriori informazioni, consulta la pagina Lavorare con le connessioni.

  • Dall'elenco puoi attivare o disattivare rapidamente la visibilità del designatore della porta (  /  ) e cambiarne il tipo (  /  ). Utilizza i pulsanti  e  rispettivamente per aggiungere una nuova porta non definita al modulo e all'elenco e per rimuovere dal modulo la porta selezionata nell'elenco.

  • Utilizza i pulsanti  e  rispettivamente per dividere la connessione selezionata nell'elenco in due porte di modulo correlate e per riunire le porte precedentemente divise in un'unica porta. Per ulteriori informazioni, consulta la pagina Lavorare con le connessioni.

Supporto per periferiche/componenti esterni

Questa funzionalità è disponibile quando le opzioni MBS.PlacePart e MBS.UseGeometryMaker sono abilitate nella finestra di dialogo Impostazioni avanzate.

Il documento schematico multi-board supporta periferiche/componenti esterni che non fanno parte dei normali assiemi PCB figli (ovvero componenti “non PCB”). Tra questi possono rientrare, ad esempio, interruttori esterni, sensori e qualsiasi altro modulo elettronico commerciale di terze parti. Questa funzionalità è resa possibile dal supporto di due tipi di oggetto:

  • Custom Part – un'entità simile a un modulo che consente di collegare uno o più componenti di libreria e che viene aggiunta al documento schematico multi-board utilizzando il comando Place » Custom Part dei menu principali. Quando la parte personalizzata posizionata è selezionata nell'area di progettazione, utilizza la regione Linked Components del pannello Properties per aggiungere e rimuovere componenti dalla parte personalizzata mediante i pulsanti  e , rispettivamente. Se l'elenco dei componenti collegati include componenti del Workspace non aggiornati, fai clic sul pulsante  per aggiornare i componenti alle revisioni più recenti. Viene aggiunta automaticamente una porta per ogni componente collegato.

  • Custom Connection – consente di aggiungere un singolo componente di libreria al documento schematico multi-board trascinando il componente desiderato dal pannello Components in uno spazio libero del foglio. Viene aggiunta automaticamente una porta per ogni pin del componente.

    Puoi anche creare un simbolo personalizzato per un componente specificamente destinato all'uso con un documento schematico multi-board. Aggiungendo nomi separati da virgole al campo Name delle proprietà di un pin, puoi raggruppare più pin in porte, creando così simboli visivamente più puliti con meno porte e semplificando notevolmente il collegamento di questi componenti.

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    Durante la modifica di un simbolo schematico, aggiungi più nomi separati da virgole al campo Name di un pin.

    Quando il componente viene aggiunto a una parte personalizzata in uno schema multi-board, viene creata una porta per ogni pin del componente anziché un'unica porta per il componente, e vengono create porte con più pin.

    Quando il componente viene posizionato in uno schema multi-board come connessione personalizzata, vengono create porte con più pin.

I componenti di libreria sono quelli disponibili nel Workspace connesso e nelle librerie locali disponibili. Una volta posizionati/definiti, puoi collegare i componenti al resto del progetto, ad esempio utilizzando connessioni tramite cavi e cablaggi.

I componenti collegati definiti tramite parti personalizzate e/o connessioni personalizzate non vengono inclusi automaticamente nella distinta base complessiva del prodotto/sistema e non vengono visualizzati nell'assieme multi-board (*.MbaDoc).

Cross-probing

I comandi di cross-probing disponibili nel menu principale Design e nel menu contestuale dell'area di progettazione consentono di passare rapidamente dal documento schematico multi-board agli elementi correlati nei progetti figli.

  • Per eseguire il cross-probing dal modulo o dalla porta attualmente selezionati al documento PCB o al connettore su tale documento all'interno del progetto PCB a cui fa riferimento il modulo, utilizza il comando Design » Crossprobe to PCB/Multi-board. Se il modulo fa riferimento a un documento di assieme multi-board (*.MbaDoc) all'interno di un progetto multi-board sorgente (*.PrjMbd), il cross-probing verrà eseguito verso il documento di assieme multi-board.

  • Per eseguire il cross-probing dal modulo o dalla porta attualmente selezionati allo schema di livello superiore o al connettore sul relativo schema all'interno del progetto PCB a cui fa riferimento il modulo, utilizza il comando Design » Crossprobe to Schematic.

  • Per eseguire il cross-probing dal modulo o dalla porta attualmente selezionati alla scheda, o al connettore su tale scheda, nel documento di assieme multi-board (*.MbaDoc) all'interno del progetto multi-board (*.PrjMbd), utilizza il comando Design » Crossprobe to MBA.

  • Per eseguire il cross-probing dalla connessione di cablaggio attualmente selezionata nel documento schematico multi-board (*.MbsDoc) a un progetto di cablaggio collegato (*.PrjHar), utilizza il comando Design » Crossprobe to Harness. Si aprirà il documento dello schema di cablaggio del progetto di cablaggio associato.

Quando si esegue il cross-probing da una porta di modulo, gli oggetti individuati nel documento schematico/PCB di destinazione vengono visualizzati in base alle opzioni Highlight Methods definite nella pagina Sistema – Navigazione di Preferences finestra di dialogo. L'evidenziazione non verrà applicata al documento schematico multi-board.

Stampa o esportazione in PDF

Per stampare il documento schematico multi-board attualmente attivo, selezionare File » Print dal menu principale (scorciatoia: Ctrl+P). Si aprirà la finestra di dialogo Print . Sul lato sinistro della finestra di dialogo è disponibile un'anteprima di stampa scalabile. Sul lato destro sono disponibili le opzioni di stampa standard. Queste consentono di specificare una stampante, verificarne la posizione, visualizzare il numero di documenti attualmente nella coda di stampa, impostare il numero di copie da stampare, il formato della pagina e l'orientamento. Dopo aver fatto clic su , i documenti da stampare verranno inviati alla stampante selezionata, in base alle opzioni definite.

La finestra di dialogo Print
La finestra di dialogo Print

Per esportare un documento schematico multi-board in un file PDF, selezionare File » Export to PDF dal menu principale.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents