Lavorare con i componenti posizionati
A colpo d'occhio
- Scopri da dove provengono i componenti, come vengono gestite le parti e i componenti multiparte e quali sono i principali metodi per posizionarli su uno schema elettrico.
- Scopri come cercare i componenti in modo più efficiente e apportare rapide modifiche grafiche durante o dopo il posizionamento.
- Comprendi la relazione tra i componenti dello schema e quelli del PCB e quali proprietà principali puoi esaminare o modificare dopo il posizionamento.
Un componente all'interno di una libreria rappresenta il dispositivo fisico che viene posizionato sul circuito stampato effettivo. Su un foglio schematico, un componente è rappresentato dal modello del suo simbolo schematico. Ogni componente può contenere una o più parti.
Parte

La parte rappresenta il componente elettronico fisico effettivo.
Panoramica
Una parte è una primitiva di progettazione elettrica. È un simbolo schematico che rappresenta un dispositivo elettronico, come un resistore, un interruttore, un amplificatore operazionale, un regolatore di tensione, ecc. Le parti sono memorizzate all'interno dei componenti nelle librerie di componenti schematici. Si noti che ogni componente può contenere una o più parti. Oltre a una rappresentazione simbolica del componente, la parte include anche collegamenti a modelli, come il footprint PCB, e parametri utilizzati per documentare dettagli quali i parametri del componente e le informazioni sul fornitore. Il modo in cui i collegamenti ai modelli e i parametri vengono aggiunti alla parte dipende dal tipo di archiviazione della libreria utilizzato.
Disponibilità
Le parti possono essere posizionate sia nell'editor schematico sia nell'editor delle librerie schematiche.
- Nell'editor schematico, fare clic su Place » Part.
- Fare clic con il pulsante destro del mouse nell'area di progettazione, quindi scegliere Place » Part dal menu contestuale.
- Nel pannello Components, fare clic con il pulsante destro del mouse su un componente e selezionare Place <ComponentName>.
- Dal pannello Components, selezionare un componente generico come segnaposto.
- Trascinare un componente dal pannello Components.
- Selezionare il pulsante Place nel riquadro Details del pannello Components, oppure utilizzare il tasto di scelta rapida Enter.
- Dal pannello SCH Library, nell'editor delle librerie schematiche, selezionare un componente, quindi fare clic su Place.
Posizionamento dal pannello Components
Nell'editor schematico, è possibile selezionare e posizionare le parti dal pannello Components.
- Il pannello visualizza il contenuto della libreria attualmente selezionata. Utilizzare il menu a discesa accanto al nome della libreria per scegliere un'altra libreria.
- Utilizzare il campo del filtro sotto il campo della libreria attualmente selezionata per filtrare l'elenco e velocizzare la ricerca, oppure scorrere l'elenco e selezionare la parte desiderata.
- Fare clic su Place, fare doppio clic oppure fare clic e trascinare per posizionare il componente selezionato sul foglio schematico attivo. Mentre la parte è agganciata al cursore, prima del posizionamento è possibile ruotarla (premere Spacebar), specchiarla rispetto a un asse (premere X o Y) o modificarla (premere Tab).
- Le colonne visualizzate nell'elenco dei componenti della libreria attualmente selezionata possono essere riordinate (facendo clic e trascinando) o riconfigurate (facendo clic con il pulsante destro del mouse e scegliendo Select Columns).
-
Fare clic sul pulsante
all'interno di un riquadro di componente generico per agganciare il componente al cursore e posizionarlo nel documento schematico attivo. Selezionando il riquadro stesso, si aprirà la categoria di quel tipo di componente nel pannello Components.
Ricerca di un componente
Le opzioni del menu delle librerie non appartenenti a un Workspace consentono di impostare le preferenze, eseguire ricerche e migrare i contenuti delle librerie basate su database e su file. Per accedere a queste opzioni, selezionare il pulsante del menu delle librerie
in alto a destra nel pannello Components.
Selezionare File-based Libraries Preferences per aprire la finestra di dialogo Available File-based Libraries, in cui sono disponibili i controlli per aggiungere o rimuovere librerie, installare librerie e specificare i percorsi di ricerca delle librerie.
L'elenco corrente dei componenti delle librerie basate su database e su file può essere filtrato inserendo una frase di ricerca nel campo Search del pannello Components. Per accedere a funzionalità di ricerca più avanzate per le librerie di componenti, selezionare l'opzione File-based Libraries Search dal menu
del pannello (in alto a destra), che apre la finestra di dialogo File-based Libraries Search. La finestra di dialogo offre opzioni di ricerca flessibili, inclusi vincoli di filtro basati su query, e la possibilità di cercare in tutte le librerie basate su database e su file disponibili oppure in quelle contenute in un percorso specificato.
- L'impostazione di ricerca predefinita Scope prevede la ricerca di Components in Available File-based Libraries.
- In alternativa, la finestra di dialogo supporta anche la ricerca in Libraries on path memorizzati in cartelle su un'unità. Per farlo, abilitare l'opzione Libraries on path e configurare le opzioni Path secondo necessità.
- I Filters utilizzano l'operatore "AND" e, pertanto, è preferibile iniziare con un filtro semplice e, se i risultati sono numerosi, utilizzare la modalità Refine last search per cercare all'interno dei risultati.
- I risultati della ricerca tramite query vengono visualizzati nella finestra di dialogo File-based Libraries Search quando si seleziona Helper.
Posizionamento dall'editor delle librerie schematiche
Una parte può anche essere posizionata direttamente da una libreria aperta nell'editor delle librerie schematiche, tramite il pannello SCH Library. Si noti che:
- Facendo clic sul pulsante Place nel pannello, la parte (componente) selezionata verrà posizionata nell'ultimo foglio schematico attivo.
- Mentre la parte è agganciata al cursore, prima del posizionamento è possibile ruotarla (premere Spacebar), specchiarla rispetto a un asse (premere X o Y) o modificarla (premere Tab). L'azione può essere eseguita anche durante il trascinamento dell'oggetto. La rotazione avviene a incrementi di 90°.
-
Se una parte viene posizionata direttamente da una libreria, non è necessario aggiungere prima tale libreria nella finestra di dialogo Available File-based Libraries.
Modifica grafica
La modifica grafica di una parte è limitata allo spostamento, alla rotazione e alla specchiatura. Quando una parte viene selezionata nell'area di progettazione, attorno a essa compare un riquadro di selezione tratteggiato. Per manipolare graficamente un componente selezionato:
- Premere Delete per rimuovere la parte selezionata dal progetto.
- Fare clic e tenere premuto per spostare la parte selezionata. Il cursore si sposterà sul punto di connessione elettrica più vicino (l'estremità di collegamento del pin più vicino).
- Premere Spacebar per ruotare l'arco in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. L'azione può essere eseguita anche durante il trascinamento dell'oggetto. La rotazione avviene a incrementi di 90°.
- Mentre si sposta una parte agganciata al cursore, premere il tasto X o Y per specchiarla rispetto all'asse corrispondente.
Lavorare tra il componente nello schema e il componente sul PCB
Il software include strumenti che semplificano il lavoro tra il componente nello schema e lo stesso componente sul PCB. Questi strumenti includono il sondaggio incrociato, la selezione incrociata e la selezione dei componenti PCB dallo schema.
Sondaggio incrociato
Come suggerisce il nome, il sondaggio incrociato consente di fare clic su un componente in un editor e passare a quel componente nell'altro editor. Per eseguire il sondaggio incrociato:
- Fai clic su Cross Probe nel menu Tools dell'editor schematico o PCB.
- Quando fai clic sul componente nell'editor schematico, questo verrà centrato e ingrandito nell'editor PCB. Il livello di zoom viene impostato nella pagina Sistema – Navigazione della finestra di dialogo Preferences.
- Il comportamento predefinito prevede di rimanere nello stesso editor, pronti per eseguire il sondaggio incrociato di un altro componente. Per passare all'altro editor durante il sondaggio incrociato, tieni premuto il tasto Ctrl.
Modalità di selezione incrociata
La modalità di selezione incrociata seleziona lo stesso componente nell'altro editor. Nota che non esegue lo zoom né il centraggio. La selezione incrociata può essere attivata o disattivata. Fai clic su Tools » Cross Select Mode per attivare/disattivare la modalità. Per selezionare più componenti, tieni premuto il tasto Shift mentre fai clic per selezionarli.
Selezione dei componenti PCB
Questa funzione consente di selezionare più componenti dello schema in un ordine specifico, quindi di posizionare gli stessi componenti nell'editor PCB nello stesso ordine. Per utilizzare questa funzione:
- Seleziona i componenti nello schema uno alla volta (tieni premuto Shift mentre fai clic per selezionare più componenti).
- Passa all'editor PCB, quindi premi la scorciatoia I, C per avviare il comando Reposition Selected Components. Il comando Reposition Selected Components è disponibile anche nel menu contestuale dopo aver premuto la scorciatoia I.
Proprietà della parte
Scheda Generale
Generale
-
Reuse Block – quando il componente fa parte di un blocco di riutilizzo, questo campo mostra il nome del blocco di riutilizzo padre. Fai clic sul collegamento ipertestuale Reuse Block per visualizzare le proprietà di questo blocco di riutilizzo.
-
Designator – inserisci il designatore. Usa l'icona a forma di occhio per mostrare/nascondere il designatore. Usa l'icona a forma di lucchetto per bloccare/sbloccare il designatore. Scopri di più sul designatore.
-
Comment – inserisci un nome o un commento. Usa l'icona a forma di occhio per mostrare/nascondere il nome. Usa l'icona a forma di lucchetto per bloccare/sbloccare il nome. Il campo Commento può essere utilizzato anche per visualizzare il valore di un parametro definito dall'utente o di sistema. Scopri di più sul commento.
-
Part <x> of Parts – mostra il numero della parte selezionata e il numero totale di parti. Fai clic su
per bloccare/sbloccare i campi, quindi usa il menu a discesa per selezionare il numero della parte associata.
-
Description – la descrizione del componente/della parte.
-
Type – seleziona qui uno dei seguenti tipi di componente per il footprint del componente. I tipi disponibili sono:
-
Standard– componenti che possiedono proprietà elettriche standard, sono sempre sincronizzati tra lo schema e il PCB (il footprint, i pin/le piazzole e le assegnazioni delle net devono tutti corrispondere) e sono inclusi nella distinta base. Un esempio è un componente elettrico standard, come un resistore. -
Mechanical– componenti che non possiedono proprietà elettriche, non sono sincronizzati (devi posizionarli manualmente in entrambi gli editor) e sono inclusi nella distinta base. Un esempio è un dissipatore di calore. -
Graphical– componenti che non possiedono proprietà elettriche, non sono sincronizzati (devi posizionarli manualmente in entrambi gli editor) e not sono inclusi nella distinta base. Un esempio è il logo di un'azienda. -
Net Tie (In BOM)– componenti utilizzati per cortocircuitare tra loro due o più net diverse, sono sempre sincronizzati tra lo schema e il PCB (il footprint, i pin/le piazzole e le assegnazioni delle net devono tutti corrispondere) e sono inclusi nella distinta base. Si differenziano da un componente Standard perché la connettività creata dal rame all'interno del footprint non viene verificata; è proprio questo rame che consente di cortocircuitare le net. Nota: abilita l'opzione Verify Shorting Copper nella finestra di dialogo Verifica delle regole di progettazione per verificare che non vi sia rame non collegato all'interno del componente. -
Net Tie (No BOM)– componenti utilizzati per cortocircuitare tra loro due o più net diverse, sono sempre sincronizzati tra lo schema e il PCB (il footprint, i pin/le piazzole e le assegnazioni delle net devono tutti corrispondere) e not sono inclusi nella distinta base. Si differenziano da un componente Standard perché la connettività creata dal rame all'interno del footprint non viene verificata; è proprio questo rame che consente di cortocircuitare le net. Nota: abilita l'opzione Verify Shorting Copper nella finestra di dialogo Verifica delle regole di progettazione per verificare che non vi sia rame non collegato nel componente. -
Standard (No BOM)– componenti che possiedono proprietà elettriche standard, sono sempre sincronizzati tra lo schema e il PCB (il footprint, i pin/le piazzole e le assegnazioni delle net devono tutti corrispondere) e not sono inclusi nella distinta base. Un esempio è un componente punto di test che desideri escludere dalla distinta base. -
Jumper– componenti utilizzati per includere ponticelli a filo in un progetto PCB, ad esempio su un PCB a singola faccia che non può essere sbrogliato completamente su un solo layer. Per questo tipo di componente, il footprint e i pin del componente sono sincronizzati tra lo schema e il PCB, ma le assegnazioni delle net non lo sono, e il componente è incluso nella distinta base. Oltre a selezionare questa opzione a livello di componente, è necessario impostare il JumperID di entrambe le piazzole del componente sullo stesso valore diverso da zero. I componenti di tipo Jumper non devono necessariamente essere collegati nello schema; devono essere inclusi nello schema solo se sono richiesti nella distinta base. Se non sono richiesti nella distinta base, possono essere posizionati direttamente sul PCB, dove viene impostato Component Type, vengono impostati JumperIDs e viene assegnato manualmente Nets alle piazzole.
-
-
Design Item ID – questo campo riporta il nome del componente selezionato (per un componente del Workspace), il campo chiave scelto definito in Field Settings regione del file DbLib/SVNDbLib (per un componente di una libreria database), oppure il Design Item ID parametro definito per il simbolo del componente (per un componente di una libreria basata su file). Fai clic su
per aprire la finestra di dialogo Sostituisci componente. Questa finestra di dialogo consente di accedere a tutti i dettagli del componente selezionato (parametri, modelli, scelte dei componenti, dati dei fornitori, ecc.), confrontare i componenti e sostituire il componente corrente con un altro, oltre ad altre possibilità. Se viene selezionato un altro componente come sostituto, questo campo visualizzerà il Design Item ID completo del nuovo componente selezionato. Fai clic sul pulsante Validate per visualizzare informazioni sulla posizione del componente. Se si tratta di un componente non appartenente a un Workspace, verrà visualizzato il percorso del file in cui è salvato sul computer. Se si tratta di un componente del Workspace, le informazioni indicheranno semplicemente che il componente è stato trovato.
-
Source – visualizza il nome della libreria di origine del componente. Fai clic su
per cercare e selezionare la libreria desiderata.
-
Revision state – questo campo visualizza lo stato corrente del ciclo di vita della revisione del componente selezionato, con l'icona colorata e il nome dello stato della revisione.
-
Revision status – se la revisione del componente selezionato si trova in uno stato applicabile (consentito per l'uso nei progetti), la voce indicherà se la revisione è la più recente (
Up to date) o meno (Out of date). Se la revisione si trova in uno stato non applicabile (non consentito per l'uso nei progetti), la voce visualizzeràNot applicable. Fai clic sul pulsante
per aggiornare il componente alla revisione più recente.
-
Component issues (solo nel pannello Properties) – se un componente selezionato proveniente dall'Altium 365 Workspace connesso presenta problemi di integrità, questi verranno segnalati dall'icona
(per gli errori) o
(per gli errori irreversibili). Il numero a destra dell'icona indica il numero di problemi rilevati. Fai clic sulla freccia verso il basso a destra del numero per vedere le brevi descrizioni dei problemi.

Un esempio di problemi di integrità della libreria rilevati. -
Supply Chain Data (solo nel pannello Properties) – visualizza le informazioni sulla catena di approvvigionamento relative alla scelta del componente associata:
- Prezzo unitario mediano. Questa voce verrà visualizzata in rosso se non sono disponibili prezzi o se il prezzo = 0.
- Scorte. Questa voce visualizza la somma totale delle scorte disponibili presso i fornitori abilitati nell'ambito della fonte Altium Parts Provider per il tuo Workspace.
-
Barra del ciclo di vita del produttore. Passa il puntatore sulla barra per visualizzare un suggerimento informativo. Può apparire in uno dei quattro stati seguenti:
- Bianco/Grigio = Predefinito, sconosciuto o nessuna informazione
- Verde = Nuovo o in produzione di serie
- Arancione = Non consigliato per nuovi progetti
- Rosso = Obsoleto o a fine vita (EOL)
Posizione
-
(X/Y)
- X (primo campo) – la coordinata X (orizzontale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente dello spazio di progettazione. Modifica il valore per cambiare la posizione X dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; includi le unità quando inserisci un valore espresso in unità diverse da quelle predefinite correnti.
- Y (secondo campo) – la coordinata Y (verticale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente. Modifica il valore per cambiare la posizione Y dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; includi le unità quando inserisci un valore espresso in unità diverse da quelle predefinite correnti.
-
Rotation – utilizza il menu a discesa per selezionare la rotazione. Le opzioni sono
0 Degrees,90 Degrees,180 Degreese270 Degrees.
Parametri
-
Grid – elenca Name e Value dei parametri associati al componente attualmente selezionato. Usa
per bloccare/sbloccare un parametro elencato e impedirne l'aggiornamento. I valori dei parametri possono essere inseriti manualmente oppure selezionati da un menu a discesa che propone valori ricavati da tutti i componenti disponibili di quel tipo. Puoi usare l'icona a forma di occhio per mostrare/nascondere il parametro.
-
Favorites – i parametri contrassegnati come Preferiti vengono visualizzati nell'elenco Parametri, mentre quelli non contrassegnati vengono nascosti. Passa il puntatore a destra del nome di un filtro dei parametri e fai clic sull'icona
per impostare il filtro come Preferito. Per rimuovere un parametro dai Preferiti, fai nuovamente clic sull'icona.
Per visualizzare tutti i parametri nascosti, fai clic sul controllo Show More in fondo all'elenco. Fai clic sul controllo Show Less per visualizzare solo i parametri Preferiti.
-
Font – fai clic sul carattere visualizzato per modificarne lo stile.
-
Other – fai clic per aprire un menu a discesa e modificare le opzioni aggiuntive:
- Show Parameter Name – abilita per mostrare il nome del parametro.
- Allow Synchronization with Database – abilita per sincronizzare con il database. Questa opzione consente di controllare se il commento può essere aggiornato. Per impostazione predefinita, queste opzioni sono abilitate per consentire sempre la sincronizzazione con la libreria/il database di origine. Puoi disabilitare questa opzione per impedire che il commento venga incluso in un processo di aggiornamento.
- (X/Y) – inserisci le coordinate X e Y.
-
Rotation – usa il menu a discesa per selezionare la rotazione. Le opzioni disponibili sono:
0°,90°,180°e270°. - Autoposition – seleziona per abilitare il posizionamento automatico: il parametro viene posizionato automaticamente ogni volta che il componente associato viene ruotato. Disabilita questa opzione per mantenere la posizione del parametro rispetto al componente associato quando quest'ultimo viene ruotato.
-
Add – fai clic per aggiungere un parametro, ad esempio un footprint, un modello o una regola. Fai clic su
per eliminare una voce selezionata dalla griglia. Fai clic su
per modificare il parametro tramite la relativa finestra di dialogo.
Grafica
-
Mode – usa il menu a discesa per selezionare la modalità desiderata. Se non sono disponibili modalità diverse da Normal, questo menu a discesa sarà disabilitato.
- Mirrored – abilita per specchiare la parte.
- Local Colors – abilita l'opzione del colore locale per sostituire i colori di riempimento, delle linee e dei pin del componente schematico con i colori dei riquadri Fill, Lines e Pins, rispettivamente. Disabilita questa opzione per utilizzare i colori predefiniti della libreria.
Scelte dei componenti
Questa sezione fornisce informazioni sulle scelte dei componenti e sui collegamenti ai fornitori assegnati al componente selezionato. Consulta la pagina Aggiunta di informazioni sulla catena di approvvigionamento a un componente per ulteriori dettagli sulle informazioni fornite dalle voci di questa sezione.
Scheda Pin
-
Grid – questa sezione elenca Pins e Names per tutti i pin del componente selezionato. Usa l'icona a forma di occhio per mostrare/nascondere il pin. Usa l'icona a forma di lucchetto per bloccare/sbloccare i pin.
Per un pin multifunzione (un pin con funzioni specificate nel campo Functions della modalità Pin del pannello Proprietà), fai clic nella cella del pin nella colonna Name e seleziona la funzione del pin nel menu a discesa che viene visualizzato. La funzione selezionata verrà mostrata come nome del pin sul foglio schematico.
- Show Full/Show Short - in Show Full vengono visualizzati i nomi estesi completi di tutti i pin elencati; in modalità Show Short viene visualizzato il nome corrente del pin.
-
– quando il pulsante è abilitato (icona del lucchetto chiuso), i pin del componente non possono essere modificati nell'editor degli schemi (ma possono esserlo nell'editor delle librerie schematiche). Disabilita questa opzione per modificare un pin del componente sul foglio dello schema.
-
– fai clic per visualizzare tutti i pin nascosti e le relative proprietà (nomi e numeri), inclusi i pin con la proprietà Show disabilitata nell'Editor dei pin del componente. Nota che, se stai lavorando nell'editor delle librerie schematiche, anche l'opzione View » Show Hidden Pins deve essere abilitata per visualizzare i pin nascosti nell'editor della libreria.
-
– fai clic per aggiungere un pin al componente. Configura il pin nel pannello Properties, quindi fai clic e trascinalo per posizionarlo.
-
– fai clic per eliminare dal componente i pin selezionati.
-
– fai clic per aprire la finestra di dialogo Editor dei pin del componente. La finestra di dialogo offre un modo pratico per visualizzare e modificare tutti i pin del componente attualmente aperto nell'editor delle librerie schematiche oppure del componente selezionato (o di una sua parte) nell'editor degli schemi.
Proprietà dei componenti generici
Componenti generici

Posizionamento di un componente generico dal pannello Components
Quando Altium Designer è connesso a un Workspace, è possibile accedere ai componenti generici disponibili dal pannello Components, dove vengono mostrati quando l'opzione All è selezionata nel riquadro Categories, oppure dal menu a discesa superiore quando il pannello è in modalità compatta. Fai clic sul pulsante
nel riquadro di un componente generico per associare il componente al cursore e posizionarlo nello schema attivo. Selezionando il riquadro stesso, si aprirà la categoria di quel tipo di componente nel pannello Components.
Proprietà dei componenti generici
Generale
- Designator – inserisci il designatore. Usa l'icona dell'occhio per mostrare o nascondere il designatore. Fai clic sull'icona del lucchetto per bloccare o sbloccare il designatore.
- Comment – inserisci il nome. Usa l'icona dell'occhio per mostrare o nascondere il nome.
-
Description – la descrizione del componente o della parte generica.
- Replace – seleziona il pulsante Replace quando il progetto ha raggiunto una fase in cui un componente generico può essere sostituito con un componente fisico specifico utilizzando la finestra di dialogo Sostituisci componente.
Posizione
-
(X/Y)
- X (primo campo) – la coordinata X (orizzontale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente dell'area di progettazione. Modifica il valore per cambiare la posizione X dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite correnti.
- Y (secondo campo) – la coordinata Y (verticale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente. Modifica il valore per cambiare la posizione Y dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite correnti.
- Rotation – usa il menu a discesa per selezionare la rotazione.
Parametri
- Grid – elenca i Name e i Value dei parametri associati al componente attualmente selezionato. Usa l'icona del lucchetto per bloccare o sbloccare un parametro elencato. I valori dei parametri possono essere inseriti manualmente oppure selezionati da un menu a discesa che propone valori ricavati da tutti i componenti disponibili di quel tipo. Puoi usare l'icona dell'occhio per mostrare o nascondere il parametro.
- Font – fai clic sul carattere visualizzato per modificarne lo stile.
-
Other – fai clic per aprire un menu a discesa e modificare altre opzioni:
- Show Parameter Name – abilita per mostrare il nome del parametro.
- Allow Synchronization with Database – abilita per sincronizzare con il database. Questa opzione consente di controllare se il commento può essere aggiornato. Per impostazione predefinita, queste opzioni sono abilitate per consentire sempre la sincronizzazione con la libreria o il database di origine. Puoi disabilitare questa opzione per evitare che quel commento venga incluso in un processo di aggiornamento.
- (X/Y) – inserisci le coordinate X e Y.
- Rotation – usa il menu a discesa per selezionare la rotazione.
- Autoposition – seleziona per abilitare il posizionamento automatico: il parametro viene posizionato automaticamente ogni volta che il componente associato viene ruotato. Disabilita questa opzione per mantenere la posizione del parametro rispetto al componente associato quando quest'ultimo viene ruotato.
Designatore
Il designatore identifica in modo univoco ogni componente del progetto.
Riepilogo
Il campo del designatore è un oggetto parametro figlio di un componente dello schema (parte). Viene utilizzato per identificare in modo univoco ogni parte posizionata e distinguerla da tutte le altre parti posizionate in tutti i fogli dello schema del progetto.
Disponibilità e posizionamento
Il designatore viene posizionato automaticamente quando viene posizionato l'oggetto parte del componente padre. Non è un oggetto di progettazione che puoi posizionare direttamente.
Modifica grafica
La stringa del designatore può essere modificata graficamente utilizzando la modalità di modifica in-place. Per modificare una stringa del designatore direttamente sullo schema, seleziona il designatore trascinando il cursore attorno ad esso, quindi premi Invio.

Esempio di modifica sul posto
Una volta completata la modifica, premi Enter o fai clic al di fuori della stringa per uscire dalla modalità di modifica sul posto.
Modifica non grafica
Ci sono due aspetti da considerare per la modifica del designatore: la modifica del suo valore e la modifica delle sue proprietà di visualizzazione.
Le stringhe del designatore (e del commento) possono essere visualizzate nell'editor delle librerie schematiche; facendo doppio clic su di esse è possibile modificarne le proprietà. L'icona
associata al campo nel pannello Properties consente di mostrare o nascondere il designatore.
Modifica del valore del designatore nell'editor schematico
Il designatore può essere definito nell'editor schematico durante il posizionamento del componente oppure dopo che il componente è stato posizionato su un foglio schematico nel Properties panel.
- Per modificare il designatore durante il posizionamento del componente, premi il tasto Tab mentre il componente è agganciato al cursore. Si aprirà il pannello Properties ; inserisci la stringa desiderata per il designatore. Fai clic sul pulsante di pausa sovrapposto all'area di progettazione per riprendere il posizionamento.
- Continua a posizionare i componenti oppure premi Esc per terminare il posizionamento.
- Premi Spacebar per ruotare l'arco in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. Questa operazione può essere eseguita anche durante il trascinamento dell'oggetto. La rotazione avviene a incrementi di 90°.
- Per modificare il designatore dopo il posizionamento, fai doppio clic sul componente posizionato per aprire il pannello Proprietà , in cui è possibile modificare il designatore.
Modifica delle proprietà di visualizzazione del designatore
L'aspetto della stringa del designatore, inclusi il tipo, la dimensione e il colore del carattere, può essere configurato nella pagina Schema - Impostazioni predefinite della finestra di dialogo Preferences. Queste impostazioni verranno applicate a meno che non siano sovrascritte dalle impostazioni definite nel simbolo del componente nell'editor delle librerie schematiche.
Come fissare la posizione della stringa del designatore
Per impostazione predefinita, il designatore viene posizionato automaticamente quando un componente viene ruotato durante il posizionamento. Se questo comportamento non è desiderato, disattiva l'opzione Autoposition nella finestra di dialogo Preferences (vedi l'immagine precedente), durante la creazione del simbolo oppure dopo aver posizionato il componente su un foglio schematico. Tieni presente che questa operazione classifica il parametro come manual parameter (ossia un parametro posizionato manualmente). I parametri manuali sono identificati da un punto nell'angolo inferiore sinistro del relativo riquadro di selezione.
Note
-
L'editor schematico include una semplice funzione di incremento automatico del designatore, utilizzabile durante il posizionamento di più istanze dello stesso componente. Per utilizzarla, premi Tab mentre il primo componente è agganciato al cursore e inserisci un designatore appropriato, ad esempio
R1. Ai componenti successivi verranno quindi assegnati i designatoriR2,R3e così via. Tieni presente che, quando passi al posizionamento di un tipo di componente diverso, devi premere nuovamente Tab e inserire un prefisso appropriato per il designatore. -
Quando si posizionano componenti costituiti da più parti e si assegna il designatore iniziale come appena descritto, viene assegnato automaticamente un suffisso per la parte, ad esempio
U3A,U3Be così via. Se il designatore iniziale non viene assegnato, tutte le parti avranno lo stesso suffisso. Questo problema viene risolto dal comando Annotation dell'editor schematico. Il suffisso della parte può essere alfabetico o numerico. Per configurarlo, utilizza l'opzione Alpha Numeric Suffix nella pagina Schema - Generale della finestra di dialogo Preferences.
Proprietà del designatore
Posizione
-
(X/Y)
- X (primo campo) - la coordinata X (orizzontale) attuale del punto di riferimento dell'oggetto, rispetto all'origine corrente dell'area di lavoro. Modifica questo valore per cambiare la posizione X dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite.
- Y (secondo campo) - la coordinata Y (verticale) attuale del punto di riferimento dell'oggetto, rispetto all'origine corrente. Modifica questo valore per cambiare la posizione Y dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; specifica le unità quando inserisci un valore con unità diverse da quelle predefinite.
- Rotation - utilizza il menu a discesa per selezionare la rotazione.
Proprietà
- Object - mostra l'oggetto associato.
- Nome - abilita questo campo facendo clic sull'icona di visibilità per aggiungere il prefisso "Designatore:" al valore del designatore stesso. In questo modo si distingue visivamente il valore di testo e si conferma che si tratta di un designatore all'interno del documento schematico.
-
Value - mostra il nome del designatore. Utilizza l'icona a forma di occhio
per mostrare/nascondere il valore.
- Posizionamento automatico - seleziona questa opzione per abilitare il posizionamento automatico, in modo che il testo rimanga nella posizione scelta quando il componente viene spostato e ruotato.
- Blocca parametro - seleziona questa opzione per bloccare il parametro, impedendo la modifica del valore dal pannello Properties o dal documento schematico.
- Consenti sincronizzazione con il database - abilita questa opzione per eseguire la sincronizzazione con il database. Questa opzione consente di controllare se il commento può essere aggiornato. Per impostazione predefinita, queste opzioni sono abilitate per consentire sempre la sincronizzazione con la libreria o il database di origine. Puoi disabilitare questa opzione per escludere il commento dal processo di aggiornamento.
- Carattere - utilizza i controlli per selezionare il tipo, la dimensione e il colore del carattere e applicare gli stili desiderati, come grassetto, corsivo e sottolineatura.
- Allineamento - fai clic sulle frecce per configurare l'allineamento del testo oppure sul cerchio per centrarlo.
- Override Library Primitive (solo nella finestra di dialogo Preferences ) - seleziona questa casella per sovrascrivere le impostazioni delle primitive definite per l'oggetto designatore in una libreria. Pertanto, quando un componente viene posizionato, adotterà le impostazioni delle primitive definite nella finestra di dialogo Preferenze, anziché quelle definite per il componente nella libreria.
Commento
Un commento consente di visualizzare informazioni aggiuntive su un componente.
Riepilogo
Il campo Commento è un oggetto parametro figlio di un componente schematico (parte). Visualizza informazioni aggiuntive sul componente.
Disponibilità e posizionamento
Il commento viene configurato quando viene posizionato l'oggetto parte del componente padre. Non è un oggetto di progettazione che può essere posizionato direttamente.
Modifica grafica
Il commento può essere modificato graficamente utilizzando la cosiddetta modifica in-place. Per modificare un commento direttamente sul posto, fare clic una volta per selezionarlo, attendere un secondo, quindi fare clic una seconda volta per accedere alla modalità di modifica.
Fare clic una volta per selezionare la stringa.
Una volta completata la modifica, premere Enter oppure fare clic al di fuori della stringa per uscire dalla modalità di modifica sul posto.
Modifica non grafica
Per la modifica del commento occorre considerare due aspetti: la modifica del valore del commento e la modifica delle sue proprietà di visualizzazione.
Modifica del commento nell'editor degli schemi
Il commento può essere definito nell'editor degli schemi durante il posizionamento del componente oppure dopo che il componente è stato posizionato su un foglio dello schema, nel campo Comment del pannello Properties.
- Per modificare il commento durante il posizionamento del componente, premere il tasto Tab mentre il componente è agganciato al cursore. Si aprirà il pannello Properties ; immettere il commento desiderato. Fare clic sul pulsante di pausa in sovrimpressione nell'area di progettazione per riprendere il posizionamento del componente.
- Continuare a posizionare i componenti oppure premere Esc per terminare il posizionamento.
- Per modificare il commento dopo il posizionamento, fare doppio clic sul componente posizionato per aprire il pannello Proprietà , in cui è possibile modificare il commento.
Modifica delle proprietà di visualizzazione del commento
L'aspetto dei commenti, che comprende il tipo, la dimensione e il colore del carattere, può essere configurato nella pagina Schema - Impostazioni predefinite della finestra di dialogo Preferences .
Fissare la posizione del commento
Per impostazione predefinita, il commento viene posizionato automaticamente quando un componente viene ruotato durante il posizionamento. Se questo comportamento non è necessario, disabilitare l'opzione Autoposition nella finestra di dialogo Preferences (fare riferimento all'immagine precedente), durante la creazione del simbolo oppure dopo che il componente è stato posizionato su un foglio dello schema. Questa operazione classifica il parametro come manual parameter (ossia un parametro posizionato manualmente). I parametri manuali sono identificati da un punto nell'angolo inferiore sinistro del relativo riquadro di selezione.
Proprietà del commento
Posizione
-
(X/Y)
- X (primo campo) - la coordinata X (orizzontale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente dell'area di progettazione. Modificare questo valore per cambiare la posizione X dell'oggetto. Il valore può essere immesso in unità metriche o imperiali; specificare le unità quando si immette un valore con unità diverse da quelle predefinite correnti.
- Y (secondo campo) - la coordinata Y (verticale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente. Modificare questo valore per cambiare la posizione Y dell'oggetto. Il valore può essere immesso in unità metriche o imperiali; specificare le unità quando si immette un valore con unità diverse da quelle predefinite correnti.
- Rotation - utilizzare il menu a discesa per selezionare la rotazione. Le opzioni disponibili sono: 0 Degrees, 90 Degrees, 180 Degrees e 270 Degrees.
Proprietà
- Componente - visualizza il nome del componente associato. Fare clic sul collegamento Component per aprire il pannello Proprietà della parte, in cui è possibile modificare le opzioni del componente, nonché il commento stesso, definito nel campo Comment di tale pannello.
- Nome - abilitare questo campo facendo clic sull'icona di visibilità per aggiungere il prefisso "Commento:" al valore del commento stesso. In questo modo si distingue visivamente e si conferma che il valore testuale è un commento all'interno del documento schematico.
-
Valore - visualizza il nome del commento stesso. Attivare o disattivare per mostrare/nascondere il valore.
- Posizionamento automatico - selezionare per abilitare il posizionamento automatico, in modo che il testo rimanga nella posizione scelta quando il componente viene spostato e ruotato.
- Blocca parametro - selezionare per bloccare il parametro, impedendo la modifica del valore dal pannello Properties o dal documento schematico.
- Consenti sincronizzazione con il database - abilitare per eseguire la sincronizzazione con il database. Questa opzione consente di controllare se il commento può essere aggiornato. Per impostazione predefinita, l'opzione è abilitata per consentire sempre la sincronizzazione con la libreria/il database di origine. È possibile disabilitarla per escludere il commento dal processo di aggiornamento.
- Carattere - utilizzare i controlli per selezionare il tipo, la dimensione e il colore del carattere e aggiungere eventuali stili desiderati, come grassetto, corsivo e sottolineatura.
- Allineamento - fare clic sulle frecce per configurare l'allineamento del testo o sul cerchio per centrarlo.
- Override Library Primitive (solo nella finestra di dialogo Preferences ) - selezionare questa casella per sovrascrivere le impostazioni delle primitive definite per l'oggetto commento in una libreria. Pertanto, quando un componente viene posizionato, adotterà le impostazioni delle primitive definite nella finestra di dialogo Preferences, anziché quelle definite per il componente nella libreria.
Aggiornamento e sostituzione dei componenti da una libreria
Dopo aver posizionato inizialmente i componenti sui fogli dello schema di un progetto di scheda, occorre disporre di un modo per aggiornare tali istanze dei componenti in base alle modifiche apportate ai rispettivi componenti di origine collegati nel Workspace pertinente. In altre parole, serve un metodo per mantenere il progetto sincronizzato con le entità del Workspace che utilizza.
Ad esempio, un componente potrebbe essere stato salvato nuovamente nel Workspace, magari in seguito a una modifica di un modello figlio. Ciò genera una nuova revisione del componente. L'istanza posizionata di quel componente utilizza ora una revisione precedente e potrebbe essere necessario aggiornarla affinché utilizzi l'ultima revisione. In alternativa, si potrebbe aver deciso di utilizzare un componente completamente diverso e dover semplicemente sostituire il componente esistente nel progetto con un altro.
Sono disponibili diversi metodi per gestire i componenti dopo il loro posizionamento iniziale in un progetto.
Modifica di una singola istanza di componente
Ogni componente posizionato mantiene un collegamento alla revisione del componente nel Workspace. Questa informazione è disponibile nel pannello Properties, quando si consultano le proprietà del componente selezionato.
Ogni istanza posizionata di un componente mantiene un collegamento alla revisione specifica di quel componente nel Workspace.
A questo livello di dettaglio, relativo al singolo componente, l'istanza posizionata può essere:
-
Aggiornata alla revisione più recente del componente esistente, facendo clic sul pulsante
.
Esempio di aggiornamento dello stesso componente alla revisione più recente: passare il puntatore sull'immagine per vedere il risultato.
-
Sostituita con la revisione più recente di un altro componente (sostitutivo) del Workspace o con un componente di una libreria basata su file, facendo clic sul pulsante
a destra del campo Design Item ID. Si aprirà la finestra di dialogo Replace Component, che presenta i componenti del Workspace connesso e delle librerie basate su file disponibili. Il componente corrente viene mostrato in cima all'elenco. Cercare il componente sostitutivo desiderato, selezionarlo, quindi fare clic su OK.
Esempio di sostituzione del componente esistente con un altro componente (alternativo)
La finestra di dialogo Replace Component offre accesso diretto a tutti i componenti disponibili nelle librerie del Workspace e nelle librerie basate su file. La finestra di dialogo offre informazioni complete sul componente selezionato (parametri, modelli, scelte dei componenti, dati dei fornitori, ecc.), il confronto tra componenti e, per i componenti delle librerie del Workspace, una funzione di ricerca parametrica basata su filtri per specificare i parametri del componente desiderato.
Opzioni e controlli della finestra di dialogo Replace Component
- Search - utilizzare la casella di testo di ricerca per cercare manualmente un componente specifico.
-
- fare clic per espandere o comprimere il Categories riquadro, per mostrare determinati tipi di componenti o visualizzare tutti i componenti disponibili. Utilizzare la barra di ricerca sotto il Categories riquadro per cercare manualmente una categoria specifica di componenti o una libreria di componenti basata su file disponibile.
-
- fare clic per accedere a un menu e scegliere tra:
- File-based Libraries Preferences - fare clic per aprire la finestra di dialogo Available File-based Libraries e aggiungere o rimuovere librerie.
- File-based Libraries Search - fare clic per aprire la finestra di dialogo File-based Libraries Search e cercare librerie.
- Refresh - fare clic per aggiornare la finestra di dialogo.
-
- fare clic per aprire/chiudere l'Details area della finestra di dialogo (descritta di seguito).
Filtri
Quando è selezionata una categoria di componenti del Workspace, fare clic sull'icona Filters per aprire l'area Filters, dove è possibile filtrare ulteriormente le categorie selezionate nell'elenco Components . Le opzioni Filters del pannello possono essere adattate alle proprie esigenze selezionando determinati tipi di parametri come Favorites, che vengono quindi spostati in cima all'elenco per la categoria di componenti corrente. Passare il puntatore a destra del nome del filtro di un parametro e fare clic sull'icona per impostare il filtro come preferito. Le impostazioni dei filtri preferiti si applicano e vengono salvate per le singole Categoriesdei componenti.
Componenti
- Name - il nome del componente.
- Description - la descrizione di ciascun componente.
- Footprint - il footprint del componente.
- Results - elenca il numero totale di componenti trovati/elencati nella ricerca.
Dettagli
- Component Revision ID - elenca l'ID della revisione e il prezzo di un determinato componente. Fare clic sull'ID della revisione per aprire il pannello Explorer e ottenere ulteriori informazioni sul componente.
- References - fare clic per aprire le informazioni di riferimento del componente in un browser web. Utilizzare il menu a discesa per accedere a Manufacturer URL o Datasheet.
- Place - fare clic per posizionare il componente selezionato in un documento schematico.
- Component information - elenca le informazioni pertinenti sul componente, inclusi produttore, data di rilascio e informazioni descrittive. Fare clic sul collegamento Show More per visualizzare tutte le informazioni; fare clic su Show Less per comprimerle.
- Models - espandere per visualizzare i modelli forniti. Utilizzare i collegamenti disponibili per visualizzare le varie parti di un singolo modello.
- References - espandere per accedere a Manufacturer URL, Datasheet e Package Specification.
- Part Choices - espandere per visualizzare le scelte dei componenti. Vengono forniti nome, prezzo e descrizione. Viene inoltre elencata la scheda tecnica del componente.
- Where Used - espandere per visualizzare i progetti che utilizzano il componente.
Menu contestuale
- Find Similar Components - fare clic per aprire la finestra di dialogo Find Similar Components, dove è possibile cercare altri componenti con caratteristiche simili.
- Place <component> - fare clic per posizionare il componente nel documento appropriato.
- Edit - fare clic per aprire i documenti della libreria di componenti relativi al componente selezionato.
- Navigate to <revision> - fare clic per aprire il componente selezionato nel pannello Explorer.
- Operations - passare il puntatore per accedere alle funzioni Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL e Full Item History.
- Refresh- fare clic per aggiornare e visualizzare gli aggiornamenti o le modifiche recenti. È anche possibile aggiornare utilizzando la scorciatoia F5.
- Library Report - quando nel riquadro Categories è selezionata una libreria basata su file, fare clic per accedere alla finestra di dialogo Library Report Settings, in cui è possibile utilizzare i controlli disponibili per configurare un report della libreria.
Applicazione di modifiche ai componenti in blocco: Item Manager
Related page: Gestione dei contenuti con Item Manager
La modifica dei singoli componenti è utile, ma diventa presto laboriosa quando si ha a che fare con un numero maggiore di componenti. In questi casi serve un unico punto centralizzato da cui applicare più modifiche in blocco. È qui che entra in gioco Item Manager (Tools » Item Manager).
Il Item Manager è il «centro di comando» per sincronizzare le entità di progettazione del Workspace, posizionate sui fogli schematici, con i contenuti sorgente a cui sono collegate in un Workspace. Rileva ed elenca automaticamente tutti i componenti, indicando se sono entità del Workspace o meno, quindi confronta la revisione dell'Item di ciascun componente del Workspace presente negli schemi con le revisioni disponibili di quel componente nel Workspace. Per ciascuna entità vengono fornite informazioni sull'Item attualmente collegato, in termini di revisione, stato del ciclo di vita e Workspace sorgente in cui risiede.
Hai il pieno controllo su quali di queste entità del Workspace aggiornare e su come farlo. Ad esempio:
- Seleziona una singola voce e aggiornala affinché utilizzi l'ultima revisione dell'Item collegato, oppure scegli di utilizzare l'ultima revisione di un Item completamente diverso.
- Seleziona un gruppo di voci che utilizzano lo stesso Item collegato e aggiornale all'ultima revisione di tale Item, oppure scegli di utilizzare l'ultima revisione di un Item completamente diverso.
Tutte le modifiche proposte vengono visualizzate nel gestore.
Una volta impostate le modifiche desiderate, genera un ordine di modifica tecnica (ECO) ed esamina le azioni che verranno eseguite per implementarle. Se necessario, disabilita le azioni: il controllo è sempre nelle tue mani! Quando sei pronto, esegui l'ECO e le modifiche verranno applicate. In modo rapido ed efficiente, i contenuti del Workspace posizionati nel progetto vengono gestiti con estrema semplicità.
Gli esempi seguenti illustrano l'utilizzo del Item Manager:
- Per aggiornare più componenti affinché utilizzino l'ultima revisione del componente del Workspace esistente.

Aggiorna un gruppo di componenti non aggiornati alle rispettive revisioni più recenti.
- Per sostituire un paio di componenti con l'ultima revisione di un diverso componente del Workspace, scelto tramite la finestra di dialogo Sostituisci componente.

Sostituisci uno o più componenti con un diverso componente del Workspace.
Il Item Manager non solo consente di mantenere i componenti dei progetti sincronizzati con le modifiche ai contenuti sorgente nei Workspace connessi, ma è anche un potente strumento per agevolare la migrazione dei progetti di schede esistenti dall'utilizzo di elementi di progettazione locali a quello di contenuti di progettazione del Workspace. Una volta migrati in un Workspace i componenti del progetto e gli eventuali fogli schematici (device sheet), puoi utilizzare il Item Manager per «sostituire» i componenti e i simboli di foglio esistenti con le corrispondenti versioni appena migrate nel Workspace. In altre parole, dal punto di vista del progetto i componenti rimangono gli stessi, ma cambia la loro sorgente.
Modificare un componente da un BomDoc
Non è raro individuare un problema con un componente durante il controllo del BomDoc e la sua preparazione per l'ordine dei componenti. Ad esempio, il progettista potrebbe aver dimenticato di finalizzare la scelta di un componente, oppure un componente potrebbe essere arrivato a fine vita (EOL) e il progettista potrebbe voler valutare il prezzo e la disponibilità di possibili sostituti. Sebbene sia possibile risolvere il problema tornando allo schema, modificando il componente, selezionando una parte adatta e quindi aggiornando il BomDoc, ActiveBOM consente di eseguire questa operazione direttamente dal BomDoc e poi trasferire la modifica allo schema tramite un ordine di modifica tecnica (ECO).
All'interno del BomDoc, fai clic con il pulsante destro del mouse sui componenti selezionati e scegli il comando Operations » Change <ComponentName>. Si aprirà la finestra di dialogo Sostituisci componente, da cui potrai cercare il componente sostitutivo. Dopo aver trovato il componente sostitutivo desiderato, selezionalo e fai clic su OK. Si aprirà la finestra di dialogo Engineering Change Order, che riporta in dettaglio le modifiche necessarie per sincronizzare lo schema con il BomDoc.

Esempio di sostituzione di un componente direttamente da un BomDoc.
Sostituire un componente generico
Quando un progetto è giunto alla fase in cui un componente generico può essere sostituito con uno specifico componente fisico, apri la finestra di dialogo Sostituisci componente selezionando il pulsante
nel pannello Properties. Questa operazione può essere eseguita anche da Gestione Item o tramite il documento ActiveBOM del progetto.
I valori dei parametri applicati al componente generico (in questo caso, i valori di potenza e resistenza) vengono utilizzati automaticamente come termini di ricerca nella finestra di dialogo Replace Generic Component, consentendo di scegliere un componente sostitutivo adatto dai risultati filtrati. Nell'esempio qui riportato, due voci di componenti soddisfano i criteri di ricerca.
|
Sostituzione di un componente generico tramite il pannello Properties. Sostituzione di un componente generico tramite il pannello Properties. |
Gestire i footprint nell'intero progetto
L'editor degli schemi di Altium Designer include un potente Footprint Manager. Avviabile dal menu Strumenti dell'editor degli schemi (Tools » Footprint Manager), il Footprint Manager consente di esaminare tutti i footprint associati a ciascun componente dell'intero progetto. Il supporto per la selezione multipla semplifica la modifica dell'assegnazione dei footprint per più componenti, la modifica della modalità di collegamento del footprint o la modifica del footprint attualmente assegnato ai componenti che dispongono di più footprint. Il Footprint Manager agevola la verifica e l'individuazione di problemi nelle assegnazioni dei footprint nell'intero progetto ed è particolarmente utile quando si lavora su un progetto preesistente o proveniente da un'altra organizzazione. Le modifiche al progetto vengono applicate tramite il sistema ECO, aggiornando sia lo schema sia il PCB, se necessario.
La finestra di dialogo Footprint Manager presenta un elenco di tutti i componenti presenti in tutti gli schemi sorgente del progetto attivo. Utilizza i controlli disponibili sul lato destro della finestra di dialogo per gestire i footprint disponibili per i componenti del progetto e quelli attualmente in uso. Le funzionalità includono:
- Possibilità di aggiungere, modificare e rimuovere modelli di footprint per uno o più componenti selezionati.
- Copia dei footprint tra componenti.
- Modifica del footprint attualmente assegnato (il footprint che verrà utilizzato per rappresentare un componente nel PCB, tra i vari eventualmente disponibili per quel componente).
- Convalida dei footprint, per verificare che i modelli di footprint siano effettivamente disponibili, in particolare quelli impostati come modello corrente.
Una volta apportate tutte le modifiche necessarie alle assegnazioni dei modelli di footprint, queste vengono implementate tramite un ordine di modifica tecnica standard (Engineering Change Order, ECO). Per farlo, è sufficiente fare clic sul pulsante Accept Changes (Create ECO) in basso a destra nella finestra di dialogo Footprint Manager.
Opzioni e controlli della finestra di dialogo Gestione footprint
Elenco dei componenti
Questo è l'elenco di tutti i componenti presenti nei fogli dello schema del progetto PCB attualmente attivo. Le informazioni includono:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Visualizzazione e modifica dei footprint
Questo è l'elenco dei footprint associati al componente selezionato in Component List. Utilizzare i controlli nella parte inferiore dell'area o i comandi del menu contestuale per gestire i footprint nell'elenco.
Menu contestuale
-
Add - fare clic per aprire la finestra di dialogo Modello PCB e scegliere un nuovo modello di footprint da aggiungere al componente dello schema evidenziato. Non disponibile quando è selezionato un componente gestito.
-
Remove - fare clic per rimuovere il footprint selezionato. Non disponibile quando è selezionato un componente gestito.
-
Edit Footprint - fare clic per aprire la finestra di dialogo Modello PCB. La finestra di dialogo PCB Model definisce quale modello di footprint è collegato al componente dello schema e in quali librerie l'editor degli schemi può cercare il footprint. Non disponibile quando è selezionato un componente gestito.
-
Validate Footprint Paths - fare clic per verificare che il footprint evidenziato sia reperibile nella posizione consentita. Se il footprint non viene trovato, nel campo Found In compare Not Validated . Se il footprint viene convalidato, viene visualizzato il suo percorso completo.
-
Change PCB Library - fare clic per aprire la finestra di dialogo Edit PCB Library e modificare la libreria PCB del footprint selezionato. Questa finestra di dialogo è una versione semplificata della finestra di dialogo PCB Model e consente di accedere alle opzioni PCB Library per definire dove il software può cercare i modelli di footprint.

La finestra di dialogo Edit PCB Library- Any - cerca un modello corrispondente in tutte le librerie disponibili.
- Library name - cerca un modello corrispondente solo nelle librerie disponibili con questo nome.
- Library path - cerca un modello corrispondente solo in una libreria con questo nome, in questa posizione. Digitare manualmente il percorso e il nome della libreria oppure fare clic sul pulsante Choose per aprire la finestra di dialogo di Windows Open, che consente di individuare la libreria desiderata.
- Use footprint from source integrated library, database library, or server - cerca il modello solo nella libreria integrata, nella libreria database o nel server da cui è stato posizionato il componente. La libreria integrata o la libreria database deve essere disponibile oppure, nel caso di un server, è necessario essere connessi a tale server.
-
Copy - fare clic per copiare i dettagli del footprint attualmente selezionato.
-
Paste - fare clic per incollare (aggiungere) i dettagli del footprint copiati nel componente dello schema attualmente selezionato.
-
Select All - fare clic per selezionare tutti i footprint attualmente visibili nell'elenco View and Edit Footprints.
-
Set As Current - fare clic per impostare il footprint selezionato come footprint corrente (contrassegnato da
nella colonna Current ).
-
Add to All Parts - fare clic per aggiungere il footprint selezionato a tutte le altre parti dello stesso componente dello schema (il comando è disponibile solo se il componente selezionato è composto da più parti e per una o più parti del componente non è stato specificato questo footprint).
Controlli aggiuntivi
-
Menu - fare clic per visualizzare un menu con gli stessi controlli del menu contestuale descritto sopra.
-
Add, Remove, Edit, Validate - questi pulsanti eseguono le stesse funzioni delle voci di menu descritte sopra.
-
Accept Changes (Create ECO) - fare clic per accettare le modifiche ai componenti dello schema e ai relativi modelli di footprint collegati e aprire la finestra di dialogo Engineering Change Order. Con la finestra di dialogo ECO è possibile convalidare ed eseguire le modifiche dopo aver esaminato quelle apportate ai valori dei footprint dei corrispondenti componenti dello schema.












