Rilascio in un Workspace
A colpo d'occhio
- Identifica quali set di dati sorgente, di fabbricazione, di assemblaggio, delle varianti e personalizzati includere e come assegnare gli Output Job necessari.
- Comprendi le opzioni di destinazione del rilascio, gli schemi di denominazione degli elementi del Workspace e i controlli per le revisioni di destinazione.
- Segui le fasi del rilascio e scopri in che modo i comandi di rilascio automatico influiscono sulla revisione, sulla generazione dei report e sulla pubblicazione su PLM.
Con la vista Release in Online Mode, il processo di rilascio segue un flusso a fasi; le voci sul lato sinistro della vista consentono di vedere a colpo d'occhio in quale fase ci si trova:
-
Configure Server Release – in questa fase del processo di rilascio si specificano i tipi di dati da generare: dati sorgente (sempre generati), dati di fabbricazione e dati di assemblaggio (per il progetto di base e per ogni variante rilevata).
-
Validate Project – questa fase successiva del processo di rilascio viene eseguita automaticamente quando nei file OutJob assegnati vengono rilevati uno o più report di tipo Validazione. Vengono eseguiti tutti i generatori di output di validazione definiti in un file Output Job assegnato all'elemento dati in fase di rilascio.
-
Generate Data – questa fase successiva del processo di rilascio viene eseguita automaticamente. In questa fase vengono generati tutti gli altri output, definiti nei file OutJob assegnati agli elementi dati inclusi, per produrre i dati da rilasciare nei rispettivi elementi di destinazione nel Workspace.
-
Review Data – una volta superati tutti i controlli di validazione e generati i dati di output, questa fase del processo di rilascio consente di esaminare i dati generati.
-
Upload Data – dopo la conferma del rilascio nella fase precedente, si accede automaticamente a questa fase. Viene semplicemente mostrato l'avanzamento del caricamento dei dati nelle revisioni dei rispettivi elementi dati nel Workspace di destinazione.
-
Execution Report – questa è la fase finale del processo, che fornisce un riepilogo del rilascio. Sono disponibili collegamenti di navigazione per accedere rapidamente alle revisioni degli elementi generate nel pannello Explorer. Se si è effettuato l'accesso a Project Releaser nell'ambito di un processo di rilascio e pubblicazione su un PLM, verrà visualizzato il pulsante
. Fare clic su questo pulsante per proseguire il flusso di lavoro sottostante al processo e pubblicare sul PLM.
-
Publish to PLM – questa fase è presente solo quando il rilascio viene eseguito nell'ambito del relativo processo attivato (per il rilascio e la successiva pubblicazione su un PLM). Si accede automaticamente a questa fase facendo clic sul pulsante
nella fase precedente (oppure direttamente se è stato utilizzato il comando Prepare & Release & Publish to PLM dal menu associato al pulsante Verrà visualizzata la finestra di dialogo Login Credentials. Inserire Username e Password per la propria istanza PLM e selezionare il modello PLM da utilizzare (visualizzato nel formato <PLMInstance>:<PublishingTemplate>).
Fase online 1 – Configurazione del rilascio sul server
In questa fase del processo di rilascio si specificano i tipi di dati da generare. Gli elementi dati che possono essere rilasciati sono:
- Source Data – un'istantanea del progetto sorgente.
- Fabrication Data – i dati necessari al produttore di PCB per realizzare la scheda nuda.
- Assembly Data for the Base Design (no variations) – i dati necessari all'assemblatore per montare tutti i componenti sulla scheda nuda in base a una distinta base, per il progetto di base senza varianti.
-
Assembly Data for Design
Variant n– i dati necessari all'assemblatore per montare i componenti sulla scheda nuda in base a una distinta base, perVariant ndel progetto di base.
Il numero di set di dati di assemblaggio corrisponderà al progetto di base (senza varianti) e a tutte le varianti rilevate definite per quel progetto.

Fase 1 del processo di rilascio del progetto: configurazione di ciò che deve essere incluso nel rilascio (quali dati generare).
L'elemento Source Data è sempre incluso nel rilascio. Gli altri elementi dati possono essere inclusi facoltativamente.
Assegnazione degli Output Job
Per includere gli elementi Fabrication Data e Assembly Data in un rilascio, è necessario assegnare loro almeno un file OutputJob. Se sono presenti file Output Job con nomi che iniziano con le sottostringhe 'fab' e 'ass', tali OutJob verranno assegnati automaticamente rispettivamente alle sezioni Fabrication Data e Assembly Data al primo accesso alla vista Release. In caso contrario, sarà necessario assegnare manualmente gli OutJob pertinenti in ciascun caso. Questa operazione può essere eseguita dalla scheda Release Options della finestra di dialogo Project Release Options (per accedervi, fare clic sul pulsante
in basso a sinistra nella vista).

Assegnare gli OutJob ai set di dati pertinenti secondo necessità.
Modifica della destinazione di rilascio
La scheda Release Options della finestra di dialogo Project Release Options può essere utilizzata anche per modificare la destinazione del rilascio, passando dalla modalità operativa gestita (Online) a quella non gestita (Offline) e viceversa. Sono disponibili tre opzioni:
-
Unmanaged - Folder(Offline): selezionare questa opzione per rilasciare i dati generati in una cartella locale. Il percorso della cartella radice è specificato nella scheda Output Path della finestra di dialogo. Per impostazione predefinita, è impostato su[OutputPath](utilizzando il percorso definito nel campo Output Path, nella scheda Options della finestra di dialogo Project Options). -
Unmanaged - Zip(Offline): selezionare questa opzione per rilasciare i dati generati in una cartella locale. I dati verranno compressi in un unico file Zip. Il percorso e il nome del file Zip sono specificati nella scheda Output Path della finestra di dialogo. Per impostazione predefinita, sono impostati su[OutputPath][ProjectName].zip(utilizzando il percorso definito nel campo Output Path nella scheda Options della finestra di dialogo Project Options). -
Managed - <WorkspaceName>(Online): selezionare questa opzione per effettuare il rilascio nel Workspace (conWorkspaceName) a cui si è attualmente connessi.

Modifica la destinazione del rilascio, ovvero dove verranno inviati i dati generati, nelle opzioni di rilascio del progetto.
Impostazione degli schemi di denominazione degli elementi del Workspace
Quando rilasci un progetto nel Workspace di destinazione per la prima volta, puoi definire come vengono denominati gli elementi di dati di destinazione in quel Workspace, le cui revisioni riceveranno i dati generati. Questa operazione viene eseguita nella scheda Item Naming della finestra di dialogo Project Release Options, accessibile premendo il pulsante
in basso a sinistra nella vista (oppure facendo clic sul collegamento Target Revision relativo a un set di dati da rilasciare e scegliendo Edit dal menu contestuale). Usa questa scheda per:
- Definire il nome del progetto. Per impostazione predefinita, questo campo viene compilato con il nome effettivo del progetto.
-
Definire gli schemi di denominazione predefiniti per i vari elementi di dati che possono essere generati durante il rilascio. Fai clic in un campo della colonna Item ID, quindi sul pulsante
a destra del campo per accedere alla finestra di dialogo Choose Item (una variante del pannello Explorer), che consente di selezionare come destinazione un elemento esistente nel Workspace attualmente connesso.
Per modificare uno qualsiasi degli schemi di denominazione, fai clic sul pulsante Settings per accedere alla finestra di dialogo Naming Template Settings.

Imposta il nome del progetto e definisci la denominazione degli elementi di dati generati nel Workspace di destinazione. Qui i campi sono modificabili perché il progetto non è ancora stato rilasciato.
In un modello di denominazione sono supportati i seguenti formati di macro:
-
Parameter-based – supporta l'uso di parametri racchiusi tra parentesi quadre (ad esempio
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based – supporta l'uso di quantificatori numerici racchiusi tra parentesi graffe (ad esempio
{0000},{9000}).
Controllo della revisione di destinazione
Torna alla vista principale e fai clic sul collegamento accanto a una voce Target Revision per accedere al menu dei comandi, illustrato nell'immagine seguente:

Accesso ai controlli per specificare la revisione di destinazione di un set di dati da generare durante il rilascio: passa il puntatore sull'immagine per visualizzarli.
I comandi disponibili dipendono dal fatto che l'elemento sia già stato rilasciato per la prima volta o meno. Di seguito sono elencati tutti i comandi possibili:
-
Auto <RevisionID> – questa voce consente al sistema di gestire le revisioni, evitando di dover creare revisioni pianificate laddove non esistano già.
RevisionIDmostra la revisione successiva dell'elemento allo stesso livello nello schema di denominazione delle revisioni assegnato (ad esempio, se la revisione corrente èA.1, questo comando mostreràA.2come destinazione). -
Next <RevisionID> – questa voce è disponibile solo dopo il rilascio iniziale dell'elemento. Usala per incrementare rapidamente la revisione di destinazione al livello successivo nello schema di denominazione delle revisioni assegnato.
RevisionIDmostra la revisione successiva (ad esempio, se la revisione corrente èA.1, questo comando imposteràB.1come destinazione). -
Custom – usa questa voce per selezionare come destinazione una revisione specifica di un elemento di destinazione, definendo un ID revisione personalizzato tramite la finestra di dialogo Custom Revision ID. A seconda dello schema di denominazione delle revisioni utilizzato, nella finestra di dialogo possono essere presenti fino a tre campi ID livello. Tieni presente che l'ID della prima revisione pianificata dell'elemento può essere modificato in qualsiasi momento dopo la creazione dell'elemento e prima che i dati vengano rilasciati in tale revisione iniziale (ovvero mentre si trova ancora nello stato
Planned). - Browse – usa questa voce per selezionare una revisione esistente di un elemento di destinazione in cui effettuare il rilascio. Verrà visualizzata la finestra di dialogo Choose Target Item (una variante del pannello Explorer), che consente di eseguire questa operazione.
- Edit – usa questa voce per accedere alla scheda Item Naming della finestra di dialogo Project Release Options, da cui puoi modificare il nome dell'elemento di destinazione (e della revisione iniziale) che verrà creato.
- Navigate – usa questa voce per passare rapidamente all'elemento nel pannello Explorer (se è già stato rilasciato e la revisione successiva esiste in stato pianificato).
La voce nella parte superiore del menu rifletterà la revisione di destinazione attualmente selezionata o definita.
Accesso ai dettagli sulla generazione dei dati
Fai clic sul controllo Details, all'estrema destra dell'intestazione di un set di dati, per accedere ai dettagli su ciò che verrà esattamente generato da quel set. Comprimi questa vista estesa facendo clic sul controllo Hide Details. Ad eccezione del set Source Data, i dati generati proverranno da uno o più file Output Job assegnati. Puoi accedere rapidamente all'OutJob di origine facendo clic sul controllo Configure.

Accedi alla vista dettagliata di un set di dati per vedere quali dati verranno generati: passa il puntatore sull'immagine per visualizzarli.
Impostazioni aggiuntive
Nella pagina Data Management – Servers della finestra di dialogo Preferences sono disponibili ulteriori impostazioni relative al rilascio del progetto:
-
La cartella usata per archiviare temporaneamente i file generati prima del caricamento nel Workspace attualmente connesso può essere impostata sul percorso automatico (
\Users\<ProfileName>\AppData\Local\Temp\Releasesper un'installazione predefinita) oppure sostituita manualmente con una cartella a scelta. - Abilita l'opzione Delete contents after exiting release mode per svuotare la cartella di archiviazione temporanea al termine del processo di rilascio.
- Il nome di ciascun output generato può essere facoltativamente preceduto dall'ID dell'elemento e dall'ID della revisione (ad es.
[FAB-Kame_FMU-A.1] Validation.PDF). A tale scopo, abilita l'opzione Prepend revision HRID to file names.

Ulteriori preferenze relative al processo di rilascio del progetto.
Dopo aver configurato secondo le esigenze gli elementi di dati da creare nell'ambito del rilascio, fai clic sul pulsante
in basso a destra nella vista per procedere.
Durante la preparazione vengono eseguiti diversi controlli preliminari al rilascio, tra cui:
- Verificare che il progetto e tutti i file siano stati salvati.
- Verificare che sia stato eseguito il commit del progetto e di tutti i file pertinenti nel VCS, se applicabile.
- Verificare che a ciascun elemento di dati abilitato sia stato assegnato un nome.
- Verificare che l'utente disponga dei diritti per creare l'elemento di destinazione e la relativa revisione.
- Creare nel Workspace gli elementi di destinazione richiesti e le revisioni pianificate, se non esistono già, e assicurarsi che venga utilizzata la revisione successiva per gli elementi già esistenti.
Se vengono rilevati problemi, ti verranno proposte soluzioni per risolverli, ad esempio salvare i file modificati localmente ed eseguirne il commit nel VCS.
In questa fase viene generato l'elemento Source Data, con il rilascio di un'istantanea dei file sorgente del progetto nella revisione dell'elemento di destinazione.
Fase online 2 – Convalida del progetto
Una volta completata la fase 1 senza problemi, questa fase successiva del processo di rilascio viene eseguita automaticamente quando vengono rilevati uno o più report di tipo convalida nei file OutJob assegnati. Vengono eseguiti tutti i generatori di output di convalida definiti in un file Output Job assegnato all'elemento di dati in fase di rilascio. Ciò include l'esecuzione dei seguenti controlli:
- Differences Report – utilizzo del comparatore per determinare se i documenti sorgente e quelli del progetto PCB sono correttamente sincronizzati.
- Electrical Rules Check – verifica della validità elettrica e di disegno del progetto sorgente acquisito.
- Design Rules Check – verifica della validità del documento PCB rispetto ai vincoli di progettazione specificati a livello di scheda.
-
BOM Checks – verifica di possibili violazioni associate agli elementi di progetto o alle scelte dei componenti nel documento BOM sorgente (
*.BomDoc), ove disponibile. - Footprint Comparison Report – confronto dei footprint sulla scheda con quelli della libreria di origine, per assicurarsi che siano aggiornati e corrispondenti.
- Component State Checking – verifica della presenza di componenti in stati soggetti a restrizioni. Durante la configurazione, puoi determinare l'azione da intraprendere per ciascuno stato attualmente definito di ogni definizione del ciclo di vita nel Workspace di destinazione: nessuna azione, un avviso o la generazione di un errore. Quest'ultima opzione impedirà il rilascio del progetto. Inoltre, l'esecuzione del controllo genera un pratico report HTML che consente di vedere a colpo d'occhio quali componenti del progetto non si trovano in stati validi.
- Environment Configuration Compliance Check – verifica che vengano utilizzati solo gli elementi di dati consentiti dalla configurazione dell'ambiente disponibile per il ruolo assegnato, se applicabile. Questo controllo può anche verificare che tutti gli elementi di progetto provengano da un Workspace.
Se la convalida ha esito positivo, viene visualizzata l'icona
con il testo Passed. In caso contrario, viene visualizzata l'icona
con il testo Failed.
Fase online 3 – Generazione dei dati
Una volta completata la fase 2 senza problemi, questa fase successiva del processo di rilascio viene eseguita automaticamente. In questa fase vengono eseguiti tutti gli altri output, definiti nei file OutJob assegnati agli elementi di dati inclusi, per generare i dati da rilasciare nei rispettivi elementi di destinazione nel Workspace.
Come nelle altre fasi, ma in modo più evidente in questa poiché richiede più tempo, vengono utilizzate delle icone per mostrare l'avanzamento della generazione:
– non ancora eseguito/generato.
– in esecuzione/generazione.
– generato correttamente.
– generazione non riuscita.
Fase online 4 – Revisione dei dati
Una volta superati tutti i controlli di convalida e generati i dati di output, questa fase del processo di rilascio consente di esaminare i dati generati.

Esamina i dati generati e verifica che tutto sia come previsto prima di confermare il rilascio e caricare i dati nel Workspace.
Per impostazione predefinita, la pagina presenta una vista semplice (compatta) dei dati generati. Puoi passare a una vista più dettagliata facendo clic sul controllo Details associato alla sezione di interesse.

Fai clic su un controllo Details per passare dalla vista semplice a quella dettagliata dei dati generati per la sezione associata. Per tornare alla vista precedente, fai clic sul controllo Hide Details.
Stati di generazione degli output nella vista dettagliata
La tabella seguente elenca i possibili stati degli output durante la generazione dei dati, così come appaiono nella vista dettagliata:
Stato |
Descrizione |
|---|---|
|
L'output non è ancora stato generato o non esiste. |
|
L'output è stato generato, ma successivamente sono state apportate modifiche al progetto, rendendo questi dati non più aggiornati. |
|
La generazione dell'output è attualmente in corso. |
|
L'output è di tipo convalida e ha generato un report privo di errori. Nel caso di un report ERC, non sono presenti errori oppure il loro livello rientra nel livello massimo di errore tollerato specificato per quel report. |
|
L'output (esclusi quelli di tipo convalida) è stato generato correttamente. |
|
L'output non è stato generato correttamente. Per un output di tipo convalida, ciò significa che nei documenti sorgente del progetto sono presenti errori che causano il mancato superamento di alcuni controlli. Per un output standard, non è stato possibile completare correttamente la generazione. Potrebbero essere presenti errori fatali durante la convalida preliminare alla generazione, oppure potrebbe esserci un problema nella configurazione del generatore di output associato nel file Output Job. |
Nella vista compatta dei dati generati, fai clic su un collegamento View per aprire il file di dati o il set di file associato nell'editor pertinente di Altium Designer (ad esempio, l'editor CAM per i file Gerber o i file ODB++ compressi/non compressi) oppure nell'applicazione esterna pertinente (ad esempio, Microsoft Excel per una distinta base). Nella vista dettagliata, fai doppio clic su una voce per visualizzare solo quel file.
Un controllo comune eseguito da molti progettisti per verificare che i dati siano pronti per il rilascio consiste nel confrontare i file Gerber generati per il rilascio corrente con quelli del rilascio precedente. Fai clic sul collegamento Compare Gerber accanto a un output Gerber e seleziona un rilascio precedente dal menu a discesa per confrontare i dati Gerber preparati con quelli del rilascio selezionato. Il browser predefinito aprirà il Workspace aziendale e mostrerà i risultati.

Accesso alla funzionalità di confronto Gerber da Project Releaser, prima di rilasciare i dati in un Workspace.
► Scopri di più sulla funzionalità Gerber Comparison (Workspace Altium 365, Workspace Enterprise Server).
Se, dopo aver esaminato i dati, ritieni necessario apportare modifiche, fai clic sul pulsante
in basso a destra nella vista. Verrà visualizzata una finestra di dialogo di conferma che ti avvisa che tutti i dati generati andranno persi: facendo clic su OK, il rilascio verrà annullato e tornerai alla fase 1 del processo.
Se tutti i dati generati risultano corretti, procedi con il rilascio facendo clic sul pulsante
(anch'esso in basso a destra nella vista). Verrà visualizzata la finestra di dialogo Confirm Release, che riepiloga le configurazioni del progetto che verranno rilasciate nel Workspace. Qui puoi anche aggiungere un Name (per impostazione predefinita, la voce è [ProjectName]), un Description ed eventuali note di rilascio pertinenti.

Conferma di ciò che verrà rilasciato, in termini di revisioni degli elementi generate, con la possibilità di modificare nome/descrizione e aggiungere note di rilascio.
Fase online 5 – Caricamento dei dati
Dopo aver confermato il rilascio nella fase precedente, si passa automaticamente a questa fase. Viene semplicemente mostrato l'avanzamento del caricamento dei dati nelle revisioni dei relativi elementi di dati nel Workspace.

Questa fase mostra semplicemente l'avanzamento del caricamento dei dati generati nelle revisioni degli elementi collegate nel Workspace.
Fase online 6 – Report di esecuzione
Questa è la fase finale del processo e fornisce un riepilogo del rilascio.

Il report finale del rilascio.
Utilizza i collegamenti di navigazione per accedere rapidamente alla revisione dell'elemento associata, contenente i dati rilasciati (dati di fabbricazione, dati di assemblaggio ed eventuali set di dati personalizzati), nel pannello Explorer, il tuo punto di accesso al Workspace.

Visualizzazione dei dati rilasciati per il progetto, direttamente nel Workspace, tramite il pannello Explorer.
Visualizzazione del progetto rilasciato
Per un progetto del Workspace, al termine del rilascio è disponibile una funzionalità aggiuntiva. Facendo clic sul collegamento Project Page, l'ultimo dei collegamenti di navigazione nella parte superiore della pagina Execution Report, si apre il pannello Explorer, che presenta il progetto in Project View, disponibile solo per i progetti del Workspace.

Puoi esplorare più in dettaglio un progetto del Workspace nel pannello Explorer, grazie a Project View.
L'area Releases (in basso a sinistra nella vista) mostra una raccolta dei rilasci associati al progetto, che include un riepilogo di ciascun rilascio e dei pacchetti che lo compongono. Fai clic sul pulsante
in quest'area per aprire la finestra di dialogo Batch state change, che consente di modificare lo stato del ciclo di vita di più elementi relativi allo stesso rilascio, contemporaneamente e in un unico processo batch.
Ulteriori informazioni sui rilasci del progetto sono disponibili nel visualizzatore Web del Workspace di destinazione, che si apre tramite il pulsante
del pannello Explorer. Nel visualizzatore Web di un Workspace, tutti i rilasci associati al progetto sono accessibili nella vista Releases, oppure nella vista Manufacture per un Workspace fornito da un server locale. La pagina elenca tutti i rilasci del progetto, con la voce più recente in cima; è possibile aprire un singolo rilascio in Manufacturing Portal del Workspace tramite il relativo pulsante di apertura La vista Manufacturing Portal fornisce informazioni più dettagliate sul rilascio selezionato, inclusi i file dei pacchetti che lo compongono, il set completo dei documenti di progettazione e i dettagli su produttori e fornitori dei componenti. Tieni presente che la funzionalità Send to Manufacturer è disponibile solo in un Workspace Altium 365. ► Per ulteriori informazioni, consulta la pagina Vista Releases del Workspace Altium 365.
È tutto: una volta rilasciato il progetto, puoi semplicemente chiudere la vista Release (utilizzando il pulsante
in basso a destra nella vista). Quando in futuro dovrai rilasciare nuovamente lo stesso progetto, Project Releaser ti consentirà di farlo in modo semplice e rapido, incrementando automaticamente le revisioni degli elementi di destinazione.
Pubblicazione su un'istanza PLM
Related pages: Integrazione PLM (Altium 365 Workspace, Enterprise Server Workspace), Pubblicazione su un PLM
È possibile pubblicare un progetto su un'istanza PLM durante l'esecuzione di Project Releaser in Altium Designer. L'operazione di pubblicazione utilizza un modello di pubblicazione, definito nella configurazione di integrazione dell'istanza PLM, per controllare come trasferire i dati al PLM. Questa funzionalità è disponibile tramite un processo opportunamente configurato. Nell'installazione è inclusa una definizione di processo di esempio, Project Releaser with Publish, il cui flusso di lavoro consente la pubblicazione sull'istanza PLM integrata come fase aggiuntiva di Project Releaser. Il diagramma del flusso di lavoro è mostrato di seguito.

Il diagramma del flusso di lavoro della definizione di processo di esempio predefinita Project Releaser with Publish
Una volta attivato, il processo per la pubblicazione su un'istanza PLM nell'ambito di Project Releaser è accessibile da Altium Designer tramite il sottomenu Project » Project Releaser del progetto attivo oppure dal sottomenu contestuale Project Releaser, accessibile facendo clic con il pulsante destro del mouse sulla voce del progetto nel pannello Projects.

Accesso al processo per la pubblicazione su un'istanza PLM nell'ambito di Project Releaser
Verrà visualizzato Project Releaser, con una fase aggiuntiva: 7. Publish to PLM. Inoltre, nel menu associato al pulsante
è disponibile il comando Prepare & Release & Publish to PLM, che consente di eseguire Project Releaser senza interrompere l'esecuzione per esaminare i dati generati e il report di esecuzione.

Un comando aggiuntivo per eseguire Project Releaser senza interrompere l'esecuzione per esaminare i dati generati e il report di esecuzione
Se si esegue Project Releaser con il comando standard Prepare, dopo aver esaminato e rilasciato i dati, nella fase Execution Report verrà visualizzato il pulsante
. Fare clic su questo pulsante per proseguire con il flusso di lavoro del processo e pubblicare sul PLM. Verrà visualizzata la finestra di dialogo Login Credentials. Inserire Username e Password per l'istanza PLM e selezionare il modello PLM da utilizzare (visualizzato nel formato <PLMInstance>:<PublishingTemplate>).

La finestra di dialogo Login Credentials visualizzata durante la prima pubblicazione sull'istanza PLM.
Fare clic sulla scheda Diagram per visualizzare il flusso di lavoro del processo.

La scheda Diagram della finestra di dialogo Login Credentials
Fare clic sul pulsante
per procedere con il processo di pubblicazione secondo tale flusso di lavoro.
).
