コンポーネントフォルダとアイテムの操作

Altium Training

Altium Essentials: Workspace Folder Structure

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

概略

Altium Designerに接続されたワークスペースで、コンポーネントフォルダーとアイテムがどのように機能するかを学びます。フォルダー別とコンポーネントタイプ別の参照方法の違いから、コンポーネントデータの表示方法のカスタマイズまでを解説します。この記事では、コンポーネントの作成とインポート、ライブラリの健全性チェックへのアクセス、マルチパートコンポーネントの操作、配置時のパラメーター表示の設定を取り上げます。ワークスペースのコンポーネントを参照・管理するためのツールをより効果的に活用する方法をご確認ください。

- コンポーネントタイプとデフォルトフォルダーによって、新しいコンポーネントの保存先がどのように決まるかを理解します。
- 列、グループ化、並べ替え、フィルターを使用してコンポーネントビューをカスタマイズする方法と、ライブラリの健全性ビューでコンポーネントの健全性に関する問題を確認する方法を学びます。
- マルチパートコンポーネントのプレビューと配置の方法、およびワークスペースのコンポーネントを配置する際にパラメーターの表示を制御する方法を確認します。
AIでさらに深掘り:

ExplorerパネルとComponentsパネルの重要な違い:

  • Explorerパネルでは、左側のツリーでFolder Name別に参照します。 Explorerパネルでフォルダーをクリックすると、そのフォルダー内のコンポーネントstoredがパネルに一覧表示されます。 これらのコンポーネントdo notは、同じコンポーネントタイプである必要があります。 

  • Componentsパネル (またはブラウザーベースのインターフェース)でWorkspaceのコンポーネントを参照する場合は、 コンポーネントが保存されているフォルダー名ではなく、Component Type別に参照します。Componentsパネルとブラウザーベースのインターフェースは、Workspace内のすべてのコンポーネントフォルダーを自動的に検索し、コンポーネントタイプごとにコンポーネントをグループ化します。

コンポーネントタイプとコンポーネントフォルダーの関連付けは、PreferencesダイアログのData Management - Component Typesページで定義します。新しいコンポーネントを作成するときには、これらの設定が使用されます。 コンポーネントを作成する際は、Create new componentダイアログでコンポーネントタイプを選択します。 新しいコンポーネントには、選択したコンポーネントタイプが割り当てられ、Preferencesダイアログでそのコンポーネントタイプに対して定義されているデフォルトフォルダーに保存されます。 これらの設定は、編集中にコンポーネントプロパティのAdvanced Settingsセクションを展開して確認できます。(画像を表示)

コンポーネントフォルダータイプのコントロール

Componentsタイプのフォルダーにまだコンポーネントが含まれていない場合は、フォルダーへのコンポーネントの追加を支援するコントロールがここに表示されます。

これらのコントロールを使用して、適切な操作を実行します。

  • Import Library – クリックすると、Windows標準のOpenダイアログが開き、ローカルフォルダーまたはネットワークフォルダーに保存されているデータベースライブラリまたはファイルベースのライブラリを選択できます。ライブラリファイルを開くと、選択したライブラリが読み込まれた状態で、シンプルモードのLibrary Importerが起動します。
  • Create Component – クリックすると、Component Editorが単一コンポーネント編集モードで開き、新しいコンポーネントを定義できます。
  • Create Other Item Type – クリックすると、Create New Itemダイアログが開き、任意のタイプの新しいアイテムを作成できます。

フォルダーにコンポーネントが含まれているかどうかにかかわらず、これらの操作は、パネル右上のAdd Componentボタンに関連付けられたメニューのオプションからも実行できます。

ライブラリ健全性ビュー

この機能は、Advanced SettingsダイアログでLibraryHealthオプションが有効になっている場合に使用できます。

接続されたAltium 365 Workspaceのコンテンツを参照する際、ExplorerパネルからLibrary Healthビューにアクセスして、健全性チェックの実行やコンポーネントの健全性に関する問題の確認ができます。パネルのServer Folder領域でLibrary Healthエントリーを選択すると、パネル内にこのビューが表示されます。

ExplorerパネルからアクセスしたLibrary Healthビュー
ExplorerパネルからアクセスしたLibrary Healthビュー

ビューの上部には、最後に実行した健全性チェックに基づくコンポーネントの健全性の概要が表示されます。その下には、サポートされている健全性チェックの分析項目が、さまざまなIssue Themesにまとめられて表示されます。健全性チェックの分析タイルをクリックすると、チェックの詳細な説明と解決手順(用意されている場合)、およびその健全性チェックに不合格となったすべてのコンポーネントの詳細な一覧が表示されます。

Library Healthビューのインターフェースと機能は、Altium 365 Workspaceのブラウザーインターフェースからアクセスできる詳細なLibrary Healthダッシュボードページと同じです。このページの詳細については、メインのライブラリ健全性ダッシュボードへのアクセスを参照してください。

コンポーネントビュー

Componentsタイプのフォルダーは、Classic ViewとComponents Viewの2つの表示モードをサポートしています。後者は、このフォルダータイプのデフォルトビューで、現在のフォルダー内のすべてのコンポーネントに関連付けられているパラメトリックデータを参照できます。さらに、コンポーネントのフォルダーごとにビューを好みに合わせて設定でき、その設定はセッション間で保持されます。

これら2つの表示モードを切り替えるには、Explorerパネルでコンポーネントフォルダーを開き、コンポーネント一覧の右上にあるボタンをクリックして、表示されるメニューからView » Classic ViewまたはView » Components Viewコマンドを選択します。

コンポーネントタイプのフォルダーでComponents Viewにアクセスすると、コンポーネントがパラメトリックデータに基づいて表示されます。画像にカーソルを合わせると、Classic Viewに戻した結果を確認できます。
コンポーネントタイプのフォルダーでComponents Viewにアクセスすると、コンポーネントがパラメトリックデータに基づいて表示されます。画像にカーソルを合わせると、Classic Viewに戻した結果を確認できます。

Components Viewの操作の詳細については、以下のセクションを参照してください。

マルチパートコンポーネントのサポート

マルチパートコンポーネントのシンボルを表示すると、Previewアスペクトビュータブでは、固有のシンボルグラフィックを持つ各パートが個別のタブとして表示されます。また、Placeメニューには、そのコンポーネントで配置可能なすべてのパートを含むサブメニューが表示されます。

コンポーネント配置時のパラメーターの表示制御

Workspaceライブラリのコンポーネントを(Componentsまたは Explorerパネルから)配置する際、それらのコンポーネントに関連付けられたパラメーター、より正確にはその値の表示/非表示は、親フォルダーのプロパティダイアログで制御します。

フォルダーのタイプはComponentsである必要があります。

親フォルダーを右クリックし、Propertiesコマンドを選択します。Edit Folderダイアログが表示されます。右側のConfigure Parameters Visibility on Addオプションを有効にします。フォルダー内のすべてのコンポーネントから取得されたパラメーターが、領域内に一覧表示されます。各パラメーターに対応するVisible On Addチェックボックスを使用して、そのパラメーターを持つコンポーネントを回路図シートに配置したときの表示/非表示を制御します。

リストにはName/Commentパラメーターも含まれます。これはシステムパラメーターです。
パラメーターの表示設定データは、Workspace内のフォルダープロパティの一部としてWorkspace自体に保存されます。この設定は、該当フォルダーを共有しているWorkspaceのすべてのユーザーに共通で適用されます。フォルダー階層も考慮されるため、親フォルダーで設定したパラメーターの表示/非表示は、その配下のすべての子フォルダーに引き継がれます(継承されます)。

コンポーネントを設計に配置したときに、どのパラメーターを表示するかをフォルダーレベルで設定します。
コンポーネントを設計に配置したときに、どのパラメーターを表示するかをフォルダーレベルで設定します。

コンポーネントのパラメーター情報をクリップボードにコピー

コンポーネントのリビジョンのパラメーター情報をクリップボードにコピーし、設計内の別の場所で使用したり、外部アプリケーション(Microsoft Excelなど)に貼り付けたりできます。Component ItemのリビジョンのPreviewアスペクトビュータブを参照しているときに、ビューのParameters領域で必要なパラメーターを選択し、Ctrl+Cキーボードショートカットを使用するか、領域内を右クリックしてコンテキストメニューのCopyコマンドを使用します。

必要に応じて、標準の複数選択操作(Ctrl+Click、Shift+Click)を使用して複数のパラメーターを選択します。

Component Itemのリビジョンのパラメーター情報をクリップボードにコピーし、必要に応じて別の場所で使用します。
Component Itemのリビジョンのパラメーター情報をクリップボードにコピーし、必要に応じて別の場所で使用します。

リリース済みコンポーネントのタイプをその場で変更

リリース後でも、1つまたは複数のコンポーネントのタイプを、その場でまったく異なるタイプに変更できます。Explorerパネルで変更するコンポーネントのリビジョンを選択し、右クリックしてコンテキストメニューからOperations » Change component typeコマンドを選択します。Choose component typeダイアログが表示され、新しいコンポーネントタイプを選択できます。

リリース済みのコンポーネントアイテムの選択したリビジョンについて、コンポーネントタイプを変更する例。この機能をわかりやすく示すため、最初に誤ったタイプを設定しています。
リリース済みのコンポーネントアイテムの選択したリビジョンについて、コンポーネントタイプを変更する例。この機能をわかりやすく示すため、最初に誤ったタイプを設定しています。

コンポーネントの検索

Explorerパネルには、強力な検索機能が用意されています。一般的な検索に加え、保存済みの検索設定を使用した絞り込み検索も実行できます。後者では、特定のコンポーネントタイプでコンポーネントを検索できるほか、範囲検索も利用できます。範囲検索は、単位を認識するコンポーネントパラメーターのデータ型によって実現される便利な検索機能です。このデータ型は、参照先のコンポーネントテンプレートを通じてサポートされます。また、保存済みの検索にキーボードショートカットを追加すると、Explorerパネルの外からでもすばやく検索を実行できます。

Explorerパネルの検索機能も強力ですが、コンポーネントパネルでは、さらに便利な検索機能を利用できます。設計プロジェクトでコンポーネントを管理・配置する際に日常的に使用するパネル内で、必要なときにそのまま検索できます。Componentsパネルでは、検索語句を入力したり、パネルのカテゴリやフィルターを選択したりして、目的に合うコンポーネントに一覧を絞り込めます。フィルターはワークスペースライブラリでのみサポートされます。また、メーカー部品検索パネルと同様に、Componentsパネルは単位を認識する(テキストを数値に変換する)検索フィルターをサポートしています。

検索の前提条件

Related pages: コンポーネントとライブラリの構築と管理、コンポーネントテンプレート

コンポーネントを検索する際に、Explorerパネルの検索機能を十分に理解し、すべての機能を活用するには、次の要件を満たす必要があります。

  • Altium Designerを実行し、そのインストールの一部としてComponent Template EditorおよびExplorerのソフトウェア拡張機能がインストールされていることを確認します。

    これらのソフトウェア拡張機能は、Altium Designerとともにデフォルトでインストールされます。 手動でインストールまたは削除することもできます。

    拡張機能の管理の詳細については、 Extending Your Installation ページ(Altium Designer Develop、Altium Designer Agile、Altium Designer)を参照してください。

  • ワークスペースコンポーネントの保存にワークスペースを使用している必要があります。

  • 単位を認識するコンポーネントパラメーターのデータ型をサポートするコンポーネントテンプレートを参照してコンポーネントを作成していない場合は、コンポーネントを編集し、ワークスペースに再保存する必要があります。これは、次の手順で行えます。

    1. コンポーネントを編集し、一時的に開かれるコンポーネントエディターでその定義にアクセスします。
    2. 以下を含むコンポーネントテンプレート(CMPT)を作成してリリースします。
      • シンボルおよびプライマリフットプリントのデフォルトリビジョン(そのコンポーネントですでに使用されているもの)。
      • ComponentTypeシステムパラメーターのデフォルト値を適切に設定します(汎用抵抗器を編集する場合はResistorsなど)。さまざまな定義済みコンポーネントタイプが用意されており、必要に応じて新しいタイプを作成することもできます。
      • そのコンポーネントに現在定義されているすべてのコンポーネントパラメーターに一致するコンポーネントパラメーターを定義します。これにより、パラメーターを重複させることなく、既存の値を保持できます。
      • 関連するパラメーター(Value、Tolerance、Powerなど)について、データ型を適切に設定し、単位を認識できるようにします。単位を認識するコンポーネントパラメーターのデータ型は、複数サポートされています。
    3. このコンポーネントテンプレートを、編集中のコンポーネントに割り当てます。コンポーネントエディターをSingle Component Editingモードで使用している場合は、Advanced Settingsの下のTemplateフィールドから割り当てます。Batch Component Editingモードで使用している場合は、Required Models/Parameters領域に関連付けられたAdd » Templatesサブメニューから割り当てます。
    4. 赤色で表示されているパラメーター(値が無効、または必須に指定されているものの未定義のパラメーター)の値を調整します。
    5. コンポーネントの次のリビジョンとして、ワークスペースにコミットします。

     

検索機能へのアクセス

検索機能のインターフェースであるSearchビューには、Explorerパネルの左下にあるSearchタブをクリックしてアクセスします。このビューは、次の画像に示す3つの主要な要素で構成されています。それぞれについては、画像の後で詳しく説明します。

また、パネル上部のSearchフィールドを使用して一般検索を実行した場合や、保存済みの検索に割り当てたキーボードショートカットを実行した場合にも、Searchビューが表示されます。Foldersビューから、Server Folders領域内のSearch Results項目をクリックしてアクセスすることもできます(検索の実行後に利用可能)。

Searchビュー — Explorerパネル内の専用ユーザーインターフェース。
Searchビュー — Explorerパネル内の専用ユーザーインターフェース。

  1. 一般検索フィールド — 標準的な検索を行えます。検索文字列を入力し、Enterを押します。
  2. 保存済みの検索 — 再利用できるように保存可能な絞り込み検索を行えます。この検索では、コンポーネントをタイプ別に検索できるほか、単位を認識するパラメーターの値に基づく高度な検索も行えます。
  3. 検索結果。
Saved SearchesペインのGeneric Search項目をダブルクリックすると、Explorerパネル上部の一般検索フィールドに最後に入力した検索語句が適用されます。これは、設計ソフトウェアの現在のセッションにのみ適用されます。

保存済み検索の作成

新しい保存済み検索を作成するには、Saved Searches領域内を右クリックし、コンテキストメニューからNewを選択します。検索を定義するためのNew Searchダイアログが表示されます。

新しい保存済み検索の作成。
新しい保存済み検索の作成。

このダイアログで、次のようにコンポーネント検索を設定します。

  • Saved Search Nameを使用して、検索にわかりやすい名前(Resistorsなど)を付けます。

    既存の保存済み検索と同じ名前の新しい検索を追加することはできません。
  • 検索にすばやくアクセスするため、必要に応じてキーボードShortcutを定義します(フィールド内をクリックしてから、目的のショートカットキーをキーボードで押して入力します)。

  • Content TypeフィールドをComponentに設定します。ドロップダウンリストには、ワークスペースでサポートされるすべてのコンテンツタイプが表示されます(ほかのコンテンツタイプに基づく検索も作成できます)。

    ワークスペース内のコンポーネントを検索するには、Content Typeフィールドのドロップダウンから「コンポーネント」を選択します。
    ワークスペース内のコンポーネントを検索するには、Content Typeフィールドのドロップダウンから「コンポーネント」を選択します。

  • Parameters領域で、必要に応じて検索パラメーターを設定します。Componentコンテンツタイプで検出されたすべてのパラメーターが一覧表示されます。各パラメーターについて、次の3つのオプションを定義できます。

    • Show Filter – 有効にすると、Search タブのSearch Results 領域の上に、そのパラメーターに対応するフィルターフィールドが表示されます。このフィールドでパラメーターの値の条件を指定することで、検索を細かく調整できます。

    • Default Visibility – 有効にすると、Search タブのSearch Results 領域に、そのパラメーターの列がデフォルトで表示されます。パラメーターデータの列は、ビューから直接、いつでも表示または非表示に切り替えられます。

    • Parameter - パラメーターの名前です。システムパラメーターまたはユーザーパラメーターを指定できます。範囲検索を使用するには、割り当てられたコンポーネントテンプレートでパラメーターを定義し、単位を認識する特定のデータ型に設定する必要があります。

    • Type - パラメーターのデータ型です。範囲検索を行う場合は、パラメーターを単位対応のデータ型に設定する必要があります。この設定はコンポーネントテンプレートでのみ行うことができ、コンポーネント定義をリリースする前に、そのテンプレートをコンポーネントライブラリに割り当てる必要があります。

    • Default Value – このフィールドを使用して、パラメーターの値を特定の値または範囲に制限します。フィールドの内容に対して文字列検索が実行され、1文字(?)および複数文字(*)のワイルドカード()を使用できます。

      値を定義する場合:

      • 範囲はハイフンで表します。例:1kOhm-10kOhm、1k-10k。大なり(>)および小なり(<)も使用できます。どちらの場合も境界値を含みます。

      • 文字列検索が実行され、このフィールドでは1文字(?)および複数文字(*)のワイルドカードを使用できます。

      • 検索対象を特定の種類のコンポーネントに絞り込むには、ComponentTypeパラメーターのDefault Valueフィールドに、その種類を入力してください(例:Resistors)。Workspaceに保存する前に、コンポーネントのComponentTypeを指定しておくことが非常に重要です。通常、これは参照先のコンポーネントテンプレートで設定しますが、コンポーネントの編集中にComponent Editorで手動設定することもできます。

      • 範囲検索を使用するには、割り当てられたコンポーネントテンプレートでパラメーターを定義し、単位を認識する特定のデータ型に設定する必要があります。

      検索パラメーターの定義例。
      検索パラメーターの定義例。

     

  • Workspaceのすべてのユーザーが保存済み検索を表示して使用できるようにするには、Publicオプションを有効にしておきます。自分だけが使用できる非公開の検索にするには、このオプションを無効にします。

必要に応じて検索を定義したら、Addボタンをクリックします。検索は、ビューのSaved Searches領域にあるGeneric Searchの下にエントリーとして保存されます。

  • Saved Searches領域内で右クリックし、コンテキストメニューからGenerate From Component Typesコマンドを選択すると、保存済み検索のセットをすばやく生成できます。このセットは、サポートされているすべてのコンポーネントタイプを網羅しています。

  • CreatedByパラメーターやModifiedByパラメーターを有効にすると、コンテンツを作成または変更した特定のユーザーで検索する保存済み検索を作成できます()。

保存済み検索の適用

保存済み検索は、次の方法で適用できます。

  • 新しく定義した検索でAddをクリックするか、既存の検索を変更した後にSaveをクリックすると、検索が自動的に適用されます。
  • Saved Searches領域で検索を選択し、Enterを押します。
  • 割り当てられたショートカットを使用して目的の保存済み検索に切り替え、Enterを押します。
  • 保存済み検索のエントリーをダブルクリックします。

定義された検索条件に基づいてコンポーネントがフィルタリングされ、対応する検索結果領域に結果が表示されます。適用した保存済み検索に、Show Filterオプションが有効なパラメーターが含まれている場合、結果リストの上に、そのパラメーター専用のフィールドが表示されます。

定義した保存済み検索(Resistors)を適用した後の結果の例。この検索にはShow Filterオプションが有効なパラメーターが4つあるため、それらのフィールドが検索インターフェースの一部として表示されています。
定義した保存済み検索(Resistors)を適用した後の結果の例。この検索にはShow Filterオプションが有効なパラメーターが4つあるため、それらのフィールドが検索インターフェースの一部として表示されています。

フィルターフィールドが表示されているパラメーターについては、次の操作が可能です。

  • 検索の定義でパラメーターのデフォルト値が指定されている場合、そのフィールドには最初からその値が入力され、検索の適用時にその値が使用されます。

  • フィールドに直接入力することで、パラメーターに新しい値(特定の値または範囲)を指定できます。

必要に応じて調整し、Enterを押して変更後のフィルタリングを適用します。

検索結果領域にある標準のコントロールを使用して、必要に応じて結果をさらに並べ替え、フィルタリング、グループ化できます。

  • ヘッダーをクリックすると、その項目で並べ替えられます。1回クリックすると昇順、もう一度クリックすると降順になります。
  • ヘッダーにマウスポインターを合わせると、その項目で絞り込むためのフィルターコントロールが表示されます。
  • ヘッダーをクリックしてドラッグすると、表示される列の順序を変更できます。
  • 列ヘッダーをヘッダーの上の領域にドラッグすると、その列で結果をグループ化できます。

保存済み検索の編集

既存の保存済み検索を変更するには、Saved Searches領域で検索を選択し、右クリックしてコンテキストメニューからEditを選択します。Edit: [<SavedSearchName>]ダイアログが表示され、必要に応じて検索を変更できます。

変更後、Saveボタンをクリックすると、新しい設定に従って検索が適用されます。

保存済み検索の削除

既存の保存済み検索を削除するには、Saved Searches領域で検索を選択し、右クリックしてコンテキストメニューからDeleteを選択します。続いて表示される確認ダイアログでYesをクリックすると、保存済み検索の一覧からその検索が削除されます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents