部品の検索と配置

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

あらゆる電子設計の中心となるのはコンポーネントです。最終的に基板にはんだ付けするコンポーネントは、各設計ドメインで表現、すなわちモデル化されている必要があります。具体的には、回路図上ではシンボルとして、シミュレータではSPICEモデルとして、基板上ではフットプリントとして、そして機構設計者に引き渡すファイル内では3D STEPモデルとして表現されます。

詳しくは、コンポーネントとライブラリの構築および保守をご覧ください。

Altium Designer のComponentsパネルは、Workspace 内外のすべてのコンポーネントを操作するための強力なインターフェースを提供します。カテゴリを指定し、検索フィールドにクエリ(コンポーネント名の全部または一部、値など)を入力するシンプルな検索モードを使って、必要なコンポーネントを検索できます。さらに、このパネルでは、Workspace コンポーネントに対して対象コンポーネントのパラメータを指定できる、フィルタベースのパラメトリック(ファセット)検索機能も利用できます。また、このパネルでは、Single Component Editing モードの Component Editorを通じて Workspace コンポーネントを編集したり、そのソース Workspace 内でコンポーネントを表示したり、コンポーネントの作成や複製、選択したコンポーネントの Part Choices や Type の編集といったコンポーネント管理機能を実行したりすることもできます。コンポーネントは、ドラッグするか、コンポーネントの右クリックメニューにあるPlace コマンドを使用して回路図上に配置できます。

もちろん独自のコンポーネントを作成することもできますが、Altium Designer には、実際に製造されている部品を検索するための強力なManufacturer Part Search パネルも用意されています。Workspace を利用している場合は、それらの部品をその Workspace に保存し、その後 Componentsパネルからアクセスできます。この処理では、新しい Workspace コンポーネントを作成し、Single Component Editing モードの Component Editor を使用して、それを Workspace に保存します。

Componentsパネルは、Altium Designer で利用可能なWorkspace コンポーネント、およびデータベースファイルベースのライブラリコンポーネントに直接アクセスするための機能を提供します。

このパネルは、接続された Workspace、および開いている、またはインストール済みのライブラリからコンポーネントを取得します。パネルでは、選択したコンポーネントの完全な詳細情報(Parameters、Models、Part Choices、Supplier data など)、コンポーネント比較、さらに Workspace コンポーネントについては、対象コンポーネントのパラメータを指定するためのフィルタベースのパラメトリック検索機能が提供されます。

Componentsパネルの通常モード

Componentsパネルのコンパクトモード

 

Componentsパネルでは、Manufacturer Part Search パネルで使用されている基本的な検索エンジン機能および表示を利用します。Manufacturer Part SearchパネルはAltium Parts Providerサービスを活用し、コンポーネントメーカーやサプライヤデータの検索に重点を置いていますが、Componentsパネルには、接続された Workspace、およびデータベースやファイルベースのライブラリソースから取得された、すぐに配置可能なコンポーネントが表示されます。

Workspace コンポーネントについては、各コンポーネントの最新リビジョンのみがパネルに表示されます。
コンポーネントを扱うための機能の多くはComponentsパネルで利用できますが、Explorer パネルを使用することもできます。基本的には前者は後者で利用可能な機能のサブセットを提供しており、コンポーネント管理に焦点を当てています。コンポーネント自体に関連する一部の機能(編集せずにデータシートを追加する、状態を変更する、コンポーネントやモデルを一括削除する、など)は依然としてExplorerパネルでしか実行できませんが、これらは主に非典型的なケース、特殊なケース、または管理作業/Workspace 構成作業の一環として使われるものです。コンポーネントはあくまで1つのコンテンツタイプにすぎないことを忘れないでください。Explorerパネルは、Workspace でサポートされるあらゆるコンテンツタイプ全体を扱う際に真価を発揮します。たとえば、コンポーネントにとって非常に重要な存在であるコンポーネントテンプレートの作成と管理は、Explorerパネル内でのみ実行できます(ただし、Library Importerを使用したライブラリインポート時にテンプレートを作成する場合を除きます)。

Components Panel Access

Componentsパネルを開くには、メインメニューからView » Panels » Componentsを選択するか、メイン画面右下のComponentsボタンメニューからオプションを選択します。レスポンシブデザイン構成では、パネルレイアウトはフルスクリーンの通常モード()と、Categories/Filters オプションがメニューに折りたたまれるコンパクトモード()との間で動的に適応します。

回路図ドキュメント内では、P, Pキーボードショートカットを使用してComponentsパネルを開きます。メインメニューのPlace » Partコマンド、回路図エディタのデザインスペースを右クリックしたメニューのPlace»Partコマンド、またはActive Bar上のPartボタン()を使用することもできます。

PCB ドキュメント内では、P, Cキーボードショートカットを使用してComponentsパネルを開きます。メインメニューのPlace » Componentコマンド、PCB エディタのデザインスペースを右クリックしたメニューのPlace»Componentコマンド、またはActive Bar上のComponentコマンド()を使用することもできます。

現在の Altium Designer セッションでComponentsパネルを初めて起動した際、Workspace に接続している場合は次のコントロールが利用できます。

  • Use Existing Components – クリックすると、パネル上部のドロップダウンで現在選択されているコンポーネントタイプを参照します。

  • Delete Existing Components – クリックするとDelete Existing Componentsダイアログが開き、続いて Workspace のData Cleanupページが表示され、削除するコンテンツタイプを選択できます。

  • Import Library – クリックすると標準の Windows Openダイアログが開き、ローカルまたはネットワークフォルダに保存されたデータベースまたはファイルベースのライブラリを選択できます。ライブラリファイルを開くと、選択したライブラリを読み込んだLibrary Importer の Simple モードが起動します。

  • Create Component – クリックするとCreate New Component ダイアログが開き、続いてSingle Component Editing モードの Component Editor が起動し、新しいコンポーネントを定義できる状態になります。

パネルのCategoriesペイン(コンパクトモードではドロップダウンメニュー)には、Allカテゴリ項目の下に利用可能なすべての Workspace コンポーネントと、利用可能なライブラリが一覧表示されます。パネルが通常モードの場合、Categoriesリストアイコン または «アイコンをクリックして列の表示を折りたたむ/展開することができ、ボタン(右上)を使用してコンポーネントDetailsペインの表示を切り替えられます。Categoriesペイン内をたどる際には、Up/DownおよびPgUp/PgDnキーボードショートカットを使って一覧を移動できます。個々のブランチを開閉するには、Left/Rightキーボードショートカットを使用できます。

Workspace コンポーネントのCategoriesグループ分けは、各コンポーネントに関連付けられたComponent Typeパラメータに基づいています。たとえば、あるコンポーネントのComponent TypeResistorとして指定されている場合、そのコンポーネントはComponentsパネル内のResistorカテゴリの下に表示されます(Workspace 内のどのフォルダに存在するかに関係なく)。

コンポーネントのタイプをその場で指定または変更するには、そのエントリを右クリックし、コンテキストメニューからOperations » Change Component Typeオプションを選択してChoose component type dialogを開きます。

コンポーネントの Type パラメータは、次のタイミングで設定されます。

Component Types は、PreferencesダイアログのData Management – Component Types pageで管理(作成/編集/削除)されます。このダイアログのTemplatesボタンをクリックするとEdit Templatesダイアログが開き、各 Component Type に関連付けられたComponent Templateを指定または変更できます。

NOTE: コンポーネントが一覧表示されるCategoryカテゴリは、その Component Type パラメータによって定義され、保存されている Workspace フォルダとは関係ありません。したがって、Explorer パネルを使ってコンポーネントを別のフォルダに移動しても、その変更はComponentsパネルには反映されません。

Operations Menu

操作メニューのオプションでは、ファイルベースライブラリの設定、検索の実行、コンポーネントモデルコレクションを表示するかどうかの指定ができます。これらのオプションにアクセスするには、パネル右上の操作メニューボタンを選択します。

  • Create Component – 選択するとCreate new componentダイアログが開き、続いてSingle Component Editing モードの Component Editor が起動し、新しいコンポーネントを定義できる状態になります。
  • Import Library – 選択すると標準の Windows Openダイアログが開き、ローカルまたはネットワークフォルダに保存されたデータベースまたはファイルベースのライブラリを選択できます。ライブラリファイルを開くと、選択したライブラリを読み込んだLibrary Importer の Simple モードが起動します。
  • Clean-up Library – 選択するとDelete Existing Componentsダイアログが開き、続いて Workspace のData Cleanupページが表示され、削除するコンテンツタイプを選択できます。
  • Models – 選択すると、Categories一覧にライブラリモデルコレクションのエントリを含めます。このブラウズモードで追加されるエントリには、接続された Workspace から取得される Symbol、Footprint、Simulation model の各コレクション、およびインストール済み PCB フットプリントライブラリ(*.PcbLib)が含まれます。
  • File-based Libraries Preferences – 選択するとAvailable File-based Librariesダイアログが開き、データベースおよびファイルベースのライブラリを現在のプロジェクトに追加/削除したり、ライブラリをインストールしたり、ライブラリ検索パスを指定したりするためのコントロールを表示できます。詳しくは、ファイルベースおよびデータベースライブラリでのコンポーネント検索ページの利用可能なデータベースおよびファイルベースライブラリの管理セクションを参照してください。
  • File-based Library Search – 選択するとFile-based Libraries Searchダイアログが開き、どのデータベースまたはファイルベースライブラリにコンポーネントが含まれているかわからない場合、あるいは利用可能かどうかさえ不明な場合でも、コンポーネントを検索できます。詳しくは、ファイルベースおよびデータベースライブラリでのコンポーネント検索ページのデータベースおよびファイルベースライブラリでのコンポーネント検索セクションを参照してください。
  • Refresh – クリックするとパネルをすばやく更新します。現在のコンポーネント選択は保持されます。

Components List

コンポーネント一覧グリッド自体に含まれる内容は、次の方法で管理されます。

  • コンポーネント一覧の並び順を設定する – 列見出しをクリックすると、その列のデータでコンポーネント一覧を並べ替えます。見出しをもう一度クリックすると、並び順が逆になります。

  • 表示列の順序を設定する – 列見出しをドラッグ&ドロップして新しい位置に移動します。

  • 表示するパラメータ列を指定する – 列ヘッダー内で右クリックし、Select Columnsを選択してSelect Columnsダイアログを開くと、パラメータ列の表示/非表示や配置順を制御できます。

    Select columnsダイアログ
    Select columnsダイアログ

    • このダイアログには、Componentsパネルに表示可能なすべての列が一覧表示されます。項目にが表示されている場合、その列はComponents パネルに表示されます。項目にが表示されている場合、その列はComponentsパネルにnot 表示されません。記号をクリックして表示/非表示を切り替えます。

    • 列ヘッダーバーの/アイコンをクリックして、すべての列の表示を制御することもできます。一部の列が表示され、他の列が非表示になっている場合は、アイコンが表示されます。

    • 2列目のヘッダーバーにカーソルを合わせ、アイコンをクリックするとドロップダウンが開き、表示する列を選択できます。

    •  / ボタンを使って、選択した項目を一覧内で上下に移動します。移動できるのは表示に設定された項目()のみです。これにより、Componentsパネルに表示される列の順序が決まります。

  • 列データで一覧をグループ化する – 列ヘッダー内で右クリックし、Enable Columns Groupingオプションを選択してから、列見出し(例:Footprint)を一覧上部のグループ化領域へドラッグします。すると、一覧エントリは指定したグループ化列の各一意のパラメータ(例:フットプリントの種類)ごとにまとめられます。

    コンポーネント一覧をまとめるためにGroupingを使用する場合、格納できるエントリ数の上限は 10,000 件です。

  • 特定の列エントリで一覧をフィルタする – 列ヘッダーのを選択すると、その列の一意のパラメータエントリ一覧が表示されます。そこで項目を選択すると、指定したパラメータ(例:フットプリントタイプコード)を含むコンポーネントのみに一覧を絞り込めます。フィルタをリセットするにはAllオプションを選択します。さらに詳細に絞り込むには、(Custom)を選択してFilter Editorダイアログを開きます。

列の表示

Componentsパネル内の内容の表示方法にはいくつかの種類があります。各列名(Name、Description、Footprint)を右クリックすると、コンポーネントの表示方法に応じて次のオプションを選択できます。

  • Best FitName列とDescriptions列の内容をまとめて表示し、各列間の余分な空白をなくして近接配置します。

  • Best Fit All Columns – すべての列の内容をまとめて表示し、各列間の余分な空白をなくして近接配置します。

  • Clear Sorting – 列の並べ替えを元に戻すために使用します。

  • Enable Columns Grouping – 特定の列を基準に列ヘッダーをドラッグできるようにし、NameDescriptionFootprint列の順序を変更できます。

  • Select ColumnsSelect Columnsダイアログを開き、このセクションで表示したい他の列を選択できます。

  • Apply Column Visibility to Child Categories – 選択したカテゴリに子カテゴリがある場合、このコマンドを使用すると、親カテゴリの列表示設定を子カテゴリへ反映させることができます。このコマンドは子カテゴリが存在する場合のみ使用できます。

コンポーネント検索と機能

コンポーネントの検索

Componentsパネルで利用可能なコンポーネントを検索するには、Searchフィールドに語句を入力し、必要に応じてパネルのCategoriesおよびFiltersを使用してコンポーネント一覧を目的に応じて絞り込みます。フィルタはWorkspace コンポーネントでのみサポートされており、Manufacturer Part Search パネルと同様に、Componentsパネルは単位認識型(テキストから数値への変換)検索フィルタをサポートしています。検索機能は、入力された検索条件に応じて結果に優先順位を付けます。

Search機能を使用すると、アクティブなSearch文字列を選択して編集または追加できます。

「アクティブ」な検索文字列をクリックすると、それがSearchフィールドに入力されます。その検索はSearchフィールドから再利用または編集できます。

Searchフィールドでは、文字列中のアスタリスク(*)を使用したワイルドカード検索もサポートされています。

一覧表示されたコンポーネントを右クリックしてFind Similar Componentsを選択すると開くFind Similar Componentsダイアログでは、選択したコンポーネントに基づいて検索設定を定義できます。

最終的な検索結果は、選択したコンポーネントタイプが Workspace コンポーネントか非 Workspace コンポーネントか、また Workspace の接続状態によって異なります。たとえば、Workspace コンポーネントは非 Workspace コンポーネントより多くのパラメータを表示することがよくあります。選択したコンポーネントと同じまたは異なるコンポーネントやパラメータを特定して収集するには、ドロップダウンを使用してSameAny、またはDifferentの各選択肢を指定できます。

コンポーネントの配置

選択したコンポーネントは、ドラッグ&ドロップするか、右クリックのコンテキストメニューからPlaceを選択するか、Detailsペインのボタンを使用するか、目的のコンポーネントのエントリをダブルクリックするか、またはEnterホットキーを使用して回路図上に配置できます。

パネルからコンポーネントを配置するには、次の方法があります。

  • Component DetailsペインのPlaceボタンをクリックする – カーソルは自動的に回路図シートの範囲内へ移動し、コンポーネントがカーソルに追従した状態で表示されます。配置位置まで移動してクリックすると配置されます。コンポーネントを配置した後は、同じコンポーネントの次のインスタンスが再びカーソル上に表示されます。配置モードを終了するには右クリックします。

    Components panel, placing from component details pane

  • コンポーネントを右クリックし、コンテキストメニューからPlaceを選択します。コンポーネントはカーソルに追従した状態で表示されるので、配置位置まで移動してクリックすると配置されます。パネルがデザインスペース上に重なっている場合は、回路図を確認してコンポーネントを配置できるように、パネルがフェード表示になる点に注意してください。コンポーネントを配置した後は、同じコンポーネントの次のインスタンスが再びカーソル上に表示されます。配置モードを終了するには右クリックします。

  • Click, Hold&Drag – パネルのグリッド領域からコンポーネントを回路図シート上へクリック&ドラッグします。このモードでは、カーソルボタンを押したままにしておく必要があります。カーソルを離すと、コンポーネントが配置されます。コンポーネントを配置した後は、別のコンポーネントまたは別のコマンドを自由に選択できます。

    ドラッグ&ドロップでは、コンポーネントは1つだけ配置されます。複数個配置する必要がある場合は、Place コマンド/ボタンを使用するか、コンポーネント項目をダブルクリックしてください。

コンポーネントの配置自体は非常に簡単です。ただし、何より先に、そのコンポーネントを受け取る回路図シート(またはPCBドキュメント)が Altium Designer で開かれており、アクティブなドキュメントになっていることを確認してください。複数のウィンドウにまたがってドキュメントが開かれている場合は、そのアクティブな回路図ドキュメントを含むウィンドウにフォーカスがあることも確認してください。

複数ウィンドウで Altium Designer を使用している場合、Components パネルまたは Explorer パネルが対象の回路図を含まないウィンドウに何らかのドッキングモードでドッキングされていると、Place コマンドはグレーアウトしたままになります。これは、ドッキングされたパネル内をクリックすると、そのパネルが属しているウィンドウにフォーカスが移るためです。一方、パネルがフローティング状態であれば、必要な Altium のウィンドウ(アクティブな対象回路図を含むもの)にフォーカスを合わせることができ、パネル内で操作している間もそのウィンドウはフォーカスを維持します。

マルチパートコンポーネントの配置

配置するコンポーネントが複数パートを持つ場合、最初に配置されるのは、パネルの Models 領域でシンボルプレビュー画像の下に選択されているパートです。

マルチパートコンポーネントのパートを1つ配置した後、そのパートを選択した状態で Properties パネルの Part ドロップダウンを使用してこのコンポーネントの別のパートに変更できます。また、メインメニューの Edit » Increment Part Number コマンド、またはパートの右クリックメニューにある Part Actions » Increment Part Number コマンドを使用して、次に使用可能なパートへ切り替えることもできます。

Altium Designer では、定義された Normal および Alternate の 表示モードShow example)を使用して、1つのコンポーネントだけでマルチパートコンポーネントを単一シンボル(すべてのサブパート)または複数シンボル(各サブパートごとに1つ)として表示できます。

  • マルチパートコンポーネントの表示モード(normal または alternate)に空のサブパートがある場合、それらのサブパートは配置時に省略されます(Show example)。

  • マルチパートコンポーネントで、1つのサブパートにのみプリミティブが定義されている場合、そのサブパートを回路図シート上に配置するとデジグネータ接尾辞は非表示になります(Show example)。

  • 現在選択されている表示モードに対してサブパートにプリミティブがない場合、または現在選択されているサブパートに対して表示モードにプリミティブがない場合、コンポーネントの Properties パネル内の Part of Mode ドロップダウンの対応する項目はグレーアウト表示されます()。そのような項目をドロップダウンで選択すると、警告アイコンが表示されます()。

  • コンポーネントにプリミティブを持たないサブパートがあり、それらのサブパートが回路図上に配置されていない場合、設計検証の実行時に Unused sub-part in component 違反は発生しません。

コンポーネントのフィルタリング

Workspace コンポーネントを表示している場合、Filters ペインには現在の検索条件と利用可能なパラメータに基づく選択済みフィルタオプションが表示されます。一覧表示されたコンポーネントのパラメトリックフィルタリングにより、特定のコンポーネントまたはコンポーネントタイプを見つけるための追加オプションが提供されます。Categories ペインの上にある ボタンから Filters ペインを開いてください。パネルのコンパクトモードでは、 ボタンをクリックして Filters をパネル拡張としてポップアウト表示します。

フィルタは Workspace components でのみサポートされる点に注意してください。特定のパラメータフィルタを見つけるには、ペイン内の Filter Search フィールドを使用します。

Javascript ID: Pnl_Components_Filter
  • パネルの Filters のパラメトリック検索機能は、Workspace コンポーネントをホストしている Workspace から適切なコンポーネントパラメータデータが渡されることに依存します。そのため、ソフトウェアが古い Altium サーバー製品に接続されている場合、Filter 機能が無効化されることがあります。以前のサーバーバージョンで Filter を有効にするには、Advanced Settings dialogComponentSearch.LegacyAFS.Filters オプションを有効にしてください。

  • なお、あるパラメータが Filters ペインに表示されるためには、選択したカテゴリ内のコンポーネントでそのパラメータに少なくとも2つの異なる値が使用されている必要があります。また、Filters ペインには、最も一般的なパラメータ最大100件のみ(接続された Workspace 全体で、全コンポーネントタイプを通じてより多くのコンポーネントで使用されているもの)が表示される点にも注意してください。次のパラメータ(または次の名称で始まるもの)は、常にペインの先頭に表示されます: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead

パネルの Filters オプションは、特定のパラメータタイプを Favorites として選択することで、用途に合わせて調整できます。そうすると、それらは現在のコンポーネントカテゴリの一覧の先頭へ移動します。パラメータフィルタ名の右側にカーソルを合わせ、 アイコンをクリックすると、そのフィルタを Favorite として設定できます。Favorite フィルタ設定は、個別のコンポーネントカテゴリごとに適用され、保存されます。

Workspace コンポーネントでは、右クリックメニューから、Component Editor を使用してコンポーネントを編集するオプション(Edit)や、コンポーネントの作成・複製、または選択したコンポーネントの Part Choices や Type の編集などのコンポーネント管理機能(Operations)を利用できます。

 
 
 
 
 

コンポーネントの Details ペインにおける追加情報オプションには、モデル画像の表示、オンラインデータシートの表示(References)、ライブ Supplier 情報(Part Choices)、その部品が Workspace プロジェクト、managed sheets、および reuse blocks のどこで使用されているかの確認(Where Used)が含まれます。また、右クリックメニューから、選択した、またはすべてのコンポーネントパラメータデータ(技術詳細)をタブ区切り形式でコピーしたり、お気に入りとしてマークされたパラメータをデフォルトの5つのパラメータにリセットしたりすることもできます。

接続された Altium 365 Workspace 内のコンポーネントを参照している際に、選択したコンポーネントの健全性に関する問題が見つかった場合は、そのことがコンポーネントパラメータ一覧の上にある Component issues 行に (エラー用)または (致命的エラー用)アイコンで示されます。アイコンの右側の数字は、見つかった問題の数を表します。問題の簡単な説明を見るには、その数字の右側にある下向き矢印をクリックしてください。

検出されたライブラリ健全性の問題の例。
検出されたライブラリ健全性の問題の例。

Workspace ライブラリの健全性は、Altium 365 Workspace のブラウザインターフェースからアクセスできる Library Health ダッシュボードページでさらに詳しく確認できます。詳細については、Library Health Dashboard を参照してください。

カスタムフィルタリング機能を使用して、Components パネルでのフィルタリングをさらに絞り込むことができます。​​​​​​​

この機能は次の方法で利用できます:

  1. ヘッダーのフィルタ()アイコンをクリックして Filter ドロップダウンを表示し、

  2. そこで Filter Value の選択(デフォルト)によるフィルタリング、またはユーザー定義の Filter Rule の設定によるフィルタリングをサポートします。一覧から値を選択すると、自動的に式に変換されます(その後編集可能です)。

  3. 独自のフィルタを定義するために Filter Rules を選択した場合、最初のドロップダウンから演算子を選択し、

  4. 次に、2番目のドロップダウンでフィルタ値を選択または入力します。

  5. 現在のフィルタは結果一覧の下に表示されます。 ボタンをクリックすると Filter Editor ダイアログが開き、フィルタを編集できます。

使用箇所

Components パネルで Workspace コンポーネントを選択すると、その最新リビジョンが現在どこで使用されているかの情報が Where Used 領域に表示されます。この領域には、次に対するクイックフィルタ情報が提供されます:

  • Projects – コンポーネントが使用されている Workspace プロジェクト。情報は、プロジェクトが Workspace に保存されると only 表示されます。

  • Managed Sheets – コンポーネントが使用されている managed schematic sheets。 

  • Reuse Blocks – 接続された Workspace のライブラリの一部として保存されている Reuse Blocks。

選択したコンポーネントを使用しているエンティティが Workspace 内に存在する場合にのみ、タブが表示される点に注意してください。

コンポーネントが Workspace プロジェクトのすべての design variants で使用されているわけではない場合、Where Used 領域のそのプロジェクト項目には、そのコンポーネントが使用されているバリアント数とそのプロジェクトの総バリアント数、およびそのコンポーネントが使用されているバリアントの一覧が表示されます()。

コンポーネントデータのキャッシュ

Components パネルを使用する際、Workspace コンポーネントのデータは Workspace からローカルマシンにキャッシュされます。これにより、Altium Designer が Workspace に接続されていない場合でも Workspace コンポーネントに対するオフラインアクセスモードが提供され、通常どおりコンポーネントの参照や配置などを行えます。

現在の Altium Designer セッションで Components パネルを最初に起動した際、オフラインモードではパネル内に警告が表示され、キャッシュされたコンポーネントデータを使い続けるか、キャッシュをクリアするかの操作項目も表示されます。

キャッシュされたコンポーネントを使用するには Use Cached Data をクリックします。 この状態は、パネルのコンポーネント一覧ペイン下部バーにある Offline mode – cached data is being used 警告テキストで示されます。このモードでは Filters は有効にならない点に注意してください。

キャッシュは時間の経過とともにコンポーネントデータを蓄積し、Preferences ダイアログの Data Management – Servers page にある Known Servers の下で利用可能な Clear Cache オプションを使用して、いつでも(すべての Workspace について)クリアできます。

キャッシュ動作では、Altium 365 Workspace など現在接続されている Workspace のキャッシュ済みコンポーネントのみが表示されるため、一部のキャッシュデータが無効になる場合があります。この動作は、Preferences ダイアログの Data Management – Servers ページで管理できます。

Part Choices List

Workspace コンポーネントに関連付けられた Part Choices List は、項目の右クリックメニューから Operations » Create/Edit Part Choices オプションを選択して編集します。

続いて表示される Edit Part Choices ダイアログの ボタンを使用して Add Part Choices ダイアログを開くと、選択したコンポーネントの Name パラメータに基づいて部品メーカーが自動検索されます。事前定義された検索語の選択を解除すると、代替候補を手動で検索できます。機能的には、このダイアログは Manufacturer Part Search panel のモーダル版です。

Part Choice リストは、適切な星アイコンのレベルを選択することで順位付けでき、その結果、最も高い順位のメーカー選択肢が自動的に先頭に並ぶようにリストが再配置されます。

Part Choices は、回路図設計、BOM ドキュメント、出力レポートなど、コンポーネントデータが適用されるあらゆる場所で、そのコンポーネントとともに保持されます。

Components パネルでコンポーネントを選択すると、その part choice 一覧を Details ペインの Part Choices 領域で確認できます。関連する part choice の基本情報(在庫、単価中央値、メーカーライフサイクル)も Details ペイン上部に表示されます。関連付けられた色付きストライプは、推定された Lifecycle 状態に基づくその部品の使用適性の基本的な目安を示します。たとえば、Obsolete (赤)とマークされたコンポーネントは、Volume Production (緑)と評価されたものより推奨されません。色付きストライプにカーソルを合わせると、その Manufacturer Lifecycle 状態を確認できます。

Silicon Expert または Z2 Data の統合機能を使用している場合、追加のデータやコントロールが Details ペイン上部に表示されることがあります。詳細については、Pulling Part Data from SiliconExpert および Pulling Part Data from Z2Data ページを参照してください。

Workspace で Part Choice Revision Control 機能が有効になっている場合、Operations » Create/Edit Part Choices オプションを選択すると Edit Part Choices ダイアログではなく Component Editor(Single Component Editing または Batch Component Editing モード)で開きます。必要な変更を part choices に加え、コンポーネントを次のコンポーネントリビジョンとして Workspace に保存し直してください。

Components パネルの右クリックメニュー

このパネルの右クリックポップアップメニューには、次のコマンドがあります:

  • Place [ComponentName/FootprintName/SimulationModelName] – 現在選択されているコンポーネントまたはシミュレーションモデルをアクティブな回路図ドキュメント上に、または現在選択されているフットプリントをアクティブな PCB ドキュメント上に配置するために使用します。

  • Find Similar ComponentsFind Similar Components dialog を開き、選択したコンポーネントに類似したコンポーネントを検索するための条件を設定します。

  • Navigate to [ComponentName] – 選択した Workspace コンポーネントを Explorer panel で開くために使用します。そこでは、詳細な Item 情報にアクセスできるほか、Item のリビジョン設定やライフサイクル設定、where-used 情報、サプライチェーンの詳細などを管理できます。

  • Edit – クリックすると、選択した Workspace コンポーネントを Component Editor(Single Component Editing または Batch Component Editing モード)で、または選択したドメインモデル(シンボル、フットプリント、シミュレーションモデル)をそれぞれのエディタで編集します。現在のコンポーネントタイプが現在使用中のテンプレートと異なる場合、Change component type ダイアログが開きます()。このダイアログを使用して、選択したコンポーネントのコンポーネントタイプを変更します。

  • Create – クリックすると Create new component ダイアログが開き、新しいコンポーネントを追加する際のコンポーネントタイプを選択できます。

  • Delete – クリックすると、接続中の Workspace から選択したコンポーネントを削除します。

  • Operations – 以下で説明する Workspace コンポーネント用の追加機能のドロップダウンメニューにアクセスするために使用します。

    • Submit Request – アクティブな part request プロセス定義にアクセスするために使用します。Part Requests プロセステーマに対してアクティブなプロセス定義が利用できない場合、Submit Request ボタンはグレーアウト表示されます(使用不可)。更新するには、Workspace からサインアウトして再度サインインするか、Altium Designer を再起動する必要がある場合があります。

    • Download – 選択したコンポーネントを、ソースライブラリパッケージ(*.LibPkg)およびライブラリファイルとともに、ZIP 化されたコンパイル済み Integrated Library (*.IntLib)としてダウンロードするために使用します。複数のコンポーネント項目を選択すると、それらのコンポーネントを1回のセッションでまとめてダウンロードできます。

    • Make a copy – クリックすると、選択したコンポーネントをコピーします。コンポーネントエディタは Single Component Editor モードで開きます。

    • Change Component TypeChoose component type ダイアログ()を開くために使用します。ここから、現在のコンポーネントのタイプを、一覧内に存在する他の定義済みタイプのいずれかに変更できます。このダイアログには、コンポーネントタイプに関連付けられたコンポーネントテンプレート、およびそのタイプのコンポーネントが接続された Workspace 内で検索/保存されるフォルダに関する情報が表示されます。 をクリックします。利用可能な Component Types の一覧を Data Management – Component Types ページの Preferences ダイアログ で管理するためのボタンです。

    • Change State – 選択したコンポーネントのリビジョン状態を変更するために使用します。このコマンドを使用すると、Batch state change dialog が開き、コンポーネントのリビジョン状態を変更できます。

    • Create/Edit Part Choices – Edit Part Choices ダイアログにアクセスするために使用します。ここでは、Workspace コンポーネントに関連付けられた部品選択リストを作成または編集できます。

      Workspace で Part Choice Revision Control 機能が有効になっている場合、このコマンドを選択すると、Component Editor が Single Component Editing または Batch Component Editing モードで開きます。
    • Full Item History – 現在選択されているコンポーネントの詳細ビューにアクセスするために使用します。これは Altium Designer 内で新しいタブ付きビューとして開かれます。Item View では、特定の Item の Revision および Lifecycle 履歴を非常に詳細に確認できるほか、その Item を構成するすべての要素も表示されます。このビューには Timeline も含まれています。Timeline を使用すると、その Item の Revision レベルまたは Lifecycle State に加えられた変更の正確な日時と、その変更を行ったユーザーを確認できます。

     

  • Refresh – クリックするとパネルをすばやく更新します。現在のコンポーネント選択は保持されます。

コンポーネント比較機能

Compare 機能では、選択した 2 つのコンポーネント(部品)のパラメータを比較できます。この機能は、グリッド領域で アイコンが有効(青色)な状態で 2 つのコンポーネントを選択すると利用できます。 Selected Component Details 領域がグリッド領域の右側に開きます。上部領域(下図の領域 1)には、選択したコンポーネントの画像、名称、説明、および価格が並べて表示されます。Datasheet ボタンをクリックすると、関連するコンポーネントのメーカー製データシート(利用可能な場合)が開きます。Place ボタンをクリックすると、コンポーネントをデザインスペースに配置できます。コンポーネントはデザインスペース上でカーソルに追従する状態で表示されるため、クリックして目的の位置に配置してください。追加のコンポーネントを続けて配置することも、右クリックまたは Esc で配置モードを終了して Components パネルに戻ることもできます。

下部領域(下図の領域 2)には、コンポーネントのパラメータが左右並びで表示され、差異は赤い文字で強調表示されるため、簡単に比較できます。

Compare 機能は、Components パネルがコンパクトモードの場合にも利用できますが、動作は少し異なります。この機能は、グリッド領域で 2 つのコンポーネントを選択すると利用できます。Selected Component Details 領域がグリッド領域の下に開きます。上部領域には、コンポーネント名、価格、およびコンポーネントのパラメータビューが表示され、差異は赤い文字で強調表示されるため、簡単に比較できます。下部領域には、コンポーネントの SymbolsModels が左右並びで表示されます。

Compare 機能およびその機能性は、Manufacturer Part Search panel でも利用できます。

コンポーネントシンボルとフットプリントの編集

特定のコンポーネントのシンボルとフットプリントは、右上の Info button をクリックしてアクセスする Details ペインの Models セクション内で非表示にできます。非表示にすると、シンボルとフットプリントは、元の表示に戻すためのクリック可能なリンクに置き換えられます。また、表示されるモデルのサイズを拡大縮小する機能も含まれています。シンボルとフットプリントのどちらについても、モデル領域の下端をクリックしてドラッグすることで画像サイズを変更できます。

モデルビューの非表示およびサイズ変更機能は、Manufacturer Part Search panelDetails ペインでも利用できる点に注意してください。

*.SchLib ファイルである Schematic Library を Components パネルで参照している場合、選択したコンポーネントのシンボルとフットプリントは、モデルプレビュー右下の ボタンを使用して編集できます。

Components にアクセスしている場合、すでに有効かつリンク済みのフットプリントが存在していれば、フットプリント編集機能を利用できます。

コンポーネント選択ダイアログ

Components パネルで使用される検索エンジンとビューは、コンポーネント選択を行う Altium Designer の他のアプリケーションにも適用されます。これらの(モーダル)ダイアログには、コンポーネント検索機能に加え、OK 確認ボタンと、利用可能なアクションコマンドに若干の違いがあります。このダイアログは通常 Component Search と呼ばれます。

  • ActiveBOM ドキュメント – Components 検索ビューは、Workspace component を代替コンポーネントに変更するときに使用されます。一覧内のコンポーネント項目を右クリックし、コンテキストメニューから Change [component name] を選択すると、Replace Component ダイアログが開きます。
  • Item Manager – Components 検索ビューは、現在のコンポーネントを置き換える Workspace component を手動で選択するときに使用されます。一覧内のコンポーネント項目を右クリックし、コンテキストメニューから Choose manually を選択すると、Replace Component dialog が開きます。
  • Variant Management – Components 検索ビューは、代替コンポーネントのプロジェクトバリエーションを選択するときに使用されます。Alternate part を Component Variation として選択し、Edit Component Variation dialog 内で Choose を選択すると、Replace Component dialog が開きます。

汎用コンポーネントへのアクセスと配置

この機能は Open Beta であり、Advanced Settings dialogComponentSearch.GenericComponents オプションが有効になっている場合に利用できます。

設計初期段階のレイアウト作業を迅速化するために、標準的で基本的な Generic Components という概念が用意されています。汎用コンポーネントを使用すると、利用可能なコンポーネントソースから特定のメーカー部品を探して選択する必要なく、設計内にすばやく配置できます。汎用コンポーネントは、設計プロセスの後半で 適切なコンポーネントに置き換えられる ことを前提としたプレースホルダーとして意図されており、仮想コンポーネントまたはパラメトリックコンポーネントとみなすこともできます。

汎用コンポーネントの作成について詳しくは、Creating Generic Components ページを参照してください。

Altium Designer が Workspace に接続されている 場合、利用可能な Generic Components はパネルから利用できます。これは、Categories ペインで All オプションを選択したとき、またはパネルがコンパクトモードのときに上部のドロップダウンメニューから表示されます。Generic Component タイル内の ボタンをクリックすると、そのコンポーネントがカーソルにアタッチされ、アクティブな回路図ドキュメント上に配置できます。コンポーネントが回路図に配置されると、シンボルのピン、ライン、および境界プリミティブ、つまり外形が赤色で表示され、汎用コンポーネントが使用されていることを示します。Components パネルでタイル自体を選択すると、そのコンポーネントタイプのカテゴリがパネル内で開きます。

Components パネルから汎用コンポーネントを配置する
Components パネルから汎用コンポーネントを配置する

Generic Components は最終設計で使用してはならないため、回路図に配置すると ERC 違反 Generic Component が発生します。その違反レベルは、デフォルトでは Fatal Error であり、Project » Project OptionsProject Options ダイアログにある Error Reporting settingsViolations Associated with Components セクションで決定されます。

配置済みの Generic Component を選択すると、Properties panel でそのプロパティにアクセスできます。ここでは、この種のコンポーネントに関連する設定とパラメータのみが提供されます。利用可能なパラメータは、関連する Component Template によって決まります(ここに示した例では Resistors)。パラメータ値は手動で入力することも、該当タイプの利用可能なすべてのコンポーネントから取得された値を提供するドロップダウンメニューリストから選択することもできます。

Javascript ID: GenericComponents_Parameters

汎用コンポーネントのパラメータ指定 – ドロップダウンからパラメータ値を選択。

汎用コンポーネントのパラメータ指定 – 結果。

ジャンパーコンポーネントのサポート

ジャンパーは、ワイヤリンクとも呼ばれ、配線を Jumper コンポーネントに置き換えることを可能にします。これは、片面基板の設計を成功させるうえで重要な要素となることがよくあります。Altium Designer は、Jumper という特別なコンポーネントタイプを通じてジャンパーコンポーネントの使用をサポートしています。

Jumper フットプリントを PCB に直接配置して開始することもできますが、推奨されるワークフローは回路図から始める方法です。詳しくは、Working with Jumper Components ページを参照してください。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content